New Features

Load Multiple Images into Image Processor

Image Processor can now open multiple images to combine into channels. Use File > Open Images to Channels.

Batch Process Multichannel Data Using Alternative Data Structure

Batch Processor can now combine multiple images into channels. The individual channels can be accessed using the Color > Channel Operation recipe step.

Generate Intensity Measurements from 16-bit Images

Image Processor can now generate pixel intensity mean, standard deviation and sum from the original bit depth image.

Improvements

  • Added options to Channel Operation to control data normalization and divide-by-zero handling.
  • Zoom is now default interactive tool in Session Processor upon opening session, and in Manual Edit in the Image Processor when adding as a new step.
  • Layers will now properly align during a session merge in Session Processor as long as both sessions use the same layer names, even if they are in different orders.

Bug Fixes

  • Reference Image now properly adjusted in Image Processor during Edit > Auto Crop.
  • Global intensity measurements in Image Processor now properly respect their dependency on Companion Image.
  • Fixed incorrect sharpen output when using GPU computation.
  • Fixed bug with copy/paste of recipe steps in Image Processor.
  • Fixed bug where Pre-Processing > FFT Filter step could be accepted with partial settings and would then not be editable
  • Auto Segmentation memory image dependencies are now respected.
  • Fixed bug where Feature Measurements set to “All” would not measure proper layers after recipe steps removed.
  • Fixed bug where cancelling adding a new layer in Session Processor would incorrectly increment the default layer name.
  • Fixed bug where canceling an Edit > Sparsely Sample Image step would rebuild the recipe.
  • Fixed bug with running optimization of Clean-up > Reject Features.
  • Fixed bug when opening pyramid Tiff with DigitalCamera and Make info fields.
  • Fixed bug with cancelling a Segmentation > Manual Edit step.
  • Fixed bug with cancelling a Feature Measurement step after editing.
  • Fixed bug preventing the opening of images from certain camera manufacturers when pyramid or thumbnail images are present.

Hotfixes

4.1.0.1

  • Added checks for starting a training with unsaved tracings and with empty layers.
  • Fixed bug with “Optimize” in Image Processor when using a sub-region
  • Original zoom limits in Image Processor no longer reset when changing recipe steps while zoomed

4.1.0.2

  • Fixed bug where occasionally “Save Model” would not enable after a DL training in AI Session Processor.

4.1.0.3

  • Memory > Call Original now interacts properly with Crop Image steps in Image Processor.
  • Interactive measure tool in Image Processor now functions properly.
  • Fixed bug where image stack would fail to create during batch process.


Need more help with this?
Chat with an expert now ››

Was this helpful?

Yes No
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.