Error Cause Possible Solution
MIPAR crashes on starup or during launching of an app

OR

HASP API DLL dynamically unloaded with active logins
MIPAR crashed on startup and thus did not properly log out of the license. This is a symptom rather than the cause of the crash. Try updating your graphics card driver (see below links). If the problem persists, try the solution below (Windows only).

NVIDIA: https://www.nvidia.com/download/index.aspx?lang=en-us
AMD: https://www.amd.com/en/support
Intel: https://downloadcenter.intel.com/product/80939/Graphics
Message on Mac stating that “MIPAR Installer cannot be checked for malicious software”. macOS is not recognizing MIPAR Software as an identified developer – Right-click on MIPAR Installer
- Click “Open”
- Click “Open” in the message that appears
Permissions setting error during installation stating that “‘Icacls’ is not recognized as an internal command, operable program or batch file.” Incorrect PATH variable – Open System Properties > Advanced tab > Environment Variables > System variables
- Make sure the Path variable contains the entries “C:\Windows\system32” and %SystemRoot%\system32
- Retry running MIPAR Installer
Interface buttons and text display incoherent text Fonts were not installed properly - Close MIPAR
- Navigate to C:\ProgramFiles\MIPAR\fonts
- Select all .ttf and .otf files
- Right click > Install (or “Install for all users” if available)
- Launch MIPAR
MIPAR takes an extremely long time to launch on a system with an NVIDIA Ampere architecture video card installed MIPAR must recompile CUDA drivers on launch Add Environmental variable: CUDA_CACHE_MAXSIZE with a variable value: 536870912

Solution for Crash on Startup or “HASP API DLL dynamically unloaded” Message (Windows)

This error occurs when the MIPAR Runtime crashes on boot. Please try in order:

Delete the MCR Cache

  • Navigate to the MIPAR install folder, default: C:\Program Files\MIPAR\
  • Delete the folder: mcrCache9.11
  • Restart Computer
  • If this does not work, try:

Delete Preferences

  • Navigate to C:\Program Files\MIPAR (installation path)
  • Delete miparPreferences.pref
  • Retry MIPAR launch
  • If this does not work, try:

Reinstall the Runtime

  • Uninstall the runtime from the system: MATLAB Runtime 9.11
  • Download and install the runtime: LINK
  • Restart the computer
  • If this does not work, try:

Adjust Permissions

  • Try launching MIPAR as an admin
  • Are you running an antivirus program? Does whitelisting MIPAR resolve the problem?

Need more help with this?
Chat with an expert now ››

Was this helpful?

Yes No
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.