Important: DID values Every WeatherlinkIP logger has two unique values associated with it – a DID and a Keycode value, which will be found on a small label on the side of the logger’s RJ45 socket (and not on the logger itself). The DID is a Device ID and is actually identical to the logger’s network MAC address consisting of a 6-byte sequence of 12 hexadecimal characters usually formatted as 6 colon-separated pairs, eg 00:1D:0A:00:02:3B.It can be useful to have a note of this DID value for checking purposes because it will crop in various places for example when finding out the logger’s IP address. NB All round characters are the digit zero ‘0’ – the letter ‘O’ is never used. If you’re attempting to enter a DID but it’s not being accepted, be sure to check that you’re not inadvertently entering the letter ‘O’ rather than the digit ‘0’.

The Keycode value provides an essential initial verification when eg setting up an account at, but otherwise is not used.

Uploads to are failing to occur

1. General points: In all cases of failed uploads there are always three points to check first:

  • Reboot the console: If there has been a power or network outage then the WLIP logger may need to reinitialise, which can only be done by power-cycling the console. Always try a console reboot as a first step and always check that the number of beeps (as listed in the Reboot topic) is correct. If beeps are fewer than expected then this suggests some type of hardware issue, which needs to be investigated before continuing with other troubleshooting steps;
  • Check that the mains adapter is connected, powered-up and working. The WLIP has a high power requirement because of its need to drive an Ethernet network and internal console batteries typically cannot provide sufficient power to run the IP logger. So, for reliable operation, a WLIP console must be externally-powered, typically by means of the standard AC mains adapter. Using an IP logger is the one configuration where we recommend not fitting console batteries because they can lead to unpredictable operation in the event of a power outage. Backup power for the console is better provided by plugging the mains adapter into a small PC UPS unit (eg an APC BE400-UK unit, for UK users). If a fault is suspected and batteries were still fitted then be sure to check operation with batteries removed just in case the mains adapter has developed a fault;
  • Check that the green LED is flashing occasionally on the WLIP’s Ethernet socket. The pattern of flashes is actually not very helpful as a diagnostic, but if the LED is either continuously on or off then something is definitely amiss with the console power or the network connection;

2. Problems getting a brand new logger to perform a first upload

In most cases and provided the set-up instructions are followed carefully, uploads to should start happening quickly and automatically. If this fails to happen then there will usually be one of two causes:

  • The instructions have not been followed in the correct order. The commonest mistake is trying to register a new account at before the WLIP logger has been installed and connected to the network – the correct order is connecting the logger fully first (including a connection out on to the Internet), waiting 5 minutes and only then registering the new account. (The server needs to have received a discovery packet from the logger before it will allow account registration to complete successfully.) If you have done things in the wrong order then simply reboot the console and waiting a few minutes before trying again to register the new account. Also, be sure that you have entered the DID for the logger correctly – the DID will consist only of digits and the letters A-F; any round character is a zero not the letter ‘O’!
  • The WLIP logger is not able to send data across the network and Internet to There are two potential issues here:
    • No IP address: By default, a new IP logger must have received an IP address on the local network from the local DHCP server. On simple home and office networks this will rarely be a problem, but on larger managed networks you may need to check with your network administrators. (There are potential workarounds if a DHCP server is not available.) The simplest way of testing for an IP address is to install the copy of the Weatherlink for Windows software supplied with every logger on a PC connected to the same network and same subnet as the logger. Then in the Setup | Communications Port dialogue, select TCP/IP and Local Device ID and press the Find button. If the new logger can be found then a small message showing the logger DID and IP address will appear; obviously if there is an error message at this stage then for some reason or other the logger has not correctly picked up an IP address. NB In the uncommon scenario where there might be two or more IP loggers in use on the same network then you may need to press the Find button repeatedly until you see a message relating to the specific logger DID that you’re testing for. There are other methods of checking for an IP address such as running an IP scanner like AngryIP or searching through all the devices currently showing as registered to the local router, but using the Weatherlink software will typically be the simplest approach.
    • Firewall issues: Data from the logger is not being allowed out on to the Internet and therefore cannot reach Usually this will be because a firewall is blocking data from the logger, but please note that the logger can only send data out on port 80 (ie it cannot be reprogrammed to use a different port number) and cannot use proxy servers to access the Internet. If you can receive data from the logger in the Weatherlink software on a PC running locally but uploads to are failing then the chances are that this is a firewall problem and something that can only be resolved by discussions with your own network administrators. In essence, the IP address of the logger must be able to see a path out on to the Internet to reach the server via port 80. (NB The public IP address of the server cannot be assumed to be fixed and so it’s not prudent to design a firewall rule around allowing data to reach this specific IP address. Rather, any rule needs to allow outbound data from the IP address of the WLIP logger to reach the Internet in general.)

3. Uploads to were working previously but have now stopped

Review the following points:

  • Be sure to check the three General points above (see point [1] at the beginning of this main topic);
  • The IP address assigned to the logger may have changed (not because of the logger itself triggering any change, but because the router or server controlling the local network has – for whatever reason – decided to update the assignment of IP addresses to its network devices). If the WLIP logger connects to the Internet via a firewall then the fact that the IP address has changed will often require a change to the firewall rule relating to the WLIP logger. So an important troubleshooting step is to double-check that the logger’s IP address has not changed.
  • Firmware may require updating:From May 2015, upgrades to the service may have broken compatibility with WLIP devices still running old firmware (specifically v1.0.7 and older) will require updating to the latest version, currently v1.1.2. Instructions for checking and updating the firmware will be found under the WLIP configuration topic.There is also a Davis video that describes how to update the IP logger firmware and that is viewable on Youtube.

4. Current data uploads successfully but archive uploads do not appear to be working

Review the following points:

  • Be sure to check the three General points above (see point [1] at the beginning of this main topic);
  • The date/time of the console in which the IP logger is fitted may be too far out. Check the date/time settings, including the year setting, and adjust if necessary.
  • There could be an issue with the local copy of the Weatherlink program into which the archive data is being downloaded. Review the general Archive download errors topic.

A network connection to other local software has stopped working

The IP logger is typically used to upload to the Davis service. But if you are also using the IP logger to connect to provide a weather data feed to other local software but are encountering problems with this then the first check is always to see if uploads to are still proceeding normally (assuming that these have not been disabled in the WLIP web interface).

If the uploads are not working correctly then troubleshoot as per the previous section (3) above. If the uploads are OK then almost certainly the logger is working correctly but something has happened to the configuration of the local software.

Obviously, if uploads have been disabled then the check will not be available. In this case, please review the WeatherlinkIP configuration by local software topic. This explains various ways of checking the IP address of the logger and testing whether the logger can be contacted locally. In particular, it is important to confirm that the IP address of the logger has not been changed by the local router and that the logger’s web interface can be reached via its IP address.

NB (Not applicable to the WLIP logger because it is not a subscription product): For subscription products that upload to (ie the Weatherlink v6 software uploads and Connect options) then an obvious reason for uploads ceasing is that the current subscription has expired. This can be checked by logging on to your upload account at and reviewing the account details.

Last modified: Jan 06, 2020


Was this helpful?

Yes No
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.

Post your comment on this topic.

Post Comment

Richard Temple wrote: Oct 11, 2015

I noticed just over a week ago that my data logger had stopped communicating with The last update was on 31 August at 07:59. I contacted Davis support and they came back with several suggestions, none of which worked. Googling on the internet Icame across this page and noticed the last item - firmware may need updating. A examination of the data logger information on my account on weatherlink showed my firmware was version1.06. I therefore updated the firmaware as per the instructions on your linked webpage and the problem was solved!

I am slightly surprised that Davis Support did not suggest a firmware upgrade as a solution.

Thanks for providing the solution.