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1. How to Use This Guide
Welcome to Mekorma’s online user guide, designed to equip you with the knowledge needed to install,
configure and run payment processes using Mekorma Payment Hub for Payables/ Payroll, Multi-Batch
Management, Enhanced Electronic Payments and the MEM Connector for Payables/ Payroll. This guide can
always be accessed from our website.

The guide is organized into four topic categories:

• Introduction: Learn what you need to know and plan for before installing and processing payments
with Mekorma products.

• Installation: Describes how to install our products or upgrade to the latest build.
• Configuration: This section shows how to enable various Mekorma features and set up your Dynamics

GP environment for success.
• Process Payments: Demonstrates how to process payments using Mekorma products and features,

once they have been installed and configured.

New users can follow step-by-step installation, configuration and usage instructions delivered via written
content and video demonstrations. Experienced users can review this guide for any applicable new feature
information, or utilize it as an ongoing reference tool:

• Pull targeted results using the Search functionality in the top menu bar.
• Use the expandable menu on the left sidebar to discover topics of interest.
• Each page in the Guide has it’s own unique URL, so individual pages can be bookmarked or links

shared with colleagues.
• Print individual pages by clicking on the printer icon at the top right corner of any page.
• Download/ print the entire User Guide by clicking on the Download as PDF button at the very end of

the left-hand menu.
• At the bottom of each page you will find a general feedback form: please fill out and submit if you

require more information on any particular topic.

Last modified: Nov 04, 2019

If you are having a specific issue with your Mekorma products and require assistance,
please log in to our online portal and open a new case with Mekorma Support.

!
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2. Release Notes for Mekorma Build x78
Mekorma Build x78 was originally released in June 2019. Watch the video below for an overview of
significant changes and new features in Mekorma Build x78 RTM:

Follow the links below for detailed notes on:

• New Features
• Issues Fixed

Last modified: Oct 31, 2019

A hotfix was issued in September 2019 for Mekorma versions compatible with GP2013,
2015, 2016, 2018. A version compatible with Dynamics GP October 2019 release (18.2)
was released in October 2019. See our downloads page for the most recent builds.

!

To access release notes for previous versions of Mekorma, follow this link.*
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2.1. New Features

Mekorma Payment Hub (compatible with GP2013, 2015, 2016, 2018)

• Improved performance as the system no longer automatically retrieves registration keys during
GP startup and no longer validates keys when printing.

• After Mekorma installation, it is recommended to login as user sa or a user with database
sysadmin rights to run table upgrade. The table upgrade message will only prompt for user
‘sa’ or system administrator if an upgrade is needed.

• If invalid, expired or all empty keys are detected upon logging in to GP, the registration error
message will only display for user ‘sa’ (system administrator.)

• Optimized Table Maintenance to improve performance during login, switching companies and
opening the Table Maintenance window.

• Payment Hub expanded integration with Binary Stream Multi-Entity Management for centralized
and decentralized payments.

• Payment Inquiry Zoom function was added for Payroll, Canadian Payroll, Transaction Check and
Miscellaneous Check in the Audit Detail Log.

• Added an explanation on how to correct the issue when receiving the following warning message:
‘Check number length does not match MICR setup.’

• Added an explanation of how to switch from Task-Based to Legacy Security on the Mekorma
Security Setup window.

• The option to opt out of Mekorma Miscellaneous Checks has been moved. Go to the Mekorma
Area Page > Setup > System > MICR System Options window > Additional > Mekorma
MICR – MISC Chks OptOut. This opens a new window that allows you to opt out by company.

• In the Mekorma Approval navigation list a new section, Payment Voucher, has been created.
The window will show the Payment, Vendor and Amount in one list. A second list shows all
vouchers that make up the payment.

• The Mekorma minor build number is now shown in the About window.
• Added an info icon on the Mekorma User Preferences, to the right of the Signature File field.
• Task-based security changes:

◦ The Mekorma Security Setup window opens with the companies collapsed – Users can
expand/collapse by double-clicking on the company’s name. This process is explained at
the bottom of the window.

◦ Added warning message ‘Not all required fields have been entered’ when attempting to
save incomplete configuration in the Mekorma Security Setup window.

◦ Added instructions on how to switch to Legacy Security in the Legacy V. Task ID Security
information box.

◦ Added the disable ‘Print Blank Checks’ option to the Security Setup window.
◦ When switching security models to either Task-Based or Legacy when a company has

Expand each section by clicking +. Collapse each section by clicking -*
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incomplete workflow transactions, users will get a message asking if workflow records
should be removed. The records will not be removed until the user clicks on ‘Save.’

◦ Removed the Look-Up and Delete buttons from the signature file in the Mekorma User
Preferences window (found in GP User Preferences > Additional).

◦ Changed message when using Legacy security to ‘Mekorma User Preferences is only
available under the Task-Based Security model.’ (found in User Preferences > Additional >
Mekorma User Preferences)

◦ Default signature now prints on split batches that require approval.
◦ When using Vendor Class Security with threshold, approval is based on transaction. For

each transaction, it first looks to the threshold assigned to vendor class. If not assigned, it
uses the threshold assigned to the checkbook.

◦ Authorization complete email is sent to requestor if the request is canceled from the
Mekorma Batch Status List and then re-requested. Please verify the Mekorma User
Preferences are set for the requestor to receive the email.

◦ Resolved issues with Authorization Password Validation for User2 field.
◦ Added text notifications option for batch approval process.
◦ Threshold Maintenance allows selection of either a User ID signature or a Signature file

(not assigned to a User ID). The Signature Lookup has been modified to allow Users or
Signatures to be selected in the Threshold Lookup window.

◦ Added the ability to import a signature to the Signature Library by clicking on the ‘New’
button in the Signature Assignment window.

◦ The ‘By Batch’ view on the Mekorma Approval List is now supported.
◦ Rejection reason is shown in the MICR Reject report when: the batch is rejected using the

drill down in the Mekorma Status list; the rejection is made in the Mekorma Approval List.
◦ Modified the label in Threshold Maintenance from ‘Enable Signatures Only for this

Threshold’ to ‘Enable Signatures Only for this Threshold ID’ for clarification.
◦ Modified the Default Signatures label to reflect that signatures can be set up for thresholds

or users.
◦ The size of the Signature field was increased to accommodate 45 characters in the

Threshold Maintenance window.
◦ Added a Task Reminder when launching GP for pending approvals. NOTE: Reminders

must be enabled in Microsoft Dynamics GP.
◦ When using the split batch feature with MEM integration, the split batch is assigned the

same entity as its original batch.

Mekorma Payment Hub for Dynamics GP October 2019 release (18.2)

• Transaction Long Description supported.

Mekorma Enhanced Electronic Payments

• Mekorma has introduced the ePayment credit model.
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• The Enhanced ePayment Vcard Management window allows the user to see the status and the
current balance of all the virtual cards issued.

◦ Filters allow the user to narrow down the list by status (Issued, Used, Drained and
Voided), by Checkbook ID, Payment Date, Vendor ID, Expiration Date and Remaining
Balance.

◦ Total Amount, Total Outstanding and Total Pending (card swipes that have been settled
but not yet pulled by the virtual card company) are shown at the bottom of the screen for all
the cards displayed, along with the amount of the Credit Line. With each card, the user will
be able to zoom to the Payment Number to see the invoices that were paid with this virtual
card and, when appropriate, to the MEEP Vendor Payment when the card settled.

◦ The user can Void a newly issued card, before it has been used, by highlighting it and
clicking on Actions > Void. Voiding a card in the credit model voids the corresponding
Vendor Payment and MEEP vendor voucher. Only unused cards can be voided. The Void
action cancels the virtual card.

◦ The Amount Used column will reflect the dollar amount that has been used of the original
amount. If an outstanding amount will not be used by the vendor, it can be written off and
that amount credited back. This is done by highlighting the card with a partial amount used,
clicking on Actions > Writeoff. The user will be prompted to select an existing or create a
new batch in the Enhanced ePayment Vcard Remainder Writeoff window, process, then
post the batch. This generates a credit memo to the MEEP Vendor.

◦ New Payments need to be entered at the end of the credit period by clicking on the ‘New
Payments’ button at the top of the Enhanced ePayment Vcard Management screen (A
reminder may be added to the GP reminders, or an automatic email may be sent by a
scheduled task). The user will be prompted to select an existing or create a new Payment
Batch and process it. A payment transaction will be created for the total amount of the
virtual cards that have settled during the period and apply records will be created for each
virtual card. This will link the payment to the Voucher created against the MEEP Vendor
when that virtual card was processed. The user will then be prompted to Post the payment
batch, if that option is selected on the New Payment window.

• If a batch fails to send to transmit, user now receives the message ‘An unexpected error occurred
when sending batch for electronic processing, please confirm status on the portal. One or more
errors occurred.’

• Added the ability to process Positive Pay files for ePayment checks.
• Added ePayment status message to the MMM Post Process Results Report.
• Added the ability to support multiple checkbooks within a single GP database. Checkbooks can

be setup in the Enhanced ePayment Configuration window.
• User is no longer prompted to print the remittance before posting an ePayment batch for virtual

cards.
• Users can now void a virtual card payment (if the payment has not been posted) from within the

Enhanced ePayment Vcard Management window.
• Added message ‘This bank account has already been assigned to different checkbook’ when

attempting to change the Remote Bank Account to one that is already assigned in the Enhanced

Mekorma Mekorma Products User Guide - Build x78
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ePayment Configuration window.
• In the Enhanced ePayment Configuration window, the subdomain name is now read only; the

ePayment Access Key has been truncated; and the Remote Bank Account field automatically
pulls from the ePayments portal, but can also be manually edited.

• When a virtual card is written off in the Enhanced ePayment Vcard Management window, a credit
memo is created to the MEEP Vendor. This credit memo is applied to the invoice generated to
the MEEP vendor for the virtual card.

• Virtual card status changes display in the Enhanced ePayment Vcard Management window when
it is manually refreshed.

• ‘Vendor Default Checkbooks’ section was added to the Enhanced ePayment Configuration
window, allowing users to assign a default checkbook for specific payment methods (check, EFT
and virtual card payments). This can be integrated with the Mekorma Assign by Checkbook
feature, allowing you to build batches by selecting payments by vendor checkbook.

• The option ‘Send Zero Value Checks’ was added in the ePayment Configuration window. By
default, it will remain deselected so that $0 checks will be printed locally (as a remittance) by
Mekorma or GP, rather than through ePayment process.

• Changed the Multi-Batch Management Action Board Post Results Report to show the status of
‘Failed’ if an ePayment failed to send to the electronic payments service.

• In the Multi-Batch Management Action Board, added the ability to drill down to view the ACH or
Positive Pay file by selecting the batch and clicking on the Status Description link.

• Batches that include an ePayment are shown separately as a split batch in the Mekorma Audit
Log.

• Integration with Multi Entity Management
◦ ePayment split batch or virtual card batch is granted with the same entity as the original

batch.
◦ The Enhanced ePayment Batch Maintenance window only shows the batches that the user

has access to in the batch entity.
◦ The Enhanced ePayment File Owner Maintenance window allows to change file owner only

if the new owner has access to the entity to which the file is tied.
• Two new windows have been created on the Mekorma Area Page > Routines > Payables

◦ Enhanced ePayment Batches: Within this window, users can view batch statuses by the
following categories:

▪ Created (integration files have been created in SQL)
▪ Sent (integration files have been transmitted)

▪ User can void the batch by clicking Action > Void. This applies to the batches
that have been transmitted but are getting a process error in the portal. In this
case, user will need to discard the payment on the portal, then also delete the
batch in GP.

▪ The user needs to ensure that the batch was not processed in the portal
before voiding a batch.

▪ Processed (sent payments have been processed and returned to GP)
▪ Processed files will allow the user to drill into the batches and post.

Mekorma Mekorma Products User Guide - Build x78
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▪ Failed (batch fails to transmit for any reason)
▪ A failed batch can be voided in GP by clicking Action > Void.

▪ Posted (ePayment batch posted)
▪ For a virtual card batch, the original batch will automatically be posted after the

Vcard batch is posted
▪ Abandoned (the batch will be removed from GP)

◦ Enhanced ePayment File Owner Maintenance: The main purpose of this window is to
assign batches that are in ‘Sent’ status to other GP users, to be processed when the batch
owner is away or on PTO.

Multi-Batch Management (MMM)

• Added Payment Method, Sub Total and Status fields to the Multi-Batch Management Post
Process Results report.

• Added the ability to see the next check number in Multi-Batch Management Action Board Process
Checks and EFTs area, by selecting the batch then clicking on the info button next to the
Checkbook ID.

• When ‘Generate EFT Files’ is chosen in MMM Action Board, only checkbooks with EFT
transactions will be displayed. Checkbooks showing a $0 batch total will not be listed.

• In the Multi-Batch Management Action Board, added the ability to set or change the dates on a
range of EFTs or SafePay files before generating.

Last modified: Nov 05, 2019

To access release notes for previous versions of Mekorma, follow this link.*
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2.2. Issues Fixed

Issues Fixed in September 2019 release (x78.10)

Mekorma Payment Hub (MICR)

• Identified and fixed an issue by which an intermittent network disconnection from SQL Server
database server may cause session ID to change, causing errors in Table Maintenance or
application registration errors.

• Fixed Payment Hub issue that allowed transactions to be added to approved MEM decentralized
batches. Payment Hub will now test decentralized entities to evaluate the batch availability. If the
batch is not available, the entity is unmarked and a warning is presented.

• Fixed an issue causing Table Maintenance to display companies as requiring upgrade, even after
all table upgrades have been completed.

• Fixed the following issue: when Blank Checks were printed and set to more than 1 check,
subsequent checks were not printing.

• When using the Task-Based security model, in the Approve ‘By Batch’ view, all batches that have
transactions needing approval will now appear.

• When using Legacy User Based Security (legacy), the Batch Number now appears in the
message ‘Batch xxx Approval request processed’.

• On the Mekorma Approval List, users are now able to sort transactions by Status as long as
System Table Upgrade has been run.

Mekorma Enhanced Electronic Payments (MEEP)

• The MEEP Vendor is now excluded from available vendors when creating a check payment batch
within the Build Payment Batch window. The MEEP vendor is paid via electronic funds transfer so
should not be included in a check batch.

• Fixed an issue that caused the first check number to skip by 1 when using Payment Hub in
combination with Enhanced Electronic Payments.

• Vendor enrollment status has been clarified in the Vendor Enrollment Status window. A vendor
can have one of the three following enrollment statuses:

◦ Enrolled: The vendor’s information is sent and maintained by the ePayment service.
Payments are processed by the service unless the processing type is set to Local.

◦ Pending: The vendor’s information will be sent to the ePayment system either overnight, or
next time the Send Vendor Master button in the Utilities module is clicked. Payments to this
vendor are processed locally using GP or MICR functionality until the vendor information
has been updated.

◦ Excluded: The vendor’s information is not sent to the ePayment service, and payments to

Expand each section by clicking +. Collapse each section by clicking -*
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this vendor are processed locally.
• The processing type is also indicated for each vendor:

◦ Local: Payments are processed locally using standard Dynamics GP/ Mekorma MICR
functionality. Payment information is not sent to the ePayment service.

◦ Vcard: The vendor will be paid by a virtual credit card issued by the MEEP Vendor.
◦ Check: The vendor will be paid with a check generated and mailed by the ePayment

service.
◦ EFT: The vendor will be paid by an EFT (ACH) emailed by the ePayment service.

• Payments made by Enhanced Electronic Payments will be excluded from the Positive Pay files
generated by Dynamics GP.

• ACH and Positive Pay files generated by the ePayment service will be placed in subfolders
organized by checkbook within the ePayment Integration Base folder.

• A customizable Comment Line and User Defined fields have been added to the headers for
payment information sent to the ePayment service. Allows users to adjust the payment
information sent to the service.

Product Manager

• Table Upgrade will now skip any company whose database does not exist on the server.
• Fixed performance issue upon login or switching companies; no longer checks for stubs

migration/upgrade each time. Removed double execution of Startup_After in MEP dictionary.

Mekorma Payment Hub (MICR)

• Users will no longer receive the error message ‘MMM does not support checkbooks with EFT
Remittance Option set to use Report Writer’ when ‘Omit $0 checks in Payables’ is marked in
Mekorma MICR System and the checkbook is set up to use Report Writer remittance.

• Fixed the error ‘The user does not have the Purchasing Task ID assigned’ message when
printing blank checks with security set to Legacy > User Based.

• With MEM Decentralized Payroll, PDF copies now print all entities processed.
• Payroll employee ID and name will print even if the HR component is not installed.
• Can now re-request authorization for batch previously cancelled after being authorized.
• Print_Cfg_Paytoll_Checks_to_File procedure will no longer point to old table ME_Check_Setup,

preventing MEM from displaying the MICR line; now directs to new ME_Pay_Check_Setup table.
• Fixed “No checks to print” error when running Payroll containing direct deposit transactions.
• All approved transactions now display in approval emails.
• Fields have been adjusted to not appear in the Mekorma Security Setup window if it is stretched

too large.
• Moving the check number string in the Mekorma MICR Checkbook Setup window by using the

shift left and shift right buttons was not saving.
• Rejection reason was not showing in the MICR Reject report when rejecting the payment in the

Mekorma Status List by opening the drill down window, selecting a vendor and clicking reject,
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when using Task-Based Security.
• Email notification was not sent out when rejecting one or more transactions from the Mekorma

Approval List when using Task Based Security.
• The Enhanced Net Check Amount field now prints the actual amount of the voucher being paid by

the check. The field subtracts terms discounts and write-offs from the voucher amount and shows
credit memos as negatives.

• GP Shortcuts now directing to new Mekorma windows.
• Authorization password validation issues fixed.
• Comments now print on Blank Checks.
• In the Mekorma Checkbook Maintenance window, when the MOD 9 check digit feature is used a

leading zero is no longer added to the GP next check number.
• EFT payments using EFT numbers no longer print with unexpected leading zeros.
• Fixed the error ‘Mekorma MICR can’t run until you create tables…’ when opening MICR windows,

even though the company has been upgraded.
• If two approvers are assigned using Task-Based security, the first approver is no longer able to

approve the batch a second time in the Batch Approval window.
• User with proper security role permissions can access the Mekorma Registration page, instead of

only those with admin role.

Mekorma Enhanced Electronic Payments (MEEP)

• When a virtual card batch is returned from the electronic payment process, it will now show in the
Post Batches area of the Multi-Batch Management Action Board

• Making changes to the Remit To or Primary Address fields in Vendor Maintenance for a company
that is not configured with MEEP does not cause the changes to be written to the
MEEP_Vendor_Changes_Pending table for that company.

• No longer receiving duplicate key error when making changes in the Vendor Combiner and
Modifier window, after changing either the Remit to or Primary Address fields in Vendor
Maintenance.

• Fixed unhandled script exception error when posting a payables batch in the Series Post window,
in a company not configured for MEEP.

• ePayments that were unable to transmit because the system was offline are no longer shown as
available to post.

• Removed ePayment table error, received when a check was printed using GP in a company that
had disabled Mekorma printing.

• Modified the batch number creation process when using Multi-Entity Management with Multi-
Batch Management to correct the issue of not having enough character length in a batch name.

• User with AP Clerk, MEEP clerk and MICR clerk roles are now able to print/transmit an
ePayment.

• ePayment check numbers now match those in GP after the ePayment has been submitted.
• Clicking on a vendor when creating a batch in the Edit Payables Cheque Batch window no longer

gives an error.
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Multi-Batch Management (MMM)

• When a batch was deselected on the MMM Action Board, additional information was not being
shown

• MMM company setup table is now created when Table Maintenance is run.
• User with AP Clerk, MEEP clerk and MICR clerk roles were not able to print/transmit an

ePayment.
• When using split batch and building EFT batches using MMM, they no longer print with check

number instead of EFT number.

MEM Integration

• The Internet User Defined 1 and 2 fields will now populate for either the MEM Centralized or
MEM Decentralized categories.

• MICR split batch is now assigned with MEM Entity ID.
• Resolved inability to access MICR_REJECT batch because it was not assigned a MEM entity.
• Modified the batch number creation process when using MEM Decentralized process with MMM,

to correct the issue of not having enough character length in a batch name.
• Fixed issue with applied credit memos in History. The Facility Name field now contains the

correct legal name for the credit memo.

GP Web Client Integration

• Task-Based fields no longer overlap if the screen is expanded and then contracted.

Last modified: Nov 18, 2019

To access release notes for previous versions of Mekorma, follow this link.*
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3. Introduction to Mekorma
Thank you for your interest in Mekorma products. Mekorma Payment Hub is a payables solution integrated
with Microsoft Dynamics GP®. The Payment Hub offers MICR check printing and the ability to print on blank
or pre-printed check stock; automated signature logic; check image archiving; and enhanced security
configuration options among the many available features. Mekorma works with Accounts Payable, U.S.
Payroll, Canadian Payroll, and is compatible with the Dynamics GP Web Client.

Mekorma also offers fully integrated add-on products/ services to optimize the payment process even
further:
Multi-Batch Management (MMM) will build and process payment batches across multiple companies and
checkbooks. MMM can be configured to the level of automation you desire. All processing actions can be
accomplished within one window.
Enhanced Electronic Payments (MEEP) allows you to pay vendors by check, EFT, or Virtual Credit Card.
MICR check printing can still be processed in-house or handled by the service. Mekorma will handle the
onboarding process to transition your vendors to electronic payments.
MEM Connector integrates with Binary Stream’s Multi-Entity Management® product to provide access to
facility information for vouchers printed on Mekorma check stubs.

How to Use This Guide

Last modified: Oct 16, 2019
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3.1. Prerequisites
There are several items to consider, and information you must have on hand to ensure your Mekorma
installation and implementation are successful:

For All Mekorma Users
1. Gather bank account information

• From what companies and checkbooks will you be making payments?
• You will need the routing number and account information for each checkbook used to print

MICR checks.
• What payment types will be made?

2. Choose a security model
• Task-Based Security
• Legacy Security

For Mekorma Users Printing Checks In-House
3. Printers and Supplies

• Do you have a printer that can do the job?
• Do you have the correct printer toner?

4. Choose your check stock
• Pre-printed or blank?
• Blank check stock is recommended, and REQUIRED when using Multi-Batch Management to

print checks.

5. Check Formats
• Mekorma comes with a library of pre-configured check formats that are customizable from

within the Mekorma MICR Configurator. What formats do you need?

6. Gather images to include on your check
• Will you use a company logo?
• Do you need signature files for approvers or authorizers?
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For Mekorma Users Transitioning to Electronic Payments
7. Vendor Qualification

• Any user wishing to implement Enhanced Electronic Payments must first have a conversation
with Mekorma Sales, then complete the vendor qualification process. This will allow Mekorma to
determine whether your company is a good fit, by reviewing annual AP spend.

Last modified: Aug 05, 2019
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3.2. Recommended Printers and Supplies

Printers for MICR Check Printing
We recommend that you print Mekorma checks to a dedicated medium – higher quality check printer using
blank check stock. The printer should have the following capabilities:

• Speed of 45 ppm and up
• Two-tray capacity
• Recommended monthly printing volume of 5,000 pages and up
• Output capacity of 400 sheets and up

Recommended models

The HP M607 series printers combine exceptional performance and energy efficiency with professional-
quality documents to use as dedicated check printers.
This printer series has a speed rating of 55 ppm. The 2-tray option makes it a perfect choice to print checks
on one tray and overflows and remittances on the second. It has a recommended monthly volume of 5,000
to 20,000 pages and input / output capacity of 650 sheets / 500 sheets.

Mekorma in-house testing has been performed successfully on the HP M607dn model.

MICR Check Printing Supplies
MICR check printing supplies include:

• Check stock (pre-printed or blank)
• Envelopes
• Magnetic Toner
• MICR Gauge

You can order supplies by contacting Mekorma’s recommended vendor, Altec. Altec can be reached by
calling 877-201-2005 (Reference – Mekorma) or email. See more infomation on ALTEC’s flyer.

You can also search the Internet using the key words “blank check stock” or “magnetic toner” to locate
vendors. Mekorma MICR will work with both blank and pre-printed check stock of almost any size. Mekorma
MICR does not work with duplicating check stock (NCR) or “C” fold.

Mekorma is not compatible with security hardware add-ons or on-board MICR fonts as are
found in Troy Printers, so there is no need spending extra for features we handle at the
software level.

!
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A free MICR gauge can be mailed to you after your Mekorma Payment Hub order is processed. If you would
like to receive a gauge, please email our Sales department. The gauge will assist you to determine the
correct spacing for the MICR font on your checks.

Last modified: Jul 31, 2020
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3.3. Security Model Options
Mekorma users can choose between two working security models, if more than the standard GP option is
desired. In addition to the below descriptions, please see here for a detailed list of features and how they
compare.

Mekorma Task-Based Security
Available in build x76 and later, Task-Based security offers more flexibility in threshold level configurations
than our historical Legacy model. Task-Based security integrates with the existing Microsoft Dynamics GP
security model by allowing administrators to manage multi-level approval thresholds with standard
application security tasks and roles. This model provides two ways to handle payment batch approvals,
depending on the level of detail you want to see within Dynamics GP:

• Secure Approval Workflow
• Authorization
• Signature Logic only can also be configured, allowing default signatures to print based on customized

threshold levels. Approval workflow or Authorization does not need to be configured in that case.

Mekorma Legacy Security
Legacy security is the model Mekorma users have employed for builds previous to x76. It is still an option
for all users and offers security by:

• User ID
• Checkbook ID
• Default GP security

Task-Based security includes an Out-of-Office feature that is not available in our Legacy
Model configuration.*

Existing Mekorma customers will inherit their Legacy settings upon upgrade to build x76 or
later. For first-time installations of Mekorma build x76 or later, Task-Based security will be
the default setting. However, it is possible to choose either model from within the Security
Setup window.

!

Please note that for Enhanced Electronic Payments customers who want to use Mekorma
security, you MUST configure secure approval workflow in either the Legacy or Task-Based
models so that payments are approved before sending to the ePayment service. If you have

!
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Last modified: Jan 13, 2020

Legacy Checkbook ID or Task-Based Authorizations set up, payments can be sent for
processing to the ePayment service without going through an approval process.
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3.3.1. Task-Based Security Model
Task-Based security allows you to configure a secure approval workflow or batch authorization process for
payables batches.

This video gives an overview of Task-Based security and how it works:

You will want to decide whether to configure secure approval workflow or batch authorization, depending on
the level of detail you would like included in the process. In both cases, Threshold IDs are configured and
saved at the system level, then applied to checkbooks. A Threshold ID allows you to save a series of
threshold ranges, associated with users’ Task IDs and default signatures in the way that works best for your
company.

Secure Approval Workflow

Secure Approval Workflow allows one or more designated user(s) to approve payment transactions
before check/ EFT batches can be printed and processed. Approvers are assigned transactions within a
particular threshold range, and those threshold ranges can also be associated with default signatures as
determined by your settings. This type of workflow allows Approvers a detailed view of each payment within
their assigned threshold range, and the ability to approve or reject as needed:

1. A designated GP user creates a payment batch.
2. The user must then Request Approval on that batch to start the workflow process. This can be done

from the following GP windows:
• Edit Payment Batch
• Edit Vendor Payment
• Build Payment Batch
• Print Payments
• Approvals can also be requested on all created batches from the Mekorma Payment Batch

Status List.
3. Approvers will receive email and/ or text notification that payment batches need approval (within their

assigned threshold range).

For Mekorma Users familiar with Legacy Security settings, this option incorporates all the
features of User ID-based Security, plus additional threshold options.*
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4. Approvers can access GP from any location. Payments are listed by Vendor in the Mekorma Approval
List, and it is possible to view all vouchers that have been applied to each payment. If you have a
document management system that integrates with GP and provides you with access to scanned
invoices from this screen, that information will also be available.

5. Payments at the Vendor level can be rejected and removed from the batch. Approvers can provide a
detailed message back to the requester as to why those payment should not be processed and how to
proceed.

6. Once approval has been given, the Requester will be notified via email that the batch can be
processed.

7. The Mekorma Audit Log keeps a record of all payments and which GP user approved them.

Authorization

Authorization happens at the batch level. 1 – 2 users (Mekorma Batch Authorizers) can be assigned to
authorize any payment batch before it is able to be printed/ processed. This type of configuration provides
less detailed drill-in capabilities. Authorizers simply view the batch total and decide whether to authorize the
entire batch for printing/ processing. Signatures can be associated with customized threshold ranges.

1. An authorized user creates a payment batch.
2. The user must then Request Authorization on the batch. This can be done from the following GP

windows:
• Edit Payment Batch
• Edit Vendor Payment
• Build Payment Batch
• Print Payments
• Authorization can also be requested on all batches created at the company level, from the

Mekorma Payment Batch Status List.
3. Designated Authorizers will receive email and/ or text notification that payment batches need

authorization.
4. From the Mekorma Payment Batch Status list, authorizers can access GP to review details about the

number of transactions in the batch and the total dollar amount.
5. Once the authorization has been given, email notices go back to the Requester and the batch can

then be processed.
6. The Mekorma Audit Log keeps a record of all batches and which GP user authorized them

Follow this link for complete instructions on how to configure Task-Based security once you have installed
Mekorma.

For Mekorma Users familiar with Legacy Security settings, this option is very similar to
Checkbook-based security and is now referred to as Authorization.*
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Last modified: Dec 12, 2019

Please note that for Enhanced Electronic Payments customers who want to use Mekorma
security, you MUST configure secure approval workflow in either the Legacy or Task-Based
models so that payments are approved before sending to the ePayment service. If you have
Legacy Checkbook ID or Task-Based Authorizations set up, payments can be sent for
processing to the ePayment service without going through an approval process.

!
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3.3.2. Legacy Security Model

Mekorma Legacy Security
Legacy is Mekorma’s original security model and includes the options to set security by:

• User ID
• Checkbook ID
• Default GP security

User ID

Security by User ID uses the Microsoft Dynamics GP User ID and password as your check printing
password. In addition, with this option, you can view an Audit Log report that records the approvers/signers
for each check batch.

With this option you can:

• Select which users are allowed to print checks.
• Select which checkbook each user can print from.
• Print a different signature for each user, share signatures between users, or print with no signatures

at all and lines for hand signing.
• Set the maximum approval amount for each user.
• Define when passwords are required and how many are required based on the dollar amount.
• Works with Vendor Class Security.

Checkbook ID

The security by Checkbook option associates signature and password logic with a specific Microsoft
Dynamics GP Checkbook. The signature and password logic is contained in the Signature ID that is
assigned to the checkbook.

• Allows different passwords for each checkbook.
• Allows for both lower and higher threshold logic.

No Security

• No additional security added beyond standard GP security

Please note that for Enhanced Electronic Payments customers who want to use Mekorma
security, you MUST configure secure approval workflow in either the Legacy or Task-Based

!
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models so that payments are approved before sending to the ePayment service. If you have
Legacy Checkbook ID or Task-Based Authorizations set up, payments can be sent for
processing to the ePayment service without going through an approval process.
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3.3.3. Signatures Only with Standard GP
Security
Payments can also be processed without configuring Mekorma security. In that case, standard Dynamics
GP security will apply.

Even if you choose not to configure passwords, thresholds, or secure approval workflow using Mekorma
security, it is possible to apply Mekorma signature logic to your check printing.

If you only make payments from one checkbook, or if the same signature logic can be applied to multiple
checkbooks within the same company, please use this method.

Mekorma recommends configuring your system in this way if you need varying signature logic for multiple
checkbooks.

Last modified: Aug 05, 2019
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3.4. How to Create a Digital Signature
If you will be using signatures as part of your security settings in Mekorma, you will need to gather all
needed signatures and transform them into a digital format. Please watch the video below to view step-by-
step instructions, as recommended by Mekorma:

1. Take a standard 8 ½ x 11 sheet of paper and draw a rectangle that represents the average signature
field.

2. Print (or make) as many copies as there are signers. For example, if six different signatures are
needed, print six copies of the sheet with the empty box.

3. Ask each signer to sign their name within the rectangle. There should be no more than one signature
per page.

4. Scan each sheet into a computer.
5. Open the signatures one at a time in the Microsoft Paint application
6. With one of the signatures opened in Paint, click on the Select drop-down menu and choose

Rectangular selection. Draw the selection box around the signature as closely as possible and then
click Crop.

7. Click on Resize and choose the Pixels button in the Resize and Skew window. Be sure that Maintain
aspect ratio is checked, and adjust either the horizontal or vertical dimensions. A good choice for use
in GP is a signature file with approximate dimensions of 220 × 50 pixels.

8. Save your signature as a 16 color bitmap.
9. Repeat the same procedure for all needed signatures, and store in a location accessible to an

administrator for use in GP.

• If additional sizing is needed, you can always adjust within the Mekorma Configurator.

Last modified: Aug 05, 2019
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3.5. Vendor Qualification for Enhanced
Electronic Payments
Mekorma Enhanced Electronic Payments (MEEP) requires that all potential customers complete the vendor
qualification process. This process will generate the necessary data needed to review eligibility, including
the annual AP spend of each company being considered.

If you want to know more about transitioning your vendors to accept electronic payments, the first step is to
schedule a meeting with Mekorma Sales.

There are two recommended methods for completing the vendor qualification process, outlined in the videos
below.

For current Mekorma customers on Build x75 or later:

The qualification process will generate an Excel spreadsheet that displays annual AP spend information for
all included companies. This spreadsheet must be submitted to Mekorma for review.

1. Install Mekorma Build x76 or later.
2. Navigate to the ‘Mekorma Enhanced ePayment Qualification’ window.
3. It is possible to exclude specific vendors from the process. To do so, right-click on the company(ies)

you will be submitting and choose Exclude Vendors to open the ‘Enhanced ePayment Qualification
Exclusion’ window. Check the box next to each vendor you want to exclude. Press OK to save.

4. Double-click on a company to open the ‘Enhanced ePayment Company Data’ window. Enter a
Subdomain Name and Administrator email address. Click Save.

5. Once you have entered this data for each company you will be submitting for review, check the box to
the left of each company and click Process. Please note – if the Email to: checkbox has been
selected, the Excel spreadsheet generated when you click Process will automatically be emailed to
Mekorma. If it has been deselected, you will have to manually email the generated file(s) to
qualification@mekorma.com.

6. Once the vendor file has been received and reviewed for qualification, a meeting will be setup with the
appropriate contact person to discuss our findings and whether or not your company has qualified for

To access the Enhanced ePayment Qualification window, go to the Mekorma Area page >
Setup > System > Enhanced ePayment Qualification*
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the program.

If you do not have Mekorma installed or would prefer to use a
SQL query:

If you have not yet upgraded to Mekorma Build x75 or later, you will need to gather data from your SQL
server and generate the necessary information within a spreadsheet template, provided to you by Mekorma
Sales. Full instructions can be found on the first worksheet of the spreadsheet.

Once the fields are populated, the spreadsheet must be emailed to qualification@mekorma.com.

Sales will then be able to determine if your company is a good candidate for Mekorma Enhanced Electronic
Payments.

Last modified: Nov 22, 2019
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3.6. Virtual Card Processing: Pre-funded or
Credit Model
Mekorma Enhanced Electronic Payments service can pay your vendors via checks, EFT, or by virtual credit
cards (Vcard). What is a virtual credit card? Rather than swiping a physical, plastic card, your vendors will
be emailed a 16-digit virtual card that is only good for that particular transaction.

If you are an Enhanced ePayment customer, you have a choice as to how you will reimburse the virtual card
company for vendor payments made with Vcards: by pre-funding the Vcards, or by taking advantage of our
credit model. You must decide which model you will use when setting up the original ePayment checkbook,
or when adding an additional checkbook for ePayment processing.

Pre-Funded Model
If using the pre-funded (or debit) model, payment batches from GP batches are submitted to the ePayment
service, and you are then required to provide funds to the virtual card company for the total amount of all
issued Vcards.

The ePayment service automatically generates an ACH file that contains the Vcard total of the batch, and
you must send this to your bank so the funds can be transferred to the virtual card company. Upon receipt of
the funds, the Vcard payments are emailed to your vendors.

Credit Model
When using the credit model, the virtual card company offers a no-cost line of credit. After batches are sent
for processing, you will not be immediately charged for issued cards. Instead, the virtual card company will
automatically transfer payments from your company’s account on a regularly scheduled basis, and you will
only pay for the card amounts that have been “swiped” by vendors during that credit period. This has the
advantage of allowing cash to float in your account for more time.

All checkbooks processing electronic payments can be viewed within the Enhanced ePayment Configuration
window. Refer to the checkbook fields of this window to confirm which model is being used for each
ePayment checkbook.

Last modified: Nov 22, 2019
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4. Installation

Preparation
1. Determine your Microsoft Dynamics GP version before downloading your Mekorma product(s).

2. Download the product installer that corresponds with your GP version from the Mekorma downloads
page.

3. Follow the installation/ upgrade procedures.

Last modified: Dec 17, 2019

Please note, you must install Mekorma on every workstation that performs operations
requiring the use of Mekorma features.*
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4.1. Find Your Dynamics GP Version

What version of Dynamics GP are you running?
Before downloading Mekorma, you need to know what version of Dynamics GP is running so you can
choose the correct Mekorma installer. If you are downloading Mekorma to multiple workstations, it is
important to know the GP version for each one. Here’s how to check:

1. Log in to Dynamics GP.

2. Click on the GP Help ? icon in the top right-hand corner of your screen.

3. Select About Microsoft Dynamics GP…

4. In the example below, the major version is displayed in the title box: Microsoft Dynamics GP 2018.
(More specific version information will be listed under the Version Information column.) This means
that the Mekorma installer corresponding to GP2018 must be chosen from the downloads page.
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4.2. New Installation or Product Upgrade

Run the Mekorma Installer
1. Log in to Windows as an Administrator.

2. Once the installer has been downloaded, launch the executable file. The file will follow this naming
convention: MICR + GP version + Mekorma build version. (ex. MICR2018b078.exe) – right-click and
select the option to Run as Admin.

3. Select the appropriate GP instance from the drop-down menu. If you only have one GP instance
available, that option will automatically be selected.

4. After following all prompts, click Finish and close the Installer.

5. After you install Mekorma, launch Dynamics GP and log in as the ‘sa’ user. The system will ask if you
want to upgrade tables now or later. Upon agreement, you must run the Table Maintenance procedure
for a first-time install or product upgrade to take effect.

6. The Mekorma Products Manager will automatically retrieve registration keys for all installed Mekorma
Products if you are connected to the Internet. If Internet access is not available, please contact
Mekorma Sales.

Install Mekorma Enhanced Electronic Payments (MEEP)
Utilities

Installing MEEP utilities automates the process of synchronizing the vendor master file (when changes are
made in Microsoft Dynamics GP or by the Enhanced Electronic Payments service). The Utilities installer
should be installed in a single computer (preferably, but not necessarily, the SQL server) and does not need
GP to be installed in that computer.

Download the MEEP Utilities Installer

Your Implementation Consultant will walk you though the following steps:

1. Log in to Windows as an Administrator.

MEEP utilities are necessary to install only for Mekorma Enhanced Electronic Payments
customers. If you are interested in qualifying for this add-on service, please complete the
Vendor Qualification process.

!
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2. Launch the MEEPUtilities.exe.

3. Follow the prompts to accept the license.

4. Choose the desired Installation folder.

5. Select whether you’d like to use Windows or Server authentication and enter necessary data.

6. On the Set up scheduled task window, please choose the time you would like Microsoft Dynamics
GP and the Enhanced Electronic Payment system to synchronize. You can run this task as the current
user or assign it to another Windows user.

7. Click Finish to close the Installer.

Last modified: Dec 12, 2019

Mekorma Mekorma Products User Guide - Build x78

Page 36 of 288



4.3. Run Table Maintenance
As third-party products are not included in the Dynamics GP upgrade process, Mekorma provides its own
unified table upgrade system for all your GP companies. Table Maintenance must be run after installing
Mekorma for the first time, or after upgrading to a more current version. Individual companies can be
upgraded at the same time or separately within the Table Maintenance window.

You must also run table maintenance after a new company is created in GP. Learn more in the video below:

Requirements
• A system administrator user is needed to perform table maintenance. If you are not a system

administrator, a warning message displays and the window will close.
• It is imperative that no one is working on a Mekorma product while the upgrade process is running.

For example, no one should be printing checks via MICR, Multi-Batch Management, or Enhanced
Electronic Payments.

• Verify that you have posted all your batches before upgrading Mekorma products.
• If any registration error occurs, see the section on product registration for more details.

Only the system administrator is prompted to run the process in both circumstances, so be
sure to log in as ‘sa’ after installation.

!

To manually access the Table Maintenance window, go to the Mekorma Area Page >
Setup > System > Table Maintenance*
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New Mekorma Installation or Product Upgrade:
1. Whether you are creating tables for the first time or upgrading, the process of running table

maintenance is the same. The option to run Table Maintenance will only be prompted for the System
Administrator (‘sa’) so the user ‘sa’ must log in after a new install or upgrade.

2. Select the companies that need tables created or updated, and click Process & Enable Selected
Companies. (You do not need to update all companies at the same time). Registration keys are
obtained automatically, so when the table update process is complete, Mekorma Products are ready
to use.

3. When the process is finished, close the Mekorma Products Table Maintenance window.

Last modified: Dec 30, 2020
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4.4. Products Registration
Upon installation or upgrade, Mekorma keys are automatically retrieved by the system (although keys can
be entered manually if needed). In order to retrieve keys, an internet connection is required (allowing access
to our Mekorma Registration Web Service).

The Mekorma Products Registration window provides the ability to enter new registration keys; request trial
period keys; and access to our online keys retrieval system. To learn more about actions you may need to
take in the Products Registration window, please see the video below:

The following products require keys:

• Mekorma MICR Payables
• Mekorma MICR US Payroll
• Mekorma MICR Canadian Payroll
• Multi-Batch Management
• MEM Connector for Payables
• MEM Connector for US Payroll

Last modified: Aug 14, 2019

For best results, create an inbound and inbound rule in your firewall to allow access to our
web service. Allow IP address 64.74.139.46.

!

To access the Mekorma Products Registration window, go to the Mekorma Area Page >
Setup > System > Registration*
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4.5. Mekorma Products Manager
The Mekorma Products Manager is a helper dictionary that manages table maintenance and product
registration for all Mekorma products. This product is installed with Mekorma Payment Hub. It is a required
component necessary to run all Mekorma products.

The Products Manager window will tell you what version of Mekorma you are running and includes links to
the following:

Last modified: Aug 15, 2019

To access the Mekorma Product Manager, go to the GP Help menu > About Microsoft
Dynamics GP > Additional > Mekorma Products Manager*
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4.6. Print Client for GP Web Client
To print Mekorma checks out of the Dynamics GP Web Client, it is necessary to install the Mekorma Print
Client (MICRPrintClient.exe) on each workstation intended for Mekorma check printing from a Web Client
session. There are two methods for accomplishing this:

Install from the GP root folder

1. Open the Dynamics GP desktop root folder where you have installed Mekorma.

2. Go to the Mekorma MICR folder > Webclient folder to access the MICRPrintClient exe file.

3. Copy this file and install it on your desktop or network as administrator.

Install from within Mekorma software

1. Open the Mekorma Web Client Download and Installation window.

2. Click on the link to download and install the MICRPrintClient.exe file.

Last modified: Oct 11, 2019

To open the Mekorma Web Client Download and Installation window, go to the Mekorma
Area Page > Setup > System > Web Client Installation*
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5. Configuration
This section of the User Guide offers instruction on where to find the configuration settings for Mekorma
features and functionality.

Last modified: Oct 11, 2019
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5.1. Navigating to Mekorma Windows
Mekorma has its own Area Page within Dynamics GP, so that all Mekorma related windows can be
accessed from one screen. Traditional Mekorma navigation via Dynamics GP menus remains in effect.

You can configure GP’s Navigation Pane to make the Mekorma Area Page easily accessible. Watch (screen
action only) below:

Once on the Mekorma Area Page, you will find seven different panes that contain all Mekorma-related
windows:

• Transactions
• Cards
• Routines
• Reports
• Setup
• Utilities
• Inquiry

Last modified: Aug 05, 2019

Throughout the Mekorma User Guide, navigation paths to Mekorma windows can be found
within these blue information boxes.*
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5.2. Mekorma Quickstart
The video below will walk you through the necessary steps to get Mekorma functioning, so that you can
assess your payment processes and ensure that you are ready to move on to production.

1. Login as ‘sa’.

2. Select the company that you want to use.

3. Run the Table Maintenance procedure.

4. Address security settings: navigate to the Security Setup window determine which security model is
selected. You can turn off Mekorma security for testing purposes:

• If the Mekorma Legacy Security model is chosen, navigate to the Security Maintenance window and
choose ‘None’ in the in the “Set Passwords By…” field.

• If Task-Based Security is selected, leave the default settings as is.

5. Configure a checkbook use in the Checkbook Setup window.

6. Open the Test Check Layout and Security window to test that checkbook’s printing.

Last modified: Aug 05, 2019
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5.3. Set Up a Checkbook
Before setting up your checkbooks for Mekorma MICR check printing, please be sure you have already
created the necessary Checkbook ID(s) within the Dynamics GP Checkbook Maintenance window. Consult
your GP documentation if you need assistance with this step.

Mekorma will attempt to create check copies in the specified folder.

If we cannot access this folder or the folder becomes unavailable, we will create the check copies in the
Data subfolder of your Microsoft Dynamics GP installation folder.

If you need information on how to set up additional checkbooks for Enhanced Electronic Payments
processing, please see this page.

Last modified: Aug 27, 2019
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5.3.1. Configure a Checkbook’s MICR Line
Watch the video below for detailed instructions on how to configure the MICR line for your AP, US Payroll
and Canadian Payroll checkbooks:

Configure the MICR Line

1. In the Checkbook Setup window, enter a Checkbook ID by using the lookup.
2. Open the MICR Line Quick Entry window by clicking on any of the hyperlinks within the MICR Line

Setup field.
3. Add any information that has not been automatically pulled in from the GP Checkbook Maintenance

window:
a. Number of Check Digits
b. Right-most position of Check Digits*
c. Routing Number
d. Region Code*
e. Account Number
f. Right-most position of the Account Number*

4. Click OK
5. Please note, the Transit (ABA) Number will automatically be calculated and entered for you upon

entry of the correct routing number/ region code.
6. If you need to make edits to the information, you can either open the MICR Line Quick Entry window

and make changes there, or edit directly on the graphical interface by clicking on a value and scrolling
through the options.

Please ask your bank for this information *

Last modified: Nov 19, 2019

To access the Mekorma Checkbook Setup window, go to the Mekorma Area Page > Setup
> Purchasing > Checkbook Setup*
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5.3.2. Choose Check Formats from the Check
Format Library
Mekorma’s Checkbook Setup window allows you to select pre-configured check formats for the Purchasing,
US Payroll and Canadian Payroll modules.

You can select up to 7 different formats for the different purposes used by Dynamics GP. The selected
formats do not have to be unique; the same format can be used for multiple purposes:

• The Primary Check Format is the main check that is sent to your vendors. This is the only format you
are required to designate.

• The Check Copy Format allows you to print a physical copy of the primary check, and can be
different than the format you send to your vendors.

• The Check Overflow format and Check Copy Overflow format are used when you want to have a
different format for overflows.

• The EFT Remittance Options defaults to Check Face/Overflow Stub. If you leave this default then
Mekorma will use the exact same formats for EFTs as it does for your checks. Since EFTs don’t
require the check portion of the format, different formats can be selected.

• The Refund Check and Refund Check Overflow formats are used if you will be using the Refund
Checks feature in Microsoft Dynamics GP.

Choose Formats:

1. Go to the Checkbook Setup window.

2. Select the checkbook and the module (Purchasing, US Payroll, Canadian Payroll) that you want to
configure.

To access the Mekorma Checkbook Setup window, go to the Mekorma Area Page > Setup
> Purchasing > Checkbook Setup*
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3. Click on the lookup to the right of Primary Check Format, and choose an appropriate option from
Mekorma’s library of pre-configured formats. The name of each format file indicates key information
included on that format.

4. If you want to customize your chosen format, open the Mekorma Configurator by clicking on the
Primary Check Format link. You can then edit within the Configurator. This process can be repeated
for any additional format selections.

Last modified: Nov 19, 2019

Within the same company, you cannot print some checks using Mekorma and others using
Microsoft Dynamics GP, unless you have a second Microsoft Dynamics GP user configured
through the Alternate Security to print checks. It is important to note that any change to your
operating system, server, or printer could cause printing variations. Always retest the
formatting of your checks and the MICR line if you have altered your system configuration
or peripherals in any way.

!
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5.3.3. Customize Check Formats Using the
Configurator
The Mekorma MICR Configurator is a report editing tool that allows you to modify Mekorma-generated
checks and stubs. The Configurator handles any size paper and any system font.

Use the Configurator in conjunction with the pre-prepared stub files provided in the Mekorma Check Format
Library to create check stub formats designed specifically for your company’s check printing needs. The
Configurator is a feature-rich, easy-to-use editing tool with drag-and-drop functionality, multiple windows,
menus, and toolbars.

• To add fields, labels, lines and images/ logos, use the Add Elements button. The element will be
added to the upper left corner of the format. It can then be moved to the check or stub of your choice.

• For quicker alignment of fields, use the Alignment tools on the Layout tab at the top of the
Configurator window.

• Use the Zoom In and Zoom Out buttons to see more of the page or get a closer look at a field.
• Select entire regions to move or delete the region and all fields. A region will appear as blue when

selected. To de-select a region, click on white space or any unselected element.
• Use the mouse to select fields to move, re-size or delete. You can use the control key to select

multiple fields.
• For finer manipulation, to change font, for alignment and other adjustments, select a field and use the

Properties box in the lower left of the Configurator window.
• You can select and copy entire regions to make duplicate remittance stubs.
• For any Amount field on a check stub, you can choose to hide it when there is no value populating

the field. Click on the field itself, and use the Properties pan to check the box next to Hide When
Empty.

To open the Mekorma Configurator, click on any of the check format links from within the
Mekorma Checkbook Setup window.*
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Last modified: Nov 19, 2019

Follow this link for a complete list of all check stub fields available in the Configurator.*
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5.3.3.1. Mekorma Fields for Check Stubs
All available check stub fields within the Mekorma Configurator are listed below by section. Any of these
fields can be added by clicking on the Add Elements button once the Mekorma Configurator has been
opened:

These fields are available for Payables, US Payroll and Canadian Payroll check
stubs:

General Information

• Approver 1
• Approver 2
• Bank Account Number
• Bank Address
• Bank Branch
• Bank Fax Number
• Bank ID
• Bank Master Transit Number
• Bank Name
• Bank Phone 1
• Bank Phone 2
• Bank Phone 3
• Check Comment 1
• Check Comment 2
• Check Comment 3
• Checkbook Description
• Checkbook ID
• CM User Defined 1
• CM User Defined 2
• Company Address
• Company Contact
• Company Fax Number
• Company Location Name
• Company Name
• Company Phone 1
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• Company Phone 2
• Company Phone 3
• GL Posting Date
• Printed By
• Requester
• Transit Number
• User ID

Commonly Used Labels

• AMOUNT
• Amount
• Canadian Funds
• Check Date
• CHECK NO
• Cheque Date
• CHEQUE NO
• Date
• DATE
• DDMMYYYY
• Description
• Description Reference
• Discount Taken
• Dollars
• GL Account Number
• Invoice Date
• Invoice Number
• MMDDYYYY
• Net Check Amt
• Net Cheque Amt
• Net Paid Amount
• Net Paid Amt
• ORDER OF
• Outstanding Amt
• Paid Amount
• Pay
• PAY
• Pay to the Order of
• Payee
• Payment Number
• PO Number
• TO THE
• to the Order of
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• US Funds
• Voucher Amount
• Voucher Number
• Write Off
• YYYYMMDD

Logical Fields

• EFT Comment
• EFT Logo
• EFT Non-Negotiable
• EFT VOID
• Facility Signature 1
• Facility Signature 2
• Line 1
• Line 2
• Continued
• Signature File 1
• Signature File 2
• Signature File 1 Based on PO Number
• Signature File 2 Based on PO Number
• Signature Line 1 Based on PO Number
• Signature Line 2 Based on PO Number

Payables

Detailed Addresses for Payables

• Bank Address 1
• Bank Address 2
• Bank Address 3
• Bank City-State-Zip
• Bank Country
• Company Address 1
• Company Address 2
• Company Address 3
• Company City-State-Zip
• Company Country
• Payment Address 1
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• Payment Address 2
• Payment Address 3
• Payment Address ID
• Payment City-State-Zip
• Payment Contact
• Payment Country
• Payment Zip
• Vendor Main Address 1
• Vendor Main Address 2
• Vendor Main Address 3
• Vendor Main City-State-Zip
• Vendor Main Country

GL Distribution

• 1099 Amount
• Account Alias
• Account Description
• Account Number
• Account User Defined 1
• Account User Defined 2
• Credit Amount
• Debit Amount
• Distribution Reference
• Document Type
• Enhanced Net Check Amount
• Freight Amount
• Intercompany ID
• Misc Charges Amount
• Multi-Currency Debit Minus Credit Amount
• New Amount Paid (Tech Knowledge 18381)
• New Document Amount (Tech Knowledge 18381)
• Originating Credit Amount
• Originating Debit Amount
• Payment Terms ID
• Posting Date
• Purchase Order Number
• Purchases Amount
• Shipping Method
• Tax Amount
• Tax Schedule ID
• Trade Discount Amount
• TRX Source
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• Voucher Amount Paid
• Voucher Credit Amount
• Voucher Credit Document Amount
• Voucher Discount Date
• Voucher Discount Taken Amount
• Voucher Discount Taken Total
• Voucher Document Amount
• Voucher Document Date
• Voucher Document Number
• Voucher GST Discount Amount
• Voucher Net Check Amount
• Voucher Net Paid Amount
• Voucher Outstanding Amount
• Voucher Paid Total
• Voucher PPS Amount Deducted
• Voucher Total Document Amount
• Voucher Transaction Description
• Voucher Voucher Number
• Voucher Write Off Amount
• Voucher Write Off Total

MEM Centralized

• Facility ID
• Facility Name
• Facility Company Name
• Document Number
• Transaction Description
• Discount Taken Amount
• Purchase Order Number
• Net Paid Amount
• New Amount Paid (Tech Knowledge 18381)
• Document Date
• Voucher Number
• Voucher Date
• Document Amount
• Internet User Defined 1
• Internet User Defined 2

MEM Decentralized
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• Facility ID
• Facility Name
• Facility Company Name
• Facility Address
• Internet User Defined 1
• Internet User Defined 2

Payment

• Amount in Words
• Amount in Words with Word Wrapping
• Amount in Words (Techknowledge 857824)
• Amount in Words (Techknowledge 857824) with Word Wrapping
• Check Comment
• Check Amount with ***
• Check Number
• Check Total
• Document Date
• Document Date-D1
• Document Date-D2
• Document Date-M1
• Document Date-M2
• Document Date-Y1
• Document Date-Y2
• Document Date-Y3
• Document Date-Y4
• EFT or Regular Check Total
• Payment Comment (from Edit Payables Checks)
• Payment Number

POP Single Line Per Invoice

• 1099 Amount
• Amount Paid
• Credit Amount
• Credit Document Amount
• Discount Date
• Discount Taken Amount
• Discount Taken Total
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• Document Amount
• Document Date
• Document Number
• Document Type
• Due Date
• Enhanced Net Check Amount
• Freight Amount
• GST Discount Amount
• Misc Charges Amount
• Net Check Amount
• Net Paid Amount
• New Amount Paid (Tech Knowledge 18381)
• New Document Amount (Tech Knowledge 18381)
• Outstanding Amount
• Paid Total
• Payment Terms ID
• POP Extended Cost
• POP Item Description
• POP Item Description or Voucher Description
• POP Item Number
• POP or Voucher PO Number
• POP QTY Invoiced
• POP Receipt Date or Voucher Date
• POP Receipt Number or Voucher Number
• POP Reference or Voucher Description
• POP Unit Cost
• POP Unit of Measure
• POP Vendor Document Number
• Posting Date
• PPS Amount Deducted
• Project Contract Name
• Project Contract Customer
• Project Contract Number
• Project Contract ID
• Project Cost
• Project Customer Number
• Project Number
• Project Purchase Order Number
• Project User Defined1 Contract
• Project User Defined2 Contract
• Purchase Order Number
• Purchases Amount
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• Shipping Method
• Tax Amount
• Tax Schedule ID
• Total Document Amount
• Trade Discount Amount
• Transaction Description
• TRX Source
• UD Date01
• UD Date02
• UD Date03
• UD Date04
• UD Date05
• UD Date06
• UD Date07
• UD Date08
• UD Date09
• UD Date10
• UD Date11
• UD Date12
• UD Date13
• UD Date14
• UD Date15
• UD Date16
• UD Date17
• UD Date18
• UD Date19
• UD Date20
• UD List01
• UD List02
• UD List03
• UD List04
• UD List05
• UD Text01
• UD Text02
• UD Text03
• UD Text04
• UD Text05
• UD Text06
• UD Text07
• UD Text08
• UD Text09
• UD Text10
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• Voucher Number
• Write Off Amount
• Write Off Total

POP Multiple Lines Per Invoice

• 1099 Amount
• Amount Paid
• Credit Amount
• Credit Document Amount
• Discount Date
• Discount Taken Amount
• Discount Taken Total
• Document Amount
• Document Date
• Document Number
• Document Type
• Due Date
• Enhanced Net Check Amount
• Freight Amount
• GST Discount Amount
• Misc Charges Amount
• Net Check Amount
• Net Paid Amount
• New Amount Paid (Tech Knowledge 18381)
• New Document Amount (Tech Knowledge 18381)
• Outstanding Amount
• Paid Total
• Payment Terms ID
• POP Extended Cost
• POP Item Description
• POP Item Description or Voucher Description
• POP Item Number
• POP or Voucher PO Number
• POP QTY Invoiced
• POP Receipt Date or Voucher Date
• POP Receipt Number or Voucher Number
• POP Reference or Voucher Description
• POP Unit Cost
• POP Unit of Measure
• POP Vendor Document Number
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• Posting Date
• PPS Amount Deducted
• Project Contract Name
• Project Contract Customer
• Project Contract Number
• Project Contract ID
• Project Cost
• Project Customer Number
• Project Number
• Project Purchase Order Number
• Project User Defined1 Contract
• Project User Defined2 Contract
• Purchase Order Number
• Purchases Amount
• Shipping Method
• Tax Amount
• Tax Schedule ID
• Total Document Amount
• Trade Discount Amount
• Transaction Description
• TRX Source
• UD Date01
• UD Date02
• UD Date03
• UD Date04
• UD Date05
• UD Date06
• UD Date07
• UD Date08
• UD Date09
• UD Date10
• UD Date11
• UD Date12
• UD Date13
• UD Date14
• UD Date15
• UD Date16
• UD Date17
• UD Date18
• UD Date19
• UD Date20
• UD List01
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• UD List02
• UD List03
• UD List04
• UD List05
• UD Text01
• UD Text02
• UD Text03
• UD Text04
• UD Text05
• UD Text06
• UD Text07
• UD Text08
• UD Text09
• UD Text10
• Voucher Number
• Write Off Amount
• Write Off Total

UK Cheques

• UK Cheque Amount
• UK Vendor Name Only
• UK Vendor Name*
• UK Vendor Name
• UK Document Date
• UK Amount in Words with Word Wrapping

Vendor

• 1099 Amount YTD
• 1099 Type
• Account Number With Vendor
• Account Type
• Bank Account Number
• Bank Name
• Bank Transit Number
• Contact Name
• Fax Number
• Governmental Corporate ID
• Governmental Individual ID
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• Parent Vendor ID
• Payment Address
• Payment Address with Country
• Payment Priority
• Payment Terms ID
• Phone 3
• Phone Number 1
• Phone Number 2
• Shipping Method
• Tax ID Number
• Tax Registration Number
• Vendor Address with Contact Name
• Vendor Check Name
• Vendor Check Name – SAFE PAY
• Vendor Class ID
• Vendor Comment 1
• Vendor Comment 2
• Vendor Contact
• Vendor ID
• Vendor Main Address
• Vendor Name
• Vendor Name – SAFE PAY
• Vendor Note
• Vendor Short Name
• Vendor User Defined 1
• Vendor User Defined 2

Voucher

• 1099 Amount
• Amount Paid
• Credit Amount
• Credit Document Amount
• Discount Date
• Discount Taken Amount
• Discount Taken Total
• Document Amount
• Document Date
• Document Number
• Document Type
• Due Date
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• Enhanced Net Check Amount
• Freight Amount
• GST Discount Amount
• Misc Charges Amount
• Net Check Amount
• Net Paid Amount
• New Amount Paid (Tech Knowledge 18381)
• New Document Amount (Tech Knowledge 18381)
• Outstanding Amount
• Paid Total
• Payment Terms ID
• Posting Date
• PPS Amount Deducted
• Purchase Order Number
• Purchases Amount
• Shipping Method
• Tax Amount
• Tax Schedule ID
• Total Document Amount
• Trade Discount Amount
• Transaction Description
• TRX Source
• Voucher Number
• Write Off Amount
• Write Off Total

Refund Single Document

• Document Amount
• Document Date
• Document Description
• Document Number
• Document Type
• Customer Name
• Customer Number
• Customer PO Number
• Extended Price
• Freight Amount
• Item Description
• Item Number
• Markdown Amount
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• Misc Amount
• Quantity
• Salesperson ID
• Sales Territory
• Shipping Method
• Tax Amount
• Trade Discount Amount
• U Of M
• Unit Price

Refund Multiple Documents

• Document Amount
• Document Date
• Document Description
• Document Number
• Document Type
• Customer Name
• Customer Number
• Customer PO Number
• Misc Amount
• Salesperson ID
• Sales Territory
• Shipping Method
• Tax Amount
• Trade Discount Amount

US Payroll

Benefits

• Benefit Amount Array
• Benefit Amount YTD Array
• Benefit Code Array
• Benefit Description
• Total Benefits

Check

• Amount in Words

Mekorma Mekorma Products User Guide - Build x78

Page 64 of 288



• Amount in Words with Word Wrapping
• Check Amount with ***
• Check Date
• Check Date-D1
• Check Date-D2
• Check Date-M1
• Check Date-M2
• Check Date-Y1
• Check Date-Y2
• Check Date-Y3
• Check Date-Y4
• Check Number
• Facility Name
• Facility Stub String
• Facility Check String
• Facility ID
• Facility Company Name
• Facility Address
• Internet User Defined 1
• Internet User Defined 2
• Net Wages Pay Run
• Check Direct Deposit Amount

Deductions

• Deduction Amount Array
• Deduction Amount YTD Array
• Deduction Code Array
• Deduction Description
• Total Deductions

Detailed Addresses

• Bank Address 1
• Bank Address 2
• Bank Address 3
• Bank City-State-Zip
• Bank Country
• Company Address 1
• Company Address 2
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• Company Address 3
• Company City-State-Zip
• Company Country
• Employee Address 1
• Employee Address 2
• Employee Address 3
• Employee City-State-Zip
• Employee Country
• Employee Country Code
• Employee County
• Employee Fax
• Employee Foreign Postal Code
• Employee Foreign State Province
• Employee Phone 1
• Employee Phone 2
• Employee Phone 3
• Employee Zip
• First Name
• Last Name
• Middle Name

Direct Deposit

• DD Array12 Account Number
• DD Array12 Amount
• DD Array12 Transaction Code
• DD Array12 Transit Number
• DD Number of Accounts
• Net Wages Pay Run (Stub Only)

Earnings

• Business Expense Earnings
• Charged Tips Earnings
• Commission Earnings
• Double Time Earnings
• EIC Earnings
• Holiday Earnings
• Min Wage Bal Earnings
• Overtime Earnings
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• Pension Earnings
• Piecework Earnings
• Piecework Units
• Regular Earnings
• Reported Tips Earnings
• Sick Time Earnings
• Special Earnings
• Total Earnings
• Vacation Earnings

Employee

• Alternate Name
• Class Description
• Department
• Department Additional Description
• Department Description
• Division Address 1
• Division Address 2
• Division City-State-Zip
• Division Code
• Division Name
• Employee Address
• Employee Class
• Employee Full Name – SAFE PAY
• Employee ID
• Employee Name
• Employee Name with Suffix
• Employee Note
• Employee Suffix
• Employee User Defined 1
• Employee User Defined 2
• Federal Classification Code
• First Name
• Job Title
• Job Title Description
• Last Name
• Location ID
• Middle Name
• NickName
• Rate Class
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• Social Security Number
• Social Security Number-MASKED
• Supervisor Code
• Type of Employment
• Union Code

Federal Taxes

• Federal Additional Withholding
• Federal Filing Status
• Federal Withholding Exemptions
• Federal Withholding YTD
• Federal Withholding Pay Run
• FICA Withholding YTD
• FICA Medicare Withholding YTD
• FICA Medicare Withholding Pay Run
• FICA Social Security Withholding YTD
• FICA Social Security Withholding Pay Run
• Total FICA Tax Withheld
• Uncollected FICA Med Tax Pay Run
• Uncollected FICA SS Tax Pay Run
• Employer ID Number

Hours

• Days Worked YTD
• Double Time Hours
• Holiday Hours
• Hours Worked YTD
• Overtime Hours
• Regular Hours
• Sick Time Available
• Sick Time Hours
• Time Available Array
• Time Code Array
• Time Code Description Array
• Total Hours
• Vacation Available
• Vacation Hours
• Weeks Worked YTD
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• Work Hours Per Year

Local Taxes

• Local Tax Array
• Local Tax Description
• Local Tax Withholding Array
• Local Tax YTD
• Local Withholding YTD

Pay Data

• Pay Code Array
• Pay Code Description
• Pay Earnings Array
• Pay Hours Array
• Pay Hours Array-Blank for Salary
• Pay Rate Array
• Pay Rate Array-Blank for Salary
• Pay YTD Array
• Total YTD Pay Code Earnings

Pay Stub Information

• End Pay Period
• Federal Wages Pay Run
• Gross Wages YTD
• Gross Wages Pay Run
• Net Wages YTD
• Payment Adjustment Number
• Start Pay Period
• Total Taxes
• Total Taxes YTD
• User ID

State Taxes

• Additional Allowances
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• State Additional Withholding
• State Filing Status
• State Name
• State Number of Dependents
• State Tax Array
• State Tax Withholding Array
• State Tax YTD
• State Withholding YTD

Tips

• Allocated Tips YTD
• Charged Receipts YTD
• Charged Tips YTD
• Federal Tax On Tips YTD
• Federal Tips YTD
• FICA Med Tax On Tips YTD
• FICA Med Tips YTD
• FICA SS Tax On Tips YTD
• FICA SS Tips YTD
• Reported Receipts YTD
• Reported Tips YTD
• Uncollected FICA Med Tax YTD
• Uncollected FICA SS Tax YTD

Canadian Payroll

Detailed Addresses

• Bank Address 1
• Bank Address 2
• Bank Address 3
• Bank City-State-Zip
• Bank Country
• City
• Company Address 1
• Company Address 2
• Company Address 3
• Company City-State-Zip
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• Company Country
• Country
• Employee Address 1
• Employee Address 2
• Employee City-Province-Postal Code
• First Name
• Last Name
• Middle Name
• Phone
• Postal Code
• Province

Detailed Advice

• Income Pay Code
• Income Description
• Income Rate
• Income Units
• Income Current $
• Income YTD Units
• Income YTD Dollars

Employee

• Address
• Birth Date
• City
• Class ID
• Country
• Department
• Employee ID
• First Name
• Full Name
• Last Name
• Middle Name
• Phone
• Position
• Postal Code
• Province
• SIN
• Start Date
• Taxable Province
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• User Defined 1
• User Defined 2
• User ID

Payment Details

• Deduction Description
• Deduction Employee Share
• Deduction Employer Share
• Deduction Paycode
• Deduction Rate
• Deduction Taxable Benefit Amount
• Deduction Units
• Earnings Amount
• Earnings Dept
• Earnings Description
• Earnings Paycode
• Earnings Rate
• Earnings Transaction Date
• Earnings Units

Summary Advice

• Income Pay Code
• Income Description
• Income Rate
• Income Units
• Income Current $
• Income YTD Units
• Income YTD Dollars
• Benefit Pay Code
• Benefit Description
• Benefit Rate
• Benefit Units
• Benefit Current $
• Benefit YTD Units
• Benefit YTD Dollars
• Deduction Pay Code
• Deduction Description
• Deduction Rate
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• Deduction Units
• Deduction Current $
• Deduction YTD Units
• Deduction YTD Dollars

Payment Summary

• Accumulated Days
• Accumulated Overtime Hours
• Accumulated Regular Hours
• Accumulated User1
• Accumulated User2
• Accumulated User3
• Accumulated User4
• Advance Amount Drawn
• Advance Amount Reclaim
• Arrears Amount Created
• Arrears Amount Reclaim
• Batch Number
• Bonus Income
• Cheque Amount with ***
• Cheque Date
• Cheque Date-D1
• Cheque Date-D2
• Cheque Date-M1
• Cheque Date-M2
• Cheque Date-Y1
• Cheque Date-Y2
• Cheque Date-Y3
• Cheque Date-Y4
• Cheque Number
• End Date
• Net Pay
• Net Pay Words
• Net Pay Words Numbers
• Overtime Income
• Payment Method
• Regular Income
• Retroactive Income
• Start Date
• Total Withholdings
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Vacation

• Accrual Amount
• Accrual Units
• Accrual Unpaid Units
• Accruing Amount
• Accruing Available After Date
• Accruing Units
• Accruing Unpaid Units
• Available Amount
• Available Payout After Date
• Available Units
• Available Unpaid Units
• Opening Balance
• YTD Accrued Vacation

YTD Tax Return

• Basic Personal Amount – AB
• Basic Personal Amount – BC
• Basic Personal Amount – Federal
• Basic Personal Amount – MB
• Basic Personal Amount – NB
• Basic Personal Amount – NL
• Basic Personal Amount – NS
• Basic Personal Amount – NT
• Basic Personal Amount – NU
• Basic Personal Amount – ON
• Basic Personal Amount – PE
• Basic Personal Amount – SK
• Basic Personal Amount – YT
• CPP Deducted 16
• CPP Pensionable 26
• EI Deducted 18
• EI Insurable 24
• Employment Income 14
• Income Tax Deducted 22
• Quebec TP-1015.3-V Base
• Registered Pension 20
• Taxable Benefits
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• Taxable Income

Last modified: Oct 29, 2019
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5.3.3.2. Add Elements to Check Formats
Our existing check formats can be customized by adding elements using the Mekorma Configurator. Fields
can be added to any of our check formats, and can be easily placed or re-located with the Configurator’s
drag-and-drop interface.

1. Open the the Checkbook Setup window and use the look-up to select a Checkbook ID.

2. Select the module for which you want to configure a check stub: Purchasing, US Payroll or
Canadian Payroll

3. Be sure a primary check format is selected, then click on the Primary Check Format hyperlink. This
will open the Configurator to display the selected format.

4. Click the button Add Elements to open the Add Elements window. The available elements will differ
depending on which module you are working with.

5. Expand any of the the listed categories by clicking on the + sign. This will display available fields
within each category.
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6. Choose the desired field to add to your check stub.

7. Click Add Elements.

8. The field will automatically be placed at the top-left of the format. You can change the field’s location
as desired by dragging and dropping it, or by adjusting its location according to its place on the X and
Y axis.

Last modified: Nov 19, 2019
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5.3.3.3. Configure Refund Check Formats

Last modified: Aug 05, 2019
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5.3.3.4. MEM Connector: Payables Check
Formats
Depending on which version of Multi-Entity Management is set up for your organization, you will find the
facility fields in either the MEM Decentralized Payables category, or the MEM Centralized Payables
category.

The following fields are provided for placement on the stub layout and can be added using the Mekorma
Configurator:

Centralized Payables

• Facility ID, Facility Name, and Facility Company Name are multi-line fields (to print on each
voucher line).

• Internet User Defined 1 and Internet User Defined 2 are single-line fields in both Centralized and
Decentralized categories.

The MEM Connector must be enabled in order to print MEM fields on checks and stubs.!
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Decentralized Payables

• Facility ID, Facility Name, and Facility Company Name are single-line fields (to print in the header).
• Internet User Defined 1 and Internet User Defined 2 are single-line fields in both Centralized and

Decentralized categories.
• Facility Address is a multi-line field which contains one line each for Address 1, 2, and 3 (if they are

populated) and a final line containing city, state, and zip code. This field is only available for
Decentralized Payables.

Setup options for payables Sorting and Subtotals can be configured.

Last modified: Oct 07, 2019

Please note, MEM Connector fields will not be displayed on a test check. You must print an
actual check in order to test.

!
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5.3.3.5. MEM Connector: Payroll Check
Formats
The following fields are provided for placement on the stub layout and can be added using the Mekorma
Configurator:

These fields are available when the Checkbook Security window is set to the US Payroll module, and the
Configurator is opened to display a Payroll check format.

• Facility Name: The description field in the GL Segment Description Setup table where the Segment
Number = 1 and the Segment ID is the Facility ID.

• Facility Stub String: A concatenated field consisting of the Facility ID, Division Code (from the
Employee Master table), and the Employee ID. This field is separated by hyphens.

• Facility Check String: A concatenated field consisting of the Facility ID, Division Code (from the
Employee Master table), Employee ID, and Employee Class ID. This field is separated by hyphens.

• Facility Address: A multi-line field that will contain the street address, city, state, and zip code for the

All payroll checkbooks should be set up with the same stub layout file. Only one layout is
used when printing payroll checks.

!

Mekorma Mekorma Products User Guide - Build x78

Page 81 of 288



facility.
• Internet User Defined 1: From the Company Internet Information window.
• Internet User Defined 2: From the Company Internet Information window.

Last modified: Oct 07, 2019

The MEM Connector must be enabled in order to print MEM fields on checks and stubs.!
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5.4. Grant Security Access to Mekorma
Alternate Windows
Mekorma Payment Hub uses alternate Microsoft Dynamics GP windows for printing payables transaction
checks, payables batch checks and US payroll checks. Security must be granted to these alternate windows
for each user printing checks.

Before setting up security roles and tasks, you must change the default security setting for the alternate
windows from Microsoft Dynamics GP to Mekorma.

To grant security to alternate windows, complete the following steps:

1. Log on to Microsoft Dynamics GP as a system administrator.

2. Open the Alternate/Modified Forms and Reports window.

3. Select an Alternate/Modified Forms and Reports ID and enter the following values in the fields:

• Product: Mekorma MICR
• Type: Windows

4. In the Alternate /Modified Forms and Reports List, open the folders (by clicking the + sign) and verify
that Mekorma MICR is selected.

You must grant access to the standard Dynamics GP window before access can be granted
to the alternate version of the window. Alternate windows will not appear in the access list
until security has been granted.

!

To access the Alternate/ Modified Forms window, go to the Microsoft Dynamics GP drop-
down menu > Tools > Setup > System > Alternate/Modified Forms and Reports*
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5. Repeat Step 3 for each user ID you wish to grant access to.

Last modified: Aug 05, 2019
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5.5. Import Signatures to the Signature
Library
Before it can be used in your company’s security settings, each signature image file must be imported into
the Signature Library. You must have all signatures needed for your security saved in a digital format. Files
can be the following formats: .bmp, .gif, .jpg and .png

Signatures can be imported in the manner described here for use with either security model – Legacy or
Task-Based.

1. Choose Import on the Mekorma MICR Signature Library window

2. Browse to select the signature image file you wish to use on your checks and click Open.

To access the Signature Library, go to the Mekorma Area Page > Setup > Company >
Signature Library*
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3. Repeat steps 1 – 2 in each company for each image to be used in that company

Last modified: Dec 16, 2019

Please note, if you are using the Task-Based security model, signatures can be imported
while assigning signatures to users.

!
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5.6. Configure Security Model
Once you’ve determined which security model you will be using, you must select the appropriate choice in
the Security Setup window.

Select Security Model in the Security Setup Window

1. Open the Security Setup window.

2. Double-click on the company you would like to configure. This will expand the list of options.

3. Select Task-Based Security or Legacy Security by clicking on the corresponding radio button.

For first-time installation of Mekorma build x76 or later, Task-Based Security will be set as
the default. Existing Mekorma customers will inherit their Legacy settings upon upgrade to
build x76 or later.

!

To access the Security Setup Window, go to the Mekorma Area Page > Setup > System >
Security Setup*
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• If Legacy Security is selected, clicking on the Legacy Security hyperlink will open the security
configuration window, allowing you to set Passwords by User ID, Checkbook or Standard GP Security
(‘None’).

• If Task-Based Security is chosen, clicking on the Task-Based Security hyperlink will take you to the
Threshold Maintenance window, where you can configure the Threshold IDs that will later be applied
to checkbooks.

4. Click Save. When switching security models, you must log out of Dynamics GP, then log back in for
the changes to take effect.

Please note, if Task-Based Security is selected for all listed GP companies, and you want to
switch to Legacy, click Options and then choose Enable Legacy Security Selection from
the drop-down.
*
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Last modified: Nov 22, 2019
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5.6.1. Task-Based Security
This video will guide you through the steps necessary to fully set up approval workflow, authorization and
signature logic using the Task-Based Security model:

Follow these steps to set up Task-Based Security:

1. Choose Task-Based Security in the Security Setup window

2. Assign Mekorma Security Roles and Tasks

3. Assign Signature Files to Users

4. Approvers / Authorizers / Requestors set up their email/ text notifications

5. Set up Threshold IDs. The way a Threshold ID is configured will define whether secure approval
workflow, batch authorization, or signature logic only is applied to the payment process.

6. Assign Threshold IDs to checkbooks

Last modified: Dec 12, 2019
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5.6.1.1. Assign Mekorma Security Tasks/
Roles
Task-Based Security utilizes Dynamics GP System Security. Administrators must assign users the ability to
authorize and/ or approve payments by adding the appropriate Security Roles and Task IDs to an
individual’s GP User Security settings.

For your convenience, Mekorma has created six security Role IDs that are tied by default to their
corresponding Task IDs. You are not required to use the Mekorma Security Roles/ Task IDs, but it creates
one less step if you choose to do so. Otherwise, you must also assign the Task ID you will be using for
security setup to a Security Role, which then is assigned to an Approver / Authorizer.

Mekorma Approver Roles Level 1 – 5

Mekorma Batch Authorizer Role

Please note, the PowerUser Role is not sufficient to designate a GP User as an Approver/
Authorizer; PowerUsers must also be assigned a Mekorma Security Role in order to perform
those functions.

!
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Mekorma Approver Task Level 1 – 5

Mekorma Batch Authorizer Task

1. Open the GP User Security window
2. Choose the User, the appropriate company (Fabrikam), and the correct Role ID to ensure that the

user is able to perform the corresponding security task.
3. The associated Task IDs can be used to configure the desired authorization or approval workflow.

Last modified: Aug 05, 2019

To assign the Roles, access the GP User Security window by following this path: GP
Administration module > Setup > System > User Security*
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5.6.1.2. Assign Signature Files to Users
In Task-Based security, before using signatures to set up Threshold IDs, an administrator must first assign
signature files to individual users. Be sure that all needed signatures are in a digital format and stored in an
accessible folder.

1. Log in as ‘sa.’

2. Navigate to the Signature Assignment window.

3. Click on the User Name for which you’d like to assign a signature.

4. Use the lookup to find the correct signature file.

• If the file has already been imported into the system, simply choose the file to complete the
assignment.

• To import a new signature file, click ‘New’ from within the Mekorma Signature Files Lookup window.
This will open the Signature Library, and you can then import the correct signature file.

• Return to the Signature Assignment window and associate the User Name with the newly imported
signature.

Last modified: Aug 05, 2019

To access the Signature Assignment window, go to the Mekorma Area Page > Setup >
System > Signature Assignment*

A User can confirm that a signature file has been assigned to their User ID within the
Mekorma User Preferences window. Signature files cannot be added or removed from this
window by the User. Only Administrators can perform this function in the manner described
on this page.

*

To remove a signature assignment, click on the User Name and select the ‘X’. This will not
remove the signature file from the Signature Library, but does remove the association with
the User Name.

!
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5.6.1.3. Email/ Text Notifications
Users assigned to Approver or Authorizer security roles can set up email and text notifications for optimal
workflow within the Mekorma Preferences window:

Set Up Email and Text Notifications

1. Login and navigate to the Mekorma User Preferences window (any GP User can do this).

2. Enter a valid email address in the E-mail Address field.

3. Enter a valid text number in the Text Number field.

• The number must be in the following format: phonenumber@provider.xxx. Please check with your
mobile provider to verify the correct format for sending texts via email or computer. (ex.
1234567899@vtext.com)

4. Select the type of notification needed

• Check the box Request Notification for Approval if you want to be notified that your approval or
authorization has been requested.

• Checking the box Notify me after others Approve/Authorize will ensure that if you are the second
Approver for a threshold level, you will be notified after the first Approver has approved the
transaction.

To access the Mekorma User Preferences window, go to the Microsoft Dynamics GP drop-
down > User Preferences > Additional > Mekorma User Preferences*
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Last modified: Dec 18, 2020
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5.6.1.4. Out-of-Office Feature Set Up
If an Approver or Authorizer needs to delegate another GP user to take over their duties for a period of time,
they can do so in the Mekorma User Preferences window. The delegate must have access to the Mekorma
Navigation lists.

1. Login and navigate to the Mekorma User Preferences window (any GP User can do this).

1. Open the Mekorma User Preferences window.

2. Check the box Enable Out-of-Office Re-Route of Approval.

3. Choose the date range for which you would like the Delegate to approve or authorize on your behalf.

4. Use the look-up to select the desired Delegate. All GP users will be listed, but you must choose a
User with access to the Mekorma Approval or Batch Status List so they are able to approve or
authorize transactions.

To access the Mekorma User Preferences window, go to the Microsoft Dynamics GP drop-
down > User Preferences > Additional > Mekorma User Preferences*

Mekorma Mekorma Products User Guide - Build x78

Page 96 of 288

https://www.youtube.com/embed/H4BY4Wl8hGg?rel=0&start=114&end=240
https://www.youtube.com/embed/H4BY4Wl8hGg?rel=0&start=114&end=240


5. Click OK on the GP User Preferences window and the delegation will go into effect.

Last modified: Dec 12, 2019

Please note, if the Delegate wishes to be notified that their approval is needed during the
specified time period, they must set up email notifications in their own Mekorma User
Preferences window.

!
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5.6.1.5. Signatures with Approval Workflow
Once you have chosen Task-Based Security in the Security Setup window, and assigned Security Roles
and Tasks to the desired Approvers, one or more Threshold IDs must be created and then assigned to a
checkbook – this will enable a secure workflow process.

Watch the video below for an example of two Threshold IDs that enable secure approval workflow with
signatures:

A Threshold ID allows you to save a series of threshold ranges, associated with User Task IDs and default
signatures in the way that works best for your company. Threshold IDs are stored at the system-level, and
can be assigned to checkbooks for cross-company use. Threshold IDs hold the logic that enables secure
approval workflow to be applied to payment processes.

Example of a Threshold ID that enables secure approval workflow:

1. Enter a name that identifies your configuration in the Threshold ID field (ex. AP_APPROVAL). Adding
a description is *optional.

2. Tab off the Threshold ID name. The From and To amount fields automatically populate from 0.01 to
the maximum dollar amount.

To access the Mekorma Threshold Maintenance window, go to the Mekorma Area page >
Setup > System > Threshold Maintenance*
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3. Create the first threshold by typing the upper limit in the To field. In the example below, the first
threshold range is $0.01 – $500.00.

4. It is possible to choose none, one, or two Approvers for each threshold range. Use the look-up to
select the correct Approver Task ID.

5. Continue to tab to the Default User Signature 1 field and use the look-up to choose the desired
signature file for checks printed within that threshold range. This will open the Mekorma Signatures
Files Lookup window.
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If you want a signature line to be printed in addition to or instead of a signature file, check the
Signature Line box.

a. There are two ways to add a signature: Signature assigned to a User ID, or a signature file that
has been imported to the signature library but is not associated with a User ID.

Signature Assigned to a User ID
In the User ID view, select a signature assigned to a User ID.
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Signature File Only
To change the view to Signature Files, click the dropdown and select Signatures.

Now you can select a signature file from the signature library that is not associated with a User
ID.
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6. When tabbing to the next line, the threshold will automatically readjust to the next possible monetary
increment, so that there is never a dollar amount left out of your security configuration. In our
example, for the second threshold, one Approver is needed along with her signature and a signature
line. Karen is assigned as a Mekorma Approver Level 1 and her appropriate Task ID was chosen
using the look-up:

7. By tabbing to the next line in the window, the final threshold range is configured. This threshold goes
up to the maximum amount. Mekorma Approver Level 2 is assigned by using the look-up; Ryan’s
signature has been selected to print on checks within this final range; and, an additional signature line
will printed for a handwritten signature by checking the Signature Line box only for Default User
Signature 2.
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Last modified: Dec 29, 2020

Please note, a Threshold ID must be applied to a specific checkbook in order for the
workflow and signature settings to take effect.

!
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5.6.1.6. Signatures with Batch Authorization
Once you have chosen Task-Based Security in the Security Setup window, and assigned Security Roles
and Tasks to the desired Authorizers, a Threshold ID must be created to enable Authorizers to authorize
batches when requested.

Watch the video below for an example of a Threshold ID that enables authorization with signatures:

Before configuring your Authorization Threshold ID, you must assign the number of Authorizers (up to two)
and the Authorization Task ID within the Security Setup window.

1. Click on any of the text in the box below, as they become hyperlinks when hovered over and will
expand the window:

2. In the expanded window area, decide which module(s) will need authorization assigned –
Purchasing, Payroll, and/ or Financial (Miscellaneous Checks). Use the drop-down menu to choose

Please note, this is only necessary for configuring batch authorization. These fields can
remain blank when configuring secure approval workflow*
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the Number of Authorizers, and the look-up to define the appropriate Authorization Task ID. You
can use the designated Mekorma Batch Authorizer Task ID designed for this purpose, as long as the
corresponding Security Role has been assigned to the authorized users:

3. Save these settings.

4. Create a Threshold ID.

Example of a Threshold ID that enables batch authorization:

A Threshold ID allows you to save a series of threshold ranges, associated with default signatures, in the
way that works best for your company. Threshold IDs are stored at the system-level, and can be assigned to
checkbooks for cross-company use. Threshold IDs hold the logic that enables batch authorization to be
applied to payment processes, and must be assigned to a checkbook in order to take effect.

1. Enter a name that identifies your configuration in the Threshold ID field (ex. AP_AUTHORIZATION).
Adding a description is *optional.

2. Tab off the Threshold ID name. The From and To amount fields automatically populate from 0.01 to
the maximum dollar amount.

3. Select Enable Signatures Only for this Threshold. This will disable the Approver Task ID fields,

To access the Threshold ID window, go to the Mekorma Area page > Setup > System >
Threshold ID Maintenance*
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essentially disabling workflow.

4. Create the first threshold for your signature logic by typing the upper limit in the To field on the first
line.

5. Tab to the Default User Signature 1 field and use the look-up to choose the desired signature file for
checks printed within that threshold range. If you want a signature line to be printed in addition to or
instead of a signature file, check the Signature Line box.

6. When tabbing to the next line, the threshold will automatically readjust to the next possible monetary
increment, so that there is never a dollar amount left out of your security configuration. In our
example, for the second and final threshold, a different signature file will print on checks printed within
this higher threshold range.
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5.6.1.7. Configure Signature Logic Only
It is possible to configure your settings so that signature logic only is applied to your check printing. This
includes the ability to print blank lines for hand written signatures.

1. Make sure all necessary signature files have been imported to the Signature Library, and that
signatures have been assigned to the appropriate User IDs.

2. Choose Task-Based Security in the Security Setup window.

3. Open the Threshold Maintenance window and type in the desired name in the Threshold ID field.
Tab off to create the new Threshold ID.

4. Check the box next to Enable Signatures Only for This Threshold ID. This will disable workflow and
ensure that the assigned signatures print according to the configured logic.

5. To add a signature, use the look-up in the Default User/Signature 1 field. This will open the
Mekorma Signatures Files Lookup window.

To access the Mekorma Threshold Maintenance window, go to the Mekorma Area page >
Setup > System > Threshold Maintenance*
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a. There are two ways to add a signature: Signature assigned to a User ID, or a signature file that
has been imported to the signature library but is not associated with a User ID.

Signature Assigned to a User ID
In the User ID view, select a signature assigned to a User ID.

Signature File Only
To change the view to Signature Files, click the dropdown and select Signatures.
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Now you can select a signature file from the signature library that is not associated with a User
ID.

6. If you want two signatures to print, perform the same action in the Default User/Signature 2 field.
This will again open the Mekorma Signatures Files Lookup window.

7. Assign the Threshold ID to the checkbook to which you would like to apply these signatures.

Last modified: Dec 29, 2020
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5.6.1.8. Apply a Threshold ID to a Checkbook
The final step in setting up Task-Based security is to assign Threshold IDs to the checkbooks from which
you will be paying. You can assign different Threshold IDs to the Payables, US Payroll and Canadian
Payroll modules from within the Checkbook Setup window.

1. Open the Mekorma MICR Checkbook Setup window.

2. Choose the checkbook to which you want to assign a Threshold ID by clicking on the lookup.

3. Use the look-up menu to select the desired Default Threshold ID. To review details of the selected
Threshold ID, click on the Information button to the right of the look-up:

To access the Checkbook Setup window, go to the Mekorma Area Page > Setup >
Purchasing > Mekorma MICR Checkbook Setup*
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4. If you want a different Threshold ID to apply to one or more of the individual modules (Purchasing, US
Payroll, Canadian Payroll), use the drop-down menu to select that module:
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5. Choose the Threshold ID you want to assign using the look-up. This will over-ride the Default
Threshold assigned above.
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6. Be sure to assign all checkbooks with a Threshold ID in order for Mekorma security to take effect.

Last modified: Aug 05, 2019
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5.6.1.9. Vendor Class Security
The Vendor Class Security feature provides the flexibility to customize Mekorma’s security settings on a per
Vendor Class basis. This feature is supported under Mekorma Legacy Security by Checkbook ID and User
ID, as well as Task-Based secure approval workflow.

The rules configured for vendor security override the basic security model that you have setup.

• Vendor Classes are set up in Dynamics GP.
• Mekorma task-based security has been configured.
• You have set up one or more Threshold IDs that define the workflow(s) to be applied to each vendor

class. Please remember that the Threshold ID must be assigned to a checkbook in order to take
effect.

1. Open the Mekorma Vendor Class Security Setup window. Each of your existing vendor classes will be
displayed.

2. Click to the right of a vendor class to which you want to apply security rules, in the column marked
Threshold ID.

3. Click the look-up next to Threshold ID to open the Threshold ID look-up window. Choose the
Threshold ID that defines the correct security rules.

4. Click OK to close the window.

Before setting up Vendor Class Security, please make sure of the following:!

To open the Mekorma Vendor Class Security Setup window, go to the Mekorma Area Page
> Setup > Company > Vendor Class Security*
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5.6.1.10. Enable EFT/ Direct Deposit Security
The same security settings that are applied to your MICR check printing process can be enabled for EFT
and Direct Deposit processing.

1. Open the Mekorma Security Setup window.

2. Make sure the Task-Based Security radio button is selected.

3. Check the box next to EFT Security (Purchasing) and/or Direct Deposit Security (Payroll).

4. Click Save.

Last modified: Oct 08, 2019

To open the Mekorma Security Setup window, go to the Mekorma Area Page > Setup >
System > Security Setup.*
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5.6.1.11. Disable Print Blank Checks
If you would like to to hide the Print Blank Checks menu command on the Mekorma MICR Payables, US
Payroll and Canadian Payroll menus, the Print Blank Checks Menu Option can be disabled.

1. Open the Mekorma Security Setup window.

2. With the Task-Based Security radio button selected, check the box next to Disable ‘Print Blank
Checks’ Menu Option.

3. This will deny users access to Print Blank Checks from the Purchasing menu.

Last modified: Oct 14, 2019

To open the Mekorma Security Setup window, go to the Mekorma Area Page > Setup >
System > Security Setup*
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5.6.2. Legacy Security
Legacy Security allows you to configure security by User ID, which includes the Payables Approval
Workflow, or by Checkbook ID. You can also configure ONLY signatures using this model.

Setting Up Signatures/Approvals by User ID

Security by Checkbook ID

Signatures Only with Standard GP Security
Last modified: Sep 25, 2019
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5.6.2.1. Setup Signatures/ Approvals by User
ID
To set up signatures and approvals by User ID, please complete the following steps:

Add Users and Signatures

1. Open the Security Maintenance window.

2. Add a user by clicking Add/Modify User and entering the appropriate information in the User
Signature Entry window. Users that are not approving the batches but are part of the workflow
should be added with a zero Max. Authorized Amount and no signature.

To access the Security Maintenance Window, go to the Mekorma Area Page > Setup >
Company > Security Maintenance*
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3. Add a signature to the user. You can also import a signature.

Email/ Text Notifications for Approvers

1. In the User Signature Entry window, enter the user’s email address in the field provided.

2. If the user would like to receive approval email notifications on their cell phone, enter the applicable
cell phone number and SMS information (EX: 8886356762VERIZON) in the Text Phone Number
field.

Setting Up Password and Signature Rules

1. Back on the Mekorma MICR Security Setup window, choose the number of passwords you want by
clicking on the When to Require Passwords drop-down. When the workflow is activated, the
passwords become Approvers.

2. Choose the number of signatures you want by clicking on the When to Print Signatures drop-down.

Last modified: Oct 15, 2019

The Max. Authorized Amount is not the tied to the Password/Signature Threshold field
and is only used to control the users’ maximum payment approval amount.*
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5.6.2.1.1. Assign a Signature to a User ID

1. Open the Security Maintenance window.

2. Use the Add/ Modify User button to add the Dynamics GP User who will be signing checks.

3. Use the look-up to select the desired User ID.

4. Use the lookup to select a Signature Image ID from the Signature Library and save the record. If the
user’s signature file is not listed as an option, please import the correct signature file into the
Signature Library.

5. Repeat for each user that will sign checks in that company.

See screen action only here (no sound):

Default Signatures

The Default Signature feature on the Mekorma Security Maintenance window allows you to assign up to two
signature that will print on every payment regardless of the user that approves the batch. Go to Additional
> Default Signatures.

To access the Security Maintenance window (for use with Legacy Security options), go to
the Mekorma Area page > Setup > Company > Security Maintenance*
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1. Click the Lookup icon and select a signature from the Signature Library.
2. Save your changes.

Using Default Signatures with Standard GP Security
Last modified: Oct 15, 2019
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5.6.2.1.2. Activate Secure Approval Workflow
Mekorma Payables Secure Approval Workflow allows users to review and approve payment batches (EFTs /
Checks). Email notifications and Navigation lists replace the password prompts.

Users receive emails that a batch requires approval and can then review and approve the batch using the
Mekorma Navigation lists on the Purchasing pane in GP. The Payables Approval Workflow uses the email
functionality that is configured for Microsoft Dynamics GP. It does not require a separate email configuration
or client.

Please note, Secure Approval Workflow is only supported for the Payables module in GP and for payment
batches (not for single payments created using the Payables Transaction Entry window).

1. Open the Mekorma MICR Security Setup window.

2. Mark the Activate Workflow checkbox within the Payables Approval Workflow area.

3. Highlight the User ID in the list on the lower left pane and then check the box next to the Checkbook
ID that you want the user to approve or request payments for.

To access the Mekorma MICR Security Setup window, go to the Mekorma Area page >
Setup > Company > Security Maintenance. Please note this window is only available if
Legacy Security is selected within the Security Setup window.
*
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4. If you are using thresholds, mark the Split Batches box to automatically split payments batches into
groups by number of Approvers and signatures.

5. Check Second Approval Notifications to receive emails notifications if you are a second approver
and the Batch Completed Notification to receive an email when the batch has been approved.

Last modified: Oct 13, 2019
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5.6.2.2. Security by Checkbook ID

To Configure Security by Checkbook:

1. On the Mekorma MICR Security screen, select the Checkbook option under the ‘Set Security By’
section.

2. Click the lookup next to the Signature ID hyperlink and then click ‘New’ to display the Mekorma MICR
Password and Signature Setup screen.

3. Enter a Signature ID and a Description if desired.

4. If you are using dollar amount thresholds enter a Lower Threshold amount and if desired, a Higher
Threshold amount. Thresholds can be used to determine when signatures and signature lines should
print and when passwords are required. Please see Using Thresholds When Printing for more
information on thresholds.

5. Leave the Sort Checks in Threshold Groups when printing option unchecked if you would like the
checks to print in check number order instead of being sorted by threshold groups.

6. Determine when you want the signatures to print for the Signature 1 and/or Signature 2 fields. You
can print signatures Always, Never, or based on the threshold dollar amounts.

7. Enter the path to each signature image file in the File Location field.

8. Determine when you want the signatures lines to print for the Signature Line 1 and/or Signature Line 2
fields. These are the lines upon which the signature is printed or manually signed. You can print
signature lines Always, Never, or based on thresholds.

9. If you will require passwords, enter them in the Password 1 and/or Password 2 fields. You may
require one, two or no passwords. You can set up a password to be required Always, Never, or based
on thresholds. Click Save when you are finished configuring your Signature ID.

To open the Mekorma MICR Security Setup window, be sure you have chosen Legacy
Security in the Security Setup window. Then go the the Mekorma Area page > Setup >
Company > Security Maintenance
*

In addition to setting up a Signature ID, the logical signature fields must be present on the
.stbx format. You will find in the .stbx formats in our format library we have included all of
these logical fields.
*
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Checkbook Security and Using Thresholds
When you print checks in threshold groups, you get a stack of checks with checks above the higher
threshold sorted to the top of the stack, checks between the thresholds to the middle of the stack and
checks below the lower threshold to the bottom of the stack.

If you want to print using threshold groups, check the Sort Checks in Threshold Groups when printing
option. This is useful when manually signing higher dollar checks. Some important conditions to note when
printing in threshold groups and using signatures and passwords:

• When you select the Amount Below (the lower or higher) Threshold option for Signatures,
Signature Lines and Passwords the exact amount of the threshold value is considered part of the
threshold.

• When you select the Amount Above (the lower or higher) Threshold option for Signatures,
Signature Lines and Passwords any amount greater than the threshold value is considered part of the
threshold.

• When you select the Amount Between Thresholds option for Signatures, Signature Lines, and
Passwords, any amount greater than the lower threshold and less than or equal to the higher
threshold is considered part of the threshold.

• When the Sort Check in Threshold Groups when printing option is checked, the program always
looks for an amount greater than the value of threshold. For example, if the higher threshold is $1000,
all checks with a value of $1001 are sorted to the top.

• When printing a batch of invoices, if only one invoice requires a password, you must enter the correct
password in order to print all the invoices.

Last modified: Aug 05, 2019
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5.6.2.3. Signatures Only with Standard GP
Security
When using the Legacy Security model, it is possible to set up very simple signature logic, allowing you to
automatically print signatures on checks without configuring passwords or workflow.

The setup steps described below will apply the same signature logic to every checkbook within a company.
If you have more than one checkbook and want different signatures applied to different checkbooks, please
use Legacy Checkbook Security, or this method.

1. Open the Mekorma MICR Security Setup window.

2. Choose None in the Set Passwords By area.

3. Select when signatures should print: Always One Signature or Always Two Signatures. You will not
be configuring thresholds so the additional options do not apply.

4. Click Additional > Default Signatures to open the Mekorma Default Signatures window.
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5. Use the Look-up to choose one or two Default Signatures, corresponding with your choice in Step 3.
If the signatures files are not in the Mekorma MICR Signature Files Lookup window, follow these
steps.

Last modified: Aug 05, 2019

This method of configuring signature logic only offers limited possibilities. We recommend
switching to Task-Based Security model and configuring signature logic by creating a
Threshold ID.

!
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5.6.2.4. Vendor Class Security
The Vendor Class Security feature provides the flexibility to customize Mekorma’s security settings on a per
Vendor Class basis. This feature is supported under Mekorma Legacy Security by Checkbook ID and User
ID.

The rules configured for vendor security override the basic security model that you have setup. For
example, if security is set to Checkbook ID, Vendor Class Security settings override the checkbook’s
Signature ID settings.

Vendor Class Security configured with Legacy User ID

1. Open the Mekorma MICR Vendor Class Security Setup window. Each of your existing vendor classes
will be displayed.

2. The Default Security option is taken from the current configuration on the Mekorma MICR Security
screen for User ID security. To select a different security configuration, click the drop-down arrows
next to When to Require Passwords and When to Require Signatures.

3. To set a threshold value, enter an amount in the Payables Threshold column. For example:

Before setting up Vendor Class Security, please make sure you have setup Vendor Classes
within Dynamics GP, and that your Mekorma Security settings have been configured.

!

To open the Mekorma MICR Vendor Class Security Setup window, go to the Mekorma Area
Page > Setup > Company > Vendor Class Security*
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Vendor Class Security configured with Legacy Checkbook ID
If you are using Security by Checkbook ID, the Vendor Class Security settings only influence what
signatures print, and not what passwords are required. Password settings are always pulled from the
Signature ID associated with the checkbook.

1. Open the Mekorma MICR Vendor Class Security Setup window. Each of your existing Vendor Class
IDs will be displayed.

2. Click in the Signature ID column next to the Class ID you want to associate the signature logic with.
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3. Click the lookup icon next to the Signature ID link to open the Signature Setup Lookup screen.

4. Select an existing Signature ID or click New to create a new ID.

5. The Signature ID is now associated with the Class ID. Click OK to close the Mekorma MICR Vendor
Class Security Setup screen.

6. The Signature ID security configuration is applied to all vendors associated with the specified Class
ID.

Last modified: Nov 04, 2019
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5.6.2.5. Enable EFT/ Direct Deposit Security
The same security settings that are applied to your MICR check printing process can be enabled for EFT
and Direct Deposit processing.

1. Open the Security Maintenance window.

2. In the Additional Security Options area, check the box next to EFT Security and/ or DD Security.

3. Click Save.

Last modified: Oct 08, 2019

To open the Mekorma Security Maintanance window, go to the Mekorma Area page > Setup
> Company > Security Maintenance. Please note this window is only available if you have
chosen Legacy Security within the Mekorma Security Setup window.
*
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5.6.2.6. Disable Print Blank Checks
If you would like to to hide the Print Blank Checks menu command on the Mekorma MICR Payables, US
Payroll and Canadian Payroll menus, the Print Blank Checks Menu Option can be disabled.

1. Open the Mekorma MICR Security Setup window.

2. Under Additional Security Options, check the box next to Disable ‘Print Blank Checks’ Menu
Option.

3. This will deny users access to Print Blank Checks from the Purchasing menu.

Last modified: Oct 14, 2019

To open the Mekorma MICR Security Setup window, go to the Mekorma Area Page > Setup
> Company > Security Maintenance*
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5.7. Setup for EFT Processing with Mekorma
This section will demonstrate how to set up your GP system to process EFTs using Mekorma. You must be
sure your checkbook(s) are already configured for EFT processing in Dynamics GP, which is essential for
the MICR process to go smoothly.

Follow these steps:

1. Specify Check or Remit Numbers.

2. Configure email settings for sending remittances.

3. Choose EFT remittance options in the Checkbook Maintenance window.

4. Enable EFT Comments for check formats.

5. Add EFT logos to remittances.

6. Set up for multi-batch EFT processing.

Last modified: Oct 15, 2019
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5.7.1. Specify Check or Remit Numbers
If you want to use check numbers instead of the EFT numbering sequence with Mekorma, that option must
be configured in Dynamics GP.

1. Open the Checkbook Maintenance window.

2. Select a Checkbook ID.

3. Click the EFT Bank option to open the Checkbook EFT Bank Maintenance window.

4. Select the Payables Options button to open the Checkbook EFT Payables Options window.

To open the Checkbook Maintenance window, go to the Mekorma Area Page > Cards >
Financial > Checkbook*
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5. Select an EFT Payment Number option based on the following:

Use Check Numbers

• When using blank check stock, EFTs will print with check numbers as non-negotiable checks using
Mekorma MICR and as reports based on the EFT Remittance Option selected.

• If using pre-printed check stock, EFTs will print in the same way. However, be advised that you must
select Microsoft Dynamics GP Report Writer as the EFT Remittance option.

Use EFT Numbers

• When using blank check stock, EFTs will print with remittance numbers as non-negotiable checks
using Mekorma MICR or reports based on the EFT Remittance Option selected.

• When using pre-printed check stock, EFTs will print in the same way. We recommend using regular
paper when printing EFT remittances.
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6. Click OK when you are finished and close any open windows.

Last modified: Oct 11, 2019

If your checkbook is configured for EFT and you print check copies to PDF, the check
copies will use EFT numbers for the naming convention instead of check numbers.*
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5.7.2. Configure Email Settings
Email settings must be configured within Dynamics GP to ensure that vendors will receive EFT remittances.

1. In the GP Company Email Setup window, check the box labeled PDF, otherwise Mekorma cannot
generate EFT files.

2. Create a Remittance Message ID in your GP Email Settings. The EFT file is attached to this
message when sent.
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3. For each vendor who accepts EFT payments, enter the appropriate email address so the system
knows where to send your EFT remittances. Go to the Vendor Address Maintenance window >
Internet Information window:

Last modified: Oct 11, 2019

Mekorma Mekorma Products User Guide - Build x78

Page 140 of 288



5.7.3. Choose EFT Remittance Options
In order to email EFT remittances to vendors, you must choose an appropriate remittance format.

1. Open the Checkbook Setup window.

2. Select the checkbook you would like to use for your EFT payments by clicking on the lookup to the
right of Checkbook ID. Mekorma allows you to process both checks and EFTs using the same
checkbook, but the formats are handled differently.

3. Using the drop-down, choose one of the options found in the EFT Remittance Options field.

• Dynamics GP Report Writer: This option only allows you to use GP’s Word templates. Do NOT
choose this option if you’d like access to Mekorma’s full library of PDF formats for your EFTs.

• Check Face/Overflow Stub: If selected, the Overflow format you have configured will be chosen first.
If you do not have an Overflow Format selected, the Primary Check format will be used instead.

• EFT Remittance Format allows you to choose from any of Mekorma’s formats by using the look-up
next to the EFT Remittance Format field.

To open the Checkbook Setup window, go to the Mekorma Area Page > Setup >
Purchasing > Checkbook Setup*
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EFT Remittance Format

Any Mekorma MICR format used to generate EFTs will differ from check formats in the following ways:

• The MICR line will not appear.
• The signature lines will not have any signatures. Instead, logical fields EFT non-negotiable and EFT

Void will print.
• EFT non-negotiable will print instead of a check value amount.

Last modified: Oct 09, 2019

Please note: In newer GP builds, you cannot process EFTs using Mekorma AND choose
the Print Separate Remittances for Overflows feature in GP for the same checkbook.
This feature requires that GP Report Writer be selected for the EFT Remittance Option.

!
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5.7.4. Enable EFT Comments for Check
Formats
The EFT Comment field prints a comment if the format is being used for an EFT transaction. EFT comments
configurations are stored on a per-checkbook basis.

1. Open the Checkbook Setup window.

2. Use the look-up to select a Checkbook ID.

3. Open the Additional menu > Additional Features.

4. In the Additional Features window, check the box for EFT comment to activate EFT comments.

5. Click the blue arrow that appears when you check the box. This will open the Mekorma MICR
Additional Features Options window.

6. Type in content that you would like to populate the EFT comment fields for the checkbook that you’ve
selected. When the EFT comment field is added to a layout in the Configurator, the information saved
here will be used to populate that field upon printing.

To open the Checkbook Setup window, go to the Mekorma Area Page > Setup >
Purchasing > Checkbook Setup*
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7. Click OK to save.

Last modified: Oct 11, 2019
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5.7.5. Add EFT Logos to Remittances
The EFT Logo field allows users to insert a logo onto a check stub. EFT logo configurations are stored by
checkbook.

1. Open the Checkbook Setup window.

2. Follow the steps to enable EFT comments.

3. Within the Mekorma MICR Additional Features Options window, click on the blue arrow next to the
EFT Logo File field.

4. Navigate to the location where the desired logo is stored, and select the logo. When the EFT logo
field is added to a layout in the Configurator, the information saved here will be used to populate that
field upon printing.

5. Click OK to save.

Last modified: Oct 11, 2019

To open the Checkbook Setup window, go to the Mekorma Area Page > Setup >
Purchasing > Checkbook Setup*
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5.7.6. EFTs with Multi-Batch Management
All previous set up steps for processing EFTs with Mekorma must be in place. This page addresses settings
that are specific to processing EFTs (ACH) with Multi-Batch Management.

Choose Automation Options

1. Open the Multi-Batch Management Options window.

2. Choose options in the EFT & Safepay section:

EFT Remittance Options

• Print Document: The remittance will be sent to the printer specified by Named Printers configuration.
• Send Document in Email: The vendor will receive an email containing the remittance after – if for

some reason internet access is not available, the remittance will print instead of being emailed.

Posting Options

• Post EFT immediately after Print or Send: This option ensure that EFTs are posted immediately
after printing or emailing remittances.

• Generate EFT after Posting: This option automatically generates the EFT file (to be sent to your
bank) immediately after posting.

With both these options checked, EFTs become a simple three-step process:

1. Create EFT payments using the Build Payments action
2. Generate and send EFT remittances, post the EFT batch and create the EFT file for your bank, all

with the Process Checks and EFTs action.
3. Transmit your EFT file to your bank.

You cannot use GP Report Writer when processing EFTs with MMM. The settings for EFT
Remittance options (as configured in the Mekorma Checkbook Setup window) must be set
to Check Face/ Overflow Stub or a Mekorma EFT Remittance Format.

!

To open the Multi-Batch Management Options window, go to the Mekorma Area Page >
Transactions > Payables > Multi-Batch Management Action Board > Options*
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You may choose not to post the EFTs automatically and / or not generate the EFT file for the bank
automatically for any of these reasons:

• You want to combine more than one batch from the same checkbook in the same company into a
single ACH file.

• Your organization has a separation of duties that requires different users to post EFTs and send them
to the bank.

• You need to change the Transmission Date or Settlement Date in the ACH file. By default, the
transmission date will be set to the GP user date.

If you do not mark Post EFTs Immediately after Print or Send option, you will post the EFT Remittances
along with your checks using the Post action on the Action Board.

If you do not mark Generate EFT File after Post, you will generate your EFT file using the Generate EFT
File action on the Action Board.

Last modified: Nov 26, 2019
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5.8. Multi-Batch Management Setup
Multi-Batch Management (MMM) allows Mekorma users to build and process payment batches, for multiple
companies and checkbooks, using one centralized action board. There are a number of setup options that
allow you to automate the payment process in various ways. You can choose which processes are
automated, and which are manually performed within the Action Board.

The video will guide you through the complete process of setting up MMM for optimal performance:

Please review the following pages for complete instructions on how to set up Multi-Batch Management:

1. Test/ Enable MMM

2. Configure Printing and Posting Reports

3. Results Reports Email Setup

4. Options for Building Multiple Batches

5. Set Up EFT Options for Multi-Batch Processing

6. How to Create a Build ID

7. How to Create a Process ID

8. Check Sorting Options

9. Show/ Hide Dynamics GP windows during processing

Last modified: Nov 13, 2019
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5.8.1. Test and Enable Multi-Batch Processing

Test Multi-Batch Management (MMM)

If you would like to try Multi-Batch Management before ordering, you can do so by designating one or more
companies as an MMM test company.

1. Open the Multi-Batch Management Setup window.

2. Mark the box in the column labeled Test Company.

3. Click OK.

Enable/ Disable MMM per company

Once you have purchased MMM and have valid registration keys, you can choose to enable or exclude a
company from using Multi-Batch Management.

1. Open the Multi-Batch Management Setup window.

To open the Multi-Batch Management Setup window, go to the Mekorma Area Page > Setup
> System > Multi-Batch Management Setup*

When testing MMM in this way, MICR checks will come out without a MICR line or
signatures; EFT files will be in a test format that is not usable by the bank. If you would like
to try MMM in your production environment, you can contact Mekorma Sales to receive
30-day temporary keys, allowing you to run your payment processes for free, for 30 days.

*
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2. To enable a company to use MMM, mark the box in the column labeled Enable for MMM for that
company. Unmark the box to disable.

3. Click OK.

Last modified: Nov 22, 2019
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5.8.2. Configure Printing and Posting Reports
There are certain setting that need to be in place to ensure that Multi-Batch Management’s automated
processes are not interrupted. Therefore, the following requirements must be met in order for MMM to
perform as intended:

Configure Named Printers

Automating the printer selection will ensure that checks and EFT remittances can print without interrupting
the process – set up Named Printers.

Define Paths for Reports/ Lists

Posting Reports and edit lists should be set up so they can be generated without interfering with Multi-Batch
Managements automated processes.

1. Open the Posting Setup window.

2. Use the drop-down to set the Series as Purchasing.

3. Use the drop-down to set the Origin as Computer Checks.

4. For each report that you want to generate, assign it to a file and not to a query, monitor or to a
printer by checking the box in the file column and unchecking the other boxes in the Send To column.

To open GP’s Posting Setup window, go to Administration > Setup > Posting > Posting*
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5. You can assign a destination for each individual posting journal type as needed. Click on the Path
field directly underneath a particular posting journal, then on the folder icon under Append/Replace.

6. Choose the file where you would like this posting journal to be sent. The file path will display:

In standard functioning, if you posted multiple checkbooks in the same company it would
overwrite your posting journal each time. However, MMM will capture the path name and
insert this phrase: (Checkbook id _ YYMMDD_HHMMSS_) between the names of the folder
and the file in order to create a unique name. The Posting setup is done on a per company
basis in Dynamics GP. Therefore you can setup each company to point to its own path if
you want to separate your posting journals on a per company basis.

*
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5.8.3. Results Reports Email Setup
After batches are built in the Multi-Batch Management Action Board, a Build Results Report is generated.

After processing checks and EFTs in the Action Board, an MMM Print Process Results Report is
generated.

After posting checks and EFTs in the Action Board, a Posting Results Report is generated.

By default, these reports are created/ displayed immediately after the corresponding process had
completed. You can choose to send them to a chosen email address instead. For example, it can be very
useful to send the MMM Build Results Report to Approvers if you are using Mekorma’s Secure Approval
workflow. That way, a single report is sent rather than having them notified with every batch that is built.

Configure Email Settings for Results Reports

1. Open the Multi-Batch Options window.

2. In the All Actions section, check the box next to Email Report After Processing.

3. Enter the correct email address in the Email Address field.

To open the Multi-Batch Options window, go to the Mekorma Area Page > Setup > System
> Multi-Batch Management Setup > Options*
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4. Click Save.

Last modified: Nov 12, 2019
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5.8.4. Options for Building Multiple Batches
When building payment batches using Mekorma Multi-Batch Management (MMM), you can configure
settings in the one of three ways.

1. Open the Multi-Batch Options window.

2. Within the Build Payment Batches area, choose one of these options:

• No Edit Lists or Approvals: This will disable edit lists and approval requests entirely.
• Request Approvals: This will automatically send approval requests during the process.
• Print Edit Lists

◦ If you generate Edit Lists, you can print them or send them to a folder:
▪ Printer: send to a printer
▪ File: Saved as a text, tab-delimited, comma-delimited or HTML file type and stored in a

file location of your choosing. MMM will give them unique file names to help you identify
them.

To open the Multi-Batch Options window, go to the Mekorma Area Page > Setup > System
> Multi-Batch Management Setup > Options*
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Create uniquely numbered batches

A suffix can be added to your batch numbers, either per company or at the system level. The suffix ensures
that batches from within different companies are numbered uniquely when batch numbers are assigned
during the build process.

To open the Multi-Batch Management Setup window, go to the Mekorma Area Page > Setup
> System > Multi-Batch Management Setup*
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1. Open the Multi-Batch Management Setup window.

2. Add the desired suffix in the column labeled Batch No. Suffix for every company you want to
differentiate. In our example, Fabrikam’s batch suffix was set to 100, Balanced Business is 200, and
Complete Solutions is 500.

3. After running a batch-building process in the Action Board, the appropriate suffix is added to the end
of each batch number according to the suffix assignment. The suffix increases by one increment for
each batch:

4. The Batch No. Suffix can be changed at any time within the MMM Setup window.

5. Click OK.

Last modified: Nov 08, 2019
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5.8.5. Create a Build ID
A Build ID allows you to save your payment voucher selection criteria so you don’t have to recreate it each
time you build payment batches.

To save the build criteria, Multi-Batch Management uses a window based on Dynamics GP’s Build Payment
Batch window. However, there are a few differences, as the selection criteria entered in the Build
Maintenance window will be saved so it can be applied repeatedly to different checkbooks, across
companies, over time.

1. Open the Build Maintenance window.

2. Type in the name and description (optional) of your new Build.

3. Select build criteria using the drop-down menu. Multiple selections can be inserted:

• Vendor ID
• Vendor Name
• Class ID
• Payment Priority
• Voucher Number
• Document Number
• Payment Number
• Due Date / Discount Date Cutoff
• Document Currency

4. Use the look-up to define the parameters of chosen criteria.

5. Click Insert to add selected criteria.

6. Save your Build ID. This set of criteria can now be added to a Process ID to automate the batch
building process.

Last modified: Nov 12, 2019

To access the Build Maintenance window, go to the Mekorma Area Page > Setup > System
> Multi-Batch Management Build Maintenance*
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5.8.6. Create a Process ID
A Process ID allows you to save build criteria for multiple companies and checkbooks. When a Process ID is
run in the Action Board, batches are built according to all the build parameters you have saved within that
ID.

Basic

To create a Process ID that will be used to generate batches in a single company with one checkbook,
proceed as follows:

1. Open the Multi-Batch Management Process Maintenance window.

2. To create a new Process ID, type the desired name in the Process ID field. Or, use the look-up to
bring up an existing Process ID for editing.

3. Using the look-up next to each corresponding field, choose a company, a checkbook, and a Build ID
that contains the desired build criteria.

4. Choose the payment types you would like to include by checking the boxes next to Checks and/ or
EFTs.

5. Press Insert.

To open the Multi-Batch Management Process Maintenance window, go to the Mekorma
Area Page > Setup > System > Multi-Batch Management Process Maintenance*
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6. Save after adding desired criteria.

Advanced

If you want to create a Process ID that applies multiple Build IDs to multiple companies and checkbooks,
using the Advanced option is an efficient way to do so.

1. Open the Multi-Batch Management Process Maintenance window.

2. Click on Advanced in the top menu bar.
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3. To create a new Process ID, type the desired name in the Process ID field. Or, use the look-up to
bring up an existing Process ID for editing.

4. When the Checkbooks radio button is selected, all available companies and their associated
checkbooks will be listed. Use control + click shortcut to select all companies/ checkbooks to which
you want to apply a particular Build ID.

5. Click on the Checks and/ or EFTs button, depending on which payments types you want to include.
This will add the information to the Linked Checkbooks and Build IDs section on the right-hand side
of the window. The applied Build ID will be listed as DEFAULT.

6. Again using the control + click shortcut, choose all checkbooks to which you want to apply a particular
Build ID, the choose the desired Build ID to apply it to those checkbooks:
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7. Repeat this process until the Process ID contains all checkbooks, payment types and Build IDs you
want to include.

8. Save and close the window.

Last modified: Nov 12, 2019

See how a Process ID can be run in the Action Board to build batches in one or more
companies/ checkbooks.*
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5.8.7. Check Sorting Options
You can choose how to sort your checks during the multi-batch printing process. The following options are
available:

1. Open the Multi-Batch Options window.

2. Use the drop-down next to the Sort Checks By field to choose from the following options:

• Payment Number
• Name
• State – City
• ZIP Code
• Voucher Number
• Company Default: This will defer to the default value from the Payables Management Setup window.

To open the Multi-Batch Options window, go to the Mekorma Area Page > Transactions >
Payables > Multi-Batch Management Action Board > Options*
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3. Click Save.

Last modified: Nov 12, 2019
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5.8.8. Show/ Hide Dynamics GP Windows
While Multi-Batch Management is processing, you will always see each company login window as the
system changes through companies. You can choose to show or hide the other GP windows according to
your preference.

1. Open the Multi-Batch Options window.

2. In the All Actions > User Interface Automation Control section, check the box next to Show Dynamics
GP windows if you would like to view all windows as the system processes. If not, unmark the box.

3. Click Save.

Last modified: Nov 12, 2019

To open the Multi-Batch Options window, go to the Mekorma Area Page > Transactions >
Payables > Multi-Batch Management Action Board > Options*
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5.9. Electronic Payment Processing
If you have qualified to use Mekorma Enhanced Electronic Payments, your Dynamics GP system will need
to be configured with the assistance of your Project Manager. For more information on Enhanced
Electronic Payments and how to qualify, please email Mekorma Sales.

Watch the video below for a brief overview of the steps you will be guided through for optimal electronic
payments processing:

After having upgraded to Mekorma Build x78 or later, and installing the MEEP Utility file, your Project
Manager will continue the ePayment set up in the following way:

Run the Configuration Wizard
To activate an approved company for ePayment processing, the Enhanced ePayment configuration wizard
must be run. The wizard will import the company’s sub-domain name, encryption key, Checkbook ID, Bank
Account ID and the administrator’s email address from the Mekorma web service. The wizard will guide you
through the rest of the required configuration:

Step 1
• Choose whether you would like the ePayment service to print your vendor’s checks (off-site), or print

them locally (on-premise).

Step 2
• Create a MEEP Vendor ID account that represents the credit card company that issues the virtual

credit cards (this field will default to MEEP Vendor by default). If the vendor does not exist, it will be
automatically created. If you select an existing vendor, check the box labeled Exists.

• Associate the MEEP Vendor with an Accounts Payable GL account by using the look-up. This field
is only available when creating a new vendor.

Step 3
• Choose the Card Name to be used for ePayments. This field will default to MEEP Card. If the card

does not exist in GP, it will be automatically created. Or choose an existing credit card using the look-
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up, and mark the box labeled Exists.

Step 4
• Select an Integration Base folder. This folder will store all files sent and received between your

company and the ePayment system. It will need to be accessible to all computers processing
ePayments. Mekorma recommends a network folder for this reason. The system will automatically
create the following subfolders within the base folder:

◦ OutVendors: This folder contains vendor files sent from Dynamics GP to the ePayment service.
◦ InVendors: This folder contains vendor update files received from the ePayment service.
◦ OutPayments: This folder contains payment files sent from Dynamics GP to the ePayment

service.
◦ InPayments: This folder contains processed payment (response) files received from the

ePayment service.
◦ AchFiles: This folder contains ACH files received from the ePayment service.

Step 5
• Click Process to export the Vendor Master file so that all necessary vendor information is sent to the

system for accurate payment processing. Vendors that have been excluded will NOT be sent to the
ePayment service.

After the configuration wizard has been run successfully, ePayment settings can be managed from within
the Enhanced ePayment Configuration window.

Last modified: Nov 22, 2019
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5.9.1. Add a Checkbook for ePayment
Processing
After the Enhanced ePayment Configuration Wizard has been run, additional checkbooks can be added for
ePayment processing. This is a two-step process, as additional checkbooks must be added in the Enhanced
ePayment portal, then within the ePayment Configuration window in Dynamics GP.

Step 1: Add the new checkbook in the ePayment Portal
1. The ePayment administrator must first log in to the ePayment portal. Portal access was granted

during the initial implementation of Enhanced Electronic Payments, and the administrator should have
created login credentials.

2. From the Home page, go to Master Data > Bank Accounts.

3. Click + to create a new bank account:

4. Fill out all required fields. Mekorma recommends that the you make the Bank Name in the ePayment
portal the same name as the Checkbook ID in Dynamics GP:
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5. Click Create to save the new account.

Step 2: Add the Checkbook in the Enhanced ePayment
Configuration window

6. Log in to Dynamics GP and open the Enhanced ePayment Configuration window.

7. Click on the next available line in in the checkbook fields at the bottom of the window. Use the look-up
to choose the Checkbook ID of the checkbook you want to add. This will pull in the GP account
description and bank account number.

8. Match the GP checkbook with the correct account in the ePayment portal by using the drop-down
menu under the Remote Bank Account column. From that point on, the checkbook can be used to
pay vendors remotely via check or EFT.

To open the Enhanced ePayment Configuration window, navigate to the Mekorma Area
Page > Setup > Purchasing > Enhanced ePayment Configuration.*
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Last modified: Nov 21, 2019

To enable the use of the checkbook for virtual card payments, you will need to have
complete the necessary paperwork to get the account set up properly. Upon approval the
Bank ID will be enabled for Vcard payments, processed using either the pre-funded or the
credit model.

*
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5.9.2. Manage Vendor Status

If you are an Enhanced Electronic Payments customer, the status of your vendors’ enrollment can be
viewed in the Vendor Enrollment Inquiry window. Filters can be applied that include or exclude vendors of
a particular status. You can also view according to Vendor ID, Vendor Name, Check Name or Enrollment
Date:

To open the Vendor Enrollment Inquiry window, navigate to the Mekorma Area Page >
Inquiry > Enhanced ePayment Enrollment Status*
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Enrollment Status

There are three possible Enrollment Status for your GP vendors:

• Pending: This vendor’s information will be sent to the ePayment system either overnight, or next time
the Send Vendor Master button is clicked. Until that time payments to this vendor are processed
locally using GP or MICR functionality.

• Excluded: This vendor’s information is not sent to the ePayment service, and payments to this vendor
are processed locally.

• Enrolled: This vendor’s information is sent to the ePayment system, and their payments are
processed by whatever payment type is listed in the processing type column.

Processing Type

There are four possible processing types for your GP vendors:

• Check: The ePayment service processes payments to this vendor by printing and mailing checks.

• EFT: The ePayment service processes payments to this vendor as EFT payments.

• VCARD: The ePayment service processes payments to this vendor by issuing virtual credit cards via
email.

• Local: Payments to this vendor are processed locally. However, if enrolled, this vendor’s information
is sent to the ePayment service. The service will work on your behalf to convert the vendor to accept
virtual credit cards.

How to Change Vendor Status
A vendor’s status can also be viewed and even changed within the Vendor Maintenance window. Depending
on the current status, you can apply one of the following changes to the vendor status:

• From Enrolled Check/ EFT/ Vcard to Excluded or Local Processing.
• From Excluded to Enrolled or Local Processing.
• From Local Payment Processing to Enrolled or Excluded.

Please note that while the transition to Excluded or Local Processing is immediate, the transition to Enrolled
is only effective after the most up-to-date vendor information has been sent to the ePayment system, and a
status update has been received by Dynamics GP. Until the updates have been transmitted, the Vendor’s
status will be listed as Pending Enrollment.
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1. Select a Vendor ID using the look-up.

2. Click on Additional > Enhanced ePayment Status to open the Enhanced ePayment Status window.
In this example, Allenson is currently enrolled as a vendor that accepts checks printed off-site.

3. Use the drop-down menu in the Enhanced ePayment Status window to change to the desired status.
In this case, the vendor can be switched to Excluded or Local Processing.

Vendor Status Change Shortcut

Please note, this same task can be accomplished with a shortcut:

1. Right-click anywhere within the Vendor Maintenance window, once your Vendor ID has been selected.

To open the Vendor Maintenance window, navigate to the Mekorma Area Page > Cards >
Payables > Vendor*
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2. The vendor’s current status will be displayed. Click on the arrow to the right of the status to display
other options.

3. Choose the desired status.

Any changes in Vendor Status get updated every day so that the Vendor Master file in Dynamics GP and in
the ePayment system are in sync.

Last modified: Nov 21, 2019
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5.9.3. Vendor Master File Management
As part of the Enhanced Electronic Payments service, we will contact your vendors to convert them to some
form of electronic payment type (virtual credit card or EFT).

On a daily basis, according to the schedule configured during installation of the MEEP utility file, the Vendor
Master file within Dynamics GP will automatically synchronize with the Enhanced Electronic Payments
system. As vendors change payment types in response to our outreach, or if you have made changes to a
vendor’s status within GP, the Vendor Master file will be updated accordingly.

You can always send an updated Vendor Master prior to the scheduled update:

1. Open the Enhanced ePayment Configuration window.

2. Click the Send Vendor Master button.

To open the Enhanced ePayment Configuration window, go to the Mekorma Area Page >
Setup > Purchasing > Enhanced ePayment Configuration*

Mekorma recommends manually updating the outgoing and incoming vendor information
before processing electronic payments. Follow this link for instructions.

!
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This lists all the information that is communicated between Dynamics GP and the ePayment system:

Vendor Records Address Records

Vendor ID Vendor ID

Vendor Name (Check Name) Address ID

GP Status Address Lines 1 to 3

Is 1099 State/Province

Payment Terms ID Postal Code

Main Address ID Country

Remit-to Address ID Contact Name

Class ID Phone Number

Tax ID Number Email-to Address

Email-cc Address

Payment Method (0:Check, 1:EFT)

Check Name

Bank Account Name

Bank Account Number

Bank Routing Number

Bank Account Type (CHECKING or SAVINGS)

Last modified: Nov 21, 2019
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5.10. MEM Connector Setup
MEM stands for Multi-Entity Management®, a product written for Dynamics GP by Binary Stream Software.
This product allows organizations to manage multiple legal entities (companies) in one single database. The
facility is assigned as payables transactions are entered or batches created.

What does the MEM Connector do?

The MEM connector provides an interface between MEM and Mekorma so that facility information can be
printed on payables checks. The software uses SQL scripts to access Binary Stream tables to retrieve the
necessary information.

Depending on which version of Multi-Entity Management is set up for your company, you will find the facility
(entity) fields for payables in either the MEM Centralized category, or the MEM Decentralized category.
Payroll can only use the Decentralized category.

MEM Centralized: A Centralized process uses one checkbook to pay multiple entities. Transactions for
multiple entities can appear on one payables check. In this case, the Facility Name or ID will be printed on
each voucher line. Facility Address is generally not used in this setup. For correct alignment of columns on
the check stub if using subtotals, the connector provides common voucher line fields which must be used
with the Facility ID or Name when creating the stub layout.

MEM Decentralized: A Decentralized process uses multiple checkbooks to pay multiple entities. Only one
facility is reported per check. The Facility Name, ID and Address will be printed in the header area of the
check or stub.

Please note: Binary Stream has changed the process for entering and storing a legal name for entities when
using MEM for Payables in Decentralized mode. The Facility Company Name should now be retrieved from
the BSSIEntityLegalName column of table B3900400 starting from the MEM version listed in the table
below.That is, entity description will be printed with entity legal name.

A1 GP Version MEM Version

2013 N/A N/A

2015 14.00.1079 506s11 (and later)

2016 16.00.0404 601s05 (and later)

2018 All Builds All Builds

All prior versions should use the former process, which retrieves the entity name from the GL Segment table
(GL40200).

Last modified: Sep 25, 2019
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5.10.1. Enable MEM Connector for Individual
Checkbooks
The MEM Connector must be enabled on a per checkbook basis for both Payables and US Payroll. This will
enable the MEM integration buttons to display on the necessary windows.

Payables

1. Open The Mekorma MICR Checkbook Setup window.

2. Choose the checkbook you want to be used with the MEM Connector.

3. Click on Additional > Additional Features.

4. Check the box next to MEM Connector for Payables.

5. Click Save to close the window.

6. Repeat these steps for any additional checkbooks you would like to configure.

Payroll

To open the Mekorma MICR Checkbook Setup window, go to the Mekorma Area Page >
Setup > Purchasing > Checkbook Setup*

To open the Mekorma MICR Checkbook Setup window, go to the Mekorma Area Page >
Setup > Payroll > Checkbook Setup*
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1. Open The Mekorma MICR Checkbook Setup window.

2. Choose the checkbook you want to be used with the MEM Connector.

3. Click on Additional > Additional Features.

4. Check the box next to MEM Connector for Payroll.

5. Click Save to close the window.

6. Repeat these steps for any additional checkbooks you would like to configure.

Last modified: Sep 26, 2019

No passwords are allowed for payroll checkbooks when MEM is installed with Mekorma. If
you have Legacy User ID or Checkbook ID security configured, you must turn off
passwords. Signature can be applied.

!
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5.10.2. MEM Connector for Payables
The Mekorma MICR MEM Payables Connector module integrates with Binary Stream’s Multi-Entity
Management® product to provide access to facility (entity) information for vouchers printed on Mekorma
MICR check stubs. The MEM Connector for Payables requires a separate registration key.

There are two setup options available for the MEM Connector: Sorting and Subtotals.

Facility Check Sorting Options

Sorting options are available for both Centralized and Decentralized. For Centralized, checks are sorted by
the Facility ID or Name of the first voucher on the check. For Decentralized, checks print in Facility ID or
Name order.

1. Open the MEM Connector for Payables Setup window.

2. Select an option in the first section to define Facility Check Sorting:

• No Facility Sorting

To open the MEM Connector for Payables Setup window, go to Microsoft Dynamics GP >
Tools > Setup > Purchasing > Mekorma MEM for Connector for Payables Setup*

Please note, to populate the setup tables, this window must be opened and the OK Button
clicked even if no options are selected.

!
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◦ The Decentralized category is used to print the Facility ID or Facility Name and Address on the
header.

• Sort by Facility ID
◦ For MEM Centralized, the Centralized category is used to print vouchers on the stub in Facility

ID order and checks in Facility ID order.
◦ For MEM Decentralized, checks print in Facility ID order.

• Sort by Facility Name
◦ For MEM Centralized, this option uses the Centralized category to print vouchers on the stub in

Facility Name order and checks in Facility Name order.
◦ For MEM Decentralized, checks are printed in Facility ID order.

3. Click Save to save your changes.

Facility Check Stub Subtotal Options

This option is available for Centralized only. Vouchers are grouped and subtotaled on the stub by Facility ID
or Facility Name. If this option is selected, all fields on the voucher line must be from the MEM Centralized
category or they will not align properly.

1. Open the MEM Connector for Payables Setup window.

2. Select an option in the second section to define Facility Check Stub Subtotal Options:

• No Facility Subtotals
◦ Uses Centralized category to print vouchers on the stub with no subtotal line

• Subtotal by Facility ID
◦ Sorts and groups vouchers by facility ID and prints a subtotal line after each group.

• Subtotal by Facility Name
◦ Sorts and groups vouchers by facility name and prints a subtotal line after each group.

See here for a detailed list of how sorting and subtotal options effect the printing results.

Last modified: Sep 26, 2019

For correct alignment of columns on the stub when using the subtotal options, all normal
voucher line fields should be replaced with fields from the MEM Centralized Payables
category of the Configurator.
*
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5.10.3. MEM Connector for Payroll
When Binary Stream’s Multi-Entity Management is installed, each employee is assigned to a facility, and
each facility is assigned to a payroll checkbook. When payroll is processed, multiple checkbooks may be
accessed.

Check numbers are assigned according to the checkbook associated with the employee’s facility. The MEM
Connector for Payroll requires separate registration keys.

The MEM Connector for US Payroll provides the following custom sort order for payroll checks:

• Facility ID
• Division Code
• Class ID
• Last Name of Employee
• First Name of Employee

Setting Up Facility Signature IDs

In standard MICR payroll processing when security is by checkbook, a default Signature ID is assigned for
all payroll checks. With the MEM Connector for Decentralized Payroll, a Signature ID needs to be defined
for each payroll checkbook. This setup is used to determine which signatures print on the checks and when
the signatures should be printed.

1. Open the Mekorma MICR Password and Signature Setup window.

2. Enter information to define a Signature ID for each payroll checkbook. Please note, the Signature ID
must match the payroll Checkbook ID.

Signature 1 and Signature 2 will print in the Facility Signature 1 and Facility Signature 2 fields on the
check layout. Detailed instructions for defining Signature ID’s can be found in the Signatures & Passwords
by Checkbook section.

Setting Up Payroll Signature IDs

In standard MICR payroll processing when security is by checkbook, a default Signature ID is assigned for
all payroll checks. With the MEM Connector for Decentralized Payroll, a Signature ID needs to be defined
for each payroll checkbook. This setup is used to determine which signatures print on the checks and when

To open the Mekorma MICR Password and Signature Setup window, go to Microsoft
Dynamics GP > Tools > Setup > Payroll > Mekorma MICR US Payroll > Facility Signature
ID
*
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the signatures should be printed.

1. Open the Mekorma MICR Security Setup window. This configuration applies to security by
Checkbook, so be sure that the Checkbook radio button is marked in the Set Passwords By section.

2. Click on the Checkbook ID to which you want to assign a Signature ID.

3. Click the look-up next to Payroll Signature ID.

4. Choose the desired Signature ID.

5. Repeat for all payroll checkbooks.

Last modified: Sep 25, 2019
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5.11. Dynamics GP Web Client
As of Mekorma Build x70, Mekorma products are compatible with the Dynamics GP web client. You can
easily print payments from a browser of your choice, although Mekorma recommends using Google Chrome.

When doing so, you will have access to all Mekorma features with a few exceptions. The following actions
cannot be done in the web client and must be performed on a Microsoft Dynamics GP desktop client:

• Edit Mekorma check formats within the Configurator.
• Import or edit signature files, check formats and company logo files.

Before printing payments using the Dynamics GP web client, be sure you have completed the following
installation and configuration tasks:

1. Install the Mekorma Print Client.
2. Configure your browser settings.
3. Grant appropriate users security access to the Web Client.

Last modified: Oct 11, 2019
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5.11.1. Browser Settings
In order to print checks using Mekorma on the Dynamics GP Web Client, there are a few browser settings
that will make the process run more smoothly.

Settings for .mcp (Mekorma Check Print) Downloads

1. Open Google Chrome and type in the following URL: chrome://settings.

2. Scroll and open Advanced.

3. Scroll to Downloads. Choose the folder location path where the encrypted Mekorma Check Print file
(.mcp) will be written at print time.

4. Turn off Ask where to save each file before downloading.

To prevent further browser dialogs when using Chrome

1. Print a Mekorma MICR test check in Web Client. You will see an .mcp file type in the lower left of the
browser.

Mekorma recommends Google Chrome, as Chrome allows you to bypass manually opening
the .mcp (Mekorma Check Print) file at print time. If you are using any other browser, you
will have to choose to open the Mekorma Print Client by selecting to open the .mcp file each
time it is generated.

*

This feature is available with all major browsers. Please consult your browser
documentation for specific steps to enable this feature.*
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2. Click the down-arrow and mark Always open files of this type. When printing a test check for the
first time, you will additionally need to click on the .mcp file to manually launch the Mekorma MICR
Print Client.

Last modified: Oct 11, 2019
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5.11.2. Web Client Security
Once your browser settings are configured, you are ready to provide Web Client print access to your
Accounts Payable users as needed.

1. Log in to Dynamics GP as a System Administrator or Power User.

2. Open the Web Client Security Access window.

3. Designate the ability to print over the GP web client by marking the box next to a User’s name.

Last modified: Oct 11, 2019

To open the Web Client Security Access window, go to the Mekorma Area page > Setup >
System > Web Client Security Access*
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5.12. Enable Split Batches
The Split Batch feature enables transactions within a workflow process to be split, according to the
threshold level and approval requirements of that threshold. If transactions within a certain threshold range
do not need to be approved, those transactions can be placed into their own batch to continue through the
workflow. Transactions of greater amounts that do require approvals are put in another batch and then go
through the configured approval process.

The Split Batch feature prevents entire batches from being held up when only some of the transactions
require approvals.

How to Enable Split Batches with the Task-Based Security Model

When Task-Based Security is configured, you can split payables batches based on the threshold levels
designated in the applied Threshold ID.

1. Go to the Mekorma Security Setup window.
2. Under the Task-Based Security radio button selection, check the box next to Split Batches.

To access the Mekorma Security Setup window, go to the Mekorma Area page >
Setup > System > Security Setup.*
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How to Enable Split Batches with the Legacy Security Model

When Legacy Security is configured, you can split payables batches based on the option selected in the
When to Require Passwords field under User ID security.

1. Go the the Security Maintenance window.
2. Be sure you have chosen to Set Passwords By: User ID
3. In the Payables Approval Workflow fields, check the box next to Activate Workflow. Split Batches will

automatically be enabled. If you want workflow without the split batch feature enabled, simply uncheck
the box next to Split Batches.

Please note, with Legacy Security the split batch feature is enabled automatically when you
choose to activate workflow. See below for instructions on how to enable/ disable.

!

To access the Security Maintenance window, go to the Mekorma Area page >
Setup > Company > Security Maintenance. This window is only used to configure Legacy
security options.
*
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5.13. Enable Assign by Checkbook Feature
You can assign Payables invoices, POP Shipment/Invoices and POP invoices to checkbooks using the
Assign by Checkbook option available from the Additional menu on transaction entry screens.

The feature must be enabled to take effect.

1. Open the Mekorma MICR System Options window.

2. In the Assign by Checkbooks Options section, mark the box next to Enable Assign by
Checkbook.

Enable Default Checkbooks for Users

There is an optional setup feature for Assign by checkbook that allows default checkbooks to be assigned
on a per-user basis. This is useful if you have different users designated for each checkbook.

To open the Mekorma MICR System Options, go to the Mekorma Area Page > Setup >
System > System Options*
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Please note: the default checkbook for the user will override the default checkbook assigned to a batch.

1. Open the Mekorma Assign by Checkbook window.

2. Click into the Default ID field for a user.

3. Use the look-up to select the appropriate checkbook.

4. Repeat this step for all users needing default checkbook assignments.

5. Click OK to save.

Once this feature is enabled, you can select your vouchers based on checkbook assignments during the
batch building process.

Last modified: Dec 09, 2019

To open the Mekorma Assign by Checkbook window, go to the Mekorma Area Page >
Setup > Purchasing > Mekorma Assign by Checkbook window*
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5.14. Test Check Layout and Security
Printing test checks help you verify the correctness of your check layouts and confirm the approver,
password and signature options you have configured. Print the test checks from the same workstation and
printer you will be using for live checks.

Differences in printers and operating systems can lead to size and placement variations on the printed page.
The Test Check Layout is used for primary check regions, stubs, and overflow stubs. Use the MICR Gauge
to confirm the placement of the MICR line.

1. Select a Check Type from the drop-down list (Payables, US Payroll or Canadian Payroll).

2. Use the lookup on the Checkbook ID field to select a checkbook you have set up for Mekorma MICR
check printing.

3. In the Check Amount field, enter the amount to print in the currency fields on the check. You can
enter different amounts to test your password and signature logic.

4. In the Number of Vouchers field, enter the number of remittance lines to print on the stub. For
example, if you want to see a stub that is paying five invoices, enter “5”. If you are using an overflow
format, enter a number large enough to force the stub information to overflow to the next page.

To access the Test Check Layout and Security feature, go to the Mekorma Area Page >
Setup > Purchasing > Test Layout and Security*
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5. Click Print. If you are using the Legacy security model, and User IDs and/or Passwords are required
for the checkbook and check amount, you will see the Check Password screen.

6. Enter the User ID and Password and click OK.

7. If the applicable approver(s) has access to the checkbook, is authorized for the check amount, and
the correct password is entered, the Mekorma MICR Check Printing window will open.

8. On the Mekorma MICR Check Printing screen, confirm that the Check Printer is the printer you will
be using for checks. If not, select the check printer from the drop-down list of printers.

9. Click Print to send the check to the printer and review the check layout.
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Please note, MEM Connector fields will not be displayed on a test check. You must print an
actual check in order to test.

!
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5.15. Automate the Selection of Printers
Mekorma leverages Microsoft Dynamics GP’s Named Printers feature to bring even more convenience and
security to the in-house check printing process. Named Printers can save you time and eliminate printing
errors by allowing you to configure, in advance, which printer you are going to use to print your MICR
checks, check copies, overflows and EFT remittances.

This means you will NOT have to choose a printer each time you process payments.

The video below will walk you through the steps necessary to configure Named Printers; or follow the written
instructions on the following pages, in the following order:

1. Set Up Named Printers
2. Assign Named Printers to Mekorma Tasks

• Named Printers MUST be setup if you are processing payments using Multi-Batch Management!
• Named Printers is NOT currently supported by Dynamics GP or Mekorma for Session or Redirected

printing.

Last modified: Aug 05, 2019

Please be advised of the following:!
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5.15.1. Set Up Named Printers

The first step in configuring Named Printers is to name them! Printers must be set up with Printer IDs:

1. Login as an adminstrator.
2. Navigate to the Assign Named Printers window.
3. Confirm that a Machine ID is entered, and that a default printer has been assigned in Dynamics GP.
4. Click on Setup to open the ‘Setup Named Printers’ window.

5. Create a new Printer ID by typing the desired name in the Printer ID field.

To access the Assign Named Printers window, go to the Microsoft Dynamics GP drop-down
menu > Setup > System > Named Printers*
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6. Choose the Printer Class from the drop-down menu options:
a. System: Applies the same designated printer across companies and for every GP user.
b. User: Allows each individual user to be assigned a unique printer, applied to every company the

user prints from.
c. Company: Gives the option to assign a printer on a per-company basis, no matter which user is

printing in that company.
d. User & Company: Ties printers to individual users on a per-company basis.

7. Fill in the rest of the fields as required by the Printer Class; a Printer Name must be selected by using
the lookup.

When setting up a printer for check copies, you must enter the integer value (1, 2, 3) for the!
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8. Click Save.
9. Proceed to assign printers to Mekorma Tasks…

Last modified: Aug 05, 2019

number of copies desired in the ‘Extra Description’ field. Check copies will not print if this
field is left blank.
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5.15.2. Assign Named Printers to Mekorma
Tasks
Once Named Printers have been set up, you can now assign different printers for MICR checks, check
copies, overflows and EFT remittances in the Assign Named Printers window:

1. Login as ‘sa’.
2. Navigate to the Assign Named Printers window.
3. Choose 3rd Party from the Task Series drop-down menu.

4. Click on a Mekorma Task Description. Example: Mekorma MICR Checks
5. Select the Printer Class you’d like for that task. Example: System

To access the Assign Named Printers window, go to the Microsoft Dynamics GP drop-down
menu > Setup > System > Named Printers*
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6. The Named Printers window will open, listing available printers within the System Printer Class – click
on the desired printer, then Select. Example: CHECKS

7. The Named Printer has now been assigned to that particular Task.

You must make to necessary adjustments in User ID and Company Name fields of the Assign Named
Printers window, depending on the Printer Class you want to assign.

If I want to use a printer that is designated with the User & Company Printer Class, I must choose the
correct User ID and Company Name in the fields at the top of the window. Example: The APFABRIKAM
Printer ID assigned to Debbie in Fabrikam:

Please Make Note of the Following:!
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5.16. Enable Automatic PDF Check Copies
Mekorma provides the option to email EFTs to vendors in PDF format, as well as generate automatic PDF
copies of posted checks. Both of these options include the ability to specify the folder location and naming
convention of the PDF.

1. Open the System Options window.

2. Click the Enable PDF Check Copies option to enable the automatic Printing Check Copies to PDF
feature.

3. Define the path of the Base Folder to store the PDFs. If the Base Folder field was populated prior to
upgrading, the Enable PDF Check Copies option is automatically checked. Mekorma recommends

To access the System Options window, go to the Mekorma Area page > Setup > System >
System Options*
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designating a UNC folder. If this folder cannot be accessed for any reason, the check copies will be
created in the Data subfolder of your Microsoft Dynamics GP installation folder.

4. Choose from the options listed under the Available Fields for Folders section. Each folder path you
select is created as a sub-folder under the Base Folder field location.

Last modified: Oct 11, 2019

You can add subfolders using the options in the Fields in Folder Path section. The PDF is
given the file naming convention specified in the Available Fields for File Name section.*
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5.17. Check Image Archive Printing Options
If you would like to view and print check copies or EFT remittances, you may do so by using the check
image archive feature. Check Archiving is enabled by default upon installing the Mekorma Payment Hub.

Disable Check Archiving
1. Open the System Options window.

2. Under Additional Printing Options, check the box labeled Disable Check Archiving.

To access the System Options window, go to the Mekorma Area Page > Setup > System >
System Options*
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Auto Display Check Preview
The check copy or EFT remittance can be displayed automatically when the Payables Payment Zoom
window is opened within the Mekorma Audit Log.

1. Open the System Options Window.

2. Under Additional Printing Options, check the box labeled Auto Show Inquiry Check Preview.

Last modified: Dec 09, 2019
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5.18. Omit Zero Dollar Checks
Enable this feature if you do NOT want to print a $0 checks when you process batches using Mekorma
functionality.

Example: a credit memo fully is applied to a payment and zero dollars is left on invoice, and you do not want
the check to print.

1. Log in to Dynamics GP as an Admin or Power User.

2. Open the Mekorma System Options window.

3. In the section labeled Additional Printing Options, check the box next to Omit $0 checks in
Payables:

To open the Mekorma System Options window, go to the Mekorma Area Page > Setup >
System > Mekorma System Options*
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4. Click Save before closing the window.

Last modified: Feb 29, 2020
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6. Process Payments
This section of the User Guide will explain, guide and demonstrate the payment process when using
Mekorma products.

Last modified: Oct 23, 2019
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6.1. Build Batches with Mekorma
Payment batches can be created using the standard Microsoft Dynamics GP procedures on a per company
basis. The following windows can be used:

• Build Payment Batch (Select Checks)
• Edit Payment Batch (Edit Checks)

Multi-Batch Management can be used in place of these procedures, and will allow you to build batches
across companies using multiple checkbooks.

Last modified: Nov 12, 2019
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6.1.1. Build Multiple Batches at Once

1. Open the Multi-Batch Management Action Board.

2. Click on the Action drop-down menu and select Build Payment Batches (this is the default selection
upon first opening the action board).

3. Choose the desired Process ID. The system will list all associated Build IDs that make up the Process
ID, in addition to pending Batch Numbers (this number will change after batches have actually been
built), company, checkbook, type of payment included in the batch, and the currency used. If there are
any issues preventing a particular batch from being built, this will display in the column Reason Batch
will not be created.

4. Once you have confirmed there are no errors, click Process. The system will build batches using the
saved build criteria stored within the Process ID. Any vouchers that meet the criteria will be pulled into
the appropriate batch.

To open the Action Board, go to the Mekorma Area Page > Transactions > Payables >
Multi-Batch Management Action Board*
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5. During the process, each company login window will display as Multi-Batch Management changes
through companies. You can choose to show or hide other windows.

If you need to access Dynamics GP while batches are being built, it is possible to pause the
process by clicking Pause, then Resume when ready. If you do not want to complete the
process after pausing, click Finish.
*
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MMM Build Results Report

6. When all batches have been built, the MMM Build Results Report is generated and can be displayed
on the screen, printed, or saved as a file in a location of your choice. You may prefer to set up your
options so the Results Report is emailed instead, in which case this window will not display:

Example:
The Report will show you:

• Batches that were built because there were payments that met the criteria of the designated Build ID.
• Batches that were not built or REMOVED because no transactions were found to meet the applied

build criteria.
• How much time it took to build all the batches.
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If you are using the MEM Connector in conjunction with Multi-Batch Management, you can
build batches for Centralized and Decentralized processes at the same time.*
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6.1.2. Using Multi-Batch Management with
Multi-Entity Management
Before processing payments using Binary Stream’s Multi-Entity Management (MEM) with Multi-Batch
Management (MMM), the following steps must be taken:

• MEM must be activated for all entities you want to process with MMM.
• All users must have a default entity assigned. That entity ID will be pulled by default from the

Payables Batch Entry window when Multi-Batch Management goes through the automated build
process. If you do not have an entity ID set up for a company that is going to be included in your
MMM processes, you will be notified through a warning message on the MMM Action Board.

When using Multi-Batch Management, you can Centralize or Decentralize your process when you are
building a Process ID.

Build Batches

1. Open the Multi-Batch Management Process Maintenance window.

2. Type in the name of a new or existing Process ID. If creating a new one, select a combination of a
company, checkbook, Build ID, and payment type to add to the Process ID.

3. Click Insert.

4. Select the build parameter you would like to Centralize or Decentralize.

5. Click on the MEM button at the top of the window to open the Multi-Entity Management Settings
window.

6. Select a Centralized or Decentralized processing type. One or both processing types can be
included within a Process ID.

To open the Multi-Batch Management Process Maintenance window, go to the Mekorma
Area Page > Setup > System > Multi-Batch Management Process Maintenance*
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7. Click OK to close the window.

8. On the Action Board, select the Process ID that contains the Centralized and/ or Decentralized build
criteria.

9. Check the box next to each batch you would like to build, and click Process. Centralized and
Decentralized processes can be built simultaneously, or one at a time.

10. When building batches for a Centralized process:

• The system will build one batch from all invoices that meet the selected build criteria from each of the
child entities within the designated parent entity. See the Build Results Report:

11. When running a Decentralized process:

• One batch is built for each entity, resulting in multiple total batches. See the Build Results Report:

12. Continue with the next steps in the Action Board to process and post your batches as is standard with
the Multi-Batch Management service.

Last modified: Oct 07, 2019
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6.2. Assign Checkbooks for Invoice Selection
Mekorma’s Assign by Checkbook feature allows payables invoices to be assigned to a specific checkbook.
You can assign each invoice to a checkbook individually, or assign groups of invoices to a single checkbook
in a batch process. This feature works with payables invoices, POP shipment/invoices and POP invoices.

In addition, each vendor can be assigned to a specific Checkbook ID. If this option is activated when checks
are built, only those vendors who have been assigned to the checkbook for the check batch are paid during
that check run.

The Assign by Checkbook feature must be enabled before any assignments can be made.

Follow these links for instructions on how to assign checkbooks to:

• Individual invoices
• Payment batches
• Purchase orders
• Vendors

After assigning checkbooks, you can use the feature to select invoices by vendor or voucher when building
batches. This process can be automated by integrating the feature into your Multi-Batch Management
process.

Last modified: Nov 27, 2019

Please note, credit memos and returns cannot be assigned to checkbooks. Instead they
must be applied to the appropriate invoices to be credited to the specified checking account.

!
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6.2.1. Assign a Checkbook to an Invoice
You can assign a checkbook to each invoice upon entry. This is effective if you are handling a group of
invoices that are each paid by different checkbooks.

The Assign by Checkbook feature must be enabled before any assignments can be made.

1. Open the Payables Transaction Entry window.

2. Create a new payment or use the look-up open an existing voucher.

3. Click on Additional and select Assign by Checkbook to open the Assign by Checkbook Entry
window.

To open the Transaction Entry window, go to the Mekorma Area Page > Transactions >
Payables > Transaction Entry*
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4. Use the look-up in the Checkbook ID field to select the checkbook you want to assign this specific
payment to.

5. Click OK to save.

Posted Invoice Assignments

If you have already posted an invoice but haven’t paid it yet, the checkbook assignment can be changed.

1. Open the Transaction Inquiry by Vendor window or the Transaction Inquiry by Document window.

2. Select the payment you want to reassign and open the Additional menu > Assign by Checkbook to
open the Assign by Checkbook Inquiry window.

To open the Transaction Inquiry by Vendor or Transaction Inquiry by Document windows,
go to the Mekorma Area Page > Inquiry > Payables > Transaction by Vendor or Transaction
by Document
*
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3. Using the look-up, select the Checkbook ID you’d like to assign this payment to. Please note: posted
invoices that have already been paid cannot be reassigned.

4. Click OK to close this window.

5. Click OK on the Transaction Inquiry by Vendor or Transaction Inquiry by Document window to save.

Last modified: Dec 09, 2019

Mekorma Mekorma Products User Guide - Build x78

Page 221 of 288



6.2.2. Assign a Checkbook to a Payment
Batch
Assigning a checkbook to an entire batch works well if you have a group of invoices that should all be paid
by the same checkbook.

The Assign by Checkbook feature must be enabled before any assignments can be made.

1. Open the Payables Batch Entry window.

2. Select the batch you want to assign using the look-up next to Batch ID, or create a new batch.

3. Use the look-up to choose the appropriate checkbook.

To open the Payables Batch Entry window, go to the Mekorma Area Page > Transactions >
Payables > Batches*
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4. Click Save.

Last modified: Nov 27, 2019
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6.2.3. Assign a Checkbook to a Purchase
Order
The Assign by Checkbook feature can also be applied to the Purchase Order (PO) system. A checkbook
can be assigned to the original Purchase Order, and that assignment will be carried through to the invoice.

The Assign by Checkbook feature must be enabled before any assignments can be made.

1. Open the Purchase Order Entry window.

2. Use the look-up to pull up an existing PO, or create a new one.

3. Click on the Additional menu > Assign by Checkbook to open the Assign by Checkbook Entry
window.

To open the Purchase Order Entry window, go to the Mekorma Area Page > Transactions >
Purchasing > Purchase Order Entry*
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4. Use the look-up to choose the appropriate Checkbook ID.

5. Click OK.

6. Click Save on the Purchase Order Entry window.

A checkbook assignment can also be made when you receive the shipment by following the exact same
steps in this window:

Or you can assign it when you match the invoice:
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Last modified: Nov 27, 2019
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6.2.4. Assign a Checkbook to a Vendor
You can assign a specific checkbook to a Dynamics GP vendor. Assigning a checkbook to a vendor allows
you to automatically exclude that vendor from check batches associated with other checkbooks.

The option to exclude vendors can be activated when each check batch is built. Even if a checkbook has
been assigned to a vendor, if the option to automatically exclude is not selected at the time a check batch is
built, the vouchers from the vendor can be included in a check batch from any checkbook.

The Assign by Checkbook feature must be enabled before any assignments can be made.

To assign a vendor to a checkbook:

1. Open the Vendor Maintenance window.

2. Click on Options at the bottom of the window to open the Vendor Maintenance Options window.

3. Select the appropriate Checkbook ID.
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4. Click OK to save and return to the Vendor Maintenance window.

Last modified: Nov 27, 2019
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6.2.5. Select Vouchers by Vendor Checkbook
ID
Assigning a payment by vendor Checkbook ID is most useful when you want to pay a certain type of vendor
from a particular checkbook.

Examples:

• You are paying grants, and the grant vendors can only be paid by the grant checkbook and not your
operating checkbook.

• You manage properties and each property has its own checkbook to pay the bills.

Once a checkbook has been assigned to a vendor, you can build check batches using the Assign by
Checkbooks feature in the Build Payment Batch (Select Payables Checks) window. The Assign by
Checkbooks feature cannot be used with the Edit Payment Batch (Edit Payables Checks) functionality.

Video tutorial for GP2013-2016

Video tutorial for GP2018

1. Create a new batch in the Build Payment Batch (Select Checks) window.

2. Choose Computer Checks in the origin field.

3. Select the Checkbook ID that you want to build payments for and Save the batch.

4. You will then be back on the Build Payment Batch window. Click the box next to Select Vouchers by
Vendor Checkbook ID on the Assign by Checkbook window (which should already be open). Clicking
this box activates the feature – only payments to vendors that have been assigned to the checkbook
that you’re building payments from will be pulled. Please note that if this box is not checked, then
the assign by checkbook feature will not work when you build your payment batch.
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5. Fill out any additional selection criteria you wish to use to build your batch. Only invoices assigned to
this Checkbook ID will be selected.

Last modified: Oct 09, 2019

In GP 2018, you have the ability to create a Payment Option ID that can be applied to any
of your batches. This ID will store selected settings from the Build Payment Batch window,
including your choice for checkbook assignments.
*
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6.2.6. Select Vouchers by Voucher Checkbook
ID
Assigning a payment by voucher checkbook ID is most useful when you want to pay a certain type of
voucher from a particular checkbook.

Examples:

• You are paying grants, and the grant vouchers can only be paid by the grant checkbook and not your
operating checkbook.

• You manage properties and each property has its own checkbook to pay the bills.

Once a checkbook has been assigned to an invoice, you can build check batches using the Assign by
Checkbooks feature in the Build Payment Batch (Select Payables Checks) window. The Assign by
Checkbooks feature cannot be used with the Edit Payment Batch (Edit Payables Checks) functionality.

Video tutorial for GP2013-2016

Video tutorial for GP2018

1. Create a new batch in the Build Payment Batch window.

2. Choose Computer Checks in the origin field.

3. Select the Checkbook ID that you want to build payments for and Save the batch.

4. You will then be back on the Build Payment Batch window. Click the box next to Select Vouchers by
Voucher Checkbook ID on the Assign by Checkbook window (which should already be open).
Clicking this box activates the feature – only payments that have been assigned to the checkbook that
you’re building payments from will be pulled. Please note that if this box is not checked, then the
assign by checkbook feature will not work when you build your payment batch.
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5. Fill out any additional selection criteria you wish to use to build your batch. Only invoices assigned to
this Checkbook ID will be selected.

Last modified: Oct 09, 2019

In GP 2018, you have the ability to create a Payment Option ID that can be applied to any
of your batches. This ID will store selected settings from the Build Payment Batch window,
including your choice for checkbook assignments.
*
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6.2.7. Select Vouchers Using Multi-Batch
Management
To use the Assign by Checkbooks feature when automating the batch building process with Mekorma Multi-
Batch Management, you can Select Vouchers by Vendor or Voucher Checkbook ID when you create a
Process ID.

Watch the video excerpt below demonstrating how to select vouchers by vendor checkbook ID. The steps to
select voucher checkbook IDs are the same, except you must mark the corresponding box when creating
your Build ID:

1. Create a Build ID with Select by Vendor Checkbook ID or Select by Voucher Checkbook ID
marked. This feature will work with both check and EFT batches.

2. Add any other filter you want to include in your batch build process. (Ex. Due Date, Discount Date,
Payment Priority, etc.)

3. Use this Build ID in your Process ID. Please note that you need to repeat the use of this Build ID for
each of your checkbooks to be sure that all of your invoices get selected.

Follow the hyperlinks for more detailed instructions on how to create Build IDs and Process IDs.

Last modified: Oct 09, 2019
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6.3. Approvals with Secure Approval
Workflow
After building a batch of payments, the batch can be locked before printing. An approval workflow can be
configured to notify designated users (Mekorma Approvers) that there are transaction payments needing
their approval.

Workflow must first be configured by activating workflow if using Mekorma Legacy security, or by configuring
Threshold IDs and applying them to checkbooks under the Task-Based security model.

Additionally, users assigned to authorize entire batches (Mekorma Batch Authorizers) can be notified that
they have pending batches to authorize.

The experience for Approvers/ Authorizers will vary, depending on which security model has been
configured. In order to complete the workflow task, Approvers/ Authorizers must navigate to the appropriate
Mekorma Navigation List where transactions/ batches can be reviewed and approved/ authorized.

Last modified: Oct 15, 2019

Mekorma Mekorma Products User Guide - Build x78

Page 234 of 288



6.3.1. Request Approval or Authorization
Request Approval

Regardless of the security model you have configured (Task-Based approvals or Legacy Security by User
ID), approval requests can be accomplished in the following way:

1. After building a payment batch, the Request Approval button can be selected on one of these
windows:

• Build Payment Batch (under Additional)
• Edit Payment Batch (under Additonal)
• Edit Payments (under Additional)
• Print Payments (replaces Print button)
• Mekorma Payment Batch Status List
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2. An email or text message will be sent to all eligible Approvers that they have transactions needing
their review.

Request Authorization

1. After building a payment batch, the Request Authorization button can be selected on one of these
windows:

• Build Payment Batch (under Additional)
• Edit Payment Batch (under Additonal)
• Edit Payments (under Additional)
• Print Payments (replaces Print button)
• Mekorma Payment Batch Status List

2. An email or text message will be sent to all eligible Authorizers that they have transactions needing
their review.
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Last modified: Oct 15, 2019

Notifications are configured differently depending on the security model you are using: if
processing with the Legacy Security model, go to the Mekorma MICR Security Maintenance
window. If using Task-Based security, go to the Mekorma Preferences window.
*
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6.3.2. Approve/ Reject Payments with Legacy
Security
Review and Approve/ Reject Payments with Legacy Security

1. After receiving notification of payments pending approval, Approvers can open the Mekorma
Payment Batches Pending Approval navigation list.

2. To review the payments in a batch, select the batch and choose Go To > Mekorma Batch Drill-
Down. You will be able to see all transactions in the batch. You cannot add or
modify any payment, but you can review or reject.

3. To review the details of a transaction, select the vendor payment on the left then double-click the
specific transaction on the right. This will open the Payment Transaction Entry Zoom window.

4. If you want to reject a transaction that it is included within a particular vendor payment, you must
reject the entire vendor payment. To do so, return to the Mekorma Approval Batch Drill-Down window
and check the box next to that payment. Click Reject. You can type in a reason for rejecting if
desired.
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5. After reviewing and/or rejecting transactions in the batch, select OK to close the window.

6. To approve payments in the navigation list, mark the payment and choose Approve.

7. When all needed approvals are obtained, a notice will be sent to the user who requested approval to
inform them the payments are ready to be printed.

Last modified: Nov 07, 2019

Mekorma Mekorma Products User Guide - Build x78

Page 239 of 288



6.3.3. Approve or Authorize with Task-Based
Workflow
Mekorma Approvers must approve transactions within their designated threshold levels before checks/ EFTs
can be printed and processed; Mekorma Batch Authorizers must authorize pending batches before the
batches can be printed/ processed.

Approve Payment Transactions

1. To complete approval tasks, Approvers must navigate to the Mekorma Approval List.

2. When using Task-Based security, transactions can be viewed using the following filters:

• All Transactions: displays all transactions needing approval whether they are in the user’s threshold
range or not. The user will not be able to approve transactions of a greater amount than their
assigned threshold level.

• Approvable Transactions: displays payment transactions within or below the user’s assigned
threshold range, all of which that user has the ability to approve.

• My Specific Transactions: displays the transactions specifically assigned to the user (those
transactions within her designated threshold range).

• By Batch: displays all transactions within the user’s threshold level grouped together by batch.

3. Individual vouchers can be reviewed by clicking the box next to a payment, then on the Payment
Vouchers button. This will display a list of all vouchers contained within that payment transaction,
along with the document number and amount.

4. To zoom in on payment details, double-click on the voucher to open the Payment Transaction Entry
Zoom window.

5. If using docattach or a similar 3rd party plug-in that integrates with the inquiry window, the image of
the corresponding invoice can be accessed within the Entry Zoom window. Select the note for a
voucher, the relevant image, then click Preview.

6. Return to the approval window to approve transactions by marking the check boxes next to each
payment and clicking on Approve. If a transaction requires a second approval, the Status will display
as Pending 2nd Approval and will only be available for printing/ processing once the second
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Approver performs this same action.

7. If instead you want to reject a payment, select the vendor payment that contains the incorrect
payment, and choose Reject. A window will open to allow the entry of a reason for the rejection.

8. The user who requested approval will be notified by email or text of the approvals and rejections that
occurred once completed, as long as email/ text notifications are configured properly. All payment
batches that have been approved can then be printed/ processed and once the payments have been
posted, they’ll automatically be available in the Mekorma Audit Log Report.

Authorize Batches

1. After receiving notification of batches pending authorization, Authorizers must navigate to the
Mekorma Batch Status List.

2. After reviewing the list, mark the check boxes next to each batch and click Authorize to allow for
continued processing.

Last modified: Nov 07, 2019

Please note, when a payment is rejected from a batch, it isn’t deleted from the system, but
simply moved.

!
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6.4. Processing Batches with Split Batches
Enabled
Processing Split Batches Using Task-Based Security with Approvals

If the split batch feature is enabled, batches are split during the workflow process based on the Threshold ID
logic:

• Transactions that do not require approval will remain in the original batch, which is immediately
available for printing.

• Transactions that require one approver are transferred to the A1 batch. The A1 batch is submitted into
the workflow for approval.

• Transactions that require two approvers are transferred to the A2 batch. The A2 batch is submitted
into the workflow for approval.

When the batches are split, the naming convention changes and the original batch name is appended to
include either an “A1” or an “A2”, depending on the number of approvers required. So for example, a batch
named “AP JUNE” becomes either “AP JUNE-A1” or “AP JUNE-A2”. The batch name is limited to 12
characters or less.

Processing Split Batches Using Legacy Security By User ID

If the split batch feature is enabled, batches are split during the workflow process based on the following
logic: If the When to Require Passwords field is set to:

• Always One: all transactions are transferred to the A1 batch which requires one approver and the
original batch is removed. The A1 batch is submitted into the workflow for approval.

• Always Two: all transactions are transferred to the A2 batch which requires two approvers and the
original batch is removed. The A2 batch is submitted into the workflow for approval.

• One Password if Over Threshold; None if Under: all transactions with amounts over the threshold
are transferred to the A1 batch which requires one approver and the original batch is available for
printing without approval. The A1 batch is submitted into the workflow for approval.

• Two Passwords if Over Threshold; One if Under: the batch is split into A1 and A2 and all
transactions with amounts over the threshold are transferred to the A2 batch which requires two
approvers and remaining transactions are transferred to A1 which requires one approvers. Both
batches are submitted into the workflow for approval and the original batch is deleted.
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When the batches are split, the naming convention changes and the original batch name is appended to
include either an “A1” or an “A2”, depending on the number of approvers required. So for example, a batch
named “AP JUNE” becomes either “AP JUNE-A1” or “AP JUNE-A2”. The batch name is limited to 12
characters or less.

Last modified: Oct 13, 2019

If you use the same batch name multiple times while the split batches (A1 and/or A2) are
still in the approval process, the system generates B1 and B2 batches, and the letter
continues to increase up to Z1 and Z2 until all batches have been cleared from the pending
approval queue. After the “Z” batches, the system can no longer split the batches, causing
the entire original batch to enter the approval process.

!
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6.5. Print Payments

Printing Checks with Mekorma Payment Hub
Mekorma MICR integrates fully with Microsoft Dynamics GP and gives you the ability to:

• Print on blank or pre-printed check stock
• Print signatures based on the dollar amount of the check
• Add secure approval workflow or batch authorization to the check printing process
• Reprint checks
• Print check copies for your files

Last modified: Aug 14, 2019

Within the same company, you cannot print some checks using Mekorma MICR and others
using Microsoft Dynamics GP. Unless you have a second Microsoft Dynamics GP user
configured through the Alternate Security to print checks. It is important to note that any
change to your operating system, server, or printer could cause printing variations. Always
retest the formatting of your checks and the MICR line if you have altered your system
configuration or peripherals in any way.

!
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6.5.1. Print Payables Transaction Checks
The process for printing payables transaction checks with Mekorma follows the same steps as printing
standard Dynamics GP payables transaction checks with one exception: The alternate Print Mekorma
MICR Payables Transaction Checks window is used, rather than the standard Dynamics GP Print
Payables Transaction Checks screen.

Dynamics GP security must be set to the Mekorma MICR alternate windows for each user printing payables
transaction checks in the company.

To print a payables transaction check:

1. Open the Transaction Entry window and enter the applicable information.

2. To select the appropriate Checkbook ID, click the arrow to the right of the Check Amount field. This
will open the standard GP Payables Check Entry window.

3. Choose the correct checkbook ID as needed and click Actions > OK to close.

4. Back on the Payables Transaction Entry window, make certain all necessary transaction information
has been entered and click Print Check at the bottom of the window.

5. The Print Mekorma MICR Transaction Check window will open. Click Print.

6. After entering any required User IDs and/or Passwords, the Mekorma MICR Check Printing screen is
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displayed.

7. Click Print to print checks. If you want to print check copies, click the Use Copy Printer option to
display the check copy fields (see Printing Check Copies for more information).

Last modified: Aug 12, 2019
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6.5.2. Print Payables Batch Checks
Printing payables check batches can be done in several different ways:

Mekorma Payment Hub MICR Check Printing
Using the Mekorma Payment Hub core MICR functionality, payables batches can be printed one batch at-a-
time, on a per-company basis. This is accomplished by following the same steps as printing standard
Dynamics GP payables batch checks, except the alternate Print Mekorma MICR Payables Checks window
will be used, rather than the standard Dynamics GP Print Payables Checks screen.

Dynamics GP security must be set to the Mekorma MICR alternate windows for each user printing payables
batch checks in the company.

1. Build the check batch using regular Microsoft Dynamics GP procedures.

2. Open the Print Mekorma MICR Payables Checks window. This can be done by clicking Print
Payments from within the Build Payment Batch or Edit Payment Batch windows, or by directly
opening the Print Payments window.

3. Use the look-up to select the desired batch. Please note, if using Mekorma secure approval workflow
or authorization based security, the batch will need to go through the required approval process
before it can be printed. Approvals/ Authorizations can be requested from this window by clicking on
Request Approval or Request Authorization.

To open the Print Mekorma MICR Payables Checks window, go to the Mekorma Area
page > Transactions > Payables > Print Payments*
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4. Choose how you would like to sort your checks when printing, if needed.

5. Click Print.

Multi-Batch Management
Within the Multi-Batch Management Action Board, check batches from multiple companies being paid with
multiple checkbooks can be printed all at once. Follow this link for instructions.

Enhanced Electronic Payments
If you are a qualified Enhanced Electronic Payments customer, you have the option to print checks locally
using either Mekorma check printing functionality or Multi-Batch Management.

You may instead choose to have the ePayment service print checks for you, removing the need to print any
checks on-premise unless you choose to do so. Follow this link for more information on how to process
payments using the Enhanced Electronic Payments service.

Last modified: Nov 18, 2019
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6.5.3. Print Multiple Batches at One Time
Mekorma Multi-Batch Management (MMM) provides an ability to automate the printing and posting of
payables batches across multiple companies and checkbooks. Checks and EFTs can be printed and
processed from within the Multi-Batch Management Action Board, whether the batches were created
manually or through the automated MMM process.

Instead of needing to log in to each company separately, all batches can be viewed and selected for
processing within one window. Batches are further filtered out by the user’s access level. This means users
can only view and select batches from companies to which they have access.

1. Open the Multi-Batch Management Action Board.

2. Select the action Process Checks and EFTs from the drop-down menu. This will display all batches
ready to be processed.

3. If a batch has an error icon, click on the icon. The line items will expand to display the Status
Description field, which explains the reason for the error. For example, if batches are required to be
authorized before being processed, but the Authorizer(s) have not yet performed that task, the
following results would display:

To open the Action Board, go the the Mekorma Area page > Transactions > Payables >
Multi-Batch Management Action Board*
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Please note, you can display only those batches that have errors by clicking on the radio button With
Errors.

4. Choose the batches you would like to print/ process by checking the box next to each batch. You can
choose to Mark All or Unmark All, or select each batch individually.

5. Click Process.

Last modified: Nov 07, 2019

Named Printers must be set up so that the Print Mekorma MICR Payables Checks window
does not interfere with the printing process as the system automatically switches between
companies.

!
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6.5.4. Print EFT Remittances
If you are printing EFT remittances, you can select the format for printing the remittances by entering an
option in the EFT Remittance Options field. The selected format is displayed in the Mekorma MICR Check
Printing screen when you print the remittances.

The same security parameters applied to your checks can also be applied to your EFT Remittances by
marking the EFT Security option whether you are using the Legacy or Task-Based security model.

Before printing EFT remittances, verify that you have completed the following processes:

• Enable EFT in Microsoft Dynamics GP.
• Configure a Checkbook for EFT.
• Set up pre-notes (if applicable).
• Configure a vendor for EFT (please see your Microsoft Dynamics GP documentation for more

information).
• Select a remittance format for each checkbook from which you will be printing EFT remittances.

To print EFT remittances after you have created an EFT batch:

1. Click the Process or the Print button in the Print Mekorma MICR Payables Checks window or open
the Process Payables Remittance window.

2. Verify that Remittance Form is selected.

To open the Process Payables Remittance window, go to the Mekorma Area Page >
Transactions > Payables > Process Remittance*
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3. Click the desired Destination option – either Print Document or Send Document in E-mail.

4. Click Process. If sending the remittance via email fails for any reason, the remittance will be printed
instead.

Last modified: Oct 14, 2019
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6.5.5. Print US Payroll Checks
You are ready to print US Payroll checks after the following steps have been completed:

1. Create a US payroll batch using the standard Microsoft Dynamics GP procedures.
2. Build and calculate your checks.

To Print:
1. Open the Print Mekorma MICR US Payroll Checks window.

2. Verify that the title of the window includes the words Mekorma MICR. If not, abort the procedure and
set up security to the Alternate Mekorma MICR Print Payables Checks window.

3. For Direct Deposit, select the Calculate Employee Deposits option for the Process field.

4. Click Process to process the Direct Deposits. After calculating the Direct Deposits or if you are not
running Direct Deposits, from the Print Mekorma MICR US Payroll Checks screen, select a sort order
using the Sort Checks By drop-down list.

5. If desired, change the Starting Check Number and Check Date. To change the Starting Check
Number, the Override Check Number option on the Checkbook Maintenance screen must be
selected.

6. Verify the Print field is set to Checks and click Print.

7. Click Print to proceed. After entering any required User IDs and/or Passwords, you see the Mekorma
MICR Check Printing screen.

8. Define your print settings and click Print when you are ready to print checks.

Last modified: Sep 03, 2019

To open the Print Mekorma MICR US Payroll Checks window, go to the Mekorma Area
page > Transactions > Payroll > Print Checks*

Checks will be numbered after being sorted in the order specified in the drop-down list.
However, if checks are being printed in threshold groups, they will be grouped after being
numbered so the checks will not print sequentially by number. For this reason, threshold
group sorting cannot be used with pre-printed checks.

!
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6.5.6. Print Canadian Payroll Checks

You are ready to print Canadian Payroll checks after the following steps have been completed:

1. Create a Canadian payroll batch using the standard Microsoft Dynamics GP procedures.
2. Build and calculate your checks.

1. Open the Payroll Cheque Reports – Canada dialog box.

2. Enter any required User IDs and /or passwords.

3. On the Mekorma MICR Check Printing screen, confirm that the Check Printer is the printer you want
to use. If not, select another printer from the drop-down list.

4. Click the Print to print checks.

5. Click OK to proceed. The Mekorma MICR Check Printing screen is displayed again with the Check
Stub defaulting to the stub you entered in the Earnings Statement field on the Mekorma MICR Setup
(Payroll – Canada) screen.

6. Click Print to print Direct Deposits.

Last modified: Sep 04, 2019

The check numbering system for Canadian Payroll checks is configured on the Payroll
Control Setup – Canada screen, not the Checkbook Maintenance screen.*

To open the Payroll Cheque Reports – Canada window, go to the Mekorma Area page >
Reports > Payroll – Canada > Transactions > Cheque Reports.*

Mekorma Mekorma Products User Guide - Build x78

Page 254 of 288



6.5.7. Print Miscellaneous Checks
The Dynamics GP Miscellaneous Check feature allows you to print a check to any entity without creating the
entity as a vendor. Mekorma MICR uses the Dynamics GP Miscellaneous Check screen, but intercepts the
check printing process and prints the checks using the Mekorma MICR check format assigned to the
checkbook.

Unlike payables batch checks, payables transaction checks and payroll checks, there is no alternate window
for Miscellaneous Checks when using Mekorma MICR and no security settings to configure. If Mekorma
MICR is installed and registered, Miscellaneous Checks print using Mekorma MICR.

If you do not want to use Mekorma MICR to print Miscellaneous Checks, you can turn off this feature by
checking the “Payables” box on the Mekorma MICR Suppress Warnings screen.

To print a Miscellaneous Check:

1. Open the Miscellaneous Check window.

2. Enter values in all required fields.

3. Click Print Check and Post.

To open the Miscellaneous Check window, go to the Mekorma Area Page > Transactions >
Financial > Miscellaneous Check*
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4. After entering any required User IDs and/or Passwords, the Mekorma MICR Check Printing window
will open.

5. Click Print.

Last modified: Sep 04, 2019
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6.5.8. Print Blank Checks
Blank checks are not posted to the General Ledger when they are printed. To record them, they must be
entered later as manual payments. Though the blank checks are not recorded at the time of printing, if the
default starting check number is used, the Next Check Number field for the checkbook will be advanced by
the number of checks printed. This can lead to missing check numbers if one or more of the blank checks
are never entered as manual payments.

To avoid this, change the starting check number for the blank check batch. This prevents the Next Check
Number from advancing. When printing blank checks, only one check Approver is required, but the approver
must be assigned to the checkbook you are printing the blank checks from.

To open the Print Blank Checks window, go to the Mekorma Area Page > Transactions > Payables > Print
Blank Checks

1. Open the Print Blank Checks window.

2. Enter the Checkbook ID and the Number of Checks you would like to print. If desired, enter a
different Starting Check Number for the batch of blank checks you plan on printing.

3. Select the number of Signature lines to print on each check. Signature lines are blank lines upon
which a signature can be written.

4. Click Print. After entering any required User IDs and/or Passwords, the Mekorma MICR Check
Printing window will open.

5. Enter your print settings and click Print when you are ready to print checks.

Last modified: Oct 14, 2019
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6.5.9. Print Refund Checks
To print a refund check with Mekorma MICR, follow the standard GP processes to create the return(s). If
you need help configuring Mekorma refund check formats, please see this page.

1. Click Print from the Print Mekorma MICR Payables Check window and enter any applicable
passwords and approvers. This will open the Mekorma MICR Check Printing window.

2. The Refund Check Stub format will not be displayed in the Check Stub field. When you print (or
preview) checks, the system replaces the displayed check stub format with the refund stub format
selected on the Mekorma MICR Setup (Payables) window.

3. Click Print to print checks or Preview to preview the checks before printing. After printing, the Post
Payments window will open.

4. Click Process to post the checks.

Last modified: Oct 14, 2019

To access the Print Mekorma MICR Payables Checks window, go to the Mekorma Area
page > Transactions > Payables > Print Payments*
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6.5.10. Print Check Copies to PDF
This feature automatically generates PDF copies of each individual check or EFT, once they have been
printed and/ or posted. Check copies are stored in a location defined on the System Options screen.

Automatic check copies are generated when you print:

• Payables Batch Checks
• Payables Transaction Checks
• US Payroll Checks
• Canadian Payroll Checks
• Miscellaneous Checks

To view PDFs:

1. After posting, navigate to the folder location defined for the PDF check copies on the Mekorma MICR
System Options screen.

2. Open the PDF file to view the check copy:

Last modified: Oct 14, 2019

PDF Check Copies follow the standard Mekorma MICR check copy rules and do NOT
display the MICR line, signatures or signature lines.

!
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6.5.11. Reprint Checks
The Microsoft Dynamics Post Payments window is used to reprint checks. You can reprint all checks or a
selected range of checks.

1. Open the Post Payments window.

2. Set the Process field drop-down list to Reprint Checks.

3. Select a range for reprinting checks. Click the lookup icon on the From option to display a list of
checks.

4. Enter a check range and click Process to reprint the checks.

Last modified: Aug 05, 2019
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6.5.12. Print Using the MEM Connector
You can print batches using the MEM Connector from GP’s Build Payment window, where you can select
whether to Centralize or Decentralize the process. The configuration for Sorting and Subtotal options will
effect the results as follows:

Setup Options Print
Category Print Results

No Sort, No
Subtotal Decentralized Prints one line only for ID and name; prints facility address; no check sorting

No Sort, No
Subtotal Centralized No MEM fields print, no sorting

Sort by ID, No
Subtotal Decentralized Sorts checks by Facility ID, no Facility fields print

Sort by ID, No
Subtotal Centralized Sorts vouchers on stub by Facility ID; sorts checks by Facility ID; Facility ID

and Name print on the stub

Sort by Name,
No Subtotal Decentralized Sorts checks by Facility Name; no Facility fields print; no subtotal line

Sort by Name,
No Subtotal Centralized Sorts vouchers on stub by Facility Name; sorts checks by Facility Name,

Facility ID and Name print on the stub; no subtotal line

Subtotal By ID,
No Sort Decentralized One subtotal line prints since only one facility is on the check; checks are

not sorted

Subtotal By ID,
No Sort Centralized Vouchers are sorted on the stub by Facility ID with a subtotal line at the end

of each Facility group; checks are not sorted

Subtotal By
Name, No Sort Decentralized One subtotal line prints since only one facility is on the check; checks are

not sorted

Subtotal By
Name, No Sort Centralized Vouchers are sorted on the stub by Facility Name with a subtotal line at the

end of each Facility group; checks are not sorted

Subtotal By
Name, Sort by
Name

Decentralized One subtotal line prints since only one facility is on the check; checks are
sorted by Facility Name

Subtotal By
Name, Sort by
Name

Centralized Vouchers are sorted on the stub by Facility Name with a subtotal line at the
end of each Facility group; checks are sorted by Facility Name

Subtotal By ID,
Sort by ID Decentralized One subtotal line prints since only one facility is on the check; checks are

sorted by Facility ID

Subtotal By ID,
Sort by ID Centralized Vouchers are sorted on the stub by Facility ID with a subtotal line at the end

of each Facility group; checks are sorted by Facility ID

Batches configured using the MEM Connector can also be printed and processed from the Multi-Batch
Action Board.
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Last modified: Oct 07, 2019

Please note, MEM Connector fields will not be displayed on a test check. You must print an
actual check in order to test.

!
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6.5.13. Print Payments Electronically
When implementing the Enhanced Electronic Payments service, you have two options for printing check
batches:

1. Print checks locally using Payment Hub functionality or Multi-Batch Management.
2. Let the service handle the printing and mailing of your vendor checks. Once batches have been built

using the Payment Hub or Multi-Batch Management, at the time of printing, the payment information is
sent to the ePayment service.

See here for more information on the electronic payment process.

Last modified: Sep 10, 2019
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6.5.14. Pay a Vendor Manually When Using
ePayments
When using Mekorma Enhanced Electronic Payments, if you have selected to have the ePayment service
print your vendor checks off-site, there may be times when you need to print a check manually using
Mekorma MICR. There are two ways to accomplish this task:

1. Change the vendor’s status to Local Processing.

2. Pay the vendor with a checkbook that is NOT configured for ePayments.

Last modified: Oct 11, 2019
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6.5.15. Print Payments Using the Web Client
These instructions apply to printing within the Dynamics GP Web Client, assuming the Mekorma Print Client
has been installed and the user who needs to print has been granted security access to the Web Client.

1. Open the Print Payments window.

2. Use the look-up to select a batch.

3. The Mekorma MICR Web Client Print Job Preparation window will open. From within this window,
you can change your check or remittance format for check printing as needed.

4. Click the Prepare and Download button to open the Mekorma Print Client. (this assumes you have
configured your browser to automatically launch the downloaded mcp file).

5. The Mekorma Print Client allows you to preview and print check files in the same way that you would
handle them through the GP desktop application. You can:

• Select whether you would like to print check copies.
• Choose to navigate to the next check batch. If you select to navigate to the next batch, you will be

prompted with a question asking if you want to delete the Mekorma Check Print (or .mcp) file that
accords to the batch that you are currently on. To print the batch that you’ve skipped at a later date,
generate another .mcp through the print process.

• Select to print to any local printer, or any remote printer (if you are connected to your network through
a VPN).

Last modified: Oct 11, 2019
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6.5.16. Sort Checks when Printing
Checks and EFTs can be sorted into groups when printing a batch from the Print Mekorma MICR Payables
Checks window.

Sorting options include the following:

• Payment Number
• Name
• State – City
• Zip Code
• Voucher Number

1. Open the Print Mekorma MICR Payables Checks window.

2. Use the look-up to select a Payables Batch that is ready to be printed.

3. Use the drop-down list to display options for Sort Checks By:

4. Print when ready.

Last modified: Nov 18, 2019
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6.6. Process Payments Electronically
The Mekorma Enhanced Electronic Payments service is designed to handle all your vendor payments –
virtual credit card, check and EFT (ACH) payments can all be sent in the same batch. You can choose to
print checks locally or let the service print and mail checks on your behalf.

See here for an overview of the Enhanced Electronic Payments service:

Once you have qualified to use the ePayment service and it has been configured within your Dynamics GP
work environment, you are ready to process payments electronically.

Last modified: Oct 23, 2019
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6.6.1. Receive and Send Vendor Master Data
Mekorma recommends using the Enhanced ePayment Utilities before beginning to process your batches
electronically. If you have installed and configured the MEEP Utility file, vendor data is automatically
synchronized between Dynamics GP and the ePayment service every 24 hours, but you can add an extra
measure of certainty by performing the following tasks:

1. Go to the Mekorma Area Page > Utilities > Enhanced ePayment.

2. In most cases, you will only need to send or receive information that has been updated/ changed
since the last automatic update. Click on the actions in this order, as you will want to be sure to
receive updates from the portal before sending GP updates:

• Get Changed Vendor Info
• Send Vendor Updates

3. You will receive a confirmation message once the action has been completed:

The additional utility options should only be used on occasion, if there have been many changes made to
vendor payment methods. Again, be sure the get the data from the ePayment system before sending the
vendor master from GP:

• Get All Vendor Detail – Please run this before the first time you process payments using the
Enhanced Electronic Payments service

• Send Vendor Master

Last modified: Oct 24, 2019

Follow this link to review all the information communicated between Dynamics GP and the
Enhanced Electronic Payments service.*
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6.6.2. Build ePayment Batches
In standard GP processing, separate batches must be built for each payment type. One of the benefits the
Enhanced Electronic Payments service offers is the ability to include all payment types in a single batch.

ePayment batches can be created in the following windows using standard GP procedures:

• Edit Payment Batch
• Build Payment Batch
• Or use the Multi-Batch Action Board

When creating the batch:

• Choose Check as the payment method.
• Select a checkbook that is configured for Enhanced Electronic Payments.
• Build your batch by selecting the desired payments/ payment criteria. Batches can contain payments

for vendors excluded from the service – those payments will NOT be sent electronically, but will be
processed using GP or Mekorma MICR functionality.

Last modified: Sep 11, 2019

Please note, if your company has multiple checkbooks it is still possible to pay enrolled
vendors with checkbooks not configured for ePayments, but in that case, those payments
would not be processed using the Enhanced ePayments service. Batch creation rules would
fall back to standard GP functionality therefore, EFT and check payments cannot be
combined in the same batch.

*

Mekorma Mekorma Products User Guide - Build x78

Page 269 of 288



6.6.3. Send Batches for ePayment Processing
Once necessary approvals have been completed (if Mekorma security has been configured for this
company), an ePayment batch can be sent for processing in the GP Print Payments window, or from within
the Multi-Batch action board.

1. Open the Print Payments window.

2. Use the look-up to select an ePayment batch (ie., a batch that is tied to a checkbook configured for
ePayments, that also contains transactions for vendors enrolled in the service).

3. Click Print.

4. A window will open indicating that the batch was sent for electronic processing. Electronic payments
are split from the original batch; the new batch is named after the original batch with an underscore
(Batch Name_). Click OK to close.

5. The Enhanced ePayment Response Check Status window will also open to display the batch
status. The ePayment service will generally respond in under a minute. Initially the status will read
Batch Check in Progress. GP is fully accessible while the system is processing.

6. When the ePayment service has completed processing, the following response will be sent back to

Please note that for Enhanced Electronic Payments customers who would like to use
Mekorma security, you MUST configure secure approval workflow in either the Legacy or
Task-Based models so that payments are approved before sending to the ePayment
service. DO NOT configure Legacy Checkbook ID or Task-Based Authorization, as
payments can be sent for processing to the ePayment service without going through an
approval process.

!

To open the Print Payments window, go to the Mekorma Area Page > Transactions >
Payables > Print Payments*

Mekorma Mekorma Products User Guide - Build x78

Page 270 of 288



the Enhanced ePayment Response Check Status window:

• All EFT and check payments processed by the service will be placed in a batch with the original name
plus underscore (Batch_); in addition, a new payment is added to Batch_ to pay the Enhanced
Electronic Payments credit card vendor, if virtual card payments have been issued using the pre-
funded model.

• If the original batch contained virtual card payments, those payments will be placed in another batch
named Batch_V.

• The batch status updates to Batch is available to post.

7. Additionally, an ACH file is returned to GP containing the details of all EFT or pre-funded virtual card
payments. If you use Positive Pay, a corresponding file is also generated. Both files can be accessed
from the Enhanced ePayment Response Check Status window by clicking first on the Integration
Files hyperlink, which opens the Enhanced ePayment Integration Files window.

8. Click the ACH File Name or the Positive Pay File Name hyperlink to access.
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9. Both batches can be posted by clicking on the Batch Number hyperlink in the Enhanced ePayment
Response Check Status window. For the EFT/ check batch, the Post Payments window will be
accessed.

10. For the virtual credit card batch, you will be brought to the Process Payables Remittance window
where you have the option to print the remittance locally. Post the batch when ready.

11. If the original batch included payments for vendors with a status of Excluded or Local Processing,
those payments will remain in the original batch and continue on to print from your local printer. The
Post Payments window will automatically open and you can post those payments immediately, or at a

The ACH and Positive Pay files can also be accessed at any time within the Enhanced
ePayment Batch Maintenance window, (Mekorma Area Page > Routines > Payables >
Enhanced ePayment Batches) by choosing a batch with a status of Processed and clicking
on the File ID link. The files are also automatically stored in the base folder that contains
your ePayment communications.

*
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later time.

Last modified: Oct 23, 2019
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6.6.4. Manage Virtual Card Payments
All virtual cards, whether processed through the pre-funded or credit model, can be managed within the
Enhanced ePayment Vcard Management window. This window displays all virtual card payments, the status
of each card, and current balance. This information is automatically pulled in from the ePayment portal.

Additionally, there are a number of actions that can be accomplished to reconcile your virtual card payments
within Dynamics GP.

Virtual Card Payment Status

The status of virtual cards that have changed during the day (typically cards swiped by your vendors) will be
reported on a nightly basis. Cards can be displayed in any of the following status:

• Issued: This means the card has been issued by the virtual card company and sent to the vendor, but
the vendor has not yet “swiped” it.

• Used: A used card signifies that the vendor has received and “swiped” the card, but not for the fully
issued amount.

• Drained: means the virtual card has been used by the vendor for its fully issued amount, or the
vendor has used a partial amount and the remainder has been written off.

• Voided indicates a card that has been voided and is no longer active.

Filter your view by card status:

1. Click on the desired status or use control + click to select multiple status
2. Select Redisplay.

To open the Enhanced ePayment Vcard Management window, go to the Mekorma Area
Page > Routines > Payables > Enhanced ePayment Vcards*
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You can also use the radio buttons to filter by Checkbook ID, Payment Date, Vendor ID, Expiration Date
and Remaining Balance.

The various columns in this window give important information related to card balances and usage.

• The Payment Amount column indicates the original amount of the payment for which the virtual card
was issued.

• Amount Used displays whether the vendor has “swiped” the card, and how much it was swiped for. In
most cases, the full amount of the issued payment will appear here once used by the vendor.

• The Write-Off Amount shows the value of an unused amount that has been written off. Learn how to
write-off a remaining balance here.

• Amount Paid displays the dollar amount that has been paid to the virtual card company for cards that
have been issued to your vendors. When using the credit model, this amount will change as you
create new payments to the MEEP vendor at the end of each credit period.

Last modified: Sep 11, 2019
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6.6.4.1. Pre-Funded Virtual Cards
When processing virtual card payments with the pre-funded model, batches are sent to the ePayment service
and you are then required to provide funds to the virtual card company for all cards being issued.

How to pre-fund your virtual card payments

1. After an ePayment batch has been processed, the ePayment service sends a response to the
Enhanced ePayment Integration Batch Status window.

2. If the batch was processed successfully and contains pre-funded virtual card payments, an ACH file
that includes the sum total of all virtual cards payments within that batch will be accessible, by clicking
on the Integration Files hyperlink.

3. This opens the Enhanced ePayment Integration Files window. Click the ACH File Name hyperlink.

4. Retrieve this file and send it to your bank. Your bank will then transfer the funds to the virtual card
vendor, to cover the sum total of all virtual card payments contained within the batch.

5. When the virtual card vendor receives the funds, the cards are considered fully funded and your
vendors will then receive payment via email.

All historical ACH files can also be accessed within the Enhanced ePayment Batch
Maintenance window, (Mekorma Area Page > Routines > Payables > Enhanced ePayment
Batches) by choosing a batch with a status of Processed and clicking on the File ID link.
The files are also automatically stored in the base folder that contains your ePayment
communications.

*

Please note, if a pre-funded card is voided or unused by your vendor, the virtual card
vendor will return the funds to your company’s account.

!
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6.6.4.2. Credit Model Virtual Cards
When processing virtual card payments using the credit model, you are extended a no-cost line of credit by
the virtual card company. After batches are sent for processing, you will not be immediately charged for
issued cards (as you are when using the pre-funded model).

Instead, the virtual card company will automatically transfer payments from your company’s account on a
regularly scheduled basis, and you will only pay for the card amounts that have been “swiped” by vendors
during that credit period. This has the advantage of allowing cash to float in your account for more time.

Watch the video below to see how credit-model virtual cards are managed:

Add New Payments

Adding new payments for the virtual card vendor is an action that must be repeated on a regular basis to
reflect the automatic withdrawals the virtual card vendor makes from your account. Mekorma recommends
adding a reminder to GP reminders, or set up a scheduled task so that an automatic email is sent to the
appropriate user.

To open the Enhanced ePayment Vcard Management window, go to the Mekorma Area Page > Routines >
Payables > Enhanced ePayment Vcards

1. Open the Enhanced ePayment Vcard Management window.

2. Click on New Payments.

3. If no virtual cards have been used within the current credit period, you will receive a message that no
new payments are required.
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4. If there are new payments, the Enhanced ePayment Vcard Payment window will open. A payment
transaction is created for the combined amount of all virtual cards that have been used for that period,
paid from the checkbook designated in the Control Checkbook ID field.

5. Assign the payment to an existing batch by using the look-up for the Batch Number field, or create a
new batch, making sure it is associated with the same checkbook ID that appears in the Control
Checkbook ID field of the Vcard payment window.

6. Note that you have the option to check the box Prompt to Post on the Enhanced ePayment Vcard
Payment window. If you check this box, you will be prompted to post the batch after processing. New
Payment batches are never available for printing, as the virtual card vendor has already automatically
withdrawn the funds.

7. Click Process.

8. Confirm that you want to create the new payment.

9. Choose whether to post the batch now. If yes, the Post Payments window will open and you can click
Process to post.
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6.6.4.3. Void Virtual Card Payments
When processing payments using Enhanced Electronic Payments, a virtual card can be voided if the card
has a status of Issued (meaning it has not yet used by the vendor.)

1. Open the Enhanced ePayment Vcard Management window.

2. Find the card you want to void by using the Issued card status filter and/ or any additional filters
available in this window.

3. Click on Actions to open the drop-down menu, then select Void:

Last modified: Oct 23, 2019

To open the Enhanced ePayment Vcard Management window, go to the Mekorma Area
page > Routines > Payables > Enhanced ePayment Vcards*

Please note, after a virtual card payment has been voided in Dynamics GP, the payment
number will display a * suffix in the Vcard Management window.*
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6.6.4.4. Void ePayment Batches
On occasion, GP may be prevented from receiving a response from the ePayment service once a batch has
been sent. For example, if GP is not connected to the internet, the batch cannot be processed.

1. Open the Enhanced ePayment Batch Maintenance window.

2. Use the drop-down menu to view batches with a status of Sent, or by searching for the GP Batch
Number/ Remote Batch ID.

3. Click on the batch you want to void.

4. Choose Action > Void.

Last modified: Oct 23, 2019

Only ePayment batches with a status of Sent can be voided. Before voiding you should
confirm that the batch has definitely NOT been processed by the ePayment service by
logging in to the ePayment portal and viewing the status there.

!

To open the Enhanced ePayment Batch Maintenance window, go to the Mekorma Area
Page > Routines > Payabales > Enhanced ePayment Batches*
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6.6.4.5. Write-Off Unused Virtual Card Balance
Although rare, there may be an instance when a vendor paid via virtual card does not use the entire amount
of the issued card. In that case, you can write-off the remaining balance so your account is credited with the
unused portion.

1. Open the Enhanced ePayment Vcard Management window.

2. Filter your view by the Used status to display virtual cards have not been fully used.

3. Select the correct payment.

4. Click Actions > Writeoff. When you agree to continue, the Enhanced ePayment Vcard Remainder
Writeoff window will open.

5. A credit memo to the virtual card company will be generated, and you must assign it to an existing
batch by using the look-up, or enter the name of a new batch and create it. Be sure to associate the
batch with the checkbook from which the original card was issued.

To open the Enhanced ePayment Vcard Management window, go to the Mekorma Area
Page > Routines > Payables > Enhanced ePayment Vcards*
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6. Click Process.

7. Post the batch. The writeoff amount will then display in the writeoff amount column of the Vcard
Management window.

Last modified: Sep 11, 2019
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6.7. Use the Check Image Archive
The Check Image Archive feature allows you to view and print an image of a posted check/ EFT remittance
from the following Payables, US Payroll and Canadian Payroll windows:

• Payables Payments Zoom
• Payroll Check Inquiry
• Payroll Transaction Inquiry
• Canadian Payroll Inquiry
• Miscellaneous Check Inquiry

For instructions on how to disable or auto-display the check preview, see this page.

The Check Image Archive uses the format specified in the Copy Stub field of the Mekorma MICR Check
Printing screen at the time the check was printed. If no format was specified in the Copy Stub field, the
format in the Check Stub field will be used.

Payables check images follow the rules of Mekorma MICR check copies and do not display the MICR Line,
Signatures, or Signature Lines. They also contain the word VOID.

Access the Check Image Archive from Dynamics GP inquiry windows

1. From the Mekorma Area Page, go to Inquiry > Transaction by Vendor or Transaction by
Document.

2. Choose the applicable vendor, highlight the check number you want to zoom to, and click the
Voucher/Payment Number or Document Number hyperlinks.

3. If the Auto Show Check Inquiry Preview option is checked on the System Options screen, the
Payables Payment Zoom window will display with the check image located to the right.

4. If the Auto Show Check Inquiry Preview option is disabled, select Additional > Show Inquiry Check
Preview to display the check/ remittance image.
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5. To print the check/ remittance image, click the Print icon on the toolbar.

Access the Check Image Archive from the Mekorma Audit Log

The Check Image Archive can also be accessed directly from the Mekorma Audit Log window.

1. Open the Mekorma Audit Log.

2. Select the appropriate batch, using the filters as needed.

3. Click on the Number of Checks link.

4. Select the check or EFT payment you would like to view, and click on the Payment Number link.

5. If you have already set up your System Options to Auto Display Check Image Preview, the archived
document will automatically open to the right. Otherwise, you can open the Additional drop-down
menu and choose Show Inquiry Check Preview. This will display the check or EFT remittance.

To access the Mekorma Audit Log, go to the Mekorma Area Page > Inquiry > System >
Audit Log*
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6.8. Track Payment History with the Audit Log
Report
The Audit Log report records the details of posted check/ EFT batches, including the Approvers/
Authorizers of each batch. This feature provides an added layer of security when processing payments with
Mekorma.

1. Open the Mekorma MICR Audit Log Report window.

2. From here, you can filter your results in the following way:

• Use the Sort By drop-down list options to filter the list, then click Redisplay to view the new sort
order.

• Use the radio buttons at the top of the screen to filter on Checkbook ID, Batch ID, or Posting Date.
• Click the Print button to view the Check Audit Log Summary report.
• To drill down to check batch detail, highlight a line item and click on the No. Checks column

hyperlink. This will open the Mekorma MICR Audit Detail Log window and the details from the
selected check batch are displayed. Click the Print button to select the Check Audit Log Detail report.
Only batches currently selected are displayed on the report.

Last modified: Dec 18, 2020

To open the Mekorma MICR Audit Log Report window, go to the Mekorma Area Page >
Inquiry > System > Audit Log*

Please note, reprinted checks will display as zero dollar checks.*
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