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Why switch from the applications I currently
use?
Why switch from the applications I currently use?

If you are a long-time user of DNASTAR software, you may be wondering why you need to make the switch
to our newer applications, SeqBuilder Pro, MegAlign Pro and SeqMan Ultra.

Some of our 32-bit applications—EditSeq, PrimerSelect and MegAlign—were retired with the release of
Lasergene 16.0 in mid-2019. Since then, all development efforts and new features related to sequence
editing, primer design, and cloning are being focused exclusively on SeqBuilder Pro, while pairwise &
multiple sequence alignment efforts are being focused on MegAlign Pro. With the release of Lasergene 17.0
in early, 2020, we replaced 32-bit SeqMan Pro with SeqMan Ultra, which features a modern, intuitive
interface. For now, we are including both applications, but will be removing SeqMan Pro in a future release.

All three of the newer applications contain numerous features not found in their classic counterparts, and
provide an improved user experience and many new capabilities compared to EditSeq, PrimerSelect,
MegAlign and SeqMan Pro.

Try the new apps for yourself online.
No download necessary!

Upgrade now to access
powerful new functionality

Why a special guide just for transitioning between applications?

During our preparations to retire three 1990’s applications with the Lasergene 16.0 release in 2019, we
realized that a substantial number of Lasergene users were still using legacy versions of our applications,
despite having had 6 to 14 years in which to switch to their replacements. Are you one of these loyal
“classic app” fans? If you haven’t yet made the switch, you are in for a treat! Lasergene’s modern apps
feature sleek, intuitive and customizable interfaces and a whole new world of time-saving functionality. Click
the following links to learn how to transition from:

• EditSeq to SeqBuilder Pro
• PrimerSelect to SeqBuilder Pro
• MegAlign to MegAlign Pro
• SeqMan Pro to SeqMan Ultra
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About this User Guide:

• For help INSTALLING Lasergene, see our separate Installation Guide.

• Click here for a list of all topics that include VIDEOS.

• To PRINT the current page of the User Guide, click the printer icon in the top right corner ( ).

• To download a PDF of the entire User Guide, scroll to the bottom of the table of contents on the left,
and press Download as PDF.
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New functionality in SeqBuilder Pro,
MegAlign Pro and SeqMan Ultra
Click the bullet-pointed links below to learn about added or improved functionality in the modern application
compared to the “classic” versions. These links will take you away from this “Transitioning” guide to the
relevant User Guide topic for SeqBuilder Pro or MegAlign Pro.

SeqBuilder Pro lets you:

• Create a new sequence based on an existing sequence; among others, by using the reverse
complement, translation, or a feature, by sampling sequences* Perform virtual cloning

• Auto-annotate sequences with or without first creating a custom feature database
• Easily edit primers by using a mutation/codon change tool, by typing or by changing the primer length
• Customize the appearance of features
• Display the translation of a sequence below the original sequence
• Easily change the appearance of views and the layout of views and panels
• Change the rendering style and font
• Easily create, modify and join features, and show or hide features in the views
• Perform highly customizable agarose gel simulations
• Export a sequence in many different formats

MegAlign Pro lets you:

• Perform multiple alignments using the Clustal Omega, Clustal W, MAFFT or MUSCLE algorithms
• Perform genome-level multiple alignments with Mauve
• Perform pairwise alignments using the Smith-Waterman algorithm, or either of two variations of the

Needleman-Wunsch algorithm; then easily perform subsequent pairwise alignments using different
parameters or a different combination of sequences.

• Rename a single sequence manually, or one or more sequences automatically, using a customized
naming convention

• Analyze results in several graphic-rich views, and customize the view layout
• View details about any selection: one or more sequences, a portion of one or more sequences, one or

more tracks or features, or a portion of a pairwise alignment
• Apply detail for rulers, features, a translation, a consensus, the sequence logo, GC content or gap

fraction histograms and many more.

Note: For illustrated help showing how to perform your current EditSeq, PrimerSelect,
MegAlign or SeqMan Pro tasks in the newer applications, see the following topics in this
guide: Transitioning from EditSeq to SeqBuilder Pro / PrimerSelect to SeqBuilder Pro /
MegAlign to MegAlign Pro or SeqMan Pro to SeqMan Ultra.

*
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• Bookmark a sequence location or range of interest, so you can easily return to it later
• Export data, a phylogenetic tree, or an image of a view

SeqMan Ultra lets you:

• Seamlessly access SeqMan NGen, where you can create and build your assembly.
• Open finished assemblies for downstream analysis
• View information about the currently open assembly or about any selection.
• Work with contigs by organizing them into scaffolds, closing gaps between them and seeing contig

information in graphical or tabular views.
• Apply data tracks that provide enhanced information about the contig, consensus and reads.
• View features in graphical, tabular or text format and filter features.
• View, filter and score variants.
• Search for sequences online in NCBI’s BLAST and Entrez databases.
• Customize the appearance and behavior of views, tables and the layout itself
• Export the consensus or data from a view.
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Timeline for “classic” and modern
applications
The following timeline shows the release dates of the “classic” Lasergene applications and their modern
counterparts:

• 1988 – EditSeq was DNASTAR’s original application for creating and editing sequences and their
features.

• 1993 – PrimerSelect was DNASTAR’s original application for primer design and primer catalog
creation, while MegAlign offered pairwise and multiple sequence alignment and the creation of
phylogenetic trees.

• 2001 – With increasing popularity of the Internet, PrimerSelect, MegAlign and EditSeq were
upgraded to allow searching of NCBI’s BLAST and Entrez databases.

• 2005 – SeqBuilder was added to the Lasergene software offering for virtual cloning, PCR primer
design, plasmid map creation, and sequence editing.

• 2013 – MegAlign Pro was released with Lasergene 11.0 for multiple sequence alignments and
visualization.

• 2017 – SeqBuilder Pro was released with Lasergene 15.0 and SeqBuilder was retired. SeqBuilder
Pro featured a beautiful new interface and supported additional cloning methods and agarose gel
simulation. To smooth the transition from EditSeq and PrimerSelect, SeqBuilder Pro even featured
a button that users could press to make the interface resemble their favorite classic applications.

• 2018 – Pairwise alignment functionality was added to MegAlign Pro.

• 2019 – With the release of Lasergene 16.0 in June, EditSeq, PrimerSelect and MegAlign were
retired.

• 2020 – With the release of Lasergene 17.0 in February, SeqMan Ultra was introduced as a
replacement for SeqMan Pro. SeqMan Pro will remain in the package temporarily, but will be removed
in a later release.
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Transitioning from EditSeq to SeqBuilder Pro
As of Lasergene 16.0, SeqBuilder Pro completely replaced EditSeq. Compared to its co-predecessor,
EditSeq, SeqBuilder Pro features a modern, colorful user interface and greatly increased functionality.

This short video is an overview of the SeqBuilder Pro application:

For an illustrated comparison showing how to perform an EditSeq task in SeqBuilder Pro, click any of the
links below:

• Edit a sequence
• Trim sequence ends
• Translate a nucleotide sequence

◦ Select and edit a genetic code
• Back translate a protein sequence
• Display a sequence and its translation simultaneously
• View sequence statistics
• Work with features
• Save or export a sequence

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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Make SeqBuilder Pro resemble EditSeq

To make the SeqBuilder Pro layout look similar to EditSeq, press the Compact EditSeq Layout tool
on the left of SeqBuilder Pro’s document window. SeqBuilder Pro will display the Sequence view in the
upper half of the Document window, without spacers or rulers, and the Features view in the lower half.

EditSeq application layout:

SeqBuilder Pro application using Compact EditSeq Layout tool:
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Edit a sequence
To edit a sequence:

• EditSeq – Paste or type IUPAC characters into the sequence pane. To delete characters, use the
Backspace or Delete keys.

• SeqBuilder Pro – Paste or type IUPAC characters into the Sequence view. To delete characters, use
the Backspace or Delete keys. For more information, see the SeqBuilder Pro User Guide topic Use
editing commands.
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Trim sequence ends
To trim sequence ends:

• EditSeq – Use File > Open and press the Set Ends button, then specify cut points in that dialog.

• SeqBuilder Pro – Select a portion of an already-open sequence in the the Circular, Linear or
Sequence views and use Edit > Cut; or right-click on the selection and choose Cut. For more
information, see the SeqBuilder Pro User Guide topic Use editing commands.
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Translate a nucleotide sequence
To create a new document containing the translation of a selected portion of DNA/RNA sequence:

• EditSeq – Use Goodies > Translate DNA.

The new document looks like this:

• SeqBuilder Pro – Use Sequence > New Sequence > Translate. For more information, see the
SeqBuilder Pro User Guide topic Create a sequence based on another sequence.

The new document looks like this:
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Select and edit a genetic code
To select a genetic code:

• EditSeq – Use Goodies > Genetic Codes and choose a code from the list.

• SeqBuilder Pro – Use Sequence > Select Genetic Code and choose a code from the list. For more
information, see the SeqBuilder Pro User Guide topic Choose the genetic code.

To edit a genetic code:

• EditSeq – Use Goodies > Edit Genetic Code.

• SeqBuilder Pro – Use Sequence > Edit Genetic Code. For more information, see the SeqBuilder
Pro User Guide topic Modify the genetic code.

Though the command is in a different menu, the genetic code editor is the same for both applications.
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Back translate a protein sequence
To create a new document containing the back translation of a selected portion of protein sequence:

• EditSeq – Use Goodies > Reverse Translate Protein.

The new document looks like this:

• SeqBuilder Pro – Use Sequence > New Sequence > Back Translate. For details, see the
SeqBuilder Pro User Guide topic Create a sequence based on another sequence.
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The new document looks like this:
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Display a sequence and its translation
simultaneously
To display the translation below the nucleotide sequence:

• EditSeq – Not available.

• SeqBuilder Pro – Select part or all of the sequence, click on the Translations and ORFs ( ) tool
and choose Create Translation. For more information, see the SeqBuilder Pro User Guide topic
Translations.

The translation appears below the DNA/RNA sequence.

.
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View sequence statistics
To view sequence statistics:

• EditSeq – Use Goodies > DNA Statistics or Goodies > Protein Statistics.

• SeqBuilder Pro – Use Sequence > Statistics. For more information, see the SeqBuilder Pro User
Guide topic Sequence Statistic.
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Work with features
Many feature-related commands are the same in EditSeq and SeqBuilder Pro, including Features > New
Feature, Features > New Feature with Translation, and Features > New Translation. The EditSeq
command Features > Join Segment changes to Features > Join to Feature in SeqBuilder Pro, but
functions identically.

However, SeqBuilder Pro’s “Features” view offers feature-related functionality that is not available in
EditSeq. For instance, you can reverse the strand the feature is on, add and edit qualifier fields, change the
lengths of segments or features, select text to use as the feature name, and much more. For details, see the
SeqBuilder Pro User Guide topic Edit information about a feature.
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Save or export a sequence
To save or export a sequence:

• EditSeq offers the following options:

◦ To save in Lasergene (.seq or .pro) file format, use File > Save As.

◦ To export to Genbank (.gbk), FASTA (.fas) , or GCG (.gcg) file formats, use File > Export .

◦ To export multiple sequences into a single file with a Genbank (.gbk), FASTA (.fas or .fap) , or
DNA Multiseq (.mseq) file format, use File > Export all as one.

• SeqBuilder Pro offers the following options:

◦ To save in SeqBuilder Pro (.sbd), Lasergene (.seq or .pro), GenBank (.gbk), FASTA (.fas or
.fap), ABI (.abi) or EMBL (.embl) file formats, use File > Save As. For details, see the
SeqBuilder Pro User Guide topic Save.

◦ To export sequences in .sbd, .seq, .gbk, .embl, or .fas. formats, use File > Export Sequence(s)
From Project. For details, see Export sequences to a file.

◦ To export sequences to GenVision (.gnv) format, use File > Export As GenVision Project. For
details, see Export sequences to GenVision.
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Transitioning from PrimerSelect to
SeqBuilder Pro
As of Lasergene 16.0, SeqBuilder Pro completely replaced PrimerSelect. Compared to its co-predecessor,
PrimerSelect, SeqBuilder Pro features a modern, colorful user interface and greatly increased functionality.

This short video is an overview of the SeqBuilder Pro application:

For an illustrated comparison showing how to perform an PrimerSelect task in SeqBuilder Pro, click any of
the links below:

• Trim sequence ends
• Locate primers
• View dimers, pair dimers and hairpins
• View general primer statistics
• View information on primer composition and amplfication
• Edit primers
• Import primers from a catalog
• Nominate new primers to a catalog
• Save a primer catalog
• Select and edit a genetic code

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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Make SeqBuilder Pro resemble PrimerSelect

To make the SeqBuilder Pro layout look similar to PrimerSelect, press the Primer Design Layout tool
on the left of SeqBuilder Pro’s document window. SeqBuilder Pro will display the Primer Design view in the
upper half of the Document window, and the Primers view in the lower half.

PrimerSelect application layout:

SeqBuilder Pro application using Primer Design Layout tool:
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Trim sequence ends
To trim sequence ends:

• PrimerSelect – Use Conditions > Sequence Positions and Limits. In the dialog box, choose either
Manually or From Feature Table to open another dialog in which you can specify the cut points.

• SeqBuilder Pro – Select a portion of an already-open sequence in the the Circular, Linear or
Sequence views and use Edit > Cut; or right-click on the selection and choose Cut. For more
information, see the SeqBuilder Pro User Guide topic Use editing commands.
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Locate primers
To locate primer pairs automatically:

Both the classic and modern applications provide multiple ways to find primers, but there are subtle
differences between the commands. The images show the results of using each command when the same
sequence feature is selected in each of the applications. A short video is available at the bottom of this
topic.

• PrimerSelect – To search both template strands for primers or probe sequences meeting specified
conditions, use Locate > Primers & Probes (left image). To limit the search to only primers contained
with the “primer catalog,” use Locate > Only Catalogued Primers. To search for compatible pairs
required for PCR amplification, use Locate > PCR Primer Pairs (right image).

• SeqBuilder Pro – For detailed information on primer design, see the SeqBuilder Pro User Guide topic
Primers. In brief, to create pairs based around a selected feature or a sequence range, use Priming >
Create Primer Pairs to open an options dialog (left image). Select the desired options and click OK to
display the list of primer pairs (right image).

Transitioning to Newer Applications - 17.0

Copyright DNASTAR, Inc. 2020 Page 24 of 93

https://www.seqbuilderpro.com/support/topic/primers


To locate forward & reverse primers separately based around a selected feature or a sequence range,
use Priming > Create Forward Primer or Priming > Create Reverse Primer or the corresponding
right-click commands. Both options are only available after using Priming > Create Primer Pairs at
least once. (In the image below, note the already-found primers to the left of the current selection.)

The following video is a brief introduction to primer design in SeqBuilder Pro. For another video on the
same topic, see: Primer Design in SeqBuilder Pro.
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View dimers, pair dimers and hairpins
To view information about dimers, pair dimers, hairpins, and false priming sites:

• PrimerSelect – Do either of the following:

◦ Select a primer pair and choose Report > Primer Self Dimers, Report > Primer Pair Dimers,
and/or Report > Primer Hairpins

◦ Use Edit > Work on Upper Primer or Edit > Work on Lower Primer to display the primer
Workbench. Then use the tools on the left to display self-dimers, hairpins and/or false priming
sites.
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• SeqBuilder Pro – This information is displayed automatically in the Primer Design view. To learn how
to interpret this information, see the SeqBuilder Pro User Guide topic Primer Design view.
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View general primer statistics
To view general statistics about located primer pairs:

• PrimerSelect – Use Report > Located Primers & Probes to open a window with these statistics.

• SeqBuilder Pro – Primer statistics are displayed automatically in the Primers view. To learn how to
interpret this information, see the SeqBuilder Pro User Guide topic Primers view.
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View information on primer composition and
amplification
To view information about primer composition and amplification:

• PrimerSelect – Select a primer pair and choose Report > Amplification Summary or Report >
Composition Summary.

• SeqBuilder Pro – Double-click on a primer in the Primer Design view to view its composition statistics
in the Details panel. For more information, see the SeqBuilder Pro User Guide topic Details panel.
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Amplification information is not available in SeqBuilder Pro.
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Edit primers
To edit primers:

• PrimerSelect – Use Edit > Work on Upper Primer or Edit > Work on Lower Primer. Drag the black
triangles left or right to change the size and location of the primer.

• SeqBuilder Pro – In the Primer Design view, either A) drag the black triangles left or right to change
the size and location of the primer; or B) use the mutation/codon change tool to select a silent or non-
silent mutation for any codon in the primer. For more information, see the SeqBuilder Pro User Guide
topic Edit primers.
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Import primers from a catalog
To import primers from a primer catalog:

• PrimerSelect – Use File > Open and change the file type to Primer Catalog (.pri). After opening a
file with a .pri extension, the primer catalog is displayed as a list.

• SeqBuilder Pro – After entering a sequence, use File > Import Primers from a Catalog and select a
file with a .pri extension. SeqBuilder Pro attempts to locate each primer in the catalog on the current
sequence by searching for sites on the template that match at least the 12-mer at the 3’ end of the
primer. Those that are found are annotated as PCR_primer features and added to the Primers view. If
primers were located, a message confirming the new primers will appear.

Otherwise, a message appears stating “There were no priming sites discovered.” For details on
importing primers, see the SeqBuilder Pro User Guide topic Import primers.
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Nominate new primers to a catalog
To nominate new primers to an unsaved primer catalog:

• PrimerSelect – Use File > Enter New Primer and type in the primer information. After clicking OK,
the primer is added to the primer catalog, which is displayed with the new entry. To view the catalog
at any other time, choose Log > Primer Catalog.

• SeqBuilder Pro – Before saving a catalog (below), ensure that only primers you wish to save are
displayed in the Primers view.
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Save a primer catalog
To save the primer catalog:

• PrimerSelect – Use File > Save. When prompted, choose Save Catalog.

• SeqBuilder Pro – Use File > Save Primer Catalog to save the primer catalog in .txt, .fas or .pri
format. For details, see the SeqBuilder Pro User Guide topic Export primers.
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Select and edit a genetic code
To select a genetic code:

• PrimerSelect – Use Options > Genetic Codes and choose a code from the list.

• SeqBuilder Pro – Use Sequence > Select Genetic Code and choose a code from the list. For more
information, see the SeqBuilder Pro User Guide topic Choose the genetic code.

To edit a genetic code:

• PrimerSelect – Use Options > Edit Genetic Code.

• SeqBuilder Pro – Use Sequence > Edit Genetic Code. For more information, see the SeqBuilder
Pro User Guide topic Modify the genetic code.

Though the command is in a different menu, the genetic code editor is the same for both applications.
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Transitioning from MegAlign to MegAlign Pro
As of Lasergene 16.0, MegAlign Pro completely replaced MegAlign. Compared to its predecessor,
MegAlign, MegAlign Pro features a modern, colorful user interface and greatly increased functionality.

This short video is an overview of the MegAlign Pro application:

For an illustrated comparison showing how to perform an MegAlign task in MegAlign Pro, click any of the
links below:

• Edit a sequence
• Trim sequence ends
• Rename a sequence
• View sequence information
• Translate or back translate a sequence

◦ Select and edit a genetic code
• Perform a pairwise alignment

◦ View pairwise alignment results
• Perform a multiple alignment

◦ View multiple alignment results
◦ View sequence distances
◦ View phylogenetic tree
◦ Create a subalignment

• Find a position
• Locate gaps and disagreements
• Copy and export
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Edit a sequence
To edit a sequence:

• MegAlign – After entering sequences, select a sequence and use File > Send Sequence to
SeqBuilder Pro. Edit the sequence and save it in SeqBuilder Pro to automatically update it in
MegAlign. There is no need to reload the sequence into MegAlign.

• MegAlign Pro – Sequences must be manually opened in SeqBuilder Pro and edited there before
entering them in MegAlign.

Transitioning to Newer Applications - 17.0

Copyright DNASTAR, Inc. 2020 Page 39 of 93



Trim sequence ends
To trim sequence ends:

• MegAlign – Use Options > Set Sequence Limits > From Feature Table (left) or Options > Set
Sequence Limits > By Coordinates (right)

• MegAlign Pro – Sequences must be manually opened in SeqBuilder Pro and edited there before
entering them in MegAlign.
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Rename a sequence
To rename a sequence:

• MegAlign – Click for about two seconds on the name of the sequence to allow editing. Then type in a
new name.

• MegAlign Pro – There are two options for renaming sequences: a manual option, and an automatic
option that can rename all selected sequences simultaneously using a specified naming convention.

◦ To manually rename a selected sequence, choose Edit > Rename. For details, see the
MegAlign Pro User Guide topic Rename sequences manually.

◦ To rename one or more selected sequences using specified data fields, use Edit > Rename
with Fields. For details, see the MegAlign Pro User Guide topic Rename sequences
automatically based on specified data fields. The left pane shows available fields, and the right
pane shows fields that will be displayed as part of the sequence name. Initially, Default name
is the only field listed in the right pane. An example showing the appearance of the name using
the specified field(s) appears in the Example box at the bottom of the dialog. Select and
organize the fields you wish to display as part of the sequence name
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View sequence information
To view information about a selected sequence:

• MegAlign – Use View > Sequence Information.

• MegAlign Pro – Do either or both of the following:

◦ Select a sequence in any view to display its information in the Details panel. To learn more
about this panel, which varies according to the current selection, see the MegAlign Pro User
Guide topic Details panel.
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◦ Use the Tracks panel to apply tracks to the sequence in the Overview and/or Sequences view.
For details, see the MegAlign Pro User Guide topics Tracks panel and Tracks. Track types vary
according to whether the sequence is nucleotide or protein, and whether the sequence is part of
a pairwise or multiple assembly, or is still unassembled. Tracks may include information about
GC content, gap fraction, protein translation, or Sashimi data.
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Translate or back translate a sequence
To translate or back translate a sequence:

• MegAlign – Use the Show as DNA ( ) and Show as Protein ( ) tools to toggle between how
sequences are displayed on the Worktable. Each command is applied to all sequences on the
Worktable.

• MegAlign Pro – To display a translation of a nucleotide sequence in MegAlign Pro, use the Tracks
panel to apply the Translation track. For details, see the MegAlign Pro User Guide topic Translation
track.

To instead use the translated or back-translated version of a sequence in a MegAlign Pro alignment,
first open the sequence in SeqBuilder Pro and change it there there, Then enter the revised sequence
in MegAlign.
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Select and edit a genetic code
To select a genetic code:

• MegAlign – Use Options > Genetic Codes and choose a code from the list.

• MegAlign Pro – You can choose an alternate genetic code only when mapping features from one
sequence to another using Features > Map Features. In the Options screen, check the box next to
Override genetic code, then select the desired code from the drop-down list. See the MegAlign Pro
User Guide topic Options screen for details.

To see feature mapping in action, see the video Copying annotations between genomes.

To edit a genetic code:

• MegAlign – Use Options > Edit Genetic Code.
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• MegAlign Pro – Not available.

Transitioning to Newer Applications - 17.0

Copyright DNASTAR, Inc. 2020 Page 47 of 93



Perform a pairwise alignment
To perform a pairwise alignment:

• MegAlign – Select two sequences in the Worktable and use Align > One Pair > Wilbur and Lipman,
Align > One Pair > Martinez-NW, Align > One Pair > Lipman-Pearson, or Align > One Pair >
DotPlot. In the ensuing dialog, make any desired changes to alignment parameters.

• MegAlign Pro – Select two sequences any view and use Align > Pairwise or press the Align tool (

) and select Align Pairwise. In both cases, a dialog opens in which you can select the desired
alignment type (Local: Smith-Waterman, Global: Needleman-Wunsch or Semi-Global:
Needleman-Wunsch) and make any changes to alignment parameters. For details, see the MegAlign
Pro User Guide topic Perform a Pairwise Alignment.

The following brief video is an overview of pairwise alignment in MegAlign Pro.
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View pairwise alignment results
To view pairwise alignment results

• MegAlign – Depending on the pairwise alignment method used, results open automatically in the
Alignment or DotPlot views.

• MegAlign Pro – Results open in the Pairwise view, whose appearance is controlled by the Style
panel’s Pairwise Alignment section. Tracks, if present, are controlled by which tracks have been
checked in the Tracks panel. If desired, use the drop-down menus and tools in the top of the view to
open additional Pairwise alignment using different combinations of sequences and alignment
methods. For more information, see the MegAlign Pro User Guide topics Pairwise view / Pairwise
Alignment section and Tracks.
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For a brief introduction to using the Tracks panel, see the following video:
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Perform a multiple alignment
To perform a multiple alignment:

• MegAlign – Select the sequences to align and use Align > By Jotun Hein Method, Align > By
Clustal V Method, or Align > By Clustal W Method. To change parameters prior to alignment, use
Align > Method Parameters, choose the tab of interest and make changes, then press the Now
button.

To edit a multiple alignment, select a portion of sequence in the Worktable and use the Straighten

Columns ( ), Shuffle Right ( ) or Shuffle Left ( ) tools.

• MegAlign Pro – Select the sequences to align and use Align > Align Using Clustal Omega, Align >
Align Using Clustal W, Align > Align Using MAFFT, or Align > Align Using MUSCLE.

Alternatively, press the Align tool ( ) and choose the option of the same name. To change
alignment options, instead use Align > Align with Options or press the Align tool and choose the
option of the same name. Select the desired method using the drop-down menu, then edit the settings
and press Align. For more information, see the MegAlign Pro User Guide topic Perform an initial
multiple alignment.
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The following brief video is an overview of multiple alignment in MegAlign Pro.

Additional videos highlighting multiple alignment functionality in MegAlign Pro include: Merging and
realigning sequences, Aligning genomes using Mauve and Aligning multi-segment files.
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View multiple alignment results
To view multiple alignment results:

• MegAlign – Use View > Alignment Report.

• MegAlign Pro – Results are displayed in the Overview and Sequences view, whose contents and
appearances are controlled through the Style panel’s Overview and Sequence sections,
respectively. Tracks, if present, are controlled by which tracks have been checked in the Tracks
panel. For more information, see the MegAlign Pro User Guide topics Overview / Overview section,
Sequences view / Sequence section, and Tracks.
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For a brief introduction to using the Tracks panel, see the following video:
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View sequence distances
To view multiple alignment results:

• MegAlign – Use View > Sequence Distances.

• MegAlign Pro – Results are displayed in the Distance view, whose contents and appearance are
controlled through the Style panel’s Distance section. For more information, see the MegAlign Pro
User Guide topics Distance view / Distance section.
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View phylogenetic tree
To view multiple alignment results:

• MegAlign – Use View > Phylogenetic Tree. The appearance and calculations used in this window
are controlled via the tools on the left.

• MegAlign Pro – Results are displayed in the Tree view, whose contents and appearance are
controlled through the Style panel’s Tree section. For more information, see the MegAlign Pro User
Guide topics Tree view / Tree section.
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The following short video shows how to create and edit phylogenetic trees in MegAlign Pro.
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Create a subalignment
To create a subalignment:

• MegAlign – After performing a multiple alignment, select a portion of the consensus sequence in the
Worktable and use Align > Create Alignment From Selection. After choosing a name for the new
project, the subalignment is opened in a new MegAlign project window.

• MegAlign Pro – After performing a multiple alignment, display a Consensus track and select a
portion of the consensus sequence in the Sequence view. Then use Align > Realign
Subsequences. Choose the desired alignment type and parameters, then press Align. The results
are shown in the current MegAlign Pro project rather than in a new project window. For more
information, see the MegAlign Pro User Guide topic Subalign sequences.
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Find a position
To find a position:

• MegAlign – Use Edit > Go To Position.

• MegAlign Pro – Use Edit > Go To (Pairwise) Position (left). For more information, see the MegAlign
Pro User Guide topic Search. To return to a sequence location or range you have visited before, use
the Places panel (right), discussed in the topic Places panel.

The following video shows how to bookmark favorite locations using the Places panel:
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Locate gaps and disagreements
To find gaps or areas of disagreement in an alignment:

• MegAlign – Use Edit > Find Disagreement and choose whether to search for a disagreement or a
gap

Or, to make facets of the alignment stand out in the Alignment Report, add one or more decorations to
the Worktable using Options > New Decoration.

• MegAlign Pro – Use the Style panel’s Pairwise Alignment or Multiple Alignment sections to
specify how to display similarities or differences. See the MegAlign Pro User Guide topics Pairwise
Alignment section and Multiple Alignment section for details.
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Copy and export
To copy a sequence:

• MegAlign – To copy any selected text as it appears in a view, use Edit > Copy. To copy part or all of
the consensus sequence after performing an alignment, select the sequence range and use Edit >
Copy Consensus.

• MegAlign Pro – To copy any selected text as it appears in a view, use Edit > Copy. To copy the
selected text or data in FASTA format, use Edit > Copy As FASTA. For details, see the MegAlign Pro
User Guide topic Copy, Paste and Delete.

To export a sequence:

• MegAlign – Use File > Export Sequences to export selected sequences from the Worktable or File
> Export Consensus to export the consensus sequence from the Worktable. Files can only be
exported to Lasergene DNA (.seq) or protein (.pro) format.

• MegAlign Pro – Use any of over a dozen commands to export data to a number of formats. Among
many other choices, you can export all the sequences (File > Export Data > Sequences), or data
from the Distance view (File > Export Data > Distance Matrix) or Tree view (File > Export Data >
Tree). For more information, see the MegAlign Pro User Guide topics Export data to a file and Export
a tree to a tree viewer.

To export an image:

• MegAlign – Not available.

• MegAlign Pro – To export an image showing the contents of a view, use File > Export Image >
(View Name). For details, see the MegAlign Pro User Guide topic Export an image of the view. Once
you have exported the image, you can edit it in PowerPoint as shown in this brief video:

Transitioning to Newer Applications - 17.0

Copyright DNASTAR, Inc. 2020 Page 66 of 93

https://www.dnastar.com/manuals/MegAlignPro/topic/copy-paste-and-delete
https://www.dnastar.com/manuals/MegAlignPro/topic/export-data-to-a-file
https://www.dnastar.com/manuals/MegAlignPro/topic/export-a-tree-to-a-tree-viewer
https://www.dnastar.com/manuals/MegAlignPro/topic/export-a-tree-to-a-tree-viewer
https://www.dnastar.com/manuals/MegAlignPro/topic/export-an-image-of-the-view


<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a

Transitioning to Newer Applications - 17.0

Copyright DNASTAR, Inc. 2020 Page 67 of 93



Transitioning from SeqMan Pro to SeqMan
Ultra
SeqMan Ultra was introduced in Lasergene 17.0 as the modern replacement for SeqMan Pro, now
considered a legacy application. Both applications will be included in Lasergene for a short time, but we
strongly encourage all users to switch to SeqMan Ultra as soon as possible.

SeqMan Ultra is a 64-bit application, which means faster project opening, better performance for analyzing
large files, increased capacity, and compatibility with macOS 10.15. Compared to its predecessor, SeqMan
Pro, SeqMan Ultra features a modern, colorful user interface and greatly increased functionality.

For an illustrated comparison showing how to perform a SeqMan Pro task in SeqMan Ultra, click any of the
links below:

• Get acquainted with the SeqMan Ultra interface
• Create a new assembly
• Open an existing assembly
• Select and work with contigs
• View contigs, consensuses and reads graphically
• View and work with features
• View and work with variants
• View information about a project or selection
• Search for sequences online
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Get acquainted with the SeqMan Ultra
interface
SeqMan Ultra uses the same type of graphic user interface as DNASTAR’s MegAlign Pro, GenVision Pro,
SeqNinja, Protean 3D and SeqBuilder Pro. This style of interface has one or more large “views” on the left,
and a narrower set of expandable “panels” on the right. The panels are used for specifying the appearance
of the views, selecting what is included in the views, showing details about a selection, etc.

We think you’ll find the new SeqMan Ultra interface to be very intuitive. However, we would like to highlight
a few items that might not be readily apparent.

Changing the layout and number of views:

• SeqMan Pro – Views, tables and reports appear as separate windows that can be resized manually.

• SeqMan Ultra – Graphic, tabular and text data is each contained in a named “view.” You can display
from 1-3 views at a time. To specify the number and layout of views, use the View > Change layout
command or the Change layout tool (image varies) in the bottom right corner of each view. The
following options are available:
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◦ One – – To show only the current view and cause it to occupy all of the view “real
estate.”

◦ Two Horizontal ( ) – To show the current view on top and one additional view
below it.

◦ Two Vertical ( ) – To show the current view on the left, and one additional view
to the right.

◦ Three Horizontal ( ) – To show the current view on top and two additional
views below it.

◦ Three – Left ( ) – To show the current view on the left and two additional views
stacked one on top of the other on the right.

◦ Three – Right ( ) – To show the current view on the right and two additional
views stacked one on top of the other on the left.

◦ Three – Top ( ) – To show the current view on the top and two additional views
side-by-side on the bottom.

◦ Three – Bottom ( ) – To show the current view on the bottom and two
additional views side-by-side on the top.

Changing parameters:

• SeqMan Pro – Assembly and display parameters are changed using Project > Parameters.
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• SeqMan Ultra – Assembly parameters are now specified during project setup in SeqMan NGen.
Display customization is now handled through the Style panel and Tracks panel.
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Remaining parameters are accessed through Project > Project Parameters.
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Create a new assembly
Creating a new assembly:

• SeqMan Pro – Launch the application. If you have closed all the windows in the document—use File
> New. Then add files, change any options, and press Assemble.

• SeqMan Ultra – Launch the application and click New Assembly.

Select a workflow from the list to launch the SeqMan NGen wizard with the workflow already selected.
Follow the wizard prompts and choose to assemble locally or on the cloud.Once the assembly is
finished, you will see options for downstream analysis, including opening the assembly in SeqMan
Ultra.
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Open an existing assembly
Opening an assembly:

• SeqMan Pro – Use drag & drop, the File > Open command or the File > Recent Documents
command. Only one assembly at a time can be open.

• SeqMan Ultra supports all of the methods listed above, but supports multiple assemblies by having a
different tab for each assembly. In addition, SeqMan Ultra features a “Welcome” tab. By pressing this
tab and then pressing Open Assembly, you can open an assembly at any time, even if you already
have other assemblies open.
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Select and work with contigs
Selecting, renaming, scaffolding, and reordering contigs:

In both applications, contigs and scaffolds appear in a table. The functions above can be accomplished by
typing into a table cell, or by using menu commands or right-click commands. The main difference is the
location of the table.

• SeqMan Pro – The table appears in the Project Summary window:

• SeqMan Ultra, it appears in the Explorer panel on the upper right of the SeqMan Ultra window. If not
visible, click on the Explorer tab to bring it to the front or use View > Explorer:
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View contigs, consensuses and reads
graphically
Viewing contigs and constituent sequences graphically:

In both applications, graphical information about contigs and constituent sequences is shown in the
Alignment and Strategy views.

• SeqMan Pro – These views are accessed using Contig menu commands or by double-clicking on a
contig in the Project Summary window.

• SeqMan Ultra – The views are accessed using View menu commands, by double-clicking on an item
in the Explorer panel or by clicking the view tools to the right of the Explorer panel.

New features in SeqMan Ultra include the ability to:

◦ Open and compare views for two or more contigs simultaneously. For instance, you could open
the Alignment view for Contig 3 and Contig 7 and compare them side-by-side.

◦ Use the Tracks panel to specify which data tracks to generate. These can include items such as
the consensus translation, consensus and read features, rulers, trace data; and coverage, split
read and pair consistency graphs. Within the views, you can then choose whether to show or
hide the tracks using the plus/minus sign to the left of each track. You can also reorder tracks
by dragging them to the desired position and dropping them there.

Transitioning to Newer Applications - 17.0

Copyright DNASTAR, Inc. 2020 Page 78 of 93



◦ Customize track color schemes, fonts, spacing, and much more using the Style panel.
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View and work with features
Viewing and working with features in a graphical display:

• SeqMan Pro – Reference or consensus features are displayed by default in the Strategy view and by
expanding the arrow next to the reference sequence name in the Alignment view.

• SeqMan Ultra – Feature “tracks” for the reference, consensus, or individual reads can be displayed or
hidden from the Alignment and Strategy views using the Tracks panel.

Viewing and working with features in a tabular display:

• SeqMan Pro – Open the Features table by selecting a contig in the Project window and choosing
Features > Show Feature Table. Table columns can be added or removed by right-clicking on the
table and choosing Show/Hide Column. The types of features included in the table are controlled
using Feature menu commands. Additional commands from this menu let you add new features or
edit existing features.

• SeqMan Ultra – Open the Features view by selecting a contig in the Explorer panel and choosing
View > Features or by using the tool to the right of the Explorer panel.

From within the Features view, table columns can be added or removed using the “gear” tool in the
top right of the view.
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As in SeqMan Pro, the types of features included in the table are controlled using Feature menu
commands. Unlike in SeqMan Pro, SeqMan Ultra does not yet support creating or editing features.
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View and work with variants
Viewing and working with variants in a graphical display:

• SeqMan Pro – Variants are displayed as colored nucleotides in the Alignment view, and can be
spotted more easily using Variant > Show Variants.

• SeqMan Ultra – Variants can be displayed in the Alignment view using a variety of foreground and
background color schemes. These displays are customized using the Style panel.

Unlike SeqMan Pro, SeqMan Ultra provides a fast method of moving from one variant to the next
along the sequences. Start by clicking the magnifying glass tool in the upper right of the Alignment
view:
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From the Search menu, choose Variant; then use the green arrows to search for variants upstream
and downstream of the current cursor position.

Viewing and working with variants in a tabular display:

• SeqMan Pro – Open the Variants table by selecting a contig in the Project window and choosing
Variant > Variant Report. Table columns can be added or removed by right-clicking on the table and
choosing Show/Hide Column. The types of features included in the table are controlled using the
Filter button. SNPs can be marked as putative/confirmed/rejected by clicking in the SNP column.

• SeqMan Ultra – Open the Variants view by selecting a contig in the Explorer panel and choosing
View > Variants or by using the tool to the right of the Explorer panel.

As in SeqMan Pro, SNPs can be marked as putative/confirmed/rejected by clicking in the SNP
column.

From within the Variants view, table columns can be added or removed using the “gear” tool in the top
right of the view.
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To filter variants shown in the view, use the “filter” tool in the top right of the view to open a filter
dialog.
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View information about a project or selection
Viewing project reports:

• SeqMan Pro – Use the Project > Statistics, Project > Summary, Project > Report or Project >
Trim Report commands.

• SeqMan Ultra – Use the View > Project Overview, View > Project Details or View > Trimming
commands. Once any of the reports is open, you can also open a different report by selecting it from
the drop-down menu on the top left of the view.

Viewing details about a selection:

• SeqMan Pro – This functionality does not exist.

• SeqMan Ultra – Make a selection (e.g. a feature, read, range of sequence, track, etc.) and see a
definition or other information in the Details panel. The Details panel may also include Action links
that act as shortcuts to additional functions.
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Order contigs and close gaps for de novo
assembly
To order contigs and close gaps in a de novo .sqd assembly:

• SeqMan Pro – Provides a primer walking feature (Contig > Primer Walk) to locate primers that can
drive the closure of gaps or to fill in low coverage areas. Results appear in the Alignment view and the
Primer Walking report.

• SeqMan Ultra – Uses a three step process to create an enhanced template that can be used in future
SeqMan NGen assemblies.

1. Order contigs into scaffolds using Contig > Order Contigs or Contig > New Scaffold.

2. Look for BLAST sequence matches using Search > Search.

3. Use Contig > Add Sequences to Close Gap to align a sequence match with the existing
assembly to close a gap between two contigs.

For step-by-step instructions, watch the video below or see this help topic.
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<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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Search for sequences online
Searching for sequence matches using BLAST or text matches using Entrez:

• SeqMan Pro – Use Net Search > BLAST Selection to search NCBI’s BLAST database for a
sequence match; or Net Search > New Text Search to search NCBI’s Entrez database for a text
match. Once the search is complete, use the buttons at the top of the search window or additional
commands in the Net Search menu to add matches to the project, save them, etc.

• SeqMan Ultra – Use Search > Search for BLAST or Search > Search for Text In for Entrez. In both
cases, a Search wizard opens. Customize the search as needed, then click Run or Run Now to
initiate the search.

Monitor the progress of the job in the Jobs panel.

When the search results are ready to review, a link will appear in the Status column. Clicking the link
opens a new window containing the Text, Table and Pairwise views. Search results are available in
the Job panel for 7 days, and (as shown above), a warning message shows when results will expire.
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The Table view is similar to the BLAST Search Results window in SeqMan Pro and shows the match
as a graphic histogram.

The Text view provides the same information and additional information in text format.

The Pairwise view allows you to compare a match to the consensus by aligning them pairwise.
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