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Welcome to SeqBuilder Pro
SeqBuilder Pro is Lasergene’s application for sequence editing and map creation, as well as plasmid auto-
annotation, automated virtual cloning and primer design. Easily navigate between synchronized views with a
click of a button, and rearrange views and toolbars by simply dragging and dropping them where you want
them to be.

The following video is a brief walk-through of the SeqBuilder Pro application.

These support pages contain written help and tutorials, as well as video tutorials.

• For help INSTALLING Lasergene, see our separate Installation Guide.

• For written TUTORIALS with free data, see SeqBuilder Pro Tutorials.

• Click here for a list of all topics that include VIDEOS.

• To PRINT the current page of the User Guide, click the printer icon in the top right corner ( ).

• To download a PDF of the entire User Guide, scroll to the bottom of the table of contents on the left,
and press Download as PDF.

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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SeqBuilder Pro Tutorials
SeqBuilder Pro tutorials are typically located in the table of contents just under the help topic they are
designed to illustrate. For convenience, all tutorials are also listed below.

Primer tutorials:

• Create and modify primers for TA cloning

Cloning tutorials:

• Gateway cloning
• MultiSite Gateway Pro cloning
• Gibson cloning with a custom vector
• PCR-directed restriction cloning
• Use a PCR insert in TA cloning

Restriction enzyme tutorials:

• Apply a restriction enzyme to the sequence
• Find restriction sites on either side of a feature

Miscellaneous tutorials:

• Open an Entrez sequence by accession number
• Create and modify a feature
• Create a style set for CDS features (for plasmid auto-annotation)
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Windows, Views, Panels and Tools
The Document window opens when you open a nucleotide or protein sequence or a SeqBuilder (.sbd)
document. This is the window where you can edit the sequence or add/edit features, restriction enzymes,
ORFs, translations and/or rulers to the sequence.

• On the left of the window is a group of shared button tools.

• The main/center portion of the window contains two view panes, each showing a different view.
Depending on the active sequence, views may include: Circular, Linear, Sequence, and Primer
Design, Features, Primers, Comment, Minimap, Site Summary or History.

• The right side of the window consists of four panels: Style, Enzymes, Settings and Details.

The following video is a general overview of the SeqBuilder Pro windows and panels:
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Document window views
The following video contains a short tour of each of the Document window views:

To change from one view to another:

Click the tab with the name of the desired view.

By default, the upper portion of the window lets you choose any of 1-4 views, depending whether the
sequence is nucleotide or protein. Views may include: Circular, Linear, Sequence, and Primer Design. The
default view is Circular or Linear, depending on the sequence type. The lower portion of the window lets you
choose any of 2-6 views, also depending on the sequence type. Views may include: Features, Primers,
Comment, Minimap, Site Summary and History.

To display a “lower pane” view on the upper pane, or vice versa:

Use the mouse to drag and drop the view tab at the new location.

To toggle between displaying one or two views:

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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Use View > Split or View > Remove Split.
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Circular view
The Circular view is one of the ten views available in the Document window, and shares a sub-set of button
tools with the other views. To make it the active view (or one of two active views), click on the Circular tab (

).

The Circular view is only available for nucleotide sequences, and displays a circular map of the current
sequence. The default view shows any restriction enzymes on the outside of the circular map and features
on the inside, with title and sequence length in the center.
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Linear view
The Linear view is one of the ten views available in the Document window, and shares a sub-set of button
tools with the other views. To make it the active view (or one of two active views), click on the Linear tab (

).

The Linear view is only available for nucleotide sequences, and displays a linear map of the current
sequence. The default view shows restriction sites above and feature graphics below the linear map. If you
attempt to view a circular sequence in the Linear view, note that ORFs and restriction sites that cross the
origin will be impacted.
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Sequence view
The Sequence view is one of the ten is one of the ten views available in the Document window, and shares
a sub-set of button tools with the other views. To make it the active view (or one of two active views), click

on the Sequence tab ( ).

The Sequence view displays the detailed, residue-level sequence display. By default, the display contains:

• For protein sequences – The protein sequence and a ruler.

• For nucleotide sequences – The top strand DNA sequence, a ruler, and any annotations except
“Source.”
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Primer Design view
The Primer Design view is one of the ten is one of the ten views available in the Document window, and
shares a sub-set of button tools with the other views. It also has its own set of tools.

To make it the active view (or one of two active views), click on the Primer Design tab (
).

The Primer Design view lets you design and analyze primers for a nucleotide sequence. Data in the Primer
Design view appears in a header (featuring tools and details about the primers) and three distinct panes
below that header. See Work with Primers for detailed information about performing tasks within this view.

Sequence details in the header:

Details about the primers, if any, are displayed in the header of the Primer Design view, just to the right of
the tools.

Selection/
Position

The current position of the cursor. If a range is selected, the length of the range and strand
(forward or reverse) is specified, along with the sequence coordinates.

Working
Pair The name of the currently selected primer pair.

Forward The length and melting temperature of the forward primer. This value is updated automatically if
settings are changed.

Reverse The length and melting temperature of the reverse primer. This value is updated automatically if
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settings are changed.

Sequence
Length The total length of the sequence. This value is shown in the top right corner of the header.

Residue pane:

Displays the base level nucleotide sequence, restriction sites, translations, and features, as well as the
currently selected primer sequence. This pane can be used to modify your primers.

Once you have done this, a green arrow represents the forward strand primer; red indicates the reverse
strand primer. Primer sequences are displayed in 5’ to 3’ orientation, and include modifications that you
have made. Edited nucleotides appear in lowercase.

Mispriming pane:

Shows primer binding sites, and the most stable conformation of dimers, pair dimers, and hairpins, if they
exist. As the current primer pair is changed, the information displayed in the Mispriming Pane is updated
automatically.

At the top of this pane, Primer Binding Sites displays where the primer binds to the template as well as
any additional sites the primer may bind to on either strand. Any sites on the template matching at least the
12-mer at the 3’ end of the primer are displayed. Primers on the top strand are indicated in green; primers
on the reverse strand are shown in red.

Beneath Primer Binding Sites, the most stable conformation of dimers, pair dimers, and hairpins are
shown, if they exist. To calculate this, SeqBuilder Pro locates secondary structure interactions using the
nearest-neighbor model for all three types of duplexing. For self and pair dimer duplexing, oligonucleotide
sequences are compared at every potential overlapping position by aligning sequences and advancing one
residue at a time.

• Most stable dimer - Displays the primer binding to itself in the most stable conformation, if there is
one.

• Most stable pair dimer - Displays the primer binding to the opposite strand primer in the most stable
conformation, if there is one.

• Most stable hairpin - Displays the primer binding to itself by folding in the most stable conformation,
if there is one.

Note: If the word BAD! appears in red, it indicates that the final pentamer value of the dimer*
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Alternate pairs pane:

Displays the list of primer pairs discovered by your search, along with additional information for each pair,
including product length, melting temperatures, and a quality score. The following information is displayed in
columns for each pair:

Name/Abbrev. Description

Pair Name The name of the primer pair.

Score The quality score assigned to the primer pair.

Prod Tm The melting temperature of the product.

Pri DTm The difference in melting temperature between the primers in the pair.

Ta OPT The optimal annealing temperature for the primer pair.

Prod dTm The difference in melting temperature between the product and the lower primer Tm*.*

Length The length of the product.

exceeds the 3’ pentamer stability threshold defined in the Primer Characteristics section of
the Create Primer Pairs dialog. The Ignore Duplexing n bp from 3’ parameter also affects
duplexing. Avoid using primers with dimers or hairpins labeled “BAD!” unless you have
experimental evidence that they will function as desired, or if you have no other option.
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Primer Design tools
The following tools are located in the upper right of the Primer Design view:

Tool Description

Selection
Mode

To enable selection of a region of sequence using the mouse. After selecting this tool, click on a
translated amino acid to select its codon. Click and hold on a restriction enzyme to show the cut
sites, represented by thin blue lines. Click and hold on a restriction enzyme while holding down
the Alt (Win) or Option (Mac) key to show the cut represented by bold black arrows, as well as
the recognition sequence.

Introduce
Restriction
Site

To introduce a restriction site into the sequence. After selecting this tool, click between the
residues where the restriction site should be added, and choose an enzyme from the list provided.
The restriction enzymes identified to cleave the sequence at your specified location will be
organized into 3 groups: Silent substitutions, Non-silent substitutions, and Introduce a stop.

Introduce
Codon
Change/
Mutation

To introduce a mutation into your sequence. After selecting this tool, the cursor will highlight each
codon as you hover over the sequence. Click the codon of interest to display a list of alternate
codons available for a silent mutation, as well as a list of alternate amino acids available for non-
silent mutations. Selecting an alternate amino acid will replace the sequence via the least
disruptive alternate codon.

Show Top
Primer
Strand To change the focus of the Residue Pane to the top primer. The Mispriming Pane is updated

automatically to reflect the associated primer.

Show
Bottom
Primer
Strand To change the focus of the Residue Pane to the bottom primer. The Mispriming Pane is updated

automatically to reflect the associated primer.
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Quality score calculation
SeqBuilder Pro assigns a quality score for each primer pair it identifies. These scores are displayed in the
Alternate Pairs pane of the Primer Design view.

The following considerations are made when determining the primer pair quality score:

• The distance of each primer from its respective end.

• Each primer’s melting temperature in relation to the Target Tm.

• The number of false priming sites for each primer.

• Whether or not a primer is located in a repeated region.

• Uniqueness at the 3’ end of the primer.

• Internal repetitiveness of the primer.

• The stability profile of the primer.

• The length of most stable dimer.

• The length of most stable hairpin.

Each of the above characteristics is assigned a score. The individual scores are then combined and
normalized to a range from 0 to 1, where 1 is the best possible score. The primer pairs are sorted from
highest to lowest by score and displayed in the Alternate Pairs Pane.
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Features view
The Features view is one of the ten views available in the Document window, and shares a sub-set of button
tools with the other views. To make it the active view (or one of two active views), click on the Features tab

( ).

The Features view displays a table of features (annotations) that have previously been identified in the DNA
or protein sequence. Features may be user-defined, or they may be part of the input file from GenBank or
from other Lasergene applications. For information on creating, editing or deleting features, see Features.

The following table describes how to perform various tasks within this view:

Task How to…

To select one or more
features in all graphical
views

Single click on one feature row; or select multiple features using Ctrl/
Cmd+click, Shift+click, or by dragging the mouse across the desired rows.
Selected features are simultaneously selected in the Circular and Linear
views.

To select the feature and its
corresponding sequence,
and to scroll to its location

Double-click on a compacted feature row or select the feature row and
choose Feature > Select Sequence.

To expand/contract a feature
row

Click a plus icon to expand the row and show details about the feature; click a
minus icon to hide feature details. As a shortcut, you can use Ctrl/Cmd+Alt
to toggle between expanding/contracting all rows.

To edit feature information Expand a row, as described above. Insert your cursor in a field and type the
desired information.

To sort data alphabetically
within a column Click on the column header.

To see the number of the
features in total, the number
visible, and the number
selected

Look at the footer at the bottom left of the view.
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Columns in the Features view are described below:

Column
name Description

Rows with a checkmark in this column denote a feature that is currently visible in the graphical
views (Circular, Linear, Sequence). To hide a feature, click its checkmark.

/ See “To expand/contract a feature row” in the table above.

Type The feature type.

Name The feature display name.

Range The range of the sequence included in the feature.

Strand The strand where the feature is located (forward or reverse ).

Length The length of the feature in base pairs.

Description Often the contents of the first /note qualifier.
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Primers view
The Primers view is one of the ten views available in the Document window, and shares a sub-set of button
tools with the other views. To make it the active view (or one of two active views), click on the Primers tab (

).

The Primers view is available for nucleotide sequence only, and displays tabular results from primer
searches, including the primer sequence and its length, product (for primer pairs), melting temperature, and
free energy (ΔG). For information on creating, editing or deleting primers and primer pairs, see Work with
Primers.

A checkmark next to a primer pair indicates that it is the currently selected pair. Select a row to also select
that primer pair in the graphical views (Circular, Linear, Sequence). The table supports selection of groups
of primer pairs using Ctrl/Cmd+click, Shift+click, or by dragging the mouse across the desired rows.

The table below describes each of the columns in the Primers view.

Column Description

Show
A checkmark in this field denotes a feature that is currently visible in the Primer Design view, as
well as the other graphical views (Circular, Linear, Sequence). To hide a feature, click its
checkmark.

Active A bullet point in this field indicates that the pair is the currently selected pair in the current working
set. The current pair is always displayed in the Primer Design view.

Set Name
The name of the set. One set is created for each primer search. By default, SeqBuilder Pro assigns
a generic name, like Set 1, Set 2, etc. However, this field is editable so that you can assign a more
descriptive name for the set of primers, if desired.

Pair
Name

The name of the primer pair. By default, SeqBuilder Pro assigns a generic name, like Pair 1, Pair
2, etc. However, this field is editable so that you can assign a more descriptive name for your
primer pair, if desired.

F/R An F in this column indicates that the primer is found on the forward (top) strand of the template
sequence; an R indicates that it is on the reverse (bottom) strand.

Primer
Sequence

For primer pairs, the sequences are shown for both members of the pair, forward strand followed
by reverse strand. For primers, the sequence of the primer is shown in the 5’ to 3’ orientation, and
is editable. Changes made to the primer sequence are automatically reflected in the Primer Design
view.

Length For primer pairs, this value indicates the length (in bp) of the PCR product. For primers, it indicates
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the length (in bp) of the primer.

Tm

For primers, the melting temperature of the primer is displayed. For primer pairs, 3 different values
are listed:

* L: The length of the product.

* Tm: The melting temperature of the product.

* dTm: The melting temperature difference between the product and the lower primer Tm.

* TaOPT: The optimal annealing temperature for the primer pair.

* dG: The delta-G value, free energy, that is computed over of the whole primer. Note that the dG
value is only calculated for individual primers, not primer pairs.
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Comment view
The Comment view is one of the ten views available in the Document window, and shares a sub-set of
button tools with the other views. To make it the active view (or one of two active views), click on the

Comment tab ( ).

The Comment view displays any descriptive text associated with a sequence; for example, the header text
of a GenBank entry. Comments are optional, and not all sequences have them. To edit a comment, insert
the cursor anywhere and edit as desired. You may type in new text, delete existing text, or paste in text from
the clipboard.
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Minimap view
The Minimap view is one of the ten views available in the Document window, and shares a sub-set of button
tools with the other views. To make it the active view (or one of two active views), click on the Minimap tab (

).

The Minimap view is available only for nucleotide sequence and displays a smaller version of the current
sequence. The Minimap is scaled to show the whole sequence in a single line. Each row in this view shows
where a particular restriction site falls along the sequence.

Because the entire sequence is shown in a single line, the font size in this view tends to be quite small. To
enlarge the font size, use the command Format > Size > Larger one or more times.
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Site Summary view
The Site Summary view is one of the ten views available in the Document window, and shares a sub-set of
button tools with the other views. To make it the active view (or one of two active views), click on the Site

Summary tab ( ).

The Site Summary view is only available for nucleotide sequences and displays a table of restriction sites
and their locations on the sequence. This view shows any restriction sites that were chosen for display in
this or another pane. The current position of the cursor appears in the upper left corner of the view.

The table contains a row for each restriction enzyme currently applied to the sequence. Enzymes that have
no cut sites all appear in a single row.

Column
Name Description

Name Enzyme name

Frequency Number of cutting sites

Position Specific cutting locations for the enzyme. Use the Settings panel to specify whether to display or
hide the fragment length in parentheses to the right of the enzyme position.
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The default font size in this view tends to be quite small. To enlarge the font size, use the command Format
> Size > Larger one or more times.
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History view
The History view is one of the ten views available in the Document window, and shares a sub-set of button
tools with the other views. To make it the active view (or one of two active views), click on the History tab (

).

The History view is empty until one of the following happens:

• You accept suggested annotation matches in the Annotation Results window. In this case, the view
displays a list of the accepted annotations.

• You perform a cloning simulation and open any of the resulting files (i.e., entry clones, inserts,
expression clones) in the SeqBuilder Pro Document window. In this case, the History view displays
the Cloning Summary.
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In the event that both of the above apply, the History view shows both cloning and annotation results. Newer
results are appended underneath earlier results.

If you would like to remove all information from this view, choose View > Clear History. You will be
prompted to confirm your decision.
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Gel Simulation view
The Gel Simulation view is available in the Document window after using the File > New Agarose Gel
command. By default, the view contains eight empty lanes and has a 10 cm width and 7 cm height., but
these parameters can be changed as desired. The following image shows how the view appears before
setting up a gel simulation. The view contains a ruler on the left, and lane numbers at the top of each empty
lane and in the status bar (i.e., the header).

After setting up the gel simulation, the header shows the marker(s), enzyme(s) and/or primer(s) that have
been applied to each lane. A ladder icon is used to represent a marker, a “gel” icon to represent an enzyme,
and green/red primer arrows to represent a primer pair.

The following table shows tasks pertaining to the Gel Simulation view.

Task How to…

Specify the number of
lanes, size of the gel,
percent agarose and
run time

Use the Settings panel.

Apply markers,
enzymes, and primer
pairs

See Agarose Gel Simulation.
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Select a lane Click on the lane number header, or click anywhere in the lane.

View information about
what has been applied
to the lane

Hover the mouse over the status bar above that lane to reveal a tooltip.

View information about
a band or fragment size
notation

Hover the mouse over it to reveal a tooltip.

Select a fragment and
its range on the
sequence

Click on a band. The fragment is shown in red, and the footer is populated with
information about the selection. Any fragment from the same sequence as the
selected fragment, and which overlaps the selected fragment in any way, will appear
in blue.
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Fragment Sizes view
The Fragment Sizes view is available in the Document window after using the File > New Agarose Gel
command. The view initially appears empty, or may contain one or more faintly outlined boxes.

After setting up an agarose gel simulation, the view is populated with columns, each representing a lane in
the Gel Simulation view. Fragment lengths are shown in base pair (bp) units. The column headers show the
marker(s), enzyme(s) and/or primer(s) that have been applied to each lane.

The following table shows tasks pertaining to the Fragment Sizes view.

Task How to…

Select a lane Click anywhere in the lane.

View information
about what has
been applied to
the lane

Hover the mouse over the lane to reveal a tooltip.

Select a fragment
and its range on

Click on a fragment size notation. The fragment is shown in red, and the footer is
populated with information about the selection. Any fragment from the same sequence as
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the sequence the selected fragment, and which overlaps the selected fragment in any way, will appear in
blue.
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Document window panels
The right side of the Document window consists of four panels: Style, Enzymes, Settings and Details.

To display/hide the panels:

Choose View > Show/Hide Side Panels or use the Show/Hide Settings tool ( ) on the left of the
Document window.

To move a panel from the upper part to the lower part of the window, or vice versa:

Each panel has an tab labeled with its name. Drag the tab up or down using the mouse. When you see a
“shadow,” drop the tab and the panel will snap into the new position.

To undock and redock the panels:

To undock, use the mouse to hover at the top of the associated frame. When the cursor changes to a
4-pointed arrow, drag the frame to the desired position. To redock, follow the same procedure, moving the
frame near its original position. When a “shadow” appears, as shown in the image below, drop the frame
and it will snap into position
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Style panel
The Style panel, represented by a paint roller icon ( ), provides the ability to change the appearance of a
currently selected item in the Document window.

Open the Style panel using any of these methods:

• Click on the Style tab to bring that panel to the front. If the tab is hidden, reveal it by clicking the

Show/Hide Settings Panel tool ( ) on the left of the Document window.

• Right-click on a feature and choose Edit Feature Style from the context menu.

• Select a feature and choose Features > Edit Feature Style.

To learn about functions that can be performed in this panel, see Change the rendering style or font.
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Enzymes panel
The Enzymes panel varies depending on which views are active. For detailed information, see:

• Enzymes panel for agarose gel simulations

• Enzymes panel for other situations
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Enzymes panel for gels
A specialized version of the Enzymes panel becomes available after you use File > New Agarose Gel to
initiate an agarose gel simulation. It can be opened by clicking on the Enzymes tab, represented by a

scissors icon ( ) and located to the right of the Gel Simulation view.

This version of the panel differs from the standard Enzymes panel in three ways:

• A Clear button appears at the top right of the panel.

• A “drag & drop” icon is added to the right of each enzyme.

• There is no Enzyme cuts checkbox under the enzyme list.

For detailed information about using the specialized Enzymes panel to apply and remove enzymes from
lanes in the Gel Simulation view, see Apply or remove enzymes in the Gel Simulation view.
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Enzymes panel for other situations
The Enzymes panel, represented by a scissors icon ( ), lets you choose which enzymes to display/hide
in the following Document window views : Circular, Linear, Sequence, Primer Design, Minimap and Site
Summary. This panel is one of two ways to display/hide restriction enzymes. See Enzymes for in-depth
information.

The Enzymes panel opens automatically when you click on the Enzymes tool ( ) and choose Pick
Specific Enzymes. It can also be opened manually by clicking on the Enzymes tab, located by default in
the top right portion of the Document window. If the tab is hidden, reveal it by clicking the Show/Hide

Settings tool ( ) on the left of the Document window.

For detailed information about using the Enzymes panel to apply and remove enzymes from the views, see
Show or hide enzymes in other views.
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Settings panel
The Settings panel varies depending on which views are active. For detailed information, see:

• Settings panel for agarose gel simulations

• Settings panel for other situations
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Settings panel for gels

When performing an agarose gel simulation, the Settings panel, represented by a gear icon ( ), is
located on the lower right of the Document window. This panel lets you change properties of the simulated
agarose gel displayed in the Gel Simulation view.

The Settings panel is only available after using the File > New Agarose Gel command, and can then be
accessed by clicking on the Settings tab.

• Brand – Use this drop-down menu to choose the gel manufacturer.

• Type – Use this drop-down menu to select the “model” of gel from the Brand manufacturer. The
choice made here affects the lane layout, which includes the next three settings below.

• Lanes – By default, the number of lanes is determined by the selections made in Brand and Type.
However, you can type in a different value, if desired.

• Combs – When using agarose gels, combs are plastic inserts with teeth, each the width of one lane.

Note: When not performing an agarose gel simulation, the Settings panel has different
options, which are described in Settings panel for other situations.*
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The spaces between the teeth are equal to the spaces between the lanes. By default, the number of
combs in the Settings panel is determined by the selections made in Brand and Type. If desired, you
may type in a different value. Numbers greater than 1 cause duplicate sets of lanes to appear in the
Gel Simulation view.

• Area – By default, the area of the gel is determined by the selections made in Brand and Type.
However, you can type in any desired Width and Length, in cm.

• % Agarose – The concentration of agarose controls the distance that fragments propagate in a given
time. A higher concentration causes fragments to slow down. Therefore, to resolve larger DNA
fragments, use a lower % Agarose, and vice versa. By default, % Agarose is set to “1.00.” If desired,
make another selection from the drop-down menu.

• Run Time – Use the slider to select a run time between 1-180 minutes. Or type in a number to define
a run time of any length.

• Blur – Check this box to slightly blur the bars in the Gel Simulation view, more closely approximating
the look of a lab-produced gel. This option is checked by default.

• Smile – Check this box to make the bars in the Gel Simulation view take on a slight “smile” shape,
more closely approximating the look of a lab-produced gel. This option is checked by default.

• Reticle at mouse – Check this box to add a blue line that travels vertically with the mouse as it
hovers over lanes in the Gel Simulation view. This option is unchecked by default.
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Settings panel for other situations

The Settings panel, represented by a gear icon ( ), is located on the right of the Document window and
lets you display or hide various components of some of the views on the left.

The Settings panel can be opened by clicking on the Settings tab. If the tab is hidden, reveal it by clicking

the Show/Hide Settings tool ( ) on the left of the Document window.

Circular Map - Use the checkboxes to choose whether to show/hide the Title and Length of the sequence
in the center of the Circular view. To change the title text, type new text into the box provided. An alternate
way

Primer Design - Use the checkboxes to specify whether to show/hide Priming Sites, Alternate Pairs, and

Note: When performing an agarose gel simulation, the Settings panel has different options,
which are described in Settings panel for gels.*
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the most stable Dimer, Hairpin and/or Pair Dimer in the Primer Design view.

Site Summary - Use the checkbox to show/hide the Fragment Size in the Site Summary view table. When
shown, the size appears in parentheses to the right of the enzyme position.

Translations – The table lists any translations created in the Sequence view using the Create Translation
command.

Task How to…

To show/
hide a
partial
translation

Add/remove the checkmark from its row

To
change
the name
of the
partial
translation

Type the desired text in the Name column

To specify
the
starting
number
for the
partial
translation
ruler

Type a number into the Start column.

To toggle
between
including/
excluding
the zero
coordinate

Click the cell in the Skip 0 column. When numbering a partial translation from the negatives into
the positive values, the Skip 0 functionality lets you specify whether to include or exclude the zero
coordinate. Protein chemists often number the mature peptide starting with one. In cases where a
signal peptide precedes the mature peptide and the signal peptide gets cleaved in the final product,
a common convention is to number those residues negatively, counting back from the mature
peptide. Since this is an arbitrary convention, and the coordinates do not actually go from left to
right, the zero coordinate is usually skipped. In combination, Start and Skip 0 give you the ability to
create such a numbering.
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Details panel
The Details panel, represented by a blue “information” icon ( ) displays information about an active view
or selection in the Document window. The Details panel can be opened by clicking on the Details tab. If the

tab is hidden, reveal it by clicking the Show/Hide Settings tool ( ) on the left of the Document window.

• If nothing is selected, the panel displays links to help you get started in SeqBuilder Pro. Click on the
links to watch a training video or open a recent document.

• When any portion of the sequence is selected, including the entire sequence, the panel shows the
following information:

• ◦ Selection – Whether the selection is on the forward or reverse strand and the endpoints of the
selection.

◦ Length – The length of the selected region in base pairs.

• If a single feature is selected and represents a gene or CDS, the panel displays an analysis of the
protein. In other situations, it displays the base composition. Among other dinucleotides, the analysis
table may include the %CG dinucleotide. This dinucleotide is relevant to mammalian biology, as it is
methylated in cells and clusters of CG are associated with certain types of promoters.
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• ◦ The Feature Information section is compiled from annotations included in the sequence when
it was opened (e.g., a Genbank file); or added later using SeqBuilder Pro’s Features view).

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 44 of 302



◦ The Statistics table contains mathematical calculations performed by SeqBuilder Pro.

• If multiple features are selected, the panel contains information about how many features are selected
and how many are currently visible in the view.

The Selection table contains information calculated by SeqBuilder Pro:

• ◦ Number of features – The total number in the project.

◦ Selected – The number of features currently selected.

◦ Visible – The number of features in the selection that have a checkmark in the Show column

◦ CDS – The number of CDS features in the current selection.

◦ mat_peptide – The coding sequence for the mature protein product following post-translational
modification. Does not include a stop codon. “All (#)” means that all Features of that type are
selected. This information is useful when making global changes by Feature type.

◦ sig_peptide – The signal peptide coding sequence. “All (#)” means that all Features of that
type are selected. This information is useful when making global changes by Feature type.

• When one or more enzymes are selected (e.g., in the Site Summary View view), the panel displays
the name of each selected enzyme, along with a portion of sequence showing its cut sites on the top
and bottom strands.
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Sequences panel
The Sequences panel, represented by a circular sequence icon, lets you choose which sequence to use
when performing an agarose gel simulation.

This panel is enabled only after you use the File > New Agarose Gel command. Sequences that were open
in the Document window or selected in a Project window prior to using this command will appear in the
panel.

If no sequences were open, the panel will appear empty.

To add sequences to the panel:

Use any of the following methods. Note that multiple sequences can be added to the panel, though only one
can be used for the simulation.

• Click the plus sign in the bottom left of the panel. Select the file of interest and press Open.

• Select a sequence and choose File > Import (Sequences to Project). Select the file of interest and
press Open.

• Right-click anywhere in the panel and choose Import (Sequences to Project). Select the file of
interest and press Open.

• Drag and drop a file from your file explorer onto the panel.

To remove sequences from the panel:

Use any of the following methods:

• Select a sequence by clicking on its name, then press the minus sign in the lower left of the panel.
When prompted to confirm, click OK.
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• Select a sequence by clicking on its name, then choose Edit > Cut.

• Right-click on the sequence and choose Cut or Delete.

To add a sequence to a lane in the Gel Simulation view:

Do any of the following:

• Drag a sequence from the Sequences panel and drop it in a lane in the Gel Simulation view.

• Select a lane in the Gel Simulation view, then put a checkmark next to a sequence in the Sequences
panel.

• Select an empty lane in the Gel Simulation view, then add a sequence to the Sequences panel, as
above. The first sequence added will be applied to the selected lane.

In each case, the sequence is applied in linear fashion to the gel in the Gel Simulation view, running the full
width of the gel. If you select a different sequence, the previous sequence will become deselected.

Note: If you attempt to remove a sequence that is being used in the agarose gel simulation,
you will receive a warning message.*
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Primers panel
The Primers panel, represented by a green/red arrow icon, lets you choose which primer pairs to apply to a
lane in the Gel Simulation view.

The Primer panel becomes available only after you initiate an agarose gel simulation using the File > New
Agarose Gel command.

If you performed at least one primer pair search prior to beginning the agarose gel simulation, the primer
pair(s) are listed here in an expandable tree.

If you did not perform a primer pair search this panel is empty, and cannot be populated. Note that unpaired
primers are not supported in agarose gel simulations.

To apply a primer to a lane in the Gel Simulation view, either:

• Select a lane in the Gel Simulation view, then put a checkmark next to one or more primer pairs in the
Primers panel to add them to the selected lane. To check multiple primer pairs, hold down the Shift
key while making selections. If the Shift key is not held down, any new primer pair selection will
replace the previous selection. If you add a primer in error, use Edit > Undo primer choice to revert
the lane to its previous state.

• Use the mouse to grab a primer pair in the Primers panel, then drag it and drop it in the desired lane
in the Gel Simulation view.
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Markers panel
The Markers panel, represented by a ladder icon, lets you choose which molecular weight marker to apply
to a lane in the Gel Simulation view.

The Markers panel becomes available only after you initiate an agarose gel simulation using the File > New
Agarose Gel command.

Expand the file tree as needed to locate the marker of interest from an extensive list of commercially-
available markers or custom markers. Any custom markers created using the procedure further down this
topic are located in a folder called User.

To apply a marker to a lane in the Gel Simulation view:

The marker is typically applied to the first lane but may be applied to any desired lane.

• Use the mouse to drag the marker from the Markers panel and drop it in a lane in the Gel Simulation
view.

• Select a lane in the Gel Simulation view and then go to the Markers panel and check the box next to
the marker you wish to add.

If you added a marker in error, use Edit > Undo marker choice to revert the lane to its previous state.
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To create a custom marker:

Common custom markers include digests of Lambda, phiX174, pBR322, and pUC19, but you can add any
custom marker using this procedure.

1. Click the plus sign in the bottom left of the panel.

2. Type in a Title for the marker.

3. Type each Fragment Size on a separate line.

To add a line, click the plus sign icon. To delete a line, select it and click the minus sign icon.

4. When all information has been entered, save and close the marker by clicking on the red ‘x’ in the
corner.

The marker now appears at the bottom of the Markers panel in a folder called User.

To edit a custom marker at a later time:

1. Select the marker from the User folder.

2. Press the pen & paper icon in the bottom left of the Markers panel.
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3. Follow the directions above to change the title or fragment sizes.

To remove a custom marker from the panel:

Select a custom marker in the Users folder by clicking on its name. Then press the minus sign in the lower
left of the panel. When prompted to confirm, click OK.
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Shared button tools
The Document window features a set of shared button tools. Tools apply to the currently-active view, and
different subsets of the tools are available for different views.

By default, the shared button tools are located on the left side of the window. However, the set of tools can
be repositioned as desired.

Tool Descriptions

Strand To choose whether to show the sequence for the Top Strand, or for Both top & bottom strands.
(Sequence and Primer Design views only)

Enzymes To choose which group of restriction enzyme cut sites to display on the sequence, if any. Use
None if you don’t wish to display any cut sites.

Translations
and ORFs

To choose whether to display translation Reading Frame(s) (Sequence and Primer Design
views only), ORFs (open reading frames; Linear and Sequence views only), or Primer Product
Coding Frames (after choosing primers in the Primer Design view). Each of these options has
a sub-menu for displaying the translation for All or No Frames, only Top or Bottom frames, or
one specific frame. To create a translation for only the selected portion of the sequence, choose
the Create Translation command (called a “partial translation” in SeqBuilder 14.1 and earlier).

Rulers To choose whether to have No Rulers, a ruler for the Sequence, Translation, or Both.
Choosing Translation Ruler or Both causes a translation of the sequence to appear, along with
the sequence. (Sequence and Primer Design view only)

Vertical
Spacing

To choose the amount of spacing between view components. Use Vertical Spacing spreads to
add some empty space between the components of the view. Choose No Vertical Spacing to
make the view more compact.

Show/Hide
Settings
Panel To toggle between displaying/hiding the panels on the right of the Document window.

Compact
EditSeq
Layout To display the Sequence view in the upper half of the Document window, without spacers or

rulers, and the Features view in the lower half.

Full
Sequence
Layout

To display the Sequence view in the upper half of the Document window, with both strands, all
features, translations for all frames, and both rulers displayed. The Features view appears in the
lower half of the window.

Primer
Design
Layout

To display the Primer Design view in the upper half of the Document window, and the Primers
view in the lower half.
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Default
Layout

To display the Circular, Linear, or Sequence view (depending on the sequence type and length)
in the upper half of the Document window, and the Features view on the lower half. SeqBuilder
respects the detected sequence type (linear vs. circular) unless the sequence is over 100 kbp,
in which case the default is to display the Sequence view.

Range To activate the Range utility. Once the tool is active, use your mouse to select a sequence
range in the view.

Zoom In To activate the Zoom In utility. Once the tool is active, click one or more times on the view to
zoom in.

Zoom Out To activate the Zoom Out utility. Once the tool is active, click one or more times on the view to
zoom out.

To undock/redock the tools from the Document window:

To undock the tools, hover the mouse near the top of the tool column. When the cursor changes to a
4-pointed arrow, drag the tools to the desired position

To re-dock the tools, follow the same procedure, moving the tools near their original position. When a
“shadow” appears, as shown in the image below, drop the tools and they will snap into position
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Project window
The Project window is a single- or multi-tabbed window that launches in the following situations:

• Choosing File > New Project
The window opens with an unpopulated folder named New Folder in the Project tab.

• Choosing File > New Cloning Project
The window opens with two unpopulated folders named Inserts and Vectors in the Project tab.

• Choosing one of many Cloning menu commands
The window opens with two unpopulated folders named Inserts and Vectors in the Project tab. The
Clone and Summary tabs are visible on the right.

• Making any selection from the Tools menu (available in version 15.1 and later)
The window opens with three folders named New Folder, Sequences and Results in the Project tab.
The Options and Script tabs are visible on the right.

• Saving and reopening a project that utilized the Project window.

Each Project window tab is described below. Note that only 1-3 tabs will be visible in a given workflow.

Project tab:

Task How to…
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To display/hide the
contents of each folder Click the plus/minus signs on the left.

To add a file to a folder Select the folder, then right-click on it and choose Import

To rename a sequence or
folder Select the sequence or folder, then right-click on it and choose Rename.

To export a sequence Select the sequence, then right-click on it and choose Export

To open a file in the
Document window

Double-click on any sequence. Linear sequences open in the Linear view, while
circular sequences open in the Circular view.

Clone tab:

When designing a virtual clone, this tab prompts you to select the cloning method, choose a vector; digest
or linearize the vector (if needed); and begin the cloning simulation.

Summary tab:

When designing a virtual clone, this tab displays the Cloning Summary, which can be reviewed prior to
completing the simulation. The Cloning Summary provides details about the components of the cloning
simulation, including fragment inserts, primers, and the steps needed to prepare the vector and amplify
inserts. It also displays the reading frame around all fragment junctions graphically, allowing you to verify
whether promoters and genes are in synchrony.
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Options tab:

When batch editing sequences, this tab lets you select options to use. For instance, when translating a
group of sequences, you can choose which genetic code to use.

Script tab:

When batch editing sequences, this tab lets you see the script (“program”) being used in the procedure.
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Find a sequence in the Project window
To find a sequence in the Project window :

1. Select Edit > Find.

2. Specify the search criteria as follows:

• ◦ Search sequence names for: To search for sequences whose names contain the text input in
this text box.

◦ Search bases for: To search for sequences containing the sequence string input in this text
box.

◦ Search feature list for: To search for sequences containing a feature whose name or title tag
matches the text in this text box.

◦ Search sequences of shape: Check Circular, Linear or both.

◦ Search sequence of type: Check DNA, RNA, and/or Protein, and only sequences that match
one of the checks will be found.

3. When you are done selecting criteria, click Find All.

Any matching sequences will be displayed in the Search Results tab of the Project window. You may work
with the sequences in this tab as you would with any cloning project. However, while in this view, you may
not rename the sequences or use the File > Import or Edit > Paste commands.

To return to the full view, click on that tab at the top of the project window. Alternatively, right-click on a
sequence and choose Show in Project to switch back to that sequence.
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Sequence Editing and Annotation

Did you arrive here by selecting the DNASTAR Navigator workflow Molecular Biology > Sequence
editing and annotation? If so, you’re in the right place!

SeqBuilder Pro lets you single or batch-edit DNA, RNA and protein sequences and add or edit features. For
detailed information, see these topics:

• Sequence editing
◦ Create a new sequence
◦ Open an existing sequence
◦ Use editing commands
◦ Select an object or range
◦ Go to a location on a sequence

• Create sequences based on other sequences (batch editing)
◦ …by translating one or more sequences
◦ …by joining multiple sequences together
◦ …from specified features in another sequence
◦ …by exporting sequences into a single file
◦ …by sampling (filtering) a group of sequences to choose ones of special interest
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Sequence editing
The following video is a brief overview of sequence creation and editing in SeqBuilder Pro.

The following topics are related to sequence editing:

• Create a new sequence

• Open an existing sequence

• Use editing commands

• Select an object or range

• Go to a location on a sequence

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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Create a New Sequence
The following video is a brief overview of sequence creation and editing in SeqBuilder Pro.

To create a new DNA or protein sequence from scratch:

1. Choose the appropriate menu command or keyboard shortcut.

• ◦ DNA: File > New DNA or Ctrl/Cmd+N.

◦ Protein: File > New Protein, Alt+N (Win), or Option+N (Mac).

2. Using the keyboard, type in the new sequence using the appropriate IUPAC codes.

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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To create a new sequence related to a currently-open sequence:

1. (optional) Choose a portion of sequence (e.g., by clicking on a feature). Otherwise, the entire
sequence will be used.

2. Use the options in the Sequence > New Sequence sub-menu to create a new sequence project that
uses the selection (or the entire sequence) as a starting point.

Menu option Description

Note: To activate all of the options in the sub-menu, you must first select all or part of the
open sequence.*
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Translate

To open the translation of the currently selected nucleotide sequence as a new, unnamed
SeqBuilder protein project. The currently selected genetic code is used in the translation. If the
range of sequence to be translated was selected by clicking on a feature, then the /codon_start
qualifier for that feature will be used to determine the starting frame of the translation, and the
feature name will be used to determine the name of the translated sequence. For information on
using translations with features, see Edit information about a feature.

Back
Translate

To open the back-translation of the currently selected protein sequence as a new, unnamed
SeqBuilder Pro nucleotide project. The currently selected genetic code is used in the back
translation.

Forward To open a copy of the currently selected nucleotide sequence as a new, untitled SeqBuilder
Project.

Reverse To open the reverse of the currently selected nucleotide sequence in a new, untitled SeqBuilder
Pro window.

Reverse
Complement

To open the reverse complement of the currently selected nucleotide sequence in a new,
untitled SeqBuilder Pro window.

New Origin
To open a copy of a circular nucleotide sequence in a new, untitled SeqBuilder Project, but with
the current position or selection as the origin. Warning: If the sequence is linear, this command
will append upstream nucleotides to the downstream end, thereby yielding an incorrect result.

Additional topics of interest:

• IUPAC codes
• Use editing commands
• Select an object or range
• Go to a location on a sequence
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IUPAC codes
IUPAC codes for amino acids:

1-Letter Code 3-Letter Code Amino Acid

A Ala Alanine

B Asx Aspartic Acid or Asparagine

C Cys Cysteine

D Asp Aspartic Acid

E Glu Glutamic Acid

F Phe Phenylalanine

G Gly Glycine

H His Histidine

I Ile Isoleucine

J Xle Leucine or Isoleucine

K Lys Lysine

L Leu Leucine

M Met Methionine

N Asn Asparagine

O Pyl Pyrrolysine

P Pro Proline

Q Gln Glutamine

R Arg Arginine

S Ser Serine

T Thr Threonine

U Sec Selenocysteine

V Val Valine

W Trp Tryptophan

X Xaa Unspecified or unknown

Y Tyr Tyrosine

Z Glx Glutamic Acid or Glutamine

IUPAC codes for nucleotides:
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Symbol Description Bases Represented

A adenosine/adenine A

C cytidine/cytosine C

G guanosine/guanine G

T thymidine/thymine T

U uridine/uracil U

W weak A T

S strong C G

M amino A C

K keto G T

R purine A G

Y pyrimidine C T

B not A C G T

D not C A G T

H not G A C T

V not T A C G

N or - any base (not a gap) A C G T

The non-standard nucleotide codes “I” (Inosine) or “X” (xanthine) are not supported.*
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Open an Existing Sequence
SeqBuilder Pro is so powerful that you can import the entire human genome or as many as 5,000 bacterial
genomes into a single SeqBuilder project file (.sbp).

The following topics describe three ways to open an existing sequence:

• Open a file stored on your computer

• Open a sequence from SeqBuilder Pro’s Project window

• Open a sequence from an online database (e.g., NCBI’s BLAST or Entrez databases or Vector NTI)

Click here for a list of supported file formats.
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Open a local sequence
To open a local sequence file:

Choose File > Open or use the keyboard shortcut Ctrl/Cmd+O to open a nucleotide or protein sequence. If
the sequence shape (circular or linear) is not defined in the file, SeqBuilder Pro will assume the sequence is
linear.

Note that SeqBuilder Pro can also open .structure files from DNASTAR’s Protean 3D protein structure
application, but the residue numbering may be different in the two applications. SeqBuilder Pro always
numbers sequence residues starting at ‘1.’ By contrast, Protean 3D uses residue numbering provided by the
author of the experimental structure. In addition, if there are gaps or extra residues in the .structure
sequence, then features mapped to the version of the file in SeqBuilder Pro will not be synchronized with
features in Protean 3D. Because of these differences, any edits made in SeqBuilder Pro can be saved for
later viewing in SeqBuilder Pro. However, these edits will not appear if the .structure document is reopened
in Protean 3D.

To open a local sequence file containing multiple sequences:

Choose File > Open. In the ensuing dialog, select one or more files using click, Shift + click or Ctrl/Cmd +
click, and then press OK. Each selected sequence will open as a separate SeqBuilder Pro document.

To send an open file from another Lasergene application to SeqBuilder Pro:

Select the sequence and use File > Send Sequence To > SeqBuilder Pro. SeqBuilder Pro is one of
several Lasergene applications that support “synchronous updating.” This means that changes made to a
sequence in one application (e.g. SeqBuilder Pro) are also applied to the sequence in the other application.
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To batch import pre-2008 Vector NTI files:

Select File > New Project and then drag and drop the Vector NTI files (DNA .gb; protein .gp; or database
archives .ma4 and .pa4) onto the Document window. A separate SeqBuilder Project will be created for each
file. SeqBuilder Pro only supports pre-2008 Vector NTI files, and does not support newer files, including
those from Vector NTI Express.

To import one or more sequences into an existing project:

Select File > Import Sequence(s) to Project. Importing creates a full copy of each imported file that is not
related to the original file.

To re-open a recently-opened document:

Note for Macintosh users: Vector NTI only runs on Macintosh macOS 10.3 or lower, while
Lasergene runs only on macOS10.10 and higher. If you are using Vector NTI on Macintosh
10.3 or earlier, you must first archive each sequence as an .ma4 or .pa4 file. Then, you can
upgrade your operating system to a current version, and import.

*
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Choose it from the File > Recent Documents list.

Non-sequence files, such as enzymes or selectors, do not appear in this list.*
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Change the default application for opening
Lasergene files
On Windows:

1. Open the Control Panel.

2. Go to Programs > Default Programs > Associate a file type or protocol with a specific program.

3. Select extension you wish to change in the Extensions list and then click the Change program
button.

4. Click the Browse button in the Open With dialog.

5. Navigate to and select the application you want the files to open in. (Lasergene applications are
located by default in C:\Program Files\DNASTAR\Lasergene ‘x’ or C:\Program Files
(x86)\DNASTAR\Lasergene ‘x’, where ‘x’ represents the version number).

6. Click Open.

7. Click OK to close the Open With dialog, and then click Close.

On Macintosh:

1. Select a file of the type you wish to change in Finder.

2. Go to File > Get Info.

3. Click the drop-down arrow in the Open With field, and navigate to the application you want the files to
open in. (Lasergene applications are located by default in Applications:DNASTAR:Lasergene ‘x’,
where ‘x’ represents the version number).

4. Click the Change All button to make the application you selected the default for all files of this type.

To change the default application for opening Lasergene files:

Click here for detailed information.
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Open a sequence from the Project window
+To open one or more sequences from the Project window

1. Open a populated Project window by selecting it from the Window menu.

2. Select the desired sequences using click, Shift+click or Ctrl/Cmd+click.

3. Choose File > Open Selections.

4. If you have selected multiple sequences, you will prompted whether you wish to Open ‘n’ sequences.
Click OK.

Each sequence opens as a separate document within the project.
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Open a sequence from an online database
SeqBuilder Pro’s Net Search menu allows you to search online databases (e.g., the National Center for
Biotechnology Information’s BLAST and Entrez servers), for sequences that match all or part of the current
sequence. Once a match has been located, you may add it to the current project or save it for use in other
Lasergene applications.

When you perform BLAST or Entrez searches using a Lasergene application, you can enter your choice of
sequences from the match list directly to the Lasergene application; the application will also automatically
save copies of each file in Lasergene format. You may also use an accession number to directly download
sequence data from NCBI and automatically open it in the Lasergene application.

See the following topics for detailed instructions:

• Open an Entrez database file by locus name or accession number

• Open an Entrez database file using a text search

• Open a BLAST database file using a similarity search

• Import a Vector NTI database

At the time of each Lasergene release, the SeqBuilder Pro Preferences dialog contains
current URLs for searching NCBI’s BLAST and Entrez databases. If NCBI changes URLs at
a later date, you will need to update the Preferences dialog as instructed in Specify URLs
for BLAST and Entrez searches.

*
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Specify URLS for BLAST and Entrez Searches
To specify URLs to use for online database searching :

1. Choose Edit > Preferences (Windows) or Seqbuilder Pro > Preferences (Macintosh) and select the
Servers tab. The upper and lower portions of this dialog let you specify BLAST and Entrez server
URLs, respectively. Unless “overwritten” by substituting custom addresses, the Servers tab uses the
NCBI BLAST and Entrez server URLs that were current at the time of the Lasergene release. At
present, these addresses are https://www.dnastar.com/blast/ncbi-blast2.html and
https://www.ncbi.nlm.nih.gov/entrez/eutils.

• ◦ To add a new address to either box, click the associated Add button and type in the URL.

◦ To delete an address, select the URL from the list and click the corresponding Delete button.

◦ To set the default server for performing a search, select the URL from the list and then click the
corresponding Choose button.

2. To save changes and edit from the Preferences dialog, click OK.
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Open an Entrez database file by locus name
or accession number
If you know the locus name or accession number for a sequence, SeqBuilder Pro can retrieve it from the
Entrez database at the National Center for Biotechnology Information (NCBI):

1. Use File > Open Entrez Sequence or the keyboard shortcut Ctrl/Cmd+R.

2. The Server field lists the currently selected Entrez server. You may change to a different server by
selecting it from the list on the right under the globe icon; or choose A New Server and then type a
new URL.

3. In the Enter Sequence ID or Locus Name text box, type a locus name or accession number.

4. Specify the database name using the drop-down menu.

5. Click OK.

If the search was successful, the Save As dialog will appear. The default file name is the accession number
or locus name followed by the sequence extension (.seq or .pro). After saving, the sequence will be opened
as a new SeqBuilder Pro document.
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Try it! – Open an Entrez sequence by
accession number
In this part of the tutorial, you will open a histone DNA sequence from NCBI’s Entrez database. In order to
complete this tutorial, your computer must be connected to the Internet.

1. Select File > Open Entrez Sequence. The Open Entrez dialog appears.

2. Under Enter Sequence ID or Locus Name, enter X05543.1, which is the sequence’s
“accession.version” number.

3. Keep the drop-down menu default selection of Nucleotide and click OK.

4. Select a location to store the sequence and click Save to open the sequence as a SeqBuilder Pro
document.

5. (optional) Use File > Save to save the sequence. The sequence is used in the tutorial Try it! – Find
restriction sites on either side of a feature.
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Open an Entrez database file using a text
search
SeqBuilder Pro provides a graphical interface for constructing Boolean queries of text databases like NCBI’s
Entrez database. Search results are returned as a list from which you may select any or all sequences, then
save them or open them as documents in the current application.

To perform a text search of the NCBI Entrez database:

1. Select Net Search > New Text Search. The Entrez Query dialog appears.

• ◦ The Server field lists the currently selected Entrez server. You may change to a different server
by choosing one from the drop-down menu, or choose A New Server and then type a new URL.

◦ Use the drop-down menu in the lower right of the window to choose the database to search.
This menu will reflect the available databases on the selected server.

2. Create the search criteria using the fields provided. To access a context menu of editing commands
(Cut, Copy, Paste, etc.), right-click anywhere in the Entrez Query dialog.
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• ◦ Enter the first (or only) criterion into the text box on the left.

◦ You may change the search field heading from the drop-down list to the right of that text box.
The default is All terms from all searches, which will search every word of every listing for the
query term in the database. The field headings vary depending upon the online database that
you are using.

◦ To add a criterion to the query, click the button and choose And, Or, or And Not from the
drop-down menu on the left of the new row. And requires both the first and the second criterion
to be present. Or will look for matches containing either criterion. And Not will search for
matches containing the first criterion but not the second.

◦ To remove a criterion, click the button in the row that you want to remove.

3. Click Search to send the query to the database. Once the search is completed, any matches are
displayed in the Entrez Search Results window.
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Entrez Search Results window
When an Entrez database search is complete, the Entrez Search Results window appears, showing a list of
sequences that match your query.

The buttons at the top of the window are used to open, save, copy or print results.

Task Button to use…

To open one or more results in the selected Lasergene application Open With

To open one or more results in the current application Create Document.

To open one or more results in your default web browser Launch Browser

To save a group of results as sequence files Batch Save

To print one or more results Print

The following table describes tasks that can be performed in the lower portion of the window:

Task How to…

To sort
results Click on a column header to sort the rows by that column.

To narrow
the results

Make sure the text search results window is active by clicking on it. If you have several text results
windows open, select Net Search > Current Results to locate the desired window. Select Net
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of a text
query Search > Search These Results and enter the desired search criteria. Click Search.

To change
the search
query

To modify a text query to obtain different results without having to completely recreate a complex
query, select Net Search > Change This Query. The Entrez Query dialog appears containing the
same search criteria that you last used, allowing you to edit as necessary before performing a new
search.

After using Batch Save or Create Document, selections that have been downloaded or opened are
denoted with a black diamond or arrow.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 80 of 302



View search results in a web browser
To view one or more results from the Entrez or BLAST Search Results windows in a web browser:

Do either of the following:

• Double-click on any result from the window.

• Select one or more results from the window using click, Ctrl/Cmd+click, or Shift+click, or by adding
a checkbox to the left of the row(s) of interest.Then click the Launch Browser button or use the Net
Search > Launch Browser menu command.

Each selected match will be displayed in a separate browser window.

Popup blocking software may prevent Lasergene from opening multiple web browser
windows simultaneously. Check the documentation for your popup blocking software for
additional information.
*
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Open results in a Lasergene application
To open one or more results from the Entrez or BLAST Search Results windows:

1. Select one or more results from the Search Results window using click, Ctrl/Cmd+click, or
Shift+click, or by adding a checkbox to the left of the row(s) of interest.

2. Do any of the following:

• ◦ To open the results in a Lasergene application other than SeqBuilder, select its name from the
drop-down menu above the words Open With.

◦ To open the results in SeqBuilder Pro, click Create Document. In the resulting dialog, select
one of the following options from the Save field:

▪ Top opens the specified number of matches, starting with the first sequence on the list.
Specify a number in the text box (default is 10).

▪ Next opens the specified number of sequences, starting with the first one currently
highlighted. Specify a number in the text box (default is 10).

▪ Checked opens sequences with a checkmark beside them.

▪ Selected opens only highlighted sequences.

▪ All opens all sequences.

◦ To save the file(s) in a location other than the default directory, click the Set Location button.

3. Click OK.
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Print search results
To print results from the Entrez Search Results window:

1. Select one or more results from the Search Results window using click, Ctrl/Cmd+click, or
Shift+click, or by adding a checkbox to the left of the row(s) of interest.

2. Click the Print button to proceed with printing using the standard Print dialog for your computer’s
operating system.

To print results from an BLAST Search Results window:

1. Select one or more results from the Search Results window using click, Ctrl/Cmd+click, or
Shift+click, or by adding a checkbox to the left of the row(s) of interest.

2. Click the Print button.

3. In the resulting dialog, select one of the following options from the Print field:

• ◦ Top prints the specified number of matches, starting with the first sequence on the list. Specify
a number in the text box (default is 10).

◦ Next prints the specified number of sequences, starting with the first one currently highlighted.
Specify a number in the text box (default is 10).

◦ Checked prints sequences with a checkmark beside them.

◦ Selected prints only highlighted sequences.

◦ All prints all sequences.

4. Click Print to proceed with printing using the standard Print dialog for your computer’s operating
system.
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Copy search results
Selected results may be copied to the clipboard from the Entrez or BLAST Search Results windows.

To copy detailed information:

1. Select one or more results from the Search Results window using click, Ctrl/Cmd+click, or
Shift+click, or by adding a checkbox to the left of the row(s) of interest.

2. Choose Edit > Copy to move results to the clipboard. At a minimum, copied results will include an
identifier and description for each selected result.

3. Paste into a spreadsheet or text document.

To copy exact text sequence only:

1. In the bottom pane of the BLAST search results window, select the desired text by dragging your
mouse.

2. Choose Edit > Copy to move the selected text to the clipboard.

3. Paste into a spreadsheet or text document.

When pasting data into a word processing application, choose a mono-spaced font such as
Courier so that the alignments display correctly.*
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Save search results
To save selected results from the Entrez or BLAST Search Results windows as a text file:

1. (optional) Specify a default download folder for online search results.

2. Make the Entrez or BLAST Search Results window the active window.

3. Select File > Save As.

By default, the file will be saved with a text file extension (.txt).

To save multiple search results as sequence files:

1. (optional) Specify a default download folder for online search results.

1. Select one or more results from the Search Results window using click, Ctrl/Cmd+click, or
Shift+click, or by adding a checkbox to the left of the row(s) of interest.

2. Click the Batch Save button.

3. In the resulting dialog, select one of the following options from the Save field:

• ◦ Top opens the specified number of matches, starting with the first sequence on the list. Specify
a number in the text box (default is 10).

◦ Next opens the specified number of sequences, starting with the first one currently highlighted.
Specify a number in the text box (default is 10).

◦ Checked opens sequences with a checkmark beside them.

◦ Selected opens only highlighted sequences.

◦ All opens all sequences.

4. (optional) To save the file(s) in a location other than the default directory, click the Set Location
button.

5. Click OK again to save the sequence files to the specified directory.
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Specify a download folder for online search
results
To specify a download folder for results from an Entrez or BLAST Search Result window:

1. Choose Edit > Preferences (Windows) or SeqBuilder Pro > Preferences (Macintosh) and select the
Internet tab.

2. (optional) To automatically check for Lasergene software updates, check the box next to Show a
notification when a newer version of Lasergene is available.

3. To specify the default directory for downloading results from online database searches, press the Set
Folder button.

4. Navigate to the desired location and press Select Folder.

5. To save changes and exit from the Preferences dialog, click OK.
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Open a BLAST database file using a similarity
search
To perform a BLAST search:

1. Select the sequence or portion of sequence that you want to search for.

2. Choose Net Search > BLAST Selection.

• ◦ The Server field lists the currently selected BLAST server. You may change to a different
server by choosing one from the drop-down list provided, or choose A New Server and then
type a new URL.

◦ The Programs field lists the currently selected BLAST program. The following programs are
available through this list, though some servers may not offer all of these programs:

▪ blastn searches a nucleotide sequence database with a nucleotide query sequence

▪ blastp searches a protein sequence database with an amino acid query sequence

▪ blastx searches a protein sequence database with the six-frame translation of a
nucleotide query sequence

▪ tblastn searches the six-frame translation of a nucleotide sequence database with a
protein query sequence

▪ tblastx searches the six-frame translation of a nucleotide sequence database with the
six-frame translation of a nucleotide query sequence
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◦ The Database field lists the database that will be searched. Choose from the databases
available on the server by selecting one from the list provided.

3. After confirming the values in the Query dialog, click OK to initiate the search. Once the search is
completed, any matches are displayed in the BLAST Search Results window. You may continue to
work with other Lasergene application activities while waiting for BLAST search results, but you
cannot launch another BLAST search until you close the current BLAST window.

Using less common databases may cause a noticeably slower search. According to NCBI,
this is because the less frequently used databases may not already be loaded in memory on
an available server. In contrast, frequently used databases such as nr or nt are already
loaded in memory on a number of servers.

*

Available databases may include the refseq_representative_genomes database. This
database contains representative bacterial/archaeal genomes, as opposed to all the
genomes (some of which are multiples) now in Genbank or RefSeq. The
refseq_representative_genomes database can be helpful when matches to Escherichia
coli/Shigella, for example, occupy all 100 of the top BLAST results. For example, say you
want to find the location of a particular sequence in the curated "model organism version" of
the E. coli K-12 MG1655 genome (U00096.3/NC_000913.3). Here is the location of the true
sequence match when using different databases: refseq_genomic - absent from top 100
hits. nr - far down the list of the top 100 hits. refseq_representative_genomes – the top
hit.

*
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BLAST Search Results window
When a BLAST database search is complete, the BLAST Search Results window appears, showing a list of
sequences that match your query.

Task Button to use…

To open one or more results in the selected Lasergene application Open With

To open one or more results in the current application Create Document

To open one or more results in your default web browser Launch Browser

To save a group of results as sequence files Batch Save

To print one or more results Print

The lower pane of the BLAST Search Results window contains the alignment of the query (upper sequence)
to the highlighted database entry (lower sequence). The upper pane of the window contains the name of
possible matches in order of probability. After using Create Document or Batch Save, selections that have
been downloaded or opened are denoted with a black diamond or arrow.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 89 of 302



The following columns are available in the upper part of the window. Click on a column header to sort the
rows by that column.

Column
Name Description

Score The similarity score for the result.

Expected

The expectation value. This corresponds to the Expect value displayed in the lower pane of the
window.

Note: Detailed information about how Score and Expected are derived is available at
www.ncbi.nlm.nih.gov/BLAST. In general, a higher score and lower expectation connote a better
match.

Query Cov.

The percentage of the queried sequence that aligns to a match in the database. For example, if
you BLAST a range of 596 bases, and 565 of those bases align to a sequence in the database,
then the Query Cov. value will be 565/596, or 95%.

Note: Query Cov. differs from the Identity value shown in the lower portion of the BLAST
window. Identity is the percentage of bases within the alignment that match. For example, if 565
bases align to a sequence in the database, and there are 3 mismatches within the alignment,
then the Identity value would be 562/565, or 99.5%.

Query Left The left end coordinate of the queried sequence that corresponds to the left end coordinate of the
matching result (DB Left).

Query
Right

The right end coordinate of the queried sequence that corresponds to the right end coordinate of
the matching result (DB Right).

Identifier The sequence identifier for the result.

DB Left The left end coordinate of the result sequence that corresponds to the left end coordinate of
queried sequence (Query Left).

DB Right The right end coordinate of the result sequence that corresponds to the right end coordinate of
queried sequence (Query Right).

Description The description, from NCBI, of the result sequence.
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Use editing commands
The following editing commands can be used in multiple views, panels and dialogs.

Task How to…

To remove the current
selection from the project and
place it on the clipboard

Choose Edit > Cut or use keyboard shortcut Ctrl/Cmd+X. Among other
things, you can cut range and text selections, comments in the Comment
view, features in the Features view and translation rulers.

You can also use Edit > Select All within the Sequence, Circular, Linear, or
Minimap and then use Edit > Cut to remove the contents.

Note: Cut data does not remain strand-specific. If you copy data from a
forward strand, you may copy it to the reverse strand and vice versa.

To paste the contents of the
clipboard into an insertion point Choose Edit > Paste or use the keyboard shortcut Ctrl/Cmd+V.

To delete the selection from
the project without placing the
contents in the clipboard

Choose Edit > Delete or press the Delete key

To select the entire contents of
the active window

Choose Edit > Select All or use the keyboard shortcut Ctrl/Cmd+A. Neither
option is available within the Features view.

To reverse the effect of the
previous operation(s)

Choose Edit > Undo or the keyboard shortcut Ctrl/Cmd+Z. You may use
these options multiple times to undo multiple actions.

To reverse the effect of the last
Edit > Undo command

Choose Edit > Redo or the keyboard shortcut Ctrl/Cmd+Shift+Z You may
use these options multiple times to redo multiple actions.
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Select an object or range
To select an object:

Click the object (e.g., a feature, translation, enzyme, ruler, etc.).

To select a range in the Circular, Linear, or Sequence views:

Click and drag the mouse across the portion of the sequence you want to select. To instead select the
inverse range, hold down the Ctrl (Win) or Cmd (Mac) key while dragging the mouse over the portion you
do not wish to select.

A selection made in one view will also be selected in the other applicable views.
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Go to a location on a sequence
To go to a numerical position or select a range on the sequence:

1. Choose Edit > Go To Position or use the keyboard shortcut Ctrl/Cmd+J.

2. Type the desired position or range into the box in the dialog. To specify a range, type in the left
coordinate, then two periods (..), then the right coordinate. For example, to include the range from
35-141, type 35..141 into the text box. The “hint” uses number symbols (#) to show the format for
entering a range. However, when you enter the range, you must substitute an integer for each number
symbol.

Inclusive ranges for the forward strand are typed with the symbol > or < or .. (two dots) between the
two positions (e.g., 2500 > 3000). Regardless of the symbol used, sequence selection is always on
the forward strand.

3. Click OK.

SeqBuilder Pro positions the cursor at the specified numerical position or selects (highlights) the specified
range. If you enter a number that is outside the range of the sequence, you will receive the message “Error:
out of bounds.”

To search for a text string in a sequence:

1. Choose Edit > Find or the keyboard shortcut Ctrl/Cmd+F.
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You can use this dialog to locate a sequence string (including sequence from a primer), an ORF, a
restriction site, or the text for any qualifier field in a feature.

2. Specify one of the following search options:

• ◦ Literal or Allow Ambiguity (DNA or protein) searches for a string like GCTTTAG of up to 256
characters in length. Enter the search string into the text box. When using Literal, searching for
the string ACNC will only find the exact match, ACNC. When using Allow Ambiguity searching
for the string ACNC will find ACTC, ACCC, ACGC, ACAC, or any other ambiguous base.

• ◦ ORF (DNA only) searches for open reading frames based on the ORF criteria.

◦ Restriction Site (DNA only) searches for a restriction site. When selected, the Select Enzyme
dialog will appear. Choose a site to search for, and then click Done to return to the Find in
Sequence dialog.

◦ Feature List searches the qualifier fields for all features in the Features view for the specified

If you selected Allow Ambiguity, one or more X’s added before the search term act as
wildcards for an equal number of bases. One or more X’s added after the search term act
as wildcards for an equal number of bases minus one. (e.g. XXGAT will return 5-base
matches; GATXX will return 4-base matches).

*

When performing an ambiguous search with an ‘N’ on the 3’ end of the search query,
searches will find matches, but the match selection will not include the base corresponding
to the 3’ N in the search. Example: An ambiguous search for NGCN will find NGCNs located
anywhere on the sequence, but only the part of the match corresponding to NGC will be
selected.

*
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search string. This option also applies to primer searches.

3. Choose the strand to search using the Strand options, which are only enabled for nucleotide
sequences. Choices are normally Forward, Reverse, or Either strand. When using ORF, you may
search either the Forward or Reverse strand.

4. Click Find Next to search right or Find Previous to search left.

Once the Find in Sequence dialog is closed, select Edit > Find Again or use the keyboard shortcut Ctrl/
Cmd+G to continue the search based on the last criteria entered.
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Import a Vector NTI database
Invitrogen’s Vector NTI software will no longer be sold after December 31, 2019. In preparation for this
event, Vector NTI users are encouraged to move their databases to SeqBuilder Pro using the following
automated method:

1. Download the Vector NTI Data Export Tool for your operating system from this Invitrogen website
page.

2. Run this export tool on the same computer where the Vector NTI database is installed. This creates a
folder called VNTI Advanced Data that contains subfolders named in the step below.

3. Open SeqBuilder Pro version 16.0 or later and choose File > Import VNTI Data into Project. Here is
what happens to the Vector NTI subfolder files upon use of the command:

• DNA and RNA sequence files – Imported.

• Protein molecules – Imported.

• Oligos – Imported. You will be prompted to save the file Oligos.csv into an primer catalog file
that is usable by SeqBuilder Pro named Invitrogen Primers.pri.

• Enzyme files – Not imported. Rebase enzyme files are already present in SeqBuilder Pro.

• Gel markers – Not imported. SeqBuilder Pro’s agarose gel simulation feature provides most
commercially available gel markers and lets you easily add additional gel markers, if needed.
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Create Sequences Based on Other Sequences
(Batch Editing)
To create new sequences related to locally-stored sequences

SeqBuilder Pro 15.1 and later support batch sequence editing. See the following topics to learn how to
create new sequences:

• …by reverse complementing one or more sequences

• …by translating one or more sequences

• …by joining multiple sequences together

• …from specified features in another sequence

• …by exporting sequences into a single file

• …by sampling (filtering) a group of sequences to choose ones of special interest
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Create reverse complements of multiple
sequences
To reverse complement one or more sequences:

1. Choose Tools > Batch Reverse Complement. The Project window opens with the Project and
Options tabs active.

2. In the Project tab, the sequences you wish to reverse complement should be placed in the
Sequences folder. To add sequences to a folder, select the folder, then right-click it and choose
Import. Select the desired sequence files, and press Open. Next, select a single sequence, or use
Shift+click or Ctrl/Cmd+click to select multiple sequences.

In the Options tab, the number of sequences selected on the left appears in the message: “‘n’
sequences will be reverse complemented.’

3. In the Options tab, press the Run button.

The new sequence(s) appear in the Project tab’s Results folder.

4. (optional) If you wish to see the script that was used to run this process, press the Script tab.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 98 of 302



5. (optional) If you want to see the history of the run, including the location of the output file(s), press the
History tab.
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Create translations of multiple sequences
To translate one or more nucleic acid sequences into protein sequences using a specified translation table:

1. Choose Tools > Batch Translate. The Project window opens with the Project and Options tabs
active.

2. In the Project tab, the sequences you wish to translate should be placed in the Sequences folder. To
add sequences to a folder, select the folder, then right-click it and choose Import. Select the desired
sequence files, and press Open. Next, select a single sequence, or use Shift+click or Ctrl/
Cmd+click to select multiple sequences.

In the Options tab, the number of sequences selected on the left appears in the message: “‘n’
sequences will be translated.’

3. In the Options tab, use the Reading Frame drop-down menu to choose the reading frame for the
translation.

• Default: 1 or as annotated – Honor any existing /codon_start annotations in the input file(s); or
otherwise, to begin at the first base.

• Ignore ‘/codon_start’ annotations – Begin translating at the first base and to ignore any
/codon_start sequence annotations. Note that this selection is equivalent to the Default: 1 or as
annotated selection (above) for any input sequence other than a .gbk or .seq file with
/codon_start qualifiers.

• 1, 2 and 3 – Begin the translation at the first, second or third base, respectively, ignoring any
/codon_start annotations. For an input sequence containing /codon_start qualifiers, selecting
the start codon implicitly is similar to choosing Ignore ‘/codon_start’ annotations, but allows a
specific frame to be set.

4. In the Genetic Code drop-down menu, choose a code for the translation. All NCBI and Lasergene
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tables are available, and are denoted by number and/or description. By default, the translation uses
the genetic code identified in the source data (e.g., the GenBank /transl_table qualifier), if available;
otherwise, it uses the standard genetic code (NCBI:1).

5. Press the Run button.

If an input sequence was annotated, each CDS feature is translated separately, and any translation
table and/or codon_start annotations are honored. If the input file was not annotated, or did not
contain CDS features, the entire sequence is translated. Note that translation halts when there are
fewer than 3 bases left. An “extra” base or two at the end will not be reflected in the output.

The new sequence(s) appear in the Project tab’s Results folder.

6. (optional) If you wish to see the script that was used to run this process, press the Script tab.

7. (optional) If you want to see the history of the run, including the location of the output file(s), press the
History tab.
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Create one sequence from multiple
sequences
To join two or more sequences end-to-end:

1. Choose Tools > Concatenate. The Project window opens with the Project and Options tabs active.

2. In the Project tab place the sequences you wish to join into the Sequences folder. To add sequences
to a folder, select the folder, then right-click it and choose Import. Select the desired sequence files,
and press Open. Use Shift+click or Ctrl/Cmd+click to select two or more sequences.

In the Options tab on the right, the number of sequences selected on the left appears in the message:
“‘n’ sequences will be concatenated.’

3. In the Options tab, type a name (and extension, if desired) in the Output File Name text box.

4. Select an output file format from the drop-down menu. Choices include .gbk (preserves annotations)
or .fas (no annotations).

5. If desired, check the Create Source Feature for each contributing sequence box. Checking this
box creates a “source” feature for each sequence that contributes to the concatenated sequence. This
can assist you in keeping track of where each sequence originated.

6. Press the Run button.

The new sequence appears in the Project tab’s Results folder under the name specified. No file
extension is appended to the name unless one was specified in the Output File Name box.
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7. (optional) If you wish to see the script that was used to run this process, press the Script tab.

8. (optional) If you want to see the history of the run, including the location of the output file(s), press the
History tab.

Example:

Input sequence 1: GGAGTCTCCC

Input sequence 2: ATTGATTACA

Output sequence: GGAGTCTCCCATTGATTACA

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 103 of 302



Create sequences from features in another
sequence
To create new sequences from existing sequence features:

1. Choose Tools > Extract Features as Sequences. The Project window opens with the Project and
Options tabs active.

2. In the Project tab, place the sequences whose features you wish to extract into the Sequences folder.
To add sequences to a folder, select the folder, then right-click it and choose Import. Select the
desired sequence files, and press Open. Use Shift+click or Ctrl/Cmd+click to select two or more
sequences.

In the Options tab on the right, the number of sequences selected on the left appears in the message:
“‘n’ sequences will be processed.’

3. In the Options tab, use the upper drop-down menu to choose the type of feature to extract (e.g., CDS,
mRNA, etc.)

4. If you wish to further limit the search to features that contain particular qualifiers, check the Filter box
and use the lower drop-down menu to choose a qualifier. To the right, enter the text that the qualifier
must match (e.g., /gene = thrL). You may use wildcards in this box if you wish (e.g., /gene = thr*)

5. Press the Run button.

The extracted features appear as individual sequences in the Project tab’s Results folder. Sequences
are named automatically according to a contained qualifier (e.g., /protein_id, /locus, or /accession).
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6. (optional) If you wish to see the script that was used to run this process, press the Script tab.

7. (optional) If you want to see the history of the run, including the location of the output file(s), press the
History tab.
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Export sequences into a single file
To create a single multi-sequence file composed of exported sequences:

1. Choose Tools > Export Sequences into Single File. The Project window opens with the Project and
Options tabs active.

2. In the Project tab, place the sequences you wish to export into the Sequences folder. To add
sequences to a folder, select the folder, then right-click it and choose Import. Select the desired
sequence files, and press Open. Use Shift+click or Ctrl/Cmd+click to select two or more
sequences.

In the Options tab on the right, the number of sequences selected on the left appears in the message:
“‘n’ sequences will be exported.’

3. In the Options tab, click the Browse button. In the ensuing dialog, navigate to the location for the
output file. Type in a name and select an extension (.fas or .gbk), then click Save. The Output File
Name text box now contains the name and file path where the output file will be saved.

4. Press the Run button.

The new multi-sequence file appears in the Project tab’s Results folder with the name chosen above.
The new file is represented by a folder icon and its contained sequences are named automatically
according to a qualifier (e.g., /protein_id, /locus, or /accession).

5. (optional) If you wish to see the script that was used to run this process, press the Script tab.

6. (optional) If you want to see the history of the run, including the location of the output file(s), press the
History tab.
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Create a file by sampling sequences
The Tools > Sample By command is used to create an output file that contains a filtered set of sequences
from a source file. Source file sequences can be filtered according to one or more specified conditions, such
as length, contents, and start/end sequence characters.

To create a sequence by sampling other sequences:

1. Choose Tools > Sample By > (Subcommand). Available subcommands are: 5’ and 3’ End Tags,
Contains Sequence, Probability or Skipping, Length, and Name.

The Project window opens with the Project and Options tabs active.

2. In the Project tab, the sequences you wish to sample should be placed in the Sequences folder. To
add sequences to a folder, select the folder, then right-click it and choose Import. Select the desired
sequence files, and press Open. Next, select a single sequence, or use Shift+click or Ctrl/
Cmd+click to select multiple sequences.

3. The Options tab varies in appearance, depending on which subcommand was chosen. The number of
sequences selected in the Project tab appears in the message: “‘n’ sequences will be sampled.”

4. Change settings in the Options tab as applicable for the chosen subcommand.

5’ and 3’ End Tags:

Tools > Sample By > 5’ and 3’ End Tags samples only those sequences beginning and/or ending
with a specified sequence fragment or “index tag” on the 3’ or 5’ end. For sequences of DNA or
unknown type, matches can occur at the ends of either strand.

Check the Starts with and/or Ends with boxes, then enter the search strand(s) to the right of the
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checked box(es).

Contains Sequence:

Tools > Sample By > Contains Sequence samples only those sequences containing a specified
sequence fragment. This provides a way to sample a set of sequences that contain the same
subsequence. For sequences of DNA or unknown type, matches can occur on either strand.

Either type the subsequence or paste copied sequence into the text field, or use the “load a file” link
to navigate to a sequence or text file.

Probability or Skipping:

Tools > Sample By > Probability or Skipping samples a random subset of sequences.

To choose every nth sequence from the file, select Sample every and type the ‘n’ value (an integer)
at the right. To sample a certain number of random sequences instead, select Random sample
containing and type the number of sequences at the right.

Length:
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Tools > Sample By > Length samples only those sequences with a length greater and/or less than a
specified length.

To specify a length threshold for sampled sequences, choose between Minimum length, Maximum
length and Range. Then type the cutoff value(s) into the box at right.

Name:

Tools > Sample By > Name samples only sequences with the specified name.

Choose whether sampled sequences need to have the specified text in the sequence name or a
feature name. Type in the text to the right of the selected option.

5. In the Options tab, press the Run button.

The resulting sequence(s) appear in the Project tab’s Results folder. The results file has the same
name as first sequence file that was sampled, followed by “_sampled.”

6. (optional) If you wish to see the script that was used to run this process, press the Script tab.
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7. (optional) If you want to see the history of the run, including the location of the output file(s), press the
History tab.
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Features
Features are annotations made to a specified range on a sequence. They can be imported as part of a
sequence file (e.g., Genbank, EMBL, etc.), or they can be created within SeqBuilder Pro. See the following
topics to learn how to:

• Create or delete features
• Edit information about a feature
• Show or hide features
• Join feature segments

TUTORIAL: Try it! – Create and modify a feature.*
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Create or delete features
To create a new feature:

1. Within any Document window view that permits range selection, select a range of the sequence. To
select a range that wraps the origin, position the cursor at one end of the feature, and then use Ctrl/
Cmd+Shift+Click to select the other end of the feature.

2. Create the new feature as follows:

• ◦ To create a new misc_feature using the currently highlighted range of sequence as the first
segment, select Features > New Feature or use the keyboard shortcut Ctrl/Cmd+K.

◦ To create a new CDS feature using the currently highlighted range of sequence as the first
segment, select Features > New Feature with Translation. The new feature will also have a
/translation qualifier attached to it. If no sequence is selected, this command is inactive.

The new feature is selected in all views, and appears, by default, in graphical views as a brown box.

3. (optional) Change the appearance of a feature (e.g., color, rendering style, text placement, etc.) using
options in the Style panel.

4. (optional) For a multi-segment feature, add the next feature segment.

To delete a feature:

right-click or Ctrl+click on the feature and select Delete. A confirmation dialog appears. Click Yes to delete
the feature.

Deletion is permanent, and thus differs from hiding a feature. However, if you change your mind
immediately, you may undo the deletion by selecting Edit > Undo Feature Delete.

If you are in the Minimap or Site Summary views, you will not be able to see the new feature
until you view the sequence in Circular, Linear, or Sequence views.*
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Edit information about a feature
To edit information about a feature:

1. Open the Features view.

2. Expand the row(s) for the feature(s) of interest:

• ◦ Expand a single row by clicking on the plus sign on the left of the row.

◦ Expand all rows by right-clicking anywhere in the view and choosing Expand All from the
context menu.

3. Do any of the tasks described in the table below.

Task How to…

To edit
existing text

Place your cursor in any text field and edit or overwrite the existing entry for that field.

Reverse the
direction of
the feature

To reverse the direction of the feature so that it references the opposite strand (top or bottom),

click the direction tool ( ) or select the feature and choose Edit > Reverse Strand. If the
feature has previously been translated, it will initially appear in red text. If this happens, you will
need to choose Features > Update All Translations to update the translation for the feature.

To extend or
shrink the
length or to
change the
segment

Click the numbered range next to the direction tool ( ). Overwrite one or both numbers to
redefine the area included in the feature. Leave two periods between the numbers. To extend
the feature by adding a segment to it, type in a comma and then the new segment coordinates.
Alternatively, follow the instructions in Joining Features.

To select
text to use
as the
feature label

The text following the /dnas_title field is used as the feature label throughout SeqBuilder Pro’s
views. To select text from another qualifier for this purpose, right-click on that qualifier and
choose Use as Feature Label or select it and choose Features > Use As Feature Label.
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To add a
new /note or
other
qualifier

Right-click on the feature and choose New Note. A /note qualifier field appears and you may
type or paste text into it. To change the /note to another type of qualifier, click on the text
/note. A menu appears containing several qualifiers. Select a new qualifier type, or click All to
see a complete list of available qualifiers.

To delete a
selected
qualifier field

Right-click on the feature and choose Delete Note; or select the feature and choose Features
> Delete Qualifier Field. Translations that have not been updated after a modification has
been made appear in red.

To rename a
feature

Right-click on the feature and choose Rename Feature or Edit Feature Description; or select
the feature and choose Features > Rename Feature or Features > Edit Feature
Description. The following conventions apply to feature names: a) Using the punctuation
symbols left parenthesis, left square bracket, semi-colon or slash in the name will cause the
feature name to be truncated just before the symbol, even if more text follows. b) If the feature
description is ≤ 40 characters in length, the entire description is accepted, including spaces. c)
If the feature description is ≥ 41 characters and does not contain spaces, the entire description
is accepted. d) If the feature description is ≥ 41 characters and contains spaces, the entire
description will be truncated just to the left of the first space.

To
permanently
remove a
feature

Right-click on the feature and choose Delete Feature, or select the feature and choose
Features > Delete Feature. If you only want to hide the feature from view, turn display of that
feature ‘off’ instead.

To add a
/translation
qualifier to
the feature

Right-click on the feature and choose New Translation or select the feature and choose
Features > New Translation. SeqBuilder Pro automatically calculates the translated protein
sequence for the selected feature. A /translation qualifier appears in the feature in the

Features view. If you later use the direction tool ( ) to change the selected strand, you must
select Features > Update All Translations to update the /translation qualifier.

To
automatically
update the
translation

Right-click on the feature and choose Update Feature’s Translation. Translations should be
updated if you have used Features> Join to Feature, or if you have modified a segment
within a feature. To update all translations, use Features > Update All Translations.
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Try it! – Create and modify a feature
In the following tutorial, you’ll locate open reading frames (ORFs), create a feature at the location of a pair
of ORFs, and then change the way the feature is displayed.

1. If you have not yet download and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. Use File > Open to open the demo file Tn5w.sbd.

The upper pane of the window displays the Linear view, while the lower pane shows the Features
view.

3. To locate ORFs, use the Translations and ORFs tool on the left and select ORFs > Top Frame 1.
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4. Hold down the Shift key and select each of the adjacent ORFs around position 3700.

In the header, check that the current Selection is “Forward 3649..3867, length = 219.”

5. Select Features > New Feature. A feature appears in the Linear view as an orange-brown box.

6. In the bottom pane of the screen, note the flashing cursor to the right of the word /note. Type ORFs
of interest and press Enter/Return; this notation now appears as the label for the feature in the
Linear view.

7. To make this the permanent label for the feature, right-click on /note and choose Use As Feature
Label.

8. Near the top-right of the SeqBuilder Pro window, click on the Style tab to make the Style panel active.
In the Style panel:

a. Click the orange-brown box to the right of Line and pick any shade of purple from the color
chooser. Press OK.

b. Change the Line Weight to 2.
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c. Add a shadow by checking the box next to Shadow.
d. Use the Shape drop-down menu to select Filled Arrow.

9. (optional) If desired, move the green zoom slider ( ) to the right to zoom in on the
feature.

The feature now appears as below.
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Show or hide features
To choose which features to show/hide:

In the Show column of Features view, rows with check marks represent the features currently displayed in
the graphical views. Rows without check marks are not displayed in the views Click the Show column for a
particular row to add/remove a check mark.

To hide a feature:

An alternate method for hiding a feature is to right-click on the feature in a graphical view and choose Hide
Feature.

To facilitate (un)checking multiple features at once (e.g., CDS features, features starting
with a particular word, etc.) you may wish to click on the heading for the relevant column to
sort it before adding/removing check marks.
*
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Join feature segments
To join a new segment to an existing feature:

1. (optional) If an initial feature segment doesn’t exist, create one.

2. Select a region of a sequence to join to the existing feature.

3. Select Features > Join to Feature. The Join to Feature dialog appears. This dialog contains a list of
all the features in the current sequence.

4. Select a feature from the list to which you will join the currently selected region. The dialog displays
that feature’s segment(s) both before and after joining the highlighted region.

5. Click OK to join the highlighted region to the selected feature.

6. In the Features view, the feature name for the multisegment feature will appear in the /dnas_title
qualifier field in the following format:

feature name;segment 1+segment 2+segment 3+segment 4…

For example:
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To change the name of the entire feature and/or each individual segment name, click in the
/dnas_title qualifier field to open the Multisegment Name Editor.

7. In the Circular view, you may move the feature name entirely outside the circular map, where it may
be easier to read. To do this, right-click on the feature and select Detach Feature Label.

The outcome of this procedure is different from simply modifying the length of a feature. The updated
feature will include two orange boxes (or other shapes, as set up in the Style panel) when displayed in the
Sequence, Linear, or Circular views. One is for the original feature and the other is for the newly joined
segment. If the two segments are not adjacent, the default style in the Sequence view is to show them
connected by a line.
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Customize the Sequence Display
To specify sequence characteristics and how a sequence is displayed:

Task How to…

To add, delete, or
change the letters in
a sequence

Open the Sequence view and insert the cursor where desired. Delete letters, type in
new letters, or overwrite existing letters.

To change the font
case Select a portion of the sequence and choose Format > Case.

To change the font
color, size or style Use the Style panel.

To change the way
residues are grouped
in the Sequence
view

Choose Format > Residue Grouping. Select from the following options.

• None: (default) The base pairs appear in an unbroken line.
• Group by 3: To visually break up the sequence after every trio of base pairs.
• Group by 10: To visually break up the sequence after every ten base pairs.

To specify whether a
sequence is linear or
circular

Choose Sequence > Linear or Sequence > Circular. Regardless of the selection
made here, SeqBuilder Pro can display any sequence in both the Linear and Circular
views. Specifying Circular impacts ORFs and restriction sites that cross the origin.

To specify whether
the sequence
contains DNA or
RNA

Choose Sequence > DNA or Sequence > RNA. If RNA is chosen, the sequence is
displayed with U’s instead of T’s.

Additional topics related to sequence display:

• Change the rendering style or font

• Move an object or row

• Switch to a preset layout

• Handle overlapping graphics

• Zoom in or out
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Change the rendering style or font
To change the rendering style or font of a selected feature, enzyme or range:

Open the Style panel and perform one of the tasks in the table below.

Task How to…

To show/
hide an
outline
around a
selected
item

To show/hide an outline, check/uncheck the Line box. Choose a line Weight using the drop-down
menu. Change the line color, if desired, by clicking on the colored box and making a selection
from the color chooser.

To show/
hide a
solid fill or
drop
shadow for
a selected
item

To show/hide a solid fill or drop shadow, check/uncheck the Fill or Shadow box. Change the fill or
shadow color, if desired, by clicking on the colored box and making a selection from the color
chooser.

To change
the shape
of a
selected
feature

By default, a new misc_feature is an brown-bordered box with the feature’s name inside.

Use the Shape drop-down menu to select the shape of the feature. The following shapes are
available:

Box

Filled Arrow

Filled Double Arrow

Triangle Glyph (may be disabled for some very long features)

Stroked Arrow

Stroked Goalpost

To choose
how to link
multi-
segment
features

Make a selection from the Linkage drop-down menu. Choices are Solid, Dashed and None.
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To change
the
position of
a feature
label

A feature’s label is the topmost note as seen in the Features view. If you are working with a multi-
segment feature, Inside will display segment names inside each segment box, while Above and
Below will instead display only the corresponding feature name above or below the segment box.

To include
a label
inside or
adjacent to
the feature
in the
Circular
view

Check Label Attached and use the Label Position drop-down menu to specify the location. For
instance, you may wish to move a long feature name above or below the feature shape. If the
Label Attached box is unchecked, the label appears outside the circular map with a line
connecting it to the feature.

To change
the font
style, color
or size

Choose the items to which changes should apply using the Font drop-down menu. Choices
include the Selected Item, All Features, All Enzymes, the Sequence, a Circular (Map) Title, or
the Ruler. To select a different font color, click on the colored box to open the color chooser. The
current font name is shown as a button. Click on the button to open a dialog where you can
change the font, font style or size. Alternatively, the font size can be changed within the Style
panel by typing a new font size into the text box or using the up/down arrows.

Note: To increase/decrease the font for a single selected feature, choose Format > Size > Larger
or Smaller.
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Move an object or row
To move an object in the Circular, Linear, or Sequence views:

Double-click on an object and then drag it in the desired direction.

To move a row:

Change the order of rows in a tabular view by dragging the identifying character at the left of the row up or
down with the mouse.
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Use preset layouts or create new ones
The following table discusses use of menu commands that affect the layout of a sequence in the Document
window.

Task How to…

To choose a template and
apply it to the current file Choose View > Apply Layout.

To save the current layout
as a template to be applied
to other projects

Choose View > Save Layout as Template.

To save the current layout
as the default layout

To save the current layout as the default layout for all SeqBuilder Pro files that
do not already have layout information included (e.g., .seq, .pro, or .gbk files),
choose View > Save Layout as Default Template.

To reformat the Linear or
Circular views to the default
layout

Choose View > Restore DNASTAR Default Layout. This minimizes white
space and places objects in the following order (from top to bottom): enzyme cut
sites, features, ORFs. Note that the position of the ruler does not change after
using this command.

To recalculate the display To rerun the dynamic/force-directed graph for enzyme display, and to refresh the
feature display, choose View > Recalculate Display.

To resize the current view
so that the printed portion of
the view appears as large
as possible

To resize the current view so that the printed portion of the view appears as
large as possible while showing the entire printed portion of the page, choose
View > Fit to View. This option is not available in all views.

To resize the current view
so that the whole printed
page appears in the
selected pane

Choose View > Fit to Page. This view is smaller than when using View > Fit to
View as it includes the margins of the page as well as the printed portion of the
page.

Installed templates can also be applied using any of the three Layout button tools on the
left of the Document window.*
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Handle overlapping graphics
If there are overlapping items in a view (e.g., restriction enzyme labels), right-click on one of the items and
choose Move to Back.
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Zoom in or out
In the Circular, Linear and Minimap views, you can use the zoom slider ( ) at the top of
a view to increase or decrease the size of the view.
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Enzymes
For information on working with enzymes, see the following topics:

• Create and manage individual enzymes or sets of enzymes

• Apply or remove enzymes in the Gel Simulation view

• Show or hide enzymes in other views

• Change the way enzymes are displayed

• View cut sites and recognition sequence
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Create and manage individual enzymes
The Enzyme Manager allows you to create, modify or delete enzymes for use in SeqBuilder Pro or other
Lasergene applications. If you want to create a new enzyme, open the manager using Enzymes > New
Enzyme. To edit an existing enzyme, select the enzyme in a view and choose Enzymes > Enzyme
Manager.

The list on the left contains all of the defined restriction enzymes in use by Lasergene.

In the main portion of the dialog:

• Enzyme name displays the name of the enzyme currently selected in a view, or chosen from the list
in the Enzyme Manager dialog.

• Recognition sequence is the pair string that identifies where the restriction enzyme will cut the
strand. (Note that Bgh I and Taq II have unusual cleavage properties.)

• Class: There are three classes of enzymes: Precise, Random, or Unknown. If the class is Precise,
you can set the forward and reverse strand cut sites. Drag the arrows above and below the
recognition sequence to the appropriate positions. The upper arrow indicates the top strand cut site
and the lower arrow indicates the reverse strand cut site.

• Isoschizomers lists any commercially available isoschizomers.

• Vendor list contains one or more three letter vendor codes.
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• On Hand*/*Procurable defines the availability of the enzyme.

The buttons at the bottom of the window are used as follows:

Revert
To return a modified enzyme to its original (default) configuration. Note that Revert will not bring back
a recently deleted enzyme. Instead, click Cancel before closing the Enzyme Manager to prevent the
enzyme’s deletion.

Delete
To remove an enzyme from Lasergene. Use caution, as Enzyme deletion cannot be undone by
selecting Edit > Undo. If you delete an enzyme from the Enzyme Manager dialog, you will have to
recreate it manually if you need it later.

New To create a new restriction enzyme. In this case, you will enter data into the Enzyme Manager dialog’s
fields.

OK to accept any changes (modifications to enzymes, deleted enzymes, or new enzymes) made since
opening the Enzyme Manager and return to SeqBuilder Pro.

Cancel To reject changes made since opening the Enzyme Manager and return to SeqBuilder Pro.

Merge

To import enzymes from another SeqBuilder Pro enzyme file (Enzymes.ezd). This function does not
overwrite any existing enzymes, but rather only imports enzymes from the selected file that do not
exist in the current file. If you want to update an existing enzyme using the Merge feature, you should
first delete that enzyme and then merge the file containing the updated enzyme.

Save
As

To save a copy of your current enzyme file. This can be useful if you wish to share your enzyme file
with others.
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Enzymes with unusual cleavage properties
(Bgh I and Taq II)
Most restriction enzymes follow a simple cutting pattern, with one forward and one reverse cut site. Several
enzymes have two forward and two reverse cut sites. For these enzymes, two restriction sites need to be
entered into the database rather than one. For example, Bgh I:

would be listed as BghI:

and BghI’:

Taq II has two distinct recognition sequences which may be represented as Taq II and Taq II’, respectively:
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Create and manage sets of enzymes
Enzyme selectors provide a way to define a group of restriction enzymes based on specific criteria. Once
created, the selector will appear in the list of preset enzyme categories that appears when you click the

Enzymes tool ( ).Once defined, enzyme selectors are available for use in SeqBuilder Pro or
GeneQuest.

• To create a new selector, open the manager using Enzymes > New Selector.

• To create a new selector for enzymes that do/don’t cut a selected region, select a region of sequence
and choose Enzymes > Show Enzymes That Cut the Selection or Enzymes > Show Enzymes
That Don’t Cut the Selection. Note that if you apply multiple selectors to the sequence, only the
enzymes that meet the criteria for all applied selectors will be displayed. For example, if the Unique
Sites selector is already applied to your sequence, and you then select a region and choose
Enzymes > Show Enzymes That (Don’t) Cut the Selection, the resulting enzymes will be those that
are both unique and cut (or don’t cut) within the selected range.

• To create a new selector for enzymes compatible with a selected enzyme, double-click on an enzyme
to select it. Then choose Enzymes > Show Enzymes Compatible With. The new selector is named
after the enzyme you chose.

• To edit an existing selector, choose Enzymes > Enzyme Selector Manager.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 132 of 302



Enzyme Selector Manager
The Enzyme Selector Manager is opened by choosing Enzymes > New Selector or Enzymes > Selector
Manager.

This topic describes the layout of the Manager. Additional information about using the Manager is in the
topic Create and manage sets of enzymes.

• The Selector list on the left contains a list of all the selectors available for use. Choose a selector to
modify by clicking it. The selector’s criteria will then appear in the Definition section of the dialog, and
the enzymes that are included in this selector group appear in the Results section of the dialog (if this
selector chooses any enzymes).

• The Definition portion of the dialog contains the criteria that the selector uses for displaying specific

enzymes using the Enzymes button tool ( ). This portion of the dialog contains the following
items:

• ◦ Name contains the name of the current selector. You can enter a name for a new selector here
when you wish to create a new selector.

◦ Type sets the type of selector and changes the options offered in this dialog. See the table
below for details:
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Type Description

Class

To create a selector that uses class, complexity, availability (or some combination of these) as its
criteria.

• Only precise – Check to select class II sites.

• Only random – Check to select class I sites.

Check both boxes to select enzymes from either class.

• Site complexity – Check to limit the enzymes in this selector by the minimum length of
the recognition sequence. Enter the minimum length in the Min box. Check the Range
box if you wish to set a maximum length for the enzyme as well as a minimum length.

• Commercial – Check to limit the enzymes in this selector to those that are
commercially available.

• On hand – Check to limit the enzymes in this selector to those that are currently
available in the laboratory. To use this, each enzyme that is on hand should be so
marked.

Overhang

To create a selector based on a set of overhang criteria.

• Overhang compatible with – Check to enable a drop-down menu that lets you specify
whether the overhang be compatible with any enzyme or with one specific enzyme.

• Overhang length – To set a minimum length in base pairs for the overhang for either
3’ or 5’ overhangs. Set a range of base pairs by checking Range:

The previous two options (Overhang compatible with and Overhang length) are
mutually exclusive.

• Overhang degeneracy – Choose whether this selector should use only specific, only
degenerate, or both types of enzymes.

Frequency

To create a selector based on criteria that specifies the frequency in which cutting sites appear
within a specified range in the sequence. Use this also to find unique cloning sites or fragment
exclusion sites.

• Cut frequency: To specify the frequency of cutting sites within a range. Check Range
if you wish to specify a Min imum and Max imum number of cuts that fall within the
range.
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• Target sequence: To select a sequence other than the current sequence; either
another open sequence, or another sequence stored on your computer. Click Browse
to select another sequence from the hard drive Or use the drop-down menu to select a
currently open sequence from the list. Generally, frequency filters should not have a
specific target. To apply the filter to any sequence, do not browse to a specific
sequence, but instead select <Set when applied> from the drop-down menu. The
program will not evaluate the Result and display it on the right side of the window.
Instead, the results will be evaluated when the selector is applied to the sequence.

• Sequence range: Check to specify the Begin ning and End of a sequence segment
where this enzyme must cut the strand the number of times specified in Cut frequency.

Pick
To create a selector that only displays specific enzymes. To add an enzyme to the selector, click
its name in Remaining Enzymes and click the left arrow. To remove an enzyme from the
selector, click its name in Selected Enzymes and then click the right arrow.

Combine

To create a selector that is a combination of other selectors. Choose a selector in the center
column list and then select a logical connector in the first column. You can choose not for the first
selector to choose enzymes that are not in that selector. You can choose not, or, and, or not, or
and not for the second and subsequent selectors.

Click + to add another selector and another row to the selector list. Click – to remove a selector
and a row from the selector list along with any associated logical connector.

• The Results list on the right displays the enzymes that this selector will display on the sequence
when chosen. Results cannot always be evaluated, so this section could potentially remain blank. In a
case where the results cannot be evaluated, red text appears on the dialog explaining why the results
can’t be evaluated. The buttons in this dialog are used as follows:

Type Description

Evaluate

To apply new criteria to the selector. Enzymes that will be selected by this selector appear in the
Results list on the right of the dialog. If the selector displays the desired set of enzymes in the
Result box, click OK to save the Selector. There are some cases when the selector cannot be
evaluated. You can create a Frequency filter where the Target Sequence is set to <Set When
Applied>. In this case, the filter is not evaluated until the filter is actually applied to a specific
sequence. This allows you to create a generic “unique” filter that will show only enzymes that cut a
specific sequence one time. The set of enzymes will vary from sequence to sequence. Such
selectors are not evaluated until applied to a sequence.

Revert To remove all changes made to the current selector and revert to the original criteria. This option
does not apply to changes made to the selector name or type.

New To create a new selector.

Delete To remove the selector.

OK To accept any changes made since opening the Enzyme Selector Manager and return to SeqBuilder
Pro. The new or modified selector will appear in the Restriction Enzymes > Selectors folder.

Cancel To reject changes made since opening the Enzyme Selector Manager and return to SeqBuilder Pro.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 135 of 302



If you click Cancel when creating a new selector, the new selector will not be added to the
Restriction Enzymes > Selectors folder.
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Try it! – Find restriction sites on either side of
a feature
In this tutorial, you will look for a single enzyme capable of excising a histone coding feature from a
sequence named X05543.1.

1. To open the sequence, follow the tutorial Try it! – Open an Entrez sequence by accession number.

You’ll need an enzyme that cuts in just two places. So you’ll start by creating and applying a
frequency selector that displays enzymes that cuts the sequence in a maximum of two places:

2. Select Enzymes > New Selector. The Enzyme Selector Manager appears. New Selector is
highlighted in the Selector list and the Name is Untitled 1.

3. In the Name box, type Two cuts max.

4. From the Type drop-down menu, select Frequency.

5. Overwrite the number 1 in the Max box with the number 2. Leave all other parameters at their default
settings.
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6. Click OK to create the new selector and return to the main view.

7. Click on the Enzymes tool ( ) on the upper left of the window, then choose the new selector Two
cuts max to display only the restriction enzymes that will cut this sequence one or two times.

Many restriction sites remain, so you can now use the Minimap view to find the best restriction
enzyme for the job:

8. In the Circular view (top) or Features view (bottom), single-click on the feature Histone H2B-1 to
select the feature in all views. Histone H2B-1 is a CDS feature that was included in the original
Genbank-formatted sequence.

9. At the bottom of the window, click the Minimap tab to move to that view. The Minimap is scaled to
show the whole sequence in a single line. In this view, restrictions enzyme names appear as
individual rows in the left-hand column. Their corresponding cut sites are shown in the same row on
the right.

Even if you were to exit now without saving the project, the Enzyme Selector “Two cuts
max” would be saved automatically and available through the Enzymes tool.*
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10. At the top of the Minimap view, click on the ruler to sort the enzymes by which cut closest to the
selection

The restriction sites are sorted so that those cutting closest to and outside the feature appear near
the top, those cutting further away from the outside appear further down, and those cutting inside the
feature’s range appear at the bottom. Note that the ApoI restriction site cuts just to the left and right of
the histone gene, and thus may be used for excising the gene.
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11. To remove all of the currently-applied enzymes from the sequence, click the Enzymes tool ( )
and choose None.

12. To apply only the ApoI enzyme, click the tool again and choose Pick Specific Enzymes. This opens
the Enzymes panel on the right. Check the box next to ApoI.

This is the end of this tutorial topic.
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Apply or remove enzymes in the Gel
Simulation view
After using File > New Agarose Gel to initiate an agarose gel simulation, a specialized version of the
Enzymes panel can be used to apply or remove enzymes from a lane in the Gel Simulation view.

To apply enzymes to an agarose gel lane:

First select a non-empty gel lane. If the gel lane of interest is empty, first add a sequence to it by clicking on
the Sequences tab and checking the box next to a sequence. If no sequences appear in the Sequences
panel, right-click in the white area and choose Import .

Next, either:

• Use the mouse to grab the icon to the right of an enzyme in the Enzymes panel, then drag it and drop
it in the desired lane.

• Select a lane in the Gel Simulation view, then put a checkmark next to one or more enzymes in the
Enzymes panel to add them to the selected lane. To check multiple enzymes, hold down the Shift key
while making selections. If the Shift key is not held down, any new enzyme selection will replace the
previous selection.

To clear enzymes from a lane:

Select the lane, then press the Clear button at the top right of the Enzymes panel.

To remove an enzyme added in error:

Use Edit > Undo enzyme choice to revert the lane to its previous state.
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Show or hide enzymes in other views
To show/hide sets of enzymes using the Enzymes tool:

To apply groups of enzymes to the sequence based on the frequency of cuts, type or class, site complexity,

or overhang compatibility, click the Enzymes tool ( ) and make a selection from the list. Choosing None
hides all enzymes from the display. The image below shows some of the categories included with the
software installation. If you have created sets of enzymes using the Enzyme Selector Manager, these will
appear at the bottom of the list.

If desired, additional sets of enzymes can be applied to intersect with those in the first selector. When
selecting subsequent sets of enzymes, hold down the Ctrl, Alt, or Shift keys (Windows) or Cmd, Ctrl,
Option, or Shift (Macintosh.

Once restriction enzyme(s) have been applied to the Sequence view, click and hold on a restriction enzyme
label in this view to show the cut sites, represented by thin blue lines. Or do the same while pressing the Alt
(Win) or Option (Mac) key to show the cut represented by bold black arrows, and to display the recognition
sequence.
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To hide an individual enzyme:

Right-click on the enzyme and choose whichever command is available: Hide Enzyme or Hide Selected
Enzyme. Alternatively, use the procedure below.

To show/hide individual enzymes using the Enzymes panel:

1. Open the Enzymes panel by clicking on its tab or by clicking the Enzymes tool ( ) and choosing
Pick Specific Enzymes.

2. In the Enzymes panel, search for enzymes of interest using the responsive search bar at the top.

• ◦ To filter the selection to enzymes beginning with particular letters, start typing the enzyme
name.

◦ To remove a filter, click the ‘x’ at the right side of the search bar.

3. Check the boxes next to enzymes you wish to display and remove check marks from enzymes you
wish to hide.

Note: Use of the Enzymes tool to display a preselected set of enzymes overrides and
selections made manually in the Enzymes panel (described below).*
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The Details panel will list any restriction enzymes that are suppressed due to very high cut frequency.

4. (optional) To predict enzyme cuts for a sequence with ambiguous bases, check the Show Potential
Cuts at Ambiguous Bases box under the enzyme list. This box is unchecked by default.

Potential cuts occur when the enzyme recognition sequence and the template sequence are both
ambiguous, as can happen when examining a back-translated protein. If the ambiguous residues
have a non-empty intersection, then a cut is possible. However, if the intersection does not cover the
whole ambiguous set, the cut is not certain. With a fully characterized sequence, all cuts are certain,
so there will be no potential cuts.

When Show Potential Cuts at Ambiguous Bases is checked, any restriction enzymes so detected
will appear in gray, rather than in blue (Minimap) or black (other views). If you edit the sequence to
remove some of the unmatched ambiguity, some of these gray sites will turn black to reflect that the
recognition sequence pattern now matches the sequence pattern. Click here to see an example of
how this option is used.

Note: Back-translations of serine and arginine are overly degenerate and will cause the
prediction of sites that cannot possibly exist. Caution should be used for sites matching
those codons.
*
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Try it! – Apply a restriction enzyme to the
sequence
In this short tutorial, you’ll remove the restriction enzymes displayed on the sequence by default, and
instead display only the DraI enzyme cut sites:

1. If you have not already done so, follow the tutorial Try it! – Create and modify primers for TA cloning.
If you closed the project since following that tutorial, use File > Open to open the file saved at the end
of that tutorial.

2. In SeqBuilder Pro, use File > Open to open demo file COX2.gbk.

3. Remove all enzymes from the view by clicking the Enzymes tool ( ) on the left of the window and
selecting None.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 145 of 302



4. To search for the DraI enzyme, click on the Enzymes tab near the top right of the window. In the
Filter search area, type ‘dr,’ the first two letters of DraI. Add a checkmark next to DraI.

5. Observe that two DraI cut sites now appear in the view.

This completes the “Try it!” for displaying restriction enzyme sites.
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Example of showing potential cuts at
ambiguous bases
The following example shows the use of the Show Potential Cuts at Ambiguous Bases option, located in
the Enzymes panel:

1. Create a new DNA project and paste in the following sequence, which contains many ambiguous
bases:

ATGWSNGCNAARGCNGARAGGATCCARAARCCNGCNWSNAARGCNCCNGCNGARAARAARCCNGCN

Several enzymes are applied to the sequence automatically and are visible in the Sequence view.

2. From the Enzymes panel, check the box next to AluI, which has the recognition sequence AGCT.

There are two possible outcomes, depending on whether Show Potential Cuts at Ambiguous
Bases is checked or unchecked in that panel:

• ◦ Unchecked (default): Since the literal sequence AGCT is not present in the DNA sequence, no
AluI enzymes appear on the sequence.

◦ Checked: Even though AGCT is not present, RGCN and NGCN are both recognized as
potential sites, and the enzyme AluI appears in six locations on the sequence.

ATGWSAA(RGCN)GARAGGATCCARAARCCWSNAACC(NGCN)GARAARAARCC
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Change the way enzymes are displayed
To change the way that enzymes appear on a particular view:

Description Command

To position the label parallel to the sequence (default).

Format > Horizontal
Labels

To position the label perpendicular to the sequence.

Format > Vertical/
Radial Labels

To set the lead lines above the enzyme label when the enzyme display has been
moved to be under or inside of the sequence.

Note: This command is only enabled in the Sequence and Primer Design views.

Enzymes > Lead Lines
Above Label

To set the lead lines for the enzymes beneath the label.

Note: This command is only enabled in the Sequence and Primer Design views.

Enzymes > Lead Lines
Below Label
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View cut sites and recognition sequence
In the Sequence and Primer Design views:

• To show cut sites, click and hold on a restriction enzyme label. Cut sites are represented by thin blue
lines.

• To display the recognition sequence, press the Alt (Win) or Option (Mac) key while clicking and
holding on an enzyme label. Cut sites are represented by thick black arrows.

In the Sequence, Linear, or Circular views:

To choose whether to display enzyme names or both names and positions, use Enzymes > Show Name/
Position. Make the desired selection and press Apply.

The following image shows the result of choosing Show name and position.
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ORFs
To display open reading frames (ORFs) in the Linear or Sequence views:

Click on the Translations and ORFs tool ( ) and make a selection from the ORFs sub-menu.

Displayed ORFs appear as color-coded boxes and lines. Multiple ORFs can be displayed on the same line,
and stops and starts appear within the color-coded boxes for each ORF. ORFs will change as you edit the
sequence. When ORFs wrap across a line break or, in the case of a circular sequence, across the “end” of
the sequence, there is no end marker at the end of the frame. Symbols within ORFs have the following
meanings:

Start codon in top frames

Start codon in bottom frames

Terminator as start in top frames

Terminator as start in bottom frames

Terminator (stop codon, end of ORF)

Sequence start (linear sequences only)

Sequence end (linear sequences only)

Invalid base (non IUB code) in ORF

To hide a single ORF strand, right-click on the strand and choose Hide ORF Strand.

To specify search criteria for ORFs and designate which ORFs should appear in the views, choose
Sequence > ORF Detection Options. The selection criteria specified in this dialog are used by the Edit >
Find and Find Again when searching for an ORF. Use Minimum ORF size to set the smallest number of
amino acids that make up the ORF. Choose whether to show ORFs with or without a start codon, or both.
Click OK.
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To change the display style for an ORF:

Right-click on it and choose Edit ORF Style. Or double-click on the ORF to select it and choose Sequence
> Edit ORF Style.

In the ensuing dialog:

• Check Line to turn on the outline for the ORF. Change the line color by clicking on the corresponding
color box.

• Use the Weight drop-down menu to set the thickness of the line.

• Check Fill to have the ORF use a fill color, if the shape permits one. Set the fill color by clicking the
color box to the right of the Fill option.

• Check Shadow to have the ORF use a shadow. Set the shadow color by clicking the color to the right
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of the Shadow option.

Click Apply to apply the changes before closing the dialog.

Note: The other options on this dialog are not available for ORFs.*
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Translations
SeqBuilder Pro lets you view the translation for part or all of an open nucleotide sequence or create a new
protein sequence based on the translation of a nucleotide sequence.
To display translations for an open nucleotide sequence:

In the Sequence or Primer Design view, click on the Translations and ORFs tool ( ) and make a selection
from the Reading Frame sub-menu.

After displaying a translation, you can modify it as follows:

• To hide a translation strand, right-click on it and choose Hide Translation Strand.

• To create a translation for only the selected portion of the sequence, in the Sequence view, click on

the Translations and ORFs tool ( ) and choose Create Translation. Type a name and press OK.

• To control the display and numbering of the translation, use the Translations table located in the
Settings panel.

• To toggle between displaying amino acids as 1- or 3-letter codes, choose Sequence > Translation
Display > Three Letter Code or Sequence > Translation Display > One Letter Code.

To save the translation of a DNA/RNA sequence as a new protein sequence:

• To create a new protein sequence from one nucleotide sequence, see Create a New Sequence.

• To create new protein sequences from multiple nucleotide sequences simultaneously, see Create
translations of multiple sequences

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 153 of 302



To change or modify the genetic code used for translations:

See the topics Choose the genetic code and Modify the genetic code.

The following video provides a brief walkthrough of translation in SeqBuilder Pro.

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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Choose the genetic code
To select a genetic code to use in translations:

1. Select Sequence > Select Genetic Codes. The active genetic code is preceded by a check mark.

2. Click on a code to select it. The default genetic code used is the Standard Genetic Code.

3. If prompted, navigate to the location of the genetic code file. By default, this location is:

• Windows 7 & Windows 8: C:\Users\Public\Public Documents\DNASTAR\Lasergene x Data\
GeneticCodes

• Macintosh: Hard Drive:Applications:DNASTAR:Lasergene x:GeneticCodes
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Modify the genetic code
To modify and rename a genetic code:

1. Open a sequence or SeqBuilder Pro project.

2. Select Sequence > Edit Genetic Code. The two-tabbed Genetic Code Editor appears.

————-
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Task How to…

To assign a
name for the
code

Type a name into the Description field.

Warning: If you do not make changes to this field, the original genetic code will be
overwritten with any changes made below.

To specify
whether the
code is for RNA
or DNA

Select RNA or DNA from the drop-down menu in the upper right of the dialog.

To modify
codon
assignments,
including stop
codons

In the Genetic Code tab, use the mouse to drag a codon to the appropriate amino acid row.
The color of the codon will change from red to black to show it has been moved. SeqBuilder
Pro only considers red codons when it calculates the aggregate codon for the set.

To include the In the Genetic Code tab, Alt+click (Win) or Option+click (Mac) on the codon to change it
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newly moved
codon when
calculating the
aggregate
codon

back to red. The sum of all codons in the row is recalculated to give the revised reverse
translation codon. The same recalculation occurs instantly when a codon is removed from a
row. Reverse translation codons, shown in the third column from the left, are the codons
used in reverse translating a protein sequence.

To change the
codons that will
be used for
back translation
without
changing the
forward
translation

In the Genetic Code tab, Alt+click (Win) or Option+click (Mac) on codons to exclude. For
example, in the Standard Genetic Code, there are two codons for Cysteine (UGU and UGC)
and the default reverse translation codon is UGY (Y means pyrimidine, i.e. C or U). To
reverse translate Cysteine residues as UGC, Alt+click (Win) or Option+click (Mac) on the
UGU codon to change its color to black so it is not considered for reverse translation. The
reverse translation codon for Cysteine will now read UGC instead of UGY.

To edit start
codons

In the Start Codons tab, select the desired start codons visually by finding the row
containing the first base (on the left), following that over to the column belonging to the
second base (in the center) and selecting the row in the table that aligns with the third base
(on the right). Click an amino acid to turn it green, and cause > to appear beside it. The
codon representing the amino acid now appears at the top of the screen to the right of the
word Starts.

To remove a
start codon from
the list at the
top of the page

In the Start Codons tab, click on the corresponding amino acid in the body of the table.

3. Click OK. If you have changed the description, SeqBuilder Pro requests confirmation.

Task How to…

To refuse the changes and return to using the
original configuration of the genetic code Select Discard.

To save the genetic code under a new name Select Save As. In the Save dialog, type a name for the
modified code. Do not change the save location. Press Save.

To return to the Genetic Code Editor and
continue modifying the genetic code Select Cancel.

Caution: Changes made to a genetic code in SeqBuilder Pro will affect the same genetic
code in all other Lasergene applications.

!
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Rulers
To display or hide rulers:

Use the Rulers tool ( ). You can also hide a specific ruler by right-clicking on it and choosing whichever
command is available: Hide Ruler or Hide Translation Ruler.

Rulers can only be edited in the circumstances described below:

To change the line weight of the ruler in the Linear view :

Right-click on the ruler and choose Edit Ruler Style to open the Edit Feature Style dialog. Select the
desired weight from the Weight drop-down menu. All other options are disabled.

To edit the header ruler in the Sequence view :

Right-click on the ruler and choose Ruler Settings.
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• Enter values for Major and Minor tick marks. Major must be a larger number than Minor or else a
warning will be displayed.

• To display the sequence without grouping, keep the default selection of None. To display it in groups
of 3 bases or 10 bases, select the corresponding radio button. To display the sequence in any other
grouping, choose Other and type a number into the text box.

• The font style is shown in the Appearance section. To change the font, click Change and choose from
available font, style and size options.

After making any desired changes, click OK.

To edit the translation ruler in the Sequence view :

After following the steps in Create a translation for only the selected portion of the sequence, a partial
translation ruler is displayed. There are two ways to edit this ruler. One way is described in the topic
Settings panel. Another way is described below:

Choose Format > Translation Ruler or right-click on a selected ruler, and choose Edit Ruler.
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• To specify that the ruler start with a number other than one (including negative numbers), enter it in
Number from.

• To skip the number zero when a translation ruler numbers amino acids from a negative number to a
positive number, check Skip 0.

Example:

If Skip 0 was unchecked, the sequence would be -3, -2, -1, 0, 1, 2, 3

If Skip 0 was checked, the sequence would be -3, -2, -1, 1, 2, 3, 4
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Primers
SeqBuilder Pro lets you design primers for regions of interest on your sequence. The following video is a
brief overview of SeqBuilder Pro’s primer design workflow.

To learn more about working with primers, see:

• Create primer pairs automatically

• Create a primer based on a selected region of sequence

• Import primers

• Pair primers manually

• Edit primers

• Choose, show or hide primers

• Export primers

• Delete primers

• Methods used in primer design
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Create primer pairs automatically
To design primer pairs:

Open the Sequence, Linear, Circular or Minimap view and use the mouse to select the region you wish to
amplify. If none of the sequence is selected, the entire sequence will be amplified. Choose Priming >
Create Primer Pairs.

In the Create Primer Pairs dialog, define the required conditions for identifying primer candidates.

Learn about “Locations” settings

The Locations section of the Create Primer Pairs dialog allows you to specify parameters that define where
SeqBuilder Pro will search for primers on your sequence.

Specify allowable primer locations by selecting one of the two radio buttons:

Primers end exactly at selection searches for primers that lie exactly within the selected region.
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Choose optimal primer location searches for a specified maximum number of primers that begin and end
within the distance specified outside of the selected region. When this option is selected, two additional
options are enabled. The default is to Stay within 0 bp of the selection and Display at most 1 primer
pair. If desired, you may type different numbers in these boxes.

If desired, you may change the region selected for amplification by editing the coordinates in the Amplify 5’
to 3’ fields. If you wish to create a product that wraps the origin, enter a 3’ coordinate that is less than the 5’
coordinate. Alternately, you can select a feature that wraps the origin prior to opening the dialog. To create
product on the reverse strand, select the region you wish to amplify as a feature on the reverse strand
before opening the dialog.

Learn about “Conditions” settings

The Conditions section of the Create Primer Pairs dialog allows you to specify the initial salt concentration, which
affects the calculation of predicted melting temperature.

By default, the salt concentration is 50.0 mM. This value may be adjusted to correspond to actual
experimental conditions.

Learn about “Primer Characteristics” settings

The Primer Characteristics section of the Create Primer Pairs dialog enables you to limit your search for
primers based on primer length, target melting temperature, and primer interactions at the 3’ end. You also
have the option to avoid known repetitive sequences that are likely to cause mispriming.

• Primer length minimum defines the minimum acceptable primer length. Primers must be at least this
length (in bp) in order to be considered for selection.

• Primer length maximum defines the maximum acceptable primer length. Primers must not exceed
this length (in bp) in order to be considered for selection.
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• Target Tm defines the target primer melting temperature. SeqBuilder Pro will attempt to locate
primers as close to this value as possible.

• 3’ pentamer stability defines the threshold for pentamer stability at the 3’ end of the primer.
Pentamer dG values at the 3’ end exceeding this value will not be considered for selection. See The
Pentamer Profile for additional information.

• Unique at 3’ for n bp defines the number of base pairs at the 3’ end of the primer that must be
unique in order to be considered for selection. Uniqueness of at least 12 or more bases reduces the
likelihood of mispriming at another site.

• Ignore duplexing n bp from 3’ defines the number of base pairs from the 3’ end of the primer where
duplexing can be ignored.

• Check the box next to Avoid repeats in catalog if you have known repetitive sequences that you
wish for SeqBuilder Pro to ignore when selecting primer locations. Click Choose to locate and select
your file containing the repetitive sequences. The file must be a tab-delimited .txt file created
manually through a text editor. If a .txt file is used, each line should include, from left to right, the
sequence fragment, then a tab, then the name or notation.

______________________________

After making changes, you can return to the original settings, if desired, by clicking the Defaults button.
Once the settings are as you wish, click OK to begin the search.

After attempting to create primer pairs automatically, there are two possible outcomes:

• If primer pairs were not located, a dialog appears saying that “No primer pairs were found.” In most
cases, this issue can be resolved by changing the settings in the Primer Characteristics dialog. This
time, allow SeqBuilder Pro to choose the primer locations by using or relaxing the Choose optimal
primer location parameter. Alternatively, you can create primers using Priming > Create Primer
from Selection and then manually pair them together.

• If primer pairs were located, SeqBuilder Pro creates and displays a PCR_product feature, two
PCR_primer features, and a PCR_frame feature for each located primer pair. Just like any other
feature, these are visible in the Primer Design view and the graphical views.
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Create a primer based on a selected region of
sequence
To create a primer based on a selected region of sequence:

1. Open the Primer Design view.

2. Select some or all of the sequence.

3. Select Priming > Create Forward Primer to create the primer on the forward strand, or Priming >
Create Reverse Primer to create the primer on the reverse strand.

A new primer feature is added automatically and is visible in all graphical views. The forward/reverse primer
is also added as an row in the Primers view.
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Import primers
To import primers from an external primer catalog:

1. Select File > Import Primers from a Catalog.

2. Choose a primer catalog (.pri).

SeqBuilder Pro attempts to locate each primer in the catalog on the current sequence by searching
for sites on the template that match at least the 12-mer at the 3’ end of the primer. Those that are
found are annotated as PCR_primer features and added to the Primers view. If primers were located,
a message confirming the new primers will appear:

Each PCR_primer feature added as a result of importing primers will have three qualifiers:

• ◦ /primer - the primer sequence

◦ /note - any notes for the primer that were contained in the catalog

◦ /set - the set number SeqBuilder Pro assigns to the group of imported primers. The Primers
view uses set numbers to organize primers into groups.

Note: After designing primers, a feature of the amplified segment is created. When you
import the primers from a primer catalog, however, the amplification features are lost.This is
by design, as primers can be imported onto an unrelated sequence. However, if you import
primers from a catalog, the PCR_primer features appear in both the Features and Primers
views. If you then select a pair of primers from the Primers view and choose Priming > Pair
Selected Primers, a new PCR_product feature will be added to the Features view

*
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Pair primers manually
To manually create a new primer pair from two existing primers (as an alternative to creating primer pairs
automatically ):

1. Select the primers you wish to pair using either of these methods:

• ◦ From within the Primers view, click on the row of the first primer, and then Ctrl/Cmd+click on
the row for the second primer.

◦ From within the Primer Design view, click on the first primer feature, and then Shift+click on
the second primer feature.

2. Select Priming > Pair Selected Primers.

A new primer pair is created from the two selected primers, and becomes the active pair.
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Edit primers
There are several ways to edit a primer in the Primers view or the Primer Design view:

• Modify a base in the primer

• Modify the primer length

• Introduce a codon change or mutation

• Introduce restriction sites
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Modify a base in the primer
To modify a base in the primer:

1. Create or import primers or primer pairs.

2. Modify bases using either of these methods:

• ◦ For single primers only (i.e., the primer cannot be part of a primer pair) – From within the
Primers view, click inside the Primer Sequence column and edit the existing nucleotide
sequence.

◦ For single or paired primers – From within the Primer Design view, click on the Selection Mode
tool ( ) at the top left of the window. Overwrite the nucleotide character with the desired
character. The edited nucleotide and the resulting changes in translation are shown in magenta.
Restriction enzymes whose recognition sites are eliminated by the edit are shown in blue; sites
that are introduced by the edit are shown in magenta.
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Modify the primer length
To modify the primer length:

1. Create or import primers or primer pairs.

2. From the Primer Design view, click on the Selection Mode tool ( ) at the top left of the window.

3. Do any of the following:

• ◦ Use the mouse to drag one or both handles at the ends of each primer in either direction.

◦ Select a base at either end of the primer and press the Delete key.

◦ Select a base at either end of the primer and press the Ctrl/Cmd key while pressing the left or
right arrow keys on the keyboard.
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Introduce a codon change or mutation
To introduce a codon change or mutation:

1. Create or import primers or primer pairs.

2. Open the Primer Design view.

3. Select the Introduce Codon Change/Mutation tool ( ) at the top left of the window; or choose
Priming > Introduce Codon Change/Mutation.

4. Click on the codon of interest to open a codon menu showing the current codon checked. The menu
lists synonymous codons and other amino acids for introducing non-synonymous changes.

5. Select an alternate codon (for silent mutations), or an alternate amino acid (for non-silent mutations).
Selecting an alternate amino acid will replace the sequence via the least disruptive alternate codon.
Codons which have been changed cause an edit to the primer, with changes appearing in magenta.
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Try it! – Create and modify primers for TA
cloning
To create a primer pair for a region of interest on the sequence to use in TA cloning:

1. If you have not yet download and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. Use File > Open to open the demo file Tn5w.sbd. The file opens in the Linear view.

3. Click on the neomycin/kanamycin resistance feature labeled aminoglycoside-3’-O-
phosphotransferase to select that range of sequence.

4. Select Priming > Create Primer Pairs. The Create Primer Pairs dialog appears.

5. Click the triangles next to Conditions and Primer Characteristics to expand those sections.
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In most cases, you will not need to change the settings in this dialog. For the purposes of this tutorial,
however, you are going to deliberately make a change such that the default Primer length values will
not yield optimal results.

6. Adjust the Target Tm to 55.0 C. Leave the rest of the values as they are, and then click OK.

SeqBuilder Pro will choose the best primer pair with the characteristics specified that lies within the
selected region. The upper view of the SeqBuilder document is now the Primer Design view, focused
on the forward strand of the primer. The lower view is the Primers view. display it in the Primer
Design view.

7. If necessary, drag the dividing bar between the Primer Design and Primers views so that you can see
all three sections of the Primer Design View: Residue, Mispriming and Alternate Pairs.
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In the Primer Design view (upper pane), notice that, in the Mispriming section, the Most stable dimer
and Most stable pair dimer are both labeled “BAD!” This indicates that the final pentamer value of
the dimer exceeds the 3’ pentamer stability threshold defined in the Primer Characteristics section
of the Create Primer Pairs dialog. In general, you should avoid using primers with dimers or hairpins
labeled “BAD!” unless you have experimental evidence that they will function as desired, or unless
you have no other option.

8. In the Primers view (lower pane) the single primer pair located by your search is displayed. Click the
plus sign next to Set 1 to expand the primer pair and view each individual primer within the pair.
Notice that the melting temperature for the Forward primer is lower than the Target Tm of 55°C.

9. In the Primer Design view (upper pane), select the codon change mode by clicking on the Introduce

Codon Change/Mutation button ( ) near the top left of the view. Notice that the cursor changes
to an arrow, and that each codon is highlighted as you hover over the primer sequence.

10. Introduce a codon change by clicking on the TTG triplet in the primer, located at 1577-1579 of your
sequence. From the list of codons given, select CTA.
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In the sequence area, the two changes to the primer sequence, and the corresponding changes to the
translation, are shown in magenta in lower case.

(In the Primers view, these edits appear in lower case, but without any color change).

In the mispriming section, note the good news that the dimers/hairpins have either disappeared or are
no longer marked “BAD!.” The bad news is that the header shows the Tm has now dropped further
from the target temperature of 55.0°C, moving from 50.8°C to 44.1°C.

11. Click the Selection mode tool ( ) to exit from the current “codon change” mode.

12. Referring to both the Tm in the header, and the Mispriming section at the bottom of the view, drag the
triangle on the 3’ (right) end of the primer sequence to the right. Increase the length of the currently
22 bp primer, stopping when these two conditions are met: 1) the Tm is close to 55.0°C, 2)
Mispriming contains no items labeled “BAD!.” This occurs when the primer is 31 bp in length and the
Tm is 55.3°C.

13. In the Primers view, name the modified pair by clicking on Pair 1 in the Name column and typing 55
degree pair.

14. Save the project with any name and in any desired location using File > Save As.

The saved project is used in the tutorial Try it! – Use a PCR insert in TA cloning.
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Introduce restriction sites
To introduce restriction sites for primers:

1. Create or import primers or primer pairs.

2. From the Primer Design view, either click on the Introduce Restriction Site tool ( ) at the top left
of the window, or choose Priming > Introduce Restriction Site.

3. Click between the residues where the restriction site should be added. This opens a top level menu
with the restriction enzymes identified to cleave the sequence at a specific location:

• ◦ <Specific enzymes by name>

◦ Non-silent substitutions

◦ Any enzyme – Select this option to choose an enzyme from a submenu. If you are looking for a
particular enzyme, click on the top-level menu, then type the first 1-2 letters of that enzyme.
This will automatically navigate to the part of the submenu list where the enzyme is located.

◦ Enzymes that don’t cut product – See note for Any enzyme, above.

◦ Introduce a stop

New restriction sites are displayed in magenta, as well as nucleotides in the primer sequence and
their translations that differ from the template. Restriction enzymes whose recognition sites are
eliminated by the edit are shown in blue.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 177 of 302



Choose, show or hide primers
To choose a selected primer pair (i.e. make it the active pair):

Within the Primers view, select a primer pair and choose Priming > Set as Active Primer. The selected
primer pair will be opened in the Primer Design view, where it can be edited or analyzed.

To display the forward/reverse (i.e., top/bottom) strand primer of the current primer pair in the center of the
Primer Design view, choose Priming > Show Forward Primer or Priming > Show Reverse Primer.

To show or hide primer pairs:

Open the Primers view. In In the Show column, checked rows represent primers currently displayed in the
graphical views. If you wish to sort the rows before selecting the primer pairs to show/hide, click on the
column header of interest. In the Show column, add check marks in rows you wish to display and remove
them from rows you wish to hide.

To show or hide alternate pairs:

In the Alternate Pairs section (lowermost pane) of the Primer Design view, right-click on a primer pair and
choose an item from the context menu:

Context menu option Function

Hide Pair To hide a selected pair.

Delete Pair To delete a selected pair.

Show Only This Pair To hide all but the selected pair.

Show All Pairs To show all found pairs.
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Export primers
To export primers:

1. Create or import primers.

2. Open the Primers view.

3. Choose File > Save Primer Catalog.

4. Select one of the following three formats:

• ◦ Tab-delimited text (.txt) – Values from the Set Name, Pair Name, T/B, and Primer Sequence
columns are exported from the Primers, as well as the sequence range of the primer, and saved
as a tab-delimited text file.

◦ FASTA (.fas) * – * The primer sequences are exported as a single FASTA file. A name for each
sequence is derived from the sequence range, the pair and set names, and whether the primer
is on the top (T) or bottom (B) strand. For example: T_1712..1731_Pair_1,Set_1

◦ Primer catalog (.pri) * – * The primers in the Primers are exported as a primer catalog for
future use in SeqBuilder Pro.
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Delete primers
To delete a primer or PCR product:

1. Open the Primers or Primer Design view.

2. Select the corresponding feature and select Features > Delete or Edit > Delete Feature. Or right-
click on the feature and choose Delete or Delete Feature from the context menu.

3. Confirm the deletion as directed in the table below.

Feature
type Confirmation dialog

General
feature

“Are you sure you want to delete the feature…?”

Confirm the deletion by pressing Yes.

Primer
that is part
of a primer
pair

“Delete the primer?”

To delete both primers from a pair, not only the selected primer, check Also delete the
associated primer. To also delete the PCR product associated with the selected primer, check
Also delete the associated product. After checking or unchecking the boxes, press Delete.

PCR
product

“Delete the PCR product?”

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 180 of 302



To delete both of the primers associated with the selected PCR product, check Also delete the
associated primer pair. After checking or unchecking the box, press Delete.
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Methods used in primer design
To learn about considerations for calculating primers and primer pairs, see the following topics:

• Thermodynamic models

• Pentamer profile

• Annealing temperature

• Melting temperature
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Thermodynamic models
The stability of a particular double stranded sequence is related to the number of hydrogen bonds formed.
GC rich sequences pair with greater stability than AT rich sequences, but sequence ordering is also a
component of stability. For example, the duplex AA/TT forms a more stable pair than the duplex AC/GT due
to the more favorable interaction of neighboring bases in the duplex. SeqBuilder Pro uses the nearest
neighbor model to measure the stability of a given duplex. It is based upon the free energy of adjacent
dinucleotides and calculated from dinucleotide entropy and enthalpy data presented in Bresslauer et al. for
DNA, and Freier et al. for RNA.

The calculation of free energy (∆G) is ∆G = ∆H - T∆S, where ∆H is enthalpy, ∆S is entropy and T is
temperature. The value of T is 25°C.

The calculation of ∆H and ∆S is where the dinucleotide data come in. For a given sequence, S(abcde): ∆H
is the sum of dinucleotide ∆H values [∆H(abcde) = ∆H(ab) + ∆H(bc) + ∆H(cd) + ∆H(de) + ∆H ini], where ∆H
ini is a helix formation constant.

∆S is the sum of dinucleotide ∆S values [∆S(abcde) = ∆S(ab) + ∆S(bc) + ∆S(cd) + ∆S(de) + ∆S ini], where
∆S ini is a helix formation constant.

SeqBuilder Pro uses ∆G values computed over the entire template sequence and ∆G values computed in
pentamer windows to evaluate the stability of a given primer. Selected primers will have ∆G values near the
mean ∆G computed over the entire template, pentamer ∆G values lower than the mean at the 3’ end, and
for pair scoring, a stability profile of pentamer ∆G values above the mean near 5’ and descending toward 3’.

Wherever possible SeqBuilder Pro uses the nearest neighbor method for computing the ∆G and the Tm of
primers. These models are valid for sequences of less than 50 bases. For long primers, probes and
products a less accurate method of computing free energy is used, which is based upon the GC content of
the sequence.
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Pentamer profile
Pentamer free energy is one of the most important considerations in designing good primers. To perform
well a primer needs to have low stability at the 3’ end (usually higher than -8.5 kCal/mol) and higher stability
toward the 5’ end. This will help to eliminate false priming, as stability is low at the 3’ end (where
thermostable DNA polymerase binds), and higher upstream. This means that if a primer hybridizes at all (3’
first), it will bind even more strongly with a good 5’ upstream match. This is why a descending 5’ -3’ free
energy profile is important.

For example, the primers below performed poorly due to their low pentamer ∆G values at the 3’ end. Their
high 3’ stability makes it easy to bind in many template locations.

By contrast, the following primers performed well, due to their higher pentamer ∆G values at the 3’ end.
Pentamers with higher ∆G value (less negative!) are less stable. They would not hybridize in as many
template locations due to the low 3’ stability, but would bind more strongly upstream.
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Annealing temperature
To amplify products with high fidelity it is important to choose an annealing temperature that is optimal for
the specific combination of primers and template sequence. A carefully chosen annealing temperature (Ta)
will significantly affect product yield and reduce the amplification of partially polymerized products. Ta
calculations used by SeqBuilder Pro are as presented in Rychlik et al. :

Ta = 0.3 Tm Primer + 0.7 Tm Product – 14.9

Where Tm Primer is the minimum Tm of the two primers using the appropriate method and Tm Product is
the product Tm using the appropriate GC content formula.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 185 of 302



Melting temperature
Melting temperature is an important factor in primer design. After the template sequence has been
evaluated for free energy, SeqBuilder Pro can then determine melting temperatures for the template and
subsequently located primers. PCR primer pairs which perform well have closely matched melting
temperatures to promote amplification of both strands in equal amounts. The Tm of primers is calculated
using entropy and enthalpy data from the nearest neighbor models:

…where salt is the concentration of Na+ in moles, R is the molar gas constant 1.987 cal/mol°C, and c is the
initial concentration of the primer.

For long primers and probes (greater than 50 bases) and for products, a formula based upon GC content
(Baldino et al. 1989) is used to calculate Tm.

For DNA:

For RNA:

For DNA-RNA:

Replace 0.35 (%formamide) with 0.50 (%formamide), as presented in Wahl et al..
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Plasmid Auto-Annotation
SeqBuilder Pro’s built-in plasmid Feature Library contains over 150 curated features, and allows you to add
your own features, as well.

If your vector sequences lack some annotations, or contain incomplete or obsolete versions of annotations,
you can effortlessly annotate them from the curated versions. Conversely, if you prefer your vector
sequence annotations to the curated versions, you can automatically update the Feature Library with the
new information.

Watch this video to see how easy it is to update vector file annotations:

While the actual auto-annotation takes only a few seconds, there are several optional procedures you may
wish to do before auto-annotating:

• Create a custom feature database for auto-annotation searches

• Specify the features to use in auto-annotation

• Specify the appearance of features in the Annotation Results window
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Create a custom feature database for auto-
annotation searches
When you auto-annotate vector sequences, SeqBuilder Pro searches for potential matches in the installed
Feature Library, and in a custom database of features named “User” features. Creating a custom “User”
database is optional.

To create a “User” database and add features to it:

1. Move sequences to the Feature Library by doing either of the following:

• ◦ From the Circular, Linear, or Sequence views, click on a feature or select a range containing
the desired feature(s). The selection must be at least 15 bp in length. Then choose Features >
Send to Feature Library; or select the feature and use Features > Send to Feature Library.

◦ Use Features > Feature Library Manager to open the Feature Library Manager. Then drag a
sequence at least 15 bp in length from your computer’s file explorer and drop it on the library
window.

If you send a sequence range or an entire sequence to the database, any features are stripped out of
the sequence and saved as separate entries in the database.

2. Repeat the above step until you have added all the desired features. Note that if you add the same
feature multiple times, all of them will be saved in the database. However, during auto-annotation,
only one will be selected as the “best” match to the query sequence.

3. Select File > Save Project. In most cases, you should save the file with the original name and
location. An exception is if you will be creating different User databases for different organisms. In
that case, save each database using a unique descriptive name and the default .library extension.
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Feature Library Manager
The Feature Library Manager is a browser for the over 150 entries in SeqBuilder Pro’s built-in plasmid
Feature Library, and allows you to add your own features to the database. This window also lets you specify
the appearance of features in the Annotation Results window.

The tools at the top of the window control aspects of how the Sequence view, and sometimes the Linear
view, are displayed or formatted in this window. The selected formatting will also be used for any auto-
annotations that originate from the Annotation Results window. Use of these tools is described in Specify
the appearance of features in the Feature Library Manager and the Annotation Results window.

The top pane in the main portion of the window shows the Sequence view for the selected feature. The
display of cut sites, sequence(s), translations, rulers and features in this section depends on choices made
using the tools at the top of the window. When multiple features are selected from the Feature list (see
below), sequences and translations in this view are displayed as a series of n’s, and no cut sites can be
displayed.
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The middle pane of the Feature Library Manager displays the Linear view for the selected plasmid feature.
The display of cut sites and features in this section depends on choices made using the tools at the top of
the window. When multiple features are selected from the Feature list (see below), no cut sites can be
displayed in this view.

The bottom pane of the Feature Library Manager shows the Feature list for the selected plasmid feature.
Items in this section can be edited by clicking on them and typing, just as in SeqBuilder Pro’s main Features
view. If multiple items are selected in the Feature list, this pane is blank.
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Specify the features to use in auto-annotation
To specify the features to use in auto-annotation:

Specifying which features to use in auto-annotation is optional.

1. Choose Features > Feature Library Manager. This automatically loads the installed database file
named feature.library. The Feature list on the left of the Feature Library Manager is populated with the
name of each feature in the installed database, but the rest of the window is unpopulated.

2. (optional) To choose a different feature database, use the drop-down menu under the list. DNASTAR
represents the installed library features, while User represents a custom database.

3. To populate the remainder of the window, select a feature from the Feature list by clicking on its
name. You can select multiple features using Ctrl/Cmd+click or Shift+click, but sequence bases,
translations and cut sites will not be displayed in this case. Multiple selection is used primarily to
apply style changes to a number of library items simultaneously (see below).

To find a feature of interest, type its name (or a portion of its name) in the search bar above the list
and press Enter/Return on the keyboard. To clear search results and return to the full list, press the
‘x.’

4. To specify which features to include/exclude from an auto-annotation search, check or uncheck the
boxes next to their names. By default, all features on the list are checked. Unchecked features are
grayed out.
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5. To save changes made in the Feature Library Manager, choose File > Save Project. These are the
two types of changes that are preserved even when you update from one Lasergene version to
another:

• ◦ The presence or absence of check marks in the Feature list on the left. Unchecked items will
not be considered when searching for matches in the Annotation Results window.

◦ Changes made in the Features pane (for changing the format style) are used in auto-annotation
of features in the Annotation Results window.
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Specify the appearance of features in the
Feature Library Manager and Annotation
Results window
You can use the tools at the top of the Feature Library Manager to control how features are displayed in the
Manager, itself, and in the Annotation Results window after performing the auto-annotation procedure. This
step is entirely optional.

For example, you could specify that all lacZ features be shown using light blue arrows outlined in purple.
Later, when you looked for query matches in the Annotation Results window, all lacZ features would be
displayed in the specified style. To try a similar workflow, see Try it! – Create a style set for CDS features.

The following table describes how to use the tools to change the appearance of features.

Tool Menu options Lets you specify…

Enzymes

Whether to display a particular class of enzyme cut sites,
or no cut sites, on both the Sequence and Linear views.
The available selectors are a subset of those available
using the Filter by Selectors check boxes in the upper
pane of the main SeqBuilder Pro Document window.

Note: When multiple features are selected from the
Features view, no cut sites are displayed, regardless of
the selection made here.

Strand
Whether to show the sequence for the top strand, or for
both top & bottom strands, on the Sequence view.

Ruler
In the Sequence view, whether to place a ruler under the
sequence, under the translation, neither, or both.
Choosing Translation Ruler or Both causes a
translation of the sequence to appear, along with the
sequence.
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Translation
Whether to display translations in the Sequence view for
1 or 3 reading frames and for top and/or bottom strands.
The options are similar to the Full Translation
checkboxes in the upper pane of the main SeqBuilder
Pro Document window.

Features

Style options for annotations in the Sequence and Linear
views.

• To display an outline around the feature, check
the Line box and choose a line Weight using
the drop-down menu.

• To select a different line color from the current
color, click on the colored box to open the color
chooser.

• To hide the outline, uncheck the Line box.

• To provide a solid fill color or drop shadow for
the feature, check the Fill or Shadow box. If a
different color is desired, click on the
corresponding colored box to open the color
chooser.

• To remove the fill color or drop shadow,
uncheck the box on the left.

• To choose a different shape for the feature,
select an option from the Shape drop-down
menu.

• To choose what type of line to use in linking
multi-segment features, make a selection from
the Linkage drop-down menu. The “DNASTAR”
(installed) library does not contain multi-
segment features, but such features can be
added as “User” features.

• To include a label for the feature, check Label
Attached. Use the Label Position drop-down
menu to specify a location for the label.
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Try it! – Create a style set for CDS features
The Feature Library Manager can be used to specify how to display particular features or groups of features
when auto-annotating plasmids/vectors in the Annotation Results window. This tutorial shows how to specify
a particular style for displaying all CDS features, but can be adapted to design style sets for any individual
feature or group of features in the Feature Library Manager.

1. Choose Features > Feature Library Manager.

2. In the Search bar on the top left, type in CDS and press Return/Enter on your keyboard. All non-CDS
features will be removed from the Feature list below the search bar.

3. Select all items remaining in the Feature list (i.e., the CDS features) by clicking on the first feature on
the list, and then Shift+clicking on the last feature.

4. Click on the Style tool at the top right of the window ( ) to open the Style pane.

The feature is currently displayed as:
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5. Change the Line and Fill colors to lilac by clicking on the corresponding color boxes. Change the
Weight to 8, and change the Shape to Stroked Arrow. Specify a Label position of Inside.

The feature is now displayed as:

6. Press the ‘x’ in the top corner of the window to close it. When prompted to save, choose Yes.

7. Follow the steps in Perform the auto-annotation procedure. CDS features will preserve the style
formatting set up in the steps above.
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Perform the auto-annotation procedure
If your vector sequences lack some annotations, or contain incomplete or obsolete versions of annotations,
the following procedure lets you effortlessly copy features from a curated Feature Library, or from your own
custom features, to the query sequences. Conversely, if you prefer the query annotations to the library
versions, you can automatically update the Feature Library version to match the annotations in the query
sequences.

Before following the steps below, you may wish to create a custom feature database, specify the features to
use in auto-annotation, or specify the appearance of features in the Feature Library Manager and
Annotation Results window. These preliminaries are entirely optional.

To auto-annotate a vector sequence from the installed Feature Library and/or your own custom feature
database:

1. (optional) If you have created multiple “User” databases (e.g. for different organisms), you must
change one of the databases to the default library name before proceeding. To do this, navigate to
C:\Users\UserName\AppData\Local\DNASTAR/UserFeatures.library (Win) or ~/Library/Preferences
(Mac) and temporarily rename the file UserFeatures.library.

2. Use either of the following methods to specify which vector sequence(s) to auto-annotate:

• ◦ Open the desired sequence in the Document window.

◦ Open a cloning project in the Project window. Expand the Vectors folder and select one or
more files or folders.
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3. Choose Features > Annotate Sequence. In the ensuing Annotation Parameters dialog, specify the
thresholds for calling a match, or check Perfect matches only to effectively set each value to 100%.
By default, SeqBuilder Pro calls a match when a feature sequence matches at least 95% of bases in
the query sequence (Minimum match percentage) and overlaps the query sequence by 98%
(Minimum coverage percentage). After making the desired selections, press OK.

The Annotation Results window opens. If the query sequence was already up-to-date, a message will
appear: “No new features were found.” In this case, click OK to exit from the annotation procedure.
Otherwise, the Annotation Results window will populate.
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The sortable table at the bottom of the window will likely contain both checked and unchecked rows.
A row with a checkmark in its leftmost column represents an annotation that is absent in the query
sequence. A row without a checkmark represents an annotation that already exists in the query
sequence. The version from SeqBuilder Pro’s plasmid Feature Library may be more accurate or up-
to-date than the annotation currently in the query sequence, so you may also wish to examine these
entries. See The Annotation Results Window for detailed information about the contents of each pane
of the window.

4. Click on a feature row to make it the active feature and to populate the rest of the window with
information relevant to that feature.

5. Use evidence in this window (e.g., match quality, shared endpoints, etc.) to determine whether or not
to copy a feature to the query sequence. For instance, you may wish to copy the feature if the plasmid
database version is more complete, or if it represents a new feature that does not yet exist in the
query sequence.

Example:
An unchecked row was selected in the annotation match table at the bottom of the window. The
Matched Feature / Putative Duplicate Feature panes (below) reveal that both features cover an
identical range, good evidence that they are duplicates. The feature in the query sequence is named
Km( R ), while the plasmid Feature Library calls it KanR but refers to “Kanamycin kinase” and

Features shorter than 15 bases in length are omitted from searches, even if they exist in the
Feature Library as “User” features.*
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“Geneticin®” in the /note and /function fields, hinting further at a possible match.

As it happens, Invitrogen/Life Technologies’ Geneticin® is the antibiotic also called G418. It is an
aminoglycoside related to Gentamicin. The enzyme encoded by this gene confers resistance to
Geneticin as well as the related antibiotics Neomycin and Kanamycin. So Km( R ) and KanR are
indeed the same gene. However, the plasmid Feature Library version on the left contains
considerably more detailed information, and you will probably want to use this information to overwrite
the feature currently in the query sequence.

6. To copy checked features from the Feature Library to your query sequence(s) (or vice versa, for rows

in which Replace has been specified), click on the Accept Checked tool ( ).If you

instead wish to exit without copying any features, click the Cancel tool ( ).

7. If you copied any features to the query, we recommend immediately using File > Save Project to
save them. Otherwise, if you later close the project without saving, any changes will be lost.
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Annotation Results Window
The Annotation Results window displays putative matches between SeqBuilder Pro’s plasmid Feature
Library and one or more query sequences, usually vector sequences from a cloning project. If the query
sequence lacks some/all of the located features from the plasmid Feature Library, or contains incomplete or
obsolete versions of certain features, this window allows you to copy features from the database to the
query sequence. To open the window, select one or more sequences from the Project window and then
choose Features > Annotate Sequence.

This topic describes the layout of the window. To learn how to perform a search, evaluate putative feature
matches and add them to the query sequence, refer to Perform the auto-annotation procedure.

Components of the Annotation Results window are described below from top to bottom. However, note that
the selection made in the lowermost pane determines the contents of all other panes.

After you have examined putative feature matches in the table, use the Accept Checked tool (

) at the top of the window to copy all features checked in the table below to the query

sequence. Alternatively, click Cancel ( ) to close the Annotation Results window without copying any
features.

The header area shows how many matching features were found, and how many were unique.
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The Matched Feature pane near the top of the window shows the full width of the selected feature in the
style specified in the Feature Library Manager. If no style has been specified, it is instead shown in the
default style.

The Match Quality pane displays an alignment histogram that uses the query vector’s coordinate system to
show where a plasmid Feature Library feature matches the query sequence. The top bar represents the
feature from the plasmid database, while the bottom bar shows the location of that match on the query.
Gaps appear as empty space, mismatches are displayed in yellow, and matches appear in green.

The Matched Feature/Context Features pane uses the query vector’s coordinate system to show features
that overlap or are near to the feature selected in the table. Gray vertical lines at the endpoints of the
feature can be used to find features with identical or near-identical endpoints. Imperfect matches can still
represent duplicates. For corroborating evidence, look for significant overlap in features, as well as text field
matches.

The Matched feature and Putative feature panes just above the “annotation match table” lets you compare
text information from the feature in the query sequence (on the right) and the putative plasmid Feature
Library match (on the left). If the query sequence does not already contain the putative feature (i.e., the row
in the table below is checked by default), the right pane will say: “No putative duplicate found.”

The Annotation match table in the lower half of the window consists of a list of annotations that match the
query sequence at the specified thresholds for match and coverage percentage. To sort entries
alphanumerically based on a particular column, click on the corresponding column header.
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The table columns are described below:

Column
name Description

A check mark at the left of a row signifies a unique annotation: it exists in the plasmid Feature
Library, but not in the query sequence. If multiple versions of an annotation match the query, only
the best match is checked, by default. An unchecked row signifies either a non-unique annotation
or a duplicate annotation where one of the other duplicates was a better match. The leftmost
table cell for each row is used to add or remove these check marks manually. When you click on
the cell, a menu opens with the following choices:

• Accept – To transfer the Feature Library version of this annotation to the query
sequence.

• Replace – To overwrite the pre-existing query sequence version of this feature with
the Feature Library version.

• Ignore – To remove an Accept or Replace designation from the row.

Query The name of the query sequence that the plasmid Feature Library match pertains to.

Type Feature type (e.g., CDS, regulatory, rep_origin, etc.)

Matched
Feature Name of the feature for which a match was found.

Score Likelihood that the plasmid database feature is a match for the query sequence, based on
calculations made within SeqMan NGen.

Coverage (Length of the plasmid database feature / length of the putative match in the query sequence) x
100%

5’ Position 5’ Position of the plasmid database feature on the query sequence’s coordinate system.

Strand Contains an arrow showing the strand direction, left ( ) or right ( ).

Length Length of the plasmid database feature.

Description Description of the plasmid database feature.
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Automated Virtual Cloning

Did you arrive here by selecting the DNASTAR Navigator workflow Molecular Biology > Automated
cloning? If so, you’re in the right place!

SeqBuilder Pro supports automated virtual cloning using a wide variety of cloning techniques. Simply select
your insert and vector sequences, and SeqBuilder Pro will automatically construct the virtual clone. Choose
vectors from the vector catalog provided, or add your own custom vectors with ease. Once your clone is
made, the Cloning Summary view shows details about the fragment inserts, primers, fragment junctions, as
well as the steps needed to prepare the vector and amplify the insert. The following video is a brief
introduction to virtual cloning in SeqBuilder Pro:

Virtual cloning consists of optional preliminary steps and the main cloning workflow.

Preliminary steps:

These optional steps take about 2-20 minutes each, but can provide benefits for many future cloning
workflows.

• Add custom vectors to the Cloning Vector Catalog

◦ Create a custom vector for Gateway cloning

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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◦ Create a custom vector for TA cloning

◦ Create a custom vector for directional TOPO cloning

• Auto-annotate vector sequences

Main cloning workflow::

The main cloning workflow takes only a few minutes from start to finish. However, for purposes of
explanation, it has been divided into seven steps.

1. Start a cloning project and specify the insert

2. Specify the method and options

3. Specify the vector and entry clone

4. Digest/linearize a circular vector

5. Run the cloning simulation

6. (optional) Verify the clone

7. View and print cloning results
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Preliminary Step (optional): Add custom
vectors to the cloning vector catalog
A comprehensive cloning vector catalog is installed with SeqBuilder Pro.

Before you begin a cloning project, you can create and add custom vectors to the catalog for a variety of
project types.

• Create a custom vector for Gateway cloning

• Create a custom vector for TA cloning

• Create a custom vector for directional TOPO cloning

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 206 of 302



Create a custom vector for Gateway cloning
If desired, a Gateway cloning vector may be constructed manually and then added to the Cloning Vector
Catalog prior to beginning the cloning workflow. Prepare the vector as follows and refer to the example at
the bottom of this topic.

• Set the type to circular by selecting Sequence > Circular.

• Add misc_recomb features to your sequence on the appropriate sub-sequences where
recombination occurs. Note that while it is preferred for the entire recombination site to exist within
your sequence, SeqBuilder Pro at minimum requires the appropriate att core sequence for each of the
five types of recombination sites. SeqBuilder Pro uses these core sequences along with the feature
labels to correctly identify each Gateway plasmid:

• ◦ Type 1: GTACAAA (forward strand)

◦ Type 2: CTTGTAC (reverse strand)

◦ Type 3: ATTATAC (reverse strand)

◦ Type 4: GTATAGA (forward strand)

◦ Type 5: GTATACA (forward strand)

• Label the features with the following /dnas_title tags:

• ◦ For Expression Clones: attB1, attB2, attB3, attB4, and attB5

◦ For Donor Vectors: attP1, attP2, attP3, attP4, and attP5

◦ For Entry Clones: attL1, attL2, attL3, attL4, and attL5

◦ For Destination Vectors: attR1, attR2, attR3, attR4, and attR5

Example:

The classic Gateway cloning protocol uses only types 1 and 2 of recombination sites.
MultiSite Gateway Pro cloning utilizes all 5 types of recombination sites, which allows you to
recombine multiple regions at one time.
*
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The pAd-PL-DEST sequence provided in SeqBuilder Pro’s Vector Catalog is shown below as an example of
how to use these tags:

misc_recomb 512..636

/dnas_title=“attR1”

/note=“attR1”

/label=attR1

/note=“recombination site for the Gateway® LR reaction”

misc_recomb complement(2092..2216)

/dnas_title=“attR2”

/note=“attR2”

/label=attR2

/note=“recombination site for the Gateway® LR reaction”
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Create a custom vector for TA cloning
If desired, a T-vector for TA cloning may be constructed manually and then added to the Cloning Vector
Catalog prior to beginning the cloning workflow.

To make the vector recognizable for TA cloning, a specific overhang must be created on both strands at the
3’ ends.

1. Use File > Open to open the file or SeqBuilder project containing the vector sequence.

2. Select Cloning > Change Overhangs.

In this dialog, you can use the Trim Blunt or Fill In buttons to simulate modification of overhangs for
incompatible ends, or manually manipulate the overhangs by dragging the arrows located above and
below the two strands. The Revert button lets you return to the default overhangs.

a. Use the arrow sliders to leave one overhanging thymine (T) residue on the bottom left and
another on the top right.

b. Click Change.

3. Choose File > Save.

4. Add the new vector to the Cloning Vector Catalog so it can be used with future projects.
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Create a custom vector for directional TOPO
cloning
If desired, a directional TOPO cloning vector may be constructed manually and then added to the Cloning
Vector Catalog prior to beginning the cloning workflow. To make the vector recognizable for directional
TOPO cloning, a specific overhang must be created at the 3’ end of the forward strand.

1. Use File > Open to open the file or SeqBuilder Project containing the vector sequence.

2. To the 3’ (right) end of the vector sequence, add the bases cacc.

3. Choose Cloning > Change Overhangs.

In this dialog, you can use the Trim Blunt or Fill In buttons to simulate modification of overhangs for
incompatible ends, or manually manipulate the overhangs by dragging the arrows located above and
below the two strands. The Revert button lets you return to the default overhangs.

a. On the left, make sure the pair is blunt, i.e. does not contain any overhangs. On the right, drag
the top arrow to the left to “mask” the bases you just added (cacc). This results in a gtgg
overhang on the bottom right.

b. Click Change.

4. Choose File > Save.

5. Add the new vector to the Cloning Vector Catalog so it can be used with future projects.
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Step 1: Start a cloning project and specify the
insert
The first step in performing a cloning simulation is to specify the insert. The following topics describe six
different methods of specifying the insert to use with your cloning project:

• Option A – Use a sequence file on your computer as the insert

• Option B – Copy inserts from another SeqBuilder Pro cloning project

• Option C – Use an entire open SeqBuilder Pro sequence as the insert

• Option D – Use part of an open SeqBuilder Pro sequence file as the insert

• Option E – Use the PCR product of the current primer pair as the insert

• Option F – Use restriction enzyme cut sites to create the insert
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Option A – Use a sequence file on your
computer as the insert

1. From the Cloning menu, select one of the following commands: Gibson, LIC Cloning; In-Fusion
Cloning, GeneArt Cloning; MultiSite Gateway Pro Cloning; Gateway Expression Clone; Gateway
Entry Clone; Restriction Enzyme Cloning; TA Cloning; Directional TOPO Cloning.

2. In the Project tab on the left of the Project window, right-click on Inserts and choose Import.
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3. Make a selection in the file chooser and click Open.

4. Expand the Inserts folder, if necessary, by clicking on the plus sign.

5. Drag the inserts from the Inserts folder and drop them in the Fragments section near the bottom right
of the Project window.

or…

1. Open your computer’s file explorer and locate the insert sequence(s) of interest.

2. In SeqBuilder Pro, choose File > New Cloning Project.

3. Drag each insert from the file explorer to the Inserts folder of the Project window.

4. Expand the Inserts folder, if necessary, by clicking on the plus sign. Drag the inserts from the Inserts
folder and drop them in the Fragments section near the bottom right of the window.
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Proceed to Step 2: Specify the method and options.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 214 of 302



Option B – Copy inserts from another
SeqBuilder Pro cloning project

1. Open an existing SeqBuilder Pro cloning project that has the desired inserts in its Inserts folder.

2. Press File > New Cloning Project.

3. Drag the inserts from the original project’s Inserts folder into the new project’s Inserts folder.

4. Close the Project window for the older project.

5. Expand the new Inserts folder, if necessary, by clicking on its plus sign.

6. Drag the inserts from the Inserts folder and drop them in the Fragments section near the bottom right
of the Clone tab.
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Proceed to Step 2: Specify the method and options.
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Option C – Use an entire open SeqBuilder Pro
sequence as the insert

1. Use File > Open to open the file or SeqBuilder Project (.sbd) containing the insert.

2. From the Cloning menu, select one of the following commands: Gibson, LIC Cloning; In-Fusion
Cloning, GeneArt Cloning; MultiSite Gateway Pro Cloning; Gateway Expression Clone; Gateway
Entry Clone; Restriction Enzyme Cloning; TA Cloning; Directional TOPO Cloning.

3. Choose File > Add [sequence name] to Untitled Cloning Project ‘n,’ where ‘n’ is a number. The
Document window will become active again.

4. Return to the Project window by clicking on it. In the Project tab, drag and drop the sequence into the
Inserts folder.

5. Expand the new Inserts folder, if necessary, by clicking on its plus sign.

6. Drag the inserts from the Inserts folder and drop them in the Fragments section near the bottom right
of the Clone tab.
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Proceed to Step 2: Specify the method and options.
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Option D – Use part of an open SeqBuilder
Pro sequence file as the insert

1. Use File > Open to open the file or SeqBuilder Project (.sbd) containing the sequence fragment you
wish to clone.

2. Use any of the following methods to select the sequence fragment to use as the insert:

• ◦ Manually select a portion of sequence by dragging the mouse across it.

◦ Click on an existing feature to select the corresponding sequence.

◦ Use the method described in Using a PCR product of the current primer pair as the insert

◦ Use the method described in Using restriction enzyme cut sites to create the insert. Note that
you do not actually need use a restriction enzyme cut site as the sequence fragment. The
sequence fragment can be anything you want: an open reading frame (ORF), multiple cloning
site (MCS; polylinker), feature, or a random selection.

3. Choose Cloning > Clone Selected Fragment, or Cloning > Clone Selected Fragment From
Opposite Strand, as needed. The latter command selects the opposite orientation of the sequence.

The Project window opens with the Clone tab active. The selection from Steps 1-2 is placed in the Inserts
folder in the Project tab, as well as in the Fragments section near the bottom right of the Clone tab.

Proceed to Step 2: Specify the method and options.
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Option E – Use the PCR product of the
current primer pair as the insert
If you will be using the TA cloning method, you can use the PCR product of the current primer pair as an
insert.

1. Use File > Open to open the file or SeqBuilder Pro project (.sbd) containing the sequence of interest.

2. Create primer pairs.

3. With the Primer Design or Primers view active, choose Priming > Create Insert by PCR.

SeqBuilder Pro extracts the sequence of the PCR product, including any modifications you have
made, and simulates its amplification with Taq polymerase including the addition of 3’ A overhangs to
each end. Primer and product features are carried forward with the insert. The Project window opens
with the new Taq-amplified insert in the Inserts folder.

4. Drag the insert from the Inserts folder and drop it in the Fragments section at the bottom of the
Cloning tab.

Proceed to Step 2: Specify the method and options.
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Option F – Use restriction enzyme cut sites to
create the insert

1. Use File > Open to open the file or SeqBuilder Pro project (.sbd) containing the vector sequence.

2. Use the Enzymes tool ( ) to apply the set of Unique Sites.

3. When you find suitable left and right cut sites, select the region between them by clicking on the label
for the restriction site on one end and then Shift+clicking on the label on the other end.

4. Choose Cloning > Copy Restriction Insert or use the keyboard shortcut Ctrl/Cmd+Shift+V.

5. Choose Cloning > Paste Restriction Insert.

The two-tabbed Clone Insert dialog opens, with separate tabs for the Left (5’) End and Right (3’)
End. The corresponding ends of the vector sequence are displayed adjacent to insert ends on each
panel.

There are several operations you can perform while in this dialog:
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• ◦ To simulate modification of overhangs for incompatible ends, use the Trim Blunt or Fill In
buttons.

◦ To manipulate the overhangs manually, move the arrows above and below the two strands.
This can be used to simulate partial fill or end protection.

◦ To return to the default overhangs, click Revert.

◦ To flip the insert, with respect to the vector, check the Reverse Complement Insert box.

◦ The translation for the reading frame specified in the Translate field is shown between the top
and bottom strands for both the vector and insert sequences. As the ends of the vector and
insert are adjusted, the translation is updated automatically. To view the translation for a
different reading frame, select the desired reading frame from the Translate drop-down menu.
Reading frames in this list correspond to the reading frames displayed on the Primer Design,
Sequence, and Linear views.

6. Once the vector and insert have been constructed with compatible overhangs, click the Clone button.

7. Choose Cloning >Restriction Enzyme Cloning.

8. The Project window opens with the Clone tab active. The selection from Steps 1-2 is placed in the
Inserts folder in the Project tab, as well as in the Fragments section at the bottom of the Clone tab.

Proceed to Step 2: Specify the method and options.
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Step 2: Specify the method and options
After beginning a cloning project and specifying the insert, the cloning project should appear similar to the
one below. This example shows four inserts, but your project may contain any allowable number for the
cloning method you will be using. The circular cartoon in the upper right corner displays inserts in the same
order in which they appear in the Fragments section. The cartoon text prompts you to “Choose a vector,”
which you will do in the step following this current one.

1. In the Experiment text box, keep the default name or overwrite it with another name.

2. If the desired cloning method is not already selected in the Method drop-down menu, choose it from
the list.

3. (optional) SeqBuilder Pro optimizes method settings, but if you wish to change method options for the
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Gibson Assembly, In-Fusion, or GeneArt methods, you can use the Preferences button.

Option Description

Number of
Fragments

Most cloning methods allow just one insert, but Gibson, In-Fusion, and MultiSite Gateway Pro
cloning each allow different numbers of inserts. The default for this menu is optimized for the
selected cloning method, but you can override this by making another selection. Choices are
1-2 Fragments, 3-4 Fragments, or Adjust Automatically.

Construct
Length

The anticipated length of the finished expression clone. Choices are 10Kb or less, More than
10Kb, or Anything.

Minimum
Overlap (Bp)

Relevant to ligation-independent cloning methods and constrains the length of overlap to the
specified value or higher. The maximum value allowed is 60 Bp; higher values are ignored.

Primer
Concentration
(nM)

(This option is currently disabled, so changing the value has no impact.)

Minimum
Primer
Length (Bp)

Desired minimum threshold for the primer length. The maximum value allowed is 60 Bp;
higher values are ignored.

4. In the Fragments section, drag and drop the inserts until they are in the desired order. For instance: a
promoter, one or two cloning sites, and Green Fluorescent Protein (GFP). If there is only one insert,
skip this step.
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Proceed to Step 3: Specify the vector and entry clone.
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Available cloning methods
SeqBuilder Pro supports the following cloning methods:

MultiSite Gateway Pro Cloning

MultiSite Gateway Pro technology enhances the classic Gateway cloning protocol by allowing you to clone
up to four regions at one time. In MultiSite Gateway Pro cloning, three additional types of recombination
sites have been engineered to recombine uniquely between the two ends of a source sequence and a host
vector. MultiSite Gateway Pro cloning can be simulated in SeqBuilder Pro using the five-step cloning
workflow.

The recombination features used in MultiSite Gateway cloning are as follows:

• For Expression Clones: attB1, attB2, attB3, attB4, and attB5

• For Donor Vectors: attP1, attP2, attP3, attP4, and attP5

• For Entry Clones: attL1, attL2, attL3, attL4, and attL5

• For Destination Vectors: attR1, attR2, attR3, attR4, and attR5

Note: When an r is added to any of these feature names, that indicates the reverse of the
specified site. For example, L5r indicates an L5 site in reverse.*

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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As in classic Gateway cloning, attL and attR sites recombine, and attB and attP sites recombine. The
recombined sites transform by swapping opposite halves into the opposite set, so attL and attR become attB
and attP and vice versa.

Click here for information on the specific 2, 3, and 4 fragment MultiSite Gateway protocol from Invitrogen.

For detailed information on creating a suitable vector, see the section “Preparation of Gateway cloning
vectors” in Add custom vectors to the Cloning Vector Catalog.

Gateway Cloning

Gateway cloning is based upon the site specific recombination of lambda bacteriophage. Two types of
recombination sites have been engineered to recombine uniquely between the two ends of a source
sequence and a host vector. The sites have also been engineered to allow the recombination reactions to
be completely reversible using two sets of catalytic proteins. These two reactions are called LR and BP, so
named because of the recombination sites involved in each; LR recombines attL and attR sites, BP
recombines attB and attP sites. The recombined sites transform by swapping opposite halves into the
opposite set, so attL and attR become attB and attP and vice versa. Vectors engineered to contain these
sites have been given the names: Entry Clone (attB), Expression Clone (attL), Donor Vector (attP), and
Destination Vector (attR).

When you perform a Gateway cloning simulation in SeqBuilder Pro, you first create an Entry Clone for a
specified fragment insert. This Entry Clone (rather than a fragment insert) is then used as input for making
an Expression Clone. Both type of clones are created using the cloning workflow. You will follow the
workflow once to create the Entry Clone, then again to create the Expression Clone.

A special type of Gateway cloning is RNA interference (RNAi) cloning. This procedure uses Gateway
recombination technology and a special vector (pHELLSGATE and its derivatives) containing two pairs of
recombination sites opposing each other on opposite strands. The cloning system is intended to create an
RNA transcript under expression that interferes with the translation of the cloned gene, thereby suppressing
it.

• To construct inverted repeat Entry Clones, use the vectors pHELLSGATE and pHELLSGATE 4.

• To construct inverted repeat Expression Clones from the single site Entry Clones, use the vectors
pHELLSGATE 8 and pHELLSGATE 12.

Note: During the cloning simulation, primers are altered to match the donor vector in the
first clone. When creating inserts with attB1-attB2 primers, SeqBuilder Pro automatically
adds four guanines (GGGG) to the 5’ end of the primer, as per the requirement specified in
in Thermofisher’s online Gateway Technology Manual.

*
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For detailed information on creating a suitable vector, see the section “Preparation of Gateway cloning
vectors” in Add custom vectors to the Cloning Vector Catalog.

Gibson (LIC, SLIC, CPEC, SLiCE) Cloning

Gibson assembly and Ligation Independent Cloning (LIC) are techniques offered by New England Biolabs.
Both cloning methods can be simulated in SeqBuilder Pro using the five-step cloning workflow. Note that
Gibson cloning allows up to 6 fragment inserts. When using this cloning method, restriction insert size must
be relatively large in order to prevent primer overlaps that could keep the fragment from being incorporated
into the expression clone.

In-Fusion Cloning

In-Fusion cloning is a technique offered by Clontech/Takara, and allows a maximum of 2 fragment inserts.
This cloning method can be simulated in SeqBuilder Pro using the five-step cloning workflow.

GeneArt Cloning

GeneArt cloning is offered by ThermoFisher Scientific and allows up to 4 inserts. This cloning method can
be simulated in SeqBuilder Pro using the five-step cloning workflow.

PCR-Directed Restriction Cloning

PCR-directed restriction cloning utilizes the unique activity of site-specific restriction enzymes. First use
restriction enzyme cut sites to create the insert. If no convenient restriction sites are available, you may
instead select the region you want to clone and SeqBuilder Pro will engineer primers to create sites
compatible with the selected sites of the chosen vector. In either case, proceed to follow Steps 2-5 of the
cloning workflow.

Using a cloning vector with compatible restriction sites, the insert and vector can be digested with restriction
enzymes to generate complementary ends, thereby enabling the vector and insert to be efficiently ligated.
SeqBuilder Pro uses the basic idea very similar to the copy/paste of text editing. The primary difference in
SeqBuilder Pro is the way the sequence endpoints are selected and what happens after the paste
command. The cloning workflow simplifies this further by making the selection of restriction sites easier and
by eliminating the need to find matching sites in the cloned region.

TA Cloning
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TA Cloning is a cloning method that takes advantage of the terminal transferase activity of some DNA
Polymerases that add a 3’-A overhang to each end of a PCR product. A linearized vector with prepared 3’-T
overhangs facilitates ligation of the PCR product. TA cloning can be simulated in SeqBuilder Pro using the
five-step cloning workflow. In Step 1, follow the instructions for Option E – Using the PCR product of the
current primer pair as the insert.

Directional TOPO Cloning

Directional TOPO cloning utilizes the binding activity of Topoisomerase I, and can be simulated in
SeqBuilder Pro using the five-step cloning workflow. A sequence of interest is PCR amplified using a
forward strand primer with four additional bases (CACC). Commercial vector sequences have been
engineered with topoisomerase bound at 3’ and a complementary 5’ GTGG overhang. The overhang
invades the 5’ end of the PCR product and anneals to the added bases. The 5’ hydroxyl group of the PCR
product attacks the topoisomerase bound to the vector, releasing it and causing the ligation of the
phosphate backbone. Orientation of the insert is determined by the 5’ overhang, allowing the other end to be
blunt.
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Step 3: Specify the vector and entry clone
After specifying the cloning method and options, the next step is to choose the vector. In addition, if you are
performing Gateway Expression cloning, you will need to specify which previously-saved Gateway Entry
clone to use.

1. From the Clone tab of the Project window, select a vector from the Vector drop-down menu. (Learn
how to add your own vectors to this list). The menu has been optimized to contain suitable vectors for
the chosen cloning method. The icon next to each vector shows whether it is linear (required for TA &
TOPO cloning) or circular.

2. If you are doing Gateway Expression cloning, the Clone drop-down menu will also be present. From
this menu, select the entry clone that was created in an earlier Gateway Entry cloning project.
Alternatively, you may select the entry clone by dragging it from its Project tab folder and dropping it
onto the Clone drop-down menu.
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The cartoon on the upper right of the tab will update its appearance and text based on your selections.

Proceed to Step 4: Digest/linearize a circular vector.
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Step 4: Digest/linearize a circular vector
After you specify the vector or entry clone, a Digest or Linearize button may appear. This button lets you
specify where in the vector to insert the fragment. The appearance (or not) and name of this button depends
on which method you chose, and whether your vector is linear or circular.

Method Button name

Gibson Assembly

In-Fusion, GeneArt

PCR-Directed Restriction Cloning

TA & TOPO No button (linear vectors required)

Gateway methods No button (uses recombination)

To digest/linearize the vector:

1. Press the Digest or Linearize button opens the Document window and displays the vector and its cut
sites. Providing the vector and insert have already been specified, only enzymes that are unique in
the vector and that do not cut the insert are displayed.

2. Select one or two cut sites using any of the following methods:

• ◦ Click on one restriction enzyme in the Circular view, and then Shift+click on the second
enzyme (if any).

◦ Select one or two enzymes using the Left Cut and/or Right Cut drop-down menus in the gold
area at the bottom of the window. SeqBuilder Pro automatically populates the menus with
enzymes that are unique in the vector being displayed and are blunt or have a non-degenerate
overhang. In addition, if you have ever manually changed the selector to display other enzymes
and chosen a site that does not meet the criteria above, that site will be displayed in the menus
from that point on.

Note: The same window also opens if you use the Cloning > Clone Restriction Insert
from the Document window without first specifying a selection. The procedure described
below also applies to that situation.
*
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◦ Select one custom cut location by clicking on that base in the Circular view. Or select two cut
locations by dragging the mouse across the area that should be removed.

◦ When you have made your selection(s), press the Select button on the bottom right.

3. To return to the cloning window without cutting the vector choose Cancel. Otherwise, press Select to
confirm the cloning region. When prompted to confirm file modification, select Yes.
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If you selected cut sites, information about them now appears below the Linearize or Digest button.

Proceed to Step 5: Run the cloning simulation.
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Step 5: Run the cloning simulation
When you have specified the insert and vector, and set up additional options as desired, you are ready to
begin the cloning simulation:

1. Press the Try It or Clone button in the bottom right corner of the Project window. The view switches
from the Clone tab to the Summary tab.

2. Review the three Summary sections: Fragments, Steps and Fragment Junctions. If the summary
procedure does not meet your requirements, click Change to switch back to the Clone tab, where you
can make changes. Otherwise, click Make It to proceed with the cloning simulation.

If simulation is successful, a new folder is added to Project tab of the Project window. Depending on
the method used, this folder may contain a copy of each insert and entry clone, as well as the
expected product that will be created after recombination occurs (i.e., the finished expression clone).
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Any item can be opened in the SeqBuilder Pro Document window by double-clicking on its name.

If simulation is unsuccessful, you may receive the error message “The vector is not digested by
restriction enzyme(s).” This message may be seen when performing a cloning simulation where
restriction enzyme cut sites were used to create the insert. Click Change to return to the Clone tab,
then try again using a different insert.

3. The Setup tab asks whether you wish to verify the clone. You can perform cloning verification at any
time. If you have already prepared the clone in the laboratory and sequenced it, proceed to Step 6
(optional): Verify the clone. Otherwise, continue to the next step.

4. Save the cloning project using File > Save Project. Then proceed to Step 7: View and print cloning
results.
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Step 6 (optional): Verify the clone
SeqBuilder Pro 15.1 and later offers the ability to verify whether or not a clone produced in the laboratory
matches the version designed in SeqBuilder Pro. To learn how, watch this brief video or follow the written
instructions below:

To verify a clone:

1. Use SeqBuilder Pro to design a virtual clone. After completing Step 5: Run the cloning simulation, you
will be asked if you wish to verify the clone, discussed in this topic. If you have already created and
sequenced the clone in the laboratory, skip to step 5 of the instructions below. Most users, however,
will continue to step 2 of the instructions below.

2. Save the cloning project.

3. Create the clone “in real life” in the laboratory.

4. Sequence the lab clone via Sanger sequencing and put the resulting .abi files on the same computer
used to design the virtual clone.

5. Launch SeqBuilder Pro and use File > Open to open the original cloning project.

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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6. Choose Cloning > Verify Clone. The Project window opens with the Setup tab active.

7. Use the Clone drop-down menu to specify the clone of interest, if it is not already specified.

8. If SeqBuilder Pro cannot locate the cloning insert, the Set Insert Location button will be enabled.
Press the button to navigate to the insert.
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9. Press the Browse files for Reads button at the bottom of the Setup tab. Navigate to the Sanger .abi
files obtained from sequencing the laboratory clone.

10. Press the Run button.

Behind the scenes, DNASTAR’s SeqMan Pro’s alignment algorithm runs an alignment to verify
whether or not the “real life” clone matches the virtual clone designed in SeqBuilder Pro.

Proceed to the topic Interpret results from clone verification.
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Interpret results from clone verification
After following the steps in Step 6 (optional): Verify the clone, SeqBuilder Pro displays the results in the
Results tab of the Project window. The results consist of up to three sections, and may feature graphics,
messages and links.

Interpreting messages in the Results tab:

Situation Results tab shows…

No issues

Minor
differences Example of a clone with a frameshift:

Major
differences

Example of a clone with a large mismatch:
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Using links in the Results tab:

Link Result
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“Show the reads assembled with the
clone” Launches SeqMan Pro’s Alignment view.

“Clone Position” link Opens SeqBuilder Pro’s Features view; also opens the Sequence
view with the position or range selected.

“Alignment Position” link (Notable
Conflicting Regions section)

Launches SeqMan Pro’s Strategy view with the position or range
selected.

“Alignment Position” link (Notable
Variations section)

Launches SeqMan Pro’s Alignment view with the position or range
selected and the trace data expanded.

If desired, proceed to Step 7: View and print cloning results.
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Step 7: View and print cloning results
The Cloning Summary provides details about the components of the cloning simulation, including fragment
inserts, primers, and the steps needed to prepare the vector and amplify inserts. It also displays the reading
frame around all fragment junctions graphically, allowing you to verify whether promoters and genes are in
synchrony.

The Summary is available once you complete a cloning project and open any of the resulting files (i.e., entry
clones, inserts, expression clones) in the Document window.

To access the Cloning Summary:

1. Design a virtual clone.

2. From the Project window, expand the folder containing the cloning project of interest.

3. Double-click on the name of any result file to open it in the Document window.

4. Open the History view to see the Cloning Summary.
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• ◦ To print the Cloning Summary, choose File > Print.

◦ To copy the entire Cloning Summary to the clipboard, choose Edit > Select All, then select
Edit > Copy. The summary can be pasted from the clipboard into many commonly-used text
editors.
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Try it! – Gateway cloning
Gateway cloning is based upon the site-specific recombination of lambda bacteriophage, and is a two-part
process. In the first part of the tutorial, you will create a Gateway entry clone. In the second part, you will
use the entry clone as input for constructing the final Gateway expression clone.

1. If you have not yet download and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. Use File > Open to open the demo file Tn5w.sbd. The sequence opens in the Linear view.

3. Click on the neomycin/kanamycin resistance feature labeled aminoglycoside-3’-O-
phosphotransferase to select that range of sequence.

4. Select Cloning > Gateway Entry Clone to launch the Project window.

The selected sequence fragment has been placed in the Clone tab’s Fragments area and in the
Project tab’s Inserts folder. To expand the Inserts folder and reveal its contents, click the plus icon
(Win) or arrow (Mac).
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The circular cartoon in the upper right corner displays the insert (in red) and prompts you to “Choose
a vector.” The cartoon updates its appearance and text based on your selections.

5. Use the Vector drop-down menu to select the donor vector pDONR201. Note that the menu has been
optimized to contain suitable vectors for the chosen cloning method. In the current project, only

circular vectors ( ) are offered.

6. Press the Try It button in the bottom right corner of the window. The Project view switches from the
Clone tab to the Summary tab.
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7. Briefly look at the contents of the three sections: Fragments, Steps and Fragment Junctions. Then
click Make It to proceed with the cloning simulation.
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8. The Setup tab asks whether you wish to verify the clone. Press the Cancel button.

9. In the Project tab, a new folder named Gateway Entry 1 appears. It contains the amplified insert and
entry clone.

Double-click on the file name ending in AttB Insert to open it in the Linear view. The top pane shows
the amplified insert and PCR product.

10. Returning to the Project window, double-click on the file name ending in L1-L2 Entry Clone 1.

The entry clone is displayed in the Circular view.

If the contents had not met your requirements, you could have clicked Change to switch
back to the Clone tab in order to make changes there.*
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The History view shows the Cloning Summary last seen in Step 6. Since this summary contains the
steps to make the entry clone, you may wish to print a copy.

11. To see a print preview, click anywhere on the Cloning Summary to select it, and then choose File >
Print. You could change the scale and/or print the summary from this window, if desired. However,
there is no need to do so for this tutorial.

12. On Windows, click the ‘x’ in the top corner to close the Print Preview window. On Macintosh, click the
Cancel button.

Next, you will create the expression clone and (optionally) print a document that includes the steps to
create the entry clone:

13. Choose Cloning > Gateway Expression Clone to again open the Project window.

14. Use the Vector drop-down menu to select the destination vector pAd/BLOCK-iT-DEST.

15. Use the Clone drop-down menu to select Tn5w(1559,2353) L1-L2 Entry Clone 1 from the bottom of
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the list.

16. Press Try It and then Make It.

17. The Setup tab asks whether you wish to verify the clone. Press the Cancel button.

18. A new folder, Gateway Expression 2, is added to Project tab.

Double-click on Gateway Expression 2 Clone 1 to open it in the Document window. The top pane
shows the simulated expression clone in the Circular view.
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As before, the Cloning Summary appears in the History view.

19. Click once on the Cloning Summary pane to select it.

20. (optional) Use Edit > Select All, then File > Print to print the summary.
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Try it! – MultiSite Gateway Pro cloning
MultiSite Gateway Pro technology enhances the classic Gateway cloning protocol by allowing you to clone
up to four regions at one time. In MultiSite Gateway Pro cloning, three additional types of recombination
sites have been engineered to recombine uniquely between the two ends of a source sequence and a host
vector.

In this tutorial, you will create a clone that has a Pol promoter, two multiple cloning sites, and a reporter
gene.

1. If you have not yet download and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. Use File > Open to open the file MultiSiteExample.sbp in the Project window.

3. Click on the plus sign next to Inserts to expand the folder.

4. Choose Cloning > Multisite Gateway Pro Cloning.

5. Use Shift+click to select all four inserts, then drag and drop them in the Fragments area to the
bottom right of the Clone tab

6. Reorder the fragments to match the image below. To do this, click on a fragment to select it, then
drag and drop it in the new position.
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7. In the Clone tab, click on the Vector drop-down menu and select pDEST8.

8. Click Try It and then Make It.

9. The Setup tab asks whether you wish to verify the clone. Press the Cancel button.

10. In the Project tab, a new folder is added containing four amplified inserts (all linear), as well as four
entry clones and the final expression clone (all circular).

Double-click on Multisite Gateway Pro 1 4-insert Expression Clone 1 to open it in the Document
window. The top pane shows the simulated Expression clone in the Circular view.

Windows users can navigate using a vertical scroll bar, while Macintosh users should use a
mouse roller or similar tool to scroll.*
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11. Open the History view to see the Cloning Summary. The summary includes a nine-step cloning
procedure and lists the primers needed for each step.
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To print the Cloning Summary or copy it to the clipboard, see View and print cloning results.
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Try it! – Gibson cloning with a custom vector
The Vectors drop-down menu in the Project window is a shortcut to all of the vectors contained in the
CloningVectors.sbp project, also known as the “Vector Catalog.” It is possible to add a custom vector to an
open project, or to add it to the Vector Catalog for use with future projects. The first part of this tutorial deals
with the former case, and takes you through the steps needed to add a custom vector to a particular Gibson
cloning project.

You will then make the Gibson clone as verification that you added the custom vector correctly. Gibson
assembly, offered by New England Biolabs, is a technique which allows up to 6 fragment inserts. When
using Gibson assembly, restriction insert size must be relatively large in order to prevent primer overlaps
that could keep the insert from being incorporated into the expression clone.

1. If you have not yet download and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. Use File > Open to open the demo file Tn5w.sbd. The sequence opens in the Linear view.

3. Click on the neomycin/kanamycin resistance feature labeled aminoglycoside-3’-O-
phosphotransferase to select that range of sequence.

4. Choose Cloning > Gibson, LIC Cloning to open the Project window.

5. Some of the cloning methods in SeqBuilder Pro have editable options. Click on the Preferences
button to see the options available for Gibson cloning.
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Leave all settings at the defaults and click Cancel to exit.

6. You’ll be using a custom vector that is not in the Vector Catalog, and therefore not in the Vector drop-
down menu on the right of the Project window. To specify the custom vector:

a. Go to the NCBI page for Promega cloning vector pSP73.

b. Click on the Send to link near the top of the page, and make the following selections:

c. Press Create File and then save the file when prompted.

d. Use your file explorer to find the saved file, then drag and drop it on the Vector drop-down
menu in SeqBuilder Pro’s Clone tab.

The vector is selected automatically, and a new Linearize button also appears.

7. Press Linearize to open the pSP73 vector in the Circular view. “Unique sites,” enzymes that cut the
sequence only once, are displayed by default.
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8. Use the Left Cut and Right Cut drop-down menus in the yellow bar at the bottom of the window to
specify EcoRI and HindIII, respectively.

9. In the yellow bar, press Select.

10. Back in the Project window, press Try It and then Make It.

11. The Setup tab asks whether you wish to verify the clone. Press the Cancel button.

12. In the Project window, double-click on the Gibson 1 Clone 1 file to open it in the Circular view.
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This marks the end of the tutorial.
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Try it! – Use a PCR insert in TA cloning
The tutorial Try it! – Create and modify primers for TA cloning demonstrated how to select and modify a
primer pair. This tutorial shows how to extract the PCR insert and create a virtual TA clone.

1. If you have not already done so, follow the tutorial Try it! – Create and modify primers for TA cloning.
If the project is still open from following the tutorial, double-click on the white space in the Primers
view to remove the current selection.If you closed the project since following that tutorial, use File >
Open to open the file saved at the end of that tutorial.

2. Choose Priming > Create Insert by PCR to extract the sequence of the PCR product and simulate its
amplification with Taq polymerase including the addition of 3’ A overhangs to each end.

A Project window opens with a new Taq amplified insert inside the Inserts folder.

3. Select Cloning > TA Cloning.

4. Drag the amplified insert from the Inserts folder of the Project tab and drop it on the Fragment area
of the Clone tab.

5. Look in the Vector drop-down menu and note that the set has been filtered to include only linear

vectors, as required for TA (and TOPO) cloning. Linear vectors have the icon . Select
pBAD-TOPO from the Vector drop-down menu.

6. Click Try It and then Make It.

7. In the Project tab on the left, note that new forward and reverse orientation clones now appear in the
Project tab in the TA Clone 1 folder.

8. Double-click on the forward orientation clone file to open it in SeqBuilder Pro. Notice that the primers
and PCR product appear as features. These features can also be seen in the Features view, as well
as all graphical views.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 260 of 302



9. Click on the History tab at the bottom of the SeqBuilder Pro window to see the Cloning Summary,
including the steps needed to create this clone in your lab.
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Try it! – PCR-directed restriction cloning
This tutorial demonstrates how to cut and clone a signal transduction gene into the pENTR/D-TOPO vector.

1. If you have not yet download and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. Use File > Open to open N.thermophilus_his.sbd. The sequence opens in the Circular view.

3. Click on the PAS/PAC sensor signal transduction feature to select it.

4. Choose Cloning > Clone Selected Fragment.

5. In the Clone tab on the right, choose the Method named PCR-Directed Restriction Clone.

6. In the Vector drop-down menu, click on the plus sign next to Gateway Vectors, then the plus sign
next to Entry Clones and select pENTR/D-TOPO.
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7. Press the Digest button. A specialized version of the Circular view opens.

8. In the yellow bar at the bottom of the view, choose the Left Cut site SacII and the Right Cut site
AscI.
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9. Press the Select button. The Clone tab comes back into focus.

10. Press Try it. Then press Make it.

11. In the Project tab on the left, note the appearance of two new files: the Restriction insert and
Restriction Clone.

12. Double-click on the Restriction Clone file to open it in SeqBuilder Pro.
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13. Click on the History tab at the bottom of the SeqBuilder Pro window to see the Cloning Summary,
including the steps needed to create this clone in your lab.
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Site-Directed Mutagenesis
Site-directed mutagenesis is a molecular biology method that is used to make specific changes to the DNA
sequence of a gene. As of Lasergene 16.0, you can perform site-directed mutagenesis using Protean 3D’s
Protein Design service together with SeqBuilder Pro. The following case study is based on a poster that
DNASTAR presented at the 2019 PEGS Summit in Boston.

Introduction:

Nature commonly evolves proteins to provide sufficient fold stability to optimize its activity—not its energetic
stability. Lasergene’s site-directed mutagenesis workflow is designed to help improve the developability of a
protein by predicting which mutations may lead to increased protein stability and developability.

In the following example, we’ll use Lasergene’s site-directed mutagenesis workflow to replicate the findings
of Lim, et al., 1994 (Proc. Natl. Acad. Sci. USA, 91:423-7). Lim made three specific mutations to the
repressor protein cl. This protein is part of the lambda P50 operon (PDB ID: 1LMB), which also includes the
genes rexa and rexb.

Lim’s study found that mutating the repressor protein cI at three specific points conferred 0.5 kcal/mol more
stability compared to the wild type.

As we describe below, Lasergene’s site-directed mutagenesis workflow not only replicates Lim’s findings,
but early on—in Step #2—reveals other mutations that could be even more stabilizing. Our results were
presented by us in a poster at the 2019 PEGS conference.

Note: The coordinates in this blog post match the current PDB structure, not the coordinates reported from
the 1994 paper or the poster cited above. UniProt indicates position 1 is a removed initiator methionine and
the chain starts at position 2 (serine). By contrast, RCSB numbers the start of the chain after post-
translational modification as position 1. This blog post uses a sequence that follows the UniProt convention
rather than the RCSB convention.

Part I: Scan for hotspots and create variants on protein structure
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Since we have a protein structure as our starting point, we will begin with the following steps. If a protein
structure was not available, we could instead start by creating variant primers as shown in Part II.

1. Launch Protean 3D and use File > Open from PDB to open the protein sequence 1LMB.

We will begin by performing “hot spot scanning” using alanine. This hot spot workflow is used to
predict folding hot spots; residues that contribute to fold stability more significantly than others. The
more destabilizing the alanine variant, the greater the probability the position and residue identity is
important to the fold.

2. Choose Modeling > Protein Design > Scan for Hot Spots With > Document. Keep all defaults and
choose Run.

In approximately a minute or less, the results of the alanine scan appear in the Report view. The
Prediction column indicates that the positions referenced by Lim—36, 40 and 47—are all predicted to
be “destabilizing.”

The Report contains several residues that are even more destabilizing (i.e., have higher DFIRE-A
potentials) than the ones in Lim’s 1994 paper. Ideally, these would be our first choice for increasing
the developability of the protein. However, for purposes of replicating Lim’s findings, we will proceed
with the three positions referenced above.

3. To manually insert variants into these positions of interest, choose Modeling > Protein Design >
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Create Variant With > Document. Then use the Substitute drop-down menus to change position 36
from V to L; position 40 from M to L; and position 47 from V to I.

If we weren’t replicating Lim’s study, which amino acids would we substitute for the originals?
Unfortunately, there is no “magical” way to determine which variants will work best. We can simply
run different combinations and see which ones lead to increased stability.

Press Run. The new Report shows that this combination of variants is predicted to be “stabilizing.”

Part II: Introduce variants in sequence and create mutated primer

1. Launch SeqBuilder Pro and use File > Open to open the original (unmutated) 1LMB protein
sequence.

2. Reverse translate the sequence to DNA. (We also created annotations showing the locations of the
three variants—these appear in the image in Step 5). Choose File > Save.

3. Select all nucleotides from the beginning of the cl gene to the right (downstream) of the sequence and
delete them. Then use File > Save As to save the remaining fragment as Upstream fragment.sbd.

4. Open the sequence saved in Step 2, above. Select all nucleotides to the left (upstream) of the cl gene
and delete them. Then use File > Save As to save the remainder of the sequence as cl mutated
fragment.sbd.

We now have two sequence files that—laid end to end—would be identical to the original nucleotide
sequence.

5. In this step, we will use the Primer Design view to create PCR primer pairs at the exact desired
location with respect to features and translational frames. Choose Edit > Select All, then Priming >
Create Primer Pairs. Keep the default setting Primers end exactly at selection and press OK. Once
the primers are created, the forward primer is extended to 41 bp in length to fully cover all three
mutation areas.

The image below shows that the three codons where the variants will be introduced (pink) all occur
on the forward primer (green).
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6. Next, we need to recreate the variants of interest using the Introduce Codon Change/Mutation tool (
). This tool allows us to easily modify triplet codons within primers to introduce the desired

mutations. Select the tool, then hover over the first codon (V in Reading Frame 1) and choose the
desired substitute: L.

7. In the same way, introduce the planned variants at the second and third codons. The mutated bases
are represented by a pink lower case font, as shown below.
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At this point, either or both primers could be further adjusted to improve T~m~ differences and primer-
dimer formation.

8. Save the cl mutated fragment.sbd project using File > Save.

9. Reopen the sequence fragment Upstream fragment.sbd and create primer pairs using the commands
in Step 4, above. Save the project using File > Save.

SeqBuilder Pro provides multi-fragment PCR based cloning options so that the mutated gene of
interest can be cloned into an appropriate expression vector. In the next steps, we will clone the
mutated cI gene (and the rest of the lambdap50 operon) and the upstream (non-mutated) fragment of
the cI gene into an E.coli expression vector system (pBAM/Thio) using PCR-based Gibson assembly.

10. Open a new, empty cloning project using File > New Cloning Project.

11. Click on the Inserts folder to select it. Then right-click on the Inserts folder and choose Import. Use
Ctrl+click (Win) or Cmd+click (Mac) to select the files cl mutated fragment.sbd and Upstream
fragment.sbd, then click Open.
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12. Choose Cloning > Gibson, LIC Cloning.

13. Next to Experiment, type in cl gene mutant.

14. Use the Vector drop-down menu and click the plus sign next to Restriction Vectors to expand the
folder. Then click on the first vector in that folder, pBAD/THIO.

15. Drag the two sequence fragments from the Inserts folder and drop them in the Fragments area on
the bottom right. Make sure the upstream fragment is on top. In the cloning dialog, name it cl gene
mutant.

16. Press the Linearize button and specify a Left Cut at NaeI (676) and Right Cut at HindIII (703). Press
Select.

17. Press Try it, then Make it. The History view shows a rendering of the fragments and clone, all primer
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information, and the list of steps needed to create the clone in the lab. The red text in the Primers
area is the junction that puts the two sequence fragments back together.

18. Open expression clone cl gene mutant GIBSON Clone 1 in SeqBuilder Pro by double-clicking on it.

The Linear view shows all the of the vector and insert feature annotations and lets us apply ORF
detection and translation to confirm that the gene of interest remains in-frame with the fusion protein.

19. Apply the ORF for “Top Frame 1,” shown as a red bar in the image below. The small white triangles
along the ORF denote the atg start sites.
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20. Click on the start site corresponding to hpTrxA, a mutated version of the E. coli protein thioredoxin
(trxA) used to create a metal-binding domain that allows purification of thioredoxin fusion on metal-
chelating resins.

The selection contains the entire cl gene feature; verification that the transcript is in-frame.
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Agarose Gel Simulation
Agarose gel simulation lets you find the location of restriction enzymes on a gel and perform ‘mock’ digests
to determine the expected size of digest products on an electrophoresis gel. Gel simulations let you find the
ideal percent agarose and set of molecular weight markers to resolve your DNA fragments. This digital
simulation replaces manual plotting of DNA fragment mobility on graph paper. Once you run the actual gel
in your laboratory, you can place the gel or its image side-by-side with an image of the simulation to confirm
gels that have complex banding patterns.

The following video is a brief walkthrough of the agarose gel simulation workflow:

To perform an agarose gel simulation:

1. (optional) Open the sequence you wish to use in the simulation.

2. (optional) If you plan to apply primer pairs to one or more lanes of the simulated gel, locate the primer
pairs.

3. Choose File > New Agarose Gel.

A new project window opens with the Gel Simulation and Fragment Sizes views active. On the right,
the Sequences, Enzymes and Primers panels appear at the top, and the Settings and Markers panels
appear on the bottom. All of these views and panels are synchronized, meaning that each of them will
update simultaneously when a change is made in any of the other views or panels. If a file was
already open in SeqBuilder Pro, it will be added to the Sequences panel.

4. Click on the Settings tab and define gel parameters such as dimensions, percent agarose, and run

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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time. Choose from a variety of commercial gels, and/or enter custom parameters.

5. Select the lanes one by one and apply a molecular weight marker, sequence, enzyme, or primer pair.

• To apply a molecular weight marker, select a gel lane. Then click on the Markers tab and check
the box next to the desired marker. For more information, see Markers panel.

• To apply a sequence, select a gel lane. Then click on the Sequences tab and check the box
next to the sequence of interest. To add sequences to the panel, right-click within the panel and
choose Import. For details, see Sequences panel.

• To apply an enzyme, select an already-populated gel lane. (Note: If a lane is unpopulated,
follow the bullet point above to first apply a sequence to the lane). Then click on the Enzyme
tab and check the box next to the enzyme of interest. For more information, see Enzymes panel
for gels and Apply or remove enzymes in the gel simulation view.

• To apply a primer, select a gel lane. Then click on the Primers tab and check the box next to
the desired primer pair. For details, see Primers panel.

To analyze the results:

• To select a fragment and its range on the sequence, click on a band in the Gel Simulation view, or on
a fragment size notation in the Fragment Sizes view. The fragment is shown in red, and the footer is
populated with information about the selection. Any fragment from the same sequence as the selected
fragment, and which overlaps the selected fragment in any way, will appear in blue.
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• To view information about a band or fragment size notation, hover the mouse over it to reveal a
tooltip.
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Sequence Statistics
To view a statistical summary of a selected portion of sequence:

1. Select a portion of the sequence in a graphical view.

2. Choose Sequence > Statistics.

• ◦ For nucleotide sequences, the display shows the number and composition of bases, the
percentage of A, G, T, C, ambiguous bases, and A+T and C+G in the selected region. The
actual numbers of each type of base follows the percentage in brackets.

◦ For protein sequences, the summary includes the number of strongly basic, strongly acidic,
hydrophobic, and polar amino acids, as well as the molecular weight, isoelectric point, and
charge at pH 7.0 for the selected region.
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Motion Library
Lasergene applications are designed to work together seamlessly. One useful workflow is to create or edit a
protein sequence in SeqBuilder Pro, fold it in Novafold and view the finished product in Protean 3D.

Whether or not you are already licensed to use Protean 3D, SeqBuilder Pro lets you browse protein
animations from Protean 3D’s “Motion Library.” The Motion Library consists of over 500 animated and
annotated macromolecular motions illustrating structural conformational changes.

To launch Protean 3D with the Motion Library open, choose Help > Molecules in Motion. To learn about
the Motion Library and how to use it, see the Protean 3D help topic, The Motion Library.
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Copy, Print, Save and Export
From within SeqBuilder Pro, you can do the following:

• Copy a sequence or image

• Print (Windows / Macintosh)

• Save

• Export sequences to a file

• Export sequences to Genvision

• Export a sequence to another Lasergene application
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Copy a sequence or image
To copy selected text (including sequence) to the clipboard:

Choose Edit > Copy or use the keyboard shortcut Ctrl/Cmd+C.

To copy selected text that will be pasted in a particular format:

Use Edit > Copy As.

• Unformatted Sequence – Copies the sequence only.

• Formatted Sequence – Copies the sequence with spacing and line breaks, as it appears in the
Sequence view.

• Translated sequence – Copies the protein translation of the highlighted range.

• Spliced sequence – Copies only the sequence corresponding to the segments of the selected
feature, rather than the whole region. For example, if a feature consisted of two segments — 100-129
and 200-232, Spliced sequence would copy a string consisting of bases 100-129, immediately
followed by bases 200-232. In contrast, Unformatted Sequence would copy every base from 100-232.

To copy an image of a view:

To copy an image of the Circular, Linear, Sequence, Gel Simulation or Fragment Sizes view, make it active
and choose Edit > Copy As Picture. When using this command from most views, only the selected
information is copied to the clipboard. From within the Circular view, the entire map is copied, regardless of
the selection.

When pasting the copied picture into a Microsoft Office application, we recommend using
Edit > Paste Special and selecting Picture (Enhanced Metafile).*
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Print on Windows
To print from within SeqBuilder Pro on Windows:

Select File > Print or the keyboard shortcut Ctrl/Cmd+P or use File > Print Preview (see below) and select
the Print tool. Select a printer and choose the pages and quantities to print.

To view a preview before printing:

Use File > Print Preview.

Several navigation and zooming tools are provided in this window.

Opens the Print dialog; identical to selecting File > Print.

Returns to the first page in the project.

Returns to the previous page.
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Shows the total number of pages, and allows you to go to a particular page by typing
in the box on the left.

Advances to the next page.

Advances to the last page in the project.

Use the plus/minus buttons or drop-down menu to choose the zoom scale for the
preview, from 10-200%. Note: To change the actual printing scale, see File > Page
Layout, below.

To exit from the Print Preview window.

To change the printing size, orientation or margins:

Choose File > Page Setup.

The default printing size for all DNASTAR applications is U.S. “Letter” size (8.5 × 11 inches = 21.6 × 28 cm).

To change the page layout:
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From within the Circular, Linear or Sequence views, select File > Page Layout.

• In the Drawing Size area, use the Horizontal and/or Vertical text boxes to set the number of pages
that will be used to display the current view. By increasing the number of pages, you will enhance the
resolution in any of these views. One or both of these options may be available depending on the
view.

• Enter a number in Groups per page sets the number of rows that will print per page in Linear view.
To view a linear map in one continuous line on the page, change this value to 1.

• (optional) Check the box next to Reset layout to restore the default values.

When you have made the desired selections, press Apply to save changes and then exit the dialog by
clicking OK. Or press Cancel to exit without saving changes.
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Print on Macintosh
To print from within SeqBuilder Pro on a Macintosh:

Select File > Print or the keyboard shortcut Cmd+P.

Initially, an abbreviated version of the Print dialog is displayed. To view all print options, press Show
Details. Once expanded, the selection you make in the middle drop-down menu (with the default of Layout)
determines which options are available in the lower portion of the dialog. For example, if the default value is
retained, the dialog appears as follows:

Other print options may be available, depending on the specific printer.

To change the printing size, orientation or margins:

Choose File > Page Setup.
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The default printing size for all DNASTAR applications is U.S. “Letter” size (8.5 × 11 inches = 21.6 × 28 cm).

To change the page layout:

1. From within the Circular, Linear or Sequence views, select File > Page Layout.

• In the Drawing Size area, use the Horizontal and/or Vertical text boxes to set the number of pages
that will be used to display the current view. By increasing the number of pages, you will enhance the
resolution in any of these views. One or both of these options may be available depending on the
view.

• Enter a number in Groups per page sets the number of rows that will print per page in Linear view.
To view a linear map in one continuous line on the page, change this value to 1.

• (optional) Check the box next to Reset layout to restore the default values.

User Guide to SeqBuilder Pro - 17.0

Copyright DNASTAR, Inc. 2020 Page 287 of 302



When you have made the desired selections, press Apply to save changes and then exit the dialog by
clicking OK. Or press Cancel to exit without saving changes.
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Save
You can save a sequence or project using File > Save (Project) or File > Save As (Project). See the table
below for restrictions. Most SeqBuilder Pro projects are saved with the extension .sbd (single document
project) or .sbp (multiple document project), but agarose gel simulations are saved with the extension
.sbgel.

You can also export a sequence from SeqBuilder Pro to GenVision.

Ability
File > Save
or Ctrl/
Cmd+S

File >
Save
As

Save to new name1 x

Save to new location x

Save a nucleotide sequence file (.seq) in .sbd, .seq, .gbk, .embl, .fas, and .abi.
formats. Save a protein sequence file (.pro) in .sbd, .pro, .gbk, .embl, or .fap formats. x

Preserve synchronous updating2 with GeneQuest x

Preserve sequence information, features, and comments x x

Preserve layout and formatting3 x

1 If you change the name of a SeqBuilder project using the file explorer, rather than the Save As command,
the name of the sequence in the project will retain its original name.

2 As shown in the illustrations below, once you use File > Save As, you can no longer update the original
sequence file synchronously with other Lasergene applications because the newly-saved project file has
copied the information from that sequence file into the new project file along with additional project
information.
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You can re-establish a synchronous updating link between SeqBuilder Pro and the other application by
opening the newly-created project file in the other application. You do not need to close the original project
file. However, because File > Save As has been used in another open application, that file will no longer be
updated when you make changes in the application where you last used File > Save As.

3 If you are saving a sequence file (e.g., .seq, .pro, .gbk, .fas) that you have changed, File > Save does not
save any layout information like active views, colors, and elements visible on the views. If you need to save
the layout information as well, use File > Save As to save the file as a SeqBuilder Pro document.
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Export sequences to a file
To export sequences to a file:

1. Select one or more sequences.

2. Choose File > Export Sequence(s) From Project.

3. Choose a format and location for saving the exported sequence(s).

• ◦ If you selected a single sequence, the sequence name is used as the default file name. If you
selected multiple sequences, the project name is used instead.

◦ Available file formats may include: .sbd, .seq, .gbk, .embl, and .fas. For formats that do not
support multiple sequences, each sequence is saved as a separate file.
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Export sequences to GenVision
To export one or more sequences to GenVision:

1. Either make a selection in the Linear, Circular, or Sequence views, or select a sequence in the Project
window.

2. Choose File > Export as GenVision Project and click the Begin Processing button.

The Export to GenVision dialog compares the features lists for all of the sequences you selected in
the Project window in order to find features with the same name that occur in more than one
sequence. Once the process is complete, a message will be displayed giving the number of features
SeqBuilder Pro identified that occur in more than one of the selected sequences. The table at the
bottom of the window lists the number of matches for each feature type, and how many sequences
contain a matched feature of the given type.

3. (optional) To exclude certain feature types from the export, remove the check mark from the row
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beside that feature type. If a feature type has 100 or more matches, it will be un-selected by default.

4. Click the Save Files button.

One GenVision project (.gnv) will be created for each of the selected sequences, and will display the
features from one sequence connecting to the same features in all of the other sequences where it
occurs. A .txt file will also be created for each exported panel. A new folder containing the exported
text files will be created within the same directory as your GenVision project and will be named the
same as your GenVision project with a .data extension.

Considerations when exporting sequences from the Project window:

• The use of color in the resulting GenVision project differs based on whether one feature type or
multiple feature types were exported. For a single type, each matching set of features will have its
own color. When multiple types are exported, each feature type will have its own color.

• Two text panels are created for the feature names. One panel displays the feature names as radial
text around the outside of the circular image and the other panel displays the feature names in an arc
inside the circular image. By default, only the radially displayed text panel is displayed. However, you
may display the other text panel if you wish by adjusting its priority within its data file.

• In the exported image, features are sorted so that feature types that have the most features appear
near the center of the circle.

Considerations when exporting sequences from the Linear, Circular, or Sequence views:

• When exporting from the Circular view, the GenVision figure will be exported as circular. When
exporting from the Linear or Sequence view, the GenVision figure will be exported as linear. Protein
sequences are exported as linear.

• The colors for fonts, ORFs, features, and the Circular map title are chosen in the Style panel, and are
preserved during export. For features, the Fill color is used for the feature color in GenVision. If a
feature does not use the fill color (e.g., stroked shapes), then the line color is used. Unchecking the
Fill checkbox will also cause the line color to be used. Feature labels are exported in the same color
as the Shape.

• For linear images, the Vertical value in the Page Layout dialog (Windows / Macintosh) is used for the
“Pages High” GenVision parameter.

• The page size and margin settings specified in the Page Setup dialog will be preserved in the
exported GenVision project.
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• An End Legend file is created for all of the panels within the export, and is named the same as your
GenVision project with “_table” appended. For example, GenVisionProject_table.txt.

• All exported text files will be prefixed with SB to denote that they were exported from SeqBuilder Pro.

Considerations regarding features:

• Features are grouped into panels by feature type. One panel is created for each feature type.

• For each feature panel created, a corresponding panel is created for the feature labels. Feature labels
are exported to GenVision if the Label Position is either Above or Below. Labels are not exported if
position is Inside. For additional information, see The Style Panel.

• If your features have detached labels, note that the label settings found in Format > Horizontal
Labels or Format > Radial Labels (for the Circular view and Format > Horizontal Labels or Format
> Vertical Labels (for the Linear view) are used when exporting feature labels to GenVision.

• Features in SeqBuilder Pro that have the Fill checkbox checked in the Style panel will be exported to
GenVision as a filled arrow. When the Fill checkbox is not checked, the feature will be exported as an
open arrow.

• For protein sequences, the export does not include segment names for multi-segmented features.

The visibility of feature labels within GenVision is determined by the priority set in the
GenVision text panel dialog or in the priority column of the text panel data file. (The values
in the data file supersede those in the panel.) If you are unable to see a feature label
exported from SeqBuilder Pro, try adjusting the priority within GenVision.

*
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Export a sequence to another Lasergene
application
Synchronous updating allows you to work on the same file in multiple Lasergene applications at the same
time, and is available in SeqBuilder Pro and GeneQuest, and—on a limited basis—in Protean 3D. Changes
made to a sequence in one application are automatically applied in the other shared applications.

To export a sequence to another Lasergene application with synchronous updating:

1. Open the sequence of interest.

2. Send the sequence to 1-3 additional applications using File > Send Sequence To > [Lasergene
application]. For example, you could open the same document in:

• ◦ SeqBuilder Pro – to edit the sequence

◦ GeneQuest – to further analyze a region of conservation

For information about how File > Save and File > Save As affect synchronous updating, see Save.

Note that Protean 3D does not allow the editing of sequences or features, and synchronous updating is not
supported for .pdb files. As a result, Protean 3D has limited, unidirectional synchronous updating capacity
compared to some other Lasergene applications. Changes made in another application may be
synchronized to Protean 3D, but not the reverse, as in these two scenarios:

• A file is open in another Lasergene application and you have made unsaved changes to it (e.g.,
trimming, adding a feature). When you initially open the same file in Protean 3D, any changes made
to the original sequence or its features will also appear there.

• The same file is already open in both Protean 3D and another application. You make changes to the
file in the other application. Only feature edits will synchronize to Protean 3D; sequence edits are
ignored.
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Close and Exit
To close a single project:

Select File > Close or use the keyboard shortcut Ctrl/Cmd+W.

To close all projects and leave SeqBuilder Pro:

Windows: Select File > Exit

Macintosh: Select SeqBuilder Pro > Quit.

If you are closing a project that has been edited since the last save, you will be prompted to save before
closing/quitting.
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Installed Lasergene file locations
The following file names use ‘x’ to represent the version number.

File Category Application Path

Application2

ArrayStar
Windows: C:\Program Files
(x86)\DNASTAR\Lasergene x\
ArrayStar

SeqNinja (command
line)

Windows: C:\Program Files
(x86)\DNASTAR\Lasergene x\
SeqNinjaCL

All others

Windows: C:\Program Files
(x86)\DNASTAR\Lasergene x

Macintosh: /Applications/
DNASTAR/Lasergene x

Data Manager2 (DMx, DMx.exe)
SeqBuilder Pro, Protean
3D, GeneQuest,
MegAlign Pro

Windows: C:\Program Files
(x86) \DNASTAR\Lasergene x

Macintosh: /Applications/
DNASTAR/Lasergene x

Data Manager State File
SeqBuilder Pro, Protean
3D, GeneQuest,
MegAlign Pro

Windows: C:\Program Data\
DNASTAR\DataManager

Macintosh: ~/Library/
Application Support/
DNASTAR/DataManager,

~/Library/Preferences/
DNASTAR/DataManager

License Manager2 All

Windows: C:\Program Files
(x86)\DNASTAR\License
Manager

Macintosh: /Applications/
DNASTAR/License Manager

Server License File (lservrc), Server License
Manager 2, Server Executables (_lserv, lservnt.exe)

All

Windows: C:\Program Files
(x86)\DNASTAR-
LicenseServer\Server

Macintosh: ~/Library/
DNASTAR-LicenseServer

Standalone & Trial Licenses (*.license), License
Server Client License (*.lshost), Key Server Client
License (*.keyhost)

All

Windows: C:\Program Data\
DNASTAR\Licenses

Macintosh: ~/Library/
Application Support/
DNASTAR/Licenses
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Preferences

Protean 3D, Navigator,
SeqNinja (DNA*),
GenVision Pro

Windows:
C:\Users\<user>\DNASTAR

Macintosh: ~/Library/
DNASTAR

ArrayStar
Windows:
C:\Users\<User>\AppData\
Roaming\DNASTAR\ArrayStar

All others

Windows:
C:\Users\<user>\AppData\
Local\DNASTAR\

Macintosh: ~/Library/
Preferences

AppData is a hidden folder in Windows. To unhide the folder, go to Organize > Folder and
Search Options > View > Show Hidden files and folders.*
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Installed enzyme file locations
SeqBuilder Pro contains representatives of a wide variety of restriction sites for available enzyme isotypes.
By default, Lasergene’s enzyme and enzyme selector files are installed in the following directory:

• Windows: C:\Program Files (x86)\DNASTAR\Lasergene x

• Macintosh: Hard Drive:Applications:DNASTAR:Lasergene x

Once an enzyme file or enzyme selector file has been edited, the revised file is saved to:

• Windows: C:\Program Files (x86)\DNASTAR\DataManager\1.0

• Macintosh (depends on version):

◦ Hard Drive:Library:Preferences:DNASTAR:DataManager:1.0

◦ Hard Drive: Users:<user ID>:Library: Preferences: DNASTAR: DataManager: 1.0

◦ Hard Drive: Applications:DNASTAR:Lasergene x

At any time, you may see what enzyme or selector file SeqBuilder Pro is using by selecting Help > About
SeqBuilder Pro (Windows) or SeqBuilder Pro > About SeqBuilder Pro (Macintosh).

If the enzyme file is write-protected, a copy of the file will be made in a user-specified location. This copy
will track changes made to enzymes, new enzymes, and deleted enzymes. Re-installing Lasergene will not
overwrite the changes, but likewise this file will not receive updated enzyme definitions.

For vendor information and a list of abbreviations used by SeqBuilder Pro, see the REBASE Suppliers web
page.
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Turn off usage logging
By default, usage logging is enabled in Lasergene version 11 and later. To opt out of usage logging, launch
the DNASTAR Navigator and go to View > Preferences > Lasergene (Win) or DNASTAR Navigator >
Preferences > Lasergene (Mac). Uncheck the box and click Apply and then OK.
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