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Welcome to MegAIign Pro

MegAlign Pro is Lasergene’s application for generating multiple and pairwise alignments of protein and/or
nucleic acid sequences using your choice of alignment methods. Easily navigate between synchronized
views with a click of a button, and rearrange views and toolbars by simply dragging and dropping them
where you want them to be.

If you're not sure whether you need to do a sequence alignment or a sequence assembly, we recommend
reading our “disambiguation” topic Sequence alignment vs. sequence assembly.

The following video is a brief walk-through of the MegAlign Pro application. Note that this video does not
show all available alignment methods.

These support pages contain written help and tutorials, as well as video tutorials.

* For help INSTALLING Lasergene, see our separate Installation Guide.

e For written TUTORIALS with free data, see MegAlign Pro Tutorials.

» Click here for a list of all topics that include VIDEOS.

» To PRINT the current page of the User Guide, click the printer icon in the top right corner ( = ).

» To download a PDF of the entire User Guide, scroll to the bottom of the table of contents on the left,
and press Download as PDF.
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Sequence alignment vs. sequence assembly

Sequence alignment and sequence assembly are very different workflows, but the terms are often used
incorrectly. Adding to the confusion, both workflows can involve an optional “reference” sequence, and both
can use some of the same sequence file types. This topic defines each workflow and recommends the best
Lasergene application to use in different scenarios.

Are your sequences from different organisms or strains?

If so, you will want to perform sequence alignment with MegAlign Pro.

Sequence alignment is used to investigate the evolutionary relatedness of two or more organisms or strains,
and the creation of a phylogenetic tree is often the end goal. MegAlign Pro lets you align DNA, RNA or
protein sequences from a single gene up to an entire genome. The sequence files used in this workflow
typically have formats like .fasta, .seq, .pro, .genbank.

Using a reference sequence in multiple sequence alignment is optional, but can be used to guide a MAFFT
alignment.

Do vour sequences consist of sequencing reads from one individual DNA sample?

If so, you will want to perform sequence assembly using SegMan Ultra for Sanger trace data reads (e.qg.,
.abi) and SegMan NGen for all other read types (e.g., .fasta, .fas, .fastq). In this workflow, longer consensus
sequences (“contigs”) are assembled from short fragments of a single DNA sample.

Both SegMan Ultra and SeqMan NGen allow you to assemble the reads de novo or by using a “reference”
sequence as a template. Using a reference in sequence assembly allows the software to assemble DNA
fragments into larger contigs faster and more accurately than assembling them de novo.

As with MegAlign Pro, the use of a reference sequence in sequence assembly also allows you to explore
variants between the sequence reads/contigs and the reference sequence. Variants resulting from
sequence assemblies in Lasergene are viewed using graphical views and tables in SegMan Ultra and

ArrayStar.

Copyright DNASTAR, Inc. 2022 Page 6 of 329


https://www.dnastar.com/software/lasergene/seqman-ultra/
https://www.dnastar.com/software/lasergene/seqman-ngen/
https://www.dnastar.com/software/lasergene/seqman-ultra/
https://www.dnastar.com/software/lasergene/arraystar/

MegAIign Pro Tutorials

MegAlign Pro tutorials appear in the table of contents just under corresponding help topics. In addition, each
tutorial is also listed below.

Miscellaneous tutorials:

 Add and align multi-segment sequences

* Map features

Multiple alignment tutorials:

» Perform a Clustal Omega alignment

* Perform a MUSCLE alignment with multi-segment sequences

e Perform a genomic alignment with Mauve

Pairwise alignment tutorials:

* Follow a multiple alignment with Global pairwise alignments

« Align transcripts to genes using Local and Global pairwise alignments

* Use Local pairwise alignment to find a gene within a genome

MegAlign Pro also plays an important role in the tutorial Phage display assembly, translation and prediction,
located in the Protean 3D User Guide. This integrated workflow starts in SeqMan Ultra, continues through
SeqgNinja and MegAlign Pro, and ends in Protean 3D.



https://www.dnastar.com/manuals/protean3d/topic/try-it-phage-display-assembly-translation-and-prediction

Create or Open a Project

Before you can add sequences to a project and align those sequences, you first need to create a MegAlign
Pro project. If you already have a project from MegAlign Pro (or its predecessor, MegAlign), you can also
open that to view or make changes. For details about each option, click the links below.

+ Open an existing MegAlign Pro project (.msa)

» Create a new MegAlign Pro project

* Import an alignment from another application

 Open a Newick-format tree file,

If you create or open multiple projects, see Navigate between projects to learn how to switch between them.




Open an existing MegAlign Pro project

To open an existing MegAlign Pro project (.msa):

Do any of the following:

« From the Welcome tab, click Open Project on the left. Then use the options on the right to Open
alignment project or open a recent document.

Meghlign Pro — O
File Edit View Align Features Sequences Owverview Search Window Help
(@] Welcome &2 = B
What do you want to do? 3 Suggest a workflow
New Project Choose alignment project

Open Project :

Open alignment project...  Import alignment...

Recent documents

H. pylori project.msa

Training

-.. ‘ E I"'

DNASTAR™

< [BeS u:

» Drag an .msa file from the file explorer or desktop and drop it on an empty MegAlign Pro project
window or tab.

» Choose File > Open from the menu.

» Click the Open a file tool (\=—")).

e Press Ctrl/Cmd+0.

* Note: If you moved or renamed any of the sequences prior to reopening a project, you may
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be prompted to supply the new name(s) or navigate to the location(s) of those sequences.

The following video (which launches, by design, at the 3:05 minute mark) demonstrates how to open
existing MegAlign Pro and classic MegAlign projects.
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Create a new MegAlign Pro project

To create a new MegAlign Pro project:

Do any of the following:

« From the Welcome tab, click New Project on the left. Then choose one of the options on the right:

MegAlign Pro — O >

File Edit View Align Features Sequences Overview Search Window Help

(@] Welcome 2 = O
What do you want to do? 6 Suggest a workflow

~pER o

New Project

Open Project E E

Training - New bIanI_{ Mew alignment... New alig_nment
alignment project... with options...

Additional project options

| Align viral genomes using reference...

WAl

DNASTAR™

o New blank alignment project — Opens an empty project window.

o New alignment — Launches a file chooser. Choose files and press Open to create a new
MegAlign Pro project with the default alignment already in progress.

o New alignment with options — Launches a file chooser. Choose files and press Open to
create a new MegAlign Pro project with the Align Sequences dialog open. Specify the alignment
algorithm, change other settings as desired, then press Align to begin the alignment.

» Choose File > New Alignment Project from the menu. Three options are available:

o Blank Document — Creates an empty document, regardless of whether any sequences or
subsequences are currently selected. See Add ungapped sequences to a project for an

alternative method.
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o With Selected Sequences — Creates a new document containing the currently selected

sequences. If no sequences are selected, this option is disabled.

o With Selected Subsequences — Creates a new document containing the currently selected
subsequences. If no subsequences are selected, this option is disabled.

» To create a new project and add sequences to it simultaneously, drag sequence files from a file
explorer and drop them on the project tab row of the MegAlign Pro window.

» Click the Create a new alignment project tool ( L ).
* Press Ctrl/Cmd+N.

If you elected to open a blank project, see Sequences to learn how to add sequences to it.
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Import an alignment from another application

To import an alignment from another applicaton:

1. Do either of the following:

+ From the Welcome tab, click Open Project on the left. Then use the option Import alignment

on the right.
* Choose File > Import Alignment.
2. Navigate to the file you wish to open. A wide variety of formats are supported, including gapped
FASTA (.fasta, .fas, .fap, etc.), Geneious alignment (.geneious), MEGA alignment file (.meg),

MegAlign file (.meg), MSF file (.msf), Vector NTI alignment project file (.apr) formats.

3. Click Open.

* Note: If you attempt to open a file that is not an alignment file, MegAlign Pro will instead
attempt to import any sequences from that file.

The following video (which launches, by design, at the 3:05 minute mark) demonstrates how to open
existing MegAlign Pro and classic MegAlign projects.
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Navigate between projects

You can open multiple projects within a single instance of MegAlign Pro. Each project is displayed in a
separate tab and is initially assigned a unique name (Untitled[#].msa).

To make a project the active project:

Click on its project tab.

To open an additional MegAlign Pro window:

Select the Window > New Window command.

To navigate between open projects:

One instance of MegAlign Pro may include multiple open projects. Each window is displayed in a separate
tab.

One tab, the Welcome screen, is always present by default unless it has been manually closed. To make
another project active, click on its tab.

If you cannot see all the window tabs in a project, press the >> icon that appears to the right of any visible
window tab(s). This icon is displayed when multiple view windows are open and the main MegAlign Pro
window is too small to display all the tabs. Click on the icon to open a yellow popup “window chooser” with a
line for typing in text at the top, and a list of open projects below.

< Salmonella_C... 2 = B | st i ST
| e
ICLE® < ADH Project.msa
Welcome

< Angiomotin_vertebrates.clustalo.msa

< DmADH.muscle.msa

< Salmonella_CT18_plus_gene.rnsa

Use your mouse to click on the window you want to make active. If you do not have a mouse, make a
selection using the keyboard arrow keys, then press Enter. To instead search for a project using a filter,
type text into the text field and press Enter. The text field supports the “?” and “*” wildcards.
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MegAlign Pro Interface

File Edit View Align Festures Sequences Overview Distance Tree Window Help
Menus — o
BY={" o-e
[ Untitledl.msa I *H. pylori samples.msa &2 = O || 9 style 52 | %8 Tracks [® Features § Places
Toolbar | 2 Ovenview I
Ruler Presentation
Project tab ©) AEI00511 St {
Multiple block display
Panels =" |

[] Show connecting lines

Viewport —

Overview -/ :

| £ Sequences |

Layout

[Linear -

Presentation

Font: [Segoe U BIERE
T T T T T k j
Sequences View | Fulert 30400 %0610 1070 667,080 667,08 || 7] Color foreground:
~ &) Consensus TAGTGGCATGGGTGGGATETTT ] Color by chemistry @

-
(&) AE000511 tagtggcatgggtgggatcttt gtagatagggtgtatgaagel
& NC_p12973

- - tagtggcatgggtgggatcttt ccasaaagcccttcaaacaad
V|ewspl|tter\ Sequence Ruler L A R e R R e

Cale hemist -

334,410 634,420 & [I:I slor by chemistry ] @

s atures elicobacter pylori B3 Helicobacter pylori B38 ; e
=

[¥] Color background:

Pane divider \ HELPY_0065 HELPY_0655 [None -
. |
'H _” Reference | Consensus
ureF HELPY 0655

Other view tabs we_ |

. p—— T |
tagtggcatgggtgggatettt tggtageataaaccegecat - |
a Parameters ‘
Console SiquencdLogo . TGG[ATGGGTGGGAT [TIT ] Metric: Uncorrected Pairwise Distar ~ | {
| T sl Gap treatment: | Global gap removal -
T T T T T T
Ruler2 0,600 90,610 7,070 667,080 667,09
Console toolbar L™ Vil =] 3
— — T 7 | Presentation
EEETE | oo D | e ]l i
EJ Console &3 ‘———i Ba B[ ™ B~ 13- = 0| pecimal places | 2
H. pylori samplesmsa -
root alignment has 168 superinterval = ‘
root alignment length: 2006784 - -
Moaganicns have 3% GC @ Oensis 2 =
L @ -
=== Ended Mauve at 5:21:26 PM after 6.91 minutes =—= [J| sedh-1

ol i ]

Type:  gene
left: 1

The following table describes components of the MegAlign Pro user interface, along with links to more in-
depth information about each item:

Item Description

The MegAlign Pro menus are: MegAlign Pro (available only on Macintosh), File, Edit, View,
Align, Features, Sequences, Overview, Distance, Tree, Window and Help. Some menu

Menus
commands can also be initiated by keyboard shortcuts, tools, and/or context menu (right-click)
options.

Tools The MegAlign Pro toolbar is situated just below the menus. To toggle between showing/hiding the

toolbar, choose View > Show (Hide) Toolbar.
Projects In MegAlign Pro, each project is displayed in a separate tab with an .msa extension.

The Overview provides a way to navigate within the sequences, no matter what type of sequences
Overview  or alignment is used. In the case of Mauve-generated alignments consisting of multiple alignment
blocks, the Overview also allows you to explore the relationships between aligned blocks.

Sequences
view

The Sequences view shows the sequences and any enabled tracks (see Work with Tracks).
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The Distance view, available only after an alignment has been performed, shows a matrix (i.e.,
Distance table) of numbers representing distances between each pair of sequences for the alignment block
view selected in the Overview. Sequence distances are used as input in creating the Tree View. In the
case of multi-block alignments, each alignment block will have a separate matrix.

The Tree view, available only after an alignment has been performed, shows evolutionary
relationships predicted from the multiple sequence alignment, and is calculated using the current

Tree view i . . . . .
Distance metric. In the case of multi-block alignments, each alignment block will have a separate
tree.

Panels The Style, Tracks, Features, Places and Details panels allow you to specify how to display items
in the views, or show details about items in the views.

View . . . o . : . . .

litt The view splitter is used to divide the Sequences view or Overview vertically into multiple panes.

splitter

Header/ A header and footer are collapsible sections above and below the selected reference sequence.

footer They contain tracks that apply to all those sequences and their alignment, if any. The Overview

provides a header, and the Sequences view provides a header and footer.

Sequence Sequence rulers pertain only to the sequences just above them, and use pre-alignment
ruler (ungapped) numbering. Gaps are not counted in this ruler.

Show/hide The gray circles to the left of each sequence name in the Sequences view and Overview contain a

icons plus or minus sign. These toggle between displaying and hiding the detail tracks.

Console The Console panel displays information about an alignment in progress, or a log for a completed
alignment.

Console . . . . :

toolbar This toolbar is located in the upper right of the Console and pertains only to the Console.
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Welcome screen

The Welcome “project” opens when you launch MegAlign Pro and is a central location for opening projects,
searching NCBI databases, getting help, and much more. As you add projects, the Welcome “project” will
remain as the leftmost tab unless you manually move or close it. We recommend leaving the Welcome tab
in place, since it has many time-saving shortcuts to useful commands.

File Edit WYiew Align Features Sequences Owerview Search Window Help
(@] Welcome 33 = 8
What do you want to do? 6 Suggest a workflow

New Project New project

> B

Training . MNew blanl.< Mew alignment... Ngw alig.nment
alignment project... with options...

Additional project options

& Align viral genomes using reference...

Open Project

“ V3l

DNASTAR™

Tab on Option on .
Shortcut to this procedure:

left right
New blank . . .
] File > New Alignment Project > Blank Document. (see Create or Open a
alignment Project)
project lect)

File > New Alignment Project > Blank Document plus File > Add Sequences

New alignment . . . .
plus Align using default method and options. (see Create or Open a Project).

New

project
File > New Alignment Project > Blank Document plus File > Add Sequences

plus Align with Options (allows you to choose the method and edit options). (see
Create or Open a Project).

New alignment
with options

Align viral File > New Alignment Project > Blank Document plus File > Add Sequences



Open
project

Search

Training
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genomes
using
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Open
alignment
project

Import
alignment

Recent
documents

Search for
sequences

Search for text

in NCBI
nucleotide

Search for text

in NCBI
protein

User guide

Tutorials

User Guide to MegAlign Pro - 17.3_en

plus Align with Options set specifically to use the MAFFT alignment algorithm.
(see Create or Open a Project).

File > Open (see Create or Open a Project).

File > Import Alignment (see Create or Open a Project).

File > Recent Documents. (see Create or Open a Project).

Search > Search for Sequences (see Search for sequence matches in BLAST).

Search > Search for text in NCBI nucleotide (see Search for text or accession
number matches in Entrez).

Search > Search for text in NCBI protein (see Search for text or accession
number matches in Entrez).

Help > User Guide. Opens this User Guide.

Opens this User Guide to the MegAlign Pro Tutorials topic.
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Views

The left side of the MegAlign Pro window is comprised of one or more “views.” To learn more about the
types of views and how to change their appearances, click the links below.

View types:

e Overview
e Sequences view
« Pairwise view

» Distance view
* Tree view

o Text view

* Table view

To learn how to select, display and customize views:

See Customize the look and layout.

To access a different instance of a view:

Some DNASTAR applications, including MegAlign Pro, allow multiple instances of a view to be created. For
instance, if you select a pair of sequences and use Align > Align Pairwise — and repeat that three times
— MegAlign Pro will create three separate Pairwise views. As shown in the image below, the view tab
shows how many views of that type are in that tab folder.

To display a different instance:

1. Hover over the view tab until you see a popup showing each instance by name.

2. Click on the desired instance.
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Overview

The Overview provides a way to navigate within the sequences, no matter what type of sequences or
alignment is used. In the case of genomic alignments generated by Mauve, the Overview also allows you to
explore the relationships between multiple aligned blocks. Selections and vertical ordering within this view
are synchronized with other views in MegAlign Pro. Similarly, selections and ordering done elsewhere are
reflected in the Overview.

To access the view, click on the Overview tab.

Overview B =
| =%
§ | I I | | T T T T I T T T 1T | T 1T T 1 I T T 11T | T T T T I T T T 1T | T 1 A
Ruler 500,000 1,000,000 1,500,000
A |
CPO02076 . -
LI lllll%
4 i -,u_g_._!!!
CPOD2332 L LS L LS ”
(@) AEDDOS11
NC_012973

& B

By default, the Overview displays a header, followed by one or more sequences with labels to their left.
Each sequence is depicted as a “sequence/alignment block,” and the length is proportional to other
sequences in the group. Each sequence row can display a variety of optional data tracks.

The Overview displays information in different ways, depending on the alignment stage and the workflow. In
all cases, sequences are represented as either gray or colored blocks. Any sequence that is not part of an
alignment is shown in solid gray. Sequences included in an alignment are usually drawn in dark green,
although multi-block alignments, such as those generated by Mauve, are drawn in up to seven colors.

See the following topics for images and details of the Overview in different situations:

» Prior to performing an alignment

« After aligning multiple genomes with Mauve

« After performing a non-Mauve alignment or a Mauve non-genome alignment

- After performing an alignment and entering additional sequences
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The blue/gray bar at the top of the view shows information pertaining to the current selection.

Selection

Nothing, and sequences have
not been aligned

Nothing, and at least some
sequences have been aligned

One sequence

Multiple sequences

A feature or any portion of one
sequence

A portion of multiple
sequences (selected in the
Sequences view)

Example

(blank)

Clustal Omega

isoH-MNM_001032097.2 = 2,024

2 of 4 aligned sequences

2 of 5 unaligned sequences

isofF-Mh_001032098.2721>1257 = 537

54=342 = 289

Tasks pertaining to the Overview:

Task

Change settings for
this view

Customize the look
and layout of the

How to...

See Customize the look and layout.

view, zoom in or split
the view

Set an unselected

Information displayed

(blank)

The name of the alignment.

The sequence name and its length in bp.

The number of sequences selected, the total
number of sequences, and the alignment
status.

The sequence name and selected range.

The selected range and length in bp.

To change settings, including showing/hiding connecting lines and changing spacing
between rows, use the Overview section of the Style panel.

Double-click on an inactive alignment block, or right-click on an inactive alignment

alignment block in
the Overview as the
active block

Change settings
related to the
Overview

Copyright DNASTAR, Inc. 2022

block and choose Set As Active Block. The corresponding sequence blocks will line
up vertically. The alignment block containing the sequence block will become active.

use the Overview section of the Style panel.
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Make an alignment Make a block active by double-clicking a sequence block. Then choose Overview >
block the active block Set Start of Sequences to Active Block or the context (right-click) option of the
and move it to the left same name. The blocks in each sequence are rotated so that the active sequence
of the Overview block is leftmost.

Center the Overview
display over the Choose Overview > Show Active Block.
active block

. Choose Overview > Reset Start of Sequences or the context (right-click) option of
Return alignment ) o )
. the same name. In the Overview, the individual sequence ruler coordinates are
blocks to their default .
updated to reflect the change.Note that resetting the start of sequences presumes

order . . . .

that alignment consists of circular genomic sequences.
Search for a Click the Search tool ( ﬂ;1']') on the right of the header area to open a search area. See
sequence by name Search for a sequence using a text query for details.

Export data from the  Click the Export Data tool (L2), a shortcut to the File > Export Data subcommands.
view See Export data to a file.

Save an image of the  Click the Export Image tool (L_“""'| ), a shortcut to the File > Export Image

view subcommands. See Export an image of the view.
Print the view Click the Print tool (L:I)' See Print Images for details.
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Overview prior to performing an alignment

The Overview has different appearances, depending on the stage and workflow.

Prior to alignment, each sequence in the Overview appears as a green rectangle (“sequence block”) with no
gaps. The length of each block is proportional to the ungapped length of its corresponding sequence.

LI L L I L L L I L L L L I T T 117171
L J 100 200 300
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Overview after aligning multiple genomes
with Mauve

The Overview has different appearances, depending on the stage and workflow.

A Mauve genome alignment results in a set of locally colinear blocks (LCBs), each of which is a conserved
region across multiple sequences. In MegAlign Pro, these may be referred to as “blocks” or “alignment
blocks”. The Overview displays the part of a sequence in an alignment block as a “sequence block.” The
sequence blocks in the same alignment block have the same color, and by default are shown connected by
lines.

I =) |

Ruler 1
(€5 AED00S11
() NC_012973
(€2 CP002076

&) CPo02332

(&) NC_17372

3 CPO02982

To orient the alignment around an active block, double-click on the sequence block. If necessary, individual
sequences flip (i.e., are reverse complemented) to orient properly for the new alignment. Sequence rulers
reorient along with the strands, and display the new coordinates. Gaps in the active block are shown by the
presence of gray bars.

» Only one block is active at a time, and the current block for all the sequences blocks for are always
shown in the forward orientation (i.e., on the top strand).

« Sequence blocks are usually displayed only if they include at least two sequences, though an
exception is made when there is only one sequence in the project.

+ Some sequences may not be included in the active block.

* In order to keep the current blocks in the same orientation, it may be necessary to reverse
complement one or more entire genomes.
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The interior of the active block (only) displays a histogram of residue count, with gray areas
representing gaps. These histograms reflect the proportion of non-gapped positions in a window
corresponding to the number of positions spanned by a single pixel at a given zoom level.

Blocks appearing out of order compared to other rows can signify an inversion. Blocks in reverse
order compared to other rows can signify that the sequence is from the opposite strand compared to
the other rows.

If an alignment block is “hanging down” compared to other blocks in the same track, this signifies that
the feature is encoded on the opposite strand. Having blocks represented on the lower strands are the
result of rearrangements, such as inversions, and are not meant to imply that the alignment is double-
stranded.

The contents of the Distance and Tree views are specific to the active block only.

After aligning sequences end-to-end, vertical blue bars are used to show the beginnings and ends of the
component sequences. These bars are displayed regardless of the type of alignment performed.

L k0 sk e a0
¢ )]
. .
[ ) S | ]
]
[ 1 )
]
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Overview after other alignments

The Overview has different appearances, depending on the stage and workflow.

After aligning with a method other than Mauve, or after performing a Mauve alignment that results in a
single aligned block, any blocks in the Overview will be green and will have the same lengths.

The interior of a sequence block displays a histogram of residue count, with gray areas representing gaps.

These histograms reflect the proportion of non-gapped positions in a window corresponding to the number
of positions spanned by a single pixel at a given zoom level.

IIIIIIIII|IIII|IIII|IIII|IIII|III
L J 100 200 300

After aligning sequences end-to-end (see Add Multi-Segment Sequences), vertical blue bars are used to
show the beginnings and ends of the component sequences (i.e., the segments). These bars are displayed
regardless of the type of alignment performed.

T T 17T 17T 17T 17 17771 I L L I 1T 17T T 7T 17 T 17771 I 1T 17T 1717 17T 177171
Q 2,000 4,000 6,000
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Overview after aligning and entering
additional sequences

The Overview has different appearances, depending on the stage and workflow. In all cases, sequences are
represented as either gray or colored blocks. Any sequence that is not part of an alignment is shown in solid

gray.

After performing an alignment, any new sequences added to the project are shown as gray blocks under a
bar with the words “Unaligned Sequences.” The bar displays the number of unaligned sequences in
parentheses, and a moveable pane divider separates the unaligned sequences from the alignment. The
unaligned sequences can be shown/hidden by clicking the Unaligned Sequences bar. The Unaligned
Sequences bar is not displayed if there is only one sequence in the project.

O||||||||||||||||||||||||||||||||||||
Ruler 1,000 2,000 3,000

MM _008285
*M_541769
MM_001042731

Aligned
seguences

1|

It Unaligned Sequences (2) |

Fo
Rl OIII|IIII|IIII|IIII|IIII|I'I|IIII|III|||'
uler 1,000 2,000 ]
Unaligned
1 H
NM_001114165 sequences
NM_001098212 ; _—

* To learn how to add the unaligned sequences to an existing alignment, see Merge unaligned

sequences into an existing alignment.

» For information on performing a completely new alignment consisting of a combination of one or more
unaligned sequences and one or more previously aligned sequences, see Align selected unaligned

sequences with an existing alignment.

Copyright DNASTAR, Inc. 2022 Page 28 of 329



Using the Overview as a sequence navigation
tool

The light blue vertical column in the Overview is a “viewport” showing the region currently being displayed in
the Sequences view. There are a number of methods—all performed within the Overview—for using the
slider to navigate to a particular region in the Sequences view:

* In any project, move the slider to a desired region by dragging it with the mouse.

» In a single-block project, double-click anywhere on a block to center the slider over that position.

* In a multi-block project, double-click on an un-highlighted block to make it the active block and to
move the slider to its left end.

* In a multi-block project, double-click anywhere on the active block to center the slider over that
location.

Once you have centered the viewport in the desired location, use the horizontal zoom slider in the
Sequences view to increase or decrease the width of the view.



User Guide to MegAlign Pro - 17.3_en

Sequences view

The Sequences View displays added sequences and aligned sequences. Sequence names selected in this
view are simultaneously selected all other views in MegAlign Pro. Similarly, sequence names selected
elsewhere will be highlighted in the Sequences View.

To access the view, click on the Sequences tab.

| u —
| L I T 1T T 17T T 17T 1771 I T T 1T 17T 1T 17T 177 I LI L
- Rulerl 803,000 803,010 803,020
@ Consensus GGTAATTTTCTTTTTCCCATGCGCTCGCTTGA
il
(&) AE000511 ggtaattttettttt t ggdt ol BE -«
() NC_012973 ggt ttttettttt tg gtagettyg
(& CPO02076 ggt@attttettttt tg tcgettg,
@ CPO02332 ggtaattttetettt tg 100
(& NC_017372 ggtlaattttettttt tg tcgettag ||
| &2 CPO02982 ggt ttttecttttt tegettg~
i,
SeqUEHCELﬂgD 1AA11T1 1TT11 A1G 1c TGA
R AA
| T T T T T T T T | T T T T T T T T | T T T T T T T T | 1
Ruler 2 803, 000 803, 010 803, 020
4 [l 3
= Sequences [ E Distance H Tree l ﬁ E

By default, the Sequences view consists of three sections: the header, the footer, and sequences area, the
last of which consists of nucleotide or amino acid codes for each sequence on the right, and their labels on
the left. Each section can display a variety of optional data tracks. The Sequences view has a different
appearance depending on the zoom level.

When viewing a multi-block alignment produced by Mauve and using a minimal horizontal zoom, the
currently-selected alignment block will appear the same color as in the Overview. Flanking sequences in
adjacent blocks will appear gray. At higher zoom levels, the residues for the active block will be shown in
bright colors, while flanking sequence residues are represented by “dimmed” (dull) colors.

(i) AEDDDS11
(£ NC_012973
) CPO02076
() CPD02332
() NC_017372

The dimmed residues are displayed as unaligned sequences, and therefore appear ungapped and without a
consensus. To view the dimmed residues as aligned sequences, select the corresponding block in the
Overview.
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The blue/gray bar at the top of the view shows information pertaining to the current selection.

Selection

Nothing, and sequences have
not been aligned

Nothing, and at least some
sequences have been aligned

One sequence

Multiple sequences

A feature or any portion of one
sequence

A portion of multiple
sequences (selected in the
Sequences view)

Example

(blank)

Clustal Omega

isoH-MNM_001032097.2 = 2,024

2 of 4 aligned sequences

2 of 5 unaligned sequences

isofF-Mh_001032098.2721>1257 = 537

54=342 = 289

Tasks pertaining to the Sequences view:

Task How to...

Specify the
look and
colors used

Information displayed

(blank)

The name of the alignment.

The sequence name and its length in bp.

The number of sequences selected, the total
number of sequences, and the alignment
status.

The sequence name and selected range.

The selected range and length in bp.

Use the Sequences section and Multiple Alignment section of the Style panel. Available color

in the
Sequences
view

Customize
the layout
of the view,

schemes are described here.

See Customize the look and layout.

zoom in or
split the
view

Show a
specific

Copyright DNASTAR, Inc. 2022

The Overview’s “viewport indicator” highlights the portion of the sequence displayed in the
Sequences view. Drag the indicator to scroll the Sequences view along the sequence. Use the
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sequence

range in the

view

Show/hide
a vertical
guideline

Show/hide
the header,
sequences
area, or
footer in
the
Sequences
view

Search for
a sequence
by name

Export data
from the
view
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zoom sliders in the Sequences view to control the width of the viewport, and thus, the amount of
visible sequence.

Ruler

| Homo sapiens (human)

@ ©

| Saccharomyces cerevisi..,

| Mus musculus (house ...

@

163 Mus musculus (house ...

&3] Caenorhabditis elegans

| —

T L B e LA e e “
Rulerl 50 70 80 20 . P10
fxxxxPVVI.GHEGAGlVESVGEGVTngpGDKVf]Pl.fnPQngfoanPxxNLCx‘ixxxg

(&) Consensus

i} Homo sapiens (human)
(£ Saccharomyces cerevisi...

-vtplpvilgheaagivesvgegvttvkpgdkv-iplftpgcgkcricknpesnyclkndlg----
Ilpvklplvgghegagvvvgmgenvkgwk igdyagikwlngsecmaceycelgnesncphadlsg----------

Note that if you split the Sequences view, multiple viewports will appear in the Overview.

The guideline is displayed, by default, and is a navigational aid to help in guiding your eye
between the sequences and the rulers. To hide the guideline in all open projects, click
Sequences > Show Guideline to remove the checkmark. Even after hiding the guideline, an
abbreviated version of the guideline will remain visible in the header and footer.

T T T T
{

BGTTT

elgttt
S
=gttt
Sgttt

The display of the header, sequences area or footer can be toggled on/off by clicking on the
small dark gray arrows near the upper right corners of each section.

934,230
TTGGGTTTA

Click the Search tool ( Q) on the right of the header area to open a search area. See Search
for a sequence using a text query for details.

Click the Export Data tool (E}), a shortcut to the File > Export Data subcommands. See Export
data to a file.
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Save an

image of Click the Export Image tool (EI ), a shortcut to the File > Export Image subcommands. See
the view Export an image of the view.

Print the . . £S5 . .

view Click the Print tool (=J). See Print Images for details.
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Pairwise view

The Pairwise view displays sequences that have been aligned pairwise. Sequence names selected in this
view are simultaneously selected all other views in MegAlign Pro. Similarly, sequence names selected
elsewhere will be highlighted in the Pairwise view.

To access the Pairwise view, do either of the following:
» Perform a pairwise alignment. In this case, the Pairwise view opens automatically to display the

results. To open the view at a later time, click on the Pairwise tab. If there are multiple Pairwise tabs,
hover over each tab to see a tooltip showing which sequences were involved in that alignment.

+ Perform a BLAST search. In this case the Text, Table and Pairwise views are displayed together in a
single popup window that is separate from the main MegAlign Pro window. To reopen the Pairwise
view (and the associated views) at a later time, click on the Status link in the Jobs panel.

4

[ Pairwise 1 - AAC41757.1 vs MP_0145551

In the left of the header, the Align (left) drop-down menu is used to specify the target sequence, which
should be the longest sequence of the two. The with (right) drop-down menu is used to specify the query
sequence. Specifying a different sequence in either menu will initiate a new pairwise alignment.

Summary area:

Local: Smith-Waterrnan DMNA alignment  [Matrie "MUC44"  Gap penalty: 10 Gap extension penalty: 1]

TETHIS21MA  TETHIS22MA Gap Gap

1906 1905 Yldentity %Gaps Identical Count Length Score Length
Alignment 13=862 1=902 69.2% 19.2% 671 46 186 2307 069
Selection  24=264 8=263 604%  256% 172 20 FERET Y] 285

The summary area describes the alignment engine and settings that were used to create the pairwise
alignment.

Value Description

% Number of matching residues divided by the sum of all residues and gap characters. The quotient is
Identity multiplied by 100 to give the similarity as a percent.

The gap length divided by the consensus length. The quotient is multiplied by 100 to give the

% Gaps . ..
similarity as a percent.

Copyright DNASTAR, Inc. 2022 Page 34 of 329



User Guide to MegAlign Pro - 17.3_en

Identical Number of residues that are identical in both sequences.

Ga
Copnt Number of gaps (of any length) in either sequence of an alignment.
u
Gap . .
Number of gap characters in an alignment.
Length
Score The cumulative score for an alignment derived by adding the matrix-derived match scores and

subtracting gap penalties.

Length  Number of residues in the consensus, including gaps that match in both sequences.

Sequences area:

Ruler 200 400 410
(22 TETHISZLMA @aaagcaagtccaccctgatgtcggtattteccaa
) LI EErt ettt ettt
I5x TETHISZZ2MA @aaagcaagtccaccctgatgtcggtatttecaa

The sequences area consists of nucleotide or amino acid codes for each sequence on the right, and their
labels on the left. The order is always “target sequence” first, and “query sequence” second. A variety of
optional data tracks can be displayed in this section. The Pairwise view has a different appearance
depending on the zoom level.

Tasks pertaining to the Pairwise view:

Task How To

All Pairwise views

Customize the look
and colors used in
the view

Use the Pairwise Alignment section of the Style panel. Available color schemes are
described here.

Customize the layout
of the view

See Customize the look and layout.

Click the Export Image tool (L_‘!JII ), a shortcut to the File > Export Image
subcommands. See Export an image of the view. The summary and sequences areas
are both exported.

Save an image of the
view

Only Pairwise views not resulting from a BLAST search
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Change pairwise Click the Change alignment options in this view tool (&), a shortcut to Align >
alignment options Pairwise. Set options as desired and press Align.

Select a portion of the alignment, then click the Create new pairwise alignment

()

Create a new pairwise

subalignment

from selection tool . The subalignment will open in a new Pairwise view.

Export data from the  Click the Export Data tool (]—}), a shortcut to the File > Export Data subcommands.
view See Export data to a file.

Copy data from the

view to paste into an  First select the range by clicking on the first residue and Shift +clicking on the last
e-notebook or text residue. Then right-click on the selection and choose Copy.

editor

Click the Clone this view tool ('1%). This makes an exact copy of the current Pairwise
view, including sequences, alignment type, settings and current selection. This is
useful if you want to change one factor for comparison to the original alignment.

Make a copy of the
current view
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Distance view

The Distance view shows a matrix (i.e., table) of numbers representing distances computed for each pair of
sequences for the selected aligned block. Sequence distances are used as input in creating the
phylogenetic tree shown in the Tree view. Selections within the Distance view are synchronized with other
views in MegAlign Pro. Similarly, selections made elsewhere will be highlighted simultaneously in the
Distance view.

The Distance view is only accessible after you have performed a multiple alignment, and becomes
inaccessible again if you unalign the sequences. After performing an alignment, you can access the view by
clicking on the Distance tab.

Eﬂist-n:e Faldentity ~  f Distance e Uncorrected Pairwise Distance ' l.'= é:?:é '@ | n =
| =3

A B C o E F G H [ ] K L M M
A Barley Calmodulin.pro MENEE 9060 9060 8993 9060 99.33 BG5S 01.95 90.60 EESEl 90866 9933 9866
B Black Mold Calmodulin.pro IS 8456 8322 8389 84.56 [18255 IETZIINEEN /6 993 (NBTSEIN8NeE 8322
C  Chicken Calmadulin.pro 003 015 8850 8993 89.93 90.60
D | Cilliate Calmodulin.pro 008 017 009 | 8926 89.93 90.60
E | Electric Eel Calmodulin.pro 010 016001 040 | 8926 89.93
F  Human 009 015 70000 0.09 (001 8993 8850 9060
G | Lily Calmodulin.pro [Toon e o0 010 011 010 8591
H | Paramecium Calmodulin.pro o3 o110 007 042 011 014
| | Potato Calmadulin.pro ooz EEE o009 011 040 009 000
) Rat Calmodulin.pre 000 015 000 o000 o0V 000 010 0.1
K  Red Bread Mold Calmedulinpro JROE 001 015 016 0315 015 0.7 N0NE DoEE
L RedBryony Calmodulinpre | 001 BB0RE8l 010 011 011 0100 001 015 009
M | Rice Calmodulin.pro oo EEEl o0 010 011 0a0 000 004 0.09
M | Soybean Calmodulin.pro [o01 017 o009 009 010 0090 001 013 0.08

| 2| [Eee x| (RN

The upper-right and lower-left triangular-shaped sections of the matrix can show different information
depending on Values selections made in the Distance section of the Style panel or using the drop-down
menus in the upper left of the Distance view itself. For instance, in the image above, %ldentity appears in
the upper-right and Distance in the lower-left. Note that no numbers appear on the diagonal, since a
sequence cannot differ from itself. In certain situations, it may not be possible to calculate distances for
every pair of aligned sequences, in which case “NA” is displayed. In other cases, “NA” may be an artifact of
the computational algorithm; for example, an attempt to calculate the log of a negative number.

If Identity is displayed, note that larger numbers correspond to greater differences between sequences.
Uncorrected distances are always <1.0. However, the Kimura and Tamura-Nei values can exceed 1.0
because they reflect the inferred actual number of nucleotide substitutions or amino acid replacements per
site, not the observed distance. When the divergence between a pair of sequence is greater than about
0.75, it may not be possible to calculate a value for corrected distance using the Kimura and Tamura-Nei
metrics.

Information bar:
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The blue/gray bar at the top of the view starts on the left end showing the color of the Block (multi-block
Mauve alignments only). The rest of the information bar consists of information pertaining to the current

selection.

Selection

Nothing

One sequence or a row/column

header (letter)

One table cell

Example Information displayed

Uncorrected Pairwise Distance  The distance metric currently specified.
AACATST = 375 The name of the sequence and length in bp.

The number of sequences involved in the cell and
their alignment status.

2 of 5 unaligned sequences

Tasks pertaining to the Distance view:

Task

Customize the
look and
layout of the
Distance view

Search for a
sequence by
name

Change the
parameters
used to
generate the
distance table

Expand the
header to
show style

How To

See Customize the look and layout. Statistical metrics and fonts are set using the Distance section of the
panel.

Click the Search tool ( & ) on the right of the header area to open a search area. See Search for a seqt
using a text query for details.

Click the Change Analysis Parameters tool ( %‘) or choose use Distance > Parameters to open the A
Options dialog. There, you can specify the Metric and Gap Treatment. Use the Metric drop-down ment
change the metric used to calculate distance; see Distance metric options for details. Use the Gap Treat
drop-down menu to specify when gaps should be ignored; see Gap treatment option for more informatiol
that you must press the OK button before MegAlign Pro will initiate the calculation or display the results.

Analysis Options O et
Metric: |Uncorrected Pairwise Distance V|
Gap treatment: |G|oba| gap removal V|

Reset to Default Cancel

Click the Show Style tool (@') to add a row below the current header that allows you to control the same
settings that can also be controlled via the Distance section of the Style panel.
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Decimal places: Font: | Segoe Ul ~ B I [Aupperright [ ] ][ b Lowerteft: [ - |
tools

To minimize the row, click the tool again or use the Collapse tool (inverted ‘v’) on the right of the row.

Export data

. Click the Export Data tool (J—}), a shortcut to the File > Export Data subcommands. See Export data to
from the view

To add a second row of header information, click the Show Quick Details tool (ﬁ).

E Distance Uncorrected Pairwise Distance 3 B o =
|Sequences: 5 Global gap removal Residues considered: 1,001 I [

A B C D E
A Dmel_ADH 0.03| 0.03| 000 0.00

See additional
details in the + Sequences — The number of sequences in the alignment or in the active block.

view header
* Global/Pairwise gap removal — The gap treatment specified in the Distance section.

* Residues considered — Total length of alignment minus all columns containing even a single
This field shows both the minimum and maximum number of residues considered, if they diffe
banners at the tops of the Distance and Tree views will show a range here if different number
residues are considered for different pairs of sequences. This happens frequently when Pairv
gap removal is checked. However, if the minimum and maximum values differ greatly, we
recommend selecting Global gap removal instead

Hover over any row/column header or any cell. For projects using Pairwise gap removal (see Distance
section), the tool tip also contains the number of residues considered for that pair.

005 0.06 95.85
Dl & 005 005L3 [aEo0os11
tooltip with CPOD2332
i W @ Dhstance: 0.06
the sequence
corresponding Zaldentity: 94.17
%eGaps 26.37

to a cell

Identical: 176,798

Gap count: 67,233

Gap length: 67,233

Residues considered: 187,739

Select all cells

. Choose Distance > Table > Select All.
in the table

Use editing

Choose Distance > Table > Copy (Select All, Rename, Rename with Fields).
commands
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with the
Distance table

Freeze Choose Distance > Table > Freeze Scrolling Region. In a large table, this command allows you to con

scrolling rows near the top with those further down.
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To change the distance metric used to generate the Distance view table, click the Change Analysis
Parameters tool ( %‘) in the Distance view. This opens the Analysis Options dialog where you can specify
the Metric and Gap Treatment. Another way to access the same dialog is to use Distance > Parameters.

Analysis Options

O

et

Metric: |Uncorrected Pairwise [hstance

St |

Gap treatment: | Global gap removal

> |

Reset to Default

Use the Metric drop-down menu to change the metric used to calculate distance. Note that metric selection

is disabled for projects without sequences. Otherwise, choices include:

* Uncorrected Pairwise Distance — (the default metric) — The number of identical bases (or residues)
divided by the number of bases being compared, ignoring any positions with gaps. Uncorrected
pairwise distance can be converted to %ldentity using the formula: %ID = 100 * (1 — distance).

+ Kimura — (protein sequences only) — The Kimura model (1983), which should not be used for very
divergent sequences, uses the formula: D =—1In (1 — p — 0.2 p2), where p is the uncorrected pairwise
distance. The Kimura distance approximates the “PAM distance” used in MegAlign.

» Scoredist — (protein sequences only) — This model, developed by Sonnhammer and Hollich (2005)
computes the alignment score between two sequences using the BLOSUM®62 scoring matrix. The
units for the ScoreDist function are “percent accepted point mutations” (PAM). Scores are converted
to distances and normalized by the average scores of the two sequences matched to them. This
approach works even for very divergent sequences, providing that there are overlapping residues.

+ Tamura-Nei (1993) — (nucleotide sequences and low degrees of divergence only) — An estimate of
divergence using the TN93 model of the evolutionary process. This model attempts to separately
account for different rates of transversion mutations (e.g., purine < pyrimidine) and the two
categories of transition mutations (i.e., purine only A « G; pyrimidine only C < T). The frequencies of

each type of nucleotide do not need to be the same.

Note that you must press the OK button before MegAlign Pro will initiate the calculation or display new
results in the Distance view..

See the topic Gap treatment options for information on that portion of the dialog.
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Gap treatment options

To change the distance metric used to generate the Distance view table, click the Change Analysis
Parameters tool ( %‘) in the Distance view. This opens the Analysis Options dialog where you can specify
the Metric and Gap Treatment. Another way to access the same dialog is to use Distance > Parameters.

Analysis Options O >
Metric: |Uncorrected Pairwise Distance v
Gap treatment: | Global gap removal w

Reset to Default Cancel

Use the Gap Treatment drop-down menu to specify when gaps should be ignored. Choices include:

* Global gap removal — (default) This option ignores any column that contains a gap in any of the
aligned sequences in the project. This is the only enabled option for MegAlign Pro projects created
prior to the 12.0 release (spring 2014).

+ Pairwise gap removal — This option ignores any column that has a gap in either of the two
sequences being compared.

Note that you must press the OK button before MegAlign Pro will initiate the calculation or display new
results in the Distance view..

To learn about the other part of this dialog, see Distance metric options.
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Tree view

The Tree view shows evolutionary relationships estimated from the multiple sequence alignment, and is
calculated using the current tree-building algorithm and settings, and the currently-selected Distance metric.
This view is only accessible after you have performed a multiple alignment, and becomes inaccessible again
if you unalign the sequences. This topic is an introduction to the Tree view. To learn how to make,
customize, reroot or export trees, refer to the main topic Phylogenetic Trees.

To access the Tree view, use the View > Tree > Tree command or click on the Tree tab. The Tree view
initially displays the following graphic, prompting you to choose a tree-building algorithm.

LNO

Meighbor Joining: BION) Maximum Likelihood: RAxhL

Once you choose an algorithm and MegAlign Pro builds the tree. The phylogeny is displayed as a rooted
tree reflecting the evolutionary relationships between the aligned sequences. The default tree will appear
similar to this one.

([ Tree1  Block [N RAXML (Snapshot) Ll @9 LBz 00 =3
| [N |
- CPO02332
0.067
ooz [,
s — NC_012973
- CPO02076
| 0052
AE000511
0023
& [
0.01
[§Sequencﬁ Hﬁﬂistance ][Pain\ise Eﬁ@] ree x ﬁ =

Some information about the view:

+ Selections within the Tree view are synchronized with other views in MegAlign Pro. Similarly,
selections made elsewhere will be highlighted simultaneously in the Tree view.

» Distance values are reflected in the lengths of the branches and their numerical values are are
displayed by default. A distance scale appears at the bottom left of the image.
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» The root can be placed on any branch using the Tree > Root On command. The true distance value
of the actual branch with the displayed root is the sum of the two displayed branches flanking that
displayed root.

+ Changes made to the alignment (e.g., realigning with a different method, or with additional
sequences) or to the distance metric cause the tree to be recalculated.

 In certain situations, it may not be possible to calculate distances for every pair of aligned sequences.
In these cases, sub-clusters of related sequences may be shown together on separate trees, or listed
together as a single node. See Distance view for more information.

* Due to the difference in alignment methods, trees built in MegAlign (discontinued in 2019) and
MegAlign Pro may appear different. In addition, trees built in MegAlign are rooted, whereas trees built
in MegAlign Pro are always unrooted, regardless of the method used for the alignment. The presence
or absence of “roots” can cause a discrepancy in the vertical ordering of sequences between the two
applications.

Information bar:

The blue/gray bar at the top of the view starts on the left end showing the color of the Block (multi-block
Mauve alignments only). The rest of the information bar consists of information pertaining to the current
selection.

Selection Example Information displayed

Nothing BIOM) The name of the tree-building algorithm.

One sequence AACATTST = 375 The name of the sequence and length in bp.

More than one 3 of 5 ; The number of sequences selected and their alignment
unaligned sequences

sequence status.

Tasks pertaining to the Tree view:

Task How To

Search for o

a sequence Click the Search tool (“#=) on the right of the header area to open a search area. See Search for a

by name sequence using a text query for details.

Order Use the commands in the Tree menu or click the Sort sequences tool (1.'=) on the right of the header
branches area to open a menu with options for changing the layout of the tree. A common reason to use these
or commands is when preparing the tree image for publication. You may wish to order the tree to create a

sequences pleasing image or to draw the viewer’s focus to a certain spot, or to allow for easier comparison. Note
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Change the
appearance
of the tree

Save an
image of
the current
tree

Change the
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that in the command names, “ascending” and “descending” are arbitrary terms referring to the display
structure of the tree. “Ascending” tends to form a diagonal from the upper-left to lower right while
“descending” tends to form a diagonal from lower-left to upper-right. Commands include:

» Order Ascending/Descending By > Default Order — Sorts in descending order by depth (i.e.
by the sum of the branch lengths).

* Order Ascending/Descending By > Depth — Sorts in ascending/descending order by the
sum of the branch lengths. Depth measures branching; the children of a subtree are sorted by
the maximum number of branches to a leaf.

* Order Ascending/Descending By > Distance — Sorts in ascending/descending order by the
distance between samples in the dataset. The children of a subtree are sorted by the
maximum distance (i.e. length in one dimension) from the subtree node to a leaf.

+ Order Sequences Like Tree — To force the other views to reorder their sequences to agree
with the order in the Tree view.

Click the View settings tool (%). This opens the View Settings dialog where you can see the method
employed to draw the tree and type in a new Name if desired.

View Settings O >

Marme: | fTree 1

Using:  Meighbor joining: BIOMN)

Use View > Style > Tree to open the Tree section of the Style panel. Alternatively, click the Show Style
tool (@') to add a row below the current header that replicates this section. In either case, see the Tree
section topic for information on changing settings.

Branches n Line: Label: Distance ~  Modes: Segoe U w B I [JBox: &

To minimize the row, click the tool again or use the Collapse tool (inverted ‘v’) on the right of the row.

Use the Take snapshot tool (). In the save dialog, choose whether to save the image as a PNG, JPG,
PDF, or editable PowerPoint document (.pptx).

Click the Compute Phylogeny tool (n). This is a shortcut to the Tree > Compute Phylogeny command
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method

and/or

parameters and allows you to change the tree calculation algorithm and related parameters. For detailed information,
used to see Phylogenetic Trees.

generate
the tree
Redraw the
tree
accordin
to the . Use Tree > Reset View of Phylogenetic Tree or Ctrl/Cmd+Shift+R.
default
settings
Export data
from the Click the Export Data tool (J—}), a shortcut to the File > Export Data subcommands. See Export data to
. a file.
view
Export an iz
image of Click the Export Image tool (=), a shortcut to the File > Export Image > (Tree Name). See Export an
. image of the view for details about export options.
the view
Print the i . [ . )
view Click the Print tool (=). See Print Images for details.
Select one Double-click on a sequence to select it. To select all sequences in a branch (i.e., a clade), click the
or more vertical bar for that branch. Click any horizontal bar to select every sequence in the tree. Any selection
items in the you make is synchronized across all MegAlign Pro views. To compare selected sequences, go to the
i i
tree Sequences view and use drag and drop to move the selected (highlighted) sequences to any location to
view them side-by-side.
Click the Show Quick Details tool (ﬂ).
The header contains a subset of the following information:
* Block — (multi-block Mauve alignments only) The color of the alignment block currently
selected in the Overview.
Add a
“details” « Alignment — The alignment method used.
header to
the view « Distance Metric — The distance metric (calculation method) specified using Distance >

Parameters.

+ Sequences — Number of sequences in the alignment or in the active block.

+ Global/Pairwise gap removal — The gap treatment specified in the Distance section of the
Style panel.
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* Residues considered — Total length of alignment minus all columns containing even a single
gap. This field shows both the minimum and maximum number of residues considered, if they
differ.
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Text view

To access the Text view, perform a BLAST search. When the search is complete, the Text, Table and
Pairwise views are displayed together in a single popup window that is separate from the main MegAlign
Pro window. To reopen all three views at a later time, click on the Status link in the Jobs panel.

An example Text view is shown below:

results.search _ | %
GEKZAZIDEI549 v ﬁ*ﬁ? %EL}
BLASTP 2.9.8+ A

Reference: Stephen F. Altschul, Thomas L. Madden, Alejandro A.
Schaffer, Jinghui Zhang, Zheng Zhang, Webb Miller, and David J.
Lipman ({1997}, “Gapped BLAST and PSI-BLAST: a new generation of
protein database search programs™, Nucleic Acids Res. 25:3389-3482.

Reference for composition-based statistics: Alejandro A. Schaffer,
L. Aravind, Thomas L. Madden, Sergei Shavirin, John L. Spouge, Yuri
I. Wolf, Eugene V. Koonin, and Stephen F. Altschul (2861},
"Improving the accuracy of PSI-BLAST protein database searches with
composition-based statistics and other refinements™, Nucleic Acids
Res. 29:2994-3885.

1=

In order, the view shows the following:
* The version of BLAST used in the search (e.g., “BLASTP 2.9.0+").
» References for the BLAST search engine.
* A description of the BLAST database used in the search, including the number of sequences.
» Information about the Query sequence, including its length and the Request ID (RID) number.
* A table of sequences producing significant alignments.

+ Pairwise alignments of each significant match with summary information on the match.

Tasks pertaining to the Text view:
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Task How to...

Make selections in the view See Make a Selection.

Copy all text Right-click anywhere in the view and choose Copy.

Select all text Right-click anywhere in the view and choose Select All.
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Table view

To access the Table view, perform a BLAST search. When the search is complete, the Text, Table and
Pairwise views are displayed together in a single popup window that is separate from the main MegAlign
Pro window. To reopen all three views at a later time, click on the Status link in the Jobs panel.

If no significant matches were identified, the Table view will be empty. An example of a populated Table
view is shown below:

A2>112) - O X
AQR&gE112) v @ 8B 7 BB
| Accession || Description " Score V" E-Value " % Coverage " % |dentity " Map | L]
WP_108997664.1 | hypothetical protein, partial [Esc... | 228 TE-T5 100 100 ]
WP_108993590.1 | hypothetical protein, partial [Kle... | 228 BE-75 100 100 ]

1C70 A Chain A, Deoxy Rhb1.2 (recombi... | 227 1E-72 100 100 ]

1C70 A Chain A, Deoxy Rhb1.2 (recombi... | 227 1E-72 100 100 ]

1ABY A Chain A, Cyanomet Rhb1.1 (Rec... | 227 1E-72 100 100 (|

1ABY A Chain A, Cyanomet Rhb1.1 (Rec... | 227 1E-72 100 100 e
SAI82135.1 TPA: globin C1 [Homo sapiens] | 227 4E-74 100 100 e
WP_109027992.1 | MULTISPECIES: hypothetical pro... | 227 2E-T4 100 100 ]

31A3 B Chain B, A Cis-Proline In Alpha-... | 227 2E-T4 100 100 ] .
ifE Table H B8

H
Columns in the view’s table are described below. Only a subset of these columns will be available,
depending on whether you did a sequence or text search.

Column Description

The NCBI “Accession” number for the match. Press the link to open the corresponding page on

Accession .
the NCBI website.

Description The NCBI “Definition” field text.

The similarity score for the match. (See the NCBI definition for raw score). In general, a higher

Score
score denotes a better match.

E-Value The chance that the match is expected to occur by chance. (See the NCBI definition for E value).
In general, a lower score denotes a better match.
The percentage of the query sequence that aligns to a match in the BLAST database.

%Coverage

° & Example: Query has 596 bases, of which 565 align to a match in the NCBI database.

%Coverage = 565/596 = 95%.
The percentage of bases that match when the query and result sequence are aligned. (NCBI
definition).

%ldentity

Example: Query has 565 bases that align to the match and 3 bases that don’t match. %ldentity
= 562/565 = 99.5%.
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Map Graphic showing areas of agreement between the query and the match.
Length (Entrez search only) The length of the sequence in bp.

Organism  (Entrez search only) The name of the organism.

Tasks pertaining to the Table view:

Task How To...
If a BLAST or Entrez search was performed

Launch the NCBI
page for matching  Click the hyperlink in the table’s Accession column.
database entry

Copy all
information from a  Right-click on the row and choose Copy.
search result row

Save the sequence Right-click on the row and choose Download sequences. In the ensuing Save As
match in .gbk dialog, choose a location in which to save the sequence. By default, the sequence is
format named using its Accession number.

Add sequences or  Use the Add sequences or matches tool (ﬂ)_ Sequences are added back into the
matches host application, not the job’s document.

Filter results from a
sequence or text
search

Use the Filter results tool (T). Learn more about sequence search or text search
filtering.

Export data from Use the Export data tool ( L ), described in the topic Export data from the Text. Table
the view or Pairwise views.

Only if a BLAST search was performed

Click the Save as tool (E ). A save dialog opens and allows you to save the search
results as a .search format file.

To save results

To display a If both the Table and Pairwise views are open, click on the desired row in the Table view
pairwise alignment to see the corresponding pairwise alignment in the Pairwise view. As an alternative,
using a particular open the Pairwise view manually and choose the desired target from the with drop-
search result down menu.
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Panels

Settings panels allow you to optimize the look, contents and layout of the MegAlign Pro window. To learn
what can be done within each panel and the expandable “sections” within each panel, click the links below.

« Style
e Tracks

» Features
* Places
* Details
» Console

The expand bars used to open panel areas have a “hamburger menu” on the right end of the bar.

T Owverview

& Sequence

Hamburger Menu

Description
Command
Available for all expand bars

Collapses all expand bars in the panel except the one whose menu was used to
Collapse Others .
choose this command.
Collapse All Collapses all expand bars in the panel.
Available only for expand bars in the Style panel

Lets you choose and apply a file of custom settings for the section controlled by this

Apply Sequence Style
A ¥ expand bar. See Style panel for more information.

Saves the current settings in the section controlled by this expand bar. See Style

Save Sequence Style i )
panel for more information.

Save Sequence Style Saves the current settings in the section controlled by this expand bar to use as

as Default default settings in future projects. See Style panel for more information.
Restore DNASTAR Restores the default DNASTAR settings for the section controlled by this expand

Default Sequence Style bar. See Style panel for more information.
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Explorer panel

The Explorer panel is used to control which phylogenetic tree is displayed in the Tree view, and allows you
to create additional trees or delete them.

To open the Explorer panel:

Click on the Explorer tab (“2). If the panel is not already visible, reveal it using any of the following
methods:

+ Choose View > Explorer > Explorer or View > Reset Panel Layout.
* Press Ctrl/Cmd+AIt+E.

The only section currently available is the Trees section, which is described separately.
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Trees section

The Trees section of the Explorer panel is used to control which phylogenetic tree is displayed in the Tree
view, and allows you to create additional trees or delete them.

* Note: If you are instead seeking information on the Tree section of the Style panel, click
here.

To open the Trees section, click on the Explorer tab (2); if the Trees section is closed, expand it by
clicking the Trees bar. Alternatively, choose View > Explorer > Explorer or View > Reset Panel Layout.

Prior to performing a multiple alignment, the Trees section is empty. Once an alignment has taken place, the
Trees section contains a table with one row for each phylogenetic tree that has been generated. The table

contains three columns:

() Explorer 52 Ty Style =M Tracks § Places = B
CE e :

Mame Method Status o
Tree 1 R ML In L = -4923.136643

* Name - The default tree generated during multiple alignment is always named Tree. Other trees are
assigned names during the use of the Tree > Compute Phylogeny command.

* Method — The algorithm used to create the tree. The default tree is always created using Neighbor
joining: BIONJ, which is abbreviated to BIONJ. Other trees may use that method or the Maximum
likelihood: RAXML method, which is abbreviated as RAxML.

» Status/Completion — Time the tree took to complete.

To the right of the table are two tools:

Icon Name Purpose
Computes a new To create a new tree and add it to the table. This is a shortcut to the Tree >
(*] phylogeny for the Compute Phylogeny command. See the topic Phylogenetic Trees for
aligned sequences instructions on adding a tree.
K Remove phylogeny To delete a selected tree from the list.
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Style panel

The Style panel has expandable sections with options affecting the Overview, Sequences, Distance and
Tree views, as well as multiple and pairwise alignments.

To open the Style panel:

Click on the Style tab ( 7 Style ). If the panel is not already visible, reveal it using any of the following
methods:

+ Choose View > Style > Style or View > Reset Panel Layout.
* Press Ctrl/Cmd+Alt+Y.
» Right-click on a track and choose Show Style Panel.

* Use Distance > Table > Show Style Panel.

To change settings in the Style panel:

T Style 77 M8 Tracks TP Features § Places = O
Chverview

Sequence

Multiple Alignment |

Pairwise Alignment
Distance

A DA A A A A

Tree

Click the links below to learn about each of the sections in the Style panel:

* Overview section

+ Sequence section

» Multiple Alignment section
» Pairwise Alignment section
+ Distance section

+ Tree section

To save styles and apply them to future projects:

Once you have set up styles, you can save them and then apply them to future projects, either by default or
only when you specify that they be applied. You can choose whether to save and apply styles for just one
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Note that some of the instructions below refer to the “hamburger” menu. To access commands on these
menus, click on the expand bar of interest in the Style panel. Then click on the tool consisting of three

horizontal lines.

T Owverview

& Seqguence

Task

Save all current styles to a file that can be
applied to future projects

Save the styles from one particular view to a file
that can be applied to that view in future projects

Save all current styles to a file that will be
applied as the default for future projects

Save the current styles from one particular view
to a file that will be applied as the default for that
view in future projects

Apply styles that were saved earlier to the
current project

Apply styles that were saved for this view
previously and apply them to the same view in
the current project

Restore all DNASTAR default styles to the
current project

Restore the DNASTAR default style for one
particular view to that view in the current project

Copyright DNASTAR, Inc. 2022

How To

Use View > Document Style > Save Style.

Click the “hamburger” menu on the right of a Style panel
expand bar and choose Save (Expand bar name)
Style.

Use View > Document Style > Save Style as Default.

Click the “hamburger” menu on the right of a Style panel
expand bar and choose Save (Expand bar name)
Style as Default.

Use View > Document Style > Apply Style

Click the “hamburger” menuon the right of a Style panel
expand bar and choose Apply (Expand bar name)
Style.

Use View > Document Style > Restore DNASTAR
Default Style.

Click the “hamburger” menu on the right of a Style panel
expand bar and choose Restore DNASTAR Default
(Expand bar name) Style.
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Overview section

To access options affecting the Overview display, click on the Style panel expand bar entitled Overview, or
choose View > Style > Overview.

i 2 Overview

Alignment layout
Spacing: I

Presentation

Font: | Segoe LI

[ ]Track names font:

Segoe Ul

v[[F E]B1I
® :BI

Multiple block display

Show connecting lines

Reference:

Task

Increase/
decrease the
amount of
vertical space
between
sequence
blocks

Change font
options for the
ruler numbers
in the Overview

Select font
options for
other items in
the Overview
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How to...

Use the Spacing slider. This command does not affect the sizes of the alignment blocks,
but only the amount of white space between them. To make the alignment blocks increase/
decrease in size, instead use the Overview’s zoom in/out.

Use the Font drop-down menu to choose a font for the ruler numbers in the Overview.
Recently selected fonts (if any) appear at the top of the menu, and other available fonts
appear below the row of dashes. Enter the preferred font size by typing a number between

4-72 in the box at right, or by using the corresponding up and down arrows ( .= ). See note
below for additional clarification.

To set a different font for sequence and track labels, first check the box next to Track
names font. If desired, use the corresponding drop-down menu to change the font from the

current value. Enter the preferred font size by typing a number between 4-72 in the box at

(=]
right, or by using the corresponding up and down arrows ( L= ).

p(banner tip). Note: When Track names font is unchecked and tracks are open, Font and

font size (described above) affect everything in the view. When Track names font is
checked and tracks are open, Font and Font size affect only the rulers, while Track names
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font and Track names font size affect sequence labels and track labels.

Display or hide
the lines
connecting
blocks from one
track to another

Check or uncheck the Show connecting lines checkbox. This option is only enabled for
multi-block (Mauve) alignments.

To use one of the aligned sequences as the reference, make a selection from the

Specify the Reference drop-down menu. This option is only enabled for multi-block (Mauve)
reference alignments, and changes the lines that connect the blocks. All blocks for the selected
sequence reference will be placed on the forward strand. Blocks for non-reference sequences can

appear on either strand.

* Note: Once you set up styles, you can save them and apply them to future projects, either
by default or when you specify.
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Sequence section

To access options affecting the Sequences view and Pairwise view, click on the Style panel expand bar
entitled Sequences, or choose View > Style > Sequences.

% Seguence
Presentation

Font: | Segoe U

Case: | Upper

vo BB

S

[ ] Track names font:

Segoe Ul B I
Task How to...
Select
font Use the Font drop-down menu to choose from available fonts. Recently selected fonts (if any)
options  5hhear at the top of the menu, and other available fonts appear below the row of dashes. Enter the
for the preferred font size by typing a number between 4-72 in the box at right, or by using the
ruler
numbers corresponding up and down arrows ( L>! ). To make the font Bold and/or /talic, press the B and/or
in the I buttons, respectively.
view
Specify . S .
the case By default, all sequence letters in the Sequence view initially appear in upper case, regardless of
for all what case is used in the sequence files. To change this, use the Case dropdown menu. Choices
sequence are Upper, Lower or Original case. If you choose Original case, the letters will be shown as they
Iet?ers in appear in the original sequence files. The selection you make here applies to all sequences in the
. MegAlign Pro project, not only to the selected sequence(s).
the view
Select
font First check the box next to Track names font, then use the corresponding drop-down menu to
options change the font from the current value. Enter the preferred font size by typing a number between
for other i i ; ; =
4-72 in the box at right, or by using the corresponding up and down arrows ( - ). To make the
items in 41t Bold and/or /talic, press the B and/or I buttons, respectively.
the view

* Note: Once you set up styles, you can save them and apply them to future projects, either
by default or when you specify.
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Multiple Alignment section

To access options affecting the display of multiple alignments in the Sequences view, click on the Style
panel expand bar entitled Multiple Alignment, or choose View > Style > Multiple Alignment.

= Multiple Alignment
Layout

Linear
Alignment coloring
Colaor all residues

Reference: Consensus

lgnore gaps

[]Solid: A

[]Scheme: |:|Cclc:r by chemistry

[]Solid: »
Scheme: |:|Cclc:r by chemistry

Task How To

Specify the
wrapping style
for rows

Specify how to
color the

sequences and
the consensus

Use the Layout drop-down menu. Choose between:

Linear — All information for a sequence appears on a single row with no line
breaks. A horizontal scrollbar is provided.

Automatic wrapping — The alignment is wrapped to fit within the view. Wrapping
adjusts automatically if the view’s width changes.

Fixed wrapping — The alignment is wrapped at the specified number of
residues. Enter a number in the Size box to wrap after a different number of
residues.

-

Fixed wrapping | Sizee 50 S

Vertical splits are not available in either type of wrapped view. However, any
existing splits are restored if wrapping is turned off.

Use the Alignment coloring drop-down menu to s. Sequence comparisons can only be
performed with aligned sequences. Choose between:

« Color all residues — All residues appear in the color schemes chosen in
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Foreground color (dark ‘T’ icon) and Background color (white ‘T’ icon; see row
below).

* Color only differences from reference — Only residues that differ from the
consensus are colored. If you chose this option, you should select the reference
sequence from the Reference drop-down menu. The reference can be the
consensus or any of the aligned sequences.

» Color only matches to reference — Only residues that are identical to the
consensus are colored. If you chose this option, you should select the reference
sequence from the Reference drop-down menu. The reference can be the
consensus or any of the aligned sequences.

to facilitate

isual + Show only differences from reference — Only residues that differ from the
visua

consensus are displayed and colored. All other residues are shown as uncolored
dashes. If you chose this option, you should select the reference sequence from

the Reference drop-down menu. The reference can be the consensus or any of

the aligned sequences.

comparisons

* Choose either Color only conserved residues or Color only non-conserved
residues to color according to whether or not residues are conserved. A residue
is “conserved” if all sequences have the same residue in that column. Otherwise,
it is “non-conserved.”

* |If you prefer to ignore gaps when determining whether or not a residue is
“conserved,” check the box next to Ignore gaps. The Ignore gaps checkbox is
only enabled if you selected Color only conserved/non-conserved residues

above.
Specify the Use the “foreground color” tools to the right of . To display the letters in a single solid
color of color of your choice, check the upper box. Then click on the ‘A’ tool to the right of the
sequence checkbox and choose a color from the color picker. To instead choose a preset color
characters scheme, check the box next to Scheme and make a selection from the drop-down menu.
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Color by chemistry
Physicchemical: Shapely
Physicchemical: Zappo
Physiocherical: UGene
Spectral colors: Taylor

Clustalx

Grayscale - Percentage |dentity
Percentage |dentity

=RBENEEE]

Hydrophobicity

Color scheme choices are described in Available color schemes.

Specify the
background
color (boxes
around each
letter)

Use the “background color” tools to the right of . To use a single solid color of your
choice, check the box next to Solid. Then click on the ‘highlighter pen’ tool to the right of
the checkbox and choose a color from the color picker. To instead choose a preset color
scheme, check the box next to Scheme and make a selection from the drop-down menu
(see image in row above). Color scheme choices are described in Available color schemes.

* Note: Once you set up styles, you can save them and apply them to future projects, either
by default or when you specify.
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Available color schemes

The Multiple alignment and Pairwise alignment sections allow you to select color schemes for sequences in
the Sequences and Pairwise views, respectively. Each available color scheme is described below:

Color Scheme

Color by
Chemistry

Physiochemical:
Shapely

L Nucleotide . -
Description Amino Acid Legend
Legend
The default color
scheme used by multiple
DNASTAR applications. Aromatic - Phenylalanine (F),
Amino acids are colored Tryptophan (W), Tyrosine (Y)
according to their side
chain chemistry. While
Color by Chemistry can
be used for nucleotide .
sequences too, we Nonpolar (aliphatic) - Alanine (4),
rec.:ommend- instead G e e T e
using a Solid T/u (L), Methionine (M), Proline (P), Valine
background color for
nucleotides and then V) .
selecting a Comparison Polar (neutral) - Cysteine (C),
like Color only non- Asparagine (N), Glutamine (Q), Serine
conserved residues, (S), Threonine (T)
Color only differences
from reference, efc.
Alanine (A)
Arginine (R), Lysine (K)
Matches the RasMol A Aspartate (D), Glutamate (E)
amino acid and RasMol Cysteine (C), Methionine (M)
nucleotide color C Gl'fcine (G)
schemes, which are, in -
E;:{;iifg;]::eb;n ; Isoleucine (I), Leucine (L), Valine (V)

Phenylalanine (F), Tyrosine (Y)

models.”

Tryptophan (W)
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Colors residues
according to their
physico-chemical
properties, and is also
used in JalView
(Waterhouse et al.,
2009).

Physiochemical:
Zappo

Physiochemical: Unipro UGENE coloring
UGene scheme.

Copyright DNASTAR, Inc. 2022
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Aromatic - Phenylalanine (F),
Tryptophan (W), Tyrosine (Y)

Cysteine (C)

Negatively Charged - Aspartate (D),
Glutamate (E)

Positively Charged - Arginine (R),
Histidine (H), Lysine (K)

Positive (KRH)

Large aliphatic hydrophobic (ILM)

Small hydrophobic (5T)
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Taken from Taylor
Spectral Colors: (1997) and also used in
Taylor JalView (Waterhouse et
al., 2009).

Taken from Thompson
et al. (1994). This color

scheme is only available
for protein alignments.

Clustal X

Copyright DNASTAR, Inc. 2022

"
C

N/A

User Guide to MegAlign Pro - 17.3_en

Histidine (H)
Isoleucine (I), Leucine (L)

Hydrophobic (ACFHILMVWY)
» 60% conservatism

| Postively charged (KR)

» 60% conservatism
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Grayscale —
Percentage
Identity

Percentage
Identity

This option uses only
black/white/gray and is
suitable for publications
requiring grayscale
images.

This option uses only

shades of slate blue.
81-100% 81-100%
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Pairwise Alignment section

To access options affecting the display of pairwise alignments in the Pairwise view, click on the Style panel
expand bar entitled Pairwise Alignment, or choose View > Style > Pairwise Alignment.

= Pairwise Alignment =
Layout
Autornatic wrapping W

[ ]Show context

Alignment coloring

Color only differences from reference ~
Reference: |Target (top sequence) o |
(] Solid: A

[]Scheme: |:|Cnlc:r by chemistry - | (@)
Solid: +
[]Scheme: |:|Culc:r by chemistry - (3

Match Bar
Show identity as: Vertical bars -

[] Color background:  Same as uery (7
Task How To

Use the Layout drop-down menu. Choose between:

« Linear — All information for a sequence appears on a single row with no line
breaks. A horizontal scrollbar is provided.

« Automatic wrapping — The alignment is wrapped to fit within the view. Wrapping

Specify the adjusts automatically if the view’s width changes.

wrapping style

e * Fixed wrapping — The alignment is wrapped at the specified number of residues.

Enter a number in the Size box to wrap after a different number of residues.

-

Fixed wrapping | Size: 50 S

Vertical splits are not available in either type of wrapped view. However, any
existing splits are restored if wrapping is turned off.

Visualize Check the Show context box. A local alignment reports the highest scoring contiguous



flanking
segments of
sequences
that are not
within the
aligned
segment

Specify how
to color the
sequences
and the
consensus to
facilitate
visual
comparisons
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segment of alignment between two sequences, even if the full extent of one or both of the
sequences is not included in the final alignment. Local alignments are ideal for finding short
sequences within a larger sequence. When you check Show context, the flanking segments
appear in a dimmer color scheme than the alignment.

As an example, consider a local alignment of a long sequence to a short one. Any positions
that aren’t part of the alignment are considered to be context and are not displayed in the
Pairwise view unless Show context is selected. In the case below, the segment “GGGC” in
on the left of Seq1 is context, as is the trailing “TTAAAA”. The internal part of Seq2 that spans
a gap in Seq1 might be considered unaligned, but is actual context, because it's not internal
to the alignment.

Seq1 GGGC CCC -- TTA TTAAAA
Seq2 ---- CCC C C TTA —————-

Use the Alignment coloring drop-down menu to s. Sequence comparisons can only be
performed with aligned sequences. Choose between:

» Color all residues — All residues appear in the color schemes chosen in
Foreground color (dark ‘T’ icon) and Background color (white ‘T’ icon; see row
below).

» Color only differences from reference — Only residues that differ from the
consensus are colored. If you chose this option, you should select the reference
sequence from the Reference drop-down menu. The reference can be the
consensus or any of the aligned sequences.

+ Color only matches to reference — Only residues that are identical to the
consensus are colored. If you chose this option, you should select the reference
sequence from the Reference drop-down menu. The reference can be the
consensus or any of the aligned sequences.

+ Show only differences from reference — Only residues that differ from the
consensus are displayed and colored. All other residues are shown as uncolored
dashes. If you chose this option, you should select the reference sequence from
the Reference drop-down menu. The reference can be the consensus or any of the
aligned sequences.

* Choose either Color only conserved residues or Color only non-conserved
residues to color according to whether or not residues are conserved. A residue is
“conserved” if all sequences have the same residue in that column. Otherwise, it is

“non-conserved.”

» If you prefer to ignore gaps when determining whether or not a residue is
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“‘conserved,” check the box next to Ignore gaps. The Ignore gaps checkbox is
only enabled if you selected Color only conserved/non-conserved residues
above.

Choose which sequence to use as the “Reference” in the pairwise comparison. Choices are

Reference
Target (top sequence) or Query (bottom sequence).
Use the “foreground color” tools to the right of . To display the letters in a single solid
color of your choice, check the upper box. Then click on the ‘A’ tool to the right of the
checkbox and choose a color from the color picker. To instead choose a preset color scheme,
check the box next to Scheme and make a selection from the drop-down menu.
[ ] Colorbychemistry
Specify the I]II] Ph],rs?uchem?cal: Shapely
Nt |:.:| Ph].rs!u-chem!cal: Zappo
sequence [I] Physiccherical: UGene
characters |:.] Spectral colors: Taylor
[BM] Clustalx
.:l Grayscale - Percentage |dentity
-:l Percentage |dentity
I]]]]"] Hydrophobicity
Color scheme choices are described in Available color schemes.
Specify the Use the “background color” tools to the right of . To use a single solid color of your

background .10 check the box next to Solid. Then click on the ‘highlighter pen’ tool to the right of the
color (boxes .o khox and choose a color from the color picker. To instead choose a preset color scheme,
around each o0k the box next to Scheme and make a selection from the drop-down menu (see image in

letter) row above). Color scheme choices are described in Available color schemes.
Use the Match bar section to customize display of the optional Match bar track. This track is
used to show similarities and differences between the query and target sequences. These
options are mirrored in the Match Bar track options section. Choices made in either location
are instantly reflected in the other location.

Specify the

* To choose how to show the connection between the query and the target, use the
Show identity as drop-down menu. Choosing Residues in target case or
Residues in query case cause the connection to appear as a copy of the residue
from the target or query sequence. Choosing Vertical bars causes the connection
to appear as a symbol, depending on the match status. See the small table below
this one for a description of the options in the Show identity as drop-down menu.

appearance of
the match bar
track

* To add a background color behind each residue, check the Color background

Copyright DNASTAR, Inc. 2022 Page 69 of 329



User Guide to MegAlign Pro - 17.3_en

check box and use the adjacent drop-down menu to choose between Same as
query and Same as target.

Match Bar Symbol Interpretation Weight table value
Vertical line Match 1

Colon Favorable mismatch  (0,1)

Period Neutral mismatch 0

Space Unfavorable mismatch <0

* Note: Once you set up styles, you can save them and apply them to future projects, either
by default or when you specify.
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Distance section

The Distance section affects the appearance of the Distance view. To access this section, click on the Style
panel expand bar entitled Distance, or choose View > Style > Distance.

* Note: In Lasergene 17.1 and earlier, this section was used to specify distance parameters.
Beginning in Lasergene 17.2, these are now set using the Distance > Parameters
command.

= Dhstance =

Distance parameters can be set through the "Distance” menu or view.

Upper right

Values: eldentity W
[“]Heat map: [ | PN
Lower left

Values: Distance ~
[“]Heat map: [ | | [Ny

Presentation

Font: Segoe Ul ~ B I

Decimal places: |2 = |

Task How to...

Use the Values drop-down menu in the Upper right and Lower left sections to choose from:

« Distance — A number between 0 and 1, with 0 being an exact match and 1
indicating no matching bases at all.

* %ldentity — 100% * (Number of identical bases, excluding ambiguous bases) /

Specify which (The number of aligned pairs of bases considered during computation of distance).
statistical

values appear * %Similar — 100% * (Number of matching bases, including ambiguous bases that
in the table may be a possible match) / (The number of aligned pairs of bases considered

during computation of distance).

* %Dissimilar — 100% — %Similar (see above).

* %Gaps — 100% * (Gap count / (Gaps + Length)).
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+ lIdentical — Number of identical bases, excluding ambiguous bases.

« Similar — Number of matching bases, including ambiguous bases that may be a
possible match.

* Dissimilar — Total number of bases — Similar (see above).

* Gap count — Number of aligned positions in the two sequences in which at least
one is a gap.

* Gap length — Length of regions in which at least one of the two sequences has a
gap.

* Length — The number of aligned pairs of bases considered during computation of
distance.

Notes:

* You can alternatively choose the distance metrics to display using the drop-down
menus in the upper left of the Distance view.

« Similarity is measured on aligned pairs of amino acids, with the help of the
BLOSUMG2 substitution matrix. A pair is similar if the substitution matrix has a
positive value for the pair. A positive value in BLOSUM®G62 indicates a more likely
substitution. The substitution matrix chosen for the alignment method, if any, does
not affect the similarity measure in the distance table.

« Statistics are calculated across the entire alignment, regardless of where the
sequences overlap.

« With global gap removal, positions ignored because they’re global gaps are not
considered in the statistics. All and only pairwise gaps are reflected.

Check the Heat map boxes corresponding to the Upper right and/or Lower left sections of
the table.

* To select a color for either end, click on the end of the colored bar corresponding

to a section and make a selection from the color picker.
Add heat map

coloration to

* To flip the direction of the gradient, click on the left of the two corresponding Flip
the table

gradient tools (“%). If the gradient went from white to dark blue, for example, it will
now go from dark blue to white. By default, the gradient progresses linearly from
0-100%.

* To better see lower or higher values, click on the right of the two corresponding
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Flip gradient tools ( ] ) and select Distinguish lower values better or
Distinguish higher values better. To return to a linear progression, choose
Normal.

Use the Font menu to choose between seven available fonts. Recently selected fonts (if any)
appear at the top of the menu, and other available fonts appear below the row of dashes.

(=]
Type a number to the right of Font or use the corresponding up and down arrows ( .= ) to
select a font size. Allowed values = 4 to 72. To make the font Bold and/or /falic, press the B
and/or I buttons, respectively.

Type a number to the right of Decimal places, or use the corresponding up and down arrows

(=]
( =1) to specify the number of decimal places. Allowed values = 1to 7.

* Note: Once you set up styles, you can save them and apply them to future projects, either
by default or when you specify.
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Tree section

To access options affecting the Tree view, click on the Style panel expand bar entitled Tree, or choose View

> Style > Tree.

= Tree
Layout
= S C =

Leaves

Font:

[] Background:

Border Color

Segoe Ul

“* ElBI

Border width:

Branches

Color Iil
Width: 2
Branch label:

Distance e

Decimal places: |E|r

Task

Specify the layout
of the Tree view

Change the font
style used in the
“leaves” of the
Tree view

Specify the font
size used in the
“leaves” of the
Tree view

Change the
background color
for sequence
names in the Tree
view

Add a border

Copyright DNASTAR, Inc. 2022

How to...
Click on any of the four orientations to show the phylogenetic tree with that layout (left,

up, down, right).

Use the Font drop-down menu to choose from available fonts. Recently selected fonts (if
any) appear at the top of the menu, and other available fonts appear below a row of
dashes.

(=]
Type a number to the right of Font or use the corresponding up and down arrows ( .=/ )
to select a font size. Allowed values = 4 to 72. To make the font Bold and/or /talic, press
the B and/or I buttons, respectively.

Check the box to the left of Background, and then click the box to the right to open the
color picker.

The following options are only available if you first check the Background box (see row
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above). To add a border around the sequence names in the Tree view, open the color
picker by clicking the box to the right of Border Color. Specify a width for the border by
typing a number into the Border width text box.

Click the Color box in the Branches section to open the color picker.

=]
Type a number to the right of Width or use the corresponding up and down arrows (.=
to select a font size. Allowed values = 1 to 20.

)

Make a selection from the Branch label drop-down menu. Options include None,
Distance and Name.

Type a number to the right of Decimal places, or use the corresponding up and down

(=]
arrows (=) to specify the number of decimal places for the branch length. Allowed
values are 1-7. This field is only enabled when Show branch length is checked.

* Note: Once you set up styles, you can save them and apply them to future projects, either
by default or when you specify.
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Tracks panel

The Tracks panel lets you manage the tracks displayed in the Overview and the Sequences view.

To open the Tracks panel:

Click on the Tracks tab ( ﬂT“"“"S'). If the panel is not already visible, reveal it using any of the following
methods:

+ Choose View > Tracks > Tracks or View > Reset Panel Layout.

* Press Ctrl/Cmd+Alt+T.

» Right-click on a track in the Overview or Sequences View and choose Show Tracks Panel.

To change settings in the Tracks panel:

éTracks S - O

w [ Owerview header
[] Ruler
w [w] Owverview details
Features
Sequence Ruler
~ [ ] Sequences header or footer
[] Consensus
[] Conzenszus Match
] Ruler 1
[] Ruler2
[] Sequence Logo
w [m] Sequence detail
Features
[] GC Content
[ ] Gap Fraction
Sequence Ruler
] Translation
w [w] Pairwise
Match Bar
Ruler
w [m] Pairwise details
Features
[ ] Gap Fraction
Sequence Ruler
] Translation
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The uppermost part of the Tracks panel lets you specify which tracks are visible, and configure their options
and appearance. Depending whether the project contains DNA/RNA or protein sequences, different sub-
sets of track types will be listed. For instance, in the absence of an alignment, Consensus, Consensus
Match, Sequence Logo and Gap Fraction are hidden from the list. For those tracks that are available,
some will be displayed and other will be hidden, by default. Put check marks next to available tracks that
you wish to display, and remove check marks next to tracks that you wish to hide. Tracks are added to the
views in the same order in which their boxes are checked in the Tracks panel. This means that the position
of a track may change when its box is unchecked and then checked again.

Click the links below to learn about each of the expandable sections in the Tracks panel:
+ Layout

* Options

To see the detail tracks that have been check-marked for display:

Expand one or more sequences in the Overview and/or Sequences view by clicking the relevant plus sign

icon. (")
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Egyoutsecﬁon

To access options affecting the height of a track and the space above and/or below the track, click on the
Tracks panel expand bar entitled “Layout,” or choose View > Tracks > Layout. Changes made in this
section are applied to all currently selected tracks.

A Layout

Consensus Match iej' @

Space before: D
Height: ; D

Space aften D

Task How to...

To control the amount of blank space above and/

Use the Space before/after sliders.
or below each of the selected track(s)

. Use the Height slider. This option is enabled only when all
To control the heights of the selected tracks .
selected tracks support user-scalable height.

To return the sliders in this dialog to their default . .
settings Click the Restore default settings tool (@).
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Options section

To access settings for the track type currently selected in the Tracks panel, click on the Tracks panel
expand bar entitled “Options,” or choose View > Tracks > Options.

The Options section varies in appearance depending upon the selection. For discussions of each track type
and its corresponding Options section, see Tracks.
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Features panel

The Features panel lets you specify which feature types should be visible in the Overview and the
Sequences view once a sequence has been expanded.

To open the Features panel:

. ¥ Features . . . . .
Click on the Features tab ( = ). If the panel is not already visible, reveal it using any of the following

methods:
* Choose View > Features or View > Reset Panel Layout.

* Right-click on a track in the Overview or Sequences view and choose Show Features Panel.

To change settings in the Features panel:

¥ Style | = Tracks | <) Features £3

Type Count
CDhs 9 289 items
gene 9,712 iterns
misc_feature 90 items
misc_RMA 2 items
rRMA 38 itermns
SOUrCE & items
STS 3 items
tRMNA 216 itemns

The Type column shows the feature type. By default, all feature types except Source are checked.

The Count column shows the number of each feature type in the project. It includes all sequences, whether
aligned or unaligned, selected or unselected. The count includes copies of features mapped to the
consensus (e.g., with Features > Map Features to Active Consensus) and other sequences.

Task How to...

To display/hide a particular feature
type

Check/uncheck its box in the Type column.

Right-click anywhere in the Features panel and select Show All or Hide

To display/hide all features all
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Places panel

The Places panel lets you quickly navigate to a sequence location or range that you have visited before.
The following video shows how to bookmark favorite locations using the Places panel:

To open the Places panel:

Click on the Places tab (V I:"3'“35). If the panel is not already visible, reveal it using any of the following
methods:

* Choose View > Places > Places or View > Reset Panel Layout.

* Press Ctrl/Cmd+Alt+P.

To change settings in the Places panel:




User Guide to MegAlign Pro - 17.3_en

Ty Style =8 Tracks TP Features = B

Alcohol dehydrogenase gene
265=282

Click the links below to learn about each of the expandable sections in the Places panel:

* Recent section

« Favorites section
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Favorites section

The Favorites section is similar to the bookmarks folder for a web browser. It contains a list of previously-
visited locations that you have decided you may wish to visit again.

To access the Favorites section:

Click on the Places panel expand bar entitled “Favorites,” or choose View > Places > Favorites.

< Favorites

50
Alcohol dehydrogenase gene
265=282

Y

Entries are nominated for this list from within the Recent section of the Places panel or by chooseing
Sequences > Add Place to Favorites. Favorites are listed in the same order in which they were added, by
default, though you can change the order manually (see table below). The Favorites list is saved whenever

you save a project.

Task

To return to a location in this
section

To move a bookmarked
location further up the
Favorites list

To move a bookmarked
location further down the
Favorites list

To rename a selected item

To remove a selected item

from the Favorites list

To remove all items from the
list

Copyright DNASTAR, Inc. 2022

How to...

Double-click on the item or make a selection from the list and press the Go to
this gene or location button (@).

Make a selection from the list and press the Move this place up arrow (‘i“).

Make a selection from the list and press the Move this place down arrow (&

).

Click on an item in the Favorites section to select it. Then right-click on the
same item and choose Rename Favorite. Type a name into the box and click
OK.

Click on an item in the Favorites section to select it. Then right-click on the
same item and choose Remove Favorite from This List.

Right-click in the Favorites section and select Clear Favorites.
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When you perform a search for a gene or numerical sequence location using Edit > Go To Position, each
found location is automatically stored in the Recent section. Access this section by clicking on the Places
panel expand bar entitled “Recent,” or by choosing View > Places > Recent.

< Recent
284 ]

50 @
300 sy

Recent locations are listed in the same order in which they were added, and the list is saved whenever you

save a project.

Task

To return to a location on the list

To save a location on the list to the
Favorites section (similar to
bookmarking a page on the
Internet)

To remove all items from the
Recent list

Copyright DNASTAR, Inc. 2022

How to...

Double-click on the location name, or make a selection from the list and
press the Go to this gene or location button ( @ )-

Make a selection from the list and press the Add this place to Favorites
button (=1). Alternatively, make a selection from the list, then right-click
on the item and choose Add This Place to Favorites.

Right-click in the Recent section and select Clear Recent.
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Details panel

The Details panel shows details of the application, selection or project.

To open the Details panel:

This panel is represented by a blue “information” icon (o ). If the panel is not already visible, reveal it using
any of the following methods:

* Choose View > Details or View > Reset Panel Layout.

» Right-click on a track in the Overview or Sequences view and choose Show Details Panel.

Interpreting the Details panel display:

) Details &2 = O
AAC41757 @
Organism: Horne sapiens (human)

Description:  alcohol dehydrogenase 1 [Homo sapiens].

Sequence type: Protein
Residues: 375

= Properties

Accession number: AACALTST

Sequence shape: Linear
Sequence version: 1
* Data

Data specification: adhl_human.pro

Data file time: 2/20/13 212 PM

Data file path: C\Users\Public\Documents\DNASTAR\Lasergene 13
Data\Demo Megdlign ProbADH projecthadhl_human.pro

+ Actions

Rename...
Rename with Fields...

Details are available for all tracks in the Overview and Sequences View, as well as the Tracks panel. The
panel shows actions to get started when there is no project open, or when the active project is empty. If
there is a selection, the panel shows details about the selected item(s). Otherwise, the panel shows details
about the project. For detailed information, see the following sub-topics:
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« When no document, or a blank document, is open

* When a non-empty document is open

 When one sequence is selected

 When a portion of a sequence is selected

* When multiple sequences are selected

 When a portion of multiple sequences is selected

« When one track is selected

« When multiple tracks are selected

 When one feature is selected

 When multiple features are selected

« When a portion of a pairwise alignment is selected
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When no document, or a blank document, is
open

When no document or only a blank document (one containing no sequences) is open, the Details panel
displays links to help you get started in MegAlign Pro.

Heading One or more links are available. The first three options are available
for blank documents, but unavailable when no document is open:

Getting Started in MegAlign Pro

_ _ « Create or open a project
Create a new alignment project

Open afile
Import an alignment * Import an alignment

Add sequences
Add sequences end-to-end * Add sequences to the project (or add them end-to-end).

Watch a training video

Watch a training video

Recent Documents

w Recent Documents

RP1 project.msa
ADH Project.msa
Drosophila project.msa

ADH project.msa

Open a recent document.




When a non-empty document is open

If a document is open and contains sequences (whether they have been aligned or not) and nothing is
selected, the Details panel contains the following information:

Heading

* The project filename.
ADH Project.msa

Sequence type: Protein + Sequence type — DNA, RNA, or Protein.

This section is only displayed for, and only pertains to, sequences in the project

. that have already been aligned.
Alignment

« Alignment — Alignment algorithm used (e.g., MAFFT, MUSCLE).
+ Alignment

Alignment: Clustal Omega . .
Sequences: 5 + Sequences — Number of sequences in the alignment.
Sequence type: Protein

Min. sequence length: 348
Max. sequence length: 377

» Sequence type — DNA or protein.

* Min. and Max. sequence lengths — Lengths of the shortest and longest
sequences in the alignment.

This section is only displayed for, and only pertains to, sequences in the project

Unaligned Sequences that are not included in the alignment.

o + Sequences — Number of unaligned sequences.

Sequences: 5
Sequence type: Protein + Sequence type — DNA, RNA, or Protein.
Min. sequence length: 348

Max. sequence length: 377 .
* Min. and Max. sequence lengths — Lengths of the shortest and longest

unaligned sequences.

Actions + Add sequences — Shortcut to File > Add Sequences (see Add
ungapped / gapped sequences to a project).
= Actions
Add sequences « Add sequences end-to-end — Shortcut to File > Add Sequences End-

Add sequences end-to-end

to-end (See Add multi-segment sequences to a project).

Align with options

« Align with options — Shortcut to Align > Align with Options.



When one sequence is selected

If a single sequence has been selected in any view, the Details panel may contain a subset of the following
information:

The default name, if present, appears in blue above
‘Organism.’

* Organism — The organism from which the

Heading

sequence originated, if available.
AACA41757 o o
Organism:  Homo sapiens (human) . Descrlptlo.n - A.descrlptlon of the selected
Description: alcchel dehydrogenase 1 [Homoe sapiens], sequence, if available.
Sequence type: Protein ]
Residues: 375 + Sequence type — DNA, RNA, or Protein.

* Nucleotides/Residues — Number of
nucleotides or residues in the selected
sequence.

+ Accession number — The NCBI accession

Properties number of the selected sequence.

* Properties * Sequence shape — Linear, Circular, or

Accession number:  AAC41757 Unknown.

Sequence shape: Linear

5 ion: 1

Fquence version * Sequence version — The NCBI version

number (the part following the decimal after
the accession number).

Data » Data specification — The name of the
sequence file and the “sequence name within

- Data the file,” followed by the file extension.

Data specification: adhl_hurman.pro

Data file time: 2/20/13 2:12 PM » Data file time — The time the sequence file

Data file

_ was created or modified.
path: Ch\Users\Public\Documents\DMASTARLasergene 13

Data\Demo Meghlign Pro\ADH projecthadhl_human.pro
« Data file path — The path to the original

sequence file on your computer.

Actions
* Rename — Shortcut to Edit > Rename (See
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Rename sequences manually).

 Actions
« Rename with Fields — Shortcut to Edit >

Rename with Fields (See Rename
sequences automatically using specified data
fields).

Rename...
Rename with Fields...
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When a portion of a sequence is selected

When a portion of a sequence has been selected in any view (e.g., by double-clicking on a feature, or by
dragging across the sequence with the mouse) except the Pairwise view, the Details panel contains the

following information:

Heading

Selected Region
Sequence: XM_541769

Alignment selection: (1,538>1 555]

Actions

+ Actions

Copy
Copy as FASTA...

+ Sequence — The name of the sequence from which the region was

selected.This is not shown for pairwise alignment selections.

+ Alignment/Sequence selection — (Pairwise) Alignment selection

displays the inclusive coordinates of the beginning and end of the
selection.

When the sequence is not part of an alignment, (i.e., is listed with
‘unaligned sequences’), then Alignment selection is replaced with
Sequence selection. In this case, the coordinates are the
ungapped sequence coordinates rather than the alignment
coordinates.

Copy — Shortcut to Edit > Copy (See Copy. Paste and Delete).

Copy As FASTA — Shortcut to Edit > Copy As FASTA (See Copy.
Paste and Delete).




When multiple sequences are selected

If two or more sequences have been selected in any view, the Details panel contains the following
information:

Heading
* The number of sequences selected (in blue).

2 sequences .
+ Sequence type — DNA, RNA or Protein.

Sequence type: Protein
Min. sequence length: 348 .
Max. sequence length: 375 * Min. and Max. sequence lengths — Lengths of the shortest and
longest sequences selected, in nucleotides or residues.
Actions
¥ Actions « Rename with Fields — Shortcut to Edit > Rename with Fields (see

Rename with Fields... Rename sequences automatically using specified data fields).




When a portion of multiple sequences is

selected

When a portion of multiple aligned sequences has been selected (e.g., by triple-clicking on a feature, or by
dragging across the consensus sequence with the mouse), the Details panel contains the following

information:

Heading

Selected Region

Sequences: 4

Alignment selection: 2,148>2173

Actions

« Actions

Copy
Copy as FASTA...

Sequences — The number of sequences in the alignment.

Alignment selection — The inclusive coordinates of the beginning
and end of the selection.

Copy — Shortcut to Edit > Copy (see Copy, Paste and Delete).

Copy As FASTA — Shortcut to Edit > Copy As FASTA (see Copy,
Paste and Delete)




When one track is selected

If a single track has been selected in the Overview or Sequences view, the Details panel contains the

following information.

Heading
* Type of track (in blue).
Features
Summary: The Features track displays the pre-alignment * Summary - Basic information about what is
coordinates of each sequence. displayed in the selected track.
Only a subset of links may be available, depending on the
selected track.
* Rename - Shortcut to Edit > Rename (See
P Rename sequences manually).
Acti * Rename with Fields — Shortcut to Edit >
w NS
Rename Rename with Fields (See Rename sequences

Rename with Fields... automatically using specified data fields).
Show track lavout
Show track options

+ Show track layout — Shortcut to View > Tracks
> Layout.

* Show track options — Shortcut to View >
Tracks > Options.

For additional information about using tracks, see Tracks panel and Tracks.




When multiple tracks are selected

If two or more tracks have been selected in the Overview or Sequences view, the Details panel contains the

following information.

Heading
B * Number of tracks currently selected (in blue).
2 tracks &
Summary: Multiple tracks are selected. They can be moved or * Summary — Description of options available
hidden together. for the multiple track selection.
Actions
- Actions » Show tracks panel — Shortcut to View >

Show tracks panel Tracks > Tracks.

For additional information about using tracks, see the topics Tracks panel and Tracks.



When one feature is selected

If a single feature has been selected in a track in the Overview or Sequences view (e.g., by clicking one
time on the feature), the Details panel contains the following information:

. * Feature name (in blue).
Heading

* Type — Feature type.
alcohol DH class I II IV

Type:  Region » Left and Right —The inclusive coordinates of the
Left: 3 L

Right: 375 beginning and end of the feature range.

Length: 373

* Length — Length of the selected feature in nucleotides
or residues.
Location
. Range of the feature in nucleotides or residues.

* Location

3=375
Properties

* Properties

db_xref: taxon:10090 Properties shown vary by feature and may include the

organism:  Mus musculus organism, gene name NCBI feature qualifiers, etc.
chromosome: 3

map: 3

strain: C57BL/ G
Notes

™ Notes + note — The NCBI feature qualifier of the same name.

note: class [ I, IV alcohol dehydrogenases; cd08299

+ Select Subsequence — Shortcut to Edit > Select
Actions Subsequence (see Make Selections). Double-clicking
on the feature fulfills the same function.

+ Actions

EE:EE’C EUEEEGUEHCE | + Select Subsequences Across Alignment — Shortcut
elect Subsequences Across Alignment . .

You can also double- or triple-click on this to Edit > Select Subsequences Across Alignment
feature. (see Make Selections). Triple-clicking on the feature

fulfills the same function. This item is not available for

features in unaligned sequences.
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For additional information about working with features, see Features panel and Features.
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When multiple features are selected

If two or more features have been selected in a track in the Overview or Sequences view, the Details panel

contains the following information:

* Number of features currently selected (in blue).

Heading

3 features * Type — List of all feature types represented in the selection.
Type: Regicn, source, Protein . . . . N
Left: 1 * Left and Right — The inclusive coordinates of the beginning

Right: 374 and end of the feature range.
Min. Length: 368

Max. Length: 374
* Min. and Max. Length — Lengths of the shortest and longest

features in the selection.

Properties

Properties, if shown in this case, will vary by feature and may include the

* Properties . .
organism, gene name NCBI feature qualifiers, etc.

db_xref: taxon: 10090, Genelln15465,
MGLE107619

For additional information about working with features, see Features panel and Features.




When a portion of a pairwise alignment is
selected

When a portion of a sequence has been selected in the Pairwise view (e.g., by double-clicking on a feature,
or by dragging across the sequence with the mouse), the Details panel contains the following information:

Heading
+ Selected Region — (in blue) Unchangeable default value.

Selected Region @
* Pairwise alignment selection — The inclusive coordinates

Pairwise ali t selection: 1955
airwise alignment sefection of the beginning and end of the selection.

Actions
* Copy — Shortcut to Edit > Copy (See Copy, Paste and
. Delete).
« Actions
Copy ]
Comy 35 FASTA... * Copy As FASTA - Shortcut to Edit > Copy As FASTA (See

Copy. Paste and Delete).
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Jobs panel

After initiating an NCBI BLAST or Entrez search, you can monitor its progress and download its eventual
output from the Jobs panel. This panel is not visible in a project until you have started running at least one

search.

To open the Jobs panel:

Do any of the following:

» Click on the Jobs tab.
* Press Ctrl+Alt+J (Win) or Option+Cmd+J (Mac).
 Use View > Jobs or Search > Show Jobs.

@ Details T Style i Models ) Jobs &3 X = 0

" lob Mame || " Status " Started V" Elapsed |
. Test Entrez Search o Done 1:44PM 18s
# | Test Entrez Search o Done 1:12 PM 1m
+— | Test Entrez Search o Done 1:12 PM 19z
' Hemoglobin plus 6 sequences & Done 12:333PM | 3m
+ | A(179=136) W Done 1Z18PM | Tm

The Jobs panel consists of a header and a table with the following columns:

Column Description

Text searches are all named with the field and term of the first search criterion followed by “plus #
Job terms,” where # represents the number of additional criteria. Sequence searches use the name
Name specified in the Job screen of the Search wizard. The same Job Name can be used for more than
one prediction.

A word and icon indicating the status of the search.

Status

Started — Run or Run Job were pressed in the Search wizard
Queued —  — Submitted and placed into the queue

Running — ¥ — Running

Done — ¥ — Job complete; results available

Failed — & — Job failed

Stopped — & — Job stopped by user

Started The date and time the job began.

Elapsed The total elapsed time between starting and completing the job.
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Tasks that pertain to the Jobs panel:

Task

To open the

results of one or

more jobs

To stop one or
more jobs that
are in progress

To delete a
finished job

To open/reopen
the progress
dialog for a job

How To

Click on the Done ( 22n ) or Expiring links for that job. See below this table for more
information on job expiration. You can also open a saved .search file using Search > Open
Search File.

Select one or more rows with a Status of Started, Queued or Running. Then press the

Stop tool ( o ) in the header above the table. Once stopped, a job cannot be restarted
from the Jobs panel. You must instead initiate a new search.

Select one or more rows with a Status of Done, Failed or Stopped. Then press the Delete
tool (?‘:) in the header above the table.

Select one or more rows with a Status of Started, Queued or Running. Then right-click
and choose Open Progress dialog.

Sequence (BLAST) and text (Entrez) search jobs are intended to be ephemeral and expire after 7 days. The
Jobs panel notifies you of upcoming expiration dates.

@ Details T Style & Models 0 Jobs £

N

3
L

lob Mame

Status

Hotspot for 7TTIM (2= 248, 2= 248) o Done

GEKZAZINBISICF plus 5 sequences |8 Expiring at 6/6/19 5:33 PM
Variant for 4HHE (1 position) + | Done

Hemoglobin plus & sequences L. | Expiring at £/6/19 12:33 PM

YL A119=136)

/4 | Expiring at 6/6/19 12:18 PM

All jobs are recorded in the location specified in the Temporary File preferences dialog. If you are a
Macintosh user and elect to keep the default save location, the operating system may remove jobs after a
reboot. To avoid this, we recommend choosing a different location in which to save temporary files.
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Console panel

The Console panel displays information, messages and warnings about the operation in progress, or an
operation that was recently performed.

To display the console for a particular project:

Click the tab with the project name, then open its console using the View > Console command. Each view
will have a different console.

To use the Console panel:

El Console &3 L“Eﬁ|£ ~[f~- =0
Untitled].msa
=== Started MUSCLE at 12:31:35 PM === -

MUSCLE v2.8.31 by Robert C. Edgar

http://www.drives. com/muscle
This software is donated to the public domain.
Please cite: Edgar, R.C. Nucleic Acids Res 32(5), 1792-97.

Muscle-Input 2 seqs, max length 986, avg length 985

a6 :00: 00 5 MB(@%) TIter 1 33.33% K-mer dist pass 1
20:00: 00 5 MB(@%) Iter 1 1@@.80% WK-mer dist pass 1

B0 : 08 : 80 5 MBE(®%) Iter 1 33.33% K-mer dist pass 2 3
80 : 68 : 80 5 MB(8%) Iter 1 108.88% K-mer dist pass 2

|8 aa:es 5 ME(8%) Iter 1 1@8.88% Align node

a0:00:00 18 ME(@H) Iter 1 1@@.008% Align node

20:00: 00 18 ME(8%) TIter 1 58.88% Root alignment

20:00: 00 18 ME(8%) TIter 1 1808.88% Root alignment

B0 : 08 : 80 18 MB(eX) Iter 1 188.88% Root alignment

=== Ended MUSCLE at 12:31:35 PM after ©.283 seconds ===

4 I

Each console has a maximum number of characters. If this maximum is exceeded, the oldest characters
disappear in order to make room for new characters.

Right-click on the Console tab to access commands allowing you to move, hide, rearrange, or restore
panels and views. (See Customize the layout of other window components).

The following tools are available in the upper right of the Console panel:
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Tool Name Description

Clear )
Clears all text from the active Console.
Console

I
x

ﬁ Scroll Stops auto-scrolling caused by alignment output. When alignment output is long, this may
&
— Lock fail due to a limit on the amount of text in the console.
= Word ) .
E Wrap Controls whether or not lines wider than the console panel should be wrapped.
= Pin . . . .
| Keeps the current Console active even if another project is selected.
Console

Display  Consoles can be displayed for one or more open projects. If more than one alignment is in
El ~  Selected progress, clicking the arrow to the right of this icon opens a drop-down menu from which the
Console desired Console can be brought to the front.

v Open Opens a new Console. If more than one alignment is in progress at the same time, you can
Console  open a new Console and pin it to a particular run using Pin Console (above).

Minimize Minimizes the Console.

B Maximize Maximizes the Console.
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Customize the Look and Layout

The following topics describe the many ways you can customize the look and layout of Protean 3D.

Use the Style panel to change the look of a view (font styles and sizes, colors, number of decimal
places, etc.)

* Customize the appearance and layout of views

e Customize the layout of other window components

* Apply information tracks to a view

Once you have customized the look and layout as desired, you can:

» Save Styles for individual views and apply them to other projects

« Save the entire layout and apply it to other projects




Customize the appearance and layout of

views

User Guide to MegAlign Pro - 17.3_en

The following table lists ways in which you can customize the appearance and layout of views.

Task
Show a view

Change the
style (fonts,
colors,
calculation
metrics and
more)

Move one or
more

sequence rows

as a group

Detach a view

Reattach all
detached
views to their
original
locations

Show the
active view in
full-screen
mode

Exit from full-
screen mode

Configure the
number and
location of
visible views.

How to...

Use View > (View Name) > Show.

Use the Style panel and its subsections. Customization for font style and size applies to all

text in a view. Individual rows cannot have different styles.

Sequence rows in some views may be rearranged one at a time or as contiguous groups
using drag and drop. First, select the desired rows using Ctrl/Cmd+click or Shift+click.
Next, drag the selected row(s) to the desired location and release the mouse button. Any

ordering changes made to one view are simultaneously made to the other.

Only certain views can be detached. To do this, right-click on the view tab and choose
Detach (View Name). Detaching a view turns it into a free-floating window. Note that each
detached view has menus in the upper left corner. For example, if you detach a Tree view
and then wish to use commands such as Tree > Root On, you must use the menu in the

detached view rather than the menu in the main MegAlign Pro window.

Use View > Reattach All Views.

Use the View > Full Screen command or the Full screen tool ﬁ at the bottom right

corner of the view, or press Ctrl/Cmd+Shift+F.

Sl b2
Click the Esc key, use the Exit Full Screen tool (#%) at the bottom of the full-screen view, or

press Ctrl/Cmd+Shift+F.

Use the View > Document Layout command or the Change layout tool (image varies) in
the bottom right corner of the view to access possible layouts. The following options are

available:

. One- J One _ 1o show only the current view.
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- Two Horizontal (5] Twe Horizontal ) _ 14 show the current view on top and one
additional view below it.

* Two Vertical ( [ Two Vertical ) — To show the current view on the left, and one
additional view to the right.

« Three Horizontal (&l ThreeHerizontal ) _ 7o show the current view on top and
two additional views below it.

+ Three — Left ([0 Three-Left) _ 1 show the current view on the left and two
additional views stacked one on top of the other on the right.

« Three — Right ( EI] Three-Right ) _ T show the current view on the right and two
additional views stacked one on top of the other on the left.

- Three — Top (3 Three-Top ) _ T show the current view on the top and two
additional views side-by-side on the bottom.

* Three — Bottom ( [ Three- Bottom) _ To show the current view on the bottom
and two additional views side-by-side on the top.

Some views have independent vertical and horizontal zoom in/out sliders. Grab any green
slider with your mouse and drag left/right or up/down to zoom in or out in the view.

%

Zoom in or out
on a view
s
For details, see the table just below this one.
Use Overview > Split View or Analysis > Split View. The split can be moved by dragging it
left or right with the mouse. Alternatively, you can drag the vertical splitter tool (' '), found at
the right edge of the view, in a leftward direction.
- 4 || Overage
Splitaview  EEEG—] 4 [V] Whole Gen
vertically | Celagz
I ” I
[] Sequence Rule
I . 1| | [Drag to add a new column
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When the Analysis view is split vertically, the Overview provides a separate viewport
indicator for each section. Splits are ignored when printing or exporting an image, although
the layout is preserved.

Remove the
right-most
vertical split

Use Overview > Remove Split or Analysis > Remove Split. Or drag the divider as far as
you can to the side of the view and drop it there.

To view two or

more By default, only one document at a time is displayed, even if several documents are open. To
documents view two or more documents simultaneously on a split screen, drag a project tab in a
simultaneously downward, right or left direction. When you see a black arrow, release the mouse button.

on a split Documents can be re-docked in their original positions by reversing this process.

screen

Return to the
default window Choose View > Reset Panel Layout.
display

Three of MegAlign Pro’s views (Sequences, Tree and Overview) all have independent vertical and
horizontal zoom in/out sliders. The following table uses the Sequences view as an example to show the look
of the sequences and some of the detail tracks at different zoom levels.

Track Maximum Zoom Medium Zoom Minimum Zoom

JUI

gcgggtgg

Sequences 9€999t9g
Once the letters disappear, At minimal zoom levels,
only the background color, if sequences are shown as
any, is shown. colored bars with white gaps.

I‘ ‘II‘II‘ II Lowormein to seegraph I
Sequence A A
Logo s(IG Once the logo letters
disappear, only the

background color, if any, is
shown.

Some tracks cannot be
displayed at low zoom levels,
and prompt you to zoom in.

Consensus Loormin to seeqgeaph
Match
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ithdorvin

co o)
Content
Some tracks cannot be
displayed at low zoom levels,
and prompt you to zoom in.
|
Gap :
Fraction L
c « A H R Fy | [NNITTRNARRIN 1
SN B S R T S 11T T [T
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Customize the layout of other window
components

Controls for this application’s view, panels and expand bars are described in the following table. For
information that pertains only to views, also see Customize the appearance and layout of views.

Task

Show or open
a hidden item

Show/Hide
the side
panels

Display panel
sub-sections

Hide panel
sub-sections

Maximize an
item

Change the
relative sizes
of panes

Hide or close
a visible item

Move a view,
panel or
project to
another
location

Scroll
vertically

Scroll
horizontally

Copyright DNASTAR, Inc. 2022

“How To”

Use the associated View menu command, click on a closed expand bar, click on a plus sign,

= H =

==l

or click the Restore icon (

Double-click on the project name to toggle between showing and hiding the side panels on the
right of the window.

Click on a closed expand bar (medium gray bar) or use the associated View menu command.
If you can’t see all the information in an expanded section, close other expanded sections and/

or increase the size of the whole panel as described elsewhere in this table.

Click on an open expand bar.

use the Maximize icon ( iy

Drag the divider bar between them to the left, right, up or down.

Use the Close icon ( & ) or Minimize icon ( = ), click on an open expand bar, or click on a
minus sign. To close one or more tabs, right-click on a project, view or panel tab and choose
Close, Close Others, Close Tabs to Right, or Close All. Some of these options are only
available for certain tabs.

Right-click on the view tab and choose Move (View Name) to (Location). In some cases, you
can use your mouse to grab a project, view or panel tab, then drag and drop it in the desired
location.

Use the vertical scrollbar or the mouse wheel.

Use the horizontal scrollbar, or hold down the Alt key (Win) or Option key (Mac) and drag the
mouse.
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Choose View > Reset Side Panel Layout. This command restores the default layout of
panels, including opening any default panels that have been closed; and restoring panels that
have been minimized or maximized. It will not reattach a detached view. In that case, use
View > Reattach All Views instead.

Return to the
default side
panel layout

Return to the

default layout
for the entire

window

Choose View > Document Layout > Restore DNASTAR Default Layout.
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Save the layout and apply it to other projects

You can change the layout of MegAlign Pro’s views and panels as described in Customize the look and
layout.

Once you have arrived at a layout you like, you can save it and then apply it to future projects, either by
default or only when you specify that it be applied.

Task How To

Save the current layout to a file that can be applied to future .
Use View > Document Layout > Save Layout.

projects
Save the current layout to a file that will be applied as the Use View > Document Layout > Save Layout
default layout for future projects as Default.

Use View > Document Layout > Apply

Apply a layout that was saved earlier to the current project
Layout.

Use View > Document Layout > Restore

Restore the DNASTAR default layout to the current project
DNASTAR Default Layout.



Sequences

You can add the following types of sequences to a MegAlign Pro project:

* Ungapped sequences, including SeqgNinja files

» Gapped sequences

* Multi-segment sequences

* Only the portion of a sequence that corresponds to a feature

« Sequences from a saved MegAlign Pro project

The following video showcases several different ways to add sequences to a MegAlign Pro project:

Once sequences have been added. you can:

» Manually specify sequence type (DNA, RNA, protein)

 Reorder sequences

* Rename sequences manually or automatically, using specified data fields

* Reverse complement sequences

e Trim an individual sequence
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- Remove sequences from a project
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Add ungapped sequences to a project

To add standard (ungapped) sequences, or additional sequences, to an existing project:

You can add standard DNA, RNA or protein sequences from a wide variety of file types, including SegNinja
.star files. (See Advantages of using SegNinja files).

ACG
» Choose File > Add Sequences, select the Add Sequences button ( + ), or press Ctrl/Cmd+E. Then
choose one or more sequences from the file browser.

+ Drag & drop one or more sequence files or folders of sequence files (but not MegAlign Pro .msa
projects) on an open project.

A project can consist of any combination of file types, including single and multi-segment sequences, but all
sequences must be either DNA, RNA or protein.

«¥s Note: Addition of gapped or multi-segment sequences is discussed separately.

The following table shows error messages that you might encounter when adding sequences to a project.

Situation Message and response

i I
e L=

- .

This list includes an alignment decument: H. pylon samples.msa.

Its sequences will be added unaligned.

Adding a Do you want to continue?
MegAlign
Project

(.msa file)

Click OK to add unaligned sequences from the saved project to the current project. This is one
way to remove gaps from sequences so that they can be used in MegAlign Pro.
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Adding a Fa One or more sequences contain gap characters and can't be loaded.
sequence Py
that contains Try loading remaining sequences?
gap
characters
(e.g.,
dashes or
question
marks)
Click OK to add only those sequences without gaps to the project. (There is a separate method
for adding gapped sequences).
Attempting Mixed Segquence Types u
to enter Thi -t tai —ed ty
. A 15 project contains mixed sequence types.
mixed Llé. Any resulting alignments may not be meaningful.
sequence
types (both
protein and [ aK l
nucleotide)
to the b 4
Sequences
View Click OK to add all the sequences to the project. Afterwards, manually remove any sequences
that are not of the desired category.
Initial warning:
Many sequences detected u
A Detected 1000 sequences or more,
Attempting Llé.
to load more Continue loading?
than 1000
sequences
ok || Cancel

After clicking OK, a progress bar is displayed:
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Entering
SeqNinja
projects
(.star) or
FASTA files
with
ambiguous
extensions
(e.g., .fasta)

Attempting
to add a
SeqNinja
project
(.star) that
contains
errors
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x Loading sequences ﬁ

Loaded 201200 sequences.

|_ | — _|

e

[ Cancel

Press OK to continue loading all of the sequences. MegAlign Pro will display a progress bar (see
lower image, left) with a running count of the number of sequences loaded so far. At any point,
you may cancel the entire sample upload by pressing Cancel. This terminates the entering step
without adding the new file(s). Otherwise, simply wait for the samples to finish loading.

e

Seguence type for Untitledl.msa

Please select the default sequence type for Untitledl.msa

| ona || RNA || Protein

MegAlign Pro can usually determine whether the sequence consists of DNA, RNA or protein. If it
cannot, MegAlign Pro will prompt you to specify file type by selecting a button from the dialog.

F

Error adding sequences

Could not add sequences.

[ OK

Click OK. Launch SegNinja, fix any errors in the project and save it before adding the file to
MegAlign Pro.
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Advantages of using SeqNinja files

SegNinja is DNASTAR'’s tool for advanced and batch editing of genome sequences and features. SeqNinja
allows you to convert file formats, batch edit and export features, merge and split sequence data, and
transfer features between genome versions, automating the process of adjusting sequence coordinates
between SeqMan NGen assemblies. The SeqNinja project — which can be created easily using the provided
templates — has the extension “.star,” and uses one or more data files as inputs for its calculations. When
you run the .star program, the output format can be saved in a variety of popular file types, such as FASTA,
GenBank, Lasergene, etc.

While you can certainly add the SegNinja output files to MegAlign Pro, it is also possible to add the .star
project as input. To add either of these, see Add ungapped sequences to a project.

Adding one or more SeqgNinja projects (.star) to a MegAlign Pro project is an indirect way of adding
sequences. Sequences specified by a SeqNinja project file are all those that would be written if the project
were run using SeqgNinja. Using SeqgNinja project files as MegAlign Pro input can save a lot of time and
effort. The advantage of adding a .star project to MegAlign Pro is that it will always call up the most up-to-
date version of the input data for use in making its output. So if you change, add, or delete the input data
that the .star file points to, the .star file will update this information in MegAlign Pro.

The following example demonstrates the advantages of adding a .star file to MegAlign Pro:

Assume you have a directory of genomes for a phylogenetic study. You want to extract a specific gene, or
set of genes, from each genome to build an alignment, and then a phylogenetic tree. Over the course of
your work, new genomes and new versions of existing genomes become available. You want to generate a
current alignment and tree that reflects those additions or changes. Here are three scenarios of the steps
needed to do this:

Good: Without using SegNinja:

1. Manually extract the genes of interest.

2. Generate output files (e.g., FASTA, GenBank, etc.).

3. Add the files to MegAlign Pro.

4. Run the alignment.

5. Repeat Steps 1-4 every time the input data changes.

Better: Using SegNinja output (e.q.. FASTA, GenBank) or a SegNinja project file as MegAlign Pro input:
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1. Create a SeqgNinja program to automatically extract the genes of interest.

2. Run the program and generate output files (e.g., FASTA, GenBank, etc.).

3. Add the output files or the SegNinja project (.star) to MegAlign Pro.

4. Run the alignment.

5. Repeat Steps 2-4 every time the input data changes

Best: Creating a SeqNinja project to use with MegAlign Pro:

For detailed information about creating SeqNinja projects, launch the SegNinja application and select Help
> Help Contents.

When you use a SeqNinja Project (.star) file as input for MegAlign Pro, note that the project is read as a “set
of sequences,” and is not actually executed, meaning no sequence files are written. This type of project has

the following limitation:

Any input files referenced in the program must already exist. In other words, the program should not
reference an input file that doesn’t exist until it is created earlier in the same program. Instead:

+ Replace all the references to the input file with a variable (e.g., $A), or...

* Create a SeqgNinja program to create the necessary files and run the program. Then, in the SeqNinja
program you wish to add to MegAlign Pro, reference those already-created files.
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Add gapped sequences to a project

To import gapped sequences from an existing MegAlign Pro file (.msa):

The following procedures both remove gaps from the sequences and place the updated sequences in the
“Unassembled Sequences” area of the project.

[HH
+ Click on the Add Sequences button ( + ) or select File > Add Sequences and choose the .msa

file.

+ Use File > Open and choose the .msa file. Once the project is open, select all the sequences, then
use Align > Unalign Selected.

* Note : MegAlign Pro uses a dash (-) to represent gaps. MegAlign Pro does accept
sequences where gaps are represented by letters such as “n” or “x.” Sequences with
non-ITUPAC symbols other than dashes may be accepted by MegAlign Pro as input, but may
not be recognized by certain alignment algorithms. Of MegAlign Pro’s methods, MAFFT is

the most tolerant of non-IUPAC symbols.

To import gapped nucleotide sequences from another type of file (not .msa):

When the gapped sequences are not part of a MegAlign Pro file, you can use SeqMan Pro to remove the
gaps. This procedure is safe to use for nucleotide (DNA or RNA) sequences only.

1. Launch DNASTAR SegMan Pro, then drag and drop the gapped sequence file(s) onto the SeqMan
Pro window.

2. Select all sequences in the Unassembled Sequences using Ctrl+A (Win) or Cmd+A (Mac).
3. Use Contig > Export Sequences > Single File.

4. Select either FastA or GenBank Flat File format and choose a file name and location. Make sure that
Include gaps is left unchecked, and then click Save.

The sequence(s) in the newly saved file can now be added in the usual way.

! WARNING: Do not use this method for protein sequences, as all letters that are not also in
the IUPAC nucleic acid code will be lost.
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Add multi-segment sequences to a project

Sequences that consist of more than one chromosome, contig, or fragment are called multi-segment
sequences. By entering a group of sequences into MegAlign Pro using a special command, the entire data
set will be concatenated end-to-end and treated as a single multi-segment sequence.

Suppose you want to string together the consensus sequences from all the contigs in an assembly, or

chromosomes in a genome, or exons in a gene, etc. If you enter these sequences using File > Add
[ACG
Sequences or the corresponding button (&), you will end up aligning the parts to one another. To avoid

this, use the following procedure:

To add sequences end-to-end:

r|'|‘|
Choose File > Add Sequences End-to-end, select the Add sequences end-to-end in project tool ( + )

or press Ctrl/Cmd+Shift+E. The following dialog appears:

" ™

Group name: | Default: Group 1

Add...

Remove

Up

Add another

* To name the group, type a name in the Group name box. This serves as a substitute for a regular
sequence name in all the MegAlign Pro views. If you do not explicitly type a name into the Group
name box, a default name will be computed from the items in the list.

* Note: Like other sequence names, a Group name can be changed later from within the
MegAlign Pro views by right-clicking on it and choosing Rename or Rename with Fields.

+ To add a sequence file to the left-hand pane, click Add. Alternatively, you may simply drag files from
any file explorer & drop them into the main part of the dialog. Any supported MegAlign Pro file type
may be added.
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« Each group of multi-segment sequence should have its segments arranged in the same order relative
to other groups. To reorganize sequences, select a sequence in the left pane and then use the Up or
Down buttons to move it to the desired position.

* Toremove a sequence from the left-hand pane, select it and click Remove.

+ To add another group of sequences after you save the current group, leave the Add another box
checked. Otherwise, remove the check mark.

Click OK to keep your changes and add the sequence group(s) to the project, or Cancel to leave the dialog
without adding the sequence group(s) to the project.

Unless you unchecked the Add another box, a new Add Sequences End-to-end dialog will appear after you
check OK. If you don’t have any additional groups to add, you can exit by pressing Cancel.

To edit an existing end-to-end group:

Select an aligned or unaligned sequence group in any view and choose Edit > Edit Sequences End-to-
end.

If you select an aligned sequence and then apply changes in this dialog, the sequence will be removed from
the alignment and placed in the “Unaligned Sequences” area. Because of this possibility, you must respond
OK to the following prompt before the dialog will open:

F ™
Continue? ﬁ
Editing the selected sequence will rernove it from the alignment. Do you want to
continue?
[ OK ] ’ Cancel
Lo J
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Try it! — Add and align multi-segment
sequences

The following video tutorial describes how to add multi-segment sequences and then align them using the
MUSCLE multiple alignment algorithm.

If you have not yet downloaded and extracted the tutorial data, click here to download it. Then decompress
(unzip) the file archive using the method of your choice.



https://star-deploy.s3.amazonaws.com/SupportingDataFiles/LG16/MegAlign+Pro+Data.zip

Add only the portion of sequence that
corresponds to a feature

This topic describes two methods that allow you to align only the portions of sequences the correspond to a
particular gene or other feature. Other portions of the sequences are discarded or removed prior to
alignment, making the alignment for that gene both faster and more accurate.

If you only need to trim a few sequences, you can do this manually. See Trim an individual sequence for

instructions.

If you need to trim a larger number of sequences, we recommend doing this in SegNinja, a batch file editor
that is included in the same Lasergene package as MegAlign Pro. You can use SeqNinja’s Extract Features
as Sequences template to batch extract the gene features (e.g., CDS, etc.) and save these as a separate
set of sequences. You then add the trimmed sequences to MegAlign Pro and align them. If you are new to
SeqgNinja, Parts A and B of this tutorial show how to batch extract genes from multiple sequence files.



https://www.dnastar.com/manuals/seqninja/topic/extract-features-as-sequences
https://www.dnastar.com/manuals/seqninja/topic/extract-features-as-sequences
https://www.dnastar.com/manuals/seqninja/topic/tutorial-2-extracting-features-as-sequences-and-translating-them

Add sequences from a saved project to an
active project

To add sequences from a saved project to an active project:

Choose File > Add Sequences and select a MegAlign Pro project file (.msa). All sequences in the .msa file
will be added to the “Unaligned Sequences” area of the active project.
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Manually specify sequence type

When you add a sequence to a project, MegAlign Pro uses clues in the sequence file to ascertain whether it
is DNA, RNA or protein. When uncertain, it will prompt you to supply the missing information as you add the
sequences. If MegAlign Pro guesses incorrectly (usually due to ambiguous information in the sequence file)
or you make an erroneous selection, you can change the sequence type at any time using any of the
methods below:

* Choose Edit > Change Source Sequence Type. In the popup, select either DNA, RNA or Protein.

Sequence type for Untitled1l.msa @

| ona || RNA || Proten

+ If sequences in the Sequences view are currently displayed as DNA (there are T's in the sequences),
switch to RNA using Sequences > RNA. All T’s will be replaced by U’s.

» If sequences in the Sequences view are currently displayed as RNA (there are U’s in the sequences),
switch to DNA using Sequences > DNA. All U’s will be replaced by T’s.

In all cases, the sequence type for all sequence in the project will be changed. MegAlign Pro does not
support aligning a mix of DNA, RNA and/or protein sequences.

Copyright DNASTAR, Inc. 2022 Page 125 of 329



Change the order of sequences

To change the order of sequences in views:

Sequences may be rearranged one at a time or as contiguous groups using drag and drop. To move several
sequences as a group, select them with Ctrl/Cmd+click or Shift+click, then drag them to the desired
location and release the mouse button. Any ordering changes made to the Sequences view are
simultaneously made to the Distance view and to the Overview.

To reorder sequences in the other views in the same order as the Tree view:

The Tree view sequences are ordered top-to-bottom in the vertical formats and left-to-right in the horizontal
ones. This means that the order of sequence names shown in the phylogenetic tree may vary from ordering
seen in the Sequences and Distance view and the Overview. To force the other views to reorder their
sequences to agree with the Tree view, use Tree > Order Sequences Like Tree. Alternatively, from the
Tree view, click the Sort sequences tool (1"%) and choose Order Sequences Like Tree.
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Rename sequences manually

To manually rename a selected sequence:

1. Select a single sequence name from any MegAlign Pro view, then right-click on it and choose
Rename. Alternatively, select the sequence name and choose Edit > Rename.

The Choose Label dialog opens with the Display drop-down menu set to Custom label.

i '
Choose Label ESREERT

What label would you like to display in this application for the selected sequence?

Display: ’ Custom label v]

Label: MP_014555

[ Ok ] ’ Cancel ]

2. Type the desired name into the Label text box.

3. Click OK to save changes and exit from the dialog, or Cancel to leave the dialog without saving any

changes.

* Note: When you export data for a renamed sequence, the new name may be exported or
not, depending on the situation. See Retain custom names during export for details.
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Rename sequences automatically using

specified data fields

The following procedure lets you create labels for one or more selected sequences automatically, using

specified fields such as sequence length, organism, or description.

To rename sequences using specified data fields:

1. Select one or more sequence names from any MegAlign Pro view.

2. Right-click on the selection and choose Rename with Fields, or instead choose Edit > Rename with
Fields from the main menu. Making no selection prior to using the main menu command is equivalent

to selecting all sequences.

The Choose Label dialog opens with the Display drop-down menu set to One or more fields.

-
Choose Label

C

=]

What label would you like to display in this application for the selected sequences?

Display: ’Gne or more fields

)

Available fields

Data file name
Diata file path
Data file time
Data specification
Description
Organism
Sequence length
Sequence shape
Sequence type
Sequence version

4=

Display fields in this order

Accessionnumber R dliDefaultname [y

Separator: -

Example: AAC41757

¥

0K

J

Cancel

The left pane shows available fields, and the right pane shows fields that will be displayed as part of
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the sequence name. Initially, Default name is the only field listed in the right pane. An example
showing the appearance of the name using the specified field(s) appears in the Example box at the
bottom of the dialog.

3. Select and organize the fields you wish to display as part of the sequence name:

« To add or remove items, move them between panes using the left and right arrows (% =). Use

the up and down arrows on the right (‘i“"i’) to specify the order in which displayed fields should
appear.

+ By default, a hyphen (-) is included between each of the displayed fields. If desired, type in a
different Separator. Or remove all text in the Separator box to include nothing between the
fields.

* The Example text box shows what the label will look like with the current selections. This text
can be manually edited, if desired.

4. When you are satisfied with the choices made in this dialog, click OK to save changes and exit from
the dialog. Or click Cancel to leave the dialog without saving any changes.

* Note: When you export data for a renamed sequence, the new name may be exported or
not, depending on the situation. See Retain custom names during export for details.
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Reverse complement one or more sequences

To reverse complement one or more sequences:

1. Select one or more sequences in the Overview or Sequences view.

2. Do either of the following:

=
+ Press the Reverse Complement tool (=) in the toolbar.
* Right-click on the selection and choose Reverse Complement.

If the selected sequences were not yet aligned, they will be reverse-complemented and renamed with the
suffix “-rc” to denote the change.

If the selected sequences were part of an existing alignment, the following popup will be displayed.

Confirm Unalign Selected e

Remove sequence(s) from the current alignrent?

If you choose OK, the selected sequences will be removed from the alignment, reverse-complemented and
will have the suffix “-rc” added to them. They will then be placed in the Unaligned sequences area.
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Trim an individual sequence

Individual sequences in the project can be trimmed before or after alignment based on features or by direct
selection. This is different from trimming the entire alignment, which affects all sequences in the project.

To trim an individual sequence before or after performing an alignment:

Select a sequence in the Overview or Sequences view, then do any of the following:

* Press the Trim Sequence tool (Eﬁ) from the toolbar.
* Choose Sequences > Trim Sequence.
» Right-click on the sequence and choose Trim Sequence.

The Trim Sequences dialog opens and the sequence range text boxes are initially populated with the first
and last nucleotides or amino acids.

5" Trim Sequence it

4282 = 3 (2]

catttggcteaaa(aaaaaaaaaaaan Laaaaaaaaaaacc)aaactttccttgg‘ll

P ] I w4208 [1 ' L =420

HRH] HRH] HRH1 HRH1

The following table shows tasks that can be done from within this dialog, or that affect its appearance.

Task How To

To reveal/hide the
sequence, ruler, and any Click the up/down arrows to the right of the range textboxes.
features that are present
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Use the “Left end” and “Right end” boxes to specify the desired range using any of
these methods.

* Type in a position.

» Drag the “wheel” to go to a particular position number or visually-located
text string. (This dialog does not support searching by entering a query

. . sequence).
To specify the desired

range .
» Click any base to center the wheel on that base.

* To select a feature, double-click on it, first on the left and then on the right
of the popup.

+ Use the textboxes to reference a number in relation to the left end (“lend”)
or right end (“rend”) of the sequence. For example, to reference the base
that is 12 from the left end, type in “lend + 12” (without quotes).

To skip to the left or right Click in a range text box, then use the left/right arrows that appear within the box.

ends of the sequence Alternatively, type in “lend” (left end) or “rend” (right end) without quotes.
To view feature Hover above a feature (if any are present) to see information about it, such as its left
information and right coordinates.

To reverse complement

Click the green arrow between the two range textboxes.
the current sub-range

IUPAC ambiguity codes are recognized both in the sequence and in the range boxes. For example, typing
AAS (where S = C or G) into a range box would cause SeqNinja to look for the first instance of AAC or AAG
in the sequence. Conversely, typing AAC into a range box would cause SeqgNinja to look for the first
instance of AAC, as well as any combination of bases and ambiguity codes that would allow for AAC (e.g.,
AAS, WWM, etc.).
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Remove sequences from a project

The following procedure causes the selected sequences to be completely removed from the project, not
simply moved to the “Unaligned Sequences” area.

To remove sequences from the project:

1. Select one or more of the aligned or unaligned sequences in the Overview or Sequences View by
clicking, Ctrl/Cmd+clicking or Shift*+clicking on the sequence name(s).

2. Toremove sequences, either:
. o Right-click on the list of sequence names, and select Remove Sequence(s) from the menu.
o Press the Delete key or use Edit > Delete.
3. Respond to the confirmation message that appears, if any. Different versions of the message appear,

depending whether you have selected aligned and/or unaligned sequences. One example is shown
below.

( Confirm Remove ﬁ\

Remowve the selected sequencels)?
The resulting alignment may not be valid.

| ok || cancel

Notes:

» During multiple alignment, “guide trees” are created that govern the order in which sequences are
aligned to each other, starting with the most similar pair. Guide trees, in turn, are based upon all
possible pairwise relationships among the member sequences.

* When one or more sequences are removed from an alignment, any column containing 100% gaps is
removed from all of the remaining aligned sequences. No new guide tree (representing the remaining
sequences) is calculated. Therefore, the resulting alignment may not be as good as one produced by
performing a completely new alignment with the remaining sequences.

* When features have been mapped to the consensus, removing sequences from the alignment or

unaligning (using Align > Unalign All) will cause all features to be removed from the consensus
sequence. This is because feature mapping may no longer be accurate, since the consensus

Copyright DNASTAR, Inc. 2022 Page 133 of 329



User Guide to MegAlign Pro - 17.3_en

sequence may have different gapping.

Copyright DNASTAR, Inc. 2022 Page 134 of 329



User Guide to MegAlign Pro - 17.3_en

Tracks

“Tracks” are rows of information that can be displayed or hidden, as desired, in the Overview and
Sequences view. Tracks can pertain to a header, footer, or individual sequence row. The following video
provides a brief overview of how tracks are used in MegAlign Pro:

The following tracks can be applied, removed or (in most cases) edited:

* Ruler

» Features

« Consensus

+ Consensus Match
» Sequence Logo

+ GC Content

+ Gap Fraction

* Numeric

+ Pairwise Match Bar
» Translation

The following table shows tasks that affect the display of tracks within the Overview and Sequences views:

Task How to...

Track data can be imported automatically with some types of sequence data (e.g.,
Create tracks Feature tracks), or can be calculated by the application itself (e.g., Ruler and Numeric
tracks).

Display tracks in  To display any type of track, you must check the box next to the name of the track in the
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Tracks panel. This is the only condition needed to view a Ruler track. For any type of

the views i
track other than a Ruler, you must also expand the track as described below.
Do any of the following:
» Click the plus/minus sign to the left of the sequence name ( / ).
Expand/collapse * To expand tracks for selected sequences, choose Sequence > Expand
tracks for selected Sequence Rows or Overview > Expand Overview Rows; or right-click on the
sequences selection and choose Expand.
» To collapse tracks for selected sequences, choose Sequence > Collapse
Sequence Rows or Overview > Collapse Overview Rows; or right-click on
the selection and choose Collapse.
Ensure that no sequences are selected.
* To expand tracks for all sequences, choose Sequence > Expand All Rows or
To expand/

Overview > Expand All Rows; or right-click in the view and choose Expand

collapse tracks for
All.

all sequences in a

particular view
» To collapse tracks for all sequences, choose Sequence > Collapse All Rows

or Overview > Collapse All Rows; or right-click in the view and choose
Collapse All.

Do one of the following:

* To hide a specific track from all views, uncheck the box next to the name of the
track in the Tracks panel.

» To hide a specific track in one view only, right-click on the track within that view
and choose Hide Track. Alternatively, select a track and use Edit > Delete or

R press the Delete key.
» To hide all tracks in one view only, click the minus sign (=) to the left of the
sequence name in that view, or use Analysis > Collapse Sequence Rows or
Overview > Collapse Sequence Rows.
* To hide all tracks in all views, do a combination of the above.
Do either of the following:
Access the

options for a
particular type of
track

* Right-click on a track in either view and choose Show Track Options.

» Click View > Tracks > Options or open the Tracks panel and click the Options
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bar ( ‘m ), then do either of the following to specify the track of interest
by clicking on its name in the Tracks panel.

Open a sequence row to view its track. Then drag a track label (e.g. “Features”) to the
desired position among the other tracks and drop it there. Note that if you turn off some
tracks in the Tracks panel and add them again later, they will appear in the order in which
their boxes were checked.

Change the order
of all tracks in a
view

Hover the mouse over the bottom of the track in the Overview or Sequences view, then
grab the resize bar and drag it up or down.

Increase/decrease GC Content
the vertical height
of a visible track

See how the zoom
level can affect
the appearance of
tracks

See Customize the appearance and layout of views.
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Ruler tracks

To view consensus rulers:

Blue consensus rulers number and tick any gaps found in the consensus. The visibility of consensus rulers
in the Overview, Sequences view and Pairwise view is dependent on:

* Which boxes you check in the Tracks panel (see image below).
o Ruler — Overview header & Pairwise view
o Sequence Ruler — Overview footer
o Ruler 1 — Sequences View header

o Ruler 2 — Sequences View footer

<« Untitledl.msa <« *RP1 projectmsa 3 = B |@ Details T Style =8 Tracks 52
I N :
F 4 Overview header
— T T T T T T T T T T T T T T
Ruler 1 [ j 2,000 4000 6,000 8,000 ‘ [7] Ruler_|
P — _ _ — —____ a Overview details
Chimp = [7] Features
L e LN LA e | Sequence Ruler
Sequence Ruler 2000 4,000 ‘ g

a Sequences header or footer
[7] Consensus

Cow [] Consensus Match
/| Ruler1]
Dog ] RulerEI
[] Sequence Logo
Hurnan Sequence details
« [ Features
[] GC Content
=] Overview ["| Gap Fraction
/| Sequence Ruler|
["] Translation
Ruler1
'#'Chimp cttctgaag
T T

Sequence Ruler !

60
@) Cow cctctgaaggtcagcttccttctcctecgeccagt ggicatcacccagecct
-:::'Dog cttttgaaggtcaaggt---cctcctecgeccac gagtgtcatgcatecct
(&) Human cttctgaaggtcaagttccacccccteocgeoc it t glalgiee t jeale|t Calt feie t
(&) Mouse cttctgaaggtcaagttccttcccctcecg attcaaatatcactcatcct
(&) Rat ctitdtgaalggtEaagtt - - -Eet tigt ccattcaaatgtcactecateccc
LI L B B L B L L L B I\Illllllll|llll|lwll|l‘II
Ruler2 300 310 320 330 340

* Whether or not tracks are visible in a given view. To display tracks, click on the plus sign next to a
sequence in the view of interest.

To view gap-aware sequence rulers:

Unlike the blue consensus rulers described above, black “gap-aware” sequence rulers use pre-alignment
numbering for the sequences. The visibility of sequence rulers in views is dependent on:
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« Which boxes you check in the Tracks panel. Boxes for Sequence Ruler appear in three parts of the
Tracks panel: Overview Details, Sequence Details, and Pairwise Details.

* Whether or not tracks are visible in the views. To display hidden tracks, click on the plus sign next to

a sequence in the view of interest.

* Note: In the Overview, a sequence ruler running from left to right (i.e., larger numbers on
the right), denotes a sequence that has been reverse complemented with respect to its
original orientation. MegAlign Pro does not permit manual reverse-complementing of
sequences, but the Mauve multiple alignment algorithm reverse-complements automatically,
where necessary. In a Mauve multi-block alignment, changing the active block can cause
entire sequences to be reverse-complemented.

To change Ruler options:

Currently, the Ruler tracks do not have editable options. However, you can add white space above and/or
below the ruler using sliders in the Layout section.
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Features tracks

To display sequence features:

The visibility of feature (annotation) tracks in the Overview, Sequences view and Pairwise view is dependent

on:

* Whether or not tracks are visible in those views. To display hidden tracks, click on the plus sign next
to the sequence of interest in the Overview or Sequences view.

* Which boxes you check in the Tracks panel.

Sequence features can be displayed in MegAlign Pro’s graphical views by checking the following boxes in
the Tracks panel:

* Overview details > Sequence features
* Sequence detail > Sequence Features

* Pairwise details > Sequence Features

Note that after performing a multiple alignment, checking the Consensus box will also cause Consensus
features imported with Features > Map Features to Active Consensus to be displayed.

To view a tooltip with details about a feature, hover your mouse over the feature in any view. Alternatively,
select one or more features by clicking on them and then view information about them in the Details panel.

The same default color scheme is used for features in both MegAlign Pro and GenVision Pro.

Feature Type | Color

gene

CDS

RNA orange
repeat ellow
transcription W0 B 10y
all others orange-red

To change Features options:

To learn how to access the options section for this track, see Tracks.
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Rows 2

Specify the number of feature rows to display by typing a number in the Rows box or by using the up/down
arrows. If features are overlapping, this indicates a need to increase the number of rows.

The example below shows three rows of features. The semi-opaque scrollbar to the right allows you to scroll
up/down to see additional features.

L =3

Unaligned Sequences (5]
Rulerl

&) AACA1TST

(£ MP_(114555

) NP_031436
Sequence Ruler

Features

(£ MNP 036126
(&) ADH1_CAEEL

1 10 20 30

mstagkvikckaawv Iw.l-pfs |-1.r.vapp.a-v|
m5|p.t gvify . .
mangqv i aavaw ag plsi
IIII|I IIIII

1 10

Mus musculus

alcohol dehydrogenase class-3

alcohol_DH_class_II

mgtqglvi [ aaiawltgsplci ilvspp
mtvllpstq alvfltwngpllv gvpvpspa

-

ac vl
i1

You can also add white space above and/or below features tracks using sliders in the Layout section.

Click (0] if you wish to return to the default values.
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Consensus track

To display the consensus:

After any type of alignment, a consensus sequence is automatically displayed in the Sequences view
header. To display or hide this consensus sequence, check or uncheck the Consensus box in the Tracks
panel. This box is only visible after performing an alignment.

Consensus characters in upper case denote that the called character comprises > 50% of the total count for
the column. This therefore disqualifies any character that shares the same frequency with another
character.

II a Sequences header or footer
(&) Consensus M- - - - - sTQgkVIKkCKAAVxWExgxPLxIEEIEVxPPKAREVRI
a [7] Censensus Match

AACALTST m---- - stagkvikckaaviwelkkpfsieevevappkahevrikm [7] Ruler1
MNP_014555 m--sipetg------ kgvifyeshgkleykdipvpkpkanellinv [7] Ruler 2

To change Consensus options:

Currently, the Consensus track does not have editable options.

< Options
Consensus @ @

This track does not have options
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Consensus Match track

To display the Consensus Match:

To display or hide the Consensus Match track in the Sequences view footer, perform an alignment and then
check or uncheck the Consensus Match box in the Tracks panel. This box is only visible after performing
an alignment.

How Consensus Match is calculated:

The Consensus Match histogram is calculated by dividing the total score for the called consensus character
by the number of sequences at the position. As agreement increases, the bar height increases and appears
in a lighter shade of green. The histogram is not calculated for positions where there are consensus gaps.
Hover over any bar in the histogram to display an information balloon showing the consensus match
percentage, as demonstrated in the image below.

The following procedure is used to calculate the consensus sequence and the match percent for a given
histogram column:

1. Score the characters in the column - Each occurrence of a non-ambiguous character in the column is
scored as “1” for that character. If the character is an ambiguity code, a fractional count is added to
each of the relevant characters. For example, in a nucleotide sequence, the character R would add “1/
2” to the counts for A and G. Likewise, B would add “1/3” to the counts for C, G, and T.

2. Use the counts to determine the consensus character - If there is a single un-ambiguous character
that is the most frequent, the consensus is called for that character. If there are two or more
characters whose scores are tied for the maximum, the consensus is called as “X” or “n,” for proteins
or nucleic acids, respectively. If there is a two-way tie, and one of the characters is a gap, the non-
gap character will be called.

3. Determine the case of the consensus character - If the count for the called character is > 50% of the
total count for the column, upper case is used. Otherwise, lower case is used.

4. Calculate the consensus match for the histogram; The histogram calculation uses the “maximum
count” value, which will either be the count of the single predominant character (the unambiguous
consensus) or will be the “tied” value that led to the calling of an ambiguity code. The final consensus
match is the total score for the called character divided by the number of sequences at the position.
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Characters in the DNA
alignment column

ACGY

AACCGT

Consensus
call

C

n

To change Consensus Match options:

User Guide to MegAlign Pro - 17.3_en

Results
Consensus match Histogram bar size (as % of total
calculation available height)
1.5/4 38%
2/6 33%

To learn how to access the options section for this track, see Tracks.

i % Options

Consensus Match

Presentation

Color IEI

(VO]

» By default, the Consensus Match histogram is shown in tones of green. To choose another color, click

on the color box to the right of Color.

Click (¢] if you wish to return to the default values.
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Sequence Logo track

To display the Sequence Logo track:

To display or hide the Sequence Logo track in the Sequences view footer, perform an alignment and then
check or uncheck the Sequence Logo box in the Tracks panel. This box is only visible after performing an
alignment.

How Sequence Logo is calculated:

The Sequence Logo is a visualization of the nucleotide or amino acid at a given position, based on a
formula for the Shannon uncertainty measure given by Schneider and Stephens (1990). The height ranges
from 0-2 for nucleotides and 0-4.3 for proteins, and the height of each letter code is proportional to its
frequency. The most common letter code is at the top of each position.The accuracy of this calculation is
proportional to the number of sequences in the alignment, and the track may not be displayed if there are
too few sequences.

To avoid implying conservation in the presence of gaps, the Sequence Logo algorithm adjusts the height of
the letter stack such that the total height of the symbols is multiplied by the fraction (# of residues / (# of
residues + # of gaps)).

Hover over the logo to reveal a tooltip with the information content of each letter at the position.

Teaere]
T

A 0,27 bits
i5: 0.18 bits
C: 0.090 bits

To change Sequence Logo options:

To learn how to access the options section for this track, see Tracks.

2 Cptions

Sequence Logo

Parameters

] Small-sample correction

When there are relatively few sequences without gaps represented at a given position, we recommend
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checking Small sample correction . This correction has no effect when there are sufficient numbers of
sequences to provide a good estimate of information content.

Click [C] if you wish to return to the default values.
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GC Content track

To display the GC Content track:

GC Content is a graph track with a scale from 0-100 showing the proportional amount of G or C residues in
a sliding window of user-defined width.

The visibility of GC Content tracks in the Sequences view is available only for nucleotide (DNA) sequences,
and is dependent on:

* Whether or not tracks are visible in the Sequences view. To display tracks, click on the plus sign next
to the sequence of interest.

* Whether or not the GC Content box is checked in the Tracks panel. This box is only visible for
nucleotide sequences.

To change GC Content options:

To learn how to access the options section for this track, see Tracks.

4.

GC Content % N6
Parameters
Window size: 10 = residues

Presentation

Line coler: | [ N

» Calculations are performed in a sliding window. Type a number in the Window size box to specify the
number of consecutive residues to use in the GC content calculation. The window size may be any
integer from 1-5,000, and the default is 25 residues. The window shifts along sequences one position
at a time, and will therefore overlap for widths greater than 1.

«¥s Note: the GC value at each residue is computed using a window centered over the residue
in the ungapped sequence. An even window width causes the window to be slightly off-
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center. As the window approaches either end of the sequence, one side will stop moving,
and the window will shrink.

» By default, GC Content is shown in tones of blue. To choose another color, click on the color box to
the right of Line color.

Click (4] if you wish to return to the default values.
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Gap Fraction track

To display the Gap Fraction track:

Gap Fraction is a graph track with a scale of 0-1 that shows the proportion of gapped positions in a sliding
window centered on each position.

The availability of a Gap Fraction track in the Sequences view or Pairwise view is available only for aligned
sequences, and is dependent on:

* Whether or not tracks are visible in the views. To display tracks, click on the plus sign next to the
sequence of interest.

» Whether or not the Gap Fraction box is checked in the Tracks panel. This box is only visible after
alignment has taken place.

To change Gap Fraction options:

To learn how to access the options section for this track, see Tracks.

2 Options

Gap Fraction @ @
Parameters
Window size: 7 = residues

Presentation

Line color: Iil

» Calculations are performed in a sliding window. Type a number in the Window size box to specify the
number of consecutive residues to use in the gap fraction calculation. The window size may be any
integer from 1-50,000, and the default is 7 residues. The window shifts along sequences one position
at a time, and will therefore overlap for widths greater than 1.

* Note: The gap fraction value at each position is computed using a window centered over
the position in the gapped sequence. An even window width causes the window to be
slightly off-center. As the window approaches either end of the sequence, one side will stop
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moving, and the window will shrink.

» By default, the Gap Fraction graph is shown in gold. To choose another color, click on the color box to
the right of Line Color.

Click [C] if you wish to return to the default values.
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Numeric tracks

A numeric track displays a plot of values along one or more sequences in the project.

To display numeric tracks:

The visibility of numeric tracks in the Sequences view is dependent on:

» The origin of the project. For example, the Model ‘n’ Ca Distances track is only available for the query
sequence in a project sent to MegAlign Pro using NovaFold’s Send template alignment to MegAlign
Pro link. It is not available for template sequences in those projects, nor for MegAlign Pro projects
that do not originate from NovaFold.

* Whether or not tracks are visible in the Sequences view. To display tracks, click on the plus sign next
to the sequence of interest.

* Whether or not corresponding box is checked in the Tracks panel.

When the track is visible, it consists of a graph. For example, the Model ‘n’ Ca Distances track is a graph
with a y-axis from 0-16. It shows the predicted pairwise distances between Ca atoms in a predicted model
and its theoretical ideal structure. These are calculated by NovaFold using a support vector machine trained
to recognize patterns in template coverage, secondary structure, solvent accessibility, and simulated
structural diversity. A separate track is available for each model. Models tend to be more accurate in regions
with lower distance values.

|_|_-—_|_ R e e — e

To change numeric track options:

To learn how to access the options section for this track, see Tracks.
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Model 1 Ca distances @

Presentation

Graph type: /\ ‘l

Coler: I | /] Background |[ |

Gridlines: ’BDth v] ’Chrer graph v]
[ Smeoeoth: | 50 residues

Y-axis

Range: 0.0 - 156.0

[] Use logarithmic scale | |og?2

» Select from three different Graph types (Line, Skyline, Bar) by clicking on the corresponding icon.

» By default, numeric graphs are displayed in green with a pale yellow background. To choose another
graph color, click on the box to the right of Color to make a selection from a color chart. To choose
another background color, click the color box to the right of the Background checkbox. To turn off the
background color, uncheck the checkbox.

» Use the first Gridlines dropdown menu to select which gridlines to display: Both (horizontal &
vertical), Horizontal (only) or None. Use the second dropdown menu to choose whether gridlines
should be visible above (Over graph) or below (Under graph) other parts of the graph.

» Check the Smooth box if you wish to average the values over a specified number of residues.
Smoothing is computed by averaging values in a sliding window of the specified number of residues.
Enter the number of residues in the adjacent text box (maximum=5000). Inputting a high value will
smooth the graph curves, while a low value will highlight local differences.

* To change the range of values displayed, enter new y-axis endpoints in the Range text boxes. The
default range may be too large or too small for some sections, causing the graph to appear empty or
peaks to be cut off. You may need to raise or lower the second value, in particular, in order to see the
graphical display clearly.

* Check the Use logarithmic scale box and select an option from the corresponding drop-down menu
if you want to use a logarithmic, rather than a linear scale. Options are log2 or log10.

* Note: The log of 0 is not defined. Therefore, log values for the track are calculated as
follows: Fory > 0, y’ = log(y); otherwise, it is displayed as a 0.

Click b if you wish to return to the default values.
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Match Bar track

To display the Match Bar track:

The Match Bar track is used to show similarities and differences between the query and target sequences.
This track is available in the Pairwise view only after performing a pairwise alignment.

aavaweagkplsieeie

aaiawktgsplcieeie

The visibility of this track in the Pairwise view is dependent on:

* Whether or not tracks are visible in the Pairwise view. To display tracks, click on the plus sign next to
the sequence of interest.

+ Whether or not the Match Bar box is checked in the Tracks panel. This box is only visible after
performing a pairwise alignment.

To learn how to access the options section for this track, see Tracks.

%< Cptions
Match Bar g @

Presentation

Show identity as Wertical bars - ]

[] Color background: | Same as query @

» Use the Show identity as drop-down menu to choose how to show the connection between the query
and the target. Choosing Residues in target case or Residues in query case cause the connection
to appear as a copy of the residue from the target or query sequence. Choosing Vertical bars causes
the connection to appear as a symbol, depending on the match status.

Symbol Interpretation Weight table value
Vertical line  Match 1

Colon Favorable mismatch  (0,1)

Period Neutral mismatch 0

Space Unfavorable mismatch <0
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+ To add a background color behind each residue, check the Color background check box and use the
adjacent drop-down menu to choose between Same as query and Same as target.

«¥s Note: These options are mirrored in the Pairwise alignment section of the Style panel.
Choices made in either location are instantly reflected in the other location.

Click (4] if you wish to return to the default values.
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Translation track

To display the Translation track:

Translation tracks in the Sequences view are available only for nucleotide (DNA) sequences, and are

dependent on:

* Whether or not tracks are visible in the Sequences view. To display tracks, click on the plus sign next
to the sequence of interest.

* Whether or not the Translation box is checked in the Tracks panel. This box is only visible for
nucleotide sequences.

Translation track conventions:

« Stop codons are represented by dots.

» For purposes of translation, alignments are assumed to be linear.

« Translations are not displayed for incomplete codons at the right end of the block.

» Translation frames 4-6 are counted from the right end (the 3’ end of the bottom strand).

* In multi-block Mauve alignments, translation is not done across the boundaries of blocks.

l|m|m|4=.|w| m|.-
=
s
Ix
&
—
=

To change Translation options:

To learn how to access the options section for this track, see Tracks.

Copyright DNASTAR, Inc. 2022 Page 155 of 329



User Guide to MegAlign Pro - 17.3_en

|+ Qptions |
Translation Ej' @
Genetic code
| NCBE 1 (Standard Code) -|

a [] All Reading Frames
4 Top Strand
Frame1l
Frame 2

Frame 3
4[] Bottom Strand

[] Frame4
[] Frame5
[] Frame &

Aminec acid display

One-letter code - ] [ Uppercase -

» Use the upper drop-down menu to choose from a variety of NCBI and Lasergene translation codes.
» Put checkmarks next to the reading frames you wish to display, and remove checkmarks from those
you do not wish to display. Click All Reading Frames to show or hide all reading frames. Click Top

Strand or Bottom Strand to show or hide all the reading frames on that strand.

* Use the left-hand drop-down menu to choose between One-letter or Three-letter amino acid
abbreviations.

» Use the right-hand drop-down menu to choose between Uppercase and Lowercase letters.

Click o if you wish to return to the default values.
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Features

MegAlign Pro provides a wizard for copying features from one sequence to another, a procedure known as
“feature mapping.” To learn more about how to map features or remove existing features, see:

* Map features

o Features, Options and Output wizard screens

o Files output after mapping features

o Mapping features in MegAlign Pro vs. SegNinja

« Remove features




Map features (copy features to another
sequence)

MegAlign Pro’s feature mapping lets you map a single annotation or all annotations from a source sequence
to a target sequence. The sequences involved must have been previously aligned. During the process, you
may optionally filter annotations so as to include/exclude specific gene types. Feature mapping is most
commonly used to map desired annotations from a “completely annotated” sequence to a closely-related but

“incompletely annotated” one.

The following video provides a short overview on feature mapping:

To map features from one or more source sequences to a target sequence:

1. In Column 1 of the table below, locate the row that describes the target sequence—the sequence that
will be “receiving” features from one or more other sequences.

2. As directed in Column 2, select one or more features or one or more sequences that will act as the
source(s) for the features.

. o To select an individual feature, open the tracks for the sequence and click on the feature. To
select two or more features, select them using Ctrl+click (Win) or Cmd+click (Mac).

o To select one or more sequences from the Overview or Sequences View, use click, Shift+click,
Ctri+click (Win), or Cmd+click (Mac).

3. As directed in Column 3, use the specified Features menu command, or the corresponding “right-



4.
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click” context menu command.

Column 1: Target
sequence

Active consensus

Sequence in the top
row of the view

Sequence that is higher
on the list than the
source sequences

Sequence that is lower
on the list than the
source sequences

Sequence in the
bottom row of the view

Column 2: Sequence or feature selection

One or more features; or one or more source
sequences. Note that feature segments falling
entirely within a gap will not be copied.

A single feature; or one or more source sequences,
none of which may be the sequence in the top row
of the view.

One or more features; or the target sequence and
one or more source sequences.

One or more features; or the target sequence and
one or more source sequences.

One or more features; or one or more source
sequences, none of which may be the sequence in
the bottom row of the view.

If more than two sequences are selected, the following popup will appear.
Map Features dialog and map all features from the specified source sequences to the target
sequence; or No to abort feature mapping.

Column 3: Command
name

Features > Map (Selected)
Feature(s) to Active
Consensus

Features >) Map
(Selected) Feature(s) to
Top Sequence

Features > Map (Selected)
Feature(s) to Top
Selected Sequence

Features > Map (Selected)
Feature(s) to Bottom
Selected Sequence

Features > Map (Selected)
Feature(s) to Bottom
Sequence

Select Yes to launch the

-
Copy from Multiple Sequences?

=2

More than cne sequence is selected.

Do you want to copy features from multiple sequences?

[ Yes Mo

If you initiate feature-mapping for one or more individual features, MegAlign Pro maps the specific feature(s)
you requested without further input.

When mapping a single feature, or mapping to the consensus, mapping happens automatically, without
launching a wizard. If you initiate feature-mapping in other situations, a wizard may appear. This Map
Features wizard has three screens—Features, Options and Output described in a separate topic. To
navigate between the three wizard screens, either use the Back or Next buttons or click on the screen
name in the left panel of the wizard.
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Things to note when mapping features:

» |tis possible to map multiple copies of features to any sequence, including the consensus. For
example, if you first map a single feature to the consensus, then later map all features from the same
source sequence, the first feature that was added will appear twice on the consensus. Be aware of
this, in case you wish to avoid adding multiple copies of the same feature.

* When mapping features to the consensus in Mauve multi-block alignments, only features within the
active block are mapped. When mapping features to a sequence, features in all the blocks are
mapped.

» The project directory will be organized into sub-directories when 1) there are multiple source

sequences, or 2) any of the source sequences are multiple end-to-end sequences, or 3) the target
includes multiple end-to-end sequences.
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Features screen

The Features screen is the first wizard screen of the Map Features dialog, and allows you to choose the
features you want to include or exclude in the mapping.

* Note: This dialog is optional, and you may click Next, if desired, to skip to the next screen.
However, note that this will cause all features except the source features to be selected. In
order to select all features, it is necessary to change the drop-down menu to All features,
as described below the following image.

Map Features

Features

What features would you like to map?

i Features
& Options Map these features
Output Features except v]

source = | |Filter: = + —

@ v

» Use the upper drop-down menu to elect to map All features, Features matching those you will
specify in the subsequent row(s) of the dialog, or Features except those specified in the subsequent
row(s).

» Use the lower drop-down menu to select the feature type to match (or not match), e.g., gene, CDS,
exon, intron, mRNA, tRNA, promoter, misc_binding, etc. To specify more than one feature type,
use the plus (+) button to add additional “Features” rows. If you want to further limit the search to
features matching (or not matching) particular qualifiers, check the Filter box, then choose a qualifier
(gene, /Iproduct, /locus_tag, /note or /db_xref) from the drop-down menu to its right. In the right-
most textbox, enter the text that the qualifier must match or not match (e.g., /gene = thrL) in order for
the feature to be removed in the output file. You may use wildcards in this box if you wish (e.g., /gene
= thr*).

The image below shows an example of how the screen might look after specifying the desired options:
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Map Features

Features

What features would you like to map?

ue Features
s Options Map these features
Output Features matching v]

site « [J|Filter  /fsite type « = active ==

Click Next to move to the Options screen.
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Options screen

The Options screen is the second wizard screen of the Map Features dialog, and lets you specify mapping
options.

Map Features

Options

Choose desired options.

wy’ Features _
wy’ Options Mapping
Output . =
Minimum feature coverage: 80 | % D

Minimum sequence identity: 80

1
S
=]

Translation

[C] Override genetic code: | MCBL 1 (Standard Code)

Feature report

[[Include specific sequence changes

Unmapped interval report

[T Generate report of intervals without mapped features

Minirmum length of interval to report: | 1

® sk [_New> o

* Mapping — Use the text boxes or sliders to specify percent cutoffs for:

o Minimum feature coverage, where:

portion of feature contained within the aligned interval
feature length

feature coverage = X 100%

o Minimum sequence identity, where:

number of identical aligned residues

sequence identity = X 100%

length of feature in gapped alignment space
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In this calculation, non-common gaps are counted in both source and target sequences.

Feature coverage is less sensitive to insertions and substitutions than is sequence identity. The
default for both Mapping items is 80%.

« Translation — The genetic code specified in this dialog is used for translation, as well as for describing
the type of sequence change in the Map Features Report file (see next bullet point). By default,
MegAlign Pro translates using the genetic code identified in the source data (e.g., the GenBank
/transl_table qualifier), if available; otherwise, it uses the standard genetic code (NCBI:1). To specify a
different code, check Override genetic code and make a selection from the corresponding drop-
down menu. This option does not appear for protein alignments.

» Feature Report — After running the Map Features program, the output is sent to the Map Features
Report file. To add a column to that report containing a SegNinja expression describing the bases in
the mapped feature in terms of the source and target sequences, check the box next to Include
specific sequence changes.

* Unmapped Interval Report — To make a report listing regions that may need further annotation, check
the box next to Generate report of intervals without mapped features. Then use the text box
Minimum length of interval to report to specify a minimum length for a stretch of sequence where

features were not mapped.

Click Next to proceed to the Qutput screen.
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Output screen

The Output screen is the third wizard screen of the Map Features dialog, and lets you specify where to store
reports and logs related to feature mapping.

Map Features

QOutput
Where should the cutput be placed?

w’ Features _
&’ Options Project

i Output Save project in:  C\Usersy,

Project name: Untitledl

@ ——

* In the Save project in box, specify the directory that will contain the project directory. To use a
different directory than the one listed, use the Browse button.

* In the Project name box, type in a name for the project.

The project directory will be created in the specified folder, with the specified name. The project directory

cannot be an existing directory. Therefore, if you decide to repeat the mapping using different options, you
will need to change the project directory before re-running.

Press OK to start feature mapping, or Cancel to leave the dialog. To learn about files output after feature
mapping, click here.
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After running the Map Features step, the output consists of several files.

File Name

PROJECT _map_features _console.txt

PROJECT _map_features_report.tsv

Notes

Copy of the text that appeared for this mapping in the Console side
panel in the MegAlign Pro user interface.

See the text and table below this one for more information.

Report of intervals in the target sequence to which no features were

PROJECT _map_features_unmapped.tsv mapped. Generated only if requested in the Map Features Options

screen under Unmapped Interval Report.

The report.tsv file is a tab-separated report file that can be opened in Notepad++ (freeware) or any
spreadsheet utility. This report file contains a row for each feature that you directed MegAlign Pro to map.
The “Variation” column summarizes the most significant variation of the mapped feature against the source

feature:

Category

Not mapped

Indels

Substitutions

No change

Label in report

Not_mapped

Deleted_end_ 5prime
Deleted_end_3prime

Deleted_end
Deleted_ends

Indel

Insertion

Deletion

No_start
Nonsense
No_stop
Non-synonymous
Synonymous
Substitution

Identical

Copyright DNASTAR, Inc. 2022

Comments

Can occur when the feature doesn’t map at all, or when the feature
maps, but not well enough to pass the mapping thresholds.

[Non-protein sequences] First residue and/or last residue cannot be
mapped with the current settings, or one/both align with a target gap.

Both insertions and deletions have occurred.

An insertion has occurred.

A deletion has occurred.

[CDS only] The initial codon in the mapped feature is not a start codon.
[CDS only] A substitution has resulted in an interior stop codon.

[CDS only] The last codon in the mapped feature is not a stop codon.
[CDS only] Non-synonymous substitution occurred.

[CDS only] Synonymous substitution occurred.

[Non-CDS] A substitution has occurred.
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* Note: If more than one item in the above table applies, the topmost item is reported.
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Mapping features in MegAlign Pro vs.
SeqNinja

The ability to map features exists in both MegAlign Pro and DNASTAR’s SegNinja. Here are some reasons
you might want to map features in one application versus the other:

Use
Task MegAlign Use
gnild SeqNinja
Pro
View the alignment and the mapped features X
Configure alignment options X
Map features in an end-to-end alignment. For instance, to perform a Mauve alignment
X
of end-to-end chromosomes with some rearrangement.
Map VCF features from a .vcffile. X
Map features into a table, then edit the table before generating the resulting sequence
X

or feature file
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Remove features

While features can only be mapped when all sequences involved have been aligned, features can be
removed from a sequence before or after aligning. Feature removal is not reversible, so use caution when
removing features, especially those from non-consensus sequences.

To remove individual features from a sequence or from the consensus:

Click the plus sign to the left of consensus or sequence to reveal the associated Features track. Select one

or more features to remove using Ctrl+click (Win) or Cmd+click (Mac), then right-click on the selection and
choose Remove Selected Feature(s) from the context menu, or Features > Remove Selected Feature(s)

or Edit > Delete from the main menu. You will be asked to confirm feature deletion.

To remove all features from one or more selected sequences:

» For reqular sequences, select one or more sequences using Ctrl+click (Win) or Cmd+click (Mac),
then right-click on the selection and choose Features > Remove Features from Selected
Sequence(s); or right-click on the consensus sequence and choose the same command from the

context menu.

» For the consensus sequence, select it and choose Features > Remove Features from Active
Consensus; or right-click on the consensus sequence and choose the same command from the
context menu.
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Try it! — Map features

Both MegAlign Pro and SegNinja allow you to copy a single annotation, or all annotations from a source
sequence to a target sequence. During the process, you may optionally filter features so as to include or
exclude specific gene types.

In this tutorial, you will experiment with feature mapping using two closely-related Drosophila simulans
sequences: a “source” sequence (.gbk) that contains features and a “target” sequence (.fas) that lacks
features.

Begin with Part A: Add, rename and align sequences.
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Part A: Add, rename and align sequences

Before mapping features in MegAlign Pro, you first need to add and align the sequences.

1. If you have not yet downloaded and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. If a MegAlign Pro project is already open, choose File > New Alignment Project. Otherwise, launch
MegAlign Pro.

[HH
3. Choose File > Add Sequences, or click on the Add sequences to project tool ( s ).
4. Navigate to and open the demo data folder Lasergene ‘x’ Data\Demo MegAlign Pro\Drosophila
project, where ‘X’ denotes the Lasergene version. This folder contains two similar sequences for
Drosophila simulans chromosome X.

5. Use Ctrl+A (Win) or Cmd+A (Mac) to both sequences and click Open.

6. Torename the first sequence, right-click on the sequence name in the Sequences view or Overview
and select Rename. Type in the new Label (see table below) and press OK. Do the same for the

second sequence.

Type Original sequence label New label
Feature source sequence (.gbk) CM002914 D. simulans PRJNA170244 chrX
Target sequence (.fas) gi|62998559|gb|CM00168.1| D. simulans PRJNA12464 chrX

7. If sequences are not already ordered as in the image below, drag one above the other so they are.

LI
Ruler 1
I D sirnulans PRINALT0244 chrx ccagttca
la! I simulans PRINAL2464 chrx ATTCAGCA

8. To align sequences with Mauve using the default parameters, choose Align > Align Using Mauve or

click the Align tool arrow ( @ T ) and choose Align Using Mauve.
9. Use File > Save to save the project with the name Drosophila project.msa.

Proceed to Part B: Map a single feature.
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Part B: Map a single feature

In this part of the tutorial, you will map a single selected feature from the source sequence to the target
sequence. In order to choose the appropriate mapping command, you will need to know where the source
and target sequences appear in relation to one another in the list on the left of the views. If you followed the
steps in Part A, the source sequence should be at the top of the two-member list.

1. To verify this, open the tracks panels by clicking both gray plus signs ( L) ) in the Overview or
Sequences view. If you followed the steps in Part A, the upper sequence should contain features and
the lower sequence should not.

a
(I | L e e e L LA A e e e e e s s e s e

~ Rulerl 56,580 856,590 856,600 836,610 856,620

125 Consensus GTTCATTTCCCTATCCTTCAATGTCCTCGAGATRATTGT
o

= D.simulans PRINA170244 chrX Ega gttcatttccctatccttcaatgtcctcgagataattgt
e {.. ......15....“...20....|....3|ﬂ....|....4|ﬂ..

i Dro... Drosophila simulans
Source sequence with -

features

(Z) D. simulans PRINAL2464 chrX TGTGGCGTA GTTCATTTCCCTATCCTTCAATGTCCTCGAGATCATTGT”I
T

CenueveER el 16,839,530 16,239,520 16,839,510 16,339,500 16,330, 4¢

Target sequence
(currently no features)

2. In the Overview, double-click on any block to make it the focus block.

In the Sequences view, note that the letters (or bars, if zoomed out) with highly-colored backgrounds
denote the active block selected in the previous step. Letters or bars with dull-colored backgrounds
indicate an adjacent, non-focus block. Colored arrows represent features.

PN
| Rulerd 732850 2460 7352470 7352480 7352490 7352500
122 Consensus GCGACTAGTATCGTAGTTGAGCAGGCGCGGTCCGTGCCGCCAGG
S
(2 D. simulans PRINA170... ta-tgat t-t- gcgactagtatcgtagttgagcaggcgecggteccgtgecgeccagyg
Sequence Ruler S B L L L L B
7,352,450 12,460 1,352,470 7,352,480 1,352,490 7,352,500
Features Drosophila simu' = 5 Dsim‘GD16142 -
I -
Dsim\GD16142 Drosophila simulans
I B N
Dsim\GD16142 Dsim‘GD16142
— . < T ., I
©) D. simulans PRINA124.., JI\JI\JI‘»JI‘»H‘»JI‘»JI‘»JI‘»JG&TTI GCGACTAGTATCGTAGTTGAGCAGGCGCGGTCCGTGCCGLECAGG
SequenceRler [ 21U oo | e[t gwino  gwigw

3. Keeping within the active block section, right-click on any feature and choose Map Selected Feature
to Bottom Sequence. Observe that the feature is copied to the corresponding location in the lower
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sequence. Repeat this with other features, if desired. If you don’t see any features, go back to Step 2
and double-click on a different block to make it active.

4. To prepare for the next part of the tutorial, remove the feature(s) you just added to the target
sequence by right-clicking on the lower sequence name and choosing Features > Remove Features
From Selected Sequence. When prompted, click Yes. Observe that the target sequence has
returned to its original state.

Proceed to Part C: Map all features.
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Part C: Map all features

In this part of the tutorial, you will map all features from the source sequence to the target sequence.

1. Right-click on the name of the source (upper) sequence and select Features > Map Features to
Bottom Sequence. The Map Features wizard launches.

2. In the Features screen, use the drop-down menu to select All Features, then press Next.

3. Inthe Options screen, keep the defaults and press Next.

4. In the Output screen, type in the Project name “All features” and use the Browse button to specify
where save the project.

5. Click OK to initiate feature mapping. When mapping is finished, click OK and Close. The output
sequence will be examined later in this tutorial.

6. To prepare for the next part of the tutorial, remove the features you just added to the target sequence
by right-clicking on the lower sequence name and choosing Features > Remove Features From

Selected Sequence. When prompted, click Yes.

Proceed to Part D: Map a filtered set of features.
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Part D: Map a filtered set of features

In this example, you will map only CDS features which have a note containing the letters RB.

1. Right-click on the name of the source (upper) sequence and select Features > Map Features to
Bottom Sequence. The Map Features wizard launches.

2. In the Features screen, select the features you want to include or exclude in the mapping:

a. From the upper drop-down menu, choose Features matching.

b. From the menu just below that, select CDS.

c. To restrict mapping to features that have a note containing the letters “RB”, check the Filter box
and select /note from the drop-down menu to its right. In the text box, type in *RB*. The

asterisk wildcards are used so that any text string containing RB will be included.

d. Click Next.

Map Features

Features

What features would you like to map?

w’ Features
& Options Map these features

Output Features matching - ]

cos « [¥|Filter:  /note * = *F{B*‘I il =

3. In the Options screen, the Mapping sliders and corresponding text boxes are used to specify the
feature coverage and sequence identity thresholds that are required to map a feature. Change both
items to 90% to make mapping extra stringent. Leave other items at their default settings and click
Next.
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Mapping
Minirnum feature coverage: 90 E‘}E

Minirnum sequence identity: 90 E %

D_
D_

4. In the Output screen, type in the Project name “CDS-RB features” and save the project in the same
location as the other output file.

5. Click OK to initiate feature mapping.

Proceed to Part E: Compare output files.
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Part E: Compare output files

1. When the mapping initiated in Part D is finished, click the hyperlink to the output directory.

Files

Mame Folder

CDS-RE features_map_feat... C\Users! WDesktopt CD5-RB features

Show Console ] ’ Ok

2. Open both All features_map_features 1 _report.tsv and CDS-RB features_map_features_1_report.tsv
in any suitable spreadsheet editor.

3. Observe that the output file All features has many more data rows than the file CDS-RB features.
That’s because in the latter case, non-CDS features and features without a note containing the letters

“RB” were omitted from feature mapping.

4. Of the remaining rows, look in the Variation column and see that some features were mapped and
others weren’t. This assignment was based on the %Coverage and %ldentity thresholds.

5. In each spreadsheet, find rows in which the Coverage and %ldentity columns are between 80 and
90%. In which mapping project were these features mapped, and in which were they “Not_mapped”?

6. When you are finished, close both spreadsheets and return to the MegAlign Pro window.

7. Once in MegAlign Pro, click OK and then Close to close the Map Features-related dialogs.

Proceed to Part F: Export the annotated target sequence.
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Part F: Export the annotated target sequence

1. In MegAlign Pro, hover over any target sequence annotation to read the entry. Verify that the sample
entry matches your search criteria by checking the following:

e |s the feature a CDS?

» Does its original note contain the letters “RB”?

Also observe that a new note has been added about the mapping you just performed, including the
accession number of the source sequence and Coverage and Identity statistics.

T T T T I LN B N B ) LI I L] T 17T I LI L | L I LI LI L |_

6,000 8,000 10,000 12,000 14
D=im'GD16490 [

qﬂS:-—:-‘
F
imtG016430 uncharacterized protein, iscform B
CD5 | 71447271, 6276<T7040, 5245<6190

product: uncharacterized protein, isoform B
gene: Dsim' GD16490

gene_synonyrm: dsim_GLEAMR_16699
gene_synonym: GO16490

locus_tag: DsirmwS01_GD16490

protein_id: KMZ07422.1

db_xref: GLA00925405

db_xref: FLYBASEFBpp0312742

db_xref: FLYBASE:FBgn0188103 _
note: GD16490 gene product from transcript GO16490-RE; Dsim\GD16490-PE

note: » > > Mapped from CM002914. Coverage: 100.00%% (1839/1839) Identity: 99.95%; (1838,/1839
odon start: 1

To export the newly-annotated target sequence, select it and choose File > Export Data >
Sequences. To preserve the annotations, select a format that supports them (e.g., .gbk, .meg).

2. Open the exported file in a text editor and observe that the notes about feature mapping have been
preserved.

This is the end of the Map Features tutorial.
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Search

See the following topics to learn how to:

* Move the cursor to a specific position on a sequence or alignment

» Search for or within a sequence using a text query
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Move the cursor to a specific position

To go to a specified position:

Choose Edit > Go To (Pairwise) Position, use Ctrl/Cmd+J.

 If the project contains only aligned or only unaligned sequences, type in a number and click OK.

r Go to Sequence Position ‘ u1

Please enter the sequence position (1-149)

1=

+ If the project contains a mixture of aligned and unaligned sequences, type in a number and use the
drop-down menu to choose whether to go to the position in the aligned or unaligned sequences. Then
click OK.

Please enter the sequence position (1-149)

1

Go te position in ‘aligned SEUENCES v'

] ]
unaligned sequences |
| r 4 1 Cancel

To go to a specific position in a Mauve alignment:

In the Overview, double-click on the desired alignment block to make it active. In the case of a multi-block
sequence, double-click on the block again to move the cursor to the selected position. This centers the
viewport on the left edge of the block and moves the visible range in the Sequences view to the same area.
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Search for or within a sequence using a text
query

MegAlign Pro supports searching for sequences by their name or by any text stored as part of the sequence

(e.g., the description or the name of a feature).

By default, the search tools are hidden. To display them, click on the Search tool ( }1‘)) in the upper right of
most views. This causes the search tools to be displayed on the top left of that view.

Find: | Sequence Mame || | dmup [ |Match case [] Wrap around |:|Allfield5|

1. Use the Find drop-down menu to choose the item to search for. Currently, the only option for any
view is Sequence Name.

2. Start typing a text query into the text box to the right of the drop-down menu. The query should be
some part of the sequence name, part of the sequence description, etc. MegAlign Pro does not
support searching for a string of nucleotides or amino acids. If your query is wider than the search
box, you can hover over the search box to view the entire query.

3. Use the right/left arrows ( o= ) to jump to the next/previous find.

4. (optional) If you wish to limit or expand the search, use the check boxes in the search bar:

* Check Match case to find only exact matches using the same case as the query term.

+ Check Wrap around if you would like to start searching the sequence again from the beginning
or end once you have searched through the sequence using the green arrows.

+ Check All fields if you would like to search for text contained in the sequence file (e.g., in the

description or a feature name). If you only want to search for sequences with the query in the
sequence name, leave this box unchecked.
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Make a Selection

Depending on the view, you can select one or more sequences, any portion of a sequence, or a specific
portion of sequence corresponding to a feature. The active selection is highlighted in light blue. The
selection can then be copied to the clipboard, copied in a specific format, exported to a file, exported to
MegAlign, or realigned using different parameters and/or alignment method. This functionality is useful for
sending a selected sequence or region of sequence to a new alignment project as an unaligned sequence.
In this way, you can create a new document using a subset of the sequences in the current document,
thereby avoiding having to find all of the input files. You can also use the selected region of one or more
sequences to create a new document.

To select... Do this...

Click on the name of any sequence, then use Ctrl/Cmd+A or Edit > Select All.

* In a Mauve alignment, this command extends the selection across
the entire active block.

+ If a portion of sequence or alignment was originally selected, the
All sequences entire sequence or alignment will be selected.

* In the Distance view, this command selects the entire distance
matrix.

+ If a subsequence was selected in one or all aligned sequences prior
to using this command, this action will extend the subsequence
selection to the full sequences.

Multiple sequences Use Ctrl/Cmd+click or Shift+click to select multiple sequences.

Either:

* Click on the sequence name.
One entire sequence . . . .
* Drag the mouse across all residues in a sequence track while holding

down the left mouse button.

« Double-click on a feature that spans the entire sequence.

A portion of all aligned Drag the mouse across residues in the consensus sequence while holding
sequences down the left mouse button.

Drag the mouse across residues in a sequence track while holding down the

A portion of one sequence
left mouse button.
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The portion of a single

sequence associated with a Drag the mouse across the open track while holding down the left mouse
section of track (e.g. a Gap button.

Fraction peak, etc.)

Click on a track to select it. To add additional tracks to the selection, use Ctrl/

One or more tracks . . .
Cmd+click or Shift+click.

One or more features and Click on a feature to select it. To add additional features to the selection, use
corresponding sequence Ctrl/Cmd+click.

To expand a selection consisting of one or more features to a selection
containing just the sequence corresponding to the feature(s), do any of the
following:

. . » Choose Edit > Select Subsequence.
The portion of a single

sequence associated with a

» Click on the feature to select it, then right-click and choose Select
selected feature

Subsequence.

* Double-click on the feature under that sequence.

* In the Details panel, click on the Action Select Subsequence.

To expand a selection consisting of one or more features or subsequence
within a single sequence, to the corresponding subsequences across all

, , aligned sequences or subsequences, either:
The portion of all aligned

sequences associated with a

* Choose Edit > Select Subsequences Across Alignment.
feature

» Triple-click on the feature under any of the sequences in the
alignment.

Additional continuous items,
when the first endpoint has Use Ctrl/Cmd+Shift and click on the other endpoint.
been selected

You can extend the length of an existing selection by Shift+clicking on the

new endpoint. The selection will expand to use the chosen base as the new
endpoint. If there are multiple selected ranges, the one closed to the chosen
base will be expanded.

The current selection, but
expanded to encompass
additional bases

In the Tree view, to select one sequence, click on it. To select multiple
One or more items in the Tree sequences, use Ctrl/Cmd+click. To select all sequences in a branch, click the
view vertical bar for that branch. To select all sequences, click any horizontal bar in
the tree.
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To toggle selection of items on or off, hold down the Ctrl/Cmd key while dragging the mouse, or while

clicking on the items to toggle on or off.
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Search for Sequences Online

This application lets you search National Center for Biotechnology Information (NCBI) databases for
matches to text or sequence that you specify.

* Query part or all of a nucleotide or protein sequence against one of NCBI's sequence databases
using the Basic Alignment Search Tool (BLAST).

* Query text or accession numbers against entries NCBI's Entrez database.

Once a search has been initiated, you can use the Jobs panel to monitor the search, stop an in-progress
search, or open search results in the Text and Table views.

Tools available in the Search wizards:

Some or all of the following optional tools may be available in the bottom left corner of the Search wizards:

-
1. To display the help for this topic, press the question mark icon ( 2 ).

2. To enter an NCBI Access ID, press the Set Access ID ( ) tool. This causes the Access ID dialog
to pop up. See Access ID dialog for information.

3. To submit an idea for a new feature, press the Suggest a feature (@) tool.

d
4. To view information about your service plan, press the Show Service Plan (% ) tool. For sequence
or text search services, the ensuing dialog describes the state of your service plan and any warning or
error text messages. The license control has three states: Active, Expiring, and Expired.
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Search for sequence matches (BLAST)

The BLAST Search wizard is used to search a query sequence against one of NCBI's databases. The
sequence can be part or all of an active sequence, another sequence file on your computer, or typed/
pasted-in text. The wizard consists of four consecutive screens, each described in a separate topic:

* Query screen
» Search screen

» Options screen
* Job screen

To launch the BLAST Search wizard, use one of the following commands or tools. Some commands let you
launch the wizard with the workflow pre-selected and the Search list already pre-populated.

Command, shortcut or tool Description

Search > Sequence Search

Use the “Change search strategy” tool (éﬁ}) from the
Text, Table or Pairwise views

From the Welcome screen, choose Search and then Search for

sequences.
MegAlign Pro - m] P4
File Edit View Align Features Sequences Overview Search Window Help
B wekome 13 < Unttczmss == Launches the wizard at the Query
What do you want to do? &9 Suggest = workflow ; screen.
New Project Search online ?
Open Project @ |T| |T|
Training Search for sequences... | Searchfortextin  Search for textin
NCBI Nucleotide... NCBI Protein...
wnbre
Search > Sequence Search with Selection Launches the wizard at the Query
screen, whose table is pre-populated
Press Ctrl/Cmd+B with the currently-selected portion of

sequence.

Launches the wizard at the Query
Search > Sequence Search with All Sequences screen, whose table is pre-populated
with all sequences in the document.



Search wizard: Query

The Query screen is the first of four screens in the BLAST Search wizard. The Query screen is where you
add the query sequence, i.e., the sequence for which you wish to locate matches in the NCBI BLAST

database.

At the top of the screen, next to “Search with,” select the Nucleotides or Proteins button.

To add one or more query sequence files or a folder of sequences:

Press the Add or Add Folder buttons. In the file explorer, navigate to and select the desired file(s)/folder(s),
and then click Open. If you add a multi-file sequence or multiple sequences, each sequence will appear on

a separate row in the table.

Query

Enter the query sequences to use for your search.

e Query Search with: (_) Nucleotides (®) Proteins

i Search

«/ Options Sequence Range Residues Sequence

v’ Job Al2>112) (1=111) m LSPADKTMVEA...
Hemoglobin (1=141) 141 VLSPADKTNVE...

@K Nedt >

To paste or type in the query sequence:

Press Enter.

Source
Selection
Manual entry

Run

Enter...

Add File...

Add Folder...

Remowve

Cancel
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Enter

Enter sequences in FASTA format

=Hemoglobin (Alpha Chain)
VLSPADKTNVKAAWGKVGAHAGEYGAEAL ERMFLSFPTTK
TYFPHFDLSHGEAQVKGHGKKVADALTNAVAHVDDOMPNAL
SALSDIHAHKLRVDPVYNFKLLEHCLLVTLAAHLPAEFTPA
VHASLDKFLASVETVLTSKYR

Range

[ ]Add another

QK Cancel

In the Enter dialog:

1. Type or paste in the desired sequence following the “dimmed” example in the dialog. A header line is

optional.
2. (optional) If you wish to use only a range of this sequence, specify the Start and End positions.

3. (optional) If you want to add another query sequence after this one, check the Add another box. After
clicking OK to the first sequence, a new Enter dialog will open to add the next query. Otherwise, leave
this box unchecked.

4. Press OK. If you add additional sequences, each sequence will appear on a separate row in the table.

To remove a file that has already been added:

Select the unwanted file from the list and click Remove.

To learn about the optional tools in the bottom left corner of the screen, see the bottom of this topic.
Once you have set up the query sequence(s) as desired, do either of the following:

» To choose the BLAST program to use and database to search, press Next to continue to the Search

screen.

* To run the search directly, press Run.
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» To close the Search wizard without starting a search, press Cancel.
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Search wizard: Search

The Search screen is the second of four screens in the BLAST Search wizard. The Search screen is used to
choose the BLAST program and database.

Search Online — O W

Search

Choose how to search with your 2 protein query sequences.

i Query Search for: () Mucleotides (®) Proteins
" Search
& Options Using: | Similar proteins (blastp) et
w? Job
In: nr w

@ Run Mow

@ @ Q{ < Back Mext = Run Cancel

» Specify whether you wish to search for Nucleotides or Proteins.

» Select the desired BLAST program from the Using drop-down menu. For information on the different
BLAST programs, see the BLAST Program Selection Guide PDF. Available options depend on the
combination of the selections you made in Search with (Query screen) and Search for (this screen).

o If you selected Proteins on both screens, the Using menu contains the unchangeable default
of Similar proteins (blastp).

o If you selected Nucleotides on both screens, Choices are Highly similar sequences
(megablast), Similar nucleotides (blastn), and Similar translated nucleotides (tblastx).

> If you selected Nucleotides in the Query screen and Proteins in the Search screen, the Using
menu contains the unchangeable default of Similar proteins (blastx).

o |If you selected Proteins in the Query screen and Nucleotides in the Search screen, the Using
menu contains the unchangeable default of Similar translated nucleotides (tblastn).

» Select the desired BLAST database from the In drop-down menu. Available choices depend on
whether you selected Nucleotides or Proteins in this screen.
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To learn about the optional tools in the bottom left corner of the screen, see the bottom of this topic.

Once you have made the desired selections, do any of the following:

* To go back to the Query screen, press Back.

* To add additional parameters to the search, press Next to continue to the Options screen.

) ) @ Run Mow
* To start the search immediately, press the Run Now button ( ) or Run button. The Jobs
panel in the application will open and contain information on the status of the search. During the
search, a progress dialog is displayed where you can cancel the search using the Stop button, hide
the dialog using the Hide button, or set up another query using the Settings... button. Use the Jobs
panel to monitor an online search, stop an in-progress search, or open search results in the Text,
Table and Pairwise views.

* To close the Search wizard without starting a search, press Cancel.
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Search wizard: Options

The Options screen is the third of four screens in the BLAST Search wizard, and has two tabs: Selection
and Matches. These tabs allow you to customize miscellaneous parameters relating to the BLAST search.

* Click the Selection tab to make it active.

Search Online — O >

Options

Choose commaon options that apply to all searches,

b’ Cuery Selection | Matches

w Search \5
" Options

w” Job Entrez query: | |

[ Ignore low complexity in query sequence
[]Ignore low complexity during database lookup

] Ignore lower case letters

@' @ Qg < Back Mext = Run Cancel

In the Selection tab:

o

To filter the database you’re searching using a text term, enter a text string in the Entrez query
field.

o To filter low-complexity regions in the query, check the box next to Ignore low complexity in
query sequence. The blastn search program will use DUST for filtering; all other programs will

use SEG.

o To mask the query while producing seeds used to scan database (but not for extensions), check
the box by Ignore low complexity during database lookup.

o To mask any letters that were lower-case in the FASTA input, check the box next to Ignore

lower case letters.

» Click the Matches tab to make it active.

Copyright DNASTAR, Inc. 2022 Page 192 of 329


https://www.ncbi.nlm.nih.gov/books/NBK62051/#Seg

User Guide to MegAlign Pro - 17.3_en

Search Online B - .

Options

Choose common options that apply to all searches,

& Query Selection | Matches

' Search o
' Options
« Job Maximum sequences | 100 V|

Expect threshold | 10 |

Maximum regional matches | 0 |

® @ Q{ < Back Mext = Run Cancel

In the Matches tab:

o Enter a number next to Maximum sequences, the maximum number of aligned sequences to
display. The actual number of alignments may be greater than this number. The default is 100.

o Enter a number beside Expect threshold, the expected number of chance matches in a
random model. The default is 10.

o Enter a number next to Maximum regional matches to limit the number of matches to a query
range. The default is 0.

To learn about the optional tools in the bottom left corner of the screen, see the bottom of this topic.
Once you have made the desired selections, do any of the following:

» To continue filtering, press Next to continue to the Job screen.

] ) @ Run Mow
» To start the search immediately, press the Run Now button ( ) or Run button. The Jobs
panel in the application will open and contain information on the status of the search. During the
search, a progress dialog is displayed where you can cancel the search using the Stop button, hide
the dialog using the Hide button, or set up another query using the Settings... button. Use the Jobs
panel to monitor an online search, stop an in-progress search, or open search results in the Text,
Table and Pairwise views.
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» To close the Search wizard without starting a search, press Cancel.
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Search wizard: Job

The Job screen is the fourth of four screens in the BLAST Search wizard, This screen allows you to
overwrite the default search name with a custom name and initiate the BLAST search.

Search Online — O W

Johb

Search with 2 protein query sequences for proteins using 'blastp’ in 'nr'

v’ Cuery Job Mame: | A(2>112) plus 1 sequence

s’ Search

& Options

w Job By clicking "Run" you are agreeing to the terms of our License Agreement

@ @ Q{ Run Cancel

The text box contains an automatically-generated name for the search job. If you wish, you can overwrite
this default name with a custom name.

To learn about the optional tools in the bottom left corner of the screen, see the bottom of this topic.
After entering a custom job name (or keeping the default name), do either of the following:

» To start the search , press the Run button. The Jobs panel in the application will open and contain
information on the status of the search. During the search, a progress dialog is displayed where you
can cancel the search using the Stop button, hide the dialog using the Hide button, or set up another
query using the Settings... button. Use the Jobs panel to monitor an online search, stop an in-
progress search, or open search results in the Text, Table and Pairwise views.

» To close the Search wizard without starting a search, press Cancel.
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Search for text or accession number matches
(Entrez)

The Entrez Search wizard is used to search a text query or accession number against NCBI's Entrez

databases for nucleotides or proteins.

To launch the Entrez search dialog, choose Search > Text Search in > NCBI Nucleotide or Search > Text
Search in > NCBI Protein. Alternatively, open the Welcome tab, choose Search and then click either
Search for text in... link.

Meghlign Pro - O b
gAalig
File Edit View Align Features Sequences Overview Search Window Help
Welcome &3 |« *Untitled2msa = O 51
£
What do you want to do? 69 Suggest s workdlow | 43
- L
New Project Search online 9

Open Project @ T T

Training Search for sequences... Search for teﬁ in Search for tgxt in
NCBI Nucleotide... MNCBI Protein...

DNASTAR>

The Visual view is displayed by default and is described below.

* Note: The Visual view is only for non-nested queries using the same type of operator (AND,
OR). To perform a more complicated search, press the Text tab near the bottom left corner
and create the search in the Text view.

1. Use the <select> drop-down menu to choose a criterion. The field headings vary depending upon the
online database that you are using. Choosing All fields will cause the application to search every
word of every listing for the query term in the database.
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Text Search - NCBI Nucleotide - o X

Page Mumber
COrganism
Accession
Primary Accession
Gene Mame

Protein Mame
EC/RM Mumber
Substance Mame

Even  JIELR | =
@ (:,T—') q:: | Run | | Cancel |

Once you make a selection, a second drop-down menu and an empty text box appear to the right.

* In the second drop-down menu on the row, choose contains or doesn’t contain (see image
below).

* In the text box, type the text that should be found in any results (in the case of contains) or
should not be found in any results (in the case of doesn’t contain).

2. To add another criterion, press the plus icon (¥). To delete a criterion, press the minus icon (7).
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Text Search - NCBI Nucleotide -

(® Match all of the following () Match any of the following

+ - |Drganism w | |cuntains V| | Alouatta

+ — |Authm w |_Glander

w | contains

contains

doesn't contain

ERR— = e |

@ BEPY

| Run | |

3. Once you have set up all desired criteria, go to the top of the dialog and choose whether to Match all

of the following or Match any of the following criteria.

4. To learn about the optional tools in the bottom left corner of the screen, see the bottom of this topic.

5. Click Run to send the query to the database. To instead exit the dialog without searching, press

Cancel.

During the search, a progress dialog is displayed. Once the search is completed, any matches are displayed

in the Jobs panel.
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Filter sequence search results

When you press the Filter results tool (T) in the header above the Table or Pairwise views, there are two
options: Filter and Clear Filter. Clicking on the Filter option opens the following dialog:

Filter %

@Matchallﬂfthefulluwing OMatchanyﬂfthefulluwing

<celect>
Accession

Description

Score

E-value
% Coverage
% ldenti

» Use the <select> drop-down menu to choose a filter type, then enter the desired options.

Filter type Description Options
Accession The Accession number.

Description The NCBI “Definition” field text.

The similarity score for the match. (See the NCBI definition for raw score). In

Score
general, a higher score denotes a better match.

E-value The chance that the match is expected to occur coincidentally. (See the NCBI
definition for E value). In general, a lower score denotes a better match.
The percentage of the query sequence that aligns to a match in the BLAST

o database.

%o

Coverage

d Example: Query has 596 bases, of which 565 align to a match in the NCBI

database. %Coverage = 565/596 = 95%.
The percentage of bases that match when the query and result sequence are
aligned. (NCBI definition).

% Identity  2'9"e% ( )

Example: Query has 565 bases that align to the match and 3 bases that don’t
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match. %ldentity = 562/565 = 99.5%.

+ To add another filter, press the plus icon (+). To delete a filter row, press the minus icon (7).
* Once you have set up all desired queries, go to the top of the dialog and choose whether to Match all
of the following or Match any of the following queries.
Once you are finished setting up filters, do any of the following:
» To apply the filters, press Apply or Filter.
» To clear all filters and start over, press Clear.

» To exit the dialog without filtering, press Close.
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Filter text search results

When you press the Filter results tool (T) in the header above the Table or Pairwise views, there are two
options: Filter and Clear Filter. Clicking on the Filter option opens the following dialog:

Filter O ¥

(®) Match all of the following () Match any of the following

<select> e

<select>

Accession

Description
Length
Organism

+ Use the <select> drop-down menu to choose a filter type, then enter the desired options.

Filter type Description Options
Accession The Accession number.

Description The NCBI “Definition” field text.

Length The length of the match sequence in bases.

Organism  The species name.

+ To add another filter, press the plus icon (+). To delete a filter row, press the minus icon (7).
* Once you have set up all desired queries, go to the top of the dialog and choose whether to Match all
of the following or Match any of the following queries.
Once you are finished setting up filters, do any of the following:
* To apply the filters, press Apply or Filter.
* To clear all filters and start over, press Clear.

» To exit the dialog without filtering, press Close.

Copyright DNASTAR, Inc. 2022 Page 201 of 329



User Guide to MegAlign Pro - 17.3_en

Access ID dialog

As of December 2018, NCBI requires an API key for faster access to NCBI services, or to run more
searches concurrently. To get a key, start by setting up an NCBI account. After registering your account,
click on your user name and request your key using APl Key Management. Once you have your key, you
can enter it in Lasergene applications to enable NCBI's premium search access.

To add your key to a Lasergene application:

1. Begin an Entrez database search using Search > Text Search in > NCBI Nucleotide or Search >
Text Search in > NCBI Protein.

2. Press the Set Access ID (1) tool in the bottom left corner of the dialog; or, from the Table view,
press the Export data tool and choose Set Access ID. In either case, the Access ID pop up appears.

Access (D =

Enter NCEI API Key
[

@ Forget Ok Cancel

» If an NCBI API key is not already present in the text box, enter your key and press OK.

« If an NCBI API key is present but you no longer use it, press Forget to remove it from the
application’s memory. Then enter the desired key and press OK.

« To exit without saving your changes, press Cancel.
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Choose the Alignment Type

Which is better, multiple or pairwise alignment?
This question is difficult to answer because it very much depends on how the alignment is going to be used.

Mechanistically, the best sequence alignment is the one that produces the fewest number of mismatches.
That metric can be misleading, especially if minimizing the score entails extreme amounts of gapping.
Consider an example where the goal is to identify some particular conserved domains or a large insertion.
Here the placement of gaps outside of the regions of interest may well be of limited concern. Note that with
MegAlign Pro, you can select the interesting regions identified by a multiple alignment and copy them as
subsequences to a new document for further analysis.

Now consider a situation where a multiple sequence alignment is used to represent the actual relatedness
of a group of sequences. Here the alignment is essentially a model, typically of an evolutionary process. In
this case the “best” alignment is the one that is most plausible in the light some biological theory or model.
One way that this visualized, of course, is to use the alignment to make an evolutionary tree.

Ovis aries (sheep)
Tupaia chinensis (Chinese tree shrew)

006
?I— Sorex araneus (European shrew)

Myotis brandtii

02
Mustela puterius furo (domestic ferret)

Condylura cristata (star-nosed mole)

Pan troglodytes (chimpanzee)
Pongo abelii (Sumatran orangutan)

Homo sapiens (human)
Pan paniscus (pygmy chimpanzee)

Mus musculus (house mouse)

Microtus ochrogaster (prairie vole)

Chelonia mydas (green sea turtle)

010
Octodon degus (degu)

ooz — Cavia porcellus (domestic guinea pig)

I_Orcinus orca (killer whale)

Equus caballus (horse)

= Bostaurus (cattle)

Bos grunniens mutus

Bos grunniens mutus

01

When should | use a pairwise alignment?

The answer to this question may seem obvious: use pairwise alignment when you are only interested in two
sequences. Also, sometimes pairwise alignment is simply more suitable than multiple alignment.
Additionally, there are situations where a multiple sequence alignment (MSA) might help identify pairs for
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sequences or sub-sequences that are worth a more detailed, pairwise comparison.

Beyond workflow considerations, there are some fundamental differences between the two categories of
alignment that might make pairwise alignment a better option for some sequence comparisons. Due to the
nature of progressive multiple aligners (including Clustal, MUSCLE and MAFFT), the final sequence
alignment can contain inappropriately placed gaps, which adversely affect the interpretation of the results.
To understand this, consider how progressive multiple alignments work. The process invariably begins with
a single pairwise alignment, adding gaps as necessary in order to minimize the number of mismatches. As
the aligner proceeds, additional gaps are added as single sequences and groups of sequences aligned
during an earlier stage of the process are included in the growing multiple sequence alignment. During this
phase, gaps may be added but are never removed.

This “once a gap, always a gap” approach is a potential drawback that is shared by all progressive multiple
alignment algorithms. The heart of the problem is that gap placement (and therefore the alignment) might be
affected by the order in which sequences are aligned to each other because sequences added later in the
process might be incorrectly aligned. All of the multiple alignment engines used by MegAlign Pro use a
“guide tree” based on pairwise similarities of sequences to determine the order in which to align sequences.
The first pair chosen consists of the two that are least distant on the guide tree. If the nearest neighbor to
this pair is more distant than some other pair are to each other, that pair gets aligned to each other. If not,
the neighbor is aligned with the first pair and gaps are added as necessary. In later rounds there may be no
singleton sequences left, just clusters of two or more sequences that got aligned. Imagine a case where one
of a group of early aligned sequences should have been added later, or where a close relative was added
too late. It's hard to know when this has happened unless you have some a priori information, such as
knowledge of the evolutionary relationship of your group of sequences.

The bottom line is that when you examine just a pair from a multiple sequence alignment you may not see

the same results as a pairwise alignment of just the two. So the direct approach under these circumstances
might give a better picture of the relatedness of the pair.
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Perform a Multiple Alignment

MegAlign Pro supports the following multiple alignment methods: Clustal Omega, Clustal W, MAFFT,
MUSCLE and Mauve. Click here for descriptions and a comparison of the different methods.

To learn how to perform, modify, and troubleshoot multiple alignments, see the following topics:

e Perform an initial multiple alignment
« Multiple alignment methods and options

* Modify a multiple alignment
* Unalign aligned sequences

Multiple alignment tutorials:

The following tutorials all use free data that can be downloaded from the DNASTAR website.

e Try it! — Perform a Clustal Omega alignment
e Tryit!l — Perform a MUSCLE alignment with multi-segment sequences
e Try it! — Perform a genomic alignment with Mauve

The following video is a quick introduction to performing multiple alignments in MegAlign Pro:
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Perform an initial multiple alignment

To perform the initial multiple sequence alignment:

1. Select two or more sequences to align. All sequences must belong to the same category (DNA/RNA
or protein). Selected sequences can include any combination of already-aligned sequences and
sequences in the “Unaligned Sequences” area. Both types are visible in the Overview (see image)
and Sequences view.

U rrrrrrrryrrrrprrrrrrrr[rrrr[rrrrJ[r1
Ruler 1,000 2,000 3,000
NM_008285
B Aligned
XM_541760
- seguences
NM_001042731
1 | m | 3
Ii Unaligned Sequences (2] |
) N
T T T T 17T TT I L L I T T T T1TT1T7 T | rrr 1 1 r—T-T11
Ruler U 1,000 2,000 .
Unaligned
NIM_001114165 i . sequences

MM_0010958212 i

2. Hover the mouse over the Align/Realign tool (@) to view a tool tip showing the currently-selected
algorithm.

Q-

lori pm_q Align using Mauve ]

3. Choose the desired multiple alignment method and perform the alignment.

. > |If the method and options are compatible with the current sequence type, and you want to use
it, press the Align/Realign tool. In general, we recommend using Mauve for genome scale
alignments and the other alignment methods for gene-level alignments. Since Mauve works by
initially breaking alignment projects into a series of smaller sub-alignments, we also suggest
using Mauve if there is insufficient memory to align sequences with the other methods, or if
another type of alignment is taking an excessive amount of time to complete.

o To choose a different method, click on the small black arrow to the right of the Align tool to
choose from available methods. Or use the main menu to choose Align > Align Using (Method
Name). If the sequences have already been aligned, note that the menu command names
change to Align > Realign Using (Method Name).

o To choose a different method and/or change method options before aligning sequences, click
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on the small black arrow to the right of the Align tool and choose Align with Options; or select
Align > Align with Options from the main menu. For a detailed description of the Alignment
Options dialog for different methods, see Clustal Omega, Clustal W, MAFFT, MUSCLE or
Mauve alignment options.

Except in the case of divergent sequences (see note, below), we recommend using the DNASTAR
default settings the first time you perform a multiple sequence alignment. Later, you may wish modify
some of the Alignment Options before realigning the sequences. After you customize options in the
Alignment Options dialog and perform an alignment using the new settings, they become the new
defaults, but only for this project, and only as long as the project remains open. For subsequent

alignments in the same project, you can use the Align tool (@) to perform the alignment using your
custom settings.

4. (optional) During the alignment, MegAlign Pro displays a progress window. If you need to interrupt the
alignment, click Cancel. To view a console window showing the start time and progress of the
alignment, click Show Console.

. o |If an alignment fails, you will receive a message with recommendations on how to obtain a
successful alignment (e.g., by modifying options or choosing a different alignment method). See
Troubleshoot multiple alignments.

o If an alignment finishes successfully, a table of pairwise distances and a phylogenetic tree are
created and displayed in the Distance view and Tree view, respectively. If the Console is not
already open, and you wish to view alignment statistics and other information there, select View
> Console. To reset the sequences to the unaligned state (i.e., as if they were just added to
MegAlign Pro), use Align > Unalign All.
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Notes regarding multiple alignments

When performing a multiple alignment, take the following tips into consideration.

Sequence order matters:

The order in which sequences appear in the Overview and Sequences view may affect the results of the
multiple sequence alignment. If you are not satisfied with an alignment, try reordering sequences and
running the alignment again.

Divergent sequences

The MUSCLE multiple alignment algorithm assumes that the sequences to be aligned have a certain degree
of relatedness. Groups of relatively divergent sequences, especially those with very large data sets, may
require considerably more computer resources, particularly RAM. When working with these types of data,
we recommend using Align > Align with Options and changing Maximum iterations to 1 or 2. This will both
reduce the amount of memory needed, and ensure that the sequences are sufficiently related to allow for
the alignment process to be successful.

Additional alignment methods:

Two additional multiple alignment methods are available in DNASTAR’s MegAlign application: Jotun Hein
and Clustal V. Please open the classic MegAlign application and select Help > Contents for more
information on these methods.

High-throughput sequencing reads:

We caution against attempting a multiple alignment in MegAlign Pro using high-throughput sequencing
reads. Analysis of these reads should instead be handled through DNASTAR’s SeqMan NGen and

ArrayStar applications.

Known issues with Mauve:

* Anissue in Mauve can cause an alignment to stall if sequences are ordered one way, but not another.
If this issue occurs, you may see up to three error messages after beginning a Mauve alignment:
“progressiveMauve-[OS].exe has stopped working,” “Do you want to send more information about the
problem?,” and “Unexpected error while running the alignment.” The last message provides a Details
button which reveals the text: “Mauve quit unexpectedly. Reported error: Unrecognized file format.” In
addition, a progress bar will open, but the alignment will not finish. To circumvent this issue, Cancel
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the alignment, drag the sequences into a different order in the Sequences View or Overview, and then
try the alignment again.

+ Sequences aligned with Mauve may give slightly different results on Windows and Macintosh. These
differences originate with the Mauve algorithm and not with the implementation in MegAlign Pro.
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Troubleshoot multiple alignments

Error message that sequences are the wrong type or are too long:

After beginning an alignment, an error message will appear if the sequences are not of the appropriate type
or are too long for the selected algorithm. If performing a MUSCLE or Clustal Omega alignment, an error
message usually indicates that the sequences are too long or that multi-segment sequence groups are
ordered incorrectly. To remedy the situation, you can align using Mauve, or correctly re-enter any incorrect
multi-segment sequences, or break up the sequences into shorter lengths. This last task can be performed
very quickly and easily using DNASTAR SegNinja.

Aligning...

Aligning...

Show Console ” Cancel

Message that an unexpected error occured:

During a multiple sequence alignment, you may receive the following warning:

# "

Error running alignment

Unexpected error while running the alignment.

[Details >>| [ ok

To reveal more information, click on the Details button.

# x

Error running alignment

Unexpected error while running the alignment.

- <<Detals] | OK

MUSCLE gquit unexpectedly. -

View the console output for more information.
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For additional details, select View > Console from the menu. An example console is shown below:

El console 52
Untitledd.m=sa

BB B~-ri~"

8

scle
@@
%]
o505
Be
Be

38 S3 88 ss

4

-In
e
[5]5]
o5 5]
ae
aa

Please cite:

S MB(8%)
S MB(8%)

5 MB(0%)
5 MB(@%)

25 MB(1%)
1294 MB(65%)

1294 MB(65%)
1294 MB(65%)

http:/ S, drives. com/muscle
This software is donated to the public domain.
Edgar, R.C. Nucleic Acids Res 32(5), 1792-97.

Iter
Iter

Iter
Iter

Iter
Iter

Iter
Iter

Fatal error, exception caught.

MUSCLE w3.8.31 by Robert C. Edgar

1
1

1
1

=== Started MUSCLE at 1:35:41 PM ===

33.33%
108 .88%

33.33%
lea.eei

108 .08%
108 .08%

58 . Bak
lee.aa%

=== Ended MUSCLE at 1:39:87 PM aftter 3.45

put 2 seqs, max length 35213, avg length 24781

K-mer dist pass
K-mer dist pass

K-mer dist pass
K-mer dist pass

Align node
Align node

Root alignment
Root alignment

minutes ===

|3

m

1

Notice that in this console, the message “Fatal error, exception caught” appears near the bottom. Either that
message or an “Out of memory” message are known to occur with particularly long, highly divergent

sequences.

* Note: If you have a question about a console error message (or anything else related to the

MegAlign Pro software), please contact DNASTAR Support.

Before attempting the alignment again, we recommend using Align > Align with Options and checking the
box next to Use Brenner’s Alignment. Checking the box causes MegAlign Pro to use Brenner’s method for
the root alignment. This method uses less memory, and enables the alignment of long and divergent

sequences, but with a concurrent loss in accuracy.
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Multiple alignment methods and options

MegAlign Pro offers both gene-level and genome-level multiple alignment algorithms.

Gene-level alignment of either protein or nucleotide sequences:

In general, the three gene-level aligners have higher accuracy than the genome-level (Mauve) aligner. They
offer editable options for speed, capacity, algorithm, etc., and are the only methods available for “profile”
alignments. The disadvantages to gene-level aligners is that sequences must be on same strand, and that
large rearrangements (e.g., inversions, translocations) are not allowed.

» Clustal Omega - Clustal Omega (Sievers F et al., 2011) was developed at University College Dublin,
and is the most advanced version of Clustal. It can align hundreds of thousands of sequences in just a
few hours. This method has few editable options, but has high, 64-bit capacity on both Windows and
Macintosh.

+ Clustal W — Clustal W aligns sequences using the method of Thompson et al. (1994). Clustal W was
designed to create more accurate alignments than Clustal V when alignments include highly diverged
sequences. However, Clustal W does not always handle end-gaps ideally. Also, note that true Clustal
W performance is only achieved when you choose the default “Slow-Accurate” option rather than the
“Fast-Approximate” option.

* MAFFT — MAFFT (Multiple Alignment Fast Fourier Transform; Katoh M & Kumar M, 2002) was
developed by the Computational Biology Research Center and generously donated to the public
domain. This method has many editable options, and provides a variety of algorithms for different
scenarios and a choice of very slow to very fast speeds. It has 32-bit capacity on Windows, and 64-bit
on Macintosh. See the CBRC’s MAFFT page for additional references.

* MUSCLE - The MUSCLE alignment algorithm was developed by Dr. Robert Edgar (Edgar RC, 2004 &
2004), who very kindly donated it to the public domain. It is one of the faster aligners, and has
numerous selectable options. MUSCLE features iterative cycles that guide tree refinement and
realignment. Like MAFFT, it has 32-bit capacity on Windows, and 64-bit on Macintosh.

Genome-level alignment of nucleotide sequences:

In comparison to the methods above, the genome-level aligner allows large rearrangements. However, it
only allows nucleotide sequences, and fine-scale gapping may not be as good as in gene-level aligners.

* Mauve was developed in the Genome Evolution Laboratory at the University of Wisconsin-Madison
(Darling AE, Mau B, and Perna NT, 2010) and is licensed under a GNU General Public License.
Mauve has high capacity and uses MUSCLE to create multiple alignments for each block that
contains more than a single sequence. The Mauve algorithm is currently the only MegAlign Pro
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alignment method that is:

o

suitable for aligning very long sequences up to genome-length.

o capable of producing an alignment when one or more of the sequences are rearranged relative
to one another.

o capable of producing a multi-block alignment (see Overview).

o only available for nucleotide sequences.
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Clustal Omega alignment options

The Clustal Omega algorithm is for gene level alignment of either protein or nucleotide sequences. To run a
Clustal W alignment, select two or more sequences and choose Align > (Re)Align Using Clustal Omega.

If you wish to change method options, instead choose Align > Align with Options. The dialog is the same
whether the sequences are protein or nucleotide.

r Align Sequenc_ . u

Align: ’All.al.i.gned. SEQUENCES v]

Using: ’Clusta.l. Omega v] )]

Clustal Ornega options

Iteration Options
["| Iterate to refine alignment

baxirmurn number of opcles of tree refinement: 1

Maxirurm nurmber of cycles of refinerment wsing alignment-based HhM: 1

Clustering options (available for alignments of 100 or more sequences)
Use distance matrix instead of k-tuple based mbed method for initial alignment
Use mbed for first round and distance matrix for later iterations

Restrict cluster size in mbed mode

Maxirmurn sequences per subcluster: | Default: 5

Reset to Default

Change settings as desired:

* Note: Certain options in this dialog may initially be disabled. For example, some options are
only enabled if there are = 100 sequences in the project, while others are enabled only after
options higher up in the dialog are checked. See below for further information.

* Use the Align drop-down menu to select sequences to align or realign.

* In the Using drop-down menu, choose Clustal Omega.
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» To refine the alignment by specifying a threshold for iteration cycles, check the box next to Iterate to
refine alignment. When this box is checked, two refinement options become available. You may
enter values for neither, either, or both options.

. o

Enter a value for Maximum number of cycles of tree refinement to specify a cutoff for the
maximum number of iterations. The default is 1.

Enter a value for Maximum number of cycles of refinement using alignment-based HMMs
to set a cutoff for the number of HMM iterations. MegAlign can often improve the placement of
gaps by comparing the alignment to a Hidden Markov Model (HMM) of the alignment. The
default is 1. The HMM is very slow, so be aware that entering a large number may cause a
commensurate decrease in alignment speed.

In both cases, MegAlign Pro will recompute the pairwise distances, recalculate the guide-tree, and
then realign the sequences while staying within the maximum cycle threshold.

» If your project contains = 100 sequences, three clustering options are available. All three options are
disabled for projects containing fewer than 100 sequences.

. o

To force clustering using a distance matrix based comparison, check Use distance matrix
instead of k-tuple based mbed method for initial alignment.

To use mbed for the first iteration and a distance matrix for other iterations, check Use mbed
for first round and distance matrix for later iterations.

If you check the second box, but not the first, you may optionally set a threshold for the cluster
size during mbed iterations by checking Restrict cluster size in mbed mode. Once you have
checked that box, you may elect to over-ride the default by entering a value for Maximum
sequences per subcluster. The default is <number of sequences to be aligned> minus ‘1,” up to
a maximum value of 100.

The following table shows how the MegAlign Pro settings correspond with settings in Clustal Omega online.

MegAlign Pro setting Clustal Omega setting

Does not correspond with the command-line, but enables the two

Iterate to refine alignments

settings directly below.

Maximum number of cycles of tree max-guidetree-iterations=(integer)

refinement

iterations=(integer)

max-hmm-iterations=(integer)

Maximum number of cycles of iterations=(integer).
refinement using alignment-based

HMMs

The value used for “iterations” is the maximum of the values
specified for this option and the option in the preceding row.
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Use distance matrix instead of k-tuple

full
(enabled)
Use mbed for first round and distance full-iter
ull-i
matrix for later iterations (enabled)
Maximum sequences per subcluster cluster-size=(integer)

After making your changes:

» Choose Align to use the entered options to perform a multiple sequence alignment.

* Use the Reset to Default button if you would like to reset all values to the MegAlign Pro defaults.

» Select Cancel to leave the dialog without saving any changes or performing the alignment.
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Clustal W alignment options

The Clustal W algorithm is for gene level alignment of either protein or nucleotide sequences. To run a
Clustal W alignment, select two or more sequences and choose Align > (Re)Align Using Clustal W.

If you wish to change method options, instead choose Align > Align with Options. The dialog has slightly
different options, depending whether the sequences are protein or nucleotide (nucleotide shown below).

-

Align Sequences

Align: ’AII aligned sequences

Using: ’CIustaIW

-

ClustalW options

Scoring matri:  |IUE -

Iteration method: ’ Mone

Multiple alignment parameters

Gap cpen penalty: Default: 10
Gap extend penalty: Default: 0.20
Delay divergent sequences:  Default: 30

Transiticn weight: Default: 0.50

Pairwise alignments for guide tree

(@ Slow, accurate () Fast, approximate

Gap ocpen penalty: Default: 10
Gap extend penalty: Default: 0.1

Reset to Default

v] Maximum Iterations: | 1

=

Align

Cancel

Change settings as desired:

* Use the Align drop-down menu to select sequences to align or realign.

* In the Using drop-down menu, choose Clustal W.

* Use the Scoring matrix drop-down menu to choose between these options:
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Matrix Description
Nucleotide sequences only

The default scoring matrix used by BESTFIT for the comparison of
nucleic acid sequences. X’s and N’s are treated as matches to any
IUB ambiguity symbol. All matches score 1.9; all mismatches for IUB
symbols score 0.

IUB

Clustal  The previous system used by Clustal W, in which matches score 1
w and mismatches score 0. All matches for IUB symbols also score 0.

Protein sequences only

(Dayhoff et al.,

BLOSUM (Hehik?ﬁ & Henikoff, 1992). BLOSUM is ideal for carrying out PAM 1978). .Widely
similarity searches. used since the
late 1970s.
Derived from PAM matrices (Dayhoff et al., 1978) but more sensitive,
GONNET
and based on a much larger data set.
ID Scores two identical amino acids as 1, and anything else as -10,000.

* In the Iteration method drop-down menu, choose between None, All alignment steps, and Final
alignment only. If you choose an item other than None, type the number of Maximum Iterations into
the text box on the right.

* Enter the desired Multiple alignment parameters:

> Gap open penalty, the numerical penalty for introducing a gap of any length when calculating
alignments. This penalty does not take into account the size of the gap. The default is 10.

o Gap extend penalty — This option affects the lengths of gaps, and must be zero or a negative
number. Lowering the magnitude of the gap extension penalty may allow for longer gaps. The
default is 0.20.

o Delay divergent sequences — This setting aligns more closely related sequences, delaying the
alignment of more distantly related ones. Input the percent identity required to delay the
addition of a sequence. The default is 30.

o Transition weight — This option is only available for nucleotide sequences and gives purine-
purine or pyrimidine-pyrimidine substitutions (i.e., A-G or C-T) a weight between 0
and 1. One denotes a match, while zero denotes a mismatch. Assign a high score for closely

related sequences and a lower score for distantly related ones. The default is 0.50.

* Enter the desired Pairwise alignment parameters:
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o Choose whether MegAlign Pro should use the Slow, accurate or Fast, approximate version of
Clustal W when making the guide tree.

o Type in the Gap open penalty, the numerical penalty for introducing a gap of any length when
calculating alignments. This penalty does not take into account the size of the gap. The default
is 10.

o Gap extend penalty — This option affects the lengths of gaps, and must be zero or a negative
number. Lowering the magnitude of the gap extension penalty may allow for longer gaps. The
default is 0.1.

After making your changes:
» Choose Align to use the entered options to perform a multiple sequence alignment.

* Use the Reset to Default button if you would like to reset all values to the MegAlign Pro defaults.

+ Select Cancel to leave the dialog without saving any changes or performing the alignment.
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MAFFT alignment options

The MAFFT algorithm is for gene level alignment of either protein or nucleotide sequences. If you want to
align a large number of sequences in MegAlign Pro, we recommend using this algorithm. As of the
Lasergene 17.3 release (2021), MegAlign Pro uses MAFFT7. This powerful aligner can typically align
thousands of viral genomes, for example, in under two minutes.

To run a MAFFT alignment, select two or more sequences and choose Align > (Re)Align Using MAFFT. If
you wish to change method options, instead choose Align > Align with Options. Options vary depending
whether the sequences are protein or nucleotide (nucleotide version shown below).

EEr=me . )

Align: ’AII aligned sequences v]

Using: | MAFFT | @

MAFFT ocptions
Gap open penalty:  Default: 1.53

Gap extension penalty:  Default: 0.0

Algorithrm: ’Choose algorithm depending upon size [auto]

Scoring matria IEDDPAM fh=2

Reszet to Default

Change settings as desired:

+ Use the Align drop-down menu to select sequences to align or realign.

* In the Using drop-down menu, choose Clustal W.

» Specify the Gap open penalty, the numerical penalty for introducing a gap of any length when
calculating alignments. This penalty does not take into account the size of the gap. The default is -2.0.
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* Gap extension penalty — This option affects the lengths of gaps, and must be zero or a negative
number. Lowering the magnitude of the gap extension penalty may allow for longer gaps. The default

is 0.

* In the Algorithm drop-down menu, either retain the default of Choose algorithm depending upon

size [auto], or specify a particular alignment algorithm.

o No. of
Description Name Strategy
Seqgs
Choose algorithm depending upon
_ g pending up (default)

size [auto]

Very slow global homology <200 g-ins-i

Very slow one conserved domain <200 [-ins-i

Very slow multiple conserved domains <200 e-ins-i
iterati fi t, iterati ified

Slow iterative refinement, iterations specifie N/A fons.i
by user

Medium Iterative refinement, two iterations N/A N/A

Fast Progressive N/A fft-ns-2

Very fast Progressive > 2000 fft-ns-1

* in the Scoring matrix drop-down menu, choose the desired matrix:

Matrix
name

Description

Nucleotide sequences

1PAM / k=2 For closely related sequences.

20PAM /

k=2 For moderately related sequences.
200 PAM / .

k=2 For distantly related sequences.

Protein sequences

(Henikoff & Henikoff, 1992). The BLOSUM series of matrices contain the same values
BLOSUM30, as in some of MegAlign Pro’s other alignment methods, except that the protein
45 62. 80 ambiguity codes B, Z, and X are excluded in this case. These matrices are ideal for
T carrying out similarity searches. Choose a larger number BLOSUM matrix for less

divergent sequences.
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(Thorne JL et al., 1998) These matrices are similar to PAM matrices and were
generated using an algorithm similar to the approach of Dayhoff et al. (1978), but based
on a larger set of protein sequences.

JTT100,
200

After making your changes:

» Choose Align to use the entered options to perform a multiple sequence alignment.

* Use the Reset to Default button if you would like to reset all values to the MegAlign Pro defaults.

» Select Cancel to leave the dialog without saving any changes.
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MUSCLE alignment options

The MUSCLE algorithm is for gene level alignment of either protein or nucleotide sequences. To run a
MUSCLE alignment, select two or more sequences and choose Align > (Re)Align Using MUSCLE.

If you wish to change method options, instead choose Align > Align with Options. Options vary depending
whether the sequences are protein or nucleotide (protein version shown below).

g

-' Align Sequences
Align: ’AII aligned sequences v]
Using: |MUSCLE - @
MUSCLE options
Substitution matric | MUSCLE default v
Gap open penalty: Default: 2.9
Gap extension penalty:  Default: 0.0
Center penalty: Default: 0.52
Maximum iterations: Default: 8
[] Use Brenner's alignment
["| Disable anchors optimization
Initial iterations Later iterations
Cluster method: | UPGME * - || upGiB * v
Distance rmeasure: ’Kmer 6-6* v”I‘Eimura % identity * v]
Sequence weight: ’CIustaIW* v”CII.JstaI‘l.I"."* v]
*indicates default value
Align ] ’ Cancel

Change settings as desired:

+ Use the Align drop-down menu to select sequences to align or realign.

* In the Using drop-down menu, choose MUSCLE.

» Substitution matrix — (protein sequences only) Choose from a list that includes one or more
members of the VTML, BLOSUM GONNET and PAM series of matrices.
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* Gap open penalty — This option affects the chance of gaps being introduced into alignments, and
must be zero or a negative number. Decreasing the magnitude of the gap open penalty may lead to
an excessive amount of gapping. The default is -400 for DNA; -420 for RNA; -2.9 for protein.

* Gap extension penalty — This option affects the lengths of gaps, and must be zero or a negative
number. Lowering the magnitude of the gap extension penalty may allow for longer gaps. The default
is 0.

+ Center penalty — This must be zero or a negative number. The default is 0 for DNA; -300 for RNA;
and -0.52 for protein.

+ Maximum iterations — This option, which must be a positive integer, affects the number of rounds of
refinement used to produce an alignment. Depending on your data, the alignment might finish before
the specified number of rounds have been performed. The default is 8.

» Use Brenner’s Alignment — Checking the box causes MegAlign Pro to use Brenner’'s method for the
root alignment. Brenner’'s method uses less memory than the default root alignment, but the alignment
will not be as accurate as if the box were left unchecked. For this reason, it is not usually necessary to
check the box unless you received certain types of error messages during a previous alignment
attempt.

» Disable anchors optimization — The default for MUSCLE is for anchor optimization to be enabled
(i.e., for this box to be unchecked). One side effect of anchor optimization is that the selected number
of Maximum iterations, if greater than two, may be over-ruled during sequence processing. If you
instead wish to run the exact number of iterations selected in Maximum iterations (above), add a
checkmark to this box.

* Use the drop-down menus to choose the desired Cluster method for Initial iterations and Later
iterations.

Cluster

Description
method

UPGMA  Fast O(N2) approximation to the textbook UPGMA algorithm.

UPGMB

Variant of UPGMA that is used, by default, for both iteration 1 and 2.
(default)

Neighbor Better at making phylogenetic trees, but slower, and usually worse for making guide trees
Joining  for progressive alignment. Not recommended for most alignments.

* Choose the desired Distance measures.

Distance measure Description

Initial iterations
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Kmer 4-6 [default for DNA/RNA; not available for protein]
Kmer 6-6 [default for protein]

Kmer 20-3

Kmer 20-4

Kmer bit 20-3

Later iterations

Kimura % identity [default]

Log % identity

+ Select the desired Sequence weights for Initial iterations and Later iterations.

Sequence weight Description

None Do not weight sequences.
ClustalW (default)

Henikoff

Henikoff PSI-BLAST

gsc

Threeway

The following table shows how the MegAlign Pro settings correspond with settings in MUSCLE online.

MegAlign Pro setting MUSCLE setting
Substitution matrix matrix

Gap open penalty gapopen

Gap extension penalty gapextend
Center parameter center

Maximum iterations maxiters

Use Brenner’s Alignment brenner

Disable anchors optimization anchors

Cluster method:
Initial iterations cluster1
Later iterations cluster2
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Distance measure:
Initial iterations
Later iterations

Sequence weight:
Initial iterations
Later iterations

After making your changes:

distance1
distance2

weight1
weight2

User Guide to MegAlign Pro - 17.3_en

» Choose Align to use the entered options to perform a multiple sequence alignment.

+ Use the Reset to Default button if you would like to reset all values to the MegAlign Pro defaults.

+ Select Cancel to leave the dialog without saving any changes.
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Mauve alignment options

The Mauve alignment algorithm is for genome level alignment of nucleotide sequences. To run a Mauve
alignment, select two or more nucleotide sequences and choose Align > (Re)Align Using Mauve.

If you wish to change method options, instead choose Align > Align with Options.

Cammee =

Align: ’AII aligned sequences v]

Using: ’Mauve v] @

Mauve options
Default seed weight

Seed weight: | 15

[ Use seed families
Min LCE weight:  Default

Reset to Default

Change settings as desired:

» Use the Align drop-down menu to select sequences to align or realign.

* In the Using drop-down menu, choose Mauve.

+ If the Default seed weight box is checked, as it is by default, the optimal seed weight (number of
matches required per k-tuple) is calculated automatically. You may uncheck the box and either use
the slider or manually enter a number in the Seed weight box to specify a particular seed weight
between 3 and 21. The default is 15.

» Check the Use seed families box to use multiple spaced seed patterns to identify potential homology.
When working with divergent genomes, checking this box can significantly improve the sensitivity and
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accuracy of the alignment.

» Whether or not you have checked either of the boxes in this dialog, you may override the default Min
LCB weight, if desired, by entering a value in the box. Increasing the Min LCB weight may reduce
the number of spurious rearrangements, and is advisable in many cases.

The following table shows how the MegAlign Pro settings correspond with settings in Mauve online.

MegAlign Pro setting Mauve setting
Default seed weight (disabled) seed-weight
Use seed families (enabled) seed-family

Min LCB weight (non-default value entered) weight

After making your changes:
+ Choose Align to use the entered options to perform a multiple sequence alignment.
+ Use the Reset to Default button if you would like to reset all values to the MegAlign Pro defaults.

+ Select Cancel to leave the dialog without saving any changes.

The following videos demonstrate how to perform a multiple alignment using the Mauve alignment algorithm:

The following video shows a multiple alignment using the Mauve algorithm:
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Modify a multiple alignment

The following table describes ways to modify an initial multiple alignment:

Task See this topic

To realign a range of aligned sequences using different parameters or a

. . . Subalign sequences
different alignment engine

Merge two existing

To merge two existing completed alignments together alignments (“Profile
alignment”)

To add all/selected sequences from the “Unaligned Sequences” area into the
current alignment, while retaining all of the gaps of the original, pre-merge
alignment

Merge unaligned sequences
into an existing alignment

Align selected unaligned
To realign existing aligned sequences PLUS selected unaligned sequences sequences with an existing

alignment

The following video illustrates some of these modification procedures:
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Subalign sequences

While sequences such as full-length calmodulin proteins typically align well throughout the entire length of
the polypeptides, full-length alignments of other sequences may not generate such neat blocks of similarity.
For example, multiple sequence alignments of full-length beta-tubulins typically show “ragged” carboxyl
termini, where the different tubulins terminate at varying positions with respect to the consensus. The
“ragged” termini are caused by considerable length variance of the beta tubulins and carboxyl termini that
are poorly conserved. Therefore, once you have performed an initial multiple alignment for two or more
sequences, you may wish to realign a section using different parameters or a different alignment engine.

To perform a sequence subalignment:

1. Make a single selection across the aligned sequences. One way to do this is to drag the mouse along
the consensus sequences. Another is to triple-click on a feature. Either selects a “vertical slice” of all
the sequences in the current alignment. If you plan to use Mauve as the alignment algorithm, note that
you can only select and subalign sequences within the active block.

2. Choose Align > Realign Subsequences to open a dialog populated for a sequence subalignment.

3. Choose the desired alignment method from the drop-down menu, then set other options as desired.

i |
Realign Subsequences lﬂ

-
Align: ’Selected subsequences V]

Using: |MUSCLE - @

T W T | )}

MUSCLE eptions

LA e e e e e Gap open penalty:  Default: -420.0
850 860 470 ,
ETTETACCTNCCCACCTTGCTCATGCTnTGGT | Oap extension penatty:

Center parameter:  Default: -300.0

Default: 0.0

cttctacctgcccaccttgoctcatgeoctcitggt
cttectacctccccactttgectcatgetgtggt Maximum iterations: Default: 8
cttectatctgeocccaccttgeoctecatgeotceitggt

[] Use Brenner's alignment
cttectacatcccttcattcctaatgectggtgt

[”] Disable anchors optimization

Initial iterations Later iterations
Cluster method: |UPGMB * - |[upGie * -
Distance measure: ’Kmer-’l-&* v”Kimura % identity * v]
Sequence weight: ’CIustaIW* v”CIustaIW* v]

* indicates default value

o) [ )

4. Press Align.

«¥s Notes:
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« Subalignments are not supported when the document contains any end-to-end sequences.

* Occasionally, the new subalignment may no longer be the same as the optimal alignment your
alignment method would generate from scratch for this particular set of sequence coordinates. You
may want to realign the shorter sequences to evaluate this possibility.

+ If you are not sure exactly which segment of an alignment you need for your new alignment, you may
select the region liberally, generate the new alignment, and continue to select sub-regions of the

alignment until you are satisfied.

* You can create a new alignment from a selection of any length, but you cannot create a new
alignment from discontiguous segments of your current alignment.
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Merge two existing alignments (“Profile
alignment”)

To merge two existing alignments:

A “profile alignment” occurs when you merge a MegAlign Pro alignment (.msa) that was saved earlier with
the current project. Profile alignments merge two existing multiple alignments without removing any of the
existing gaps. However, new gaps may be automatically inserted to reconcile the new alignment. Mauve

alignments are not supported in this workflow.

1. Create a project, align the sequences using any alignment method except Mauve, and then save the
project in MegAlign Pro (.msa) format.

2. Create a second project and perform an alignment using any method except Mauve. Both projects
must use the same sequence type (nucleotide vs. amino acid), but it is not necessary to use the same
alignment method that was used in Step 1. If the projects do not contain the same sequence types,
you will receive an error message:

i ™
Unabie to Merge icrment S|

|[ - ]I Cannct merge alignments. Alignments contain different sequence types.

3. (optional) The next step will over-write the alignment in the second (current) project. Therefore, you
may wish to save the alignment before proceeding further.

4. From within the second (current) project, select Align > Merge Alignment into Existing Alignment.

5. In the ensuing Open dialog, navigate to the saved project and click Open. A warning will be displayed
if you attempt to merge an unsaved project with the active project.

6. Choose the desired alignment method from the drop-down menu, then set other options as desired.
Note that Mauve and MAFFT alignment methods are not supported for this workflow.

7. Press Align.

* Note: Any unaligned sequences from the merged project are automatically transferred to
the “Unaligned Sequences” area of the current project.
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Merge unaligned sequences into an existing
alignment

To merge unaligned sequences into the current project’s existing alignment:

In contrast to the “Profile alignment” method, this method retains existing gaps, and adds new gaps, if

necessary.

1. Add sequences to the project and align some or all of them. If all sequences were aligned, add more
sequences to the project.

2. Before proceeding, check that the “Unaligned Sequences” bars in the Overview and Sequences view
display a number = 1 in the parentheses. If you wish, you may show or hide the unaligned sequences
by clicking the arrows on the left of each bar.

@Unaligned Sequences (7] j

3. (optional) An upcoming step will overwrite the current alignment. Therefore, you may wish to save the
original alignment before proceeding further.

4. Specify which unaligned sequences to add to the current alignment.

5. Select Align > Merge Unaligned into Existing Alignment or press the Align sequences to an

existing alignment tool (@). The menu command and tool are enabled only if the project contains
an alignment and at least one unaligned sequence.

6. Choose the desired alignment method from the drop-down menu, then set other options as desired.
The Mauve alignment method is not supported in this workflow.

7. Press Align.



Align selected unalighed sequences with an
existing alignment

In some cases, you may have already aligned sequences, then decide to completely realign the same
sequences plus certain selected unaligned sequences.

To align selected unaligned sequences with an existing alignment:

1. Add sequences to the project and align some or all of them. If all sequences were aligned, add more
sequences to the project.

2. Before proceeding, check that the “Unaligned Sequences” bars in the Overview and Sequences view
display a number = 1 in the parentheses. If you wish, you may show or hide the unaligned sequences
by clicking the arrows on the left of each bar.

@Unaligned Sequences (7] [

3. (optional) An upcoming step will over-write the current alignment. Therefore, you may wish to save the
original alignment before proceeding further.

4. Specify which unaligned sequences to include in the new alignment by clicking on them or by using
Ctrl/Cmd+click or Shift+click.

5. Select Align > Realign with Selected Unaligned.

6. Choose the desired alignment method from the drop-down menu, then set other options as desired.

7. Press Align.
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Unalign aligned sequences

To unalign all sequences in an alignment:

1. Choose Align > Unalign All.

2. When the following message appears, click OK.

@ Remove all gaps in the current alignment?

Execution of this command causes gaps to be removed from all of the previously aligned sequences. The
sequences are then automatically relocated to the “Unaligned Sequences” areas of the Overview and
Sequences view. In some cases, a progress bar may be displayed during the unalignment procedure.

To unalign particular aligned sequences:

1. Select one or more of the aligned sequences in the Overview or Sequences view.

2. Choose Align > Unalign Selected.

3. When the following message appears, click OK.

Contirsunaign s

@ Remove sequence(s) from the current alignment?

Depending on the size of the alignment, a progress dialog entitled Removing All-Gaps Columns may be
displayed during the unalignment process.

Execution of this command causes gaps to be removed from all of the previously aligned sequences. The
sequences are then automatically relocated to the “Unaligned Sequences” areas of the Overview and
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Sequences view. In some cases, a progress bar may be displayed during the unalignment procedure.

Removing All-Gaps Columns...

I;I
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Detect and remove outliers from the
alignment

After performing a multiple sequence alignment, you may wish to detect and remove outliers from the

alignment.
1. From the Distance view, select a reference sequence.

2. Choose Distance > Order Sequences by Distance from Selection. By default, a heat map color
scheme is applied. This can be customized in the Distance section of the Style panel.

3. From the Distance table, select the sequences you want to remove from the alignment. Note that the
rows nearest to the bottom of the table differ the most from the reference sequence. The Distance
table metrics and heat map coloration can help you decide which sequences to remove.

4. Choose Align > Unalign Selected.



Try it! — Perform a Clustal Omega alignment

This tutorial will use the Clustal Omega algorithm to multiply align 143 DNA sequence files consisting of
regional variations of the Human Papilloma Virus L1 gene (HPV-L1). HPV has affected humans for

hundreds of thousands of years and is known to cause cervical cancer. Some regional variations of the
gene are more pathogenic than others. For example, HPV-16 is the most pathogenic variation in Western
populations.

The L1 gene is not the cause of variation in pathogenicity. However, variations of the L1 gene are used to
tell various strains apart and group them according to relatedness. The results of this tutorial reveal a

deeply branched tree revealing an ancient phylogeny for HPV within the human genome.

Begin with Part A: Add and align sequences.




Part A: Add and alignh sequences

In this part of the tutorial, you will be adding 143 DNA sequences to the MegAlign Pro project and aligning
them with the Clustal Omega algorithm using the default settings.

1. If you have not yet downloaded and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. If a MegAlign Pro project is already open, choose File > New Alignment Project. Otherwise, launch
MegAlign Pro.

CG
3. Choose File > Add Sequences, or click on the Add sequences to project tool ().

4. Open the folder HPV project. Use Ctrl+A (Win) or Cmd+A (Mac) to select all 143 DNA sequences
and click Open.

5. When prompted, select DNA.

Sequence Type for Untitled1.msa b4

=% Please select the default sequence type for Untitled1.msa

DNA RMNA Protein

6. In the Overview at the top left of the MegAlign Pro window, note the appearance of a series of gray
blocks, one for each sequence. The gray blocks have the lengths of their corresponding sequences.
Solid gray blocks and varying block lengths are both indicative of sequences that have not yet been
aligned.

Ruler 500 1,000

HPV1_L1

HPVZ_L1

HPV3_L1

HPV4_L1

HPV5_L1

HPVE_L1 v

7. To align sequences with Clustal Omega using the default parameters, choose Align > Align Using

Clustal Omega or click the Align tool arrow (@ v ) and choose Align Using Clustal Omega.
Sequences now appear mostly in green, with gray representing gaps.

Proceed to Part B: Navigate using the Overview.



https://star-deploy.s3.amazonaws.com/SupportingDataFiles/LG16/MegAlign+Pro+Data.zip
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Part B: Navigate using the Overview

Observe that the sequence blocks in the Overview are now the same lengths. Sequence gaps are
represented by gray coloring within the blocks.

Ruler 500 1,000 1,500

HPVI_L1 2
HPVZ_L1 L' ..r .1 t W F ' 1

HPVA L1 A N S S [
HPVA_L1

HPVS_L1 . .r T r ' 1t ' I} 5

< >

The light blue vertical column shown at the left of the green blocks, above, is a "viewport" showing which
region is currently being displayed in the Sequences view. The width of the viewport will vary depending on
the zoom levels in both this view and the Sequences View. You can use the mouse to drag the viewport to
whichever region you wish to see in the Sequences view.

» Using the mouse, slide the viewport to the far right, and then back to the left. At the same time, notice
how the Sequence view slides in the same way.

« To navigate to a particular residue in the Sequences view, double-click anywhere on a block in the
Overview. The viewport will move so that it is centered on the selection.

» Use the horizontal zoom slider in the Sequences view to zoom in and out. As you do this, notice how
the width of the viewport in the Overview changes.

Proceed to Part C: Change sequence names and rendering in the Sequences view.

Copyright DNASTAR, Inc. 2022 Page 240 of 329



Part C: Change sequence names and
rendering in the Sequences view

In Part B, you looked at the Sequences view while learning the function of the "viewport." You will now
explore the Sequences view in more depth. The Sequences view displays entered sequences and aligned
sequences. Sequences selected in this view are simultaneously selected in all other MegAlign Pro views.

1. In the Sequences view, observe that the names of each sequence originated from the accession
numbers that were embedded in the input files.

i
Ruler 1 e A R A T
uler 1 10 20 30 40 50
Consensus ---ATGGCttTGTGGCggCCTAgQTgAcGGtAAGGTATAL - TcCCaCCTcCaACaCCTGTgG(
HPVI_L1 —--atggctgtctggttaccagcgcagaataagttcta--—tcttcctccccagcccatc"
HPV2_L1 ---atggectttgtggeggectaatgaaagcaaggtata---cctacetcecaacacctgtt
HPV3_L1 ---atggcactgtggegctctagtgacaacctggtgta---cctgecetcetaccectgtt
HPV4_L1 ---atgtcgagttggttatctacaacgggtaaagtctacttacctccagetcaacctgty
HPV5_L1 ---atggcagtgtggeactcggctaatggtaaagtatatcttccaccategacaccggty
HPVELT - - - - - - atgtggeggecctagcgacagcacagtatatgtgectecectecectaaccetgtpa ||
HPVZ7 LT - - - - atgtggcaacttaatgaaaaccaagtgtatttaccaccgecccacgecectgt)t
HPVE L1 ---atggcagtgtggeaatcggctacecggtaaggtttatctgcetcetteaacaccagty
HPVI L1 ---.at::ltcattt:lt::lt:lcttcca::lcaat:lt(:lc:lta.a::l::ltatattt::lccacca::lcaacacca::ltﬂv
Sequence Logo :| ATGGC Ti; Gﬁc_ CCTAGTBJ\_GGTAAJG AIA cET_E AC ccTGI G
o va==-T%= =2 TISTZ-GE_=C=aaf==42Z1Z c"’ T— a=2=2Z=7N=210T
Ruler 2 1|...|....1|D....|....2|D.||.| ...|.........|....|....|....|....|.
< >

To also add the sequence length as part of the name:

a. Use Ctrl+A or Cmd+A to select all of the sequence names.

b. Right-click on the highlighted group and select Rename with Fields, or choose Edit > Rename
with Fields from the main menu.

c. Select Sequence length from the left pane and click the right arrow to add it.
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Choose Label O -
What label would you like to display in this application for the selected iterns?

Display: | One or more fields w

FAvailable fields: Display fields in this order

Accession number | W Default name ‘f

Data file narme Sequence length

Data file name base « ¥
Data file path

Data file time

Data specification
Description
Sequence shape
Sequence type

Separator: | - |

Example: | HPV1_L1 - 1,508 bases |

Cancel

d. Click OK.

The sequence labels now reflect their lengths in base pairs:

| HPY1_L1 - 1,509 bases ---atggctg
| HPY2_L1 - 1,485 bases ---atggett
| HPY3_L1 - 1,515 bases ---atggkae
| HPV4_L1 - 1,551 bases ---atgtecga
I HPV5_L1 - 1,551 bases ---atggcag
I HPV& L1 - 1,503 bases - - - - - - - - - a

HPY7_L1-1,518 bases @ - - - - - - - - - a
| HPWE_L1 - 1,545 bases ---atggcag
| HPVS L1 - 1.524 bases ---atatcat

2. Remove the current selection by double-clicking on any white space, e.g., white space in the header

or footer area of the Overview or Sequences view.

3. Use File > Save to save the project as HPV project.msa.

4. In the Sequence view, click on any plus icon ( © ) to reveal a details track containing a gap-aware
ruler. These sequences do not contain annotations, but if they did, the annotations would also be
visible.
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5. The appearance of the sequences can be changed using settings in the Style panel’s Sequence and
Multiple Alignment sections located to the right of the views. Experiment with the items in this area to
see how they affect the look of the Sequences view. Some items must first be enabled by checking
the associated checkbox.

= Seguence

Presentation

Font: | Segoe U b B I

Case: | Upper ~
[ ]Track names font:

Segoe Ul B I

Display As: |DNA w

= Multiple Alignment
Layout

Linear e
Alignment coloring
Colar all residues

Reference:  Consensus

Ignore gaps

Di

] |:|Cnlnr by chemistry -~ (3
-

[ |color by chemistry v |(@

[ 15clid: =

Default

When you have finished trying out different color schemes and fonts, we recommend changing them
back to the original settings (shown in the image above) for ease of following the remainder of this
tutorial.

6. Imagine that you want to see the Consensus Match track, but it is not included in the default display.
To display the track, click the Tracks tab in the upper right of MegAlign Pro (or select View > Tracks
> Tracks) and check the box next to Consensus Match.
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4 Owerview header
Ruler
P Owverview details
Features
Fuler

Consensus

4 Sequences header or footer

Consensus Match
Rulerl

Ruler 2
Sequence Logo
a [H Sequence details
Features

[] Gap Fraction

Ruler
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7. Locate the Consensus Match histogram in the footer of the Sequences view. Hover over a bar to see
a pop-up showing the percent of sequences that match the consensus at that residue.

00

8. Hide the footer by clicking on the small gray arrow near its top right corner

( ™ ). The

Sequence Logo, Ruler and Consensus Match will disappear. Click on the arrow again to redisplay the
footer. (Note: For future reference, you can close other panes the same way, including the footer and

the main parts of the Sequence view and Overviews).

Proceed to Part D: Change metrics and rendering in the Distance view.
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Part D: Change metrics and rendering in the
Distance view

The Distance view shows a matrix (i.e., table) of numbers representing distances between each pair of
sequences. Sequence distances are used as input in creating the Tree view, which you will explore in Part
E. Selections within this view are synchronized with other views in MegAlign Pro.

1.

To display the Distance view, click on the Distance tab at the bottom of the MegAlign Pro window.

The Distance view matrix is calculated, by default, using Uncorrected Pairwise Distance

display shows %ldentity results in the upper right and Distance results in the lower left.

A B c p[_El F G H 1 ) K LM [ R—] PQ R H 0 u VoW
HPV1_L1T - 1,509 hases 5669 5685 5092 5033 5847 5815 5847 6040 5774 5001 5092 5758 60.81 6105 6073 5927 5831 6073 6040 6073 5984 59.44
HPV2 L1 - 1,485 bases (D] 6863 5710 5758 67.34 6452 59.03 5742 6847 6710 5742 6524 3855 5660 6661 5782 6815 58.23 5798 5677 5620 5694

HPV3_L1 - 1,515 bases 0.31 58.31
HPV4_L1 - 1,551 bases
HPV5_L1 - 1,551 bases
HPV6_L1 - 1,503 bases
HPV7_L1 - 1,518 bases
HPVE_L1 - 1,545 bases
HPVO_L1 - 1,524 bases
HPV10_L1 - 1,512 bases

5879 67.18 6637 5895 5984 8266 6879 5060 67.58| 5044 58.15| 6831 5831| 7097 5879 5984 5815 57.50 5879
6508 6145 6121 6210 6306 5879  60.89 63.06| 60.65 6597 6282 6234 6185 6234 6556 6492 6532 6113 61.94
60.89 6120 8048 7274 5035 60.00 8234 60.16 77.66 71.61 6056 7105 6129 7833 TA74 7815 6952 6935
6879 6048 5919 6685 8573 60.00 77.56 60.00 60.08 70.81 60.00 6847 5984 6032 5935 5863 59.03
59.52| 6097 6645 6992 6121 7008 61.69 61.69 7153 61.61 6935 60.81| 6135 359.60| 6032 60.24

7024 60.97| 5968 8177 6008 77.74 7081 6161 7048 5984 77.58 7621 7685 6831 69.84
59.11| 5068 7202 60.65 7274 7895 6145 7895 6129 7226 7282 7331 7355 7484
6742 59.11| 67.50 60.65 57.02| 6895 57.82 7048 5935 61.13 600D 5790 58.95
HPV11_L1 - 1,506 bases 6121 77.82 61.05 60.08 7161 6048 6319 60.40| 6161 59.27| 5068 60.16
HPV12_L1 - 1,554 bases 61.13 | 7831 7081 61.85 7032 6153 79.11 7823 7677 6182 68.87
HPV13_L1 - 1,500 bases 0.22 09| 6129 6113 7177 61.77 6360 59.84| 6121 61.29| 6097 60.89
HPV14_L1 - 1,557 bases 0s9 o022 039 7202 6411 7258 6282 8427 805 8685 7065 7194
HPV15_1 - 1,524 bases 029 039 028 63.06

HPV16_L1 - 1,518 bases 039 02¢[ 038 039 o031 o028 038 028 036] 037
HPVA7_L1 - 1,524 bases 042 042 029 [ 040 038 030 0217042 040 030] 038 027 049 039
HPV18_L1 - 1,524 bases 031 040 039 030 031 038 030 037

HPV19_L1 - 1,554 bases 028

HPV20_L1 - 1,551 bases
HPV21_L1 - 1,557 bases
HPV22 L1 - 1,333 bases
HPV23_L1 - 1,521 bases
HPV24_L1 - 1,339 bases
HPV25_L1 - 1,554 bases
HPV26_L1 - 1,512 bases
HPV27_L1 - 1,458 bases
HPV28_L1 - 1,509 bases

zle M= =] = =[] =] =] = o 2 2] = | 7 = =[] || = o=

AC  HPV29_L1-1,512 bases
AD  HPV30_L1 - 1,506 bases
AE  HPV31_L1- 1,455 bases

LGLNEIER L r—— B R

~r
]

. The default

X ¥ o AR A
60.08 60.40| 5871 55.81
56.94 5871 64.03 | 90.16
58.63 59.60 69.03 6847
64.19 65.16| 60.08 | 57.58
T702 7637 60.65 57.50
59.19 60.73| 69.35| 67.18
6089 61.21| 6831 64.03
7685 7621 6040 59.11
7185 73.15 6048 56.21
59.19 59.84 69.84 68.15
59.76 60.56 67.58 66.85
7694 7734 5976 58.79
59.52 59.19 68.63 64.92
7798 8419 6121 5879
56.53

2. Click on the Style tab in the upper right of the MegAlign Pro window, then open the Distance section.
Experiment with changing the Values and Presentation settings and observe how these changes

affect the look of the Distance view.

= [Distance =

Distance parameters can be set through the "Distance” menu or view.

Values
Upper right: |%Identih_.r v|
Lower left: | Distance - |

Presentation

Font: |5egue Ul V| |g E| BI
Decimal places: |1Z E|
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3. Open the Distance Parameters dialog by clicking on the Change analysis parameters tool ( &2 ) in
the top right of the Distance view, or by choosing Distance > Parameters.

Analysis Options O >
Metric: |Uncorrected Pairwise Distance V|
Gap treatment: |Gln-bal gap removal V|

Reset to Default Cancel

Change the distance Metric to Tamura-Nei (1993). For greatest accuracy, we recommend using an
evolutionarily adjusted metric such as Tamura-Nei (1993) rather than “Uncorrected Pairwise Distance.
Press OK to recalculate the Distance view using the new settings.

4. Try selecting, copying, and exporting the distance table.

« To select a portion of the table, use the mouse. To select the entire table, use Edit > Select All
or Ctrl/Cmd+A.

* To copy the selected information to the clipboard, use Edit > Copy or Ctrl/Cmd+C. The
information can be pasted into common text or spreadsheet applications.

» To export the distance matrix in your choice of available formats, press the Export data tool (

]—?f) or choose File > Export Data > Distance Matrix.

Proceed to Part E: Change the appearance of the Tree view.
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Part E: Change the appearance of the Tree
view

The Tree view shows evolutionary relationships predicted from the multiple sequence alignment.

1. Click on the Tree tab at the bottom of the MegAlign Pro window. Press Neighbor Joining: BIONJ
and then OK to calculate the tree.

Sequences [ Distance ree

The Tree view is calculated using the current Distance metric which is currently the default value
Tamura-Nei (1993).

I — HPVE3_L1- 1,512 bases
0.062 1 - m} HPV102_L1 - 1,512 bases
— HPVES L1 - 1,509 bases
o TS HPVE2_L1 - 1,512 bases
0.033 - HPVE1 L1- 1,515 bases
0081
2.00:
— HPY72_L1- 1,521 bases
0.037 0.025 I Py HPV51_L1- 1,518 bases
4 =1
HPV85_L1- 1,518 bases
—| 0.034
0.020 e HPFWVET_L1- 1,515 bases
e 001 ] — HPV114_L1 - 1,524 bases
0o - U HPVE4 L1 - 1,512 bases
e HPV27_L1 - 1,458 bases
0.028 u.n'" HPV2_L1- 1,485 bases
0132 =
HPW57_L1 - 1,485 bases
0.08s
HPV106_L1 - 1,521 bases
—— 0.082
0.056 HPW90_L1- 1,518 bases
0054 pos
HPVT1_L1- 1,524 bases
0132
0.021 ! — HPV125_L1 - 1,512 bases
076
— HPV3_L1- 1,515 bases
002 0.065
— HPV28 L1 - 1,509 bases
0033 _I HPW10_L1 - 1,512 bases
- HPV117_L1 - 1,518 bases
| 001 0051
0072 T HPV94 L1 - 1,515 bases
— HPV29_L1- 1,512 bases
0.055 | HPVTT_L1- 1,512 bases
0.069
— HPVES_L1 - 1,512 bases
—l ol
0052 HPY56_L1 - 1,500 bases
0.079
0.062 — HPW53_L1 - 1,500 bases
0.027 | : HPV30_L1 - 1,506 bases
0.081
Im — HPV6S L1 - 1,518 bases
|-| . HPWYT0 L1- 1,515 bases
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Note that the MegAlign Pro tree is always unrooted, regardless of the methods used for the multiple

alignment and distance calculations.

2. Experiment with the settings in the Style panel’s Tree section on the right to see how these changes

affect the look of the Tree view.

= Tree
Layout
= E Y

Leaves

Font: Segoe U
[]Background:

Border Color

v ElB 1

Border width: 2
Branches

Colar Iil
Width: 2

Branch label: Distance

Decimal places: | 3

Change the Layout by clicking any of the four position icons at the top of the Tree section.

* Change the font style and/or size used for the Leaves using the middle drop-down menu and

text box.

» Add a background color for the text, if desired, by checking the Background checkbox, then

clicking on the white box on the right to make a selection from the color picker.

» Change the color of the branches by clicking on the Branches Color box and making a

selection from the color picker.

« Show or hide the branch length by checking and unchecking the corresponding box. While the

box is checked, try adjusting the number of Decimal places.

3. If desired, save the project using File > Save, or by clicking on the Save tool ( E’).

This is the end of the Clustal Omega alignment tutorial.
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Try it! — Perform a MUSCLE alignment with
multi-segment sequences

Sequences that consist of more than one chromosome, contig, or fragment are called multi-segment files.

Suppose you want to string together the consensus sequences from all the contigs in an assembly, or
chromosomes in a genome, or exons in a gene, etc. If you enter these sequences using File > Enter

CG
Sequences or the corresponding button ( ), you will end up aligning the parts to one another. By
entering these sequences into MegAlign Pro using the procedure in this tutorial, the entire set of sequences
in the multi-segment file (or set of files) will instead be treated as an end-to-end concatenation.

Begin with Part A: Add and align multi-segment files.
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Part A: Add and align muIti-segment files

1. If you have not yet downloaded and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. If a MegAlign Pro project is already open, choose File > New Alignment Project > Blank Document.
Otherwise, launch MegAlign Pro.

3. Choose File > Add Sequences End-to-end, or click on the Add sequences end-to-end in project
|

tool (Mdl).

i ™
Add Sequences End-to-end - g

Group name: Default: Group 1

[¥] Add another

4. Click the Add button, then navigate to and open the tutorial data folder Rp7 exon groups. The
nucleotide files in this folder represent the RP1 exons for several mammal species. Each exon
consists of 3-4 segments.

5. If needed, click either once or twice on the file name header to ensure the sequences are in
ascending alphabetical order, as in the image below.
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Mame

|| chirnp.Rpl.exonl.gbk
chimp.Rpl.exon.gbk
chimp.Rpl.exon3.gbk
chimp.Rpl.exond.ghbk
cow.Rpl.exonl.gbk
cow.Rpl.exon2.gbk
cow.Rpl.exon3.gbk
dog.Rpl.exonl.gbk
dog.Rpl.exon.gbk
dog.Rpl.exon3.gbk
human.rpl.exonl.gbk
hurnan.rpl.exond.gbk
human.Rpl.exon3.gbk
hurnan.Rpl.exond. gbk
mouseRpl.exonl.gbk
mouse.Rpl.exon?.gbk
mouse.Rpl.exon3.gbk
mouse.Rpl.exond.gbk
rat.Rpl.exonl.gbk
rat.Rpl.exon. gbk
rat.Rpl.exon3.gbk
rat.Rpl.exond. gbk

EEEENREREEEEEEEEFEEFER

6. Use Shift+click to select only the four "chimp" segments, and then click Open. In the Add Sequences
End-to-end dialog, the files will appear in ascending alphabetical order.

et

Group name: Default: chimp.Rpl.exon

chimp.Rpl.exonl . gbk#Fchimp.Rpl exonl Add...
chimp.Rpl.exon2.gbk#chimp.Rpl.exon2
chimp.Rpl.exon3.gbk#Fchimp.Rpl.exon3 Remaove
chimp.Rpl.exond.gbkZFchimp.Rpl exond

[V] Add another

7. In the Group name text box, replace the default name with Chimp, and then click OK.
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8. Follow steps 3-5 four more times to create separate groups for the Cow, Dog, Human, and Mouse
sequences. In each case, replace the generic Group name with the informal species name.

9. For Group 6, add the rat sequences and replace the default name with Rat, but do not yet click OK.
For demonstration purposes, you will deliberately be ordering these sequences incorrectly.

10. Select the "exon1" sequence by clicking on it once, and then click three times on the Down button
until the sequence appears at the bottom of the list. Similarly, select the "exon4" sequence, the click

twice on the Up button until the sequence appears at the top of the list.

-
Add Sequences End-to-end

Group name: Rat

rat.Rpl.exond. gbk#Frat.Rpl ex?
rat.Rpl.exon3. gbk#Frat.Rpl.ex3
rat.Rpl.exonl. gbk#Frat.Rpl.exd

rat.Rpl.exond. gbkFrat.Rpl .exd Add...

Remowve

=
=]

[ Add anether 0]'4

||

Cancel

el

11. Remove the checkmark next to Add another, and then click OK.

Looking at the Overview, observe that each species is represented by multiple gray blocks of different
lengths. Blue dividers show where one segment ends and another begins.

[ LY I
Unaligned Sequences (&)

2,000

4,000

6,000

1 Rue )
Chimp '-NI' ﬂ
Cow L ﬂ
Dog L ﬂ
Human fll ﬂ
Mouse t’} ﬂ
Rat L

I

12. To make the blocks appear smaller or larger, use the horizontal and/or vertical zoom sliders ().

13. Select Align > Align Using MUSCLE to align the sequences using the MUSCLE algorithm. The
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alignment will likely take several minutes to complete.

14. While the alignment is being performed, try using the View > Console command. This opens a log
showing the progress of the alignment. Before proceeding, close the Console by clicking the ‘X’ in its
tab.

15. Use File > Save to save the project under the name RP1 project.msa.

Proceed to Part B: Replace a sequence in the Overview and view the phylogenetic tree.
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Part B: Replace a sequence in the Overview
and view the phylogenetic tree

In the Overview, look for the longest segment and the longest gap region (shown in gray) in each sequence.
Note that both of these are located on the left for "Rat," and on the right for all the other groups. These clues
indicate that the segments for "Rat" were likely added in the wrong order. (As you recall, these were
deliberately added these in the wrong order in Part A.)

In this part of the tutorial, you will remove the "Rat" group and add it again--this time in the proper order.
You will then re-align the sequences.

1. Single-click on the name "Rat" to select it.

2. Right-click on "Rat" and choose Remove Sequence. When asked to confirm, click OK.

3. Click the black triangle to the right of the Add Sequences to Project tool and select the Add
sequences end-to-end in project tool ( Fl'i'm ).

4. Click the Add button and add the rat sequences again. This time, leave the sequences in ascending
order (exon1, exon2, exon3, exon4).

5. Change the default Group name to Rat, and uncheck the Add another box. Click OK.

Observe that the Rat sequence has been added to a new area of the view called “Unaligned
Sequences.” Click on the expand arrows to reveal the sequence, shown in the image below.
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< *RP1 project.msa i3 =
| L
)
III|IIIIIIIII|IIIIIIIII|IIII|IIII|IIII|III
Ruler O 2,000 4,000 6,000 8,000
N @ Chimp M
Cow :_—-:
I
Dog :__D
Y @ Human P:Z
_I| 11 = |
< Unaligned Sequences (1)
i
III|IIIIIIIII|IIII|IIII|IIII|IIII|I
Ruler U 2,000 4,000 6,000
Rat PII[ :lr:lt )

6. To perform the MUSCLE alignment with the "Rat" group in the correct order, select the name “Rat” on
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the left of the Overview and choose Align > Realign with Selected Unaligned. This command tells
MegAlign Pro to perform a novel alignment that includes all the sequences in the existing alignment
plus the selected unaligned sequences.

Leave the settings at their default values, and choose Align. As before, the alignment will likely take
several minutes to complete.

Once the alignment has finished, note that the gap regions in the Overview now appear more
randomly distributed, and that all six organisms now have the longest block on the right.

Click on the Tree tab at the bottom of the MegAlign Pro window to display the Tree view. Choose the

Neighbor Joining:BIONJ method. In the popup dialog, keep the default values and click OK. The
tree appears, graphically illustrating plausible evolutionary relationships for the seven species.
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I Mouse
1 n.os2
0115 Rat

n.osz

Cow
0115

0009 L Dog

0.083

r— Chimp
Human

0.073

0.1

9. Change the distance metric by choosing Distance > Parameters. Note that the original Metric was
Uncorrected Pairwise Distance. Change the selection to Tamura-Nei (1993) and press OK.

Unlike the Try it! — Perform a Clustal Omega alignment tutorial, where changing the method caused a

visible change in the tree organization, the tree retains the original structure, and has only slight
changes in the branch length.

I Mouse
- { 0.057
0183 Rat
00s7
Cow
+— D124
0018 Dog
0.09s
— Chimp
B.0e0 L Human

0.1

10. Save the project using File > Save, or by clicking on the Save tool ( ).

This is the end of the MUSCLE alignment tutorial.
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Try it! — Perform a genomic alignment with
Mauve

In this tutorial, you will be adding six nucleotide sequences to MegAlign Pro using drag & drop, and then
aligning them with the Progressive Mauve algorithm. Drag and drop is a feature available in all Lasergene
applications, and is useful for entering multiple sequences.

Begin with Part A: Add genomic sequences using drag & drop.



Part A: Add genomic sequences using drag &
drop

1. If you have not yet downloaded and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. If a MegAlign Pro project is already open, choose File > New Alignment Project. Otherwise, launch
MegAlign Pro.

3. Outside MegAlign Pro, use the Windows Explorer or Macintosh Finder to locate and open the tutorial
data folder H. pylori genomes. Arrange and size the file explorer and the MegAlign Pro window so that
you can see both simultaneously.

4. In the file explorer, use Shift+click to select the four files.

5. Use the mouse to drag & drop the selected files onto any "white space" in the Overview or Sequences
view.

The sequences appear in the Overview as solid gray blocks of unequal length, indicating that the
sequences have not yet been aligned.

6. Use your mouse to drag and drop the sequence names (on the left side of the window) so they appear
in the same order as in the image below. This will ensure that your block colors and positions match
those referenced in later sections of this tutorial.

MegAlign Pro - Untitled2.msa SAREN X
File Edit View Align Features Sequences Overview Window Help
T T (GG
O&E O-
<« *Untitled2.msa 2 = O  Trstyle 57 @8 Tracks T8 Features § Places = O
Unaligned Sequences (4) N 2 Overview
L B o e e e e LR R R RS R " P
Ruler 400,000 600,000 800,000 1,000,000 1,200,000 1,400,000 1,600,000 Alignment layout
CP002076 ) Spacing: -
) ¥ Sequences
CP002332 ” * Distance
AED00SLL ) 2 Tree
-
NC_012073 . o —
E |
! L b Leaves 2
[ - =5
" (- @
Unaligned Sequences (4) AE000511
&
L L e L N T R 7T Helicobacter pylori 26695 c
Ruler1 1 10 20 0 40 30 Description:  Helicobacter pylori 26695, complete
CPO02076 taaaacaccctcaattcaagggtttttgagcgagectttttgectcaaagaa * genome.
CP002332 tttaacgctctcaattcaagggtttttgatcgagctttttgctcaaagaaE” Sequence type: DNA
AE000511 tgattagtgattagtgattagtgattagtgattagtgattagtgattagt R:idues: PII,GGT,SGT
MNC_012973 tgattagtgattagtgattagtgattagtgattagtgattagcgattagt ™
< r
~ Properties
E E Accession number:  AE000511 <

7. Use File > Save to save the project under the name H. pylori project.msa.

Proceed to Part B: Perform a Mauve alignment using modified parameters.
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Part B: Perform a Mauve alignment using
modified parameters

In this part of the tutorial, you will explore how to view and change parameters prior to performing a multiple
sequence alignment.

1.

Choose Align > Align Using Mauve and align the sequences using the default parameters. Because
this is a genomic alignment, the alignment will take longer than those done in the first two tutorials
(approximately 5-10 minutes).

After genomic sequence alignment with Mauve, MegAlign Pro displays genomes in the Overview as
Locally Co-linear Blocks, usually abbreviated to "blocks" or "LCBs." Blocks represent multiple-aligned
sections of at least two of the current set of genomic sequences. Discontinuity in numbering is
displayed as a break between blocks. Connecting lines show the correspondence between blocks.
Blocks hanging below the black line, signify that the hanging blocks are on the opposite strand
compared to the other blocks.

| =Y |
U|||||||||||||||||||||||||||||||||||
Ruler 500,000 1,000,000 1,500,000
CPO02076 '
CP002332 Il.lllll |
[ [
< (£ AED00511 . B || [ )
][ e -
..r'- =
NC_012973 D D G

The default settings used in creating this alignment are suitable for most projects, including this one.
However, you will make a change to Mauve’s Seed weight parameter in order to see how this affects
the alignment results.

In Mauve, Seed weight is the minimum weight of the seed pattern used during the first pass of a
multiple alignment. When aligning divergent genomes, lower seed weights may provide better
sensitivity. However, if the value is set too low, the result will be reduced sensitivity. In the following
steps of this tutorial, you will lower the Seed weight slightly, from the 15 (the default) to 13.

Choose Align > Align with Options. This dialog allows you to change methods and/or parameters.
Note that Mauve is already selected in the menu at the top of the dialog, since it is the last method
used.

3. By default, the Default seed weight box is checked, meaning that the optimal seed weight (humber of
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matches required per k-tuple) is calculated automatically. Uncheck the box and either use the slider to

change the Seed weight to 13, or type 13 in the Seed weight text box.

5ok

-
Align Sequences

Align: ’AH aligned sequences v]

Using: ’Mau'.re "] @

Mauwve options
Default seed weight

(]

Seed weight: 13

Uze seed families
Min LCB weight:  Default

I Align I ’ Cancel

4. Choose Align to perform the Mauve alignment again using the selected parameters.

Proceed to Part C: View a genomic alignment in the Overview.
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Part C: View a genomic alignment in the

Overview

Once the alignment has finished, notice how the Overview has changed in response to the parameter
change, including changes to the colors of the blocks, and differences in which blocks are hanging below
the line (i.e., on the opposite strand).

1. Locate the medium-width block whose right edge is close to the 1,000,000 mark on the ruler. The
block will not necessarily be gold, as shown here, but the location should match the location of
checkmarks in the image below. Double-click on the block in any row to make it the active block.

Ruler

CPO02076

CP002232

AED00511

MC_012973

600,000

800,000 1,000,000

1,200,000 1,400

Observe that the active blocks are now in a single, highlighted column, with each block having equal
width. The viewport is located on the left-most end of the blocks.

1,000,000
=
= =
 —"
Y ——

Notice how genome NC_012973 flipped in orientation when the new block was made active. To allow
this genome’s active block to match the orientation of the active blocks in other rows, MegAlign Pro

automatically reverse-complemented all the blocks on the opposite strand.

2. In the Overview, slide the viewport to the right edge of the active blocks. You can use the horizontal
green slider above the view to expand this area so you can see it more clearly.
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3. Use either set of scroll arrows to center the Sequences view on the right edge of the active block, as
shown below. (The exact location of the edge may differ from that shown in the image). Observe that
residues outside and to the right of the active block are shown in a dimmed/dull version of the color

scheme.
< “H. pylori proj b = 8
"
Ruler 1,060,000 1,080,000 1,100,000 1,120,000 1,160,000 1,180,000 1,200,000 1,220,000

@l CP002076

T

@l CP002332

@l AED00511

1h 4000 1160000
X

@l NC_012973

[ overien——

Rulerl

LI e e LI e
- 1,138,440 1,138,450
(2 Consensus

(&) CPD02076
(&) CPD02332
(&) AED00511
(&) NC_012973

,Z]CGCC;HAH?AEHEHEAME 1T E

T
1,138,440 1,138,450 1 138 460

Sequence Logo

Ruler 2

4

Right edge of
active block

R Cosmee |G

4. Select View > Style > Overview to open the Overview section. Experiment with changing the

parameters.
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T Style 7 8 Tracks () Features = B

|; Owverview

Presentation

Spacing: - D
Font: ISEQ oe Ul - 9 =
[] Track names font:

Segoe Ul 9

Multiple block display
Show connecting lines

Reference: ’CPDUZU?& -

. o To increase/decrease the amount of white space between rows of blocks, use the Spacing
slider. Unlike the zoom in/out sliders, this setting affects only the white space between the
blocks, and does not affect the sizes of the blocks.

o Change the font and font size. If you wish to change the track names font, check the box to
enable changing the font and size.

o To toggle between displaying or hiding the lines connecting blocks from one row to another,
check or uncheck the Show connecting lines checkbox.

o |If you select a different Reference, change it back to CP002076 before you are finished.

Proceed to Part D: View the phylogenetic tree.
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Part D: View the phylogenetic tree

* Note: The images in this section show examples of how the trees might appear. Your trees
may have different arrangements or different branch lengths from the ones shown.

1. The current names of each sequence originated from the accession numbers that were embedded in
the input files. Before viewing the phylogenetic tree, you can change these names to show the
organism from which each sequence originated:

a. Use Ctrl+A or Cmd+A to select all of the sequence names.

b. Right-click on the highlighted group and select Rename with Fields, or choose Edit > Rename
with Fields from the main menu.

c. Select Default name from the right pane and click the left arrow (blue) to remove it. Then select
Organism from the left pane and click the right arrow to add it. Click OK.

The sequence labels now reflect the species names:
Helicobacter pylon Cuz2(
Helicobacter pylori Garmnbia94,/24 (Helicobacter pylori Gam34,/24)
Helicobacter pylori 26635

Helicobacter pylori B38

2. To display the Tree View for the active blocks, click on the Tree tab at the bottom of the MegAlign Pro
window.

Sequences Hﬁﬂistance ] ree

The contents of the Tree view (and also the Distance view) are specific to the currently selected block
only.
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Helicobacter pylon Gambia®24/24 (Helicobacter pylon Gam94/24)

Helicobacter pylon 26695

Q035
— Q021
QU003
0030
om0 Helicobacter pylori B38
_
0.0

Helicobacter pylon Cuz20

3. In the Overview, double-click on different blocks in the Overview and see how the branch lengths, or
(sometimes) the tree itself, change.

4

0031

Helicobacter pyleri Gambia94,/24 (Helicobacter pylori Gam94,/24)

0024

Helicobacter pylor Cuz20

0021

0018

Helicobacter pylori 26695

Helicobacter pylori B38

4. To order sequences in the other views so they match the tree, select Tree > Order sequences like

tree.

5. If desire, save the project using File > Save, or by clicking on the Save tool ( E ).

This is the end of the Mauve alignment tutorial.
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Perform a Pairwise Alignment

This application supports local, global and semi-global pairwise alignment methods. Pairwise alignments
can only be performed when two sequences, and only two sequences, have been selected. A common
workflow is to first perform a multiple alignment on an entire group of sequences. From the resulting Tree
view, two closely related sequences can then be further analyzed by selecting them and performing a
pairwise alignment.

Pairwise alignment tutorials:

The following tutorials use free data that can be downloaded from the DNASTAR website:

e Try It! — Follow a multiple alignment with Global pairwise alignments
o Try It! — Align transcripts to genes using Local and Global pairwise alignments
e Try It! — Use a Local pairwise alignment to find a gene within a genome

To perform a pairwise sequence alignment:

1. Decide which two sequences you want to align. The sequences can be any length (DNASTAR has
successfully aligned protein sequences up to 35,000 bases in length), but both must belong to the
same category: DNA/RNA or protein. If one sequence is significantly longer than the other, use drag &
drop in the Sequences view or Overview to organize them such that the longer sequence is above the

shorter sequence.

2. Select the two sequences and choose Align > Pairwise or right-click on the selection and choose
Align Pairwise. Dialog options vary depending on whether protein or nucleotide sequences were
selected. An example is shown below.
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Align Pairwise

Align: ’The two sequences in this view

Using: lﬁemi-glﬂhal.' Meedleran-Wunsch v] @

Semi-global: Needleman-Wunsch options

-

=

3. Use the Align drop-down menu to specify which sequences to align.

Substitution matric |BLOSUM *|®
Gap open penalty: 10 =
Gap extension penalty: 1 =
[] Require minimum word match:
Reset to Default ] ’ Cancel

4. In the Using drop-down menu, choose the desired pairwise alignment method:

* Global alignment, represented in MegAlign Pro by the Global Needleman-Wunsch algorithm,
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includes the full length of both sequences, even if this requires padding one or more of the
sequence ends with gaps. MegAlign Pro considers overhangs and underhangs created this way
as unaligned context. One example of a situation where a global alignment is preferred over a
local alignment is when there are multiple, but disjoint, segments of aligned sequence.
Examples when a global alignment is a good choice: 1) aligning a CDS or mRNA sequence to a
gene that contains introns; 2) aligning two sequences that differ because of the presence of
large insertions, such as might be caused by transposable elements. In both cases, a local
alignment is less likely to reflect the full alignment, especially if the lengths of the unalignable
inclusions are long relative to the gap extension penalty.

Semi-global alignment, represented by the Semi-global Needleman-Wunsch algorithm, is
similar to global alignment, except the gaps placed at the ends of sequences are not penalized.
A semi-global alignment might be more useful than global alignment in situations where long
leading/trailing gaps might be suppressed in favor of a result that contains segments of aligned
sequences punctuated by gaps.

Local alignment, represented by the Local Smith-Waterman algorithm, reports the highest
scoring contigous segment of alignment between two sequences, even if the full extent of one
or both of the sequences is not included in the final alignment. Local alignments are ideal for
finding a short sequence within a larger sequence. Flanking segments of sequences that are
not within the aligned segment can be visualized in MegAlign Pro by checking the Show
context box in the Pairwise Alignment section of the of Style panel.
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See this page from Trinity College-Dublin’s Department of Genetics for a good synopsis of
Needleman-Wunsch vs. Smith-Waterman algorithms.

Note: When two sequences are nearly identical (check by performing a multiple alignment and
consulting the Distance view), all pairwise methods should work equally well.

5. Use the drop-down menu(s) to choose the Substitution matrix and related options, if any

6. Specify the Gap open penalty, the amount deducted from the alignment score for each gap in the
alignment. Gaps of different sizes carry the same penalty. Default is 10.

7. Specify the Gap extension penalty, the value which will be deducted from the alignment score after
first multiplying it by the length of gaps. Longer gaps have a greater penalty than shorter gaps.
Default is 1.

8. If you wish to specify the length of the smallest perfect match of contiguous bases/residues to
consider in building an alignment, check the Require minimum word match box and enter a value.
The default is unchecked; if checked, the default value is 7.

9. Press OK.
During the alignment, MegAlign Pro displays a progress window. In most cases, this will appear and
disappear too suddenly to notice it. In the cases of longer alignments, you can interrupt the

alignment, if necessary, by clicking its Cancel button or view a console window showing the start time
and progress of the alignment by clicking its Show Console button.

If an alignment finishes successfully, a Pairwise view opens. If an alignment fails, you will receive a
message with recommendations on how to obtain a successful alignment (e.g., by modifying options

or choosing a different alignment method).

10. (optional) If the Console is not already open, and you wish to view alignment statistics and other
information there, select View > Console.

* Note: Pairwise alignments are not saved when you save or close a MegAlign Pro project.
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Comparison of pairwise alignment methods

The three types of alignment—Local, Global and Semi-Global—are actually quite similar, although they can
often produce very different results. All use a method called dynamic programming to find the best scoring
alignment between two sequences. Alignment scores are computed by adding up per-base match scores
and subtracting a penalty for opening a gap (of any length) and another for the number of positions that
have gaps. The match scores are based on a scoring matrix such as NUC42 or BLOSUMG2. It’s always a
good idea to explore the effects of various settings of these three parameters to see if you can get a more
desirable outcome.

Depending on your two sequences, the three methods can potentially yield widely different results, so it's
important to understand how they differ.

Local Pairwise Alignment:

MegAlign Pro’s local alignment algorithm, a modernized variant of the one described by Smith-Waterman
(1981), is designed specifically to find the highest scoring aligned segments of two sequences, even if the
full extent of the two is not included in the final alignment. (Note: in MegAlign Pro, the “Show Context”
check-box in the Style Panel lets you display any unaligned parts of the sequences flanking the aligned
segments).

Global Pairwise Alignment:

The alternative to locally aligning is to align globally. To do this MegAlign Pro uses two variants of the
Needleman and Wunsch (1970) algorithm. Global aligners don’t try to find the best scoring segment, but
instead require that the full extent of both sequences be included in their results. There is no requirement or
guarantee that the best scoring pair of aligned segments from a local alignment will be aligned in a global
alignment.

Semi-Global Pairwise Alignment:

Semi-global alignment is a relatively new approach that is particularly suitable when the two sequences
differ greatly in length. When that happens, the longer sequence will have overhangs on either end of the
alignment. Since overhangs are represented with gaps, a global aligner will attempt to increase the match
score and minimize accumulated gap penalties by aligning parts of the shorter sequence to overhanging
sequence region(s). This effect can produce a number of unrealistic, usually small aligned segments spaced
by gaps near the ends of the alignment. Semi-global alignment is designed to address this problem by not
penalizing gaps in overhangs (aka “end gaps”).

The differences between these three pairwise approaches really can make an impact in the resulting

alignment, but the choice of which to use really depends on your task. For basic cases, such as aligning two
genes or proteins, Local alignment is a good starting point, but when things get more complicated, Global or
Semi-Global may be the way to go. We have included three tutorials to demonstrate some of the differences
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between these methods.

e Try It! — Follow a multiple alignment with Global pairwise alignments

e Try It! — Align transcripts to genes using Local and Global pairwise alignments

 Try It! — Use a Local pairwise alignment to find a gene within a genome
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A substitution matrix describes the rate at which a nucleotide or amino acid changes to another nucleotide
or amino acid over time. When performing a pairwise alignment, you can specify the desired substitution

matrix in the (Pairwise) Alignment Options dialog.

Available matrices for nucleotide sequences:

Matrix Description

DNASTAR’s modified version of NCBI's NUC.4.4 algorithm, the modification being that U is treated as
a synonym of T. In NUC44, exact matches, and T:U matches score as 5, and mismatches between
unambiguous bases [G A T C U] score as -4. Matches between bases and ambiguous symbols [S W
RY KM B V H D NJ] have intermediate scores. A base versus a 2-way ambiguous category [RY W S

NUC44
scores as -4.

K M] to which it belongs scores as +1, and a mismatch to a 2-way group to which it doesn’t belong

Example: Cis in [S R M] but notin [W Y K] . The 3-way groupings are [B V H D] where C is in all but
D (which means not C). Therefore, C vs [B V H] scores as -1 while C vs [D] scores as -4.

Available matrices for protein sequences:

Matrix Description

(Henikoff & Henikoff, 1992). These
BLOSUM matrices are ideal for carrying out

similarity searches.

Derived from PAM matrices (Dayhoff et
GONNET al., 1978) but more sensitive, and based

on a much larger data set.

Scores two identical amino acids as 1, and
IDENTITY _

anything else as -10,000.

Scores two identical amino acids as 1, and
MATCH .

anything else as -1.

(Dayhoff et al., 1978). Widely used since
PAM

the late 1970s.
VTML Derived from PAM matrices (Dayhoff et

al., 1978) by Muiller T et al. (2002), .
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Secondary option

Available matrices range from 30-100, and are
provided in increments of 5 and 62. Choose larger
numbers for less divergent sequences.

(Unchangeable default of 250)

N/A

N/A

Available matrices range from 10-500, and are
provided in increments of 10. Choose larger numbers
for more divergent sequences.

Available matrices range from 10-500, and are
provided in increments of 10.
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o¥s Notes:

+ BLOSUM, PAM, GONNET, IDENTITY, and MATCH are part of NCBI's BLAST distribution. For more
information, see NCBI’'s matrix page.

* The PAM, GONNET and VTML numbers are based on the presumed millions of years of divergence.

* In BLOSUM, the matrix number is proportional to the presumed degree of similarity. Therefore,
BLOSUM100 would be the preferred matrix for near-identical sequences.

* VTLM and GONNET are considered to be updated versions of PAM250.
* In BLOSUM, PAM, and GONNET, match/mismatch scores vary with the series number. Also exact

matches vary with the particular amino acid. For example, BLOSUMS30 scores W:W as 20 and S:S as
4. BLOSUM100 scores these as 17 and 9, respectively.
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Try It! — Follow a multiple alignment with
Global pairwise alignments

This tutorial demonstrates a situation in which a pairwise alignment can help resolve a confusing placement
of gaps within a multiple alignment. In this case, a multiple protein sequence alignment suggests that the
protein sequence from a specific organism (Tupaia chinensis, the Chinese tree shrew) is severely truncated
at its C-terminus and ends with a run of 27 residues that seem to be unrelated to the other members of the
alignment, including a relative (Sorex araneus, the Eurasian shrew). A pairwise global alignment of the two
shrew sequences, however reveals that a more likely interpretation is that the T. chinensis sequence
contains a deletion of 235 residues followed by a terminal stretch of 32 amino acids that is nearly identical
to that of the S. araneus sequence. Here the pairwise alignment suggests that first-pass multiple sequence
alignment is not optimal. Armed with this information, you can try changing the alignment engine and gap
penalties to see if a more reasonable result can be achieved. Another technique that might help is to use
sub-alignments to refine the overall multiple sequence alignment.

This example also demonstrates the power of using pairwise and multiple alignments together to help
interpret specific relationships between sequences that might have become obscured by gaps which were
added during the multiple alignment process. With MegAlign Pro, it is simple to generate many pairwise
alignments without ever having to disturb the multiple sequence alignment, which has the larger picture.
This is far more convenient that starting over with several different documents.

To perform the analysis:

1. If you have not yet downloaded and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. Double-click on the Angiomotin_vertebrates.clustalo.msa project file to launch it in MegAlign Pro.

This project contains a collection of Angiomotin proteins from a diverse set of vertebrate species,
already multiply-aligned with Clustal Omega. The figure below shows the alignment with the
Sequences view and QOverview scrolled to show the two tree shrew sequences. For more detail, you
can expand the image below by clicking on it.
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Notice that the Tupaia sequence (the lowermost item on each list) seems to end abruptly with an

unaligned run of amino acids. If you can’t see the abrupt end, move the Sequence view’s green
horizontal zoom slider to the left until the Sequences view appears as in the image above.

To investigate this using pairwise alignment, click on the name of the Tupaia sequence to select it,

and then Ctrl-click (Win) or Cmd-click (Mac) on the name of the Sorex sequence to add it to the
selection. You can select these sequences in either the Sequences view or the Overview.

Right-click on either name and select Align Pairwise.

In the Align Pairwise dialog box, select Global: Needleman-Wunsch from the Using drop-down

menu. Since you are specifically interested in the C-terminal ends of the sequences, the Global

option is ideal.

Pairwise view will appear.

Keep the default settings for all other dialog options and click OK. The alignment will run and a

Scroll down the Pairwise view to the end of the alignment and notice that it is now clear that the

Tupaia sequence contains a large deletion and that the C-terminal ends of the two shrew sequences

are nearly identical.
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Pairwise alignments can also be used to help interpret multiple alignments with gaps that might
obscure the relationships between sequences. While the Pairwise view is still open, try some Global
alignments between different species pairs. This is easily done by changing the sequence(s) in the
drop-down menus at the top of the Pairwise view.

9. Change the sequence in the right drop-down menu to to Homo sapiens (human).

10. Scroll through the updated alignment and observe that the two sequences match pretty well, despite
some mismatches and gaps. The header shows a similarity calculation (Similar) of 91.3.

11. Change the sequence shown in the left drop-down to Pan troglodytes (chimpanzee). The human and
chimp sequences are 98.4% similar, with only an11-residue gap differentiating them. This similarity
can be seen with a much greater degree of clarity than could be seen looking at the Overview of the
original multiple alignment. (Click on the image below to expand it.)

Align: |Serex araneus (Eurepean shrew) x| with [Tupaia chinensis (Chinese tree shrew) =l @ BT
Global: Needleman-Wunsch Protein alignment [Matrix: "BLOSUMG2™ Gap penalty: 10 Gap extension penalty: 1]
Sorex araneus (European shrew) Tupaia chinensis (Chinese tre... Gap Gap
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Try It! — Align transcripts to genes using
Local and Global pairwise alignments

This three-part tutorial illustrates the utility of pairwise alignments when comparing mRNA transcripts to their
cognate genes. This example begins with multiple alignments of the alcohol dehydrogenase (ADH) gene
from Drosophila melanogaster and four mRNA transcript isoforms. Comparing the overview of the alignment
to the gene’s annotations reveals a few problems that are easily resolved with pairwise alignments.

As in Try It! — Follow a multiple alignment with Global pairwise alignments, a global alignment is the most

suitable approach, because long gaps corresponding to introns may make it hard for a local aligner to join
segments from exons. With a local alignment the ends of a transcript may not be included among the
aligned segments.

Start with Part A: Compare results from three multiple alignment methods.
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Part A: Compare results from three multiple
alignment methods

This part of the tutorial demonstrates that if you don’t have annotations to rely on for validating multiple
alignments, a pairwise alignment is a good alternative.

This tutorial uses a default MUSCLE alignment of the Drosophila melanogaster ADH gene and the mRNA
transcripts for isoforms F,C,E and H. In this example, some of the annotations of the original GenBank

entry, NT_033779.5, were removed for the sake of clarity.

To beqin the analysis:

1. If you have not yet downloaded and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

2. Double-click on the DmADH.muscle.msa project file to launch it in MegAlign Pro.

The Overview for this alignment is shown in the image below. (Click on the image to make it larger.)

Broel ADH e —
Features
e —— - et
C et i
[ o — et
| — e
-tV
Sequence Ruler 500 1,000 1,500 2,000 2,500 3,000
E— I/ B
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In this example, the transcripts, represented by the four lower sequences, have already been
arranged in the same vertical order as the mRNA-features for the ADH gene, represented by orange
arrows in the upper sequence.

3. Hover your mouse over some of the orange mRNA features and verify that they are in the same order
as the transcripts represented by the lower four sequences.

As expected, there is a good correspondence of the aligned regions of the transcripts to the exons of
the gene. But a closer examination reveals a few problems, one of which is indicated by the red
boxes in the image above. Notice that that isoF and isoC are annotated to code for Exon | (box A),
which matches the multiple alignment result. However the 5’ end of isoH and isoE are also aligned,
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somewhat poorly, to this exon. How can you tell? Note that there are only two yellow arrows in box A,
but there are green bars in all four transcript rows for box A, the bottom two of which are much
sparser than the others This part of the lower two transcripts — which have no corresponding yellow
arrows — should really have aligned with the start of Exon Il (box B).

As a reminder, the example above used the MUSCLE alignment method. Before testing whether or
not pairwise alignment can resolve this problem, check out how some of the other three multiple
alignment engines handle these particular sequences.

4. Multiply realign the sequences using Clustal Omega (Align > Realign Using Clustal Omega).

5. Examine the alignments of transcript sequences to the first two exons of the gene’s sequence. In this
case, there are no green bars at all in box A.

6. Realign again, this time using MAFFT (Align > Realign Using MAFFT). For this example data set
only MAFFT gives a result that is consistent with the annotations. (Click on the image to make it
larger.)
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Proceed to Part B: Use a Local pairwise alignment method.
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Part B: Use a Local pairwise alignment
method

Now that you have finished Part A of the tutorial, this part shows how you can use a local pairwise
alignment to resolve the correct mapping of the first intron in isoF and isoC.

1.

Click on Pairwise view tab. Look at the left drop-down menu at the top of the view to see that the
uppermost sequence (Dmel_ADH) has automatically been selected as the reference.

In the right drop-down menu, choose "isoF-NM_001022098.2". | The default Local: Smith Waterman
method is used to create the alignment

To make sure all features will be displayed:

a. Open the Tracks side-panel.

b. Under Pairwise details, click once on the word Features.

c. Move the Height slider to the right until you can see all the feature rows.

In the Pairwise view, click on the plus-sign icon next to the name Dmel_ADH to reveal the Features
and Sequence Ruler tracks.

A correct alignment would show the 5’ end of the isoF sequence aligned with the two orange arrows
that begin at the very start of the Dmel_ADH sequence. Instead, however, the beginnings of both the
ADH reference sequence and the mRNA are shown as dimly colored context; in other words, as
unaligned flanking sequence.

Ruler

Features Adh

Adh T T T Y T | I
ccaacaagaacgtgattttcgttgce

Adh Instead of the normal
coloration, shown above,
these residues are "dimmed"

.
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| [ | | | L1 L |

. L L L L L L L PR I A
(=) Dmel_ADH catgcattattgtctcagtgcagttgtcagttgecagttcagecagacgggctaacgagtacttgecatctettcaaattt

()isoF-NM_001032088.2

Scrolling down through the alignment observe that the 5’ end of the transcript sequence has aligned,
albeit poorly, with a region beginning within the first intron. Meanwhile, a solid ungapped alignment
doesn’t start until 5’ end of the second exon annotated for either isoF or isoC. (See the boxed area in
the image below.)
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Clearly, a local pairwise alignment was not an improvement over the first two multiple alignments tried in
Part A.

Most likely, introducing a sufficient number of gaps to span the intron would reduce the score so much that
the aligner can find a higher scoring segment that contains numerous short gapped regions.

Proceed to Part C: Use a Global pairwise alignment method.
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Part C: Use a Global pairwise alignment
method

Since the Local pairwise alignment in Part B was not an improvement over the multiple alignments in Part A,
you will now try a Global pairwise alignment. This type of alignment forces the ends of both sequences to be

aligned.

1. Click the gear icon on the Pairwise view toolbar and select Global: Needleman-Wunsch from the
“Using” drop-down menu. Then press Align.

2. After aligning, the display options that you set above remain in effect, but the sequences’ detail tracks
will collapse. Expand the Dmel_ADH track again by clicking on its plus sign.

3. To see the “big picture,” zoom all the way out using the green “zoom slider” above the view. The
pairwise alignment now appears similar to the Overview. You can see that the global alignment using
isoF matches Dmel_ADH'’s annotations. (Click on the image to expand it.)
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MegAlign Pro allows you to open additional pairwise views so that you can compare alignments with
different settings, or even different pairs of sequences. You can use this to compare any of the other
three mRNA sequences to Dmel_ADH, while leaving the previous alignment untouched.

4. Clone the current Pairwise view using the "Clone this view” tool situated at the far right side of the
toolbar. The two views will start out the same, but they are completely independent.

5. Select isoE-NM001032099.2 as the query sequence, keeping the reference sequence set to
Dmel_ADH. The new Global pairwise alignment now gives the expected results.

This is the end of the tutorial.
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Try It! — Use Local pairwise alignment to find
a gene within a genome

Consider the case of a researcher who is trying to investigate the role of a gene isolated from a yet-
unsequenced Salmonella strain. This strain has already been demonstrated to be both copper and multi-
drug resistant. As demonstrated in the following tutorial, one way to proceed would be to align the sequence
of the uncharacterized gene to the genome of a related reference strain. If a reasonable alignment was
found, the annotations of the matching segment could then be examined to infer the function of the cloned
gene.

* Note: To align the large genomic data set used for this tutorial, we recommend using a
machine with a minimum of 8 GB — and preferably 16 GB — of RAM.

To perform the analysis:

1. If you have not yet downloaded and extracted the tutorial data, click here to download it. Then
decompress (unzip) the file archive using the method of your choice.

1. Double-click on the Salmonella_CT18_plus_gene.msa project file to launch it in MegAlign Pro.

The document contains just two unaligned sequences: the genomic sequence of reference strain S.
enterica serovar Typhi, strain CT18, and the unknown sequence.
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2. Select both sequences, right-click on the selection, and then select Align Pairwise from the context
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menu.

3. In the ensuing dialog box, note that the default pairwise alignment method is Local: Smith-
Waterman. Since this method is the best choice for finding a small segment of similarity within a
larger sequence such as chromosome, keep the default settings and click the OK button. (Note: If any
long gaps were needed for alignment, you could always realign later using lower gap penalties.)

This is a good time to discuss the concept of "reference" (or "target") sequence versus the "query"
sequence. In MegAlign Pro, these two sequences are defined through the two drop-down menus at
the top of the view. The left menu should be used for the reference, and the right menu for the query
sequence. Most of the time, the sequence selected to be the “reference” is somewhat arbitrary.
However, when one sequence is much longer than the other — as in this example — the longer
sequence should be used as the reference.

After the alignment has completed, the Pairwise view header indicates that the 706 bp query matches
a 702 bp segment in the CT18 genome with 98.6% ldentity and has 1 gap that is 4 bp long.

Local: Smith-Waterman DMNA alignment  [Matrix: "NUC44"  Gap penalty: 10 Gap extension penalty: 1]

MC_003198.1 (CT18) unknown Gap Gap
1=4800037 1=706 Yeldentity %Gaps |dentical Count Length Score Length
Alignment 278279>2798980 1=7086 08.6% 0.6% 608 1 4 3,443 706

4. Scroll down through the alignment until you locate the gap, which begins at alignment position 452.

—
440 450 480

ilatgecgetgegtpg----gtatgtatgtatacag

LTt Pt ettt
latgecpgetgegtggtatgtatgtatgtatacang

—
470

Notice that the gap is shown within the reference, indicating that there is a 4 bp insertion in the
unknown sequence. Since the insertion length is not a multiple of three, the gap most likely
represents a frame-shift in the unknown sequence.

5. In the Tracks side panel on the right, locate the Pairwise Details section and check the box next to
Translation.
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6. Returning your attention to the Pairwise view on the left, open the tracks for the unknown sequence

by clicking the plus sign corresponding to that sequence.

The translation tracks (labeled 1, 2, 3) clearly indicate that the frame-shift has introduced an in-frame
stop beginning at base 530 of the query sequence (red box in the image below). In other words, it
represents a nonsense mutation. This is good evidence that this is indeed a mutant gene compared
to the non-drug resistant reference strain.

I I I
520 530 540
gccpggtecgecagtaacgececcagett
Frrrrrrrrrer et rrrrild
geEEcggtegeesa cgeccecagett
T T T
520 530 540
A G R Q . R P A

To find more clues to the identity of the unknown gene,you will next investigate the CT18 reference
sequence annotations at this position.

Collapse the tracks for the unknown sequence by clicking on any of the minus signs corresponding to
that sequence.

8. Expand the detail tracks for the reference (CT18) by clicking any of the corresponding plus signs for

that sequence.
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Observe that the indel’s position overlaps a gene and a CDS that are identified as STY0266.

9. Click anywhere on the STY0266 feature to select it.
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STYDZ266

Salmonella enterica subsp. enterica serovar Typhi str. CT18

STYDZGE6

79,780 279,790 279,800 279,810 279,820 279,830 279,840
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10. Examine the annotations for STY066 in the Details panel. If the Details panel is not visible, reveal it
using View > Details.

@ Details 53 i
STY0266 @
Type: gene

Left: 279,278
Right: 279,980
Length: 702

+ Location
279279=279980
+ Properties

gene_synonym: cutF
locus_tag: STYOD2E6
db_xref: GenelD:1246754

» Actions

Select Subseguence
You can also double-click on this feature.

As shown in the Details panel, the gene sequenced from the unknown, copper-resistant strain is a
defective version of cutF (also called nlpE) which encodes a copper homeostasis protein that has
been shown (Nishino, et al. 2010) to be associated with elevated multidrug and copper resistance in
E. coli.
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thlogenetic Trees

MegAlign Pro lets you create and display one or more phylogenetic trees for a multiple alignment. The trees
can use different algorithms, or the same algorithm with different settings. To learn more, see the following
topics:

* Generate a phylogenetic tree
> Advice on choosing the best tree for your data (DNASTAR blog post)
* Get to know the Tree view
+ Work with multiple trees
+ Change the look of the tree (fonts, colors, decimal places shown, etc.)
* Reroot a tree

* Import a Newick-format tree
» Export a tree to a tree viewer
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Generate a phylogenetic tree

To generate a new phylogenetic tree:

. Add sequences and perform a multiple alignment.

Use any of the following methods to direct MegAlign Pro to create a tree using the algorithm you
specify. For helpful advice on choosing the best tree for your data, see this December 2020
DNASTAR blog post by Brian Walsh, PhD.

» Click on the Tree tab to open the Tree view. Choose one of the two available tree-building
algorithms.

> g

Meighbor Joining: BIOMN) Maximum Likelihood: RAxhL

> Neighbor joining: BIONJ uses the BIONJ algorithm (Gascuel, 1997, a variant of the
Neighbor-Joining algorithm (Saito and Nei, 1987) that was used in classic MegAlign.

o Maximum likelihood: RAxML was developed by Stamatakis (2014). Comprehensive
information about options associated with this algorithm can be found in the RAxXML
Manual (PDF).

* In the Trees section of the Explorer panel, press the green plus-sign tool (ﬁ) to the right of the
table. In the Using drop-down menu, select the desired algorithm.

+ Use the menu commands Tree > Compute Phylogeny Using > Neighbor Joining:BIONJ or
Tree > Compute Phylogeny Using > Maximum Likelihood: RAXML. Choose Maximum
likelihood (RaxML) if your data set is divergent, if it contains many taxa and/or very long
sequences, or if you need support (bootstrapping) values. To see support values, you need to
check bootstrapping in the parameters dialog. If bootstrap value is 50% or below, it's a coin flip,
most use 70% cutoff to trust phylogenetic analysis data. Choose Neighbor joining: BIONJ if
your project includes fewer than 4 sequences, the minimum needed to use Maximum
likelihood (RaxML).

3. Customize settings based on the algorithm you chose.

* If you chose Neighbor joining: BIONJ:
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Compute Phylogen O >
P ylogeny

Mame: | Tree 1

Using: | Neighbor joining: BIOM) ~

Reset to Default QK Cancel

o Type in a new Name for the tree or keep the default name of Tree <number>.

> |If you change your mind and want to use the other algorithm, choose it from the Using
drop-down menu.

o Press OK to generate the tree.

» If you chose Maximum Likelihood: RAxML:

Compute Phylogen O >
P ylogeny

Mame: | Tree 1

Using: | Maximum likelihood: RAxML ~

Maximum likelihood: R&xML options

Options: [] Bootstrap analysis

Seed: |DEfau|t:—15';'._'C';'5 0eE7112958 | | Choose

Threads: | 2 =

*

Reset to Default Cancel

o Type in a new Name for the tree or keep the default name of Tree <number>.

o If you change your mind and want to use the other algorithm, choose it from the Using
drop-down menu.

o To add a bootstrapping step to the calculation, place a checkmark next to Bootstrap
analysis; if you do so, another option appears. Type in the number of Iterations or keep
the default value of 100.

o Keep the default Seed value, type in a new integer, or select Choose > Random to enter
a random value in the box.
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o Enter the desired number of Threads. The default value is 2.

o Press OK to generate the tree.

4. (optional) Use the Style panel’'s Tree section to customize the tree as desired.

5. (optional) Create another phylogenetic tree using a different algorithm or different settings for the
same algorithm. See Work with multiple trees.
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Try it! — Determine the strain of an
experimental viral genome sample

In this tutorial, you will use MegAlign Pro to compare an experimental SARS-CoV-2 sample to references
sequences from four SARS-CoV-2 strains in order to see which strain is present in the sample. This type of
analysis can be used with any viral genome samples that have been sequenced and assembled into an
accurate draft genome by your sequencing core.

1.

7.

Download the tutorial data and extract it to any convenient location (i.e., your desktop).

Launch MegAlign Pro. From the Welcome screen, choose New blank alignment project.

Use File > Add Sequences to add the four (known) COVID-19 variant .fasta files and the
experimental Spike-var.fasta sample from the tutorial data folder.

If a popup asks the file type, specify the sequences are DNA.

Use Align > Align Using MAFFT to perform a multiple alignment. The alignment will finish in 1-2
minutes.

. To generate a phylogenetic tree, click the Tree tab at the bottom of the view. Select Maximum

Likelihood: RAXML. Keep all defaults and press OK. The tree will take 1-2 minutes to generate.
Once the tree is displayed, move the green slider at the top of the Tree view all the way to the right to

better differentiate the branches. There are four strains represented, and these may appear in any
order as you scroll down the tree.

Reference group name SARS-CoV-2 strain

B.1.1.7 Alpha
B.1.351 Beta
B.1.617.2 Delta
C.37 Lambda

Differentiate the strains even more by applying a different background color to sequences from each
strain. To do this:

a. Inthe Tree view, select all members of a strain by clicking the horizontal root anchoring its
clade.

b. Choose View > Style > Tree to open the part of the Style panel that controls the appearance of
the tree.


https://star-deploy.s3.amazonaws.com/SupportingDataFiles/LG+17.3/SARS-CoV-2+tutorial+data.zip
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c. In the Style panel, click the Background box to add a checkmark, then click the white box to

the right to choose a new shade from the color chooser.

Welcome & “*Untitled1.msa i3 = O
| Tree1 59 of 238 aligned sequen & @ ”?’ (S = @ a8 = i3 |
I S—

I

0.000
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In the image below, the Beta strain was assigned a green background and the Delta strain was
assigned a salmon background.

8. Inthe Tree view, locate SRR13380669_NC _045512.2, the experimental draft genome that you added
as Spike-var.fasta from the tutorial data folder. Note that this strain is a close relative of the “Beta”
strain, which was first noted in South Africa in January 2021.
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0.000

—— 5SRR13380669 NC_(45512.2
0.000

9. To confirm this observation, open the Distance table by clicking the Distance tab at the bottom of the
window. Select the experimental sample row, SRR13380669_NC_045512.2 (typically the bottom-most
row), then choose Distance > Order Sequences by Distance from Selection.

10. The lower-left triangle of the table shows distances between sequences, with white being most related
and dark red being least related. Note that all visible distances in the visible portion of this triangle are
“0.00.” To see differences between the sequences more clearly, locate the Distance section of the
Style panel (on the right) and change the Decimal places from 2 to 4 (or 5).

Scrolling down, notice that most of the closely related sequences—shown in white or very light

pink—are from the “Beta” strain B.1.351. Two random examples within these light areas are shown in
the image below.
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[7] Distance  %ldentity ~ / Distance

Al B C| D | El Fl G| H| 1|
A SRR13380...= ] 998767 998167 GQ9.8167
3 ETST56 | 00018 Experimental sample 00,9762 90,0604 99,0503
C B.1.351:37 | 00018 0. 999762 99.9694 99.9503
D B.1351:42 | 00018 00002 0.0002 999660 999728 999762 09.9694 99.9593
E B.1.351:56 | 0.018 00003 00003 0.0003 999660 99.9627 99.9627 99.9932
F B.1.351:57 | 0.0018! 0.0003 00003 00003 0.0003 999762 99.9808 99.9503
G B.1.351:45 | 0.0018! 00002 00002 00002 0.0004 0.0002 999660 99.9559
H B.1.351:48 | 00018 00003 00003 00003 00004 00001 0.0003 99,9559
| B.1.351:49 | 0.0018! 00004 00004 00004 00001 00004 00004 0.0004
J B.1.351:55 | 0.0018! 00004 00004 00004 0.0003 0.0004 00004 00004 0.0004
K B.1.351 0.0004  0.0004
L B.1.251:18 Closest distances = "Beta” 0.0004 | 0.0004
M B.1.351:26 strain references, B.1.351 0.0004  0.0004
N B.1.351:29 | 0.0019 0.0004  0.0004
0 B.1.351:31 | 00019 0. : ) : : 0.0004  0.0007
P B.1.351:50 | 0.019 00004 00004 00004 0.0003 0.0004 00004 00004 0.0004
Q B.1.351:51 | 0.0019 00004 00004 00004 00001 00004 00004 00004 0.0001
R B.1.351:54 | 0.0019 00004 00004 00004 0.0005 0.0004 00004 00005 0.0006
5 B.1.351:4 00019 00004 00004 00004 00004 00004 00005 00005 0.0005
T B.1.351:22 | 00019 00004 00004 00004 0.0001 0.0004 00005 00005 0.0002
U B.1.351:27 | 0.0019! 00004 00004 00004 0.0004 0.0004 00005 00005 0.0004
v B.1.351:46 | 0.0019 00004 00004 00004 0.0004 0.0004 00005 0.0005 0.0004
W B.1.351:47 | 00019 00004 00004 00004 0.0004 0.0004 00005 0.0005  0.0005
X B.1.351:5 00019 00005 00005 00005 0.0004 00005 00005 00005  0.0005
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Work with multiple trees

What are dynamic trees and how do they differ from “snapshots?”:

MegAlign Pro allows you to compare multiple phylogenetic trees generated using custom settings. The
phylogenetic algorithm you choose dictates which customizations affect the tree and whether a tree can be
dynamic, static, or either.

Neighbor Joining: BIONJ trees are “dynamic.” Dynamic trees are recomputed automatically when their
input changes. Changes made to rooting, zoom level, ordering of nodes and any changes made in the Tree
section of the Style panel will affect only the individual BIONJ tree to which changes are applied. However,
changes made to the alignment method or its parameters or to the distance parameters will affect the
structures of all BIONJ trees equally. To compare two BIONJ trees before and after making changes to the
alignment method or distance parameters, use the Take snapshot tool (@]) to preserve a copy of each view
showing the tree in its current state. By taking additional snapshots as you change parameters, you can
then compare multiple versions of the tree. To learn how to view trees side-by-side, see the final section in
this topic.

Maximum likelihood: RAXML trees are created as snapshots from the start. You can generate multiple
RAXML trees, each with different alignment methods, RAXML parameters, etc. Each tree will be generated
as a unique snapshot that is unaffected by subsequent customizations. Note that distance parameters have
no effect on RAXML trees.

How can you determine whether a tree is dynamic or whether it is a snapshot? Snapshots are distinguished
from dynamic trees by having the word “Snapshot” in the header, and by featuring the snapshot icon in the
leftmost column in the Trees section of the Explorer panel. You can apply custom styles to snapshot trees
just like you can with dynamic trees.

Controlling which tree is currently displayed:

There are three methods for choosing which tree is displayed in the Tree view.
* View > Tree commands — Use View > Tree > (Tree name) to make that tree active.

» Explorer panel — The Trees section of the Explorer panel contains a table listing the name of each
tree, the method used to create it, and the time the tree was built. Snapshot versions of trees have a
snapshot icon in the leftmost column. To make a particular tree active, click its row in the table. In the
example below, three trees are available and their names are: Tree (the default tree), Tree 1 and
Tree 2.
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1 Explorer 3% T Style 9 Tracks ’f‘ Places

|| = Trees
| Name | Method | Completion
Tree 1 BION 1049 A
Tree BIOh 1050 Ak
5 Treez BION B

* Tree view tab — The Tree view tab shows the number of available trees as follows: (Number of
trees) Tree. The trees themselves are numbered as specified during their creation (see steps above).
In the example below, three trees are available, and their names are: Tree (the default tree), Tree 3,

and Tree 5.
[ Tree &3 ]
[ Tree 3 &3 ]

Tree 3 x

Bl RS T x

Displaying multiple trees side-by-side:

Right-click on the Tree tab and choose Detach ‘n’ Tree Views. You can then drag the views with your
mouse to position them as desired.

Note that each detached view has its own File, View and Tree menu. If you wish to use commands such as

Tree > Root On, you need to use the menu in the detached view rather than the menu in the main MegAlign
Pro window.

Copyright DNASTAR, Inc. 2022 Page 295 of 329



User Guide to MegAlign Pro - 17.3_en

Reroot a tree

Each tree in the Tree view displays an incoming root edge, which is intended to represent the location of a
possible common ancestor. The root edge appears on the left of a tree drawn in the default orientation.

[ Tree 1 Block: (D) RAxML (Snapshot) Ll 89 Liss 00 s
[N |
- CPO02332
0.067
0.0z [,
| s — NC_012073
- CPO02076
0052
AE00511
0.0z23
—_
0.01
| Sequences | [ Distance | [@Painise 7 [CRALCINEN 208

For purposes of visualization or publication, you may wish to root the tree or choose a different location for
the root. For example, you may wish to balance the tree by moving the root to a long branch.

To reroot a tree, use the Tree > Root On subcommands or press the Sort sequences tool (1.'=) in the Tree

view and use the Root On commands there.

* Root On > Selected Branch places the root at the base of the currently selected branch. After
selecting CP002076 in the example tree above, this command yielded the following tree:

- CP0O02076
_ 0.026
AEDOOST

0.023
NC_012973

0.028
—l 0022
0oz CP002332

0.087

0.1

* Root On > Midpoint Branch computes the midway point between the two leaf nodes that are farthest
apart and places the root there. This can result in a more balanced tree. Using this command with the

example tree yielded the following tree:
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CP002332
0.065
| NC_012973
n.0z2z2

I t:;‘ AEDOOST

1 0.023
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Import a Newick-format tree

MegAlign Pro can open Newick trees with .newick, .txt or .tree extensions.

To import a Newick-format tree file:

1. Make any MegAlign Pro project tab active, or open a new, blank project. Trees cannot be opened
from within the Welcome screen

CG|
2. Choose File > Add Trees or click to the right of the Add Sequences tool () at the top left of the
window and choose Add Trees.

3. Select one or more Newick tree files and choose Open. Each tree is added as a named tree in the
Tree view tab and the Explorer panel, as described above. The tree name is the same as the file

name.

4. (optional) If desired, repeat Step 2 to add additional trees.
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Trim an Alignment

After performing a multiple or pairwise alignment, you may wish to trim off one or both ends before
realigning, saving or exporting.

To trim one or both ends from an alignment:

Perform a multiple sequence alignment then use either of the methods below:

» Use your mouse to grab and drag the gray slider located on either end of the Sequences view. The
selected portion will be trimmed off instantly. If you release the mouse button in the wrong location,
use Sequences > Clear Alignment Trim to restore the trimmed portion, then try again.

= Sequences
Ruler-l -= L L |1|DI L L IEIDI LI |
Consensus - - - - - - - - antTTgGTanttnAtCI
TETHISZTMA - - - - - - - - AATTTGGTAATTAAGCC
TETHISZZMA AAGCAACAGGTTTTGTATTAAATTI
¥sCH21 0 - - - - - - - ACCTTGGTTGGTTATCT
¥sCH2B2 0 - oo e e e e - - - - GTAACT

+ Select a portion of the consensus sequence in the Overview or Sequences view. Then use the Align
> Trim Alignment to Selection command.

o To remove the region from the 5’ end of the sequence to the 5’ end of the selection, choose
From Start.

o To remove the region from the 3’ end of the selection to the 3’ end of the sequence, choose
From End.

o To remove everything except the selection, choose From Start and End.

To restore all trimmed regions:

Use Sequences > Clear Alignment Trim.
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Copy, Paste and Delete

In many cases, once you have selected text, data, sequences or subsequences, you can copy the information to
the clipboard.

* Note: Copy functions are limited by application memory and operating system buffer size.
Therefore, for very long sequences or subsequences, we recommend exporting data to a
file rather than copying it.

To copy the selected text as it appears in the view:

Choose Edit > Copy, press Ctrl/Cmd+C, or use the context (right-click) menu to choose Copy.
+ If a portion of sequence or one or more features are selected, this command copies the selected
subsequence(s) as one long string, including the gaps. The subsequence is copied as one long string,
without line breaks. If the selection extends across multiple members of the alignment, names are

included as prefixes.

» If a selection is made in the Distance view, this command copies the selection in a tab-delimited
format suitable for use with spreadsheet programs like Microsoft Excel®.

» |f a selection is made in the Pairwise view, this command also copies the header information.

* In the Details panel, contents of each section must be copied separately.

To copy the selected text or data in FASTA format:

Choose Edit > Copy As FASTA, press Ctrl/Cmd+Shift+C, or use the context (right-click) menu to choose
Copy As.

To paste text from the clipboard into a text field:

Choose Edit > Paste or use Ctrl/Cmd+V. This command is disabled in all but a few circumstances.

To delete selected text from a text box:

Press the Delete key or use Edit > Delete.
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Export

The following topics discuss how to:

* Export an image of the view

« Export data to a file

* Export a tree to a tree viewer

« Export data from the Text, Table or Pairwise views

If you renamed sequences manually or automatically, learn how to retain custom names during export.
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Export an image of the view

To export an image of a view :

1. Choose File > Export Image > (View Name) or click the Export image tool ( bl ) at the upper right
of a view that allows exporting.

2. Specify the file name and choose the export format: Adobe PDF (.pdf), Microsoft PowerPoint-
optimized (.pptx), PNG image (.png) or JPG image (.jpg, .jpeg).

* Notes: If you choose Adobe PDF format and a particular font is not supported there, a
similar font will be substituted for the original one automatically. If you choose the
format that is optimized for use with Microsoft PowerPoint, the MegAlign Pro image is
converted into an editable set of objects that can be grouped, ungrouped and moved
within the target application. To constrain an object (e.g., a MegAlign Pro track) within
Microsoft PowerPoint to move only vertically, rather than laterally, hold down the Shift
key.

If exporting the Tree view, the export procedure is now complete.

If exporting the Overview, Sequences view or Pairwise view, the following dialog (or an abbreviated

version) will open.

i =

Pairwise Image Options = @
Range of alignment: il to 4 residues
Residues per line: 100 =
Presentaticon: [¥] Include summary

Include dividing lines

Resulting image size: 654 x 223 pixels

| ok || cancel

—

3. Choose export options.

+ Use the Range of view or Range of alignment boxes to specify the range of residues that
should appear in the image. The default is the current viewport range.

* Type in the number of Residues per line. By default, MegAlign Pro places the entire range on
a single line.
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* Check the include summary box if you want to include the summary (above the sequences

area) in the image.

+ Check the Include dividing lines box if you wish to include separators between the header,
sequences, and footer.

The Resulting image size updates automatically based on the options you choose.

4. Click OK to export the image using the specified options or Cancel to close the dialog without
exporting.

The following video shows how to export an image from MegAlign Pro and edit it in PowerPoint.
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Export data to a file

Several commands in the File menu allow you to export alignments, distance matrices and phylogenetic
trees, as well as aligned sequences and the consensus sequence. Unless you wish to export all sequences
in the project, you must first make a selection.

Command

Alignment
Report

Active Block
Alignment
Report

Active Block
Alignment

Active Block
Subsequences
Alignment
Aligned

Subsequences

All Data

Distance Matrix

Copyright DNASTAR, Inc. 2022

What is exported?

See Export the alignment report.

Aligned sequences in the active block with gaps included (Mauve alignments only). This
option supports exporting to a wide variety of formats, including FASTA, GenBank, MEGA,
MegAlign, MSF and Nexus.

A selected range of the aligned sequences in the active block (Mauve alignments only).

All aligned sequences, including gaps.

A selected region of the aligned sequences, including gaps.

Aligned sequences, distance table and phylogenetic tree information. Supports Nexus
formats (.nex, .nxs) only.
Matrix information from the Distance view Supports comma- or tab-separated formats (.csv

or .tab), PHYLIP format (.dist) or Nexus formats (.nex, .nxs).

After selecting a name and format, click Save to launch the Choose Matrix Form dialog:

il =

Choose matrix fcrrm_“

Please choose the part of the distance matrix to write,

’5quare matrix v]

Lok ]|

Cancel l

Use the drop-down menu to choose whether to save the entire (“square”) matrix or only the
upper or lower triangle.
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Sequence(s)

Selected
Aligned
Sequence(s)

Selected Active
Block Aligned
Sequence

Sequences

Tree
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Elock: - Metric: Uncorrected Pairwise Distance
A B C 0 E F

A AED00S11 0.04] 005 0.06. 047 105
B NC_012973 | 0. 005 005 v,
C  CP002076 | 'wupper ”
D CP002332 06 =TT ot

L ! =
E nco17372 w27 04 006 005
F CP002982 | 005 /057002 006 005

Note: If you choose to save in .dist format, the sample names in the saved file will
automatically be truncated to 10 characters.

Selected individual sequence(s), exported as unaligned individual sequences.

Selected aligned sequence(s), including gaps.

Aligned sequences in the selected block (Mauve alignments only), including gaps.

All sequences in the project, exported as unaligned individual sequences. Supports various
GenBank and FASTA formats; MegAlign format (.meg); or Nexus formats (.nex, .nxs).

When exporting to most formats, gaps are represented as embedded dashes. When
exporting to GenBank, gaps in nucleotide sequences are represented as “n’s” and those in
amino acid sequences are represented as “x’s.”

Phylogenetic tree information from the Tree view. See Export a tree to a tree viewer.
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Export the alignment report

To export the alignment report for the selected block from a Mauve alignment, use File > Export Data >
Alignment Report. To export the report for any other alignment type, use File > Export Data > Alignment
Report. In both cases, the report is saved as a .ixt file.

Export Alignment Report e

Sequences: | All w

Include

Header
Include: Consensus

Sequences

Left
Mame [ ] Right-justify
[ ]Position

Sequence

Wrapping: residues

[] Extra space between residues:  Tab
(] Residue groups: 10 Tab
[]End gaps
3-letter amino codes
Right
[ ] Position
Marme

» From the Sequences drop-down menu, choose All to create a report for all sequences or Top to
create a report only for the uppermost sequence in the Sequences view.

* In the Include section, check items you with to include and remove checkmarks from the others.

* In the Left and Right sections, check boxes showing where, if anywhere, you wish to include the
sequence Name and/or Position. To right-justify any labels chosen to occupy the left margin, check
Right-justify.

» To wrap sequences (rather than allowing them to go off the page), check Wrapping to wrap
sequences in the report rather than allowing the sequence to go off the page. If you elect to wrap,
enter the number of residues per line in the text box.
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* Toinclude a tab or space between residues, check the Extra space between residues tab and
choose Tab or Space from the drop-down menu.

* To group residues and include a tab or space between them, check Residue groups, make a
numberican selection from the drop-down menu, then choose Tab or Space from the second drop-
down menu.

» Toinclude gaps at the end of the sequence, check End gaps.

 If your alignment consists of protein sequences, you can show their 3-letter IUPAC amino acid codes
in the report by checking 3-letter amino codes.

After making the desired selections, press OK to generate the report. You will then be prompted to save the
report.
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Export a tree to a tree viewer

To export a phylogenetic tree to a file:

Use File > Export Data > Tree to export tree data in Newick (.newick) or Nexus (.nex, .nxs) formats . The
saved file can be opened by several free and commercial evolutionary biology software programs.

To set the default application for opening saved trees, see Set preferences.

To export and open the phylogenetic tree in a third-party tree viewer:

The following procedure lets you automatically launch a third-party tree viewer and view the tree within that
application.

1. Outside MegAlign Pro, download the desired tree viewer and install it on your computer. One
compatible viewer is Archaeopteryx (Win only).

2. In MegAlign Pro, set the default application for opening saved trees using the File > Send Tree To

menu command.
3. Perform an alignment.
4. Export the tree using File > Send Tree to (Tree Viewer). If you have chosen a compatible tree

viewer, this command launches the viewer with the active MegAlign Pro project tree open. If a tree
viewer has not yet been specified, you will receive the following message:

F 2 e

This action requires specifying a tree viewer application in Preferences, on the
Applications page.

Click OK to launch the Application preferences dialog, where you can indicate the viewer location.

* Note: If you export a tree containing duplicate sequence names, you may receive a warning
when you try to open it in a third-party application. To fix this issue, return to MegAlign Pro,
rename one of the sequences, and then re-export the tree.
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Retain custom names during export

After using File > Rename or File > Rename with Fields, the custom names are only exported as part of
the sequence data in certain cases. Raw data sequences imported into MegAlign are never modified in any
way, and always retain their original names.

The following table lists the cases in which custom sequence names are exported:

Export
target

Notes

Send an alignment to MegAlign using File > Send to MegAlign. Or use File > Export Data, save
MegAlign  as a MegAlign (.meg) file and then open the file in MegAlign. In either case, MegAlign truncates
imported labels to a maximum of 39 characters.

Send an alignment directly to a tree viewer with File > Send Tree to (Tree Viewer). Or save a

Tree

owers tree file via File > Export Data > Tree, and then open it in a tree viewer. The custom label will be
view

retained.
Sequences )
q Custom labels are exported to Nexus, and MegAlign formats. They are not exported to FASTA or

an

i GenBank formats.
alignments
Distance

matrices Custom labels are exported to distance matrices of all formats (e.g., .csv, .tab, .dst, and .nex).



Export data from the Text, Table or Pairwise
views

The Export data tool ( L ), located in the header above the Text, Table or Pairwise views, lets you export
data from those views. This tool provides a choice of three options, one of which has four sub-options.

Export Data * Matches Without Gaps...
Download Sequences... Aligned Matches...
Set Access D Table...

Text...

Options include:
+ Export Data >

o Matches without Gaps — To export an ungapped FASTA (.fasta) file consisting of matching
regions of displayed matches, but not the query sequence itself.

o Aligned Matches — To export a gapped FASTA (.fasta) file with displayed matches aligned
against the query.

o Table — To save Table view contents in either Comma- or tab-separated value (.csv or .tab)
formats.

o Text — To save the Text view contents in Text (.txt) format.
+ Download Sequences — To download the selected match sequence in GenBank (.gbk) format.

The commands above all launch a Save As dialog. Choose a file name, location and file type (fixed, in some

cases) then press Save.

+ Set Access ID — To launch the Access ID dialog, in which you can specify your NCBI Access ID
(optional). See Access ID dialog for information.
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Print Images

To print an image of any MegAlign Pro view, whether it is currently active or not:

Choose File > Print or use Ctrl/Cmd+P. The Print Document dialog opens:
i ™
# " Print Document ﬁ

Printer [HP easealod Do oo LRI Job bich v]

Content to print: ’ Sequences - ]

Sequence Options

Range of sequence: 1 to 39 residues
Residues per line: 39 =
Presentaticn: [¥] Include dividing lines

Page Setup

Page Size: [USLetter -
Margins

Orientation: @ Portrait (0 Landscape

Page Opticns

Include footer text
Ch\Users\Public\Documents\DNASTAR Sample Data\Demo Meghlign ProfADH Project.msa
[¥]Include date and time [¥]Include page numbers
Print with Options... ’ Print ] ’ Cancel ]
- o’

* Use the Printer drop-down menu to choose the desired printer from a list of available options.

» Specify the view you wish to print using the Content to print menu. Choices may include: Overview,
Sequences View, or Tree View. Depending upon the selection, additional options may appear just
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below this drop-down menu.

. o Overview and Sequences View - To print only a sub-range of the alignment, type the left and
right residues into the Range of alignment boxes (if an alignment has taken place) or Range
of sequence boxes (if alignment has not taken place).

o Sequences - To specify how many residues to include on one line, type in a number from 1-100
next to Residues per line. Check the Include dividing lines box if you wish to include
separators between the header, sequences, and footer.

o Tree - Check Fit to page to automatically size the tree to fit on a single page of the size
specified in Page Size (see below).

» Choose which Page Size to print on. (Note: If you wish to change the default print size setting, see
Change the default print size.)

« Specify the top, bottom, Margins by typing a number in the associated box and choosing the units
(inches, cm, etc.) from the nearby drop-down menu.

» Choose whether to print in Portrait or Landscape orientation.

+ Under Page Options, use the checkboxes to specify what to include in the footer: footer text, date
and time and/or page numbers. If you check Include footer text, the footer will incorporate the text
just below the checkbox. By default, this is the path and MegAlign Pro project name (or only the
default project name, for unsaved documents), but you may type in any text that you wish.

» Click the Print with options link if you want to launch the default Print dialog for your computer.
Choose Cancel to exit from the MegAlign Pro Print Document dialog without printing. Click Print to print
using the selected parameters, or Print with Options to open the Print dialog for your computer’s operating

system. The generic dialog can be used to specify additional options, such as the page range and number
of copies to print.
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Change the default print size

Unless otherwise specified on your computer, the default printing size for all DNASTAR applications is “U.S.
Letter” size (8.5 x 11 inches = 21.6 x 28 cm). You can temporarily change to another size, such as A4, from
within the application. However, the next time you print, the default size will again be U.S. Letter size.

To correct this issue, you need to change your computer’s default printing size:

On Windows 7 and Windows 8:

—_—

. Open the Control Panel.

2. In the Hardware and Sound category, click on Printers or View devices and printers.
3. Right-click on your printer and choose Properties.

4. In the General tab, click on the Printing Properties button.

5. In the ensuing Printing Shortcuts tab, choose the desired default printing size from the Printing
Sizes drop-down menu.

6. Click the Apply button, then the OK button.

On Macintosh:
1. Open System Preferences.
2. Click on Printers and Scanners.

3. Choose the desired size from the Default paper size drop-down menu.

* Note: Changes to the default printing size will not be applied until after you restart the
DNASTAR application.
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Save, Close and Exit

To save, close, or exit:

The following table describes how to save files, close projects and exit from MegAlign Pro:

Task How to...

To save all of the open projects . .
. Choose File > Save All or press Ctrl/Cmd+Shift+S.
simultaneously

To save a new project in E
multiple sequence alignment Choose File > Save, select the Save tool ( ), or use Ctrl/Cmd+S. If you

(.msa) format, or to overwrite a  want to preserve the earlier version of a project, or store a copy of the project
previously saved version of the With a different name or location, use File > Save As instead. By default,
project MegAlign Pro saves to the desktop unless directed to save elsewhere.

Choose File > Close or Ctrl/Cmd+W. If multiple projects are open, first select

To close an active project . ) .
the tab corresponding to the project you wish to close.

On Windows, use File > Exit. On Macintosh, use MegAlign Pro > Quit

To exit from MegAlign Pro .
MegAlign Pro. The shortcut Cmd+Q works on both platforms.

Closing or quitting when there are unsaved documents:

If you select File > Close, or if you quit MegAlign Pro when just one unsaved project is open, MegAlign Pro
will open the Save Resource dialog. Click Save to save changes, Don’t Save to close/quit without saving
changes, or Cancel to return to MegAlign Pro without closing/quitting.

Save 'Untitled?.msa'? |

Don't Save Cancel

If you select File > Close, or if you quit MegAlign Pro when multiple unsaved projects are open, MegAlign
Pro will open the Save Documents dialog.
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(€5 save Documents? O et
.
Save all Save Some Don't Save

To save all changed projects, choose Save All. To choose which projects to save, choose Save Some. To
exit from MegAlign Pro without saving any projects, choose Don’t Save. Click Cancel to return to MegAlign
Pro without saving the checked projects.
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Turn off usage Iogging

By default, usage logging is enabled in Lasergene version 11 and later. To opt out of usage logging, launch
the DNASTAR Navigator and go to View > Preferences > Lasergene (Win) or DNASTAR Navigator >
Preferences > Lasergene (Mac). Uncheck the box and click Apply and then OK.


http://www.dnastar.com/t-about-legal.aspx#usage
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Set preferences

To set preferences, choose Edit > Preferences (Windows) or MegAlign Pro > Preferences (Macintosh).
Click any of the four items on the left to open the preferences dialog for that item, then follow the steps in
the sections below. After setting preferences, click Apply and OK to save your changes or Cancel to ignore
any changes. Alternatively, click Restore Defaults to return to the default settings for that dialog.

Applications:

The Applications dialog designates an (optional) Newick or Nexus viewer of your choice to use in advanced
editing of phylogenetic trees. Note that the download, use, or specification of a tree viewer is optional, and
is only necessary if you wish to use MegAlign Pro’s File > Send Tree to [Tree Viewer Name] command.

Preferences '?‘@
| Applications & T
Applications
. Help Specify applications to use with data from MegAlignPre.
Internet
Ternporary Files Tree Viewer

Location: Browse...

FRecommended Tree Viewers

’ Restore De‘l‘aults] ’ Apply ]

| ok || cancel |

By default, the Location box is empty. If you already have tree viewing/editing software on your machine,
use the Browse button to navigate to the application file, and then click OK. Most software that can read a
Newick- and/or Nexus-formatted tree file will work here.

If you would like to download free tree viewing/editing software, click the link provided to visit this page of
our website. After downloading appropriate software, the Location box will usually update automatically. If
not, use the Browse button as described above.

Internet:

The Internet Preferences dialog lets you choose whether you wish to be notified about Lasergene updates.
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i

Preferences = |
type filter text Internet L= - -
Applicati
Hp:ﬂ lcations Show a notification when a newer version of Lasergene is available
- Help
Internet
Temporary Files ’ Restore Defaulﬁ] ’ Apply ]
| ok || Ccancal |

_—

Check the box if you would like MegAlign Pro to display a notification when a newer version of Lasergene is
available. Uncheck the box if you do not wish to receive this notification.

Temporary Files:

MegAlign Pro creates and uses temporary files while a project is open. The need for temporary file space
grows with the number and length of the sequences and amount of track data in open alignment projects. If
you expect the temporary files will be too large to fit in the default location, you may specify a different
location for these files using the Temporary Files Preferences dialog.

Preferences

type filter text

Applications

> Help
Internet
Temporary Files

Temporary Files

Specify where this application should store its temporary files.

Temporary Files

Location:  ChlUsers\MameAppData\Localh Temp\DNASTAR\MegAlignProt Temp

This folder must remain accessible while the application is running.

[ Restore Defaultsl l Apply

l

[ ok

J |

Cancel

)

To change the temporary file location, close all MegAlign Pro projects and then return to this dialog. Select
the Browse button, navigate to the new location and click OK. As noted in the dialog, the location you
choose must remain accessible while MegAlign Pro is running. The new location will be used for all projects
that are subsequently created or opened.
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Change the default application for opening
files

Windows 7 and Windows 8:

1. Open the Control Panel.
2. Go to Programs > Default Programs > Associate a file type or protocol with a specific program.

3. Select extension you wish to change in the Extensions list and then click the Change program
button.

4. Click the Browse button in the Open With dialog box.

5. Navigate to and select the application you want the files to open in. (Lasergene applications are
located by default in C:\Program Files\DNASTAR\Lasergene ‘x’ or C:\Program Files
(x86)\DNASTAR\Lasergene ‘x’, where ‘X’ represents the version number).

6. Click Open.

7. Click OK to close the Open With dialog box, and then click Close.

Macintosh:
1. Select a file of the type you wish to change in Finder.
2. Go to File > Get Info.
3. Click the dropdown arrow in the Open With field, and navigate to the application you want the files to
open in. (Lasergene applications are located by default in Applications:DNASTAR:Lasergene ‘x’,

where ‘X’ represents the version number).

4. Click the Change All button to make the application you selected the default for all files of this type.



Clean cached files on startup

Prior to the Lasergene 14.0 release, the default MegAlign Pro startup ran a “-clean” option. This option
automatically removed some cached files on application restart.

The “-clean” option is no longer executed at each startup. However, if you are a Windows user, you may
execute an explicit “-clean” in the unusual event that cached data has become corrupted:

1. Close MegAlign Pro if it is currently open.
2. Launch the Command Line (C:\Windows\system32\cmd.exe).
3. Type the path to the MegAlign Pro application, followed by a space and the —clean command.

C:\Program Files (x86)\DNASTAR\DNASTAR\Lasergene 14\MegAlign Pro.exe —clean



Troubleshoot the error “A different version is
running”

If you receive the error “A different version of Lasergene is running” when you try to launch a Lasergene
application, but another version of Lasergene actually isn’t running, there may be a lingering .state file from
another version that needs to be deleted.

The solution is to locate and delete files named STARDM?* state, ...where **’ represents the version number.

These files may exist in the following directories:

Windows 7 and Windows 8:

» C:\Users\username\AppData\Local\DNASTAR\DataManager

* C:\ProgramData\DNASTAR\DataManager

Macintosh:

* Hard Drive:Library:Preferences:DNASTAR:DataManager

* Hard Drive:Users:username:Library:Preferences:DNASTAR:DataManager

If you find any of the .state files listed above, delete them. Once the files are deleted, the error should no
longer appear.



Supported file types

For a list of file formats supported by this DNASTAR product, please see the File Formats page of our
website.


http://www.dnastar.com/t-fileformats.aspx

IUPAC codes

IUPAC codes for amino acids:

1-Letter Code 3-Letter Code Amino Acid

A Ala Alanine

B Asx Aspartic Acid or Asparagine
C Cys Cysteine

D Asp Aspartic Acid

E Glu Glutamic Acid

F Phe Phenylalanine

G Gly Glycine

H His Histidine

I lle Isoleucine

J Xle Leucine or Isoleucine
K Lys Lysine

L Leu Leucine

M Met Methionine

N Asn Asparagine

O Pyl Pyrrolysine

P Pro Proline

Q GIn Glutamine

R Arg Arginine

S Ser Serine

T Thr Threonine

U Sec Selenocysteine

V Val Valine

W Trp Tryptophan

X Xaa Unspecified or unknown
Y Tyr Tyrosine
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Z Glx Glutamic Acid or Glutamine

IUPAC codes for nucleotides:

Symbol Description Bases Represented
A adenosine/adenine A

C cytidine/cytosine C

G guanosine/guanine G

T thymidine/thymine T
u uridine/uracil u
W weak A T
S strong c G

M amino A C

K keto G T
R purine A G

Y pyrimidine C T
B not A c G T
D not C A G T
H not G A C T
\ notT A C G

N or - any base (notagap) A C G T

* The non-standard nucleotide codes “I” (Inosine) or “X” (xanthine) are not supported.
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Installed Lasergene file locations

The following file names use ‘x’ to represent the version number.

File Category Application Path
Windows: C:\Program Files
ArrayStar (x86)\DNASTAR\Lasergene x\
ArrayStar

Windows: C:\Program Files

SegNinja (command
aninja ( (x86)\DNASTAR\Lasergene x\

line) .
Application? SegNinjaCL
Windows: C:\Program Files
(x86)\DNASTAR\Lasergene x
All others

Macintosh: /Applications/
DNASTAR/Lasergene x

Windows: C:\Program Files
SeqBuilder Pro, Protean (x86) \DNASTAR\Lasergene x
Data Manager? (DMx, DMx.exe) 3D, GeneQuest,
MegAlign Pro Macintosh: /Applications/
DNASTAR/Lasergene x

Windows: C:\Program Data\
DNASTAR\DataManager

SeqgBuilder Pro, Protean Macintosh: ~/Library/
Data Manager State File 3D, GeneQuest, Application Support/
MegAlign Pro DNASTAR/DataManager,

~/Library/Preferences/
DNASTAR/DataManager

Windows: C:\Program Files
(x86)\DNASTAR\License
Y M 2 All Manager
icense Manager
Macintosh: /Applications/
DNASTAR/License Manager

Windows: C:\Program Files
All (x86)\DNASTAR-
LicenseServer\Server

Server License File (/servrc), Server License

Manager 2, Server Executables (_Iserv, Iservnt.exe)
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Macintosh: ~/Library/
DNASTAR-LicenseServer

Windows: C:\Program Data\

S . . DNASTARI\Licenses
Standalone & Trial Licenses (*.license), License

Server Client License (*.Ishost), Key Server Client All

Macintosh: ~/Library/
License (*.keyhost) Y

Application Support/
DNASTAR/Licenses

Windows:
Protean 3D, Navigator, C:\Users\<user>\DNASTAR
SegNinja (DNA¥),

GenVision Pro Macintosh: ~/Library/
DNASTAR
Windows:

ArrayStar C:\Users\<User>\AppData\

Preferences
Roaming\DNASTAR\ArrayStar
Windows:
C:\Users\<user>\AppData\
Local\DNASTAR\

All others

Macintosh: ~/Library/
Preferences

* AppData is a hidden folder in Windows. To unhide the folder, go to Organize > Folder and
Search Options > View > Show Hidden files and folders.
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