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Welcome to GenVision Pro
GenVision Pro supports visualization and analysis of multiple samples from a single genome. In RNA-seq,
ChIP-seq and copy number variation (CNV) studies, where coverage and peak plots are compared and
used to interpret gene expression and regulation, the ability to display and compare genome-wide data sets
for multiple samples makes GenVision Pro an essential tool

With GenVision Pro, you can visually navigate between single-segment chromosomes and/or contigs of a
genome, then export publication-quality images.

The following video shows how easy it is to use GenVision Pro:

These support pages contain written help and tutorials, as well as video tutorials.

• For help INSTALLING Lasergene, see our separate Installation Guide.

• For written TUTORIALS with free data, see GenVision Pro Tutorials.

• Click here for a list of all topics that include VIDEOS.

• To PRINT the current page of the User Guide, click the printer icon in the top right corner ( ).

• To download a PDF of the entire User Guide, scroll to the bottom of the table of contents on the left,
and press Download as PDF.

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 3 of 136

http://www.dnastar.com/manuals/installation-guide
https://www.dnastar.com/manuals/genvisionpro/search?q=video


GenVision Pro Tutorials
GenVision Pro tutorials are listed below. Any data needed can be downloaded for free using the link
provided in the tutorial.

• Analyze an E. coli assembly – Links to the first of four parts.

• Analyze Copy Number Variation (CNV) results – This tutorial is located in the SeqMan NGen User
Guide. The workflow begins with assembly in SeqMan NGen and uses ArrayStar and GenVision Pro
for downstream analysis.
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Try It! – Analyze an E. coli assembly
The following tutorial uses free data from the DNASTAR website to demonstrate a typical workflow in
GenVision Pro. The tutorial is in four parts, which should be done in order.

Begin with Part A: Start a new session and rename a sequence using data fields.
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Part A: Start a new session and rename a
sequence using data fields
In this first part of the GenVision Pro tutorial, you will start by downloading and extracting the tutorial data
from the DNASTAR website. Next, you will begin a new session and add an E. coli assembly produced by
DNASTAR’s SeqMan NGen. You will then create a custom label for the sequence based on the accession
number and sequence description.

1. Download the tutorial data extract the folder to any suitable location (e.g., your desktop).

2. If a GenVision Pro project is already open, choose File > New GenVision Pro Session. Otherwise,
launch GenVision Pro.

3. Add file MG1655_genome.assembly to the session using either of the following methods:

• Use File > Add Assemblies or press the Add Assemblies to project button ( ). Select the
assembly, and then press OK. Note that double-clicking is not supported in this dialog.

• Drag & drop the assembly on the GenVision Pro window.

4. Drag the pane dividers and the horizontal zoom sliders until the view looks approximately like the
image. Drag the horizontal pane divider upwards, if necessary, until the Analysis view is about twice
as tall as the Overview.
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Note that the name of the active sequence is ‘1.’ In the next steps, you will be changing this name to
something more useful.

5. Right-click on sequence ‘1’ in either view and choose Rename with Fields. This opens the Choose
Label dialog.

Note that the Display is set to One or more fields. This setting lets you automate the naming
process for any number of selected sequences using fields such as sequence length, organism, or
description.
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The left pane shows available fields, and the right pane shows fields that will be displayed as part of
the sequence name. Initially, Default name is the only field listed in the right pane.

6. Select and organize the fields to display as part of the sequence name:

a. Click on the left arrow ( ) to remove Default name from the right-hand pane.

b. Use Ctrl/Cmd+click to select Accession number and Description from the list on the left.
Click the right arrow ( ) to move them to the right-hand pane.

c. Click on Description on the right to select it. Then use the up or down arrows on the right (
) to move Description to the top of the list.

d. Click OK to save changes and exit from the dialog.
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The sequence name in both the Overview and Analysis view has changed from ‘1’ to:

However, you may only be able to see the first part of the name.

7. To see a tooltip displaying the full name, hover your cursor over the visible portion of the name (see
area boxed in purple, below).

8. To view the entire name, drag the pane divider (boxed in red, above) to the right. Then return the
pane divider to its original position for ease of viewing the sequence section in the next part of the
tutorial.

9. To edit the name field manually, right-click on the name and select Rename. This opens the same
dialog as before, but Display is now set to Custom label. The current name appears in the Label
field. In that field, change “Escherichia” to “E.” and remove the comma and the words “complete
genome.” Click OK.

Proceed to Part B: Work with feature tracks.

Note: Even if the full name is not visible when viewed in the GenVision Pro window, it
will be shown in the Details panel, the Navigation bar’s chromosome selector (the drop-
down menu) and in printouts of the views.
*
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Part B: Work with feature tracks
Features are displayed as colored arrows in the Overview and the Analysis view. In this part of the tutorial,
you will learn to toggle between displaying/hiding features, and to view features that are not currently
visible.

1. To see an information balloon for any feature, hover over the feature. Try clicking on the feature. This
displays the same information in the Details panel on the right, where it can be copied and pasted into
a text document.

2. Right-click on the word Features in either view and select Show Track Options. This command
opens both the Tracks panel and the Options section associated with the selected track type; in this
case, Features.

3. Note that there are two “Feature” check boxes in the Tracks panel; one under Overview details and
one under Sequence details. Experiment with unchecking and rechecking these two Features boxes
to toggle feature display in the views. Check both boxes before moving to the next step.

4. The GenVision Views display several rows of features, by default. If you wish to see additional rows of
features, use the up/down triangles near the right end of the features display. These arrows are
connected by a semi-transparent blue bar.

Note:*If you can’t see the Details panel, click *View > Reset Panel Layout.*
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An alternative is to hover the mouse over the bottom of the track, then grab the resize bar and drag it
downward.

Proceed to Part C: Investigate sequence coverage.
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Part C: Investigate sequence coverage
GenVision Pro’s navigation tools consist of a “sequence selector,” a text box, and a Go button. In this part of
the tutorial, you will use the navigation tools to go to a particular region of low coverage that begins around
4,314,000.

1. In the navigation tools area near the top of the window, hover your cursor over the sequence selector
(drop-down menu) and the navigation field text box, in turn. Note that each provides tool tips.

2. Enter 4314000 into the text box. (Alternatively, depending on your locale and computer settings, you
could enter 4,314,000 or 4.314.000.)

Press Go or Return/Enter.

3. In the Analysis View, slide the horizontal zoom slider until the Coverage track (entitled “MG1655
genome”) roughly matches the image below. Note the obvious area of low coverage (boxed in red,
below).

4. To optimize the Coverage track options, right-click on the name of the track and choose Show Track
Options.
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a. Next to Graph type, click the bar graph icon ( ). Note that low-coverage areas like the area
found above now appear in dark green, making them easier to recognize.

b. Experiment with other available options. For example, try changing the Height slider and/or the
Y-axis Range, select a different Graph type or Color, and experiment with the Gridlines drop-
down menus. Check the Use logarithmic scale button and observe how the Coverage track
changes.

c. When you are finished, revert to the default values using the Restore default settings tool (
).

Proceed to Part D: Work with region tracks.

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 13 of 136



Part D: Work with region tracks
In this part of the tutorial, you will load two BED files associated with the E. coli assembly.

• MG1655_m56_v3.prophage-regions.bed. contains ten regions or intervals corresponding to the
locations of prophages within the genome of this particular strain of E. coli.

• MG1655_m56_v3.Sigma32_regulon.bed contains regions corresponding to genes that are known to
be induced by heat shock (i.e., high temperatures).

Each BED file will appear as a separate Region track in GenVision Pro, just like the Features and Coverage
tracks discussed in earlier parts of this tutorial.

1. BED files must be added one at a time. Select File > Add Track. Navigate to and double-click on
MG1655_m56_v3.prophage-regions.bed.

2. Leave the Track category set to Region and press OK.

3. Repeat the above steps to add MG1655_m56_v3.Sigma32_regulon.bed.

Now that the tracks are loaded into the session, the next step is to find regulon members that reside
within prophages. One way to do this is to use the Overview to manually navigate to each of the ten
prophage regions in the BED file and visually check whether any regulon regions overlap prophage
regions.

4. In the Overview, move the horizontal zoom slider to the left, if it is not already there. Even zoomed out
the whole way, you should be able to see 10 orange regions in the MG1655_m56_v3.prophage-
regions.bed track.

Note: Tracks can be renamed by right-clicking on their names in the Tracks panel (not
in the views) and choosing Rename or Rename with Fields. This is the same basic
procedure used to rename sequences in Part A of this tutorial. You can rename the
tracks if you wish, but it is not necessary for this tutorial.

*
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5. In the Analysis view, move the horizontal zoom slider until the viewport (the semi-transparent vertical
bar in the Overview) is narrower than 1 cm in width. Then drag the Viewport so that it is over the left-
most orange region.

In the Analysis view, adjust the horizontal zoom slider so that the entire CP4-6 prophage region is
visible. Note that the regulon track below it does not contain any data at this point, indicating that
there are no overlapping regulons in this region.

6. Repeat the previous step for each of the other nine prophage regions. You should see overlapping
regulons at two of them.

One is the fifth prophage from the left (“Qin”):

The other is the ninth from the left (“CP4-57”):

7. Under CP4-57, click on the orange arrow to see the regulon member’s region name and coordinates
in the Details panel.

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 15 of 136



Imagine you are interested in the gene dnaK, and want to see if is a member of the regulon.

8. In the navigation area at the top of the window, start typing dnaK. As you type, a list of matches
appears.

You can select dnaK from the list by double-clicking on it. Or simply finish typing the name manually
and press Go or Enter/Return.

In the Analysis view, you can see that dnaK is indeed a member of the regulon.
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Congratulations on completing the tutorial!
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Create or Open a Session
Because GenVision Pro does not store data when you close it, the information shown in the interface is
called a “session,” rather than a “project.” Once you open GenVision Pro, you can open one or many
sessions. Each session is displayed in a separate tab and is initially assigned a unique name
(Untitled[#].gvp).

For more information, see the following topics:

• Create a new session

• Open an existing session

◦ Change the default application for opening files

• Launch a session from within ArrayStar

• Make a session active

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 18 of 136



Create a new session
To create a new, untitled GenVision Pro session :

Choose File > New GenVision Pro Session or press Ctrl/Cmd+N.

Once you open a session and add sequences or assemblies, the information is shown in two views: the
Overview and Analysis view. The appearances of the views are determined by options in the Style panel’s
Overview and Analysis sections.

To open an additional GenVision Pro window:

Select the Window > New Window command.
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Open an existing session
To open an existing GenVision Pro (.gvp) session :

Use the File > Open command or press Ctrl+O (Win) or Cmd+O (Mac).

Once a project is open in GenVision Pro, you can open additional sessions using the same command.

If you moved or renamed any of the assembly projects, the track file(s) or index file (if any) prior to
reopening a session, you may be prompted to supply the new name(s) or location(s) of those files.

If you always want to open_.gvp_ files using GenVision Pro, see Change the default application for opening
files.
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Change the default application for opening
files
Windows 7 and Windows 8:

1. Open the Control Panel.

2. Go to Programs > Default Programs > Associate a file type or protocol with a specific program.

3. Select extension you wish to change in the Extensions list and then click the Change program
button.

4. Click the Browse button in the Open With dialog box.

5. Navigate to and select the application you want the files to open in. (Lasergene applications are
located by default in C:\Program Files\DNASTAR\Lasergene ‘x’ or C:\Program Files
(x86)\DNASTAR\Lasergene ‘x’, where ‘x’ represents the version number).

6. Click Open.

7. Click OK to close the Open With dialog box, and then click Close.

Macintosh:

1. Select a file of the type you wish to change in Finder.

2. Go to File > Get Info.

3. Click the dropdown arrow in the Open With field, and navigate to the application you want the files to
open in. (Lasergene applications are located by default in Applications:DNASTAR:Lasergene ‘x’,
where ‘x’ represents the version number).

4. Click the Change All button to make the application you selected the default for all files of this type.
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Launch a session from within ArrayStar
To view and analyze a selected entry from ArrayStar:

1. Create or open a project in DNASTAR’s ArrayStar application.

2. Open any table and locate a row with a position of interest. Select the row and choose File > Send
Selection To > GenVision Pro or right-click on the row and choose Send Selection To GenVision
Pro. GenVision Pro will launch and load the corresponding contig(s) or chromosome(s). If your project
contains multiple experiments, all experiments will be loaded into GenVision Pro.

3. (optional) To move to a new location on the sequence in GenVision Pro, repeat Step 2 using a
different table row.

The following video shows this workflow in action:

This next video shows an RNA-Seq workflow that begins with assembly in SeqMan NGen, proceeds to
downstream analysis in ArrayStar, and then uses ArrayStar’s Send Selection to GenVision Pro command
to open the results in GenVision Pro. Once in GenVision Pro, the Sashimi track is applied. (GenVision Pro
section begins at 2:41).

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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Make a session active
To make a session active:

Do any of the following:

• Click+ on any session tab to make that session active.

• Click on the Window menu and choose the name of the session from the list.

• Press Ctrl+; (Win) or Cmd+; (Mac) to open a “session chooser.” You may also open the session
chooser by pressing the >> icon that appears to the right of the session tabs. This icon is displayed
when multiple sessions are open and the GenVision Pro window is too small to display each one in an
individual tab.

The session chooser appears as a yellow popup with a line for typing in text at the top, and a list of
open sessions below. Use your mouse to click on the session you want to make active. If you do not
have a mouse, make a selection using the keyboard arrow keys, then press Enter.

To instead search for a session using a filter, type text into the text field and press Enter. The text
field supports the “?” and “*” wildcards.
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GenVision Pro Interface

The following table describes components of the GenVision Pro user interface, along with links to more in-
depth information about each item:

Item Description

Menus
The GenVision Pro menus are: GenVision Pro (available only on Macintosh), File, Edit, View,
Overview, Analysis, Window and Help. Some menu commands can also be initiated by
keyboard shortcuts, button tools, navigation tools, or right-click options.

Button
tools The GenVision Pro button tools are above the Overview on the left.

Navigation
tools The GenVision Pro navigation tools are above the Overview, to the right of the button tools.

Sessions In GenVision Pro, each session is displayed in a separate tab with a .gvp extension.

Overview The Overview allows you to navigate or visualize the genome or an individual chromosome.

Analysis
view The Analysis view shows a reference sequence and enabled tracks.

Panels The Style, Tracks, Features, Places and Details panels provide details about the views on the left,
or affect what is displayed there.

View
splitter The view splitter is used to divide the Analysis view or Overview vertically into multiple panes.

Header/
Footer

A header and footer are collapsible sections above and below the selected reference sequence.
The Overview provides a header, and the Analysis view provides a header and footer.
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Sequence
Ruler Sequence rulers pertain only to the sequences just above them.

Show/Hide
icons

The gray circles to the left of each label in the Analysis view and Overview contain a plus or minus
sign. These toggle between displaying or hiding the detail tracks.
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Views
By default, the GenVision Pro interface displays two views: the Overview and the Analysis view.

If desired, you can customize the look and layout and of these views.
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Overview
To access the view, click on the Overview tab (the dark blue part of the image, below) or use View >
Overview.

The Overview has two modes:

• No active chromosome or contig – When you first add an assembly, or when you select (Genome)
using the navigation tools, the Overview displays a header, followed by one or more sequences with
labels to their left (see image above). Each sequence is depicted as a “sequence block” of length
proportional to the length of the entire sequence. The Overview displays all the sequences in the
genome until you navigate to one sequence by double-clicking on its name.

• When a chromosome or contig has been selected –When the project contains a single sequence or
after you have selected one sequence by navigating to it or double-clicking on its name, the Overview
displays the single sequence. Display of optional data tracks is also enabled.
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Analysis view
The Analysis View shows tracks for a single sequence. The view is empty unless the session contains only
one sequence; or until a single sequence has been chosen in the Overview or by using the navigation tools
or Places panel bookmarks. At that point, the Analysis view appears automatically and is populated with
data.

To access the Analysis View at any time, click on the Analysis tab, the dark blue tab in the image below, or
use View > Analysis.

By default, the Analysis view displays a header and footer, along with a sequence and its corresponding
data tracks. The Analysis view has a different appearance depending on the zoom level.

The following table shows ways to customize the Analysis view:

Task How To

Show the
header &
footer

Click on the small dark gray arrows near the upper right corners of each section.

Hide the
header &
footer

Click on the small dark gray arrows near the upper right corners of each section.
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Show a
vertical
guideline

Click Analysis > Show Guideline. The presence of a check mark directs GenVision Pro to display
the guideline. A vertical guideline is displayed by default, and is a navigational aid to help in guiding
your eye between sequences and tracks.

Hide a
vertical
guideline

Click Analysis > Show Guideline. The absence of a checkmark means that only an abbreviated
version of the guideline will remain visible in the header and footer.
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Panels
Settings panels allow you to optimize the look, contents and layout of the GenVision Pro view. To learn what
can be done within each panel and their “areas” (expandable sections within each panel), click the links
below:

• Style
• Tracks
• Features
• Places
• Details
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Style panel
The Style panel lets you customize view formatting and layout.

To open this panel, do any of the following:

• Click on the Style tab ( ).

• Use the View > Style > Style command.

• Right-click within a view and choose Show Style Panel.

This panel consists of two expandable sections:

• The Overview section contains options affecting the Overview.

• The Sequence section contains options affecting the Analysis view.

• The Analysis section contains options affecting the wrapping used in the Analysis view.
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Overview section
The Overview section contains options affecting the Overview. To access this section, click on the Style
panel expand bar entitled Overview, or choose View > Style > Overview.

• To change font options for the ruler numbers in the Overview, use the Font drop-down menu to
choose a font for the ruler numbers in the Overview. Recently selected fonts (if any) appear at the top
of the menu, and other available fonts appear below the row of dashes. Enter the preferred font size
by typing a number between 4-72 in the box at right, or by using the corresponding up and down

arrows ( ). See note in the row below for additional clarification.

• To select a different font for sequence and track labels in the Overview, first check the box next to
Track names font. If desired, use the corresponding drop-down menu to change the font from the
current value. Enter the preferred font size by typing a number between 4-72 in the box at right, or by

using the corresponding up and down arrows ( ).

Note: When Track names font is unchecked and tracks are open, Font and Font size (described
above) affect everything in the view. When Track names font is checked and tracks are open, Font
and Font size affect only the rulers, while Track names font and Track names font size affect
sequence labels and track labels.

Customization for font style and size applies to all text in the Overview. Individual rows cannot have different
styles or sizes.
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Sequence section
The Sequence section contains options affecting the Analysis view. To access this section, click on the
Style panel expand bar entitled Sequence, or choose View > Style > Sequence.

• To specify font options for the ruler numbers in the Analysis view, use the Font drop-down menu.
Recently selected fonts (if any) appear at the top of the menu, and other available fonts appear below
the row of dashes. Enter the preferred font size by typing a number between 4-72 in the box at right,

or by using the corresponding up and down arrows ( ).

• To select font options for other items in the Analysis view, first check the box next to Track names
font, then use the corresponding drop-down menu to change the font from the current value. Enter
the preferred font size by typing a number between 4-72 in the box at right, or by using the

corresponding up and down arrows ( ).

Customization for font style and size applies to all text in the Analysis view. Individual rows cannot have
different styles or sizes.

• To change the sequence letter color scheme in the Analysis view, check the Color foreground box.
To change the background color (boxes around each letter), check the Color background box. Then
make selections from the corresponding drop-down menus.
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Analysis section
The Analysis section contains options affecting the wrapping style for rows in the Analysis view. To access
it, click on the Style panel expand bar entitled Analysis, or choose View > Style > Analysis.

Use the Layout drop-down menu to select the preferred line wrapping style:

• Linear – All information for a sequence appears on a single row with no line breaks. A horizontal
scrollbar is provided.

• Automatic wrapping – The alignment is wrapped to fit within the view. Wrapping adjusts
automatically if the view’s width changes. Note that vertical splits are not available in either type of
wrapped view. However, any existing splits are restored if Automatic wrapping is turned off.

• Fixed wrapping – The alignment is wrapped at the specified number of residues. Enter a number in
the Size box to wrap after a different number of residues.
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Tracks panel
The Tracks panel lets you manage tracks displayed in the views.

To open this panel, do either of the following:

• Click on the Tracks tab ( ).

• Use the View > Tracks > Tracks command.

The uppermost part of the Tracks panel lets you specify which tracks are visible, and configure their options
and appearance. Put check marks next to available tracks that you wish to display, and remove check
marks next to tracks that you wish to hide. For information about each track type, including user-editable
options for the track, see Work with Tracks.

To move up or down the list of tracks, either use the mouse wheel or use the vertical scrollbar on the right.

To see the detail tracks that have been checkmarked for display, expand one or more rows in the Overview

and/or Analysis view by clicking the relevant plus sign icon ( ).

Note: Tracks are added to the views in the same order in which their boxes are checked in
the Tracks panel. This means that the position of a track may change when its box is
unchecked and then checked again.
*
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Below the list of tracks are two expandable sections:

• Layout lets you change the height of a track and create blank space above and/or below the track.

• Options lets you optimize how tracks appear in the Overview and Analysis view.
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Layout section
The Layout section lets you change the height of a track and the space above and/or below a track.
Changes made in this section are applied to all currently selected tracks.

Access this section by clicking on the Tracks panel expand bar entitled Layout, or by choosing View >
Tracks > Layout.

• To control the amount of blank space above and/or below each of the selected track(s), use the
Space before/after sliders.

• To control the heights of the selected tracks, use the Height slider. This option is enabled only when
all selected tracks support user-scalable height.

• To return the sliders in this dialog to their default settings, click the Restore default settings tool (
).|
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Options section
The Options section is used to edit settings for the track type currently selected in the Tracks panel, and
varies in appearance depending upon the selection. Access the Options section by clicking on the Tracks
panel expand bar entitled Options or by choosing View > Tracks > Options.

See the following topics for discussions of each track type and its corresponding Options section.

• Ruler tracks

• Feature and Region tracks

• Numeric tracks

• Sashimi tracks
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Features panel
The Features panel lets you specify which feature types should be visible in the Overview and the Analysis
view when the feature and region tracks are visible.

To open this panel, do any of the following:

• Click on the Features tab ( ).

• Use the View > Features command.

• Right-click within a view and choose Show Features Panel.

The Type column shows the feature type, while the Count column shows the number of each feature type in
the session. Count includes all sequences, whether selected or unselected. By default, all feature types
except Source are checked.

To display or hide a particular feature type:

Check or uncheck its box in the Type column.

To display or hide all features:

Right-click anywhere in the Features panel and select Show All or Hide All.
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Places panel
The Places panel and the GenVision Pro navigation tools work together so you can quickly navigate to a
chromosome or sequence range that you have visited before.

To open this panel, do either of the following:

• Click on the Places tab ( ).

• Use the View > Places > Places command.

This panel consists of two or three expandable sections:

• Recent lists all locations that you visited after performing a search using GenVision Pro’s navigation
tools.

• Received lists data exported to GenVision Pro from ArrayStar (e.g. from ArrayStar’s Gene or SNP
Tables) using the File > Send Selection To > GenVision Pro command. If the GenVision Pro
session does not contain items exported from ArrayStar, the Received section is disabled.

• Favorites is similar to the bookmarks folder for a web browser. It contains a list of previously-visited
locations that you have decided you may wish to visit again.

The following video shows the Places panel in action in another DNASTAR application, MegAlign Pro:
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<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 42 of 136



Favorites section
The Favorites section is similar to the bookmarks folder for a web browser. It contains a list of previously-
visited locations that you have decided you may wish to visit again.

Access this section by clicking on the Places panel expand bar entitled Favorites or by choosing View >
Places > Favorites.

To nominate an entry to the list:

Do any of the following:

• Use the Recent or Received sections of the Places panel.

• Choose Analysis > Add Place to Favorites.

• Right-click within the Analysis view and choose Add Place to Favorites.

Favorites are listed in the same order in which they were added, by default, though you can change the
order manually (see table below). The Favorites list is saved whenever you save a session.

The following table shows tasks that can be done from within the Favorites section:

Task How To

To return to a location in this
section

Double-click on the item or make a selection from the list and press the Go
to this gene or location button ( ).

To move a bookmarked
location further up the
Favorites list

Make a selection from the list and press the Move this place up arrow ( ).

To move a bookmarked
location further down the
Favorites list

Make a selection from the list and press the Move this place down arrow (
).

To rename a selected item
Click on an item in the Favorites section to select it. Then right-click on the
same item and choose Rename Favorite. Type a name into the box and
click OK.

To remove a selected item Click on an item in the Favorites section to select it. Then right-click on the
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from the Favorites list same item and choose Remove Favorite from This List.

To remove all items from the
list Right-click in the Favorites section and select Clear Favorites.
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Recent section
When you perform a search for a gene, feature or numerical sequence location using the navigation tools or
the Edit > Go to Place command, each found location is automatically stored in the Recent section of the
Places panel.

Access this section by clicking on the Places panel expand bar entitled Recent or by choosing View >
Places > Recent.

Recent locations are listed in the same order in which they were added, and the list is saved whenever you
save a session.

• To return to a location on the list, make a selection from the list and press the Go to this gene or
location button ( ).

• To save a location on the list to the Favorites section (similar to bookmarking a page on the Internet),
make a selection from the list and press the Add this place to Favorites button ( ). Alternatively,
make a selection from the list, then right-click on the item and choose Add This Place to Favorites.

• To remove all items from the Recent list, right-click in the Recent section and select Clear Recent.
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Received section
After opening a SeqMan NGen assembly in DNASTAR’s ArrayStar application, you can send up to 100 data
rows from its Gene Table or SNP Table directly to GenVision Pro using the File > Send Selection To >
GenVision Pro command. When you do this, each row exported from the ArrayStar table is automatically
stored as a “bookmark” in the Received section of the Places panel.

Access this section by clicking on the Places panel expand bar entitled Received or by choosing View >
Places > Received.

Received locations are listed in the same order in which they were added, and the list is saved whenever
you save a session.

• To return to a location on the list, make a selection from the list and press the Go to this gene or
location button ( ).

• To save a location on the list to the Favorites section (similar to bookmarking a page on the Internet,
make a selection from the list and press the Add this place to Favorites button ( ). Alternatively,
make a selection from the list, then right-click on the item and choose Add This Place to Favorites.

• To remove all items from the Received list, right-click in the Recent section and select Clear
Received.
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Details panel
The Details panel shows details of the application, selection or session. Details are available for all tracks in
the Overview and Analysis view, as well as the Tracks panel.

To open this panel, do any of the following:

• Click on the Details tab ( ).

• Use the View > Details command.

• Right-click within a view and choose Show Details Panel.

The appearance of this panel varies according to the situation:

• When no session, or a blank session, is open
• When a non-empty session is open
• When one sequence is selected
• When a portion of a sequence is selected
• When multiple sequences are selected
• When one track is selected
• When multiple tracks are selected
• When one feature is selected
• When multiple features are selected

Text in the Details panel can be copied using basic editing commands and pasted into a text editor, etc.
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When no session, or a blank session, is open
When no session, or only a blank session, is open, the Details panel displays links to help you get started in
GenVision Pro.

Heading

Click on the links to:

* Create or open a session

* Add assemblies to the session

* Watch a training video
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When a non-empty session is open
If a session is open and data has been added, the Details panel contains the following information:

Heading The session file name, in blue.

Sequences

* Sequences – Number of sequences in the assembly.

* Sequence type – Type of sequences in the assembly
(DNA or RNA).

* Min. and Max. sequence lengths – Lengths of the
shortest and longest sequences.

Actions

* Add assemblies – Shortcut to menu command File >
Add Assemblies.

* Add tracks – Shortcut to menu command File > Add
Track.
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When one sequence is selected
If a single sequence has been selected in any view, the Details panel may contain a subset of the following
information:

Heading

The label used in the Analysis view
and Overview, in blue.

* Organism – The organism
containing the chromosome, if
available.

* Description – A description of the
selected chromosome, if available.

* Sequence type – Type of
sequences in the assembly (DNA or
RNA).

* Nucleotides/Residues – Number of
nucleotides or residues in the selected
chromosome.

Properties

Note that the Properties for a
sequence show information about a
single assembly (not all assemblies)
loaded into the session. The
information here pertains to the first
loaded assembly that covered the
chromosome of interest.

* Accession number – The NCBI
accession number of the selected
sequence.

* Assembly name – The name of the
assembly where the sequence or
chromosome is located.

* Assembly path – The file path to
that assembly.

* Assembly time – The time the
SeqMan NGen assembly finished.

* Assembly type – The type of
assembly performed in SeqMan
NGen, if available (e.g., Exome/Gene
Panel).

* Sequence shape – Linear or
circular, if specified in the reference
sequence.
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* Sequence version – The NCBI
version number (the part following the
decimal after the accession number)
for the sequences in the chromosome
or contig.

* Template name – SeqMan NGen’s
name for the assembly template,
usually the same as its NCBI
accession number. Example: In the
image shown at left, the Template
name is the accession number of the
human ‘X’ chromosome.

* Template short name – May match
the label displayed in the Overview or
the default name originating from the
Genome Template Package used to
create the assembly.

Data

* Data specification – The name of
the sequence file, including extension.

* Data file time – The time the
sequence file was created or modified.

* Data file path – The path to the
sequence file in the assembly.

Actions

* Rename – Shortcut to Edit >
Rename.

* Rename with Fields – Shortcut to
Edit > Rename with Fields.
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When a portion of a sequence is selected
When a portion of a sequence has been selected in the Analysis view (e.g., by double-clicking on a feature,
or by dragging across the sequence with the mouse), the Details panel contains the following information:

Heading

* Sequence – The name of the sequence from which the region
was selected.

* Residues – The total number of residues in the selection.

* Sequence selection – The inclusive coordinates for the
beginning and end of each selection.

Actions

* Copy – Shortcut to the menu command Edit > Copy.

* Copy As FASTA – Shortcut to the menu command Edit > Copy
As FASTA.

See Copy for more information about these commands.
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When multiple sequences are selected
If multiple sequences have been selected in the Overview, the Details panel contains the following
information:

Heading

* Number of sequences currently selected, in blue.

* Sequence type – DNA or RNA.

* Min./Max. sequence length – Lengths of the shortest and longest
sequences in the current selection.

Actions * Rename with Fields – Shortcut to Edit > Rename with Fields
command.
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When one track is selected
If a single track has been selected in the Overview or Analysis view, the Details panel contains the following
information.

Heading

The heading contains:

• Type of track or assembly name, in
blue.

• Summary – Basic information about
what is displayed in the selected track.

Data

Some tracks may have a Data section that
includes the source of data.

• Assembly name – The name of the
assembly where the sequence or
chromosome is located.

• Assembly type – The type of
assembly performed in SeqMan NGen,
if available (e.g., Exome/Gene Panel).

• Assembly time – Date and time the
SeqMan NGen assembly finished.

• Assembly path – The file path to that
assembly.

Actions

Only a subset of links may be available,
depending on the selected track.

• Rename – Shortcut to Edit > Rename.
• Rename with Fields – Shortcut to

Edit > Rename with Fields.
• Show track layout – Shortcut to View

> Tracks > Layout.
• Show track options – Shortcut to

View > Tracks > Options.
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When multiple tracks are selected
If two or more tracks have been selected in the Overview or Analysis view, the Details panel contains the
following information.

Heading

The heading contains:

• The number of tracks currently
selected (in blue).

• Summary – Description of options
available for the multiple track
selection.

Actions

The Actions area contains:

• Rename – Shortcut to Edit >
Rename.

• Rename with Fields – Shortcut to
Edit > Rename with Field.
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When one feature is selected
If a single feature has been selected in a track in the Overview or Analysis view (e.g., by clicking one time
on the feature), the Details panel contains the following information. Note that the tooltip displayed when
you hover over a feature is a subset of the Details panel information for that feature.

Heading

The heading contains:

• The feature name, in blue.
• Type – Feature type.
• Left and Right – The inclusive

coordinates of the beginning and end
of the feature range.

• Length – Length of the selected
feature in nucleotides or residues.

Location The location of the feature, as a set of one or
more segments.

Properties

This section shows properties of the selected
feature. The properties included vary based on
the type of feature and the annotations present
in the original data file.
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Translation
This section is displayed only for some CDS
features. When present, it displays the NCBI
/translate feature qualifier.

Notes

This section is not available for all features.

• note – The NCBI feature qualifier of
the same name.

Actions

Select Subsequence – * Shortcut to the
menu command|topic=Menu Commands
*Edit > Select Subsequence. Double-clicking
on the feature fulfills the same function.

For additional information about working with features, see Features panel.
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When multiple features are selected
If two or more features have been selected in a track in the Overview or Analysis view, the Details panel
contains the following information:

Heading

The heading shows:

• Number of features currently selected, in blue.
• Type – List of all feature types represented in

the selection.
• Left and Right – The inclusive coordinates of

the beginning and end of the feature range.
• Min. and Max. Length – Lengths of the shortest

and longest features in the selection.

Properties

Shows a subset of the qualifiers that all selected features
have in common. This section does not show qualifiers
that appear elsewhere in in the Details panel when a
single feature is selected (e.g., /translation and /note)
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Button tools
At the top of the GenVision Pro window are eight button-style tools, as well as a set of navigation tools. In
the bottom right corner of the view, GenVision Pro offers two additional button-style tools for selecting the
screen mode.

You can toggle between showing/hiding the toolbar using the command View > Show/Hide Toolbar.

The following table describes the ten button-style tools.

Name Tool
Keyboard/
Mouse
Option

Description

Create a
new session Ctrl/Cmd+N Shortcut to the File > New GenVision Pro Session menu command.

Open a file Ctrl/Cmd+O Shortcut to the File > Open command.

Save
session Ctrl/Cmd+S Shortcut to the File > Save Session command.

Add
assemblies
to session

Ctrl/
Cmd+Shift+E Shortcut to the File > Add Assemblies command.

Add
sequences
to session

Ctrl/Cmd+E Shortcut to the File > Add Sequences command.

Download
and add a
genome to
this session

Shortcut to the File > Download and Add Genome command.

Add tracks
to session

Ctrl/
Cmd+Shift+T Shortcut to the File > Add Track command.

Show whole
genome

Same as choosing (Genome) from the navigation tools drop-down
menu. All available sequences (i.e., the whole genome) will be displayed
in the Overview. This is default state of the Overview when a selection
has not yet been made.

Full screen Ctrl/
Cmd+Shift+F

Shortcut to the View > Full Screen command. Undo by clicking the Esc

key or the Exit Full Screen icon ( ) at the bottom of the full-screen
view.

Show/
Remove
split

This tool appears under the Overview and Analysis view. It toggles
between showing one or two views for this session in the main window.
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Navigation tools
GenVision Pro’s navigation tools are located just to the right of the button tools and consist of a “sequence
selector” (the drop-down menu), a text box, a Go button, and two green arrows. By default, (Genome) is
shown in the sequence selector, causing the entire genome to be displayed in the Overview. The Analysis
view remains empty until a different selection is made.

To move the cursor to a particular position or range:

Type a position or range into the text box and press the Go to gene or location specified button ( ).
See the table below for syntax examples, and the contexts in which they may be used. If you are currently
displaying all chromosomes (see above), you may limit the search to a particular one by including it in the
query syntax. GenVision Pro will automatically update the drop-down menu to correspond to the
chromosome specified by the query.

Context Type… To go to…

All contexts

chr1: chromosome 1

3: chromosome 3

chr1:42 position 42 on chromosome 1

chr2:300-433 range 300-433 on chromosome 2

When viewing a chromosome
451 position 451 of current chromosome

23-4343 range 23-4343 of the current chromosome

When viewing a genome 3 chromosome or contig 3

If you forget how to enter a query, hover over the sequence selector or text box to reveal a list of sample
queries.

A variety of separators (e.g., spaces, < or > symbols) are accepted between the endpoints in a range. For
example, all of the following are accepted: 300-433, 300 433, 300..433, 300>43 and 433<300. You can also
paste in a range obtained from a variety of external sources, including SeqNinja and the National Center for
Biotechnology Information (NCBI).

Example: The following image shows an example where both the sequence selector and the text box were
used to perform a search.
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After pressing the Go button, the location will automatically be saved to the Recent section of the Places
panel. This section is similar to the “recent items” cache in other computing contexts, and allows you to
return to the same location in the future.

To move the cursor to a particular feature:

Type the feature name into the text box. As you begin typing, possible matches will appear in a list below.
To pick one of them, use the up/down arrow keys or the mouse. Press the return key or Go to gene or

location specified button ( ) to go to the selected item. You can also go to an item by double-clicking on
it in the list.

After pressing the Go button, the location will automatically be saved to the Recent section of the Places
panel. This section is similar to the “recent items” cache in other computing contexts, and allows you to
return to the same location in the future.

To go back to the last recent place:

Click the left arrow ( ). The arrow is only enabled if another location was visited prior to the current
location. Note that more recently-visited places are higher up on the list.
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To go forward to the next recent place:

Click on the right arrow ( ). The arrow is only enabled if you returned to this location after first visiting
another location.
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Customize the Look and Layout
The following topics describe ways in which you can customize the appearance of views and panels:

• Change font style and size

• Change the order of sequences, assemblies or genomes

• Change the Analysis view color scheme

• Wrap the Analysis view display

• Detach or reattach a view

• Display or hide a vertical guideline

• Move a view or panel

• Resize a view, panel or section

• Scroll horizontally or vertically

• See a view in full-screen mode

• Show or hide an element of the interface

• Split a view horizontally or vertically

• Zoom in and out

• Return to the default layout
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Change font style and size
The font style and size for text in the views are specified in different sections of the Style panel:

• Analysis view fonts are customized within the Sequence section.

• Overview fonts are customized within the Overview section.

Customization for font style and size applies to all text in the view. Individual rows cannot have different
styles or sizes.
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Change the order of sequences, assemblies
or genomes
To move one or more sequence or assembly rows as a group:

Sequence and assembly rows in the Overview or Analysis view may be rearranged one at a time or as
contiguous groups using drag and drop.

1. Select the desired rows using Ctrl/Cmd+click or Shift+click.

2. Drag the selected row(s) to the desired location and release the mouse button.

Any ordering changes made to one view are simultaneously made to the other.
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Change the Analysis view color scheme
The foreground and background color schemes for the Analysis view are specified in the Sequence section
of the Style panel. To open the section, click on the expand bar entitled Analysis, or choose View > Style >
Analysis.

To change the letter color in the Analysis View, check the Color foreground box. To change the
background color (boxes around each letter), check the Color background box. Then make selections from
the corresponding drop-down menus. Note that the color options are disabled unless a session is open in
GenVision Pro.

• Color by Chemistry – This is the default color scheme, and matches the colors used in DNASTAR’s
Protean 3D application. Amino acids are colored according to their side chain chemistry:

• Shapely – This color scheme matches the RasMol amino acid and RasMol nucleotide color schemes,
which are, in turn, based on Robert Fletterick’s “Shapely models.”
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• Taylor – This color scheme is taken from Taylor (1997) is also used in JalView (Waterhouse et al.,
2009).
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• Zappo – This scheme colors residues according to their physico-chemical properties, and is also used
in JalView (Waterhouse et al., 2009).

• Solid – These scheme colors residues with the color shown. After selecting Solid, you can specify
the color by clicking on the colored box to the right of the menu.
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Wrap the Analysis view display
To wrap the display in the Analysis view:

In the Style panel’s Analysis section, select Automatic wrapping from the Layout drop-down menu. The
Analysis view will immediately wrap horizontally.

If you had been using a Linear layout and had already split the sequence portion of the view vertically,
choosing Automatic wrapping will change vertical splits to horizontal ones. Also, the scroll bars will move
from the bottom of the view to the right.

When the Analysis view is split, the Overview provides a separate “viewport indicator for each section. Splits
are ignored when printing or exporting an image, although the layout is preserved.
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Detach or reattach a view
To detach the Overview :

Use View > Overview > Detach or right-click on the view tab and choose Detach Overview View.

To detach the Analysis view :

Use View > Analysis > Detach or right-click on the view tab and choose Detach Analysis View.

To reattach all detached views:

Use, View > Reattach All Views.
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Display or hide a vertical guideline
To toggle between displaying or hiding a vertical guideline in the Analysis view, click Analysis > Show
Guideline. A vertical guideline is displayed by default, and is a navigational aid to help in guiding your eye
between sequences and tracks.
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Move a view or panel
To move a view up or down:

• Overview – Right-click on the Overview tab and choose Move Overview View Up or Move Overview
View Down.

• Analysis view – Right-click on the Analysis tab and choose Move Analysis View Up or Move
Analysis View Down.

To move a tabbed view or panel manually:

Use the mouse to grab the tab, then drag and drop it in the desired location.
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Resize a view, panel or section
To increase or decrease the size of a view or panel:

Do either or both of the following:

• Drag the bottom or left sides of the item using the mouse.

• Drag the light gray divider bar between the panes to the left or right.

Overview:

Analysis view:

To view more of an open section within a panel:

Do either or both of the following:

• Close neighboring sections by clicking on their expand bars.

• Increase the size of the panel.
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Scroll horizontally or vertically
To scroll horizontally:

Do any of the following:

• Use the horizontal scrollbar.
• Hold down the Alt key (Win) or Option key (Mac) and drag the mouse.
• Drag the mouse left or right in the Overview or Analysis view.

To scroll vertically:

• Use the vertical scrollbar.

To move up or down the list of tracks :

Either:

• Use the mouse wheel.
• Use the vertical scrollbar on the right.

Note The presence or absence of scrollbars depends upon the reference sequence length
and the current zoom level.*
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See a view in full-screen mode
To show the active view in full-screen mode:

Either:

• Press the Full Screen tool ( ).

• Use Ctrl/Cmd+Shift+F.

To exit from full-screen mode:

Do any of the following:

• Use the Exit Full Screen tool ( ) at the bottom of the full-screen view.

• Press Ctrl/Cmd+Shift+F.

• Click the Esc key
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Show or hide an element of the interface
Interface
element
type

To show To hide

Views

If neither view is visible, click the Restore
icon.

To see both views when only one is
displayed, either:

• Use View > Split.

• Press the Split ( ) tool in the
bottom right corner of the current
view.

To hide both views, either:

• Click the Close ( ) or Minimize ( )
icons.

• Right-click on a view tab and choose
Close, Close Others, Close Tabs to
Right, or Close All.

To hide one of the two views that is
currently displayed, either:

• Click on the tab of the view you wish to
preserve, then use View > Split.

• Press the Remove Split ( ) tool in the
bottom right corner of the view you wish to
preserve.

Panels

Do any of the following:

• Click on the panel tab
• Use the associated View menu

command.
• Click the Restore icon (see above)

Do either of the following:

• Click the Close ( ) or Minimize ( )
icons.

• Right-click on a view tab and choose
Close, Close Others, Close Tabs to
Right, or Close All.

Panel
sub-
sections

Click on a closed expand bar (medium gray
bar) or use the associated View menu
command.

Click on an open expand bar.
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Split a view horizontally or vertically
To view different sections of sequences, assemblies or genomes simultaneously, you can split the Overview
or Analysis view into any number of panes.

To split a view vertically:

• Use Overview > Split View or Analysis > Split View. The split can be moved by dragging it left or
right with the mouse.

• Drag the vertical splitter tool ( ), found at the right edge of the view, in a leftward direction.

Overview:

Analysis view:

To split a view horizontally:

Drag horizontal splitter tool ( ), found at the bottom of the view, in an upward direction.

To automatically remove the right-most vertical split:

Use Overview > Remove Split or Analysis > Remove Split.
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To remove any split:

• Drag the divider as far as you can to the side/top/bottom of the view and drop it there.

Notes:

• When the Analysis view is split vertically, the Overview provides a separate “viewport indicator for
each section.

• Splits are ignored when printing or exporting an image, although the layout is preserved.
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Zoom in and out
Both the Overview and Analysis view have independent vertical and horizontal zoom sliders. Grab any
green slider with your mouse and drag left/right or up/down to zoom in or out in the view.

The following table shows the look of the Analysis view sequences and a numeric track at different zoom
levels.

Track Maximum Zoom Minimum Zoom

Sequences

Numeric tracks

Note that when zooming past the point where a single base corresponds to single screen pixel, the
sequence track is shown a gray bar.
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Return to the default layout
To return to the default GenVision Pro display:

Choose View > Reset Panel Layout. This command restores the default layout of panels, including opening
any default panels that have been closed; and restoring panels that have been minimized or maximized. It
will not reattach a detached view. In that case, use View > Reattach All Views instead.
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Add Data
Once you have created a GenVision Pro session, the next step is to add data. See the following topics for
information:

• Add sequences
• Add assemblies
• Add genomes from NCBI
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Add sequences
To add sequences:

To add a genome sequence to the session in Genbank (.gbk) or FASTA (.fasta) format, do any of the
following:

• Use the Add sequences to project button tool ( )

• Choose File > Add Sequences.

• Press Ctrl/Cmd+E

You can add additional sequences at any time. However, once sequences are added, they cannot be
deleted from the session. Note that it usually takes longer to add sequences to GenVision Pro than it does
to add assemblies.
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Add assemblies
To add SeqMan NGen .assembly packages:

Do any of the following:

• Drag & drop one or more assemblies on an open GenVision Pro session

• Press the Add assemblies to project button tool ( ).

• Choose File > Add Assemblies

• Press Ctrl/Cmd+Shift+E.

For all but the first option on the list above, you will be prompted to select an assembly (or folder of
assemblies) from the file browser. After making a selection, press OK. Note that double-clicking is not
supported in this situation.

The following table shows warning messages that you might encounter when adding an assembly to a
session.

Warning Explanation

Please pick an assembly or a
directory containing assemblies.

The item selected was not an assembly project or a folder containing
an assembly project.

Unable to add duplicate data source. The selected assembly has already been added to the current session.

Most of the sequences being added
from the assembly “<assembly
name>” do not match those in the
document. Add data anyway?

Most contigs or chromosomes in the selected assembly do not match
those of assemblies already in the session. Click OK to add the
assembly anyway, or Cancel to close the dialog without adding the
assembly.

Feature index not found for
assemblies. Index features now?

If this prompt appears, we recommend choosing Yes. Choosing Yes
simply causes a “feature index” file to be quickly created and added to
the original assembly file package. A detailed explanation of “feature
index” appears below this table.

“Feature index” description:

During assembly, SeqMan NGen 14.0 (and later) automatically includes a features index file as part of the
assembly package. GenVision Pro uses the file for rapid access to features. The presence of a features
index allows you to navigate to a gene by name and to view features in the Features panel.

An assembly built in an older version of SeqMan NGen will initially lack this feature index. When you add
such an assembly to a GenVision Pro session, this message asks whether you wish to have a feature index
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created automatically. If you click Yes, a file will be created and stored within the original assembly data. If
you click No, no file will be created, and the assembly will be added to the session without indexing. This
will cause loss of the functionality described in the paragraph above. If you decline to create the feature
indices, you may be prompted again when the assembly project is used a different session.

If you add a set of assemblies built using equivalent reference templates, and respond Yes to this prompt, a
feature index will be created for just one member of the set. In this case, the genome templates for other
members of the set are not loaded into GenVision Pro. Note that if you later add one of the non-indexed
assemblies to a different GenVision Pro session, you will again be prompted to index, as the new GenVision
Pro session will no longer have access to the indexed assembly. Also, if you add assemblies that have
additional chromosomes from those added earlier, one of the “expanded” assemblies will also need to be
indexed.

Example: Say you start a GenVision Pro session by adding some human female assemblies from SeqMan
NGen v. 13.0. You respond Yes to the indexing prompt, and a feature index is created for one of the
assemblies. This index will lack feature indexing for the Y chromosome, since all samples so far are female.
If you then add human male assemblies that have the additional chromosome Y, one of the male
assemblies will need to be indexed.

Note: In order for GenVision Pro to add the index file, you must have “write” permission for the assembly
package. If you do not, someone with Administrator status may need to do this step for you. Alternatively,
you can copy to the assembly to a location where you have write permission.
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Add genomes from NCBI
To import a genome from the National Center for Biotechnology Information (NCBI) database via organism
name or accession number:

1. Choose File > Download and Add Genome or press the Download and add a genome to the

session button to ( ).

2. In the Download Genome Reference dialog, use the Download dropdown menu to choose between
downloading a Whole genome or By accession numbers.

• If you select Whole genome, GenVision Pro will retrieve the most recent build of the selected
genome. Use the next two drop-down menus to select the Organism type and Organism.

• ◦ If you select By accession numbers, the Organism section disappears and is replaced by an
Accession numbers entry area. Type an accession number or paste it from your clipboard, then
press Add to add a number to the list. Continue adding numbers, as desired. Multiple accession
numbers should be separated using a space, comma, semi-colon or line break. To remove an

Note: GenVision Pro will download all the reference sequences from the NCBI
Entrez Genome Project database for the selected genome. These downloads may
include auxiliary genomes such as mitochondria and chloroplasts. They may also
include some contigs which have not yet been placed by the genome finishing
process.

*

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 86 of 136

https://www.ncbi.nlm.nih.gov/


accession number from the list, select it and click Remove.

3. Click Browse to select a name and location in which to save the downloaded genome files.

4. If you do not need to download additional genomes, you can check Close dialog when complete.
Otherwise, leave the box unchecked to keep the dialog open after initiating the current download.

5. Press Download. Once the download is complete, a message like the one below will appear.

6. Click OK to close the dialog and add the accessions to the GenVision Pro session. If you checked
Close dialog when complete, the Download genome reference dialog will also close. Otherwise, it
will remain open so that you can download additional NCBI genomes.
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Tip: Some large genomes may take extra time to download. In the meantime, you can work
on a different GenVision Pro session by clicking on its tab.*
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Specify the Data Rows to Display
The Overview can display one or many chromosomes, contigs or sequences simultaneously. However, only
one of these at a time may be displayed in the Analysis view.

To display Overview rows for all uploaded session data:

Either press the Home ( ) button tool or use the navigation tools to choose (Genome) from the drop-
down menu.

To display an individual chromosome, contig or sequence in both the Overview and Analysis view:

Either double-click on the name of the chromosome, contig or sequence in the Overview, or use the
navigation tools to make a selection other than (Genome) from the drop-down menu.
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Rename Sequences
Once you have loaded sequences into GenVision Pro, you can rename them in either of two ways. See the
following topics for details:

• Create names automatically using specified data fields

• Rename a single sequence manually
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Create names automatically using specified
data fields
The Edit > Rename with Fields command lets you create labels for one or more selected sequences
automatically, using specified fields such as sequence length, organism, or description. The custom labels
are then displayed for those sequences within the GenVision Pro application.

To rename sequences using specified data fields:

1. Select one or more sequence names from any GenVision Pro view.

2. Right-click on the selection and choose Rename with Fields, or instead choose Edit > Rename with
Fields from the main menu. Making no selection prior to using the main menu command is equivalent
to selecting all sequences.

The Choose Label dialog opens with the Display drop-down menu set to One or more fields.

Note: If you selected a single sequence and wish to rename it manually, select Custom
label from the drop-down. Then follow the instructions in Rename a single sequence
manually.
*

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 91 of 136



The left pane shows available fields, and the right pane shows fields that will be displayed as part of
the sequence name. Initially, Default name is the only field listed in the right pane. An example
showing the appearance of the name using the specified field(s) appears in the Example box at the
bottom of the dialog.

3. Select and organize the fields you wish to display as part of the sequence name:

• To add or remove items, move them between panes using the left and right arrows ( ). Use
the up and down arrows on the right ( ) to specify the order in which displayed fields should
appear.

• By default, a hyphen (-) is included between each of the displayed fields. If desired, type in a
different Separator. Or remove all text in the Separator box to include nothing between the
fields.

• The Example text box shows what the label will look like with the current selections. This text
can be manually edited, if desired.

4. When you are satisfied with the choices made in this dialog, click OK to save changes and exit from
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the dialog. Or click Cancel to leave the dialog without saving any changes.
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Rename a single sequence manually
The Edit > Rename command lets you manually enter a label (name) to display for those sequences within
the GenVision Pro application.

To manually rename a single selected sequence:

1. Select a single sequence name from any GenVision Pro view, then right-click on it and choose
Rename. Alternatively, select the sequence name and choose Edit > Rename.

The Choose Label dialog opens with the Display drop-down menu set to Custom label.

2. Type the desired name into the Label text box.

3. Click OK to save changes and exit from the dialog, or Cancel to leave the dialog without saving any
changes.

Note: To instead name the sequence using specified data fields, select One or more
fields from the drop-down. Then follow the instructions in Creating names automatically
using specified data fields.
*
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Find a Location
To navigate to a specific spot in the sequence:

To move the cursor to a specific point on the sequence, do any of the following:

• Use the navigation tools near the top of the GenVision Pro window.

• Open the Places panel and double-click on a previously-stored location.

• Use Edit > Go to Place or press Ctrl/Cmd+J. In some cases, the right-click option Go to Position
may also be available. In the Go to Place dialog, type the desired text and click OK. Using this dialog
is equivalent to typing a search query in the navigation area text box and pressing the Go button.

The following video shows several of these search functions in action:

To navigate to a general area of the sequence:

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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The light-blue vertical bar in the Overview, known as the “viewport indicator,” can be used as a navigation
tool.

The viewport highlights the portion of sequence displayed in the Analysis view. The shading between the
vertical lines of the viewport indicator corresponds to the range of sequence currently visible in the Analysis
view.

Here are some examples of how the viewport can be used as a general navigation tool:

• Drag the indicator to scroll the Analysis view along the sequence.

• Double-click on any block in the Overview to center the Analysis view at that position. Once an
Overview block has been selected, double-click anywhere on it to move the cursor to that location.

• Once you have centered the viewport in the desired location, use the horizontal zoom slider in the
Analysis view to increase or decrease the width of the view.

• If you split the Analysis view, there will be more than one viewport indicator in the Overview. If you
split the Overview, a viewport indicator may appear in more than one of the sub-panes.
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Make a Selection
Within the Analysis view, you can select an entire chromosome, a portion of one, or a specific portion of
chromosome corresponding to a feature. The active selection is highlighted in light blue. The selection can
then be copied to the clipboard in standard or FASTA format.

To select… Do this…

One or more rows
In either the Overview or Analysis view, click on a row label to make it the
active selection, and click again to deselect it. To select multiple rows, use
Ctrl/Cmd+click or Shift+click.

The entire active chromosome Use Edit > Select All.

A portion of the active
chromosome

Drag the mouse across residues in the sequence track while holding down
the left mouse button.

Only the portion of a single
sequence associated with a
section of track (e.g. a Gap
Fraction peak, etc.)

Drag the mouse across the open track while holding down the left mouse
button.

One or more tracks Click on a track to select it. To add additional tracks to the selection, use
Ctrl/Cmd+click or Shift+click.

One or more features and
corresponding sequence

Click on a feature to select it. To add additional features to the selection, use
Ctrl/Cmd+click.

The portion of a single
sequence associated with a
feature

Do any of the following:

• Click on the feature to select it, then use Edit > Select
Subsequence.

• Click on the feature to select it, then right-click and choose Select
Subsequence.

• Double-click on the feature under the sequence.

Additional continuous items,
when the first endpoint has
been selected

Use Ctrl/Cmd+Shift and click on the other endpoint.

Toggle selection of items on
or off

Hold down the Ctrl/Cmd key while clicking on the items to toggle on or off.
For subsequence selection, hold down the Ctrl/Cmd key while dragging the
mouse.

The current selection, but
expanded to encompass
additional bases

You can extend the length of an existing selection by Shift+clicking on the
new endpoint. The selection will expand to use the chosen base as the new
endpoint. If there are multiple selected ranges, the one closed to the chosen
base will be expanded.
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Work with Tracks
Tracks are rows of information pertaining to a header, footer, or individual sequence row in the Overview
and Analysis view. Tracks may be displayed or hidden, as desired, and some tracks may change in
appearance depending upon the zoom level.

The following tracks can be applied, removed or (in most cases) edited:

• Ruler
• Feature and Region
• Numeric
• Sashimi

The following table shows tasks that affect the display of tracks within the Overview and Analysis views:

Task How to…

To create tracks
Track data can be imported manually, imported automatically with some types of sequence
data (e.g., Feature and Region tracks), or can be calculated by the application itself (e.g.,
Ruler and Numeric tracks).

To display tracks
in the views

To display any type of track, you must check the box next to the name of the track in the
Tracks panel. This is the only condition needed to view a Ruler track. For any type of track
other than a Ruler, you must also select a single sequence to display (as opposed to a
genome) and expand the track as described below.

To expand/
collapse tracks
for selected
sequences

Do any of the following:

• Click the plus/minus sign to the left of the sequence name ( / ).

• To expand tracks for selected sequences, choose Sequence > Expand
Sequence Rows or Overview > Expand Overview Rows; or right-click on the
selection and choose Expand.

• To collapse tracks for selected sequences, choose Sequence > Collapse
Sequence Rows or Overview > Collapse Overview Rows; or right-click on the
selection and choose Collapse.

To expand/
collapse tracks
for all sequences
in a particular
view

Ensure that no sequences are selected.

• To expand tracks for all sequences, choose Sequence > Expand All Rows or
Overview > Expand All Rows; or right-click in the view and choose Expand All.

• To collapse tracks for all sequences, choose Sequence > Collapse All Rows or
Overview > Collapse All Rows; or right-click in the view and choose Collapse
All.
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To hide tracks

Do one of the following:

• To hide a specific track from all views, uncheck the box next to the name of the
track in the Tracks panel.

• To hide a specific track in one view only, right-click on the track within that view
and choose Hide Track. Alternatively, select a track and use Edit > Delete or
press the Delete key.

• To hide all tracks in one view only, click the minus sign ( ) to the left of the
sequence name in that view, or use Analysis > Collapse Sequence Rows or
Overview > Collapse Sequence Rows.

• To hide all tracks in all views, do a combination of the above, or display a genome
instead of a single sequence.

To access the
options for a
particular type of
track

Do either of the following:

• Right-click on a track in either view and choose Show Track Options.

• Click View > Tracks > Options or open the Tracks panel and click the Options

bar ( ), then do either of the following to specify the track of interest by
clicking on its name in the Tracks panel.

To change the
order of all tracks
in a view

Open a sequence row to view its track. Then drag a track label (e.g. “Features”) to the
desired position among the other tracks and drop it there. Note that if you turn off some
tracks in the Tracks panel and add them again later, they will appear in the order in which
their boxes were checked.

To increase/
decrease the
vertical height of
a visible track

Hover the mouse over the bottom of the track in the Overview or Sequences view, then grab
the resize bar and drag it up or down.

To see how the
zoom level can
affect the
appearance of
tracks

See Zoom in and out.
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Import track data
GenVision Pro lets you import an accessory file with track information for one or more assemblies.

1. Choose File > Add Tracks, press the Add Tracks to Project tool ( ) or press Ctrl/Cmd+Shift+T.

2. In the file chooser, navigate to and select the desired file. There are three allowable file types: BED
(.bed), GenVision file (.txt; formatted as a histogram or arrow panel) and Wiggle file (.wig). For
instance, you could use a targeted region BED file from a SeqMan NGen assembly, or a box file from
DNASTAR’s original GenVision application. Press Open.

3. In the ensuing Add Track dialog, use the drop-down menu to select the Track category for the file
you chose in the previous step. Choices will include a subset of Feature, Region, Coverage or
Custom. You can type a custom value directly into the field. Optionally, you can choose the Custom
menu item to clear the field.

GenVision Pro will use the Track category to place the track in the hierarchy in the Tracks panel and
determine default track options.

4. Press OK to add the track to the current session.

The following table shows error messages that may occur when attempting to import track data:

Error Message Explanation

Some data could not be
mapped to document
members.

This message appears if some of the sequences identified in the track data
could not be matched automatically to sequences in the session.

This file is already loaded in
this document. The selected file has already been added to the current session.

Could not open file. The file does not contain recognizable track data.
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Ruler tracks
Header and footer rulers:

The visibility of header and footer rulers in the Overview and Analysis view is dependent on:

• Which boxes you check in the Tracks panel (see image below).

◦ Ruler – Overview header

◦ Ruler 1 – Analysis view header

◦ Ruler 2 – Analysis view footer

• Whether or not tracks are visible in the Overview and/or Analysis view. To display tracks, click on the
plus sign next to the sequence in the view of interest.

Sequence rulers:

The visibility of sequence rulers in the Overview and Analysis view is dependent on:
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• Which boxes you check in the Tracks panel (see image below).

◦ Sequence Ruler (under Overview Details) – Check this box to display sequence ruler tracks in
the Overview.

◦ Sequence Ruler (under Sequence Details) – Check this box to display sequence ruler tracks
in the Analysis view.

• Whether or not tracks are visible in the Overview and/or Analysis view. To display hidden tracks, click
on the plus sign next to a sequence in the view of interest.

Changing Ruler options:

Currently, the Ruler tracks do not have editable options.

However, you can add white space above and/or below the ruler using sliders in the Layout section.
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Feature and Region tracks
Feature and region tracks may come from the sequences in an assembly, or can be imported separately
using File > Add Track.

To display features:

The visibility of feature or region tracks in the Overview and Analysis view is dependent on:

• Whether or not tracks are visible in those views. To display hidden tracks, click on the plus sign next
to the row of interest in the Overview or Analysis view.

• Whether a track added using File > Add Track contains data relevant to the chromosome being
viewed.

• Which boxes you check in the Tracks panel (see image below).

◦ Features (under Overview details) – Check this box to display any available features as
Overview tracks.

◦ Features (under Analysis details) – Check this box to display any available features as
Analysis view tracks.

Note: If File > Add Track was used, there may be multiple feature and/or region tracks
available. Additional feature and region tracks are placed under the parent items
“Features” and “Region,” respectively.
*
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To view a tool tip with details about a region or feature, hover over it with the mouse. Or select one or more
features or regions by clicking on them. You can then view information about them in the Details panel.

Features are displayed with the same default color scheme in both GenVision Pro and MegAlign Pro.

Inferred features:

An asterisk next to a feature name indicates that the feature was inferred by SeqMan NGen. For example, if
you assembled data in SeqMan NGen using a template that contained a CDS feature—without a
corresponding gene feature—then "gene" would be inferred at that position, and would be displayed in the
Feature track. However, the inferred gene would be marked with an asterisk.
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To change feature options:

To learn how to access the options section for this track, see Options section.

Specify the number of feature rows to display by typing a number in the Rows box or by using the up/down
arrows. If features are overlapping, this indicates a need to increase the number of rows.

The example below displays 5 rows of features.

You can also add white space above and/or below features tracks using sliders in the Layout section.

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 105 of 136



Numeric tracks
Sources of numeric tracks in the Analysis view :

• Numeric data of any type imported via a Wiggle file using File > Add Track.

• Coverage tracks imported with an assembly. This track displays a plot of values along one or more
sequences in the session. Values are obtained automatically from assemblies added to the session.
When the Coverage track is visible, it consists of a graph showing the depth of sequence coverage for
each nucleotide position along the Analysis view.

To display numeric tracks:

The visibility of numeric tracks in the Analysis view is dependent on:

• Whether or not tracks are visible in the Analysis View. To display tracks, click on the plus sign next to
the sequence of interest.

• Whether a track added using File > Add Track contains data relevant to the chromosome being
viewed.

• Whether or not the corresponding box is checked in the Tracks panel.

To change numeric track options:

To learn how to access the options section for this track, see Options section.

Note: If File > Add Track was used, the Tracks panel may list multiple numeric tracks.*
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• Select from three different Graph types (Line, Skyline, Bar) by clicking on the corresponding icon.

• By default, numeric graphs are displayed in green with a pale yellow background. To choose another
graph color, click on the box to the right of Color to make a selection from a color chart. To choose
another background color, click the color box to the right of the Background checkbox. To turn off the
background color, uncheck the checkbox.

• Use the first Gridlines drop-down menu to select which grid-lines to display: Both (horizontal &
vertical), Horizontal (only) or None. Use the second drop-down menu to choose whether grid-lines
should be visible above (Over graph) or below (Under graph) other parts of the graph.

• Check the Smooth box if you wish to average the values over a specified number of residues.
Smoothing is computed by averaging values in a sliding window of the specified number of residues.
Enter the number of residues in the adjacent text box (maximum=5000). Inputting a high value will
smooth the graph curves, while a low value will highlight local differences.

• To change the range of values displayed, enter new y-axis endpoints in the Range text boxes. The
default range may be too large or too small for some sections, causing the graph to appear empty or
peaks to be cut off. You may need to raise or lower the second value, in particular, in order to see the
graphical display clearly.

• Check the Use logarithmic scale box and select an option from the corresponding drop-down menu
if you want to use a logarithmic, rather than a linear scale. Options are log2 or log10.

Click if you wish to return to the default values.

Note: The log of 0 is not defined. Therefore, log values for the track are calculated as
follows: For y > 0, y’ = log(y); otherwise, it is displayed as a 0.*
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To change the height of the graph, and the white space surrounding it, use the sliders in the Layout section.
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Sashimi tracks
Analysis of mRNA isoform expression is a key aspect of understanding gene expression. For many genes,
the change in isoform ratios for a given gene produce a more significant physiological effect than the overall
expression level of that gene. Isoforms are typically visualized as Sashimi plots, a way of quantitatively
visualizing splice junctions for mRNA sequences aligned to an annotated genomic reference. Sashimi plots
allow you to screen differentially spliced exons in genomic regions of interest.

When the Sashimi track is visible in the Analysis view, it consists of two components:

• A bar graph showing the abundance of each exon

• Arcs representing the number of reads split across the junction, also referred to as “junction depth.”

Multiple Sashimi plots from multiple samples can be displayed simultaneously.

Scroll to the bottom of this page to see two videos showing Sashimi tracks in action.

Sashimi track data can come from the sequences in an assembly, or can be imported separately using File
> Add Track. When data are available for a given sample, GenVision Pro automatically replaces the
Coverage track with a Sashimi plot, which contains the same Coverage histogram, but also allows for “arcs”
to be displayed. The number at the top of each arc represents the number of split reads; the thickness of
each arc is proportional to this number. Note that split reads do not necessarily correspond to introns; other
types of structural variation can also cause SeqMan NGen to split reads. Annotations are not considered
when creating the Sashimi track.

For a brief video showing RNA-Seq data analysis using the Sashimi track, see the second video in Launch a
session from within ArrayStar.

To display a Sashimi track:

The visibility of Sashimi tracks in the Analysis view is dependent on:

• Whether or not tracks are visible in the Analysis view. To display tracks, click on the plus sign next to
the sequence of interest.

• Whether a track added using File > Add Track contains data relevant to the chromosome being
viewed.
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• Whether or not the Sashimi box is checked in the Tracks panel. Note that if File > Add Track was
used, the Tracks panel may list multiple Sashimi tracks.

To change Sashimi track options:

To learn how to access the options section for this track, see Options section.

• By default, Sashimi graphs have navy blue arcs and purple coverage histograms. To choose different
colors, click on the Arc color and/or Coverage color box and make a selection from a color chart.

• By default, arc numbers (“labels”) and the Sashimi plot, as a whole, do not have background colors.
To add colors, check Label background color and/or Background color, then click on the
corresponding color box and make a selection from a color chart. To turn the colors off again,
uncheck either or both check-boxes.

• Minimum read count lets you set a threshold for the minimum number of split reads needed to
display an arc. If this value is set to zero, no filtering will occur.

• Maximum span allows you to set a threshold for the maximum allowable arc length, in bases. To turn
off this filter, delete any numbers from the text box, leaving it blank.

• Under Coverage y-axis, set a Maximum limit for the height of the y-axis on the coverage graph. This
setting is equivalent to the Y-axis range maximum in the Numeric track options.

Click if you wish to return to the default values.
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This video shows how to apply and interpret Sashimi plots in GenVision Pro:

This video shows an RNA-Seq workflow that begins with assembly in SeqMan NGen, proceeds to
downstream analysis in ArrayStar, and then uses ArrayStar’s Send Selection to GenVision Pro command
to open the results in GenVision Pro. Once in GenVision Pro, the Sashimi track is applied. (GenVision Pro
section begins at 2:41).

Note: The height of track labels is specified using the presentation Font settings in View >
Style > Analysis. To change the height of the graph and the white space surrounding it,
use the sliders in the Layout section.
*

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a
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Use Basic Editing Commands
The following basic editing commands are available in GenVision Pro:

Command Keyboard
Shortcut

Right-
Click
Option

Description

Edit > Cut Ctrl/Cmd+X Cut This command is not enabled in GenVision Pro.

Edit >
Copy Ctrl/Cmd+C To copy text or data to the clipboard. A warning message will appear if

you attempt to copy an extremely large amount of data to the clipboard.

Edit >
Copy As
FASTA

Ctrl/
Cmd+Shift+C

Copy
as
FASTA

To copy text or data to the clipboard in FASTA file format. This command
is only available if a subsequence is selected.

Edit >
Paste Ctrl/Cmd+V To paste text from the clipboard into a text field. This command is

disabled in all but a few circumstances.

Edit >
Delete Delete key

To remove selected text from a text box, or to remove one or more
selected tracks from the Overview and Analysis view. Using Edit >
Delete or pressing the Delete key has the same effect as unchecking the
corresponding box(es) in the Tracks panel.

Edit >
Select All Ctrl/Cmd+A If used in the Overview, selects all chromosomes. If used in the Analysis

view, selects all of the active chromosomes in both views.
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Copy
In many cases, once you have selected text, data, sequences or subsequences, you can copy the
information to the clipboard. The copy functions described below are accessible using menu commands,
context menu commands (i.e., “right-click options”), and/or keyboard shortcuts.

• Edit > Copy or Ctrl/Cmd+C – Copies the selected text, just as it appears in the view.

◦ If a portion of sequence or one or more features are selected, this command copies the
selected subsequence(s) as one long string, including the gaps. The subsequence is copied as
one long string, without line breaks. If the selection extends across multiple members of the
alignment, names are included as prefixes.

◦ If a selection is made in the Style panel and in dialogs, use Ctrl/Cmd+C.

• Edit > Copy As FASTA – Copies the selected text or data in FASTA format.
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Export
GenVision Pro lets you export an image of either view for use in a text editor or similar program. A separate
topic describes how to edit an exported image using Microsoft Powerpoint.

To export an image of the Overview or Analysis view :

1. Choose File > Export Image > Overview or File > Export Image > Analysis.

2. Specify the file name and choose the export format: Adobe PDF (.pdf), Microsoft PowerPoint-
optimized (.pptx), PNG image (.png) or JPG image (.jpg, .jpeg).

• If you choose Adobe PDF format and a particular font is not supported there, a similar font will
be substituted for the original one automatically.

• If you choose the format that is optimized for use with Microsoft PowerPoint, the GenVision Pro
image is converted into an editable set of objects that can be grouped, ungrouped and moved
within the target application. To constrain an object (e.g., a GenVision Pro track) within
Microsoft PowerPoint to move only vertically, rather than laterally, hold down the Shift key.

If exporting the Analysis View, the following dialog appears. If exporting the Overview, an abbreviated
version appears.

3. Choose export options.

• Use the Range of sequence boxes to specify the range of residues that should appear in the
image. The default is the current viewport range.

• (“Analysis” only) Type in the number of Residues per line. By default, GenVision Pro places
the entire range on a single line.

• (“Analysis” only) Check the Include dividing lines box if you wish to include separators

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 114 of 136



between the header, sequences, and footer.

The Resulting image size updates automatically based on the options you choose.

4. Click OK to export the image using the specified options or Cancel to close the dialog without
exporting.
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Edit an exported image in PowerPoint
The following video shows how to edit exported images of your alignment or genomic tracks within Microsoft
PowerPoint:

<div class="player-unavailable"><h1 class="message">An error occurred.</h1><div class="submessage"><a

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 116 of 136



Print
To print an image of any GenVision Pro view, whether it is currently active or not, choose File > Print or
press Ctrl/Cmd+P. The Print Document dialog opens:

• Use the Printer drop-down menu to choose the desired printer from a list of available options.

• Specify the content you wish to print (Overview or Analysis view ) using the Content to print menu.
Depending upon the selection, additional options may appear just below this drop-down menu.
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◦ Overview and Analysis View - To print only a sub-range of the sequence(s), type the left and
right residues into the Range of sequence boxes.

◦ Analysis View - To specify how many residues to include on one line, type in a number from
1-100 next to Residues per line. Check the Include dividing lines box if you wish to include
separators between the header, sequences, and footer.

• Choose which Page Size to print on.

• Specify the top, bottom, left and right Margins by typing a number in the associated box and choosing
the units (inches, cm, etc.) from the nearby drop-down menu.

• Choose whether to print in Portrait or Landscape orientation.

• Under Page Options, use the checkboxes to specify what to include in the footer: footer text, date
and time and/or page numbers. If you check Include footer text, the footer will incorporate the text
just below the checkbox. By default, this is the path and GenVision Pro session name (or only the
default session name, for unsaved documents), but you may type in any text that you wish.

• Click the Print with options link to launch the default Print dialog for your computer.

Choose Cancel to exit from the GenVision Pro Print Document dialog without printing. Click Print to print
using the selected parameters, or Print with Options to open the Print dialog for your computer’s operating
system. The generic dialog can be used to specify additional options, such as the page range and number
of copies to print.
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Change the default print size
Unless otherwise specified on your computer, the default printing size for all DNASTAR applications is “U.S.
Letter” size (8.5 × 11 inches = 21.6 × 28 cm). You can temporarily change to another size, such as A4, from
within the application. However, the next time you print, the default size will again be U.S. Letter size.

To correct this issue, you need to change your computer’s default printing size:

On Windows 7 and Windows 8:

1. Open the Control Panel.

2. In the Hardware and Sound category, click on Printers or View devices and printers.

3. Right-click on your printer and choose Properties.

4. In the General tab, click on the Printing Properties button.

5. In the ensuing Printing Shortcuts tab, choose the desired default printing size from the Printing
Sizes drop-down menu.

6. Click the Apply button, then the OK button.

On Macintosh:

1. Open System Preferences.

2. Click on Print & Fax.

3. Choose the desired size from the Default paper size drop-down menu.

Note: Changes to the default printing size will not be applied until after you restart the
DNASTAR application.*
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Save, Close and Exit
To save one or more sessions:

To save one or more sessions or to overwrite a previously saved version of the session in GenVision Pro
(.gvp) format

• To save all open sessions, use File > Save All Sessions or press Ctrl/Cmd+Shift+S.

• To save only the active session, do any of the following:

◦ Use the Save Session button tool ( ). If you want to preserve the earlier version of a
session, or store a copy of the session with a different name or location, use File > Save
Session As instead.

◦ Choose File > Save Session

◦ Press Ctrl/Cmd+S.

In all cases, GenVision Pro saves to the desktop by default.

To close the selected session:

Use File > Close or press Ctrl/Cmd+W. If multiple sessions are open, first select the tab corresponding to
the session you wish to close.

To quit the application:

• Windows: Use File > Exit or Ctrl+Q.

• Macintosh: Use GenVision Pro > Quit GenVision Pro or Cmd+Q.

Note: When you add Wiggle files using File > Add Track, they are indexed for fast
retrieval. When the session is saved, these indices are written to a folder called
<Session Name> .gvp.index. When you reopen the session, GenVision Pro uses these
indices for faster performance. If you move or copy the .gvp file to another location, you
can move the .gvp.index folder also; this avoids the need to recompute indices upon
reopening the session. Alternatively, you can move just the .gvp file, and the indices will
be automatically recomputed.

*
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Closing or quitting when there are unsaved documents:

If you select File > Close, or if you quit GenVision Pro when just one unsaved session is open, GenVision
Pro will open the Save Resource dialog. Click Yes to save changes, No to close/quit without saving
changes, or Cancel to return to GenVision Pro without closing/quitting.

If you quit GenVision Pro while multiple unsaved sessions are open, GenVision Pro will instead display the
Save Resources dialog.

• To save all changed sessions, choose Select All. To close all changed sessions without saving the
updates, pick Deselect All. To save only some of the sessions, add/remove checkmarks individually.

• Click OK to save only the checked sessions and to quit GenVision Pro. Click Cancel to return to
GenVision Pro without saving the checked sessions.
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Appendix
The Appendix contains the following topics:

• View a list of supported file types

• Set preferences for displaying help, for the Internet or for specifying temporary file locations.

• View IUPAC codes

• See the installed Lasergene file locations

• Turn off usage logging

• Troubleshoot the error

• Clean cached files on startup

• See the list of research references related to this application
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Supported file types
For a list of file formats supported by this DNASTAR product, please see the File Formats page of our
website.
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Set preferences
You can set preferences in GenVision Pro for help, Internet, and temporary files.

To open the Set Preferences dialog:

On Macintosh, choose GenVision Pro > Preferences. On Windows, choose Edit > Preferences.
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Set help preferences
The Help Preferences dialog controls how help documentation is displayed when you use the Help > Help
Contents command.

The dialog is accessed via the command Edit > Preferences (Win) or GenVision Pro > Preferences
(Mac). If the Help section is not already active, click on the word "Help" on the left.

• Specify the browser used to display the Protean 3D Help search results by selecting one of the
following options from the Open help search menu:

◦ In the dynamic help view – To display the GenVision Pro Help search results in a new section
of the Help interface. This is the default setting.

Note: There is no need to use the expand arrow to the left of “Help.” Its only sub-menu
item, “Contents,” is disabled in GenVision Pro.*

User Guide to GenVision Pro - 17.1

Copyright DNASTAR, Inc. 2020 Page 125 of 136



◦ In a browser – To display the GenVision Pro Help search results in your default web browser.

• Choose how to display the GenVision Pro Help contents by selecting one of the following options from
the Open help contents menu:

◦ In the help browser – to display the GenVision Pro Help content in a new section of the Help
interface. This is the default setting.

◦ In an external browser – to display the GenVision Pro Help content in your default web
browser.

Click Apply to save your changes while keeping the preferences dialog open, or Apply and Close to save
the changes and exit from the dialog. If you instead wish to return to default settings for all four drop-down
menus, click Restore Defaults. To leave the dialog without applying changes, choose Cancel.

Note: The ContextHelp options in the lower half of the dialog are not applicable to
GenVision Pro.*
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Set Internet preferences
The Internet Preferences dialog lets you choose whether you wish to be notified about Lasergene updates.

To access the dialog, use Edit > Preferences (Win) or GenVision Pro > Preferences (Mac). If the Internet
section is not already active, click on the word "Internet" on the left.

• Check the box if you would like GenVision Pro to display a notification when a newer version of
Lasergene is available. Uncheck the box if you do not wish to receive this notification.

Click Apply and OK to save your changes or Cancel to ignore any changes. Click Restore Defaults to
return to the default settings for all four drop-down menus.
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Set temporary file preferences
GenVision Pro creates and uses temporary files while a session is open. The need for temporary file space
grows with the number and length of the sequences and track data in open sessions. If you expect the
temporary files will be too large to fit in the default location, you may specify a different location for these
files using the Temporary Files Preferences dialog.

To access the dialog, use Edit > Preferences (Win) or MegAlign Pro > Preferences (Mac). If the
Temporary Files section is not already active, click on the phrase "Temporary Files" on the left.

• To change the temporary file location, close all GenVision Pro sessions and then return to this dialog.
Select the Browse button, navigate to the new location and click OK. As noted in the dialog, the
location you choose must remain accessible while GenVision Pro is running. The new location will be
used for all sessions that are subsequently created or opened.

Click Apply and OK to save your changes or Cancel to ignore any changes. Click Restore Defaults to
return to the default (temporary) storage location.
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IUPAC codes
IUPAC codes for amino acids:

1-Letter Code 3-Letter Code Amino Acid

A Ala Alanine

B Asx Aspartic Acid or Asparagine

C Cys Cysteine

D Asp Aspartic Acid

E Glu Glutamic Acid

F Phe Phenylalanine

G Gly Glycine

H His Histidine

I Ile Isoleucine

J Xle Leucine or Isoleucine

K Lys Lysine

L Leu Leucine

M Met Methionine

N Asn Asparagine

O Pyl Pyrrolysine

P Pro Proline

Q Gln Glutamine

R Arg Arginine

S Ser Serine

T Thr Threonine

U Sec Selenocysteine

V Val Valine

W Trp Tryptophan

X Xaa Unspecified or unknown

Y Tyr Tyrosine

Z Glx Glutamic Acid or Glutamine

IUPAC codes for nucleotides:
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Symbol Description Bases Represented

A adenosine/adenine A

C cytidine/cytosine C

G guanosine/guanine G

T thymidine/thymine T

U uridine/uracil U

W weak A T

S strong C G

M amino A C

K keto G T

R purine A G

Y pyrimidine C T

B not A C G T

D not C A G T

H not G A C T

V not T A C G

N or - any base (not a gap) A C G T

The non-standard nucleotide codes “I” (Inosine) or “X” (xanthine) are supported in
DNASTAR’s PrimerSelect and EditSeq applications only.*
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Installed Lasergene file locations
The following file names use ‘x’ to represent the version number.

File Category Application Path

Application2

ArrayStar
Windows: C:\Program Files
(x86)\DNASTAR\Lasergene
x\ArrayStar

SeqNinja (command line)
Windows: C:\Program Files
(x86)\DNASTAR\Lasergene
x\SeqNinjaCL

All others

Windows: C:\Program Files
(x86)\DNASTAR\Lasergene
x

Macintosh: /Applications/
DNASTAR/Lasergene x

Data Manager2 (DMx, DMx.exe)
SeqBuilder Pro, Protean 3D,
GeneQuest, MegAlign,
MegAlign Pro, PrimerSelect

Windows: C:\Program Files
(x86) \DNASTAR\
Lasergene x

Macintosh: /Applications/
DNASTAR/Lasergene x

Data Manager State File
SeqBuilder Pro, Protean 3D,
GeneQuest, MegAlign,
MegAlign Pro, PrimerSelect

Windows: C:\Program
Data\DNASTAR\
DataManager

Macintosh: ~/Library/
Application Support/
DNASTAR/DataManager,

~/Library/Preferences/
DNASTAR/DataManager

License Manager2 All

Windows: C:\Program Files
(x86)\DNASTAR\License
Manager

Macintosh: /Applications/
DNASTAR/License
Manager

Server License File (lservrc), Server License
Manager 2, Server Executables (_lserv,
lservnt.exe)

All

Windows: C:\Program Files
(x86)\DNASTAR-
LicenseServer\Server

Macintosh: ~/Library/
DNASTAR-LicenseServer

Standalone & Trial Licenses (*.license),
License Server Client License (*.lshost), Key All Windows: C:\Program

Data\DNASTAR\Licenses
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Server Client License (*.keyhost) Macintosh: ~/Library/
Application Support/
DNASTAR/Licenses

Preferences

Protean 3D, Navigator,
SeqNinja (DNA*), GenVision
Pro

Windows:
C:\Users\<user>\DNASTAR

Macintosh: ~/Library/
DNASTAR

ArrayStar

Windows:
C:\Users\<User>\AppData\
Roaming\DNASTAR\
ArrayStar

All others

Windows:
C:\Users\<user>\AppData\
Local\DNASTAR\

Macintosh: ~/Library/
Preferences

AppData is a hidden folder in Windows. To unhide the folder, go to Organize > Folder and
Search Options > View > Show Hidden files and folders.*
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Turn off usage logging
By default, usage logging is enabled in Lasergene version 11 and later. To opt out of usage logging, launch
the DNASTAR Navigator and go to View > Preferences > Lasergene (Win) or DNASTAR Navigator >
Preferences > Lasergene (Mac). Uncheck the box and click Apply and then OK.
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Troubleshoot the error “A different version is
running”
If you receive the error “A different version of Lasergene is running” when you try to launch a Lasergene
application, but another version of Lasergene actually isn’t running, there may be a lingering .state file from
another version that needs to be deleted.

The solution is to locate and delete files named STARDM*.state, …where ‘*’ represents the version number.

These files may exist in the following directories:

Windows 7 and Windows 8:

• C:\Users\username\AppData\Local\DNASTAR\DataManager

• C:\ProgramData\DNASTAR\DataManager

Macintosh:

• Hard Drive:Library:Preferences:DNASTAR:DataManager

• Hard Drive:Users:username:Library:Preferences:DNASTAR:DataManager

If you find any of the .state files listed above, delete them. Once the files are deleted, the error should no
longer appear.
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Clean cached files on startup
If you are a Windows user, you may execute a “-clean” in the unusual event that cached data has become
corrupted:

1. Close GenVision Pro if it is currently open.

2. Launch the Command Line (C:\Windows\system32\cmd.exe).

3. Type the path to the GenVision Pro application, followed by a space and the –clean command.

C:\Program Files (x86)\DNASTAR\DNASTAR\Lasergene 15\GenVision Pro.exe –clean
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Research references
Taylor WR (1997). “Residual colours: a proposal for aminochromography.” Protein Engineering vol.10 no.7
pp.743 – 746. (See the PDF file.) [“Taylor” color scheme]

Waterhouse AM, Procter JB, Martin DMA, Clamp M and Barton GJ (2009). “JalView version 2: a multiple
sequence alignment and analysis workbench.” Bioinformatics 25:1189-1191. (See on PMC.) [Discusses
methodology later used to create the “Taylor” and “Zappo” color schemes]
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