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1. CSoft Software License Agreement

CSoft AS – All rights reserved.
No part of this documentation may be altered, adapted, or translated into other languages without prior
written permission from the CSoft. It is prohibited to create any documents based on this original.
WiseIndex and its logotype as well as CSoft and its logotype are the trademarks of CSoft*. Microsoft
Windows is the registered trademark of the Microsoft Corporation. MS-DOS is the registered trademark
of the Microsoft Corporation. Pentium and Pentium Pro are the registered trademarks of the Intel
Company.

Other program and equipment names are the registered trademarks of the corresponding companies.
CSoft and the Licensee agreed as the follows:
Object: CSoft Software products including programs and documentation (hereafter referred to as the
license). The license described in the CSoft product User Guide, shall be distributed in accordance with
the terms of the License Agreement and cannot be used, transferred or sold under any conditions, other
than what is clearly specified in the following Agreement.

License Agreement
CSOFT transfers the Licensee a non-exclusive License to use the license supplied under this Agreement
according to the conditions specified bellow. Should the Licensee not agree to the terms of the
Agreement the installation must be terminated before the activation of said license and return for a full
refund within 30 days of the purchase. CSOFT will on receipt of all deliverables and after confirmation to
non-activation of the license make a 100% refund of the amount paid for the license.

License

1. Under this License the Licensee may use the programs on one consecutive computer only. To use
the programs on several consecutive working computers the Licensee shall obtain the
corresponding number of paid Licenses.

2. The Licensee is entitled to make one archive copy of the license, which automatically becomes
CSOFT property and falls under this Agreement.

3. The documentation may not be copied and/or distributed in any way or form.
4. The Licensee shall prevent the license from being used, copied or distributed without

authorization.
5. This License is valid from the date the Licensee obtains it and until its termination. Should the

Licensee break the terms of this License agreement it will automatically void the terms of the
agreement.

6. All rights of name, contents and appearance of the package shall be the exclusive property of
CSOFT.

7. The present version and all the following license versions shall fall under the terms of this License
Agreement or any future License Agreement that supersedes this agreement.

Warranty

CSoft AS WiseIndex 2022 - 7_en
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1. CSOFT warrants that the Software is free from defects at delivery and for a period of ninety (90)
days of normal use from the date of the original purchase. Should any defects be detected CSOFT
shall replace the defected materials. Minor non-fatal bugs and compatibility issues relating to
normal product uses does not constitute defects.

2. CSOFT has no warranty responsibility for the license or the results of the usage of this license in
terms of accuracy, correctness, reliability or similar.

3. CSOFT is not responsible for any damage, directly or indirectly linked with the use of or misuse of
this license.

4. No other information, except for the present License, obtained by the licensee shall cause any
CSOFT warranty responsibility.

Modifications in the programs and new versions

1. The Licensee will have to fill out and return to CSOFT the User’s Registration Card in order for the
Licensee to have the right of getting any possible supplements, new license copies on preferential
terms and notice of errors corrections.

CSoft AS WiseIndex 2022 - 7_en
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2. Server Requirements
Server Requirements

• Operating System Requirement: Windows Server 2012 R2+
• .net Framework: .NET Core 3.1 (Windows Server)
• Application Server: IIS 8.0+
• Supported Databases: MS SQL Server Express 2008 R2+
• Hard Disk: minimum of 10 GB
• Memory: 4 GB
• Processor Speed: Recommended: 2.8 GHz or faster

Solr Server Requirements (Depends on the documents storage)
• Operating System Requirement: any.
• Hard Disk: minimum of 10 GB
• Memory: 2 GB minimum (minimum 1GB standby to run Solr is recommended)

Tika and Tesseract server Requirements
• Operating System Requirement: any.
• Hard Disk: minimum of 10 GB
• Memory: 2 GB

CSoft AS WiseIndex 2022 - 7_en
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3. 2.Introduction
WiseIndex 2022 is a web based document archiving and revision management software. An archive is a
database that holds references to documents, attributes and linked data. WiseIndex collects and
organizes documents. WiseIndex can contain CAD files like .DWG, .DXF or .DGN, documents such as
.PDF files, scanned images, digital photos or any kind of imagery and more. WiseIndex Uses
Departments, Projects, Tags, Filters and Views to simplify locating and using documents. WiseIndex
2022 inherits all the good features from EDA, such as filtering and multi-user, multi-role support to
facilitate document management in a distributed environment. WiseIndex 2022 spreads its functionality
to facilitate revision management of documents. WiseIndex utilizes a hybrid drawing database approach,
effectively working with documents and associated data. It can contain image referenced fields with text
comments to maintain relation between multiple documents.
WiseIndex incorporates a powerful search engine that facilitates searching
This document attempts to be a comprehensive guide to WiseIndex 2022. This document will attempt to
cover the steps needed to install WiseIndex in your local intranet. It will detail the settings needed to
configure WiseIndex. Also, this will function as an exhaustive manual to guide you through all the
features in WiseIndex.

We will also compose a list of frequently asked questions (FAQs) at the end of this document

This is a web based manual. Your comments and suggestions are welcome and will assist us in
continuously improving our user guide. Please send us your feedback in the space available below

.
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4. 3.Installation Guide
CSoft AS WiseIndex 2022 - 7_en
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5. 4. Configuration Guide
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6. 5. Getting Started
This chapter will present a brief overview of WiseIndex. This will include the concept of document
archiving and revision management in WiseIndex and various entities and phrases used in WiseIndex
and their purpose. This chapter will also attempt to describe how to get around WiseIndex. This section
will explain the navigation menus as well as common controls on WiseIndex. Once the basic idea is
communicated, we will try to explain a scenario where user(s) will be able to find a particular document
and work with it.

Following are the subtopics covered in this chapter:

• 5.1 Overview of WiseIndex 2020
• 5.2 Navigation
• 5.3 Finding Documents

CSoft AS WiseIndex 2022 - 7_en
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6.1. 5.1 Overview of WiseIndex 2022
WiseIndex is a Web based Archiving and Revision Management Software. This application is mainly
targeted towards today’s companies where there are multiple teams working with multiple documents
across various locations. WiseIndex groups the documents into logical structures to help users archive
their important documents. WiseIndex also manages revisions of documents by storing every version of
the document throughout its lifetime.

CSoft AS WiseIndex 2022 - 7_en
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6.2. 5.2 Navigation

Navigating within WiseIndex
WiseIndex offers a login screen to the user. WiseIndex only allows authenticated users to view and work
on the documents stored inside WiseIndex.

The login screen can show your company logo for personalization and customization. This logo can be
setup by the server administrator through the WiseIndex Configuration Wizard available in the server
where WiseIndex is installed. The steps for this are detailed in the Configuration Guide Section.
Alternatively it can also be setup by the administrator user (System Admin) through his/her login.The
steps of this will be discussed in detailed in the Section.

Basic Access Points

Once you login successfully, you will be taken to the Dashboard. The Dashboard is the basic page lists
the available menus/ Access Points on the left side, the users profile information on the top-right side
and license information on the bottom-right side of the page.

CSoft AS WiseIndex 2022 - 7_en
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The above image displays the Dashboard of a System Admin.

List Controls

WiseIndex offers several list controls to the users. Each list item normally has several actions associated
with it. to access the actions, the user has two alternative options. She can either select the list item by
left click of the mouse button. The available actions are then listed as buttons on top of the list control.
She can also right click on the selected list item and available actions are then listed as the context
menu.

the above image displays both the options of accessing available actions in a list control.

CSoft AS WiseIndex 2022 - 7_en
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6.3. 5.3 Setting up WiseIndex
WiseIndex has two basic types of login. One is SystemAdmin login another is normal login.There must
be one user with systemadmin role.Without this role,WiseIndex setup is not possible.Once the
systemadmin login into the system,he/she will be taken to first set up page. There he/she has to set up
the system as below order:

1.Enterprise details

Systemadmin has to add an enterprise before starting WiseIndex.
To add an enterprise,complete the steps:

• Enter a name
• Enterprise phone,Email id
• Enter address

Then click next

2.Set up mail

Then it is required to set up a mail server and test mail server setup.Follow the steps:

• Enter an email id
• Enter password
• Enter valid hostname,port number
• Enable SSL.

CSoft AS WiseIndex 2022 - 7_en
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Once email configuration is completed,you can send a test mail.To send a test mail,enter email details
and send.

3.Add roles

Then add roles.For the steps of adding a role view the topic Add role

CSoft AS WiseIndex 2022 - 7_en
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4.Add user

Once role is created,assign the role to a user.For creating the user,see the topic Add user

After creating roles,add departments and projects.

5.Add departments

To add departments,see the topic Add departments

CSoft AS WiseIndex 2022 - 7_en
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6.Add projects

To add projects,see the topic Add projects

Your profile set up is 100% completed.Now you can login into WiseIndex with your userid and password
and start exploring the software.

CSoft AS WiseIndex 2022 - 7_en
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6.4. 5.4 Finding Documents
WiseIndex stores files and helps to find a document using various option.We can search a file using
Tag,Filter,View,Temporary view,Temporary filter.Here is the various methods for viewing files:

• Tree view:

In tree view we can view the files in folder and subfolder manner.Tree view looks like below screenshot.

• List view
In list view we can view the files in list.List view looks like below screenshot.

CSoft AS WiseIndex 2022 - 7_en
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• Thumbnail view
Screenshot for thumbnail view is given below.

• Tags
A tag is a keyword that helps to describe a file and allows to search a file.You can select a tag at
the top of any view.And click apply.See topic Add tag

• Filter
A filter works on some conditions.you have to add some fields in files.you can set conditions
according to the field name and value.Using the filter we can view files which match the filter
conditions.See topic Add filter

CSoft AS WiseIndex 2022 - 7_en
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• Temporary view
Temporary view allows user to search a file without saving view.User can create a temporary view
with some field.The fields will be applicable to that file.See topic Add quick view

• Temporary filter
Temporary filter allows to search files without saving a filter.See topic Temporary filter

CSoft AS WiseIndex 2022 - 7_en
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7. 6. Enterprise
Enterprise is another word for organization or company.It is the first step to add an enterprise in
WiseIndex.To add an enterprise,complete the steps:

1. Navigate to Dashboard>Enterprise
2. Enter name of the enterprise
3. Give a profile image
4. Add enterprise email id and phone number
5. Enter address
6. Click save

CSoft AS WiseIndex 2022 - 7_en
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8. 7. Departments

CSoft AS – All rights reserved.
No part of this documentation may be altered, adapted, or translated into other languages without prior
written permission from the CSoft. It is prohibited to create any documents based on this original.
WiseIndex and its logotype as well as CSoft and its logotype are the trademarks of CSoft*. Microsoft
Windows is the registered trademark of the Microsoft Corporation. MS-DOS is the registered trademark
of the Microsoft Corporation. Pentium and Pentium Pro are the registered trademarks of the Intel
Company.

Other program and equipment names are the registered trademarks of the corresponding companies.
CSoft and the Licensee agreed as the follows:
Object: CSoft Software products including programs and documentation (hereafter referred to as the
license). The license described in the CSoft product User Guide, shall be distributed in accordance with
the terms of the License Agreement and cannot be used, transferred or sold under any conditions, other
than what is clearly specified in the following Agreement.

License Agreement
CSOFT transfers the Licensee a non-exclusive License to use the license supplied under this Agreement
according to the conditions specified bellow. Should the Licensee not agree to the terms of the
Agreement the installation must be terminated before the activation of said license and return for a full
refund within 30 days of the purchase. CSOFT will on receipt of all deliverables and after confirmation to
non-activation of the license make a 100% refund of the amount paid for the license.

License

1. Under this License the Licensee may use the programs on one consecutive computer only. To use
the programs on several consecutive working computers the Licensee shall obtain the
corresponding number of paid Licenses.

2. The Licensee is entitled to make one archive copy of the license, which automatically becomes
CSOFT property and falls under this Agreement.

3. The documentation may not be copied and/or distributed in any way or form.
4. The Licensee shall prevent the license from being used, copied or distributed without

authorization.
5. This License is valid from the date the Licensee obtains it and until its termination. Should the

Licensee break the terms of this License agreement it will automatically void the terms of the
agreement.

6. All rights of name, contents and appearance of the package shall be the exclusive property of
CSOFT.

7. The present version and all the following license versions shall fall under the terms of this License
Agreement or any future License Agreement that supersedes this agreement.

Warranty

CSoft AS WiseIndex 2022 - 7_en
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1. CSOFT warrants that the Software is free from defects at delivery and for a period of ninety (90)
days of normal use from the date of the original purchase. Should any defects be detected CSOFT
shall replace the defected materials. Minor non-fatal bugs and compatibility issues relating to
normal product uses does not constitute defects.

2. CSOFT has no warranty responsibility for the license or the results of the usage of this license in
terms of accuracy, correctness, reliability or similar.

3. CSOFT is not responsible for any damage, directly or indirectly linked with the use of or misuse of
this license.

4. No other information, except for the present License, obtained by the licensee shall cause any
CSOFT warranty responsibility.

Modifications in the programs and new versions

1. The Licensee will have to fill out and return to CSOFT the User’s Registration Card in order for the
Licensee to have the right of getting any possible supplements, new license copies on preferential
terms and notice of errors corrections.

CSoft AS WiseIndex 2022 - 7_en
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8.1. 7.1 Add Departments
In this section,we will learn the steps for adding a department.The required fields to add a departments
are :Department name,Department description and Admin.To add a department,navigate to
Dashboard>Department and complete the following steps:

1. Enter a Title
2. Enter a description
3. Select a user as department admin.

We can choose anyone from the user list as an admin.First we have to select the check box Select
Admin.A new page of user list will be opened.Just select the user whom you want to make admin.

Once we fill up the form properly,we can create department.

CSoft AS WiseIndex 2022 - 7_en
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8.2. 7.2 View/Edit Departments
A department can be viewed or edited by two alternative options. User can either select the department
by left click of the mouse button. The edit/view are then listed as buttons on top of the list control.
User can also right click on the department name and edit/view options are then listed as the context
menu.

View Departments:
In this section we can only view a saved department can not edit the department.

CSoft AS WiseIndex 2022 - 7_en
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Edit department:
To edit a saved department, select the department to edit and complete the following steps.

• Modify the department name and description as necessary.
• Change the department admin as necessary
• Click Save.

CSoft AS WiseIndex 2022 - 7_en
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8.3. 7.3Active/Inactive Departmennt
A department can not be deleted,it can be made inactive by Inactive option.To access the option, the
user has two alternative options. User can either select department by left click of the mouse button. The
Inactive option is then listed as buttons on top of the list control.
User can also right click on the department and Inactive option is then listed as the context menu.

If a department is made inactive then it will go to the inactive list.And we can view the inactive list of
department by selecting Inactive option from the drop down list at the right side corner of the page.

CSoft AS WiseIndex 2022 - 7_en
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8.4. 7.4 Manage department projects
We can add projects to a department by this option. To access the option, the user has two alternative
options. She can either select department by left click of the mouse button. The Go to projects option is
then listed as buttons on top of the list control.
She can also right click on the department and Go to projects option is then listed as the context menu.

Manage projects:
User can directly add projects to the selected department and can access others project related actions
by this option.The steps for this are detailed in the Add project section

CSoft AS WiseIndex 2022 - 7_en
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8.5. 7.5 Manage Department Users
We can add users to a departments by this list control.To access the option, the user has two alternative
options. She can either select the department item by left click of the mouse button. The Manage user
option is then listed as buttons on top of the list control.
User can also right click on the department and The Manage user option is then listed as the context
menu.

The steps of this is detailed in the Navigation.

Note:If a user is admin of a particular department,then we can not remove him/her from user list

CSoft AS WiseIndex 2022 - 7_en
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8.6. 7.6 Manage department fields
Department fields can be added by this option.To access the option, the user has two alternative
options. She can either select department by left click of the mouse button. The Fields option is then
listed as buttons on top of the list control.
She can also right click on the department and Fields option is then listed as the context menu.

Fields:
User can directly add fields to the selected department and can access others field related actions by
this option.The steps for this are detailed in the Field section

CSoft AS WiseIndex 2022 - 7_en
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9. 8. Projects
WiseIndex organizes documents in various logical groups. project is such a logical group in WiseIndex.
A project may contain files.Every Department can contain multiple Projects.
Following are the subtopics covered in this chapter:
* 8.1 Add Projects
* 8.2 View/Edit Projects
* 8.3 Active/Inactive Projects
* 8.4 Manage/View Project Users
* 8.5 Manage project fields
* 8.6 View project files
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9.1. 8.1 Add Projects
In this section,we will learn how to add Projects.Project can be added by two option.Either we can add
project from project option on Dashboard or we can add projects from manage projects option in
department. The required fields to add a projects are :Project name,Project description and
Department.To add a project,navigate to Dashboard>Project and complete the following steps:

1. Enter a Title
2. Enter a description
3. Select a department.We can choose a department from the department list in the drop down

option.

CSoft AS WiseIndex 2022 - 7_en
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9.2. 8.2 View/Edit Projects
A project can be viewed or edited by two alternative options. User can either select the project by left
click of the mouse button. The edit/view options are then listed as buttons on top of the list control.
User can also right click on the project name and edit/view options are then listed as the context menu.

View Projects:
In this section we can only view a saved project can not edit the Project.

Edit Projects:
A saved project can be edited here.We can change the project name,Description only.The department

CSoft AS WiseIndex 2022 - 7_en
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name is not allowed to modify.
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9.3. 8.3 Active/Inactive projects
A project can not be deleted,it can be made inactive by Inactive option.To access the option, the user
has two alternative options. User can either select project by left click of the mouse button. The Inactive
option is then listed as buttons on top of the list control.
User can also right click on the project and Inactive option is then listed as the context menu.

If a project is made inactive then it will go to the inactive list.And we can view the inactive list of project
by selecting Inactive option from the drop down list at the right side corner of the page.
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9.4. 8.4 Manage/View Project Users
Users can be added and viewed by these options.

Manage user
We can add users to a project by this list control.To access the option, the user has two alternative
options. User can either select the project item by left click of the mouse button. The Manage user
option is then listed as buttons on top of the list control.
User can also right click on the project and The Manage user option is then listed as the context
menu.(picture)
The steps of this is detailed in the Navigation section.

View user
Users of a project can only be viewed by this option.To access the option, the user has two alternative
options. User can either select the project item by left click of the mouse button. The View user option is
then listed as buttons on top of the list control.
User can also right click on the project and The View user option is then listed as the context menu.
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9.5. 8.5 Manage project fields
Project fields can be added by this option.To access the option, the user has two alternative options. He/
She can either select project by left click of the mouse button. The Fields option is then listed as buttons
on top of the list control.
He/She can also right click on the project and Fields option is then listed as the context menu.

Fields:
User can directly add fields to the selected project and can access others field related actions by this
option.The steps for this are detailed in the Field section.
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9.6. 8.6 View project files
Project files can be viewed by this option.To access the option, the user has two alternative options. He/
She can either select project by left click of the mouse button. The View files option is then listed as
buttons on top of the list control.
He/She can also right click on the project and View files option is then listed as the context menu.

We can view all the files those are uploaded under the selected project.
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10. 9. Files
WiseIndex is a file archiving software which offers to store a bunch of files and keep tracks of them.This
software makes it easier for you to search files.It can store a variety of document type such as
pdf,image,CAD files etc.It is easy to modify a file through WiseIndex.If anyone make any changes to a
document,WiseIndex can track them.WiseIndex manages multiple versions of the same file as revisions.
Following are the subtopics covered in this chapter:
9.1 Upload Files
9.2 View Files
9.3.1 View file information
9.2.2 Navigate within multiple documents
9.2.3 Navigate using layers
9.2.4 Search text
9.2.5 Other viewing controls
9.2.6 Annotations
9.3 Download files
9.4 Revisions
9.4.1 Upload a new revisions
9.4.2 View earlier revisions
9.5 Related files
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10.1. 9.1 Upload Files
We can create folder in WiseIndex.If we do not create a folder,then a file will be uploaded to root
folder.Every new folder will be created under root folder.To create a folder,complete the step:

1. Navigate to Dashboard>Files>View Files.
2. Right click on root folder.
3. Create new folder

To upload a file in WiseIndex,complete the following steps:
Navigate to Dashboard>Files>Upload files

1. Select department from the dropdown
2. Select project from the dropdown
3. Select a folder where you wish to upload a file
4. Browse the file from your local system
5. Click upload
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10.2. 9.2 View Files
In WiseIndex we can do multiple operations on files.We will cover the following operations in this section.
*View file information
*Navigate within multipage documents
*Navigate using layers
*Search text
*Other viewing controls
*Annotation
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10.2.1. 9.2.1 View file information
In WiseIndex we can view file name,file format,size,creation time,last access time,read only
status,last write time,file related fields (Fields.) To view a file information,here is the following steps:

1. Navigate to Files>View files
2. Open the selected file
3. Select file info from the file dropdown at the left side corner.
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10.2.2. 9.2.2 Navigate within multipage
documents
In WiseIndex we can store documents in various formats like jpg,pdf,txt,dwg,dxf etc.A document might
contains several pages.In that case we can work with multiple pages simultaneously.We can directly go
to last page,first page.Below are the steps:

1. Navigate to File>View files
2. Open the file
3. Select File>Thumbnail at the left corner of the page

Here we can see the multiple pages on the thumbnail view and we can easily choose the page we want
to work on.

We can also do it by another way.

1. Navigate to File>View files
2. Open the file
3. Select View>First page/last page
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10.2.3. 9.2.3 Navigate using layers
WiseIndex allows to store and modify CAD drawings. For CAD drawing we can divide the drawing into
multiple layers.

1. Go to Files>View Files
2. Open the file
3. Select CAD on the top
4. Select view layers
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10.2.4. 9.2.4 Search text
We can search a particular text in a CAD drawing and work on that text.This is case sensitive.

1. Open the file from view file option
2. Navigate to CAD>Search text
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10.2.5. 9.2.5 Other viewing controls
In WiseIndex,there are various options to view a files.We can select tree view,list view,thumbnail
view.

Tree view

In tree view we can view the files in folder and subfolder manner.Tree view looks like below screenshot.

List view

In list view we can view the files in list.List view looks like below screenshot.
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Thumbnail view

Screenshot for thumbnail view is given below.
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10.2.6. 9.2.6 Annotations
WiseIndex offers several annotations on a file.List of annotations allowed in WiseIndex are as
below:(annotation pic)
Open a file

1. Click Annotation tab at the top.
2. Modify as per your choice.You can draw a line,rectangle,ellipse,stamp etc.After modifying the file

click on save annotation.
3. If you want to apply the annotation click on Load annotation

You can also edit the annotation by clicking Edit annotation
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10.3. 9.3 Download Files
WiseIndex allows to download a file.Below are the steps to download a file.

1. Navigate to Dashboard>Files>View Files.
2. Select the file you want to download.Right click on it.And Click on Download Option
3. Your file will be downloaded to local system
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10.4. 9.4 Revisions
WiseIndex has built-in version control. When you add a new version of a file with the same name to your
WiseIndex project, WiseIndex automatically updates the file and maintains a record of all previous
versions.
We will cover the following operations in this section.
1. upload a new version
2. View earlier revisions
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10.4.1. 9.4.1 Upload a new version
WiseIndex allows you to modify a file and upload the same file.In that case,the old file goes to revision
part and the modified file is stored as current version.Here are the steps:

1. Select the file and right click on it
2. Select upload a new version
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10.4.2. 9.4.2 View earlier revisions
To view a preview of a revision’s content,

1. Open the file.
2. Select the revision tab.This shows a preview of any file at any revision.version of the file.
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10.5. 9.5 Related files
The related files feature in WiseIndex provides users access to the supporting and related files that are
associated with the file they are working on.In that case user does not need to search a file from a bunch
of files.

For example, if a pdf file is associated with the main file, this feature facilitates viewing and editing this
pdf file. The user can also view the main file while editing the related file.

How to upload related file?
To upload a related file right click on the file,and select upload related file.

How to get related file list?
To get related file list,open the file and select Related files tab at the top of the page.
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10.6. 9.6 Tasks Against a File
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10.7. 9.7 File History
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10.8. 9.8 File Operations
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11. 10. Fields
Fields in WiseIndex offers an unique identification method for searching files.It helps to search a
particular file from a chunk of files in WiseIndex.If we create a field with a field value and assign the field
to a file,then we can easily search the file using the field value.We can create two kinds of field
here.Details will be discussed in the next chapters.

Following are the subtopics covered in this chapter:
* 10.1 Field types
* 10.2 Add Fields
* 10.3 View/Edit Fields
* 10.4 Active/Inactive Field
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11.1. 10.1 Field Types
In WiseIndex we can create several types of fields.The fields types available in WiseIndex are String
Field,Decimal Field,Integer field,Lookup field.Date filed,Date-time field.For each type of field we can
input a default value.If we do not assign any value to a field,then it will take the default value.
Field value can be as follows:
Integer field:Any integer value like 1,2,3…….
Decimal Field :Decimal value like 1.0,1.5……..
String field Any string value like “abcd”,“1234”.
Date field:Date value in MM/DD/YYYY Format like 02/26/2019
Date-time field:Date and time value in MM/DD/YYYY 00:00 Format like 03/26/2019 17:35
Lookup field:It will take a lookup list values.We can make a value as default value from the lookup
value list.We can also edit a lookup value if necessary.Below is the screenshot for lookup field.
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11.2. 10.2 Add Fields
In WiseIndex we can add two kinds of field.One is project level field and another one is Department level
field.A project level field will be applicable for all the files in a project.And a department level field will be
applicable for all the project in a department.For a department level field we don’t need to create field for
projects separately.It will be applicable for all the projects under a department.The required fields to add
a Field are :Field name,Field description and Field type,.Once we fill up the form properly,we can
create Field.

Default value

If we check the option This field is mandatory,then we have to input a default value for the field type
selected.
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Department level field
If we want to create a Department level field then we have to check the option Department level
field.In this case Current department is mandatory.

Project level field
If we want to create a Project level field then we have to check the option Project level field.In this
case Current department and Current project is mandatory.
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11.3. 10.3 View/Edit Fields
A Field can be viewed or edited by two alternative options. User can either select the field by left click of
the mouse button. The edit/view are then listed as buttons on top of the list control.
User can also right click on the field name and edit/view options are then listed as the context menu.

View Field:
In this section we can only view a saved field can not edit the field.

Edit Field:
A saved field can be edited here.We can change the Field name,Description only.But we can not
change Current department,Current project,Field type and Default value.
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11.4. 10.4 Active/Inactive Fields
A Field can not be deleted,it can be made inactive by Inactive option.To access the option, the user has
two alternative options. User can either select field by left click of the mouse button. The Inactive option
is then listed as buttons on top of the list control.
User can also right click on the Field and Inactive option is then listed as the context menu.

If a field is made inactive then it will go to the inactive list.And we can view the inactive list of fields by
selecting Inactive option from the drop down list at the right side corner of the page.
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12. 11. Filters
A filter restricts what records appear in a list by providing a set of conditions.A condition consists of the
following parts.
Field: Each field contains some value.
Operator: Each field type has its own set of valid operators.Like greater than,less than,equals to etc
Value: Each field has its own set of values determined by the field type.
Grouping: Each condition line is grouped with an AND connector .The filter requires all condition lines
linked with an AND connector to be met.We can Create, Edit, and Delete filters.
Following are the subtopics covered in this chapter:

• 11.1 Add Filters
• 11.2 View/Edit Filters
• 11.3 Delete Filters
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12.1. 11.1 Add Filters
We have to navigate to Filter option from the dashboard to create a filter.The mandatory fields are Filter
name,Filter description,Current department,Current projects and at least one condition.
To create a filter, complete the following steps.

1. Enter a Title
2. Enter a filter description
3. Select Current department from the drop down list
4. Select current project from the dropdown list.
5. Add filter conditions.
6. Click add filter

To add a filter condition,complete the steps

• Select a field from drop down list.
• Select an operator.
• Give a field value.
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12.2. 11.2 View/Edit Filters
A Filter can be viewed or edited by two alternative options. User can either select the Filter by left click
of the mouse button. The edit/view are then listed as buttons on top of the list control.
User can also right click on the Filter name and edit/view options are then listed as the context menu.

View Filter:
In this section we can only view a saved filter.can not modify the filter.
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Edit Filter:
To edit a saved filter, select the filter to edit and complete the following steps.

• Modify the filter name and description as necessary.
• Modify the Filter conditions as necessary.
• Click Save.

Note:We can not edit the Current department and Current project.
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12.3. 11.3 Delete Filters
A filter can be deleted by two alternative options. User can either select the filter by left click of the
mouse button. The Delete option is then listed as buttons on top of the list control.
User can also right click on the filter name and Delete options are then listed as the context menu.

To delete the filter just select the filter name and click on Delete button.The deleted filter will no longer
appear on the list.
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12.4. 11.4 Temporary filter
Temporary filter allows to search files without saving a filter.To apply a temporary filter,
Navigate to Files>view files
Select quick search at the top right corner of the page.
Add filter condition
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13. 12. Views
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13.1. 12.1 Add Views
We have to navigate to View option from the dashboard to create a View.The mandatory fields are View
name,View description,Current department,Current projects and at least one Available Fields.
To create a View, complete the following steps.

1. Enter a Title
2. Enter a View description
3. Select Current department from the drop down list
4. Select current project from the dropdown list.
5. Add Fields from the list
6. Click add
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13.2. 12.2 View/Edit Views
A View can be viewed or edited by two alternative options. User can either select the View by left click of
the mouse button. The edit/view are then listed as buttons on top of the list control.
User can also right click on the View name and edit/view options are then listed as the context menu.

View Views:
In this section we can only view a saved View.can not modify the View.
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Edit Views:
To edit a saved View, select the view to edit and complete the following steps.

• Modify the View name and description as necessary.
• Modify the Field list as necessary.
• Click Save.

We can not edit the Current department and Current project
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13.3. 12.3 Delete Views
A View can be deleted by two alternative options. User can either select the view by left click of the
mouse button. The Delete option is then listed as buttons on top of the list control.
User can also right click on the View name and Delete options are then listed as the context menu.

To delete the view just select the View name and click on Delete button.
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13.4. 12.4 Temporary view
Temporary view allows user to search a file without saving view.User can create a temporary view with
some field.The fields will be applicable to that file.To create a temporary view,complete the steps:

1. Navigate to Dashboard>Files>View files
2. Open a file
3. You can see a logo for quick view at the right hand side(quick view logo)
4. Add the fields in the list
5. Selected fields will be applicable to the selected file.

CSoft AS WiseIndex 2022 - 7_en

Page 79 of 111



14. 13. Reports
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14.1. 13.1 Create Report
We can create a role to control access to modules. The new role does not have access to any module
until you add access to it.Below are the basic steps for creating a role.

1. Enter a Title
2. Enter a role description
3. Select Current department from the drop down list
4. Select Access.We can assign access by two alternative options.We can either select all access to

a role or we can assign multiple access selectively.
5. Click Save
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14.2. 13.2 View/Edit Reports
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14.3. 13.3 Delete Report
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14.4. 13.4 Preview/Multiview Reports
CSoft AS WiseIndex 2022 - 7_en

Page 84 of 111



15. 14. Tasks
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15.1. 14.1 Create Task
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15.2. 14.2 View/Edit Task
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15.2.1. 14.2.1 View Task Information
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15.2.2. 14.2.2 Associated Files
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15.2.3. 14.2.3 Task History
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15.2.4. 14.2.4 Task Comments
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16. 15. Users and Roles
WiseIndex offers Security of applications against unauthorized access by roles.After access has been
granted to a role, all the users assigned to the role are granted the access.We can assign selective
access to an user.An user can only create another role and user if he/she has access to it.
Following are the subtopics covered in this chapter:

• 13.1 Create roles
• 13.2 View/Edit roles
• 13.3 Add Users
• 13.4 View/Edit Users
• 13.5 Active/Inactive User
• 13.6 Edit profile
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16.1. 15.1 Create Roles
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16.2. 15.2 View/Edit Roles
A Role can be viewed or edited by two alternative options. User can either select the Role by left click of
the mouse button. The edit/view are then listed as buttons on top of the list control.
User can also right click on the Role name and edit/view options are then listed as the context menu.

View Role:
In this section we can only view a saved role.can not modify the role.
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Edit Role:
To edit a saved role, select the role to edit and complete the following steps.

• Modify the role name and description as necessary.
• Modify the access list as necessary.
• Click Save.

Note:We can not edit the system admin role
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16.3. 15.3 Add Users
You can add a user to WiseIndex to allow them to log in and use the features.We can create a user
only if we have role access.To create a user,complete the following steps:

1. Navigate to Dashboard>User>Add
2. Enter name of the user
3. Assign a role to the user
4. Enter email id,contact number of the user
5. Enter a user name
6. Make the user active(if needed) by selecting the “User is active” checkbox.
7. Enter address details
8. Click Save
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16.4. 15.4 View/Edit Users
A User can be viewed or edited by two alternative options. User can either select the User by left click of
the mouse button. The edit/view are then listed as buttons on top of the list control.
User can also right click on the User name and edit/view options are then listed as the context menu.

View User:
In this section we can only view a User details,Access list and departments.can not modify the User.
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Edit User:
To edit a saved User, select the User to edit and complete the following steps.

• Change profile picture
• Modify the User name,description,role as necessary.
• Modify the User’s available department list as necessary.Note that,We can not remove a

department from that list if the user is admin of that department
• Make the user active/inactive
• Click Save.

Note:
• We can not edit the User’s access list,Email id and Username.
• System admin user can not be modified except system admin himself modify it.
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16.5. 15.5 Active/Inactive Users

Active user
A User can be made Active by Active option.To access the option, the user has two alternative options.
User can either select User by left click of the mouse button. The Active option is then listed as buttons
on top of the list control.
User can also right click on the User name and Active option is then listed as the context menu.

Inactive user
A User can not be deleted,it can be made inactive by Inactive option.To access the option, the user has
two alternative options. User can either select user by left click of the mouse button. The Inactive option
is then listed as buttons on top of the list control.
User can also right click on the user and Inactive option is then listed as the context menu.
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There can be maximum five active users in the list.If the limit exceeds,it is not possible to make another
user active.
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16.6. 15.6 Edit Profile
To edit a User profile, navigate to logged in user name on the top right corner,and then select profile.

• Change profile picture
• Modify the User name,description,role as necessary.
• Modify the User’s available department list as necessary.Note that,We can not remove a

department from that list if the user is admin of that department
• Make the user active/inactive
• change password if necessary
• We can change user’s role only if we have access to change role
• Click Save.

Note:
• We can not edit the User’s access list,Email id and Username.
• System admin user can not be modified because it is mandatory that there must be one user as

system admin.
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17. 16 Tags
A tag is a keyword that helps to describe an file and allows to search a file.For example if we create a
tag “xyz” and search files using the tag,then every file name contains “xyz” will appear in the list.
Following are the subtopics covered in this chapter:
14.1 Add tag
14.2 View tags
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17.1. 16.1 Add tags
To add a tag complete the following steps:

1. Open a file

2. There is a tag logo
3. Right click of mouse button
4. Enter name
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17.2. 16.2 View files using tags
To view files using tags,

1. select Files>view files.
2. Add a tag to a file.See topic Add tag
3. Select the tag you want to use and click apply
4. All the files associated with the selected tag will appear on the page.
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18. 17. System admin role
WiseIndex restrict one user to be a system administrator.The task is performed by a system
administrator who performs configuration,cache reload, provides user access, manages user
accounts,manages department,projects etc.We will cover the below topics in this chapter:

• System admin dashboard
• Settings
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18.1. 17.1 System admin dashboard
Once a system admin login into WiseIndex with user name and password,he will be taken to dashboard
page.System admin dashboard looks like as below:

A system admin can do the below operation:

1.Department:
System admin can view all the departments created by other users and do other department related
operation.For details see the topic Department

2.Project:
System admin can view all the projects created by other users and do other project related operation.For
details see the topic projects

3.User and role:
System admin can add,edit any role and user.
See topic User and roles

4.Enterprise
See topic Enterprise

CSoft AS WiseIndex 2022 - 7_en

Page 107 of 111



18.2. 17.2 Settings
System admin in WiseIndex is responsible for system set up and settings.Setting option can be seen on
the system admin dashboard.There are two parts in settings.1)*System setup* 2)*Cache management*

1.System setup

1. Navigate to Dashboard>Settings>System setup
2. Enter valid email id,password
3. Give host name,port number
4. Enable SSL
5. Click save

2.Cache management

WiseIndex’s cache management system is an easy way to improve the performance of your software.
Whenever a cache needs to be refreshed, a notice appears at the top of the page to guide you through
the process.After clearing a cache, always refresh your browser to make sure that you can see the most
recent files. To reload cache,below are the steps:

1. Navigate to Dashboard>Settings>Cache management
2. Click the button reload cache.A permission tab will open.
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19. 18.Current details
Current details tab defines the Current department,Current project,Current filter,Current view of
logged in user.The logged in user has to set the details in current details page so that whenever it is
required to create a field,filter,project,or view the current details will be fetched from this page.This will
also work for uploading a file in a project.This page looks like the below screenshot:
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20. 19. Frequently Asked Questions (FAQs)
1. What is the minimum Server Requirement to install WiseIndex?
2. Is it possible to import our existing data?
3. What are the formats of data can be uploaded in WiseIndex? Can we view all file formats in

WiseIndex?
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