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1. Before Starting

Purpose of Document
This document provides the information on how to use the CodeScroll Controller Tester Product.
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2. Overview

Introduction
Controller Tester is a test automation solution for unit and integration tests of software developed and
executed in various environments.

Toolchain supported in Controller Tester
Controller Tester supports about 100 toolchain. For more information, please contact the Technical
support contact at the bottom of this document Troubleshooting page.

Features
Controller Tester is a source code-based software test automation tool for unit and integration tests and
the major features are as follows.

Test design

1. Automatically create tests and test data
2. Intuitive test design interface
3. Ability to import test data in various format
4. Ability to design of integration test for complex nested structures

Achieving coverage goals

1. Supports statement, branch, MC/DC and function call coverage
2. Provides guides to achieve the goal of MC/DC
3. Checks the coverage results by linking the control flow graph with the source code
4. The coverage goal can be achieved quickly by testing only uncovered section after measuring the

system coverage (QualityScroll COVER product).

Others

1. Supports the simulation and the actual target environment tests
2. Links with DevOps(issue management + continuous integration + configuration management) tools
3. Shares project settings with CodeScroll product family: By carrying out the project settings only

once, coding rule inspection + runtime error detection + unit/integration test can be possible.
4. Reports in various formats

Standard certification

1. IEC 61508-3 (Electrical/Electronic)
2. ISO 26262-8 (Automotive)
3. IEC 60880 (Nuclear)
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4. IEC 62279 / EN 50128 (Railway)
5. DO-178C / DO-330 (Aviation)

Overall screen of Controller Tester
It provides high DOF windows made by Eclipse RCP. User can set them in [Window] menu and each
view.
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3. Install

Installation requirements
OS Microsoft Windows 7/10 (32bit/64bit)

RAM 512MB or more

HDD Free space about 500MB (GCC Compiler not installed) or about 1GB (GCC Compiler installed)
(When carrying out tests actually, HDD usage may be increased due to the test results.)

Install Controller Tester for Windows
By using the install package, you can install Controller Tester as follows:

1. Execute setup.exe file.

2. Click [Next] after the installation wizard runs and gathers installation information.

3. Accept the end-user license and click [Next].

It does not work properly when installed with ‘CodeScroll Controller Tester_3.x.msi’.!
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4. Set the path to install Controller Tester and whether or not to install the GCC compiler built in
Controller Tester, and click [Next].

5. All required information for the installation has been collected. Click [Install].

6. Install Controller Tester.
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7. When running Controller Tester immediately after installation is complete, check [Launch
CodeScroll Controller Tester] and click [Finish].

Suresofttech User Manual - 3.4

Page 8 of 267



4. Uninstall

Uninstall Controller Tester for Windows
There are three ways to uninstall Controller Tester.

1. Uninstall using [Control Panel] -> [Uninstall a program]

2. Uninstall using [Start] -> [All programs] -> [CodeScroll Controller Tester 3.x] -> [Uninstall
CodeScroll Controller Tester 3.x]

3. Uninstall using [Path to install] -> [Uninstall CodeScroll Controller Tester 3.x]

The procedures for [Uninstall CodeScroll Controller Tester 3.x] are as follows:

1. Run [Uninstall CodeScroll Controller Tester Tester 3.x] to collect the information needed to
uninstall the program. Click [Next] to proceed.

“Uninstall Controller Tester” deletes the files necessary to operate the Controller Tester.
The workspaces set by users are not deleted.*
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2. Select the checkbox [Uninstall CodeScroll Controller Tester 3.x] and [Uninstall GCC Compiler] and
click [Next].

3. All the necessary information for uninstalling has been collected. Click [Uninstall].

[Remove GCC Compiler] can be checked only when [Remove CodeScroll Controller
Tester 3.x] is checked.
If the GCC compiler has not deleted, the GCC compiler cannot be installed when re-
installing the Controller Tester.

*
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4. When the Controller Tester is successfully uninstalled, click [Finish].
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5. Run
Select the shortcut icon or [Start] -> [All programs] -> [CodeScroll Controller Tester 3.x] -> [CodeScroll
Controller Tester 3.x].

Select the workspace (working space) following the splash screen of the Controller Tester. You can
select either the already existed directory or enter a new directory as the workspace path. You can also
use the currently selected workspace as the default so that you do not need to reselect the workspace
the next time you run again. When the path has been set, click the [OK] button.

If the selected directory does not exist, confirm the user whether to create the directory.

Create a directory in the workspace you have set and the welcome page of the tool is displayed. The
welcome page is displayed only when creating a workspace newly, and is not displayed when selecting
the workspace created previously.
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Close the welcome page and the product screen is displayed.
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6. Set License
To use Controller Tester, you must register the license first. The procedures for registering the license
are as follows.

1. Select [Help] -> [License] in Menu.

2. Select [Product] -> [Controller Tester] and click [Edit].

3. Enter the license in the manner provided in Editing License Information and click [OK] button to
register the license.
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• Floating: Register it through the license server. Enter the server information (operating
system, IP, port) and click [Authentication Test] button.

• Node-lock: Register the license file provided.
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7. Set a Toolchain (Analyzer)
To perform the test using Controller Tester, the toolchain setting is required.
You must have a toolchain (compiler information) for the source under test to create a project.

The toolchain can be set in [Window] -> [Preferences] -> [Toolchain].

And it can also be set through [Toolchain setting] in Create a source file C/C++ project wizard or in
Create a C/C++ Project from Embedded wizard.

The functions related to the toolchain setting provided by Controller Tester are as follows.

• Add a Toolchain
• Edit a toolchain
• Duplicate a toolchain
• Remove a toolchain
• Export a toolchain
• Import a Toolchain
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7.1. Auto-registration of Toolchain
When executing the Controller Tester, it extracts the information of Visual Studio compiler installed in
user PC and the information GCC compiler installed along with the Controller Tester and registers the
toolchain automatically (the registered toolchain is not registered again.).

The auto-registered toolchain can be checked in [Window] -> [Preferences] -> [Toolchain] window, and it
displays the message “Automatically generated.” in the description.
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7.2. Add a Toolchain
1. In [Window] -> [Preferences] -> [Toolchain] window, click the [Add Toolchain] button.

2. In [Add a toolchain] window, enter the toolchain information.

• When you click [Extract toolchain Info] button after [Compiler] , the toolchain information
is extracted automatically from the compiler entered.

• In [Compiler] , enter the compiler path.
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◦ Ex:
▪ If it is based on Visual Studio:

C:\program Files (x86)\Microsoft Visual Studio 10.0\VS\bin\cl.exe
▪ If it is based on GCC:

C:\MinGW\bin\gcc.exe
▪ CodeWarrior 5.x or higher for Freeescale HC (s) 12:

C:\Program Files (x86)\Freescale\CWS12v5.1\Prog\chc12.exe
3. In [Name], enter the name of toolchain to be created.
4. In [Description], enter the description of toolchain to be created.
5. The entry information of [Env Script], [Configuration] and [C/C++] is set automatically by extracting

the information from the compiler or can be entered directly by user.
6. After entering the toolchain information, click the [Next] or [Finish] button.

7. In [Advanced Compile setting] window displayed when clicking the [Next] button, the detailed items
related to the configurations selected in the [Configuration] are shown. Each item can be changed
by the user. The application of the changed items can be checked in advance via [Example].

For the detailed setting procedure for the other toolchain detail, please contact the
Technical support contact at the bottom of this document Troubleshooting page.*
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7.3. Edit a Toolchain
1. Select the toolchain to be edited and click the [Edit] button.

2. Edit the information of toolchain.
3. Click the [Finish] button.

Suresofttech User Manual - 3.4

Page 20 of 267



7.4. Duplicate a Toolchain
1. Select the toolchain to be copied and click the [Duplicate] button.

(It can copy only a toolchain which a compiler is not entered.)
2. Edit the toolchain information that you want to change.
3. Click the [Finish] button.
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7.5. Remove a Toolchain
Select the toolchain to remove and click the [Remove] button.

If there is a project using the toolchain you want to remove, the project will not work
properly.

!
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7.6. Export a Toolchain
The toolchain information can be exported via ‘Export’ function.

1. Click [File] -> [Export] in menu and select [Toolchain] in [Preferences].

2. Select the toolchain to be exported and click [Browse] button to specify the path to be exported. If
you set the system header file in the toolchain settings, a checkbox will be displayed in the
[Exporting system header] column, where you can choose whether to export.

3. Click [Window] -> [Preferences] -> [Toolchain] -> [Exporting] in menu to set the system header
size to be exported. The system header larger than the size you had set cannot be exported.
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7.7. Import a Toolchain
The exported toolchain can be imported via the [Import] function.

1. Select [File] -> [Import] in menu and click [Toolchain] in [Preferences].

2. Select the file to import and check the toolchain to import when the toolchain fo the file is
displayed.

It the name of the toolchain to import is duplicated with the existing toolchain name, the status of export
becomes “Need to configure”. The name of the toolchain to import can be modified in [Select how to
resolve] window shown when clicking the [Next] button.
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8. Create a Project

Checklist before creating a project
Since Controller Tester is a tool that detects errors by actually executing source codes, the source code
under test must be executable. In other words, the source code under test must be buildable for normal
testing.

Before creating and testing a project, you need to set up a ‘toolchain’ that takes into account the
development environment of the target software. Please refer to Set a toolchain for details.

Controller Tester automatically generates a stub if the target object to link does not exist during the build
process. However, the automatic test stub generation feature may have limitations in performing tests,
so it is recommended to prepare an appropriate test strategy in advance.

Create a project
To create a Controller Tester project, execute [Create a Project wizard].

Select [File] -> [New] or click the shortcut icon.

The following types of project creation wizards are provided.

• C/C++ Project with Source Files
Creates a project by selecting the source file directly.

• C/C++ Project from Embedded
Creates a project by using an embedded project file.

• C/C++ Project from Visual Studio Project
Creates a project by using Visual Studio dsw, sln, vcxproj and vcproj files.

• C/C++ Project form Existing CodeScroll Project
Creates a project by using the CodeScroll project created previously.

• Creates a C/C++ Project with CPI File
Creates a project by using project creation information located in a CPI file.

• Creates a C/C++ Project with Build Information
Creates a project by using a makefile and build script.
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8.1. C/C++ Project with Source Files
Create a project with C/C ++ source code files. The user needs to enter the necessary information to
build the source code.

1. Enter the project name in [Project name].

2. In [Select Toolchain], select the toolchain to use in the project. If there is no created toolchain,
create a toolchain through [Toolchain Setting]. Please refer to Set a Toolchain for details.

3. Click the [Next] button to move to the next screen. If you click the [Finish] button, an empty project
containing no source file is created.
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• You can select the source file directly, or through a text file with a file path.

4. Select source files directly.
a. Click [Browse …] to specify the [Top Directory] to be displayed in the directory screen

below.
• Except in special cases, make the directory one level higher than the directory

containing the source files you want to select as the top-level directory.
b. On the [Directory] screen shown on the left, select the directory containing the source files

to be used for project creation.
c. The files in the selected directory appear on the [File] screen shown on the right. Check the

files to add.

5. Select by using a text file with the file paths.
a. On the [Text file written list of source files] screen shown below, click [Browse …] to select a

text file with a list of source files(absolute file path).
b. Clicking the [Remove] button deselects the selected text file and the source file selected

through the file.

6. After all settings are completed, click the [Finish] button to create the project.
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8.2. C/C++ Project from Embedded
Create a project with an embedded project file(.xml, .gpj, .prw, .prj). Except in special cases, the
information required for the build is automatically entered, so there is nothing to specify by the user.

1. Enter a project name in [Project name].
2. Choose a toolchain that fits the embedded project you select.
3. In [Import Setting] -> [Embedded Project File], specify the embedded project file of the software

under test.
4. After completing all settings, click [Finish] to create the project.
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8.3. C/C++ Project from Visual Studio
Project
Create a project with a Microsoft Visual Studio project file(.dsw, .sln, .vcxproj, .vcproj). Except in special
cases, the information required for the build is automatically entered, so there is nothing to specify by the
user.

1. Enter the project name in [Project name].
2. Specify the Visual Studio project file to import in [Visual Studio Project].
3. If there are values that must be set before calling the compiler of the toolchain to be registered,

add a script file to set the values to [Advanced]-> [Environment Script File].
4. Click [Next] to move to the next screen. When you click Done, module settings are randomly

selected for the imported Visual Studio project.
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5. Select the module to be activated from the modules included in the Visual Studio project.
6. Select the configuration of each module.

• [Set All Configurations …] allows you to change the configuration for all modules in a batch.
7. After all settings are completed, click the [Finish] button to create the project.
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8.4. C/C++ Project form Existing CodeScroll
Project
Import an existing CodeScroll project and create a new project with that information. You can easily
create a new project with the same configuration(source file, exclude/include analysis, compile flags) as
the existing project.

1. Use the [Browse …] button to select the CodeScroll workspace or CodeScroll project path.
2. Projects existing in the selected path are displayed in the [Projects] list.

• When the CodeScroll workspace is selected, all the projects under it are displayed.
3. Click [Finish] to create the project.
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8.5. Create a C/C++ Project with CPI File
Create a project from a CPI file. The CPI file is an information file for project creation in the command
line interface.

The CPI file must be created by the user using the template file in the {installation path}\plugins\
com.codescroll.gp.cli_x.x.x.x\cpi folder.

1. Select a CPI file with the [Browse…] button.
2. Click the [Finish] button to create the project.

You can also create a project by dragging and dropping a CPI file into the test navigator.*

Suresofttech User Manual - 3.4

Page 32 of 267



8.6. Create a C/C++ Project with Build
Information
Create a C / C ++ project from build information. The project is created as many as the number of
modules extracted from the build information.

1. Enter a project name in [Project name]. The final project name is determined by combining the
entered project name with the module name extracted from the build information.

• Ex) [Project name]Extracted module name

2. Choose the same toolchain as the compiler you use for the build.
3. In [Import Setting]-> [Build Command], enter the command required for the build.

• Ex) Make all / make clean
4. Specify the path where the makefile is located in [Import Setting]-> [Build Directory].
5. If there are values that must be set before calling the compiler of the toolchain to be registered,

add a script file to set the values to [Advanced]-> [Environment Script File].
6. After completing all settings, click [Finish] to create the project.
7. When the project creation is completed after building, the result screen appears.
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• Success: Project creation complete.
• Error: If the creation failed due to an error during project creation.
• Exclude: If the same project name exists in the workspace.
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9. Create a Test
Generate test data and test code to test the functions of the source code. You can create individual tests
for each function.

Create unit tests
Generate test data and test code for each function under test.

1. Select the project or module to create unit tests, right-click and click the [Create Unit Test] menu.

2. After the analysis is finished, in [Select function to be tested], select the function to perform the
unit test.
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a. You can filter the function under test using [type filter text].
b. You can use the [Selection type] combo box to select the function to be tested based on the

source file or function.
c. You can easily select and deselect all functions under test with the right-click menu.
d. When [Run after Test Creation] is selected, the test is executed after the test data is

generated.
3. Click [Finish] to create the unit test.

Create and run tests
The [Create and Run] function allows you to create and run unit tests at once without using the [Create
Unit Test] function.

1. Select the function to be tested in the test navigator and right-click.

2. If you select the [Create and Run] menu, it creates a test for the target function and then runs the
test.

Create an integration test
You can use the toolbar menu to create an integrated test.

The integration test name is automatically assigned and can be changed using the [Rename] context
menu.
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10. Test Editor
The test editor can be opened by double-clicking the test or test case in each test view, located at the
bottom of the unit/integrated test view.

You can move the editor and open it in a separate window.*
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10.1. Test Info
The Test Information tab is a feature that presents the test code as a tree of test structures, making it
easy for users to modify the test code.

• User code can be inserted into the test code.
• You can control global variables related to the function under test.
• You can control the input and output of the function parameters and return values.
• You can enter the code to be executed just before calling the function under test.

Repeat function calls
You can have the function under test be called multiple times.

Change detection
If you edit and save the information of a test that has already been executed, “The information has been
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changed after executing the test.” is displayed at the top of the test editor.

Suresofttech User Manual - 3.4

Page 40 of 267



10.2. Test Case
Test cases provide the ability to edit inputs for a function under test and the expected value for the
execution result.

• In the test structure tree, you can enter input values for the variables specified as input.
◦ If there is no input value, the value of the variable is ‘undefined value’, and the tool

initializes the variable with no value entered as 0 (Blank if a string) for the
convenience of the user.

• You can switch the representation of the test structure as a table or tree with the [Show as Tree],
[Show as Table] toolbar menu.

• With the [Apply the test case in a lump] context menu, you can apply the input and expected
values of the test case to other test cases in the same test at once.

• If you select the ‘Out’ of a variable in the test structure tree, You can check the value of the
variable after the test is performed.

• Editable cells are displayed in a pale sky color.
• If the expected value is different from the host/target output, it is displayed in blue.
• You can use ~ (range) and logical operators! (Not), & (and), and | (or) in expected values.
• The following shortcuts are available.

◦ Move row: arrow keys (↑, ↓)
◦ Editable cell focus: Enter
◦ Editable cell focus out: Esc
◦ Move column (editable cell): Tab (right), Shift + Tab (left)

Change detection
If you edit and save the information of a test case that has already been executed, “The information has
been changed after executing the test.” is displayed at the top of the test editor.
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10.3. Test Code
You can check the test code by clicking the Test Code tab in the test editor.

• If the user edits and saves the test structure tree, the changes are automatically reflected in the
test code.

• If the return type of the function under test is a primitive type, a macro that outputs the return value
is automatically generated.

• If you want to modify the test code yourself, you must switch the test to unmanaged code.
• The test execution function must have a return type and an input parameter of a void type.
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10.4. Configuration
On the configuration tab, you can make various settings for unit testing.

• If you modify and save the test name, the test name that appears in the unit test view changes.
• You can enter a description for the test.
• With the related file settings, you can select the file to which the function under test belongs.
• You can set the timeout for the test.
• You can choose whether to keep the context for the test.
• If you want to write test code yourself, you need to do [Change Unmanaged Code].
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10.5. Test Macro
Controller Tester provides several macros to help users write test code more easily. You can check and
write the macro provided using the “[Ctrl] + [SPACEBAR]” shortcut in the editor view.

ASSERT macro
Examine the conditional expression and print the success/failure in the test case view.

Macro Parameter

CS_ASSERT(_b) _b: conditional expression

CS_ASSERT_MSG(_B, _msg) _B: conditional expression
_mgs: message to print when the conditional expression is false

Output macro
Print the values of specific variables in the test case view.

Macro Parameter

CS_INT_OUTPUT(_v, _s) _v: Integer variable
_s: test data name

CS_UINT_OUTPUT(_v, _s) _v: unsigned integer variable
_s: test data name

CS_FLT_OUTPUT(_v, _s) _v: real variable
_s: test data name

CS_STR_OUTPUT(_v, _s) _v: char* or char[] variable
_s: test data name

Input macro
Pass test data to the function under test.

Macro Parameter

CS_INT_INPUT(_t, _s) _t: integer type name
_s: test data name

CS_UINT_INPUT(_t, _s) _t: unsigned integer type name
_s: test data name

CS_FLT_INPUT(_t, _s) _t: real type name
_s: test data name

CS_STR_INPUT(_t, _s) _t: char* or char[] type name
_s: test data name
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Address-related macros
If there is a part that directly assigns or fetches the value in the embedded address in the converted
source code, it may not operate normally when executed on the local computer. In this case, you can
use an address-related macro for the virtual address.

Macro Description

CS_VIRTUAL_ADDR(_b,_e) Creates the space from the address (_b) to the address (_e)

CS_ADDR_ASSIGN(_t,_a,_v)
CS_ADDR_SET(_t,_a,_v) Assigns the value (_v) of type (_t) to the address (_a)

CS_ADDR_GET(_t,_a) Fetches the value of type (_t) from the address (_a)

CS_VIRTUAL_ADDR_CLEAR() Frees the memory space created

Address-related macro example

Other macros
Macro Parameter Description

CS_LOG(_msg) _msg: log message Outputs user log

CS_TESTCASENO() Returns the number of the test currently running
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11. Test Run
Testing can be performed in a variety of ways.

Run all tests
Run the selected tests in the [Unit Test] view and [Integration Test] view.

1. Select the project to run the test, right-click ans slect [Run test]

2. A progress monitor of the test opens. When the test is completed, you can check the results
through each test view.

Run unit tests
Run the selected unit tests in the [Unit Test] view.

1. Click the [Run] button on the dashboard in the [Unit Test] view.

2. A progress monitor of the test opens. When the test is completed, you can check the results
through each test view.
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Run integration tests
Run the selected tests in the [Integration Test] view.

1. Click the [Run] button on the dashboard in the [Integration Test] view.

2. A progress monitor of the test opens. When the test is completed, you can check the results
through each test view.

To perform only a specific test case, select the test case you want to run and right-click
the mouse and click the [Run Test Case] menu.*
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12. Inspect Debug Information
If an error occurs while running the test case, you can use the [Inspect Debug Info] function to determine
the cause of the error.
[Inspect Debug Info] function can be checked in the unit test view with the context menu of the test case.

When [Inspect Debug Info] is performed, debug information is displayed in the [Inspect Debug Info].

The test case (Debug info included) is displayed in the test case where the [Inspect Debug Info] was
performed.

Before executing the test case, the test case is automatically executed before performing
[Inspect Debug Info].*
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13. Properties
Controller Tester provides a page to set the properties of the project, module, and source files
(translation unit).

The property page types are:

• Project Properties
• Module Properties
• Source File(Translation Unit) Properties
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13.1. Project Properties
You can edit the properties of the created project.
Select [Project]-> [Properties] from the menu or right-click the project in the Test Navigator view and
click the [Properties] menu.

Inclusion and Exclusion Info
You can set what to exclude or include when analyzing the project.

• Add targets to include in the analysis.
1. Click the [Add File] or [Add Directory] button.
2. Select files or a directory to analyze.
3. Click the [Open] or [OK] button.

• Add targets to exclude from the analysis.
1. Click the [Add File] or [Add Directory] button.
2. Select files or a directory to exclude from the analysis.
3. Click the [Open] or [OK] button.

Info
Shows brief information(path, type, location) about the project.

To analyze only selected directories or files, add the targets to be analyzed to [Included]
and check [Exclude All].*
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Virtual Address
You can select a memory setting managed by the Virtual Address preference.

External Command
You can enter external commands to run before or after the test run.
In [Pre-command for test run], you can enter a command or batch file to execute an external command
before running the test.
In [Post-command for test run], you can enter a command or batch file to execute an external command
after running the test.
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Exclusion of coverage
You can set coverage exclusions on a per-file or per-function basis.
You can see that the coverage of the excluded function is excluded from the coverage results obtained
by running the test.
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Run Test
Set the generated tests to run in a user-specified directory, not in a workspace. In this case, you do not
need to copy the library or header files used by the target under test to the workspace or change the link
settings.

Click the [Start Test in User Code] checkbox.
Select the home directory to run the test and click the [Apply] button.

[Test Case Timeout] Set the time to be used as the timeout judgment when executing the test case. If
the test execution time exceeds the test case timeout time, the test for that test case ends and the result
is reported as a timeout.

[Maintain test case context] is a feature that performs all test cases with one launcher. The previous test
execution result (static, global variable) is maintained during the test, and each test case result value
does not appear independently. This makes the relationship between the test case result values clear.

[Redirect standard output or standard error] is a feature to record standard output and standard error in
the log file for each test case.

Generate test cases automatically
You can set to keep previous test cases when automatically generating test cases.

The search-based generation is not affected.!

Suresofttech User Manual - 3.4

Page 54 of 267



Combination

You can set up how to extract test data if the variable partition is range.

Select the desired test data extraction method by checking the checkbox. The meaning of each value is
as follows.

Method Description

Max value Selects the maximum value of the partition section.

Min value Selects the minimum value of the partition section.

Random value Selects a random value among partition sections.

You can select multiple test methods of data extraction.
When all are unchecked, the default is automatically set to the maximum and minimum values.
[Data combination] supports Flat, Pairwise and Random. The meaning of the combination is shown in
the following table.

Combination Description
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Flat Combines simply based on variables having the largest number of test data.

Pairwise

Combines so that each selected parameter data is paired at least once with the parameter
data other than itself.
Pairwise is performed as many as the maximum number(default 200) of symbols used for
the combination, and when the number of symbols is exceeded, Flat is performed.

Random
Combines the test data as many as the number of test cases that the user defines any value
between the minimum value and the maximum value for the variable partition of input
parameters(default 5).

[Array elements] is a feature to select how to generate test data for each array element.

Method Description

Generate an array of the first element Creates only the first element regardless of the array size.

Generate an array of all the elements Creates elements as much as the array size.

When creating a test, global variable creation is an option to create all global variables used by all
functions called from the function under test.

Search-based (CS Labs)

You can set the maximum search when automatically generating test cases based on search.
You can turn this feature on or off with [activating search-based test case generation] option. Reanalysis
is required after turning the feature on.

Option Description

CS Labs allows you to preview new features that will be released in CodeScroll tools
later. Based on feedback for the new features, CS Labs features may or may not be
applied as formal features.
*
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Number of searches(for each
branch)

Searches for the number of times entered for each branch
combination.

Search time(seconds) Searches for the time entered.

Function Generator

When using the function generator to automatically generate test cases, specify common setting values
that each function has in common.

Option Description

Sample interval Interval of samples when sampling from function

Sample count Number of samples when sampling from function
(Number of test cases)

Start value Default value at which the function starts, and generates a value based on the value
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Import settings

Project created by Visual Studio project

You can see the path of the Visual Studio project used for creating the project and the modules active in
the selected project.
You can change whether each module is active or not and the configuration.
You can change the configuration of all modules collectively through the [Set All Configurations] menu.

1. If you click the [Set All Configurations] button, a dialog box where you can select one of the
configurations common to all modules opens.

Suresofttech User Manual - 3.4

Page 58 of 267



2. Select the configuration to be applied to all modules in common and click the [OK] button.
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13.2. Module Properties

Build
You can set toolchain related information (toolchain, linker) and link flags for the module. Changing the
toolchain also changes the toolchain set in all source files(translation units) under the module.

Compile flag
You can set compile flag information for that module.
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• Enter compile flags in [Command] tab. [Include] tab and [Define Macro] tab help to enter compile
flags easily.

• [Overwrite all sub source files] overwrites the compile flag entered to all source files (translation
units) under the module.

• [Import] imports an external compile flag. [Export] saves the current compile flag externally.
◦ Import

1. Click the [Import] button.
2. Select the file (.cf file) which has compile flags from the file open dialog.

◦ Export
1. Click the [Export] button.
2. In the save dialog, enter the name and location of the file to enter the compile flag and

save.
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13.3. Source File Properties

Build
You can set toolchain related information (toolchain, compiler) for the source file (translation unit).

Info
Shows the information of the source file (translation unit) and the module containing the source file.

Compile flag
You can set compile flags for source files(translation units).
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• If you select the [Parent compile flag inheritance] check button, the compile flag of the module
containing the source file is applied. Conversely, deselecting can change the current compilation
flag.

• [Import] imports an external compile flag. [Export] saves the current compile flag externally.
◦ Import

1. Click the [Import] button.
2. Select the file (.cf file) which has compile flags from the file open dialog.

◦ Export
1. Click the [Export] button.
2. In the save dialog, enter the name and location of the file to enter the compile flag and

save.
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14. Preferences
In the preference menu, you can check or change the current settings of the tool.

The preferences provided by Controller Tester are as follows.

• Analysis
• Exclusion
• Performance
• Source File Types
• Language
• Theme
• Test
• Toochain
• Persperctive
• Editor
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14.1. Analysis
You can check or change the settings related to the analysis.

Metric
For any view showing metric data, you can set which metrics are visible or hidden and the order in which
they are displayed.
The name of the selected metric is displayed as a tooltip message.

After selecting a metric, you can move to the ‘Hide’ list or the ‘Show’ list with the [>>] or [<<] button.
After selecting a metric in the ‘Show’ list, you can change the order in which the metrics are displayed
with the [Up] or [Down] button.

Metrics View

You can change the settings of the views showing metric data.
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Diagnosis

You can check or set diagnostic information for metrics.
Set the message and diagnostic image (shown in the metrics view) to be displayed when the selected
metric value is included in each range.

To edit the diagnostic information, click the [Edit] button.
A dialog box appears where you can edit the diagnostic information for the selected metric.
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1. Set the diagnostic stage (2 ~ 5).
2. Sets the diagnostic image to show in the metrics view.
3. Press the [Change Sort Order] button to change the sort order of diagnostic images.
4. Enter the diagnostic message and diagnostic range for each step.
5. Select the [OK] button.

CFG
You can change the settings for the control flow graph displayed in the control flow graph view.
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Node Color

You can change the color of nodes in the control flow graph.

Test Navigator
For each operation that copies or moves source files in the Test Navigator view, you can set options to
ask whether or not to continue.
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Function View

Call Graph
You can change the settings of the function call graph displayed in the call graph view.
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The [Show Library Functions] checkbox allows you to set whether or not to display library functions.
If you set the value of ‘Does not distinguish the direction’ to ‘2’ in ‘Call Depth Setting’, it shows the call
information of one depth for both the caller and callee, centering on the selected function(Just the callers
or callee of the selected function shown).

If you want to set the caller and callee separately, you can specify the value of each step by selecting
the sub-option. You can change the color of nodes visible in the function call graph.
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14.2. Exclusion
You can set the directories and files to exclude from the analysis.

• Add the analysis exclusion target.
1. Click [Add].
2. Select the directories or files to be excluded.
3. Click [OK] or [Open].

• Delete the analysis exclusion target.
1. Select the directories or files to be deleted.
2. Click [Remove].
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14.3. Performance
It provides the settings that can improve the work performance suitably for the user environment.

Multi-Core Usage
The option [Multi Core usage] improves performance by using multiple cores when executing the project
analysis. (If PC has not enough CPU resource, it can affect the performance of the other tasks.)

• Perform Multi-core Analysis: Enter the number of the core to be used when analyzing the source
code. (The range of the core number: 2 ~ the maximum number of cores in the execution
environment)

Using frozen code
The option [Using frozen code] improves the performance by minimizing unnecessary tasks (detecting
and re-analyzing source code modifications etc.) assuming that there is no change in the source code
configuration.
Use this option only if the PC performance is very slow and the source code configuration is never
changed during testing. (If the source code or analysis setting is changed while the option is enabled, it
may cause unexpected problems.)

Difference with Editor – [Detect modifications] option
While if [Detect modifications] option of Editor is enabled, it analyzes the modified source
code when executing [Analyze], if [Using frozen code] option of analysis is enabled, it
does not analyze the modified source code until re-analyzed even though the source
codes are modified. In addition, Editor – [Detect modifications] option is ignored.

*
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14.4. Source File Types
You can set the extension to be used as a source file for each project type.

• Add a source file extension.
1. Select the project type.
2. Click [Add].
3. Enter an extension, select the type and click [OK].

• Remove a source file extension.
1. Select the project type.
2. Select the extension to be removed.
3. Click [Remove].
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14.5. Language
Sets the language to be displayed in tools and reports.
You can select a language from the drop-down menu for [System] and [Report].

If you click the [Apply] button after changing the [System], a dialog box asking you to restart Controller
Tester will open.

When you change the system language, the report language also changes automatically.*
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To set the report language differently from the system language, change the report
language after restart.
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14.6. Theme
It provides the settings for changing the theme of the Controller Tester.

CS Labs allows you to preview new features that will be released in CodeScroll tools
later. Based on feedback for the new features, CS Labs features may or may not be
applied as formal features.
*
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14.7. Test
Provides settings related to editing test and execution.
[Except for non-executable tests when errors occur during test execution] is an option that allows you to
execute only executable tests, excluding non-executable tests, when the whole test cannot be performed
due to an error that occurs during test execution.
The [Using Macro Constant] option allows you to edit the test using macro constants defined in the
source file (ex: using macro constants for input/expected values of array indexes and test cases).

Virtual Address
It provides the memory settings for the embedded environment test. You can manage the memory
address group to be used in the project properties.

This setting only applies to converted projects.!
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In the screen above, you can check the virtual memory address information set. Click [Add…] button to
add the virtual memory address.

The virtual memory address areas can be specified up to 50 areas and it can be entered in hexadecimal.

Export test data
When exporting data, you can set the output direction of variables to either horizontal or vertical
Select the output direction of the export variable and click [Apply].
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External Editor
You can set the external editor to open CSV file.
Enter the path of the external editor and click [Apply].

Unit Test View
You can set the function node display in the Unit Test view included in the test perspective that UI/UX is
improved.
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Coverage
You can set the branch coverage measurement and whether to display the covered/uncovered.

[Branch coverage Column Info display] radio button allows you to select the information of the marker to
be displayed in the left column of the editor.

• T/F marker option is shown in the source code editor.
• Covered Decision: T/F indication of a covered decision
• Uncovered Decision: T/F indication of an uncovered decision

The checkbox [Branch coverage, MC/DC measurement operator] sets the branch coverage measuring
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target. If it is re-analyzed and executed, the settings are applied.

• Conditional Operator(?:) expression: Measures the branch coverage for ternary operator
expression.

• Boolean Operator(&,||,!,<,<=,>,>=,==,!=): Measures the branch coverage for boolean operator
expression.

• If unchecked all, measures the branch coverage for ‘if’, ‘for’, ‘while’, ‘do-while’ and ‘switch’
statements only.

Type Partition
You can edit the basic type partition for each toolchain and restore it into the default value provided.
In Toolchain combo box, select the toolchain to be modified, edit the partition and click [Apply].

Perspective
After the test has created, you can set the opening option for the perspective associated.
Select one among [Always open], [Never open] and [Prompt] and click [Apply].
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14.8. Toochain
You can set the information for the toolchain to be used in the tool.

You must have a toolchain (compiler information) for the source to be tested in order to create or
analyze the project.

The detail description of the toolchain settings can be found in the ‘Set a Toolchain (Analyzer)’.

Export Toolchain
It sets the system header size of the toolchain to be exported. The system headers larger than the size
you set cannot be exported.
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14.9. Persperctive
You can change the settings related to perspective.
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14.10. Editor
You can change the settings related to the editor.

Text file encoding
You can set the encoding to be used when opening a text file in the editor. If the [Automatic detection]
option is on, it will automatically detect the encoding of the text file. (If it cannot be detected
automatically, it will open with the encoding you set.)

Indentation
If you change the tab size, the tab size shown in the editor is changed too.

Detect modifications
If the [Detect modifications] option is on, it checks the impact of the changes each time the source file is
modified.

If the disc speed if slow, deselect this checkbox to improve the performance.*
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15. Test Perspective
The Test Perspective provides UI for displaying only the necessary information so as to keep the flow of
the testing task and focus on the goal.

It provides a high DOF screen with Eclipse RCP. You can set it in the [Window] menu and in each view.

The components that make up the test perspective are:

• Dashboard
• Test Navigator View
• Unit Test View
• Integration Test View
• Coverage View
• MC/DC View
• Stub View
• Class Factory View
• Control Flow Graph View
• Call Graph View
• Error View
• Debug Information View
• Fault Injection View
• Input/output Data Graph View
• Console View
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Views that are not included by default can be opened from [Window]> [Show View]> [Other…] on the top
menu.
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15.1. Dashboard
The Dashboard section provides a summary of frequently used functions or tests that are currently in
progress.

Project name
It shows the name of the project selected in the [Test Navigator] view.

Bookmark menu
You can use the Create Project, Create Test, Import, Export, Properties and Preferences functions.

Host/Target setting menu
You can change the test environment to the host or target.

Coverage-related menu
You can use the Show the Merger coverage between host and target and the Show full coverage
(Include External Coverage) functions.

Open Perspective menu
You can select and open the perspective located in Controller Tester
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Global Search
The Global search allows you to search New, View, Editor, Menu, Properties, Preferences, Project
resource (source file, function), Test, Stub and Class factory, etc. by keywords. Select the Global search
window or press the shortcut key (Ctrl + 3) to use the Global search function.

The project resource (source file, function, etc.), test, stub and class factory can be
searched by selecting the analyzed project.*
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Show Coverage
It allows you to set the covered area in the source code editor is marked or not.

Open/Close the test-related view menu
You can open and close the [Coverage] view, [MC/DC] view, [Stub] view, [Class Factory] view, [Control
Flow Graph] view, [Call Graph] view, [Function Call Hierarchy] view, and [Error] view.
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15.2. Test Navigator View
The [Test Navigator] view shows the hierarchy structure of the projects and the test models under the
projects included in the workspace.

The [Test Navigator] view does not occupy any space but remains the minimized state. If you select
[Test Navigator] in the dashboard, the [Test Navigator] view is located above the source code editor
area.

Icon
Icon Description(*: created after analysis)

Open project

Closed project

Module

Source file (translation unit)

*Global variable

*Function

*Header folder

*Header file

*System header file
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Toolbar menu
Menu Description

Link with Selection Highlights the items selected in the other view.

Collapse All Hides all tree nodes.

Icon overlay
Icon overlay Description

Analyzed

Changed after analysis

Copy the source file into the other module
To copy the source file into the other module, with Ctrl key pressed, drag and drop the source file to be
copied into the target module.
Alternatively, right-click the source file to be copied, select [Copy], right-click the target module and
select [Paste]. (Shortcut keys: Ctrl + C and Ctrl + V)

Move the source file to the other module
To move the source file to the other module, drag and drop the source file to be moved into the target
module.

Drag and Drop from Windows Explorer
• Creates a project by Visual Studio project

From Windows Explorer, drag and drop the Visual Studio file (.dsw, .sln, .vcxproj, .vcproj) into Test
Navigator view.

• Imports the source file from the file system
From Windows Explorer, drag and drop the source file into the target project or module in Test
Navigator view.

Drag and Drop functionality in Explorer does not work in Windows 10.!
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15.2.1. Merge Project Coverages
If a project size is too large to run the test at once, you can run the test by dividing it into multiple
projects. [Merge Project Coverage] function runs the test by dividing one project into multiple projects
and then shows the overall coverage results by merging the result of the test for these projects.

Merge Project Coverage
1. After selecting all the projects that you want to merge the coverage results, right-click it and select

[Merge Project Coverage].

2. Select [Merge Project Coverage] menu to open for creating the project name. Enter the project
name to be created in [Project Name].

• By clicking the [Add] button, you can perform a merge coverage function for projects not
included in the workspace.

3. Click [OK] to check that a new project that the project results had been merged has created in the
Test Navigator view. The merged project is displayed with a red mark on the upper right corner.
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4. Select the project that the results had been merged and check the coverage view to see the
overall coverages.
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The [Merge Project Coverage] function may not work properly when two or more
different functions in the project to be merged have the same function name.

!
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15.3. Unit Test View
The [Unit Test] view section is located on the right of the screen. The [Unit Test] view combines the test
and coverage information and provides it in a single view.

Toolbar menu in the Unit Test view
Toolbar icon Description

Expand All Shows all test view tree.

Collapse All Hides all test view trees.

Show as Unique Test Name Displays by unique test name.

Total Displays all the tests.

Failure/Error Displays only the tests that the test result is Failure/Error.

Failure Displays only the tests that the test result is Failure.

Error Displays only the tests that the test result is Error.

Success Displays only the tests that the test result is Success.

Function changed Displays only the tests that the function to be tested has been changed.

Run not guaranteed Displays only the tests that the test execution is not ensured.

Host/Target result different Displays only the test that the host result and the target result are different.
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Pull-down menu in the Unit Test view (▽▽)

Menu name Description

Show coverage at all elements Displays the coverage in all items.
(function, test, test case)

Add description when duplicate test
case Adds original test case number on duplicated test case.

Insert Default Values for Empty Input When input data are empty, inserts default values.

Check Integrity Checks integrity about functions and stubs. Then, reset test if it
needs.

• Insert Default Values for Empty Input

Variable type Default value

string (empty string)

without string 0

Dashboard in Unit Test

Menu Description

Runs unit tests.

Shows success, failure, error and total of test case.

Selects the coverage type to be displayed in the [Unit Test] view.
(statement, branch, MC/DC, function call)

Shows the selected kind of full coverage.

For [Test reconfiguration], refer to [Source Code Modification and Test Reconfiguration]
on User Guide 3.4*
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Search
In the Unit Test view, you can search functions, tests and test cases by file, function, test, status
(success, failure, error) and issue name.

Status search keyword

In the Unit Test view, you can filter the tests that are displayed by the status search keyword. It provides
searchable keyword recommendation and auto-complete function.

Keyword Description

%TEST_SUCCESS% Test success

%TEST_FAILURE% %TEST_ERROR% Test failure/error

%TEST_FAILURE% Test failure

%TEST_ERROR% Test error

%TEST_HAS_NOT_FUNCTION% Function changed

%TEST_NOT_GUARANTEE% Run not guaranteed

%TEST_RESULT_DIFFERENT% Host/Target result different

Structure of the Unit Test view
The Unit Test view presents the hierarchy structure of [Function]-[Test]-[Test case]. If there are more
than 100 test cases in a test, they are grouped in groups of 100 to represent a group.

‘Run not guaranteed’ is a case where test code is generated, but there is no guarantee
that it will run normally. This is the case when using a type that is difficult to specify as a
parameter or return value.
*
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Item icons in the Unit Test view

Item icon Description

None Function

Test

Test case, Test case group

Item status color in the Unit Test view

The execution information of functions, tests, and test cases in the Unit Test view is represented by
colors.

Color Description

Green Function/Test: If the execution result of all the test cases under it is success.
Test case: The result of execution is success.

Blue Function/Test: If only test cases with failure and no test cases with errors exist under it.
Test case: The result of execution is failure.

Red Function/Test: If test cases with error exist under it.
Test case: The result of execution is error.

Orange Function/Test: All test cases have not been executed under it and test cases that are not
guaranteed to run exist.
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Test case: Run not guaranteed.

Black Function/Test: All test cases under it have not been executed.
Test case: Not been executed.

Function node

The Function node provides the function name, the coverage and the test case execution results
(success, failure, error and total).

Double-click on a function node to check the location of the function in the Source Code Editor window.

For the coverage for each function node, the test execution result of the other function
may be applied depending on the call relationship between functions.*
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Context menu of the function node

Context menu Description

Create Test Creates a test of the selected function.

Copy Test Copies tests of the selected function.

Delete Deletes tests and test cases of the selected function.

Show call graph Shows the function call graph of the selected function.

Show Control Flow Graph Shows the control flow graph of the selected function.

Show MC/DC Shows MC/DC of the selected function.

Host Output Value -> Expected Value Pastes the host output value to the expected value.

Test reconfiguration Reconfigure test information.

Set related file Selects the files containing that test.

Relevant issues settings Associates the selected test with the issue of the management tool.

Import Test Data Imports the test data saved in local.

Export Test Data Exports the test data to local.

Add Stub Adds the stub to the selected test.

Select Function Selects the checkbox of all the functions selected by a mouse.

Deselect Function Deselects the checkbox of all functions selected by a mouse.

Generate coverage report Exports the selected test coverage to the selected path.
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Test node

The test node provides coverage, test case execution results(success, failure, error, total).
Double-click on a test node to open its Test Editor.

Context menu of the test node

Context menu Description

Add Test Case Adds the test case to the unit test selected.

Generate test cases
automatically Creates the test case in various ways.

Host Output Value -> Expected
Value Pastes the host output value to the expected value.

Initialize Test case Delete all the test cases.

Copy Copies the test and test case.

Paste Pastes the test and test case.

Duplicate Duplicates the test and test case.

For [Test reconfiguration], refer to [Source Code Modification and Test Reconfiguration]
on User Guide 3.4*
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Duplicate multiple times Duplicates tests and test cases as many as the number entered.

Delete Deletes the test and test case.

Rename Modifies the test name.

Test reconfiguration Reconfigure test information.

Set related file Selects the files containing that test.

Relevant issues settings Associates the selected test with the issue of the management tool.

Import Test Data Imports the test data saved in local.

Export Test Data Exports the test data in local.

Large test data Exports it locally or registers the file written by the user to the target test
as a test case.

Add Stub Adds the stub to the selected test.

Select Test Checks all checkbox of the tests selected.

Deselect Test Checks all checkbox of the tests selected.

Generate coverage report Exports the selected test coverage to the selected path.

• Rule for importing test data
When importing the test data, if you select multiple test data numbered with the test name, it
imports those files by merging them.

Import test data

You can import the test data in various formats (csv, xlsx, txt, json).

For [Test reconfiguration], refer to [Source Code Modification and Test Reconfiguration]
on User Guide 3.4*
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1. In the context menu of Unit Test view, click [Import Test Data] and select either [Basic format data]
or [External format data].

2. If you select [Basic format data], the test data with the format (csv) exported from the Controller
Tester is imported.

3. If you select [External format data], the test data is imported from the files in various formats (csv,
xlsx, txt, json).
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Generate test cases automatically

It creates a test case by using Flat/Pairwise/Random combination, Generates with Function Generator,
and Search-based Test case Generation (CS Labs).

1. In the context menu of Unit Test or Integration test view, click [Generate test cases automatically]
and select one among [Flat Combination], [Pairwise Combination], [Random Combination],
[Generate with Function Generator] and [Search-based Test case Generation (CS Labs)].

Method Description

Flat Combines simply based on variables having the largest number of test data.

Pairwise
Combines so that each selected parameter data is paired at least once with the
parameter data other than itself.
※ The number of variable partitions must be more than 2 and less than 52
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Random
Combines the test data as many as the number of test cases that the user defines
any value between the minimum value and the maximum value for the variable
partition of input parameters.

Generate with
Function Generator

Creates a test case by using six function types. (Ramps, Random, Range, Sine,
Toggle, and Single Value)

Search-based Test
case Generation
(CS Labs)

Creates a test case by using AVM, which is a local search algorithm.
※ Currently, only C language supported

2. If you select [Random combination], the Random combination window is displayed so that the user
can enter the number of test cases.

3. If you select [Generate with Function generator], you can select the function type (Ramps, Sine,
Random, Toggle, Range, Single value and None) and change the settings of the function selected
via the settings of the function generator. In the properties window of the project, you can set the
function generator information in [Test] -> [Generate test cases automatically] -> [Function
Generator].
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a. Common settings

You can change the value in [Project] -> [Properties] with the setting value common to each
function.

Setting Description

Sample
interval The interval of samples to be sampled from the function

Number of
sample The number of samples to be sampled from the function(The number of test cases)

Start value The default value at which the function is started (the values are created based on the start
value)

Minimum
value of type

The minimum value of variable partition (if the return value of the function is less than the
minimum value of type, the minimum value of type is returned.)

Maximum
value of type

The maximum value of variable partition (if the return value of the function is greater than the
maximum value of type, the maximum value of type is returned.)

b. Ramps function

It is a function that creates a pulse by using Pre, Post and Hold values. If the number of samples is
greater than the period of the function, the function is called recursively.
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Setting Description

Pre delay The time to last Pre/Post sample value

Rise samples The time to rise from Pre/Post sample value to Hold sample value

Hold samples The time to last Hold sample value

Fall samples The time to fall from Hold sample value to Pre/Post sample value

Post delay The time to last Pre/Post sample value

Pre/Post delay value Pre/Post delay sample value

Hold value Hold sample value

c. Random function

It is a function that creates a random value between the minimum value (Min) and the maximum
value (Max).

Setting Description

Min The minimum value of random range

Max The maximum value of random range

d. Range function

It is a function that creates values that increments or decrements by a certain interval (Step Size)
between the minimum value of type and the maximum value of type.

Setting Description

Step
size The size of increment or decrement value

Hold The number of times that the Step size holds

Rising The function type that rises by the Step size
Ex) if the step size is 30, 0,30,60……

Falling The function type that falls by the Step size
Ex) if the step size is 30, 100,70,40……

Alternate
If the result value of function meets the minimum/maximum value of type, the function type that
changes to rise or fall.
Ex) if the step size is 30 and the maximum/minimum value are 0~100, 0,30,60,90,60,30,0……

e. Sine function

It is a function that creates Sine value. If the number of samples is greater than the period of the
function, the function is called recursively.

Setting Description

Amplitude The amplitude of Sine function
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Period The period of Sine function

Phase The phase of Sine function

Offset The offset of Sine function

f. Toggle function

It is a function that creates FirstValue and SecondValue repeatedly.

Setting Description

First value The first value that is repeated in Toggle function

Second value The second value that is repeated in Toggle function

g. SingleValue function

It is a function that returns only a constant single value.

Setting Description

Value The value to be created

h. None

It does not create a function.

Relevant issues settings

It associates the selected test with the issue in the issue management tool registered. The Controller
Tester supports the following issue management tools: JIRA, Trac, Redmine, Mantis, Bugzilla.

1. In the context menu of Unit Test view, click [Relevant issues settings…].
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2. Enter the information of the issue management tool in the configuration file
(IssueManagement.ini).

3. Add the issues to be associated with the test.
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4. Check the checked issue list and click [OK].
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15.4. Integration Test View
The [Integration test] view provides the integration test unit that can group the unit tests. The unit tests
under the integration test run in order with the context maintained.

Toolbar menu in the Integration test view
Toolbar icon Description

Expand All Shows all test view tree nodes.

Collapse All Hides all test view tree nodes.

Move Up Test Moves the selected test up.

Move Down Test Moves the selected test down.

Create Creates an integration test.

Shows as Unique Test
Name

Displays with unique test name.

Total Displays all the tests.

Failure/Error Displays only the tests that the test result is Failure/Error.

Failure Displays only the tests that the test result is Failure.

Error Displays only the tests that the test result is Error.

Success Displays only the tests that the test result is Success.

Function changed Displays only the tests that the function to be tested has been changed.

Run not guaranteed Displays only the tests that the test execution is not ensured.

Host/Target result different
Displays only the test that the host result and the target result are
different.
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Pull-down menu in Integration Test view (▽▽)

Menu name Description

Show coverage at all elements Displays the coverage in all items.(integration test, test, test case)

Add description when duplicate test
case Adds original test case number on duplicated test case.

Insert Default Values for Empty Input When input data are empty, inserts default values.

Check Integrity Checks integrity about functions and stubs. Then, reset test if it
needs.

• Insert Default Values for Empty Input

Variable type Default value

string (empty string)

without string 0

Dashboard in Integration Test

Menu Description

Runs integration tests.

Shows success, failure, error and total of test case.

Selects the coverage type to be displayed in the [Integration Test] view.
(statement, branch, MC/DC, function call)

For [Test reconfiguration], refer to [Source Code Modification and Test Reconfiguration]
on User Guide 3.4*
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Shows the selected kind of full coverage.

Search
In the Integration Test view, you can search the integration tests, tests and test cases by file, function,
test, status (success, failure, error) and issue name.

Status search keyword

In the Integration Test view, you can filter the tests displayed by the status search keyword. It provides
searchable keyword recommendation and auto-complete function.

Keyword Description

%TEST_SUCCESS% Test success

%TEST_FAILURE% %TEST_ERROR% Test failure/error

%TEST_FAILURE% Test failure

%TEST_ERROR% Test error

%TEST_HAS_NOT_FUNCTION% Function changed

%TEST_NOT_GUARANTEE% Run not guaranted

%TEST_RESULT_DIFFERENT% Host/Target result different

Structure of the Integration Test view
The Integration Test view presents the hierarchy structure of [Integartion tes]-[Test]-[Test case].
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Item icons in the Integration Test view

Item icon Description

None Integration Test

Test

Global variable test

Test case, Test case group

Item status color in the Integration Test view

The execution information of functions, tests, and test cases in the Integration Test view is represented
by colors.

Color Description

Green Integration Test/Test: If the execution result of all the test cases under it is success.
Test case: If the result of execution is success.

Blue Function/Test: If only test cases with failure and no test cases with errors exist under it.
Test case: If the result of execution is failure.

Red Function/Test: If test cases with error exist under it.
Test case: If the result of execution is error.

Orange
Function/Test: All test cases have not been executed under it and test cases that are not
guaranteed to run exist.
Test case: Run not guaranteed

Black Function/Test: All test cases under it have not been executed.
Test case: Not been executed
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Context menu in Integration test view

Context menu Description

Create Test Creates the dialog for creating a test

Create sub-integration
test Creates a sub-integration test

Copy Copies the test and test case

Paste Pastes the test and test case

Duplicate Duplicates the test and test case

Duplicate multiple times Duplicates tests and test cases as many as the number entered

Paste as sub-integration
test

Pastes the integration test copied into the integration test selected as a sub-
integration test

Delete Deletes the test and test case

Rename Modifies the test name

Select tests Checks all checkbox of the tests selected

Deselect tests Checks all checkbox of the tests selected

Create Integration test and Rename
The integration test can be created in the toolbar menu. The name of the integration test is assigned
automatically and can be changed by using [Rename] context menu.

• Create

Suresofttech User Manual - 3.4

Page 116 of 267



• Rename

Sub-integration test
You can create a sub-integration test under the integration test by using [Create sub-integration test]
context menu or pasting an existing integration test into other integration test using [Paste as sub-
integration test] context menu.

Add a test and change the order of run
There are four ways to add tests to the integration test.
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1. You can select an integration test and create it by using [Create Test…] context menu.
2. You can add by dragging and dropping the test in the Unit Test view to the integration test.
3. You can select the test of Integration Test view and copy/paste it by using the context menu.
4. You can select the test in the Unit Test view and copy/paste it by using the context menu.

There are two ways to change the execution sequence for the test.

1. You can select a test or test case and change it by moving with a mouse.
2. You can select a test or test case and change it by selecting either “Move test up” or “Move test

down” in the toolbar.

The coverage result of Integration Test
If you select the integration test, the result can be checked in the Coverage.
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15.5. Coverage View
It shows the coverage of the function to be tested after test has been run as a percentage.

Coverage type provided in Controller Tester
Coverage Description

Statement Percentage of source code statement executed by the test

Branch Percentage of branch executed by the test
100% branch coverage includes 100% decision coverage and 100% statement coverage

MC/DC Coverage considering the condition coverage and the decision coverage complexly(described
in MC/DC view)

Function
call Percentage of the function called by the test among all the functions

Function Percentage of functions that have been called at least once in all functions

Label icon in Coverage view
Icon Description

Function changed

Function containing Asm code

Toolbar menu in Coverage view
Toolbar icon Description
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Shows coverage for each test.

Shows full coverage.

Shows full coverage(including the external coverage).

Show Coverage
The Coverage view shows the coverage information of the test or test case selected in the Unit Test
view and Integration Test view. If you click [Show full coverage], the coverage information for all tests
can be checked by merging them. And if you click [Show full coverage (Include External Coverage)], it
shows also the coverage imported externally by merging them.

The coverage for the items selected in the tree is displayed at the bottom of the Coverage view.

In the Coverage view, the coverage for each function is displayed for the items selected in the Unit or
Integration Test view.

In the Coverage view table, you can the control flow graph, the function call graph and MC/DC for each
function via the context menu.
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If you enable [Show Coverage] icon in the main toolbar and click the wanted test case in the Unit/
Integration Test view, it shows which part of the source code is covered by using the color information.
The green color indicates that the code is executed and all branches are covered, the red color indicates
that the code is not executed, and yellow color indicates that the portion of the branch is covered only.
You can check T/F of the branch statement covered in vertical column left to the source code editor.
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15.6. MC/DC View
The [MC/DC] view shows the information of MC/DC coverage(Modified Condition/Decision Coverage).

MC/DC coverage
MC/DC is the improved condition/decision coverage allowing each individual conditional expression to
independently affect the result of the whole conditional expression without being affected by the other
individual conditional expressions and it is stronger than the conditional/decision coverage.
If there is no change in the other conditions and it affects the result when the own state has changed,
the state can be said to satisfy MC/DC, and the conditions for creating the truth table are as follows.

• The state of decision(decision statement) must satisfy at least once all possible results(true, false).
• All individual conditional expressions belonging to the decision must satisfy at least once all

possible results(true, false).
• Each conditional expression belonging to the decision affects independently the result value of

decision it belongs to without being affected by the other individual conditional expressions.

MC/DC view table
• View combination lists satisfying the target coverage

The following figure is a view that can identify easily the combinations which need to be covered to
achieve the target coverage.
The left section shows the list of Decisions for the selected functions, below which the list of
combinations satisfying the target coverage are displayed.
The right section shows the truth table of the selected Decision or combinations and whether or
not it is covered. The covered combination is displayed in green and the uncovered combination is
displayed in red.
In the Preferences page, you can change the target coverage rate and the screen view mode. And
you can select all for the truth table and use ‘Ctrl + C’ or Copy clipboard function from the context
menu.
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• View combination lists satisfying the coverage for each condition
The following figure is a view that can identify a one-pair combination satisfying one condition. The
left section shows the list of combinations that satisfies the coverage for each condition. The right
section shows the truth table for the selected combinations and whether or not it is covered.
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15.7. Stub View
In Controller Tester, if there are no libraries used in the target function when executing a test, if the
libraries are not yet developed, or if the variables not declared are used, it creates automatically the
stubs instead. The stubs are created when running the test and the body is not implemented.

You can add stubs directly in addition to the stubs created in Controller Tester. Multiple stubs can be
created for the same function and the stubs created can be linked to each test.

You can control the behavior of each stub by using user macro within the stub. The value used in the
user-entered macro can be controlled in Edit a test case tab for the test linked.

Function type
Type Description

Function Function without deficition

Function Function with definition

Variable Global variable

Stub type
Type Description

User stub User-defined stub

Build stub Auto-created stub

Old version stub Stub with 2.3 or less version
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Menu
Menu Description

Create Creates stubs.

Delete Deletes stubs.

Import Imports the stub file exported.

Export Exports a stub file.

Save Saves the change stub information.

Enable Enables stubs.

Disable Disables stubs.

Create stubs
• Create stubs in Stub view

1. Click the pull-down menu (▽) in Stub view and click [Create] menu.

2. Check the functions to be created as stubs and select [OK].
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• Create stubs by drag-and-drop in the Test Navigator

• Create stubs by drag-and-drop in the Test Navigator
1. Select the functions to be created as stubs.
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2. Right-click it and select [Create Stub] context menu.

• Create and Link in Test Editor
1. In the test structure of Test Editor, select the stubs or sub nodes.
2. Select [Add New Stub…] button on the right section.

3. Check the functions to be created as stubs and select [OK].

Suresofttech User Manual - 3.4

Page 127 of 267



Delete stubs
• Select and right-click unnecessary stubs and select [Delete] menu.
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Edit stubs
• You can check the macro information by pressing ‘Ctrl + Space’ in the Stub Code screen. After

editing the stub code, press ‘Ctrl + S’ or [Save] button in the toolbar to save it.

• In the stub setting screen, the description can be edited.

Link between stubs and tests
Each stub can be linked to the host/target test.
If you select “Stub” in the test structure editor, you can edit all the stubs included in the host and the
target.
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If you select “Host” or “Target”, you can only edit the stubs in the selected test environment.

• Dragging and dropping into the test editor in Stub view

• Link with [Add Stub…] button in Test Editor.
1. Select stubs from the test structure in Test Editor.
2. Select [Add Stub…] button on the right section.

3. Among the existing stub list, check the stubs to be linked and select [OK].

If linked by drag & drop, it is linked to all the targets and all the hosts.*
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Unlink between stubs and tests
Select the stubs linked in the Test editor and select [Remove Stub] button or select the stubs in the test
structure tree and right-click it to unlink them.

Export stubs
1. Select and the stubs to be exported and right-click and select [Export…] menu.
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2. Specify the saving location of the stub file in the directory dialog and select [OK].

Import stubs
1. Select [Import…] menu from the pull-down menu (▽) in Stub view.

2. Select the stub file to be imported and select the [Open] button.
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Use/Not use stubs
You can set whether to use the created stubs.

1. Select the stubs and right-click and select [Disable] menu.

2. The stub image decorator is added and the color of the stub name changes to gray as shown in
figure below.

The old version stubs or the stubs that are the same as build stubs existed in the project
cannot be imported.

!

Suresofttech User Manual - 3.4

Page 133 of 267



Suresofttech User Manual - 3.4

Page 134 of 267



15.8. Class Factory View
The Class Factory view shows the class list belonging to the project. The auto-created test code creates
an object by using the class creation function located in the Class Factory view. If you modify the object
creation code in the Class Factory view, it is applied to the object creation of all the tests that use that
factory.

If you don’t want to use the class factory, you can select and change the constructor to be used directly
in the test information editor.
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15.9. Control Flow Graph View
The [Control Flow Graph] view shows the control flow information for the function selected in graph
format.
If you click [Show Coverage] button in the main toolbar, the covered section is displayed in blue color
and the uncovered section is displayed in red color.

Toolbar menu
Menu Description

Unfold All Shows all group nodes.

Fold All Hide all group nodes.

Show Legend Shows the legend(the node type in the currently displayed graph).

Copy to System Clipboard Copies the currently displayed graph into clipboard.

Show Outline Displays the graphs in a tree format.

Show Overview Shows the overview of a graph.

Link with Editor Shows the selected items in the graph in the editor by one-click.

Export View Content Exports the contents of view in a report.

Print View Content Prints the contents of view.
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Pull-down menu
Menu Description

Unfold All Shows all group nodes.

Fold All Hides all group nodes.

Show Call Graph Shows the function call graph for the function selected in the current view.

Show Legend Shows the legend(the node type in the currently displayed graph).

Show Outline Displays the graphs in a tree format.

Show Overview Shows the overview of a graph.

Link with Editor Shows the selected items in the graph in the editor by one-click.

Export View Content Exports the contents of view in a report.

Save as Graph Format

Creates the graph model file for the graph displayed on the current screen.
Four kinds of formats supported:

• Graph Modeling Language XML (*.xgml)
• Graph Modeling Language(*.gml)
• yWorks Binary Graph Format(.ygf)
• Trivial Graph Format(*.tgf)

Save as Image Format Saves the currently displayed graph as an image format file(jpg, gif).

Copy to System Clipboard Copies the currently displayed graph into clipboard.

Preferences Opens the preferences.

Node Pop-up menu
Menu Description

Show Call Graph Shows the function call graph for the function selected in the current view.

History function
The node that had been selected in the current graph can be seen again by using the arrow button(Go
back, Go forward) in the lower-left corner of the view.

Zoom out/in function
You can change the zoom out/in ratio by entering a number at the bottom of the view or by adjusting the
slider.

You can reset the zoom out/in ratio by using [Initialize zoom out/in ratio] button at the lower right
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corner of the view, and change the zoom out/in ratio accordingly to the view size by using [Fit to view
size] button.
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15.10. Call Graph View
The [Call Graph] view shows the function call information for the selected function in a report format.
(Ex: When calling function ‘B’ from function ‘A’, it is expressed ‘edge from node ‘A’ to node ‘B’, and it is
represented as one edge even if called multiple times.
If you select the node (function), it shows the function call information for that node.

Toolbar menu
Menu Description

Edit Layout
Changes to make the node position of graph modifiable(it cannot be automatically
edited when the graph is updated).

Copy to System
Clipboard

Copies the currently displayed graph into clipboard.

Show Outline Displays the graphs in a tree format.

Show Overview Shows the overview of a graph.

Link with Editor Shows the selected items in the graph in the editor by one-click.

Export View
Content

Exports the contents of view in a report.

Print View
Content

Prints the contents of view.
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Pull-down menu
Menu Description

Show CFG Shows the control flow graph for the function selected in the current view.

Show Outline Displays the graphs in a tree format.

Show Overview Shows the overview of a graph.

Link with Editor Shows the selected items in the graph in the editor by one-click.

Save as Graph Format

Creates the graph model file for the graph displayed in the current screen.
Four kinds of formats supported:

• Graph Modeling Language XML (*.xgml)
• Graph Modeling Language(*.gml)
• yWorks Binary Graph Format(.ygf)
• Trivial Graph Format(*.tgf)

Save as Image Format Saves the currently displayed graph as an image format file(jpg, gif).

Copy to System Clipboard Copies the currently displayed graph into clipboard.

Preferences Opens the preferences.

Node Pop-up menu
Menu Description

Show CFG Shows the control flow graph for the function node selected.

Expand Shows the call relationship after the selected function one more step.

Collapse Hides the call relationship after the selected function.

Set to Start Node Specifies the start function for checking the call path for two functions.

Set to End Node Specifies the end function for checking the call path for two functions.
Shows all paths possible in the current graph.

Search function
When you enter a search word in the top of the view, the functions with the name containing the entered
search word are highlighted.
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History function
The node that had been selected in the current graph can be seen again by using the arrow button(Go
back, Go forward) in the lower-left corner of the view.

Zoom out/in function
You can change the zoom out/in ratio by entering a number at the bottom of the view or by adjusting the
slider.

You can reset the zoom out/in ratio by using [Initialize zoom out/in ratio] button at the lower right
corner of the view, and change the zoom out/in ratio accordingly to the view size by using [Fit to view
size] button.

Show/Hide function
By using the menu displayed when right-clicking a node, you can show or hide the edge out from that
node. If you select [Hide], it hides the call relationship for all functions called by the function
corresponding to the selected node. The Hide menu of the node having no function call information is
disabled. If you select [Show], it shows the functions called by the function corresponding to the selected
node one more step. Likewise, if there are no call relationships, the Show menu is disabled.

Highlight Path between Nodes function
By selecting the start node and end node, it highlights all paths exited between two nodes so that you
can see easily the interesting section in the complex function call relationship.
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15.11. Error View
You can check the analysis error information of the project in detail.

Log type
Type Description

Build Errors occurred during build

Statement analysis Errors occurred during statement analysis

Link Errors occurred during linking

Pre-processing Errors occurred during pre-processing

Error type
Type Description

Source Errors occurred int the source file

Stub Errors occurred in the stub file

Test Errors occurred in the test editor

Go to the error location
In the context menu, select [Go to error location] to go to the location where the error has occurred so as
to correct the error easily.
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Show error details
Double-click the error information or select [Show error details…] in the context menu to check the detail
information for the error.

Buttons
Button Description

Previous Shows the previous error information.

Next Shows the next error information.

Copy Copies the error information.

Go to Error Points to the location of the error.
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15.12. Debug Information View
The debug information view shows information to help you determine the cause of an error in a test
case.

• Trace function calls in test cases with errors
• Actual value of variable/expression added to inspect debug information

If you select a test case that has [Inspect Debug Info] in the unit test view, debug information is
displayed in the Debug Information view.

• The Stack trace shows the function call trace when the test case in error was executed. The
location where the error occurred is displayed at the top.

• The variable/expression list shows the actual value of the variable/expression added to inspect the
debug information.

Debug Information View toolbar menu
icon description

List of variable/expression to debug

In the list of debug variable/expression, you can check and remove variable/expression.

If the actual value of the added variable/expression is not displayed:
- When [Inspect Debug Info] of the test case is not executed after adding a new variable/
expression
- When the line where the variable/expression was added was not executed when the
test case was executed (it was not executed depending on the condition or an error
occurred before execution)

!
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Adding variable/expression to debug
You can add variable/expression to debug in the following ways.

1. Double-click the line area in the source code editor
2. Select [Add Variable/expression to debug…] from the line area context menu in the source code

editor
3. After specifying a variable or expression in the source code editor, select [Add Variable/expression

to debug…] from the context menu.

When the above operation is performed, the [Add variable/expression to debug] window appears.
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You can double-click on the line area to add or remove variable/expression to debug at that location.

marker description

Variable/expression added before the line

Variable/expression added after the line

You can add markers only in the shaded area.

If you can add a variable/expression to debug both before and after the line in the shaded area, a dialog
will pop up asking where to add it.
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You can add or remove variables/expressions anywhere you can add to the target function through the
[Add All], [Remove All] buttons at the top of the source viewer.
After specifying the variable/expression and type and clicking the [OK] button, you can see that the
marker has been added to the source code editor.

If the test case is selected in [Unit Test View], you can immediately perform [Inspect Debug Info] while
adding a variable/expression to be debug.

If you enter an invalid variable/expression, a compilation error or a runtime error may
occur when performing [Inspect Debug Info].

!
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15.13. Fault Injection View
The [Fault Injection] view provides the feature for inserting the code needed to test additionally into the
specific area of the function to be tested.

1. In [Test Navigator], drag and drop the function that you want to insert a fault into [Insert Code
view].

2. In the tree structure left to the view, click the checkbox for the node that you want to insert a fault
and enter the user code in the right edit window.

3. Click [Run Unit Test] button to run the test that the fault inserted is applied.
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Context menu in the Fault Injection view

Menu name Description

Cut Cuts the code inserted by user.

Copy Copies the code inserted by user.

Paste Pastes the code inserted by user.

Delete Deletes the code inserted by user.

Select Selects the checkbox for the selected node.

Deselect Deselects the checkbox for the selected node.
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15.14. Input/output Data Graph View
The Controller Tester provides the data for input value/expected value/output value in graph format.
The horizontal axis of the graph indicates the number of the test case and the vertical axis indicates the
data of the test case.

Toolbar icon in Input/output Data Graph view

Toolbar icon Description

Refresh Refreshes the input/output data.

Save graph Saves the input/output data.

Click [Save graph] to display the notification window that can enter the path for saving the graph. Enter
the path to save, the file name and the file format and click [OK] to save the graph.

Graph settings
Select [Select input/output item] in the pull-down menu (▽) to display the Graph settings window.
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• For the items selected in the checkbox, the [Input], [Output value] and [Expected value] are
displayed in the Input/output Data Graph. However, if the expected values are specified as ~, &, |
and ! etc., the expected value is not applied to the Input/output Data Graph view.

• [Number of test cases showed in a view] allows you to specify the number of test cases to be
displayed on one screen.
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15.15. Console View
Enter the instruction or batch file in [Pre-command for test run] and [Post-command for test run] of
[Project] -> [Properties] -> [Test] -> [External Command] and execute the unit test to display the
execution result for the external instructions before and after the test execution in the [Console] view.

Toolbar icon in the [Console] view
Toolbar icon Description

Clear Console Clears the console contents.

Scroll Lock Locks the scrolling of the [Console] view screen.

Display Selected Console Shows the selected console.

If [Display Selected Console] is selected, the following two menus are displayed: [Pre-command for test
run] and [Post-command for test run].

If you select [Pre-command for test run], the execution result for the external command before running
the test is displayed in the Console view.

If you select [Post-command for test run], the execution result for the external instructions after the test
execution is displayed in the Console view.
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16. Analysis Perspective
The Analysis Perspective provides a UI for analysis information that can be confirmed from the test
results.

The components that make up the analysis perspective are:

• Metrics View
• Metrics Chart View
• Metrics Top Chart View
• Metrics Bar Chart View
• Metrics Diagnosis Chart View
• Unused Function View
• Source-Header Relation View
• Global Variable Relation View
• Function Call Hierarchy View
• Source Code Editor section

Views that are not included by default can be opened from [Window]> [Show View]> [Other…] on the top
menu.
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16.1. Metrics View
The Metrics view shows the result that measures the metric for the project. It shows the summary
information for the overall metric and the metric information for each items included in the project
(module, file, class, function).

Icons
Icon Description

Module (a logical portion that divides the project for each function)

File (Source file and header file belonging to the project)

Class

Function

Toolbar menu
Menu Description

Show Diagnosis Displays a diagnostic image of the value in the left of the metric value.

Change Mode Changes the view mode ( module, file, class, function).

Export View Content Exports the contents of view as a report.

Print View Content Prints the contents of view.

Pull-down menu
Menu Description

Sort by Sorts based on the selected item (even if clicking the column name in the table, it is
sorted equally).

Columns Changes the order and width of the columns (allows you to change the order by dragging
and dropping the table’s column name).

Configure Opens the diagnostics preferences page (allows you to set the diagnostic step and the
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diagnosis ranges or images for each metric).

Set to Hide/
Show metric Sets whether to hide or show the metrics.

Metric View
Option Sets the number of lines per page in the Metric view.

Filtering

The filtering allows you to view only those items within the desired range for the specific metric.
Select a metric, enter the range value and click [Filtering] button in the right section to see those values
corresponding to the entered information.
If you want to return to the status before filtering, click [Initialize the Filtering Criteria] button on the right
side of [Filtering] button.

Paging

The Paging allows you to view many items conveniently.
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16.2. Metrics Chart View
The Metrics Chart shows the metric view in a line chart. The x-axis is each item, and the y-axis is the
metric value of the item. You can compare the distribution of values between different metrics each other
in the project.

Toolbar menu
Menu Description

Show Log Scale Changes the y-axis of chart to log units.

Show Normalized Metric Shows the standardized metric value.

Change Mode Changes the view mode ( module, file, class, function).

Pull-down menu
Menu Description

Sort by Sorts based on the selected item (even if clicking the column name in the table, it is
sorted equally).

Set to Hide/Show
metric Sets whether to hide or show the metrics.
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Metrics View
Options Sets the connection function with Metric view.

Select Metric
If you select the checkbox left to the metric name in the right table, the checked metrics are displayed in
the chart. If you click the metric name in the checked metric, the items are sorted based on that metric
value.
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16.3. Metrics Top Chart View
The Metrics Top Chart view shows the top items of the metric value in a pie chart. You can see the ratio
of the top items in the total.

Menu Description

Change Mode Changes the view mode ( module, file, class, function).

Pull-down menu
Menu Description

Metrics Hide/Show
Setting Sets whether to hide or show the metrics.

Metrics View Options Sets the number of top items to be displayed and sets whether to show the sum of
the resting items.

The selection of the pie chart and the selected item in the table are connected together.
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16.4. Metrics Bar Chart View
The Metrics Bar Chart view shows the metric values in a bar chart. You can check the value size for
each item in the bar chart.

Icons
Icon Description

Module (a logical portion that divides the project for each function)

File (Source file and header file belonging to the project)

Class

Function

Toolbar menu
Icon Description

Show Normalized Metric Shows the standardized metric value.

Change Mode Changes the view mode ( module, file, class, function).

Pull-down menu
Icon Description
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Metrics Hide/Show Setting Sets whether to hide or show the metrics.

Metric View Options Sets the number of items to be displayed.
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16.5. Metrics Diagnosis Chart View
The Metric Diagnosis Chart view shows the number of items included in the diagnostic range in a pie
chart. You can check the number of items within each diagnostic range in the project.

Toolbar menu
Menu Description

Change Mode Changes the view mode ( module, file, class, function).

Pull-down menu
Menu Description

Configure
Diagnosis

Opens the diagnostics preferences page (allows you to set the diagnostic step and the
ranges or images for each metric).

Metrics Hide/
Show Sets whether to hide or show the metrics.

Metric View
Options Sets whether to display the items having no diagnostic value.

The selection of the pie chart and the selected item in the table are connected together.

Suresofttech User Manual - 3.4

Page 162 of 267



16.6. Unused Function View
The Unused Function view shows the functions included in the selected project by classifying them
according to the specified criteria. It shows the currently unused functions and the criteria for classifying
can be added.

Menu Description

Copy to System clipboard Copy unused function view image to system clipboard.

Save as PNG Save unused function view as image.

Icons
Icon Description

Classification criteria

Function group

Function

Pull-down menu
Menu Description

Function View Options Sets the number of functions to be displayed for each group.
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16.7. Source-Header Relation View
Source-Header Relation view shows <include> and #include relations between the source file and
the header file

Icons
Icon Description

Source file

Header file

System header file

Toolbar menu
Menu Description

Show System Header Shows the system header.

Show Includers Shows the files that includes the selected file.

Show Files Included Shows the file included in the selected file.

Show Includers, Show Files Included
You can display the files that includes the selected file or the files that the selected file is included by
using the menu displayed when right-clicking a file in the view.
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16.8. Global Variable Relation View
The Global Variable Relation view shows the function where the global variable is defined and used. If a
function is selected, it shows the global variables defined or used in the function, and if a global variable
is selected, it shows the functions where the global variable is defined or used.

Menu Description

Copy to System clipboard Copy global variable relation view image to system clipboard.

Save as PNG Save global variable relation view as image.

Icons
Icon Description

Function

Global Variable

Show Relation
You can view the relation for the selected items again by using the menu displayed when right-clicking
the related item in the view.
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16.9. Function Call Hierarchy View
The [Function Call Hierarchy] view shows the information for the function called by the selected function
or the called function in the hierarchy structure.
You can change the call information for the selected function by using the context menu that appears
when selecting and right-clicking the function displayed in the hierarchy structure and double-click it to
open the editor for the source file that the function is defined and to go to the location of the selected
function. (However, not included if it is a system function)
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Menu Description

Show System
Function

Sets whether to indicate the call information for the system function in a
hierarchical structure.

Show Caller
Hierarchy

Shows the functions that call the selected functions in a hierarchical structure.

Show Callee
Hierarchy

Shows the functions called by the selected function in a hierarchical structure.

Copy to System
clipboard

Copy function call hierarchy view image to system clipboard.

Save as PNG Save function call hierarchy layer view as image.
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16.10. Source Code Editor section
The source code editor section is a pre-reserved area, located on the left of the screen.
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17. File Menu
In File menu, Create a new project or module, Editor-related operation, Refresh, Change Workspace,
Import and Export, View Properties of the selected item and Exit Tool etc. can be carried out.

• New:
◦ Create a project
◦ Create a module

• Close/Close all/Save/Save all: Editor-related menu
• Rename: You can modify the name of project or module.
• Switch workspace
• Export
• Import
• Exit: Exit tool.
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17.1. Create a Module
You can create a new module in the project. The information other than the module name is created the
same as the modules already existed in the target project.

1. In [New] menu, click [Other…], select [Module] in [Other] and click [Next].
2. Select the project that you want to create a new module.
3. Enter the module name. The module name existed already cannot be used.
4. Click [Finish] to create the module.

You can also create a module by using the [New] menu displayed when right-clicking a
project in Test Navigator view.*
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17.2. Switch Workspace
You can switch the directory of workspace. When you witch the workspace, the tool restarts with the
switched workspace.

Click [Browse…] to select the workspace directory to be switched or to enter it manually. You can select
the workspace directory selected previously in the list displayed when clicking [▼].
If you select the checkbox [Use this as the default and do not ask again], you are not prompted again to
select a workspace directory the next time you execute the tool.
If you click [Clone], the selected workspace is copied to the other directory.
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17.3. Export

Export a Project
The project can be exported including the project settings and the test.
The exported project can be imported with [Import Project].

1. Click [File] -> [Export] menu.

2. Click [General] -> [Export Project].

The exported project can be imported from CLI environment using projectIE.exe. Please
refer to the projectIE document for details.*
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3. Select the project to be exported and the export path and click [Finish].
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Create a test result report
You can create the test result report in various formats by using Export.

1. Click [File] -> [Export] menu.

2. Click [Test] -> [Create Test Report].

3. Select the project that you want to create the report, and as an option, select Create Report for
each Test, Create Report for uncovered function, and Create Report containing the external
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coverage, and then select the report creation path and the report extension.

a. In [Project], select the project that you want to create a report.
b. In [Option] group, select the desired checkbox among [Generate reports for each test],

[Generate reports for uncovered function], and [Generate reports including external
coverage].

• Generate reports for each test: Generates the report for each test in the selected
project.

• Generate reports for uncovered function: Generates the report for the uncovered
function in the selected project.

• Generate reports including external coverage: Generates the report containing the
external coverage in the selected project.

c. Selecting the checkbox [Use default location] specified “User Account\Export” directory by
default.

d. [File Extension] provides the report file format with html, pdf, docx, pptx and xlsx (※ if you
need to create the report with the extension of doc, ppt and xls, please contact the support
team). The report file extension can be selected in duplicate.

4. Click [Open Folder] button in the message “Report has been created” to check the report in the
folder where it is saved, or click [Confirm] to finish the export.

Export Test
The test information created in the project can be exported at once. Before a project is not analyzed or if
there is no test information (Unit/Integration Test, Stub) created, the export cannot be carried out.

1. Click [File] -> [Export].
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2. Click [Test] -> [Export Test].

3. Select the export path, the unit test items, the integration test items, the stub items, and the
options, and click [Finish].

Suresofttech User Manual - 3.4

Page 176 of 267



a. In [Export path], enter the path to export the test.
b. In [Unit Test] group, check whether to export [Test] and [Test Data] respectively.
c. In [Integration Test] group, check whether to export [Test].

• When exporting the integration test, it is exported with the test data in a set.
d. [Stub] group, select the stub to be exported among [Connected stubs] and [All stubs].

• Connected stubs: The stubs connected with the test to be exported. If the stubs have
no link with the test or the test to be exported is not selected, it does not export that
stubs.

• All Stub: It exports all the stubs created in the project.
e. In [Option] group, choose whether to overwrite the existing test file when they exist, and

whether to export only the tests checked in the Unit/Integration Test view.
4. Click [Open Folder] button in the message “Test has been exported successfully.” to check the test

exported in the folder where it is saved, or click [Confirm] to finish the export.

From 2.6.14 or later version, when exporting tests, [testinfo.export] file is created in the
project directory exported.
(testinfo.export: the file that records the exported information)
*
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Export Coverage
You can export the coverage information measured in the project as a file in the form of Coverage
Shared Data (*.csd) format.

1. Click [File] -> [Export].

2. Select [Coverage] -> [Export Coverage] and click [Next].

3. Select the project that you want to export coverage information and click [Next].
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4. Enter the directory path to export and click [Finish].

5. A file with the same name as the project name is created.
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Metric
It exports the metric result of the project in a report file.

1. Click [Metric] -> [Metric] and then click the [Next] button.

2. Select the project and metric type to export metric information.
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3. Click the [Next] button.
4. Select the path and report format to export the report.
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5. Click the [Finish] button.

Toolchain
You can export the information of the toolchain created.

1. In the main menu, click [File] -> [Export]. The Export wizard is opened.
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2. Click [Preferences] -> [ToolChain] and click [Next].
3. The list of toolchains registered currently is displayed.
4. Check the system header and the toolchain to be imported and enter the export path.

5. Click [Finish].
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17.4. Import
By using Import the existing project to workspace function, you can import the project not existed in the
workspace into the workspace.

Import Test
1. Click [File] -> [Import].

2. Select [Test] -> [Import Test] and click [Next].
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3. Enter the information for the test to be imported and click [Finish].

4. If there are items that the name has been changed or the file has been deleted when importing the
test information, the notification windows is displayed, allowing you to select whether to import the
information except for that items. This notification window is displayed only if the information was
exported from 2.6.14 or later version at a time. If the information is exported from the other menu
and previous version, the notification is not displayed.

5. If the same test exists in the project, select whether to overwrite the test. Select [Yes] to overwrite
and select [No] to cancel the import.
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6. After the import has completed, it is applied to the selected project.

Import information exported from 2.6.14 or earlier

1. Enter the path to import the test in [Import path].

The status icon(?) ‘the test that cannot find the function to be tested in the source file to
be tested’ is displayed, the associated file can be set by using the [Set related file]
context menu.
*
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• If [testinfo.export] file exists in the test path to be imported, select the directory containing
the file.
If you import the information exported separately from 2.6.14 or less version, select the
higher-level directory containing the information exported.

2. In [Unit Test] group, check whether to import [Test] and [Test data] respectively.
3. In [Integration Test] group, check whether to import [Test].

• The test and data must always be in the same directory, and if it is not, the data is not
imported.

4. In [Stub] group, select the stub to be imported among [Connected Stubs] and [All stubs].
• For the stubs created in 2.3 version, or the stubs migrated to 2.6, if the same stubs exist in

the project, the import cannot be carried out.
• For the stubs created in 2.6 version, if the same stubs exist, you can select either not to

import them optionally or to create as a new stub additionally.
• There is no feature to link the stubs to the test in 2.3 version, so you need to link

directly to the test when migrating to version 2.6 or later.
5. In [Option] group, select whether to overwrite the existing test files if they exist and how to handle

them when the same stub exists.

Import Test from Test Code file
1. Click [File] -> [Import].
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2. Select [Test] -> [Import test using test code file] and click [Next].

3. Click [Add…] and select the test to be imported.
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4. Click [Finish] to apply the selected test to the selected project.

Import Coverage
1. Click [File] -> [Import].

The status icon(?) ‘the test that cannot find the function to be tested in the source file to
be tested’ is displayed, the related file can be set by using the [Set related file] context
menu.
*
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2. Select [Coverage] -> [Import Coverage] and click [Next].

3. Enter the path of coverage file to be imported and click [Finish].
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Toolchain
You can import the toolchain information exported by using the Import function.

The imported coverage information can be checked by selecting [Show full coverage
(Include External Coverage)] in the toolbar menu of Coverage view.*
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1. In the main menu, click [File] -> [Import]. The Import wizard is opened.
2. Click [Preferences] -> [ToolChain] and click [Next].
3. If you select the file (*.tch) to be imported, the list of toolchains included in the selected file are

displayed.
4. Select the toolchains to be imported from the toolchain list.
5. If the toolchain to be imported uses the same compiler as the existing toolchain, or if the toolchain

name is duplicated with the name of the existing toolchain, the import status becomes “Need to
modify”. You can change the toolchain name to be imported in the [Select how to resolve] window
displayed when clicking [Next>] button.
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6. Click [Finish].

Import Project
Using the Import Project function, you can import a project exported from another PC.

1. Click [File] -> [Import] in the main menu. The Import Wizard opens.

2. Click [General] -> [Import Project] and then click the [Next] button.
3. Click the [Browse] button to locate the exported project directory. When you select a directory, the

toolchain associated with the project to import is automatically selected. If you don’t have a
suitable toolchain, you need to import the toolchain using the toolchain export/import feature
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before importing the project.

4. Click the [Next] button.
5. You can check the path information included in the project to be imported. Invalid paths are

marked in red and can be modified by clicking with the mouse or pressing the F2 key.

6. If you edit one path, all paths that can be found in the relative path are automatically corrected.
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The number of modified paths is displayed at the top of the wizard.

7. Click the [Finish] button.

File System
You can add the source files to the project by using Import File System function.

1. In the main menu, click [File] -> [Import]. The Import wizard is opened.

If path is not in window absolute path format, the path is not checked for validity.*
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2. Click [General] -> [File System] and click [Next].
3. Select the top-level directory path containing the source file to be added by clicking [Browse…]

button.
4. Select the source file to be added.
5. Select the target project that the selected source file will be added to by clicking [Browse…]

button.

6. Click [Next].
7. Select the module that the source file will be added from the list of modules included in the project.
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8. Click [Finish].

You can also add the source file by, from Windows Explorer, dragging and dropping the
source file into the target project or module in Test Navigator view.*

Suresofttech User Manual - 3.4

Page 197 of 267



18. Search Menu

Search Analysis Result
You can search the result created after analysis.

Search word

Enter characters to be searched.
The available wildcards are displayed in the Search dialog box.

• “*” Wildcard string: matches the set of characters containing the empty string.
• “?” Wildcard character: matches all characters.

Search target

Select the target to be searched. The global variable, function or all targets can be searched.

Search range

Select the searching range. It can be searched within the workspace or the selected item range.

File search
A file can be searched.
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Text included

Enter a character to be searched. To search a file, the field must be empty.
Click [▼] to select the characters searched recently.
The available wildcards are displayed in the Search dialog box.

• “*” Wildcard string: matches the set of characters containing the blank string.
• “?” Wildcard character: matches all characters.
• To search “*”, “?” or “\” character, enter a backslash before the characters in order to indicate that

you do not use these characters by “\ *” wildcards. (Ex: “\?” or “\ \”)

File Name Pattern

Enter the pattern of all file names for the files to be searched by using the specific expression.
The wildcards that can use the file name pattern are displayed in the Search dialog box.

• “*” Wildcard string: matches the set of characters containing the blank string.
• “?” Wildcard character: matches all characters.
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19. Edit Menu
In the Edit menu, you can carry out the functions such as Cut, Copy, Paste, Delete and Find/Replace the
items selected in the view or editor, or undo or redo the last action performed.

The menu may vary depending on the selected view or editor.
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20. Project Menu
In the Project menu, you can execute the operations for the project (open, close, initialize).

Open Project
You can open a closed project selected in the Test Navigator view.

Close Project
You can close an open project selected in the Test Navigator view.

Initialize Project
You can initialize all the open projects in the workspace or the selected projects in the project list below.
If you initialize the project, all analysis results are cleared.

Generate Command Line Interface INI File
Based on the project information selected in the Test Navigator, you can create the configuration file
needed to execute the Controller Tester in CLI environment.

Collect Project Log
You can export the log file of the project selected in the Test Navigator view into the specified path.
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Properties
You can see the information or change the settings for the project selected in the Test Navigator view.
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21. Window Menu
In the Window menu, you can open the same new editor as an active editor, open a perspective or a
new view, and see the preferences.

New Editor
It copies the selected source code editor or test editor.

Open Perspective
You can select and open the perspective registered in Controller Tester.

Show View
You can select and open the view registered in Controller Tester.

Save Perspective As
Saves the perspective reconfigured by the user as the other name.

Reset Perspective
Resets the perspective into the initial state.

Close Perspective
Closes the perspective currently open.

Preferences
You can check or change the settings currently applied to the tool.
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For more information, please refer to Preferences
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22. Help Menu
In the Help menu, you can set the license, and modify or revert the parser config and check the product
information.

Welcome
You can see the welcome page that appears when the tool is executed for the first time.

Modify Parser Config
You can modify the parser config by entering the compressed file provided by SureSoft Technologies,
Inc.

How to use

1. Select [Help] -> [Parser Config] -> [Modification…] menu.
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2. Click [Open…] to select the compressed analysis setting file and enter the changes of analysis
settings to [Comment] text as an option.

3. Click [OK].

Format of the parser config file

• The directory [parserConfig] must exist immediately when opening the compressed file as shown
in the figure below.

• The extension is “zip”.

Revert the Parser Config
You can revert the parser config by selecting one among the previous parser configs.

How to use

1. Select [Help] -> [Parser Config] -> [Revert] menu.
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2. Check the parser config to be reverted in the list of the existing parser configs and select [OK].

Information
You can see the information and version of the product installed.

Click [Installation Details] to see the features installed and plug-in.
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23. Troubleshooting

If it conflicts with the security program at installation
Some security programs may stop running the tool installation package. If an error occurred, temporarily
stop the security program operation and proceed with the installation again.

If the product does not operate after specifying the
workspace when executing it
When executing the product for the first time, the global data of CodeScroll is stored in \APPDATA\ path.
If access to this path is restricted, the product may not be operated.
To solve this problem, please use the feature to set the global data path.
Setting method: Enter the global data path to be set instead of –g default (default value) in CodeScroll.ini
file. (the same if a case of -g or –global and csc.ini file)
If the -g option is not given, the dialog for setting any global data path when executing the product for the
first time is displayed. If canceled here, it is set to the default path.

If it is installed and run in Windows Vista/7
It can only be run with the User Access Control (UAC) features disabled.
If you want to use it without disabling UAC, change the directory during installation so that it is not
installed under the Program Files.
In addition, the Windows accounts for installation and execution must be the same and must be installed
with an administrator account.

If an analysis is failed or Compile (pre-processing) error
occurred
It is the state of source code that the test cannot be run. Please check the compile/link flag and header
file/library settings.
You can check the settings in [Preferences] -> [Toolchain settings].
If all settings are correct (if it is possible to build without any problems in the actual development
environment (IDE etc.)), please contact SureSoft Technologies, Inc.

If it fails to run all test cases
This is because the test engine operation is blocked by the firewall. The test engine loaded in memory
when executing the test must be added as an exception to the firewall setting to run normally.
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If it fails to register toolchain automatically
If it fails to register toolchain automatically due to some problem with toolchain information installed on
PC, the toolchain auto-registration feature can be turned off. (--disableAutoToolchain option)

• Add --disableAutoToolchain option to CodeScroll.ini file

Upload data to VPES

When you select and right-click a project, [Upload data to VPES…] is indicated in the menu. For this
feature, please contact Technical support.

Collect Project Log
This feature collects the logs left in use of Controller Tester on a project basis in batch and exports them.
When you contact Technical support due to an error occurred, please send us the collected compressed
file so that we can solve the problem more quickly.
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When you select and right-click a project, [Collect project log] item is indicated.

Technical support
If you find any problems, please contact the Technical support contact below.

• support@suresofttech.com
• +82-2-6472-2800
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24. CONTROLLER TESTER Target Plug-in

Introduction
Controller Tester Target Plug-in complements the functionality of the default Controller Tester.
Controller Tester allows you to automate testing in your own host environment. In other words, you run
the test in a software development environment (normal PC). Controller Tester Target Plug-in allows you
to run tests of Controller Tester in a real embedded target environment. This makes it easy to check
whether the test results are the same in the host and target environment and to run tests that cannot be
executed in the host environment because of factors dependent on the target environment.
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24.1. Target Environment Settings
To run tests in a target environment using Controller Tester Target Plug-in, you need to enter information
about the target environment.
Controller Tester Target Plug-in builds a test harness using information about the target environment
entered by the user and automatically gets the results of running in the target environment.

The target environment can be set in the project properties page or in the new target test project wizard.

Target environment settings
Target environment settings are divided into basic information and detailed settings.

After entering the basic information, detailed settings that require input are displayed.

Target environment detailed settings
Target environment detailed settings are divided into the analysis, build, run, and etc.

Category Description

Analysis The toolchain information is displayed, and in the case of a target test project, the target
compiler related settings required for analysis are displayed.

Build The settings for building the test software are displayed.

Run Settings for running tests and getting results in the target environment are displayed.

etc. Other settings are displayed. (Program entry point, etc.)

Required settings for each category are indicated in red. Depending on whether the required settings for
each category are entered or not, the behavior when clicking the [Run] button is different as shown
below.
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Required settings
completed category Description

None Test run impossible

Analysis If you click [Run], it overwrites the original source code with the test code. To
perform the test, the user must manually build and run the test.

Analysis, Build If you click [Run], it builds the test code. To perform the test, the user has to
manually run the test on the target.

Analysis, Build, Run Automatically run tests in the target environment.

Import target test results
Controller Tester Target Plug-in saves and imports the result of running the test in the target
environment in log format.
If you do not use the debugger, you need the settings for saving the target test results(Log interface) and
the settings for importing(Target Log Collector – Preferences).

Log interface

Log interface is a setting for saving the test results in the target environment. Log interface is written in
the form of a source code that is actually run in the target environment.

Log interface structure

Function Description

viod cs_io_initialize() Initial function for transfer

void_cs_io_finalize() Transfer end function

void cs_io_flush() Remaining data transfer function

void cs_io_putbyte(codescroll_byte v) 1-byte data transfer function
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Import target log automatically
The target log, which is the result of the test execution, can be automatically imported through the target
log collector. For the target log collector settings, please refer to [Target Log Collector] in Target Log
Collector and Target Test Preferences.

Import target log manually
If the target log cannot be imported automatically, you can import the target log manually.

Import from a log file

1. After selecting an analyzed project, click [Target] -> [import Target Test Log] -> [Import from Log
File…] in the global menu.

2. Select a target test log file and click the [OK] button.

Import from a target log archive

1. After selecting an analyzed project, click [Target] -> [import Target Test Log] -> [Import from
Target Log Archive…] in the global menu.

2. Select a target log archive file and click the [Next] button.
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3. Check a target test log file and click the [Finish] button.

Import from target log collector

1. To get logs from the target log collector, you need to select ‘Use the default target log collector’
from [Preferences] -> [Target Test] -> [Target Log Collector].

2. After selecting an analyzed project, click [Target] -> [import Target Test Log] -> [Import from
Target Log Collector…] in the global menu.

3. Click the [Yes] button to import all the new target test logs or click the [Show details] button.

4. If you click the [Show details] button, check the target test log to be imported and click the [OK]
button.
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Result

After the import is completed, you can check the target coverage information in the coverage view.

[Import Target Test Log] may fail because the target test run information and the host
test information are not valid if the host test case, source file, function information, etc.
are changed before importing the log of the target test result.
*
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24.2. C/C++ Target Test Project
The C / C ++ target test project (hereinafter referred to as the target test project) is a project for target
environment testing. Target testing projects do not support host testing.

Create a target test project

C/C++ Target Test Project with Source Files

1. Create a project by selecting [File]-> [New]-> [Other …] in the global menu and clicking [C / C ++
Target Test Project with Source Files].

2. Enter a project name and select a toolchain to use.

3. After selecting the basic information of the target environment, enter the detailed settings for each
category and click the [Next] button.
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4. Select the source files under test and click the [Finish] button.

C/C++ Target Test Project from Embedded(CodeWarrior, Green Hills, NEC)

1. Create a project by selecting [File]-> [New]-> [Other …] in the global menu and clicking [C/C++
Target Test Project from Embedded(CodeWarrior, Green Hills, NEC)].
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2. Enter a project name and select a toolchain to use. After selecting the toolchain, import the
embedded project file to test. Currently, embedded projects supported by Controller Tester are
CodeWarrior, Green Hills, and NEC.

3. After selecting the basic information of the target environment, enter the detailed settings for each
category.
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Create a C/C++ Target Test Project with Build Information

1. Create a project by selecting [File]-> [New]-> [Other …] in the global menu and clicking [Create a
C/C++ Target Test Project with Build Information].

2. Enter a project name and select a toolchain to use. After selecting the toolchain, Specify the path
of the created Makefile and build script as the build directory and write the build command. You
can choose a script file to set the build-environment from the [Advanced] menu.
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3. After selecting the basic information of the target environment, enter the detailed settings for each
category.

Toolchains with invalid compiler paths cannot be selected when creating a target test
project.

!
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24.3. Target Test Run Settings
You can check the target test execution settings on the target test page in [Project]-> [Properties].

Coverage kind
You can select the type of coverage(Statement, Branch, MC/DC) to be measured for the target test.

Target for coverage measurement
In addition to the functions under test, you can select functions to measure coverage.

All functions called by the target
function

Measures coverages for all functions called by the function
under test.

The functions called by the previous
test run

Includes functions whose coverage was measured from the
previous test.

Testcase run
You can choose how to run the test case.

Run at once Loads and runs all test cases on target at once.
Each test case is affected by the previous test case run results.

Run one by one Repeats loading and running each test case on target.
It takes longer than running at once but uses less memory.
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24.4. Target Log Collector
The target log collector is a server that collects target test results and sends them to Controller Tester.
Collecting target test results methods are largely divided into communication and file scanning.
Supported communication protocols and scannable file formats are as follows.

Protocol TCP, UDP, UART

File format Target log(text), memory dump(Hex, Intel HEX)

Installation
The target log collector is automatically installed when Controller Tester is installed.

Run
When [Use the default target log collector] is checked in [Preferences] -> [Target Test] -> [Target Log
Collector], the target log collector starts collecting target test results.
If you use TargetLogCollector.zip after extracting it, run TargetLogCollector.exe in the unzipped directory
at the Windows command prompt.

Settings
It can be set through the ‘settings.ini’ file in the target log collector installation path, and the options are
as follows.

[LogReceiveServer] Settings for receiving target test results

port TCP, UDP communication port

protocol Communication protocol for receiving target test results

timeout Connection timeout

lastString String representing the end of the data

serialPort Serial communication port
(Windows: COM#, Linux: /dev/ttyS#)
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baudRate Serial communication settings

dataBits Serial communication settings

stopBits Serial communication settings

parity Serial communication settings

flowControl Serial communication settings

[ScanLog] Settings for file scanning

dir Directory to scan

fileExtension File extensions to scan(Scan all files if blank)

[LogSendServer] Settings for communication with Controller Tester

port Target log file transfer port

timeout: If there is no data transmission for the specified number of seconds from the
last reception, the received data is saved.
dir: When a target log file (text, hex) is entered in the specified directory, the target log
collector recognizes it.

*
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24.5. Preferences

Target Test
You can set whether to open the target test step notification dialog when the target test is run.

Target Log Collector
Set target log collector information to use and whether to automatically detect target test results. If you
turn on automatic target log detection by clicking the [Atuto-detect on] button, a new target test result is
received from the target log collector at a specified automatic detection cycle.

Target Log Collector Setting Description

Auto-detect cycle(sec) Cycle to check for new target test results

IP IP on the server or PC where the target log collector runs

Port Target log collector’s communication port
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When using the default target log collector, set only the auto-detection interval(sec).!
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25. CONTROLLER TESTER RTV(Remote
Target Verifier)

Introduction
Controller Tester RTV helps you perform automated testing in your Linux environment.
After installing the Controller Tester RTV server in your Linux environment and completing the default
configuration, you can use the Controller Tester RTV client to perform the RTV test as easily as you
would in a hosted environment.
For information on how to install the Controller Tester RTV server in your Linux environment, please
contact the Technical support contact on bottom of the Troubleshooting page of this document.

Supported Operating Systems
Server: Linux (RHEL, Ubuntu, Debian, Fedora based)
Client: Windows 7/10
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25.1. RTV Server Settings
In order to use Controller Tester RTV, you need to add a RTV server with Controller Tester RTV server
installed.
The RTV server can be added in [Window] -> [Preferences] -> [RTV Server].

Add a RTV server
1. Click [Add] in [Window] -> [Preferences] -> [RTV Server].

2. In the [Add RTV Server] window, enter the RTV server information.

The server name only accepts characters that can be used as Windows file names and!
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3. Click the [Connection Test] button to check the connection status with the RTV server you entered.

4. If the connection test with the RTV server is successful, click the [OK] button to add the RTV
server.

5. You can see that the RTV server has been added.

Edit a RTV server
1. Double-click the server in the RTV server list, or select the server and click the [Edit] button.

can not be modified after adding the RTV server.
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2. On the [Edit RTV server] window, edit the server information and then click [OK].

3. You can see that the RTV server information has been edited.

Remove a RTV server
If you no longer use the RTV server, you can remove it.
When you remove a RTV server, the toolchain or project resources associated with the RTV server are
deleted from the client environment(Can not be deleted if a RTV toolchain added from that RTV server
exists).
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1. Select a server from the list of RTV servers and click the [Remove] button.

2. Click the [OK] button in the [Remove RTV Server] window(Depending on the size of the RTV
server resource, it may take a minute or two).

3. You can see that the RTV server has been removed.
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25.2. RTV Toolchain Settings

RTV toolchain
To build and run a test in a RTV environment with Controller Tester RTV, you need to set the toolchain
(compiler) information for the source file being tested.
This chapter describes how to add, edit, and delete the RTV toolchain information that has previously
extracted from the RTV environment where the Controller Tester RTV Server is installed.
(For extracting toolchain information from your RTV environment, please contact the Technical support
contact at the bottom of this document Troubleshooting page.)

Add an RTV toolchain
1. Click the [Add RTV Toolchain] button in the [Window] -> [Preferences] -> [Toolchain] window.

2. If you select the RTV server in the [Add RTV Toolchain] window, you can see the list of RTV
toolchain extracted from the RTV server. Select the toolchain you want to add and click the [OK]
button.

3. The toolchain information is imported from the RTV server (Depending on the size of the system
header, it may take 1 to 2 minutes). When the operation is completed, you can see that the RTV

If you do not have a RTV server, the [Add RTV Server] window will appear first.*
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toolchain has been added.

4. If you select the RTV toolchain added, you can see that the information of the RTV server is
displayed on the [Detail].

Edit an RTV toolchain
1. Select the toolchain to be edited and click the [Edit] button.

2. Edit the RTV toolchain information.
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3. Click the [Finish] button.

Duplicate an RTV toolchain
The duplication for an RTV toolchain is not provided.

Remove an RTV toolchain
Select the toolchain to delete and click the [Remove] button.

Import/Export an RTV toolchain
The RTV toolchain can not be imported/exported because it can be added through the RTV server.

If you have a project associated with the toolchain you want to delete, you can not use
the project normally after deleting the toolchain.

!
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25.3. Create a RTV Project
Create an RTV project to test the source files that exist in the RTV environment.

When building source files in the RTV environment, you can extract the information needed to create the
RTV project.
This chapter describes how to create an RTV project by using pre-extracted source file build
information(using the Controller Tester RTV Server Utility) in the RTV environment, or extracting
information at the same time as building the source file.

To create an RTV project, run the [Create Project Wizard].
Click [File] -> [New] or Shortcut.

C/C++ Project from RTV Build
It is selected when creating an RTV project using pre-extracted source file build information (using the
Controller Tester RTV Server Utility) in the RTV environment.

1. Enter the project name in [Project name].

2. A list of RTV toolchains appears in the [Select Toolchain]. Select the RTV toolchain to use.
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3. After selecting the toolchain, then click the [Next] button. You can see the list of source file builds
pre-extracted from the RTV server.

4. In the [Build Project List], select the item for which you want to create the RTV project and click
the [Next] button.

5. After selecting source files to be tested, click the [Finish] button to create the project.

C/C++ Project from RTV Build Command
It is selected when creating an RTV project by extracting information at the same time as building the
source file. The user builds the source file on the RTV server using the build command and then creates

Among the generated projects, ‘All_Sources_Project Name’ is a project that combines all
the source files of the modules captured by csbuild. Since this project is a combined
project without considering whether it is built or not, it may not be able to perform the
test normally.

*
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the RTV project.

1. Enter the project name in [Project name].

2. A list of RTV toolchains appears in the toolchain list. Select the RTV toolchain to use.
3. After selecting the toolchain, click the [Next] button. The build will be performed on the RTV server

from which the selected toolchain was imported.

4. Enter the path to build from the RTV server (for example, the directory where the make file is
located), and enter the build command.

5. In [Build Log], specify the path to the build results file.
The default location is the .metadata directory of the workspace. If you uncheck [Use default
location], you can change the path.

6. After entering the required information for the build, click the [Next] button. It builds the source file
on the RTV server with the entered build command (depending on the build target, it can take a lot
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of time).
7. When the build is complete, a list of built projects appears.

8. In the [Build Project List], select the item for which you want to create the RTV project and click
the [Next] button.

9. When creating the RTV project, select the source file to be included and click the [Finish] button to
create the project.

RTV build command
To create a project from build information, you must use the csbuild command on the build command.

Among the generated projects, ‘All_Sources_Project Name’ is a project that combines all
the source files of the modules captured by csbuild. Since this project is a combined
project without considering whether it is built or not, it may not be able to perform the
test normally.

*
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csbuild command

The cs is a utility that automatically extracts the Controller Tester project configuration information of the
source files that are built so that the Controller Tester RTV project can be created.

How to use csbuild

Prefix the existing build command with csbuild.

• Ex) make → csbuild capture make

csbuild option

new: Generate the necessary information before extracting build commands. Specify the toolchain with
the --toolchain option and the project name with the --project option.

• Ex) csbuid new --toolchain=gcc5.4 --project=PRJ

capture: Creates an RTV project by performing build command extraction.

• Ex) csbuild capture make

convert: Convert a STATIC project to an RTV project.

• Ex) csbuild convert

The --toolchain option is required.!
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25.4. Refresh/Add RTV Source Files

Refresh RTV source file
If the source file is modified and rebuilt on the RTV server, the [Refresh RTV Source File] allows the
revised content to be reflected in the project.

1. In the [Test Navigator] view, click the [Refresh RTV Source File] context menu.

2. When you create an RTV project, you can see the latest build information for the source files you
selected (display a change notification if the build has changed). Click the [Finish] button to
confirm your changes.

If the source file is modified but not rebuilt, the changed contents will not be reflected.
If you modify the source files on the RTV server and then rebuild, you must perform a full
build.

!
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3. After confirming the changes, click the [OK] button.

Add RTV source file
You can add source files to your RTV projects via the [Add RTV Source File] if new source files are
added and built on the RTV server, or if only some source files are selected when you create the RTV
project.

1. In the [Test Navigator] view, click the [Add RTV Source File] context menu.

If the source file is added but not rebuilt, the changed contents will not be reflected.
If you build the target server after adding the source file, you must perform a full build.

!
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2. When you create the RTV project, you can see the latest build information for the selected source
file (show change notification if the build has changed). Click the [Next] button to confirm the new
file list.

3. In the [New file], select the file you want to add and click the [Finish] button.
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4. After confirming the changes, click the [OK] button.

Suresofttech User Manual - 3.4

Page 243 of 267



25.5. RTV Project Information

Test navigator
1. The icon for the RTV project is displayed as .
2. The RTV server’s information ([server name: IP]) is displayed after the name of the RTV project.

3. Source files in the RTV project can not be modified(the source file editor of the RTV project is
read-only).

Project property

Info

1. The RTV project displays the RTV server and project information.

2. If the general project has set the toolchain as the RTV toolchain, information about the RTV server
from which the RTV toolchain was imported is displayed.
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Module/File property

Build

1. The RTV project can not change the RTV toolchain that was set when the project was created.
2. However, if the RTV toolchain you set originally is deleted, you can change it to another toolchain.
3. In general projects, you can change the toolchain to the RTV toolchain. Changing to the RTV

toolchain changes all toolchain settings (modules and source files) under the project and allows
you to run the RTV tests.

4. The project with the RTV toolchain can not change the compiler settings of the source file (the
module’s linker configuration can be changed).
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25.6. Run RTV Test
The RTV project allows you to run RTV tests without any additional setup. To test a general project in
the RTV environment, you must set the toolchain of the project to the RTV toolchain created from the
RTV server to be tested.

Run all RTV tests
It runs the selected tests in the [Unit Test] view and the [Integration Test] view.

RTV tests can be run in the following way.

1. Select the project to be tested, right-click it and click [Run RTV Test].

Run RTV unit test
Runs the selected test in the [Unit Test] view.

Run RTV test

[Run] button In the [Unit Test] view.

Run RTV test case

[Run RTV Test Case] context menu (multi-selectable) in the [Unit Test] view.
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Run RTV integration test
Runs the selected test in the [Integration Test] view.

[Run] button In the [Integration Test] view.
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25.7. RTV Test Results

Coverage
You can change the coverage information (host, target, host/target merged) displayed in each view and
editor through the coverage view menu in the top toolbar menu.
You can check the detailed information of each view in Test Perspective.

Test results
You can change the test results through the host/target settings menu on the dashboard.

Stub
The RTV build stubs that are created when running the RTV test is distinct from the build stubs which
are created when running the host test.

Type Description

Target build stub Auto-created stub during RTV tests
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26. CONTROLLER TESTER RTV(Remote
Target Verifier) Target Plug-in
Using Controller Tester RTV (Remot Target Verifier) Target Plug-in, software developed in Linux
environment can be tested in a real embedded target environment. You can run RTV target after
installing Controller Tester RTV server in Linux and setting target environment in Controller Tester. For
information on how to install the Controller Tester RTV server in your Linux environment, please contact
the Technical support contact on bottom of the Troubleshooting page of this document.

The followings are how to create Controller Tester RTV Target Plug-in project and run a test.

• RTV Server Settings
• RTV Toolchain Settings
• RTV Target Environment Settings
• Create a RTV Target Project
• Refresh/Add RTV Target Source Files
• RTV Target Project Information
• Run RTV Target Test

Supported Operating Systems
Server: Linux (RHEL, Ubuntu, Debian, Fedora based)
Client: Windows 7/10

Suresofttech User Manual - 3.4

Page 249 of 267



26.1. RTV Server Settings
For RTV server setting to use Controller Tester RTV Target Plug-in, refer to RTV Server Settings.
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26.2. RTV Toolchain Settings
For RTV toolchain setting to use Controller Tester RTV Target Plug-in, refer to RTV Toolchain Settings.
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26.3. RTV Target Environment Settings
To run tests in a target environment using Controller Tester RTV Target Plug-in, you need to enter
information about the target environment as with Controller Tester Target Plug-in. Using information
about the target environment entered by the user, Controller Tester builds a test harness in RTV server
and run in the target environment. Target log collector can get the test results automatically.
The target environment can be set in the project properties page or in the new RTV target test project
wizard.

Target environment settings.
Target environment settings are divided into basic information and detailed settings.
RTV target project don’t need to enter the basic information.

After entering the basic information, detailed settings that require input are displayed.

Target environment detailed settings
Target environment detailed settings are divided into the analysis, build, run, and etc.

Category Description

Analysis The toolchain information is displayed, and in the case of a target test project, the target
compiler related settings required for analysis are displayed.

Build The settings for building the test software are displayed.

Run Settings for running tests and getting results in the target environment are displayed.

etc. Other settings are displayed. (Program entry point, etc.)

Required settings for each category are indicated in red. Depending on whether the required settings for
each category are entered or not, the behavior when clicking the [Run] button is different as shown
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below.

Required settings
completed category Description

None Test run impossible

Analysis If you click [Run], it overwrites the original source code with the test code. To
perform the test, the user must manually build and run the test.

Analysis, Build If you click [Run], it builds the test code. To perform the test, the user has to
manually run the test on the target.

Analysis, Build, Run Automatically run tests in the target environment.

Target environment detailed settings – Build

Enter a build script path of RTV server into build script area. After entering the build script path,
Controller Tester checks validity of the path. If the path is invalid, build script area is displayed in red and
if vaild, it is displayed in black.

Target environment detailed settings – Run

Run setting is divided into batch script area and log interface area. Controller Tester checks validity of
batch script area as with build script area. Informations to get results of RTV target test from target
environment is entered in log interface area.

Batch script area

Enter a batch script path of RTV server into batch script area as with build script area.

Log interface area

The log interface area is a setting to record test result from target environment. The followings are how
to get target log into Target Log Collector.

• File
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• Socket communication (TCP, UDP)
• Serial communication (UART)

To allow target log collector to get test results during recoding the results in file, you modify a path in log
interface into %SMITH_HOME%/targetLogCollector/scan/log/%file_name%.
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26.4. Create a RTV Target Project
Create an RTV project to test the source files that exist in the RTV environment.

When building source files in the RTV environment, you can extract the information needed to create the
RTV project.
This chapter describes how to create an RTV target project by using pre-extracted source file build
information(using the Controller Tester RTV Server Utility) in the RTV environment, or extracting
information at the same time as building the source file.

To create an RTV project, run the [Create Project Wizard].
Click [File] -> [New] or Shortcut.

C/C++ Target Test Project from RTV Build
It is selected when creating an RTV target project using pre-extracted source file build information (using
the Controller Tester RTV Server Utility) in the RTV environment.

1. Enter the project name in [Project name] and select the RTV toolchain to use in the [Select
Toolchain]. After selecting the toolchain, then click the [Next] button.
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2. You can see the list of source file builds pre-extracted from the RTV server(※ Among the
generated projects, ‘All_Sources_Project Name’ is a project that combines all the source files of
the modules captured by csbuild. Since this project is a combined project without considering
whether it is built or not, it may not be able to perform the test normally). In the [Build Project List],
select the item for which you want to create the RTV project and click the [Next] button.

3. After selecting source files to be tested, click the [Next] button.
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4. After entering the detailed settings for each category and click the [Next] button

C/C++ Target Test Project from RTV Build Command
It is selected when creating an RTV target project by extracting information at the same time as building
the source file. The user builds the source file on the RTV server using the build command and then
creates the RTV target project.

1. Enter the project name in [Project name] and select the RTV toolchain to use in the [Select
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Toolchain]. After selecting the toolchain, then click the [Next] button.

2. Enter the path to build from the target server (for example, the directory where the make file is
located), and enter the build command. In [Build Log], specify the path to the build results file.
After entering the required information for the build, click the [Next] button. It builds the source file
on the target server with the entered build command (depending on the build target, it can take a
lot of time).

3. When the build is complete, a list of built projects appears(※ Among the generated projects,
‘All_Sources_Project Name’ is a project that combines all the source files of the modules captured
by csbuild. Since this project is a combined project without considering whether it is built or not, it
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may not be able to perform the test normally). In the [Build Project List], select the item for which
you want to create the RTV target project and click the [Next] button.

4. After selecting source files to be tested, click the [Next] button.

5. After entering the detailed settings for each category and click the [Next] button
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RTV build command
To create a project from build information, you must use the csbuild command on the build command.
For RTV build command, refer to [RTV build command] in Create a RTV Project
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26.5. Refresh/Add RTV Target Source Files
If the source file is modified or added on the RTV server, the [Refresh RTV Source File] and [Add RTV
Source File] allow the revised content to be reflected in the project. For Refresh/Add RTV Target Source
Files, refer to Refresh/Add RTV Source Files.
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26.6. RTV Target Project Information

Test navigator
• The icon for the RTV project is displayed as .
• The RTV server’s information ([server name: IP]) is displayed after the name of the RTV target

project.

• Source files in the RTV project can not be modified(the source file editor of the RTV project is
read-only).

Project properties

Info

The RTV target project displays the RTV server and project information.

Target test

The RTV target project can set about target test run and RTV environment. For target test run settings,
refer to Target Test Run Settings and for RTV environment settings, refer to Target Environment
Settings.
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Module/file properties
For properties about module or file, refer to RTV Project Information.
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26.7. Run RTV Target Test

Test run
The binary file built in Linux environment can be tested in target environment using RTV Target Plug-in.
For running the RTV target test, refer to Run RTV Test.

Suresofttech User Manual - 3.4

Page 264 of 267



27. EULA(End-User License Agreement)

Software End User License Agreement
Important: This End User License Agreement (“EULA”) is a legal agreement between the user
(individual or organization) and Suresoft Technologies, Inc. (“SureSoft Tech”) which is the manufacturer
the software products (“Software product” or “Software”) identified by the product identification card or
recognition label attached to this EULA. The software product includes computer software, related
media, related documents, and “online” or electronic manual. When installing, copying, downloading,
backing up, accessing or using the software product, the user must accept the terms of use in the EULA;
if the user does not accept the terms of use in EULA, the user may not be licensed for the software
product. Unless the user is licensed to use the software product, the user cannot install, copy, download,
backup, access or use this software product.

Software Product License

The Software product is protected by intellectual property rights as well as copyrights, program
copyrights, and international copyright regulations. The term “computer” used in this agreement means a
single computer system, the range of which is described below.

1. License Grant

The EULA grants the user the following rights.

Software Installation and Use. Except for those clearly explained in the EULA, only one copy of
software product can be installed, used, accessed, executed or interacted (“execution”) on the computer.
To install, use or execute the software product on two or more computers, the user must obtain the legal
license(s) that corresponds to the number of computers regardless of the interaction of software used or
executed on each computer.
Backup Copy. When there is no software product backup copy on the computer, the user can create a
single backup copy that corresponds to the computer software part of the software product. The backup
copy can be used for the purpose of recording. To create a single backup copy, a backup utility can be
used. Except for those clearly stated in this EULA, the user may not make copies of the software product
including documents provided with the software product.

2. Other Rights and Limits

Computer or Single Computer System. The Software product’s license is applied only to a single
computer system. If the single computer system has multiple CPUs, it is considered as a single
computer system only when these CPUs are installed to one circuit board and the structure is the
symmetric central processing structure that shares one system bus.

Choose language versions. When the software product is included in one or more language versions, it
is allowed to use only one language version.
Reverse engineering limitations. De-compilation and decomposition. The user cannot decompile or
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decompose software the product using reverse-engineering.
Component separation. The software product is allowed as a single product. Users cannot separate
the components to use in one or more computers.
Lease. The Software product cannot be leased or lent.
Right Transfer of software product. The user may permanently transfer all rights as part of the sale of
hardware or right transfer according to this EULA, it is regarded that the recipient has accepted the
terms of use in this EULA.
Expiration. When the user violates the terms and conditions in the EULA, without infringing other rights,
Suresoft Technologies can make user’s rights expire according to the terms and conditions in this EULA.
In such a case, the user must discard all the duplicates and composing parts, including software product
that has been already installed.
Registered Trademark. The EULA doesn’t grant any rights related to the registered trademark and
service trademark of the software manufacturer, the computer manufacturer, and other related suppliers.
Upgrade. If the software product is upgraded via Suresoft Technologies, the terms of use in the EULA
are still valid for the upgraded software and it cannot be separated to use in one or more computers.

3. Copyright

Every right and intellectual propriety right (including all the image, figure, animation, video, audio, music,
text, and applet of the software product) of the software product, the enclosed manual, and every copy of
the software product are the property of software manufacturer or supplier. All rights and intellectual
property rights for the contents that are not built-in the software product but are accessible through the
use of the software product are the property of the Company, and this EULA does not grant any rights
for such use. When software product includes the manual in a file, only one copy of that file can be
printed. The documents accompanied by the software product cannot be copied. All the rights that are
not clearly stated are the property of the corresponding software manufacturer and supplier.

4. Double Media Software Product

The Software product can be delivered in one or more media. Regardless of the received media’s type
or size, only one media can be used in the computer. Other media cannot be executed on another
computer. Except for the case of transferring rights permanently (as described above), the user cannot
lease or lend the other media or transfer the right to other users.

5. Guarantee

The Software product’s guarantee on quality follows the attached warranty. If there is no separate
warranty enclosed, Suresoft Technologies guarantees that there was no defect during the production
process if it has been normally used for one year from the day of purchase. This does not mean that the
software product has no error, and does not exclude the possibility that unexpected result may appear
when using the product. Except for the cases where it is clearly stated in the separate warranty
agreement, Suresoft Technologies is not liable not only for the inaccuracy, error or defect of the software
product but also for the loss and damage produced from these. Suresoft Technologies doesn’t take any
responsibility for the third party’s claims for damage or the user’s claims for damage to the third party.
The Limited warranty statement, mentioned in the EULA, is still valid even though the user notified
Suresoft Technologies or its official representative in advance of the possibility mentioned above.
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6. Export limitation

The right transfer of the software product can be carried out only within Korea, and it cannot be exported
to other countries.

7. JAVA Support

The Software product includes the support of programs written in JAVA. JAVA technology is not
designed as an online control device, or not made, used or sold in dangerous environments that need to
error preventive function, such as nuclear facility, aircraft navigation, aircraft control, medicine, medical
system, and weapon system that can cause death, injury, or critical physical/environmental damage.

Caution

© Suresoft Technologies, Inc. All copyrights reserved. Printed in Korea
Suresoft Technologies and CODESCROLL are trademarks of Suresoft Technologies, Inc.

The product name or trade name mentioned in this document and related document are the trademarks
or registered trademarks of the Company having the copyright for the product. The software described in
this document is provided according to the usage agreement and non-disclosure agreement.

The software may only be used or copied according to the terms of use in this Agreement.
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