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1. Target Test Guides

This user guides document describes how to execute target tests using CodeScroll Controller Tester.

Texas Instruments Code Composer Studio
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1.1. Texas Instruments Code Composer

Studio

1. Creat a CodeScroll Controller Tester project.

File Edit Search Project Target Window Help

New » C/C++ Project with Source Files
Close Chrl=W @ C/C++ Project from Embedded(CodeWarrior, Green Hills, NEC)
Close Al Cirl=Shift=W ¥ C/C++ Project from Visual Studic Project
ﬁ C/C++ Project from Existing CodeScrell Project
save e Create a C/C++ project with CPI File
Shei Sl i@ Create a C/C++ project with Build Information
Rename... F2 & C/C++ Project from RTV Build
Refresh F5  §m C/C++ Project from RTV Build Command
Switch Workspace... .| C/C++ Target Test Project with Source Files
b Import. ¥ C/C+= Target Test Project from Embedded(CodeWarrior, Green Hills, NEC)
4 Export.. BS  Create a C/C++ target test project with Build Information
F¥ C/C++ Target Test Project from RTV Build
Properties AltEnter E%  C/C++ Target Test Project from RTV Build Command
Bt T Other.. Cirl+N

2. Select a created Code Composer Studio toolchain.

m Mew Project

New Project

Create new project

O X

Project name: | CCStest

Location: | D:WCT34 workspacew201112

Select Toolchain

Toolchain MName -

CCS toolchain

GCC ARM 7.2

gccs.4

gccy.s

GCC 4.7 (32hit)

GCC 5.3 (32bit)

Microsoft Visual Studio 2010 (32...
Microsoft Visual Studio 2010 (32..

[}
i
=

=

OOoooOoOoor

Description

Autornatically generated.
Automatically generated.
Automatically generated.
Autornatically generated.

Teolchain Setting

= Back Mext >

cocl

3. Select source files to test.
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. Mew Project

MNew Project

Choose source files

Top Directory: | W CCSworkspacewtest

Directory

w [ test

File

» settings
» Debug
> targetConfigs

|| type filter text

main.c

Text file written list of source files

1 items selected

# The entered text file is separated by ;' or newline character.

| | Browse... |

Remave

MNext =

Finish || Cancel |

Searck Prigect Window  Help
['% CCStest

Show Coneagh
pTestbngator | EVEE TS A [ mane T
~ 1 CC3test

v (1 Detauit Moduk 2 .
Ld manc s * wain
int mein{usid)
l il
. reten 0;
]

e Updata Modify

o 51

Emors in the CCShest project

P i

Mesage Log location

Emor

[ 1 e sedected

When finish the settings, click [Finish] button to create the project.
- Codeteroll Controber Teiter BTV Rermote Target Werfien « Target Plugin (s6d)

=1
Hiew Prect

o Lt Test

i, funcion, et i, e
ame

v B rain
~ B (# main

T O
b Test_import Exgont Properies Prafeences

Giobal Seerch (O3

F) Clas Factory < Comicd Flow Gragh - Call Graph T3 Fenction Call ribsrarchy |#) Emor

BE-
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=

v Staement Caverage

M/0/01

100.0%
141

Coverage

100.0%
17000

To use debuggers, set up in Code Composer Studio and CodeScroll Controller Tester. For more

Debugger User Guides in this document.

information, refer to Texas Instruments Code Composer Studio, a sub-topic of Controller Tester
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2. Debugger User Guides

This user guides document describes how to use debugger when executing CodeScroll Controller Tester
target test.

» Lauterbach TRACE32

+ PLS Universal Debug Engine

* ISYSTEM winIDEA Debugger

* AR Embedded Workbench C-SPY Debugger
» Texas Instruments Code Composer Studio
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2.1. Lauterbach TRACE32

Controller Tester can target test using the TRACE32 debugger.

Controller Tester uses TRACE32’s cmm script to run tests in the target environment and get the results.
A list of targets supported by TRACE32 can be found on the Lauterbach homepage.

» Supported target list that can generate cmm script automatically

» Step1: Setting target environment in Controller Tester

« Step2: Run the target test
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. Supported target list that can generate

cmm script automatically

Controller Tester automatically generates a cmm script file or receives it from the user.

If the cmm script can be generated automatically, you only need to enter the chip name of the target. If

you cannot generate cmm scripts automatically, you must enter the cmm script file path manually.

The targets that currently support the automatic generation of cmm scripts are:

PowerPC

ARM

tricore

mpc5554, mpc5553, mpc5534, mpc556x, mpec551x, mpc560xe, spc560bxx, spc560pxx,
spc560sxx, mpc560xb, mpc560xp, mpc560xs, spc563mb54, mpc5632m, spc563m60,
mpc5633m, spc563m64, mpc5634m, mpc564xs, mpc5668, mpc5674, mpc5644a, spc564a80,
mpc5642a, spc564a70, mpcb567xk, spcs56hk, mpc5643l, spc56el60, spc56el70, mpc5644b,
mpc5644c, spc564b64, spc56ect64, mpc5645b, spc564b70, mpc5645c, spcs56ec70, mpc5646b,
spcb564b74, mpc5646¢, spcb6ec74, mpc5676r, spcS6ap, mpc5746m, mpc5744k, spc574k74,
mpc5777m, spc57hm90, mpc574xp, mpc574xg, mpc574xr, mpc577xk, mpc5777¢, spc570s,
mpc5726l, spc572l, spcd574s, spcd8ne, spch8eg, spcd8nn, spc582b, spcb8ec, spcb8nh,
spc584b, s32r274, s32r264, s32r372

mkw01, mkw20, mkv30, mkv40, mkv10, mkv50, mkm30, mklO, mkl10, mki20, mkI30, mkl40,
mkl80, mk0, mk10, mk20, mk30, mk40, mk50, mk60, mk70, mk80, mac57d54h, mac71x1,
mac71x2, mac71x4, mac71x5, mac71x6, mac72x1, [pc51u68, Ipcb4xx, Ipc8xx, Ipc11xx,
Ipc12xx, Ipc13xx, Ipc17xx, Ipc18xx, Ipc21xx, Ipc22xx, Ipc23xx, [pc24xx, Ipc28xx, Ipc29xx,
Ipcd0xx, Ipcd3xx, imxrt1064, xmc1100, xmc1200, xmc1300, xmc1400, xmc4100, xmc4200,
xmc4300, xmc4400, xmc4500, xmc4700, xmc4800, tle98, s3fm02g, s32k, sbela, sbelc, s6j3

tc2dx, tc21x, tc22x, tc23x, tc26x, tc27x, tc29x, tc35x, tc37x, tc38x, tc39x, tc116x, tx1167,
tx1197, tc1724, tc1728, tc1736, tc1762, tc1764, tc1766, tc1767, tc1782, t¢c1784, tc1791, tc1792,
tc1793, tc1796, tc1797, tc1798
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2.1.2. Step1: Setting target environment in
Controller Tester

Select Debugger on the target environment setting page of the Controller Tester. Only a list of
debuggers supported is displayed, depending on the toolchain selected for the project.

Set the debugger to TRACE32.
b Freescale ¢ CodeWarrior-MPCS5xx ¢ 2.6 ¢ others »  trace32

The setting items are displayed according to the selected information. The items you need to set when
using the TRACE32 debugger are shown in the table below.
Some of the settings are required.

TRACE32 executable file path. Each target has a different
trace32_exe_file_path executable file, so you need to make sure that the target
executable is the correct one. Required

Path to the binary file for loading into the target environment.
target_binary_path Check and enter the path where the target binary file is created in
your IDE or build script. Required.

Enter the chip name of the target you are using. It is used when
chip auto-generating a cmm script, so you need to enter the correct chip
name.

Custom cmm script file path. For targets that do not support
automatic generation of cmm scripts, you must write a script to set
the debugger and target usage environment, or enter the path to
the cmm script file you are using.

user_defined_cmm_script_file_path
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2.1.3. Step2: Run the target test

You must exit the running TRACE32 program before running the target test.

You can run a target test by selecting [Run Target Test] from the project context menu in the Test
Navigator view or by clicking the [Run] button in the Test View.

* [Run Target Test]

Tq Test Navigator == =
b [k test]
L Mew »
3 Delete Delete
Rename... F2
= Import..
&g Export.
Refresh F5
Close Project
Quality Management Tools 2
& Run Target Test
*y Import Target Test Log L
* [Run]
Unit Test Integration Test

* When you run the target test, the TRACE32 program runs. If the test is succeeded, the
TRACE32 program ends automatically.
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2.1.4. Debug the target test

o &

—_— -

13.

oo 0 e NO

. After setting it as a target, right-click the test case in the ‘Unit Test’ view and click ‘Check Debug

Information’

Build the user project directly or execute the build script registered in the ‘target environment’
setting in the controller tester project

Verify that the build was successful

Restore the original source by opening the project in Controller Tester

After running Trace32, open the cmm script file (start.cmm) and execute ‘debug’
(Controller_Tester_project_path/.csdata/target/start.cmm)

Click the ‘step’ button to go to the first line of the target.cmm script

Add breakpoint to ‘Go.HII’ in target.cmm file

Click ‘Var’ > ‘Show Function’

Double-click after searching for the function to be tested

Add breakpoint at the beginning of the function

Click the ‘step’ button and confirm that the debugging point moves to the location specified in step
10.

‘Var’ > ‘Show Local...” . Click to confirm that the value of the local variable changes

Run up to the debugging point
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2.2. PLS Universal Debug Engine (UDE)

Controller Tester can target test using the UDE debugger.

Controller Tester uses debugging scripts supported by UDE to run tests and get results in the target
environment.
A list of targets available for connection to UDE can be found on the PLS homepage.

Controller Tester uses the UDE workspace information to perform target tests. For this reason, users
must first create a workspace before performing a target test.

» Step1: Create a workspace in UDE IDE

» Step2: Setting target environment in Controller Tester

» Step3: Run the target test
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2.2.1. Step1: Create a workspace in UDE IDE

UDE can generate UDE workspaces from the UDE desktop IDE.

1. Create the workspace by selecting the configuration file suitable for the target used.

Select Target Configuration

Last Used Browse |

Folder to browse :

{UDE install path}WTargetsW j

Additional Filter:

Files in folder : [ Show descriptions

Bl MXP XPC560P Mini Module with MPC5604F (Jtag)

Default New Copy Edit Remove

2. Click the [File]> [Load Program] button to load the binary file. At this point, select the binary file
built from the test code.
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File Edit Debug Show Views Tools Config W

[0 New Workspace CTRL+N
& Open Workspace... CTRL+O
kS Save Workspace CTRL+S
k2 Save Workspace As..

Save Workspace as Template...
H Save View Content As.. CTRL+ALT+S
= Close Workspace ALT+F4

Ell__oa d Program

. Connect Target System..

< Disconnect Target System..

Print Setup

Print CTRL+P

Recent Files

Recent Workspaces 4

Exit

3. Follow the instructions and press the [program] button to load the binary file into the target
according to the target settings. If the load completes successfully, the workspace setup is
complete. Click [Exit] to exit the dialog.

. UDE - FLASH/OTP Memory Programming Tool - Controller0.Core

—FLASH/OTP - Memory Dewvice

|PFLASH: 512 kByte OnChip FLASH ~| |¥ Enable Exit

dadip

Index | Start End | Size | ~ Erase ... | Ahout
0 000000000 0x00007FFF 32K
Ox00000000 Ox00000007 Help
Ox00000020 Ox000002FF
Ox00001000 Ox0000171A7 ety | General ...
Ox00002000 Ox00007FFF
1 000008000 0x0000BFFF 16K Hy Protect |
Ox00008000 Ox0000BFFF
2 Ox0000Ca00 0=0000FFFF 16K S\ Protect |
Ox0000Ca00 Ox0000FFFF
3 0x000710000 0x0001 7FFF 32K TestEmpty |
Ox00010000 0x00013F7E
4 nv%?'lq?gnqn?'lun m%ﬁ?‘quggg ’ 7K i Infor.. | Frogram All |
Fermawe All Femowe Sel. Setup ... | Werify Al |

See the manual provided by UDE for details.
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2.2.2. Step2: Setting target environment in
Controller Tester

Select Debugger on the Target Environment configuration page of the Controller Tester. Only a list of
debuggers supported is displayed, depending on the toolchain selected for the project.

Set the debugger to UDE.
b Freescale ¢ CodeWarrior-MPCS5xx » 2.6 k¢ others » ude

The setting items are displayed according to the selected information. The items you need to set when
using the UDE debugger are shown in the table below.
Some of the settings are required.

Path to the binary file for loading into the target environment. Check and enter the

LETE L ATETS 2R path where the target binary file is created in your IDE or build script. Required.

ude_project_file Path to the workspace project file (.wsx) generated by the UDE IDE. Required.
The default scripting language used by Controller Tester is visual basic script.

When the target configuration is complete, click the [OK] or [Finish] button. You are ready to execute the
target test.
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2.2.3. Step3: Run the target test

You must have exited the UDE desktop IDE to run the target test.

You can run a target test by selecting [Run Target Test] from the project context menu in the Test
Navigator view or by clicking the [Run] button in the Test View.

* [Run Target Test]

Tq Test Navigator == =
b [k test]
L Mew »
3 Delete Delete
Rename... F2
= Import..
&g Export.
Refresh F5
Close Project
Quality Management Tools 2
& Run Target Test
*y Import Target Test Log L
* [Run]
Unit Test Integration Test

* UDE debugging scripts can be written in languages such as C ++, .NET, and Perl. See
the UDE Automation Basics documentation included in the UDE manuals for other
supported languages that can be scripted.
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2.2.4. Debug the target test

N o ok w

© o

. After setting it as a target, right-click the test case in the ‘Unit Test’ view and click ‘Check Debug

Information’

Build the user project directly or execute the build script registered in the ‘target environment’
setting in the controller tester project

Verify that the build was successful

Restore the original source by opening the project in Controller Tester

Select project after executing Pls Ude (.wsx file)

Select the output file built in step.2

Notice that the source file and function information contained in the output file are displayed on the
left navigation.

Select a source file containing the function to be tested and add breakpoints in the function
Press F5 to start from the entry point
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2.3. iSYSTEM winIDEA Debugger

Controller Tester provides the ability to run tests on your target environment and get results from it

automatically by using winIDEA debugging scripts.
The list of targets supported by winIDEA can be found on the iISYSTEM home page.

The execution of the debugging script requires the python SDK installed together when installing
winIDEA. If it is not installed, you can download it from the iISYSTEM SDK installation page. Also, you

should check the version of winIDEA you use if it supports the SDK. The debugging script provided by
Controller Tester is based on python 3.3.

This document describes the process from creating a project in winIDEA to running a target test in
Controller Tester. The iSYSTEM BlueBox iC5000 Unit debugger and NXP’s MPC56xx target are used for
the examples.

» Preparation for use of iISYSTEM winlDEA
« Step1: Creating and setting up a winIDEA workspace

» Step2: Setting target environment in Controller Tester

Step3: Run the target test

Page 17 of 80


https://www.isystem.com/support/supported-chips-overview.html
https://www.isystem.com/support/supported-chips-overview.html

Suresofttech User Guides - 3.4

2.3.1. Preparation for use of iSYSTEM
winlDEA

Target testing with winIDEA in Controller Tester requires a debugger that winIDEA supports.

Before running the target test, you need to create a winIDEA workspace and connect the debugger for
use to the PC with Controller Tester.
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2.3.2. Step1: Creating and setting up a
winlDEA workspace

1. After running winIDEA, create a new workspace by selecting [File]> [Workspace]> [New
Workspace ...] from the top menu. Additional workspace settings are required to use the
workspace you create for the Controller Tester target test.

| w| winIDEA

File Tools Window Help
d  New. Ctrl+N
& Open.. Ctrl+O
=

@ Save All

Hi

=

Select Workspace...

Workspace 3 New Workspace...

& Open Workspace..

Source Control 4

2. First, go to the top menu, select [Hardware]> [Hardware...], and then select the type of the
connected BlueBox in the [Hardware Type] tab.
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Hardware Configuration *

Hardware Type  Communication

Hardware

iC5000, TAG2k w

System Configuration. ..

3. Next, set the communication method in the [Communication] tab, and press the [Test] button to
check the connection to the debugger. Please refer to the iSYSTEM BlueBox manual for
instructions on how to connect the debugger device depending on the communication method.

Hardware Configuration X

Hardware Type Communicaticn

Port
@uss
) TCR/IP IP addr Port | 5313
Use global discovery on UDP port 58371
BRIDGE Eridge Configure...

Device

n IJSE and TCP connections #12345 notation can be used to
nnect to device with serial number 12345

SB: For optimum streaming performance:

- Always use quality cables
- Avoid hubs
- Perform comm. test from different host PC ports

4. Click [Hardware]> [Use Software Breakpoints] on the top menu to activate it, and then select the
target type to use in the [CPU] of [Hardware]> [Emulation Options...].
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E] demo_workspace - winlDEA
File View Hardware Debug Test Tools Window Help

n Project Hardware... E —
= x |Filte License... o
=] Initialize =
E Emulation Options..
2 CPU Options. >
e Use Software Breakpoints @
= Use Hot Attach __E
] E
FLASH 4 5=
= o
= ELASH Setup.. _
— )
Analyzer Setup..
Tools...
= Options...
Emulation Options >
Hardware CFU Initialization Initialization After Download
Famil POD/ICARD/TAG cru|
MPC56048
MPC5604C
| CPUSetup.. |
| SetDefaut | m
MPC56058
MPC5605BK
MPC56068
MPC5606BK
MPC56065
MPC56078 v
CPU wariant
(default) e

* The specific options you need to set for each target may vary.

5. After the debugger setup is complete, you need to register the binary path of the software under
test in the workspace. First, build the source code under test to generate the binary. Then from
winIDEA’s top menu [Debug]> [Files for Download ...], select [New...] and add the binary
generated.
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Download X

Download Files Options Target Download SMP  Endian VLE  Overlays

Path Type Offset
MPC5604P_Example¥tbintinternal_FL... ELF r

MNew... Remove Properties...

Memory area | default o

[ ]include project output file

Default file for debugging linternal FLASH.elf w

6. When everything is set up, save the workspace to create a winIDEA workspace file (.xjrf). The
workspace file is used to configure the target test using winIDEA in Controller Tester.
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@ demo_workspace - winlDEA

File View Hardware Debug Test Tools Window Help
0 New. Ctri+N | I .
& Open. Ctrl+0O ~
Close Ctrl+F4 -
| Save Ctrl+
e i '
@ Save All o
A Te e oz
m B o Lo [;E
@ r Ctrl+F N
Select Workspace... T
Workspace 3 New Workspace...
Open Workspace...
Source Control = pen o obe
@  FEind In Files.. Save Workspace Template...
Exit Alt+E4 Close Workspace

You are now finished creating the winIDEA workspace for the target test.

User Guides - 3.4
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2.3.3. Step2: Setting target environment in
Controller Tester

Select a debugger in the [New Project] wizard of the target test project or [Target environment settings]
of the project properties on Controller Tester. The list of selectable debuggers depends on the toolchain
selected for the project.

Set the debugger to BlueBox.
b Freescale ¢ CodeWarrior-MPCS5xx ¢ 2.6 ¢ others ¢ blusbox

The fields to be set are displayed according to the selection. If you are using BlueBox, the fields are
shown in the table below.
Required fields are displayed in red in Controller Tester.

winidea_binary_path The winIDEA execution file(winIDEA.exe) path. Required.

winidea_workspace_file_path The path of the workspace file (.xjrf) created by winIDEA. Required.

The default scripting language provided by Controller Tester is python. If you use a custom debugging
script, you need to write it in python to work properly. If you write in other languages, refer to the
iISYSTEM homepage to install additional SDKs.

When the target environment settings are complete, click the [OK] or [Finish] button. Now you are ready
to run the target test.
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2.3.4. Step3: Run the target test

You can run a target test by selecting [Run Target Test] from the project context menu in the Test

Navigator view or by clicking the [Run] button in the Test View.

* [Run Target Test]

Tq Test Navigator =R
b [k test]
L MNew 3
€ Delete Delete
Rename... F2
g Import.
&y Export..
Refresh F5
Close Project
Quality Management Tools *
#  Run Target Test
=y Import Target Test Log 3
. [Run]
Unit Test Integration Test

* Target tests cannot be run if winIDEA is running. You must exit winIDEA before running
the target test in Controller Tester.
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2.3.5. Debug the target test

© N o O

. After setting it as a target, right-click the test case in the ‘Unit Test’ view and click ‘Check Debug

Information’

Build the user project directly or execute the build script registered in the ‘target environment’
setting in the controller tester project

Verify that the build was successful

Restore the original source by opening the project in Controller Tester

After running winlDEA, select the workspace containing the built project (.xjrf file)

Download to binary file target by selecting [Debug]> [Download]

Debugging mode by pressing the Run button at the top

Double-click [Project]> [Functions], move to the function location, and set the debugging point
where you want

Press F5 to proceed debugging

Page 26 of 80



Suresofttech User Guides - 3.4

2.4. IAR Embedded Workbench C-SPY
Debugger

Controller Tester provides the ability to automatically run tests and get results in the target environment
through the IAR Embedded Workbench C-SPY debugging function.
The list of targets supported by C-SPY can be found on the |IAR website.

To test a target with the IAR Embedded Workbench C-SPY in the Controller Tester, you need a C-SPY
compatible debugging probe. You need to create an IAR Embedded Workbench project and connect the
debugging probe to be used with the PC where Controller Tester is installed before performing the target
test.

The list of debugging probes provided by IAR can be found on the homepage.

Step1: Creating an IAR embedded workbench project

» Step2: Setting an IAR project

» Step3: Setting target environment in Controller Tester

Step4: Run the target test
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2.4.1. Step1: Creating an IAR embedded
workbench project

1. Click [File]> [New Workspace] to create a new workspace and then click [Project]> [Create New
Project...] to create a project file (.ewp). When a project file created, the project name is displayed
in the [Workspace] view of the IAR Embedded Workbench.

Waorkspace w 0 X
Debug e
Files o .

@ sample_project-De... +

2. Next, you need to add the source files under test to the project. Right-click on the project, click
[Add]> [Add Files... ] and add the source files to be tested. The added source files are displayed in
a hierarchical structure in [Workspace] view.

Workspace w 0 X
Debug e
Files = B

= @Wsample_project-De...
rmain.c
B Output
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2.4.2. Step2: Setting an IAR project

If you created a project, you need to configure the project to use the C-SPY debugging feature. Right-

click on the created project and select [Options ...].

1. First, set [Processor variant] in [General Options]. For example, for ARM’s STM32F429IG target,

select Device and select a name that matches the target from the target list on the right.

Options for node "sample_project” Cypress >
Epson ¥
EtaCompute >
Categony: Faraday »
Fujitsu >
Static Analysis HDSC .
‘ )
€JC-++ Compiles Library Options 2 MISRA-C-2004 MISRA: Hilscher *
Assembler Target Output Library Configuration Library Holtek >
Qutput Converter i 5
Custom Build Processor variant
Buid Actions I Lapis r »
i Ocore |ARMTTOMI “| e N .
Debugger
prisycfal [oeice]  [Nome | Maxim > sPEar » ST STM32F229AG
capt Oomsis.pack | None Mediatek > STM32F0 > ST STM32F429A1
CMSIS DAP et Microchip * STM32F1 i AR
GDB Server
Tet Endlan mode Floating point settings Micronas E STM32F2 2 ST STM32F4298G
Jink[)-Trace ] Microsemi > STM32F3 > ST STM32F4298I
T1 Stellaris @ Little PU |Nnne—
sy Osig Milandr > smEzR S sTm3zraot > ST STM32F4201E
PE micro reglsters i = MindMotion > STM32F7 > STM32F405 >
8E32 9
i‘-ﬂ‘(d i MitsubishiElectric > STM326G0 > STM32F407 > ST STM32F42911
ird-Party Driver
TIMSPFET NetSilicon ¥ STM32G4 ¥ STM32F410 ¥ ST STM32F420NE
TrustZone -
TIXDS DSP Extansion NerdicSemi > STM326GB > STM32F411 > ST STM32F420NG
Mode |Secure Nuvoton > STM32HT > STM32F412 > ST STM32F429NI
Advanced SIMD (NEON) g
NXP > STM32L0 > STM32F413 > ST STM32F429VE
ONSemiconductor > STM32L1 > STM32F415 > ST STM32F429VG
[ ok ][ caea Qorvo > ST™32L4 > STM32Fa17 > ST STM32F420VI
Redpine 3 STM32L4+ » STM32F423 ¥ ST STM32F420ZE
[ e > swems > _swawer st
Samsung > STM32MP1 » [ SIM3Ra28 5 STSTM32F4a207)
siliconLaboratories > STM3ZW > STM32F437 >
socle > STM32WB > STM32F439 >
Sonix ¥ STR7 » STM32F446 ¥
STR9 » STM32F469 >
Texasinstruments » I STM32F479 »

2. Second, go to the category [Debugger] and select the debugging probe you want to use in the
[Driver] field. Set the details in the Debugging Probe section at the bottom of the [Debugger]
category, depending on how the selected debugging probe and PC are connected.
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Cateqary:

Options for node "sample_project”

Pt

General Options

Static Analysis

Runtime Checking
CfC++ Compiler
Assembler
Output Converter
Custom Build
Build Actions
Linker
Debugger

CADI

CMSIS DAP
GDE Server
I-et
Jink/1-Trace
TI Stellaris
Mu-Link

PE rnicra
ST-LIMNK
Third-Party Driver
TI MSPFET
TI XDS

Setup  Download

Diriver

Setup macros

[ 1Use macre file(s)

Device description file
[1Cverride default

Images Extra Options Multicore

Run to

|main

Factom Settings

If 1-jet is selected, select [I-jet] at the bottom of the [Debugger] category to set details. For a

description of each setting tab, refer to the IAR debugger manual you want to use.
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Options for node "c_proj"

Cateqgory:

s

General Options
Static Analysis
Runtime Checking
CfC++ Compiler
Aszembler
Output Converter
Custom Build
Build Actions
Linker
Debuagger
Simulator
CADI
CMSIS DAP
GDE Server
1-Link/J-Trace
TI Stellaris
Mu-Link
PE micro
STINK
ThirdParty Driver
TI MSPFET
TI XD5

ISE‘tUF" Interface  Trace Breakpuintsl

Reset

Factory Settings

‘Cunnect during reset {default)

Ciuration: 300 | ms

Target power

From the probe
(®) Leave on after debugging
() Switch off after debugging

[]Log communicaticn

$PROJ_DIR$Wcspycomm.log

Delay after: 200 | ms
Ernulator
[ Always prompt for probe
selection
Serial no

Cancel

Now you are done creating and setting the IAR project for target testing.
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2.4.3. Step3: Setting target environment in
Controller Tester

Select a debugger in the [New Project] wizard of the target test project or [Target environment settings]
of the project properties on Controller Tester. The list of selectable debuggers depends on the toolchain
selected for the project.

When creating a project using the IAR toolchain, the debugger must be set to ide to use the IAR C-SPY

debugging feature.
b IAR » ARM-Compiler » 5x » others b ide

The fields to be set are displayed according to the selection. The fields for C-SPY are as shown in the
table below.
Required fields are displayed in red in Controller Tester.

The path to the debug.general.xcl file required when using the IAR
Embedded Workbench C-SPY debugger. When creating an IAR
project, the project file (.ewp) is automatically created in the [setting]
folder in the saved location. Required.

cspy_debug_general_xcl_file_path

Path to the debug.driver.xcl file required when using the IAR
Embedded Workbench C-SPY debugger. When creating an IAR
project, the project file (.ewp) is automatically created in the [setting]
folder in the saved location. Required.

cspy_debug_driver_xcl_file_path

When the target environment settings are complete, click the [OK] or [Finish] button. Now you are ready
to run the target test.
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2.4.4. Step4: Run the target test

You can run a target test by selecting [Run Target Test] from the project context menu in the Test

Navigator view or by clicking the [Run] button in the Test View.

* [Run Target Test]

T'q Test Navigator =R
H 4 =
b |l test]
L MNew 3
€ Delete Delete
Rename... F2
g Import.
&y Export..
Refresh F5
Close Project
Quality Management Tools *
#  Run Target Test
=y Import Target Test Log 3
« [Run]
Unit Test Integration Test
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2.4.5. Debug the target test

1. After setting it as a target, right-click the test case in the ‘Unit Test’ view and click ‘Check Debug
Information’

2. Build the user project directly or execute the build script registered in the ‘target environment’
setting in the controller tester project

3. Verify that the build was successful

4. After IAR Workbench run, select the workspace containing the built project (.eww file)

5. Select the source file with the function to be tested in the workspace view, and click the left side of
the line to add the debugging point

6. Right-click the project in the workspace view and open ‘Options ..." to check the Run to option
check in the Debugger item and check that it is designated as ‘main’

7. Click the Download and Debug button at the top to start from main

8. Press F5 to proceed to the debugging point to debug
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2.5. Texas Instruments Code Composer
Studio (CCS v4 and later)

Controller Tester can run target tests using the Code Composer Studio debugger. Controller Tester uses

debugging scripts supported by Code Composer Studio (since version 4.x) to run the tests in target
environment and get results. Check the Code Composer Studio manual for a list of debugging devices
you can connect to and use with Code Composer Studio.

This document describes how to use Code Composer Studio debugger with following three steps.

» Step1: Create a project in Code Composer Studio

» Step2 : Setting target environment in Controller Tester

» Step3: Run the target test

The example uses Spectrum Digital’'s XDS560v2 as a debugger and Texas Instruments’ TMS320 as
target device.
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2.5.1. Step1: Create a project in Code
Composer Studio

1. Run Code Composer Studio and create a new project. Select [File]-[New] from the top menu and
select the desired project type. In this case, click [CCS Project] to create a project. After entering

the target and debugger information used, click [Verify] to confirm that the connection is

successful.

88 New CCS Project O X

New CCS Project @

Create a new CCS Project.

Target: <select or type filter text= ~ [#TMS320F28335 ™

Verify...

2. After verifying the debugger and target connections, enter the remaining settings. The example
uses the C2000 Ti compiler. When you click [Finish], the CCS project is created in the workspace.
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4 C28XX [C2000]

Project name: test

Use default location

Location: | C:#cestudio wsitest Browse...
More...
» Tool-chain
~ Project templates and examples
type filter text Creates an empty project initialized

for the selected device. The project
will contain an empty ‘'main.c’
source-file.

~ [5 Empty Projects ”
& Empty Project
‘& Empty Project (with main.c)
& Empty Assembly-only Project
& Empty PowerSuite Project
& Empty RTSC Project

< >

Open Resource Explorer to browse a wide selection of example projects..

Open Import Wizard to find local example projects for selected device...

® < Back Mext = Cancel

Code Composer Studio supports several more debuggers in addition to the built-in debuggers from
Texas Instruments.

T1 XDS USB (Code Composer Studio default)
BlackHawk JTAG emulator

Spectrum digital

MSP430 USB

MSP432 USB

Tiva/Stellaris ICDI

o0k N~

Controller Tester controls the debugger supported by Code Composer Studio with javascript. You can
select the target and debugger details from the Project Settings screen in Code Composer Studio.
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2.5.2. Step2 : Setting target environment in
Controller Tester

1. Creat a CodeScroll Controller Tester project. For more information to create the project, refer to
Texas Instruments Code Composer Studio in this document.

2. Right-click on the project in test navigator view and select [Properties] — [Target test] — [Target
environment settings]. You can set up target environment in [Target environment settings]. Setting
fields and the list of selectable debuggers depend on the toolchain selected for the project.

3. Select a debugger in [Target environment settings] of Controller Tester. This example selects IDE

debugger to use Code Composer Studio debugger.
B OTIM C2000 F 62 ¢ TMS320F28x » ide

4. Enter needed informations on [Build] tab of [Target environment settings] for Code Composer
Studio build. Following fields need to be filled and these are necessary.

Properties for CCStest O X
type filter text (D) When running the target test, it will build the test co..lly by filling out the required fields on the Run tab. = v -
Inclusion and Exclusion )
Info b T » C2000 » 6.2 » TMS320F28x b ide Import Target Envirenment Setings
v Target test Settings
Target environment set ; :
Tt S [Juse build script
Build Mame Value
Run use_stdio_header false
ete. use_std_string_header false
ide_directory_path CHccs10114ccs
workspace D:WCCSworkspace
project_name test
toolchain_kind ti
MName: ide_directory_path | Value: |C:’#cc51 011%ccs Browse...

Description: | The path to the
directory where Code
Composer Studio ide
is installed

Apply and Close Cancel

+ Fileds of [Build] tab
ide_directory_path Directory path of Code Composer Studio ex) C:\ti\ccs930

workspace Directory path of Code Composer Studio workspace

project_name Project name analyzed by Controller Tester

5. Enter needed informations on [Run] tab of [Target environment settings] for running target tests.
Following fields need to be filled and these are necessary.
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Properties for CCStest ] X
type filter text When running the target test, it will build and run the test code. - v v
Inclusicn and Exclusicn
Info b Tl » C2000 » 6.2 » TMS320F28x ¢ ide Import Target Environment Settings
v Target test Settings
Target environment set P
Test Analysis Mame Walue
Build ccxml_path Do CCSworkspacettestwtargetConfigewTMS320F28335.coxml
Run target_binary_path Do CCSworkspacettestwDebugitest.out
et debug_probe Spectrum Digital XDS560V2 STM USB Emulator
= cpu_name C28xx
memory_page Memory Page DATA
char_format 5
Description:
< >
Apply and Close Cancel

» Fields of [Run] tab

Enter a path of Code Composer Studio target configuration file. Check the
ccxml_path project path and target name. File name is the target name selected in

Code Composer Studio ex) project-path\targetConfig\target-name.ccxml

Enter a path of execution script. You don’t need to enter if you don’t have

script_path
Al the script.

. Enter a path of binary file created during build in Code Composer Studio.
target_binary_path ) .
ex) project-path\Debug\project-name.out
Refer to front of /’ in [Device] of Code Composer Studio properties and
debug_probe enter a target device name. (Spectrum Digital XDS560V2 STM USB
Emulator in example shown below)
Refer to back part of ‘/’ in [Device] of Code Composer Studio properties

cpu_name : .
and enter a target device name. (C28xx in example shown below)

Enter a memory page that Code Composer Studio debugger can access
memory_page _ )

(Refer to a Code Composer Studio Memory Browser imgae below)

Enter a order of character of Code Composer Studio data format. If
char_format character is the 6th from the top of the bar, enter 5 in the char_format

value.

* Code Composer Studio properties
o Right-click Code Composer Studio project and select [Properties] — [Debug] — [Device]
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debuqg probe

Cpu_narme

Device §Spectrum Digital XDS560V2 STW USE EmulatoriC2 8]

» Code Composer Studio Memory Browser

!

= Disassembly @ Memory Browser &2
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v wlve e i

Data < |0x003rB100

Data:0x3fb100 - 0x003FB100 <Memory Rendering 1>

Character w

8-Bit Hex - Tl Style index: 0 ~
8-Bit Hex - C Style index: 1
8-Bit Signed Int  index: 2
8-Bit UnSigned Int index: 3
-Bit Bj index : 4

Packed Char

16-Bit Hex - C Style
16-Bit Hex - Tl Style
16-Bit Signed Int
16-Bit UnSigned Int
16-Bit Binary

32-Bit Signed Int
32-Bit UnSigned Int
32-Bit Hex - C Style
32-Bit Hex - T Style
32-Bit Floating Point v

char_format value : 5

r

[

/
]
H
d

}

&

Mo -

€0 - -

k

*

?

(-
|

. #

K . E

If Code Composer Studio is running during execution, compile error occurs.

6. After finishing target environment settings, click [Finish] button. You are ready to do target tests.
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2.5.3. Step3: Run the target test

Before running the target test, you should stop using the workspace where the project you want to build

is located. If you are using a workspace in the IDE, target testing does not work properly.
You can run a target test by selecting [Run Target Test] from the project context menu in the Test
Navigator view or by clicking the [Run] button in the Test View.

* [Run Target Test]

Tq Test Navigator =R
b (o test]
L Mew 3
¥ Delete Delete
Rename... F2
= Import..
g Export.
Refresh ]
Close Project
Quality Management Tools 3
& Run Target Test
=3 Import Target Test Log *
* [Run]
Unit Test Integration Test

* For more information on debug scripting in CCS, see the Texas Instruments home page.
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2.54. Debug the target test

1. After setting it as a target, right-click the test case in the ‘Unit Test’ view and click ‘Check Debug
Information’.

2. Run in debugging mode in Code Composer Studio.

3. Click [File] > [Open] File in Code Composer Studio.

4. Select the source file_number.c file with the function to be debugged in the
Controller_Tester_workspace path/.metadata/.plugins/com.codescroll.ut.embedded/project name/
TestFixture/cs

5. Add breakpoint where you want to debug

6. Run Debug
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3. Target Build Guide

CodeScroll Controller Tester guides you through building target test code using target project

information.

» |AR Embedded Workbench IDE

+ Texas Instruments Code Composer Studio
+ CodeWarrior IDE

» Hightec Development Platform IDE

+ Tasking VX IDE

* Renesas CS+ IDE

+ MPLAB X IDE

* Microsoft Visual Studio

+ GNU Compiler
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3.1. IAR Embedded Workbench IDE

The target preference page is automatically filled in according to the tool chain selected by the user. The

type of debugger you can choose depends on your toolchain analysis settings.

To build an IAR Embedded Workbench, enter the required information in the Analysis and Build tab of
the target preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

* Analysis tab

cpu CPU of target that can be selected from Core of Processor variant

» Build tab

Installation path of the IAR Embedded Workbench IDE ex. C:\Program

ide_directory_path
Files (x86)\IAR Systems\Embedded Workbench 8.4

project_file_path Project file (.ewp) path of IAR Embedded Workbench

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.

When using the 10 function of stdio.h, it is necessary to change the library settings.
Right click on the project in the workspace -> Options -> General Options -> Library
Configuration -> Library tab and change it to Full.
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Options for node "test”

Categary
General Optons
Static Analysis
Runtime Checking
CfC++ Compiler
Ass=mbler
Output Converter
Custom Build
Buid Actions
Lirker
Debugger
Simulator
CADI
CMSIS DAP
GDB Server
Ijet
Minkf])-Trace
T1 Stellaris
Mu-Link
PE micro
STAINK
Third-Party Driver
TIMSPFET
TI1XDS

Library Options 2
Target Output
Library:

Ful v

Configuration file

MISRA-C:1998
Library Options 1

MISRA-C:2004
| Library Configuration |

Description:

Use the full configuration of the C/C++ runtime
library. Full loczale interface, C locale, file
descriptor support, multibytes In printf and scanf,
and hex floats in strtod.

STOOLKIT_DIR$Winc#cwDLib_Config_Fullh

(L] Enable thread support in library

Library low-level interface implementation CMSIS
None stdout/stderr
© v Use CMSIS
(O Semihosted Via semihosting
) ] DSP library
() IR breakpoint Via SWO
ok | Cancel
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3.2. Texas Instruments Code Composer
Studio

The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an Code Composer Studio, enter the required information in the Build tab of the target

preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

Properties for CCStest O *
type filter text (L) When running the target test, it will build the test co..lly by filling out the required fields on the Run tab. & v v
Inclusion and Exclusion
Info P Tl » C2000 » 6.2 » TMS320F28x » ide Import Target Envircnment Setfings
v Target test Settings
Target environment set ; :
Tect o [JUse build script
Build MName Value
Run use_stdio_header false
etc. use_std_string_header false
ide_directory_path C¥ccs10114ccs
workspace D:#CCSworkspace
project_name test
toolchain_kind ti
Marne: ide_directory_path | Value: |C:wcc51 011%ces Browse...
Description: | The path to the
directory where Code
Composer Studio ide
is installed
< >
Apply and Close Cancel
+ Build tab

ide_directory_path Directory path of Code Composer Studio ex.C:\ti\ccs930
workspace Path to workspace directory in Code Composer Studio

. The name of the Code Composer Studio project to be analyzed by
project_name
Controller Tester

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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3.3. CodeWarrior IDE

The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an CodeWarrior project, enter the required information in the Build tab of the target preferences
and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

* Build tab

Path to CodeWarrior IDE ex. C:\Program Files (x86)\Freescale\CW for

ide_directory_path
MPC55xx and MPC56xx 2.10, C:\Freescale\CW MCU

ide_version Classic or Eclipse(for MCUs)

. . In the case of Classic, the .mcp file named when creating the project, and
project_file_path ) ) ) ) . .
in Eclipse, the .project file created when creating the project.
If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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3.4. Hightec Development Platform IDE

The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an Hightec IDE project, enter the required information in the Build tab of the target preferences
and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

» Build tab
ide_directory_path Path to Hightec IDE ex. C:\HIGHTEC\toolchains\arm\v4.6.5.0
project_directory_path Path of project directory created by HighTec IDE
If you click the Done button on the target preference page without writing all the contents or if the path

has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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3.5. Tasking VX IDE

The target preference page is automatically filled in according to the tool chain selected by the user. The

type of debugger you can choose depends on your toolchain analysis settings.

To build an Tasking VX IDE project, enter the required information in the Build tab of the target
preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

» Build tab
ide_version Version of Tasking VX IDE
makefile_path Path of makefile created in Tasking VX IDE project

. . Path to the directory where Tasking VX IDE is installed ex. C:\Program
ide_directory_path
Files (x86)\TASKING\C166-VX v3.1r2

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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3.6. Renesas CS+ IDE

The target preference page is automatically filled in according to the tool chain selected by the user. The

type of debugger you can choose depends on your toolchain analysis settings.

To build an Renesas CS+ IDE project, enter the required information in the Build tab of the target
preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

* Build tab

. . Directory path of Renesas CS + IDE ex. C:\Program Files (x86)\Renesas
ide_directory_path .
Electronics

ide_kind IDE kind(CS+)

This is only necessary for the Renesas HEW IDE, so you do not need to

workspace_path o
enter it in CS +.

project_file_path  Project file path created by Renesas CS+(.mtpj)

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.

«¥s When exporting test codes from Controller Tester, some reference relative paths.
To reference this path when building in the Renesas CS+, add an environment variable.
- Add below paths at property of Build Tool-> Compile Options -> Preprocess ->
Additional include paths
(CTWORKSPACE) \.metadata\.plugins\com.codescroll.ut.embedded\ CT project name
\TestFixture
(CTWORKSPACE) \.metadata\.plugins\com.codescroll.ut.embedded\ CT project name
\TestFixture\cs
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0 S o P 4| e T v e an

Fath Edit =

Fath(One path per one lin): 14

Y'com codescroll ut embedded W RenesasCSPlusRLTE_2'W Test Fisture
¥com codescroll ut. embedded WhRenesasCSPlusRL7E W Test Fixturetes|

Browse...

[ ] Permit non-existent path
Include subfolders automatically

Flaceholder:

Placeholder Value 2

ActiveProject Dir C:iUses WSUREW Documents™WTEST

ActiveProjectMame  TEST

BuildModeMName Default Build

MainPraject Dir CAUsesWSUREW Documents™WTEST

MainProjectMame  TEST W

£ >
OK || Cancel || Heb
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3.7. MPLAB X IDE

The target preference page is automatically filled in according to the tool chain selected by the user. The

type of debugger you can choose depends on your toolchain analysis settings.

To build an MPLAB X IDE project, enter the required information in the Build tab of the target
preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

* Build tab

Installation path of MPLAB X IDE ex. C:\Program Files

ide_directory_path . .
(x86)\Microchip\MPLABX\v5.35

project_directory_path Project directory path created in MPLAB X IDE

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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3.8. Microsoft Visual Studio

The target preference page is automatically filled in according to the tool chain selected by the user. The

type of debugger you can choose depends on your toolchain analysis settings.

To build an Microsoft Visual Studio project, enter the required information in the Build tab of the target
preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

* Build tab

Installation path of Microsoft Visual Studio ex. C:\Program Files

ide_directory_path . ) )
(x86)\Microsoft Visual Studio 10.0

build_configuration Configuration and platform to test the target solution ex. Release  Win32

sin_path File path of target solution (.sin file)

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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3.9. GNU Compiler

The target preference page is automatically filled in according to the tool chain selected by the user. The

type of debugger you can choose depends on your toolchain analysis settings.

To build an GNU Compiler code, enter the required information in the Build tab of the target preferences
and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

* Build tab

makefile_path Path of user-made makefile

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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4. Sharing Projects with Other Users

You can share the CodeScroll Controller Tester projects with others.
Controller Tester 3.3 or later uses [Export Project] and [Import Project] functions.

* Guide to Share Projects
* Guide to Share RTV Projects
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4.1. (Ver.3.3 or later) Guide to Share Projects

From Controller Tester 3.3, you can easily share a project with the [Export Project] and [Import Project]
functions.

» Export project
» Import project
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4.1.1. Export project

User Guides - 3.4

You can export projects, including project setup and testing.

1. On the main menu, click [File] > [Export]. The Export Wizard opens.
, File | Edit Search Project Target Window

MNew »
Close Ctrl+W
Close All Ctrl+Shift+W
Save Ctrl+5
Save All Ctrl+Shift+5
Rename... F2
Refresh F5

Switch Werkspace...

Import...
Export...
Properties Alt+Enter

B E

Exit

2. Click [General] > [Export Project].

B eport a *
Select ﬁ
Export the project, including project settings and tests. H

Select an export wizard:
type filter text

» [= Coverage
w [= General
|= Export Project
> [= Metrics
s [= Preferences
y [= Test

< Back Mext = Finish Cancel

3. After selecting the project to export and the path to export, click the [Finish] button.
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B export Project a *

Export Project
Export the project, including project settings and tests.

Project:

=ib Select All

1 of 1 selected.

Fath:

4. You can see that there is a folder containing the exported project name in the exported path.
Compress the folder and move it to the computer of the user you want to share.

Page 59 of 80



Suresofttech

4.1.2. Import project
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Using the Import Project function, you can import a project exported from another PC into the
workspace.

Import general C/C++ Project

1.

Click [File] > [Import] in the main menu. The Import Wizard opens.
, File | Edit Search Project Target Window

C- |E

Rename...
Refresh

Switch Workspace...

Import...
Export...

Properties

Exit

Ctrl+wW

Ctrl+Shift+W

Alt+Enter

¥

Click [General] > [Import Project] and then click the [Next] button.
Click the [Browse] button to find the directory corresponding to the exported project.

When you select a directory, the toolchain is automatically selected from the project information to

be imported. If a project with the same name already exists in the workspace, you need to modify

the project name.
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B impor o @]
Import a Project -
Import the exported project.
-l
Project directory: DhvprojectlE_20200513113853 Search...
Project name: projectlE
Location: ChUsers\vagrant\Desktop\workspace\CT\1
Select Toolchain
Default Toolchain Name ° Description
gcc 84
vs2019 x64_x64
vs2019 x64_xE6
2019 186 +E6
GCC 4.7 (32bit) Automatically generated.
GCC 5.3 (32bit) Automatically generated.
Toolchain Setting
<Back || Net> || Fnsh  |[  concel

o¥s |If there is no toolchain with the same name as the toolchain of the project to be
imported, you must first export and then import the toolchain of the project to be
imported. For details, see [Import Toolchain] and [Export Toolchain] in the CodeScroll
Controller Tester document.

# Click the [Next] button.

1. You can check the source path included in the project to be imported. Invalid paths are marked in
red and can be modified by clicking on the path window.
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. Import
Check the paths included in the project
/v, Invalid path: 15/15

Path(click to edit):

C\Users\seo hyunji\Desktop'target plugintzlib-1.211%zlib-1.2.11N\adler32.c
C\Users\seo hyunji\Desktophtarget plugintzlib-1.2.11%zlib-1.211Nere32.c
C\Users\seo hyunji\Desktopitarget plugintzlib-1.2.11%zlib-1.2. 11\ deflate.c
C\Users\seo hyun)i\Desktopitarget plugintzlib-1.2.11%zlib-1.2.11\gzclose.c
Ch\Users\seo hyunji\Desktop\target pluginizlib-1.211zlib-1.2.11\gzlib.c
sersiseo hyunji\Desktop'target plugin'zlib-1.211%zlib-1.2.11\ gzread.c

C eo hyunji\Desktop\target plugin'zlib-1.2 11%zlib-1.2.11\ gzwrite.c
C\Usersiseo hyunji\Desktop\target plugintzlib-1.2.11%zlib-1.2 11\infback.c
Ch svseo hyunji\Desktop\target plugintzlib-1.2.11%zlib-1.2 11\inffast.c

C\Users\seo hyunji\Desktopttarget plugintzlib-1.2.11%zlib-1.2 11\inflate.c
C\Users\seo hyunji\Desktopitarget plugintzlib-1.2.11%zlib-1.2 11\inftrees.c
C\Users\seo hyun)i\Desktopitarget plugintzlib-1.2.11%zlib-1.2. 11 trees.c
C\Users\seo hyun)i\Desktopitarget plugintzlib-1.211%zlib-1.2.11\uncormpr.c
eo hyunji\Desktop'\target plugin'zlib-1.211%zlib-1.2.11zutil.c
sersiseo hyunji\Desktopitarget plugin'zlib-1.2 11%zlib-1.2.13\ compress.c

2. If there is an invalid path, modifying one file path automatically modifies the associated file path.
At this time, you can check the number of modified routes at the top.

B import = [Fe=r]
Check the paths included in the project E:‘_—]_
7|

(D Invalid path: 0/15
15 paths have been resolved.

Pathiclick to edit):
C\Users\vagrant\Desktop\sourcetzlibl 211\zlib-1.2 11\adler32.c
Ch\Users\vagrant\Desktop\sourcelzlib1211\zlib-1.2 11\ compress.c
C\Usershwvagrant\Desktophsource\zlibl211\zlib-1.211%erc32.c
C\Usershwvagrant'Desktop\source\zlib1211\zlib-1.2.11\deflate.c
C:\Users\wagrant'Desktopisourcezlib1211\zlib-1.2.11\gzclose.c
Ch\Users\wagrant'\Desktop\sourcetzlibl 211'\zlib-1.2 11\ gzlib.c
ChUsers\wagrant'\Desktop\sourcetzlibl 211\zlib-1.211\gzread c
C:\Users\wagrant\Desktop\sourcelzlib1 211'zlib-1.2 11\gzwrite.c
C\Users\wagrant'Desktop\sourcetzlib1 211\zlib-1.2 11\infback.c
Ci\Users\wagrant'\Desktop\source\zlibl 211'\zlib-1.2 11%inffast.c
Ci\Users\vagrant'Desktopisource\zlibl1211'zlib-1.211\inflate.c
C:\Usershwagrant'Desktop\source\zlib1211\zlib-1.2. 11\ inftrees.c
Ch\Users\wagrant'\Desktophsourcetzlibl 211\zlib-1.2 11\ brees.c
ChUsers\wagrant'\Desktop\sourcetzlibl 211'\zlib-1.211uncompr.c
ChUsers\wagrant'\Desktop\sourcetzlibl 211\zlib-1.2 11\zutil.c

net> [ Fnish | [ cancel

p(banner tip).If is not in absolute path Windows format, the path is not checked for validity.

3. Click the [Finish] button.
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Import RTV projects
RTV C/C++ projects can be imported in the same way as regular C/C++ project imports.

1. Click [File] -> [Import] in the main menu. In the Import Wizard, select [General] -> [Import Project]
and click [Next].

2. Click the [Browse] button to select the directory of the project to be imported. When you select a
directory, the toolchain is automatically selected from the project information to be imported. Click
the [Next] button.

* If there is no RTV server and toolchain information identical to the project to be imported,
RTV server and toolchain information is automatically generated from the project to be
imported.

3. You can check the source path included in the project to be imported. Invalid paths are marked in
red and can be modified by clicking on the path list.
4. Click the [Finish] button.

Import target project
When importing a target C/C++ project, additional target preferences must be created.

1. Click [File] -> [Import] in the main menu. In the Import Wizard, select [General] -> [Import Project]
and click [Next].

2. Click the [Browse] button to select the directory of the project to be imported. When you select a
directory, the toolchain is automatically selected from the project information to be imported. Click
the [Next] button.

3. In the case of a target project, the [Target Environment setting] window appears. The target
environment setting is loaded from the project information to be imported. Items with invalid paths
are displayed in red.
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p
B impor = E@=)
Target Environment Settings =
() When running the target test, it will overwrite the source code with the test code. You can run the target test

manually, or automatically by filling out the required fields on the Build/Run tab. |

b GMU Compilers » gecc b 53 » others B nodebugger Import Target Environment Settings

Settings

Analysis Mame Value

Build language c

g Toolchain Name GCC5.3 (32bit)

= Status This teelchain is supported.

: C Compiler Chgecis3.0032bit\bin\gcc.exe

System Header(C Compiler) c\gec\5.2.0032bit\bin\../lib/goc/mingw32/5.3.0/include el gech5.3.0032bi...
Library(C Compiler)
C++ Compiler Chgech5.3.0032bit\binhg+ + exe
Systemn Header(C++ Compiler) c\geci5.2.0032bkit\bin\./lib/goc/mingw32/5.3.0/include/c++;ch\geci5.3.0..
Library(C++ Compiler)

Marne:

Description:

<Back || Net> Finish

* Even if it is not a target C/C++ project, if it is a project that includes target environment
settings, the target environment setting window appears when [Import Project] is
executed.

=

Even if it contains an invalid path, you can complete the target environment setup and
proceed to the next one, but the one-click target test may not be executed.

4. Complete the target environment settings and click the [Next] button.

5. You can check the source path included in the project to be imported. Invalid paths are marked in
red and can be modified by clicking on the path list.

6. Click the [Finish] button.
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4.2. (Ver.3.2 or earlier) Guide to Share RTV
Projects

RTV projects can be easily shared because the toolchain and source file information can be fetched from
the RTV server.

The step-by-step scenario according to the usage environment is as follows, and the RTV project can be
shared when the scenario is followed.

« Project sharing scenario

« RTV server user quide
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4.2.1. Project sharing scenario

When using the [Existing Projects into Workspace]

function

1. When you create a RTV project, a RTV project directory (hereinafter referred to as RTV_A project)
is created under the Controller Tester workspace.

2. The user who wants to share the project receives the RTV_A project directory created in the
above step, and copies and pastes the RTV_A project directory into the Controller Tester
workspace path that he uses.

3. Select top-level path to the project directory to import the projects using [Import] > [General] >
[Existing Projects into Workspace] function.

. Import O *
Import Projects —— 1
Select a directory to search for existing Eclipse projects. ; ‘ff
I@ Select root directory: |F#CT3.2%6-2 | Browse... I
() Select archive file: Browse...
Projects:
Select All
Deselect all
Refrash
Copy projects into workspace
= Back Mext = Cancel

4. Information required for the project is received from the RTV server, and [the toolchain or resource
setting of the project is incorrect. If you want to reset automatically?], Click ‘Yes’ to complete the
RTV setup (RTV server and toolchain registration used when creating the project).

5. You can see that an RTV project (hereinafter RTV_A’ project) with the same name as RTV_A has
been created in the Controller Tester test navigator view.

6. Right-click the RTV_A’ project in [Test Navigator View] and perform [Reanalysis].

7. This should be done when connected to the same RTV server.
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When using the [C/C++ Project from RTV Build] function

1.

When you create an RTV project, an RTV project directory (hereinafter RTV_A project) is created
under the Controller Tester workspace.

The user who wants to share the project connects to the same RTV server where the above
project was created from Controller Tester that he uses, and registers the same RTV toolchain.
In the project creation wizard, select [C/C++ Project from RTV Build] to create an RTV project
(hereinafter RTV_A’ project).

Import the $(project folder)/.csdata/link.mk file from the RTV_A project folder in the Controller
Tester workspace and overwrite the link.mk file in the RTV_A’ project folder.

If you want to share the same test data, check the below.

* If the path where the source files are located is long, the entire source file may not be

imported properly. If the path where the source files are located is too long, make sure to
specify the CT’s global path just below the drive. (ex. C:\temp)
To modify the CT global path, open the CodeScroll.ini file in the location where the CT
package is installed and replace the default under the -g option with the new global path
to set.

1 -startup
plugins/org.eclipse.equinox.launcher 1.4.0.v20161219-1356.jar
—-launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86 64 1.1.500.v20170531-1133
-data
@nopefault

C:\temp
—vmargs

]l ohn N Wk

Q

\D

* Even if you share the same project, coverage results may differ if you create each unit

test. When you share a test, you must export the test using the [Export] > [Export Test]
feature, and then import the test you exported using the [Import] > [Import Test] feature.
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B export tests O d

Export tests
Export project's test informations.

Export path: | $(temp_folder) Search...

Unit Test
Test
Test Data

Integration Test
Test
Test Data

Stub
() Connected Stub
@ all stub

Cpticn
[] Ovenwrite existing test files without warning
[ Export only checked tests in Unit/Integration Test View.

Mext = Finish Cancel

B import tests O hd

Import tests

Import project's test informations.

Import path: | $(temp_folder)

Unit Test
Test
Test Data

Integration Test

Test
Test Diata

Stub
() Connected Stub
® all Stub

Option

[] Ovenwrite existing test files without warning

(O If the same stub exists already, it is not imported.
(® If the same stub exists, it is added as a new stub.

= Back Mext = Finish Cancel
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4.2.2. RTV server user guide

When using one RTV server

1. When RTV server has a project built using the csbuild capture function
a. Projects can be imported according to the project sharing scenario above, without the need
for additional settings.
2. When the RTV server is connected, but the server (IP/Port) information is different
a. Since server (IP/Port) information at the time of project creation is imported, existing server
information is imported and toolchain information is not imported.
b. After modifying the server information to access the existing server, import the toolchain
with the same name by importing the toolchain. At this time, the path of the tool chain used
in the project should be the same.

! Sharing of RTV projects can be difficult if you are using more than one RTV server
(same source file, tool chain, or if you want to receive and use a virtual machine file with
RTV server installed).
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5. Identifxing the Cause of a Test Error

Occasional errors occur when performing tests on CodeScroll Controller Tester. At this time, the user
can find out the cause of the test error by checking the debug information of Controller Tester.

If test execution fails

Progress Information

@ Run Test

~ 4

Cannot proceed test. Please check test envircnmentiex:DIl path).

Cancel

Debug information verification can be performed even if the test fails. When you execute the [Inspect

Debug Info] of the generated test case, the stack trace is displayed in the [Inspect Debug Info], and you
can know where the test failed.

If the result contains errors after running the test

In some cases, after performing a test in Controller Tester, error results such as Signaled and Abnormal
Exit are displayed. When you execute the [Inspect Debug Info] of the failed test case, the function call
stack trace is displayed in the [Debug Information View]. If you added a variable/expression to debug, a
list of executed variables/expressions is also displayed.

% Debug Information &2

0= 8
Test Case (test/func_test0) #1
Stack trace: List of variable/expressicn:
v b [Project: test] test run Variable/Expression Value Location
= i int # -
= func3(signed int 4 at fest1.c:42 p (testl.c: 40) 12319812 before line
= func2() at test1.c:30

= func(signed int) at test1.c12

The Stack trace indicates the order of the function calls. The location where the function was called is
recorded, and the last execution location is recorded at the top of the Stack trace.
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The List of variable/expression represents the variable/expression values executed with the test case.
The list of variables/expressions added to the entire source code can be checked in [List of Variable/
Expressiont] in the toolbar menu of [Debug Information View].

] testl.c &3 = 08
-~ N
= int test() B
{
int a, b;
a = func{@);
b = func(l); =
if (a < b) {
return g(8); =
} [==]
gl1);
a=a+ b;

while(a<@) {
a--;
h

return @;

et
4 fm ]
nomom

You can also check the variable/expression information to debug in the marker in the source code editor.
When you add a variable/expression to debug, the additional position is expressed as a marker in the
source code editor, and when you mouse over each marker, you can see the list of variables/
expressions added at that position.

If you select a test case that contains debug information, each marker displays the result of the variable/
expression executed by the test case.

The stack trace and the executed variable/expression value can be used to identify the cause of the
error in the test case that executed [Inspect Debug Info].

* For more information on adding variables/expressions to debug, see [Add Variables/
Expressions to Debug] in the CodeScroll Controller Tester document.
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6. (After Ver.3.4) Source Code Modification
and Test Reconfiguration

After designing tests source code can be modified. CodeScroll Controller Tester offers [Test
reconfiguration] feature to detect source code modifications and help reconfiguring tests affected by the
modification.

* Reflect modified source codes using [Refresh RTV Source File] feature before using
[Test reconfiguration] in case of RTV projects and RTV target projects.

Controller Tester divide source code modifications into three cases.

+ Modifying names of test or stub functions.
* Modifying names of global variables used in tests.
* Modifying names or the numbers of return type or parameter of test functions.

In cases of detectable modification by Controller Tester, refer to In Cases of Detected Modification by

Controller Tester and in cases of undetectable modification by Controller Tester, refer to In Cases of
Undetected Madification by Controller Tester.
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6.1. Run [Test Reconfigurationl

How to automatically use [Test Reconfiguration] feature

Controller Tester automatically detects following modifications.

* When differ present project information from imported project information using [Import Project]
feature.

* When differ present project information from imported test information using [Import test] feature.
* When detect source code modification after analyzing project.

When differ present project information from imported project information
using [Import Project] feature

B mport m] X
Check the paths included in the project 1
The path included in the preject is shown below. Check for invalid paths. ; // |

Path{click to edit):
D:WCT_prj_codewUpdate_MedifyWstudy sample.c

[&8 Test Reconfiguration X

g% The source code related to the test asset has been changed. Reconfiguration is
¥ required to reuse test assets
All associated test editors are closed. Would you like to continue?

Yes No

(18/18) Test Data: abc_1_test0.csv
I, | =

= Back Next > Finish Cancel
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When differ present project information from imported test information using
[Import test] feature

ﬂ mport tests O X

Import tests

Import project's test informations.

Import path: | DxwexportwUpdate_Modify_2020111717261 5%exportTest Search...

Unit Test

v | Test
[& Test Reconfiguration X

The source code related to the test asset has been changed. Reconfiguration is
required to reuse test assets.
All associated test editors are closed. Would you like to continue?

TETARIT ST

Option
Overwrite existing test files without warning
If the same stub exists already, it is not imported.
If the same stub exists, it is added as a new stub.

(18/18) Test Data: abc_1_testO.csv

. =

= Back Mext = Finish Cancel

When detect source code modification after analyzing project

You can use [Test Reconfiguration] feature when Controller Tester detects source code modification

after project analysis or reanalysis.

1. When the source codes modify, [Test Navigator] view indicates whether the change was made.
Tg Test Navigator  [5] g v = 8
w [lg Updatd Modify

& ault Module

v Lgfstudy_samplec

abc

abc_aa

apil

api

charlesFunc

exit error

]

P o OO

2. Select [Reanalyze] in project context menu or run tests to analyze the source codes.
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Tq Test Mavigator | [ & ¥ = 0O study_sample.c (b s

W '[d L:|Fu-|-|+n Rdmdif, b
v T Mew >

v Delete Delete

Rename... F2

Import...
Export...

C. E

Refresh F5

Close Project

Quality Management Tools >

I'

Run Target Test
Import Target Test Log ¥

Collect project log

Create Unit Test...
™ Run Test F11
% Rebuild and Run Test

Reanalyze
=% Delete Test Results (including coverage)

Merge Project coverage...

Froperties Alt+Enter

3. Click [Yes] button in [Test Reconfiguration] dialog, then a dialog for recofiguration appears.

M Test Reconfiguration x

@=% The source code related to the test asset has been changed. Reconfiguration is
W' required to reuse test assets.
All associated test editors are closed. Would you like to continue?

How to manually use [Test Reconfiguration] feature

If you click [No] button in [Test Reconfiguration] dialog or [Cancel] button while reconfiguration, following
two method allow to use [Test Reconfiguration] feature.

» Select [Integrity Check] in pull-down menu of unit test view.
i B v ¥ = O
Show coverage at all elements
»  Add description when duplicate test case
#0] Insert Default Values for Empty Input
[¢3  Check Integrity |

» Select [Test reconfiguration] to use [Test Reconfiguration] feature in function context menu or test
context menu of unit test view.
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> @0ut™ "

X abe Create Test

> @ abc Copy Test Ctrl+C
y api ¥ Delete Delete
> api

y cha Show Call Graph

y exi Show Centrol Flow Graph

» fib Show MC/DC

» hel

5 hel Host Output Value -> Expected Value

3 loa Target Cutput Value -= Expected Walue

’ med |Test reounﬁngatTunl

» pTe

» stu Set related file

>  tes Relevant issues settings...

» tes

5 tim g2y Import Test Data >
> @ tim .4 Export Test Data

|

Add Stub...

[ .

Select Function
Deselect Function

m=m  Generate coverage report...

* You can design a new test based on original test using [Test reconfiguration] feature.
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6.2. In Cases of Detected Modification
Automatically

When re-analyze or run the tests after modifying source codes, Controller Tester detects modifications
with integrity checker. Controller Tester divide source code modification with three cases.

* Modifying names of test or stub functions.
* Modifying names of global variables used in tests.
* Modifying name or number of return type or parameter of test functions.

Modifying names of test or stub functions

When modifying names of test or stub functions, [Function reconfiguration] dialog shows up.

{8 Function reconfiguration O %
Select the changed function
Functions that have been renamed were found. Please select the changed function. 3 4
(3 Functions are sorted according to similarity. Functions with high similarity are automatically selected.)
abe_10 I IE‘
« fibonacci_fail() » fibonacci_failure() - -
« medcEror() % medc_Emor) 1 Function name File path
+ testMe2() = testMe1() [ abc_aap D#CT_prj_codesUpdate_Modifysstudy_sample.c
timeQutFunc() O aben D:WCT_prj_codewlUpdate Modifywstudy_sample.c 2
O apit D:#CT_prj_codewUpdate_Modify#study_sample.c
O api2o D:#CT_prj_codetUpdate_Modify#study_sample.c
1 maing D:#CT_prj_codewUpdate Modifywstudy sample.c
O plest) D:WCT_prj_codewUpdate_Modify#study_sample.c
[ helperq D:#CT_prj_codewUpdate Modifywstudy sample.c
O testMel( D#CT_prj_codeUpdate_Modify#study_sample.c
O timeout() D:#CT_prj_code¥Update_Modifywstudy_sample.c
[ loadFile) D:#CT_prj_codewUpdate_Modify#study_sample.c
[0 mede_Ermor() D#CT_pr)_code#Update_Modify#study_sample.c
O stubFuncog D:WCT_prj_codewUpdate Modifywstudy sample.c
O exit_error() D#CT_pri_code#Update_Modify#study_sample.c
O charlesFuncO D:#CT_prj_codetUpdate_Modifywstudy_sample.c
[ helper_Enm2( D:WCT_prj_codewUpdate_Modifywstudy_sample.c
O testMeSecond() D:WCT_prj_codewUpdate_Modifywstudy_sample.c
[J time_out funcg D:#CT_prj_codewUpdate Modifywstudy sample.c
O fibonacci_failure() D#CT_prj_codesUpdate_Modify#study_sample.c
O oOutOfindex_error() D:#CT_prj_codewUpdate_Modifywstudy_sample.c

oK Cancel

1. Left area is a list of function that modification detected. Functions that finish reconfiguration are
marked with .
2. Left area is a list of function contained in present source code.
* It’s sorted by similarity of function name.
* Function with high similarity is connected automatically.
3. It allow to search a function name. ( *: any string, ?: any letter )

e

It show or hide functions with tests.

Modifying names of global variables used in tests

When modifying names of global variables used in tests, [Global variable reconfiguration] dialog shows
up.
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Global variables that have been renamed have been found. Please enter the changed global variable name.
(3 Please uncheck the deleted global variables.)

M\sslng global varlable 1 Enter current glnbal vanable 2
globalo

[globalo

] X
Enter the changed global variable name

{8 Global variable reconfiguration

a
Enter the changed global variable name

Global variables that have been renamed have been found. Please enter the changed global variable name
(3 Please uncheck the deleted global variables)

Missing global variable Enter current global variable
N —

1. Left areais a list of global variables that cannot find.

Uncheck check boxes when variables are deleted.
2. Right area contain text boxes for entering present global variable

* When user modify a global variable name, it shows global variable list in order of similarity

3. When user enter a valid variable, red mark in the text box disappear.

Modifying name or number of return type or parameter of test functions

When modifying name or number of return type or parameter of test functions, [Test reconfiguration]

dialog shows up.

B Test reconfiquration

Raconfigure test information

[m] ®
Refer o the previousileft) test information and set the newinight) test information. If you drag a variable from the old test and drop it on the new test. the variable is linked and the test data is automatically copled. [Connected: Green, Mot Connected: Red]
(% Variables with the sarme name tomatically connected)
|ShE mcde_Enorsigned int, signed mcde_Eorisigned int, signed .
4
% E L : Test Info (Update Madity/medeError_testd) o ixa || Test nte (Update Modity/mede_Errar_testo} e
Test Structure 1B E Test Structure 1L @B
Tesk struciure using a tree view and edit the information in the test Test structure using 2 tree view and edit the infomnation in the test
Hame n Qut A Name In o Out
Test global code Test global code
User code User coce
Global Variable Global Variable
~  Test target function ~  Test target function
~ & mede Enceizigned int, signed int) v & mede_Emorigned int, saned int)
Local Static Varlable Local Static Varisble
~  Pammeterretum ~  Parameteriretum
°a it = © mode_Emor_a - int =
o b ik = e b:int ¥
& c:int E " retumivar : Int =]
o d - int =i Before call code
o returmivar : ik = After call code
Betore call code P User code
Test Info Edit Test Info Edit
Set the number format edit the partiticn. B [Manzge the stub items added to test
Bae [ Namg Description | [aca wew st
Decimal i |
Add Stub,
iable Partition s
add 3
Test Info| Test Case | Test Code | Configuration Test info | Test Case| Test Code| Configuration
Finkh Cancel

1. A list of modified functions.

2. Test information about function before modifying.

 If a variable connect to test information after modifying, it's displayed in green and if not, it's

displayed in red.

3. Test information about function after modifying.

* When select a variable of function before modifying, it shows connected variable with

selected variable.

* When drag a variable of function before modifying and drop to a variable of function after

modifying, test data are copied.
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api1(signed int. signed Int, f...|

‘api1(signed int, char, float, ..|
Test Info (Update_ Modify/api1_test0)

4 iz || Test Info (Update Modify/api1_test1)

(=T
Test Structure Q@B Test Structure. amB
Test structure using a tree view and edit the in the test. Test structure using a tree view and edit the information in the test
Name In out A Name In  Out A
~  Test target function v Test target function
~ & apil(signed int, signed int, float, unsigned leng, long deuble) ~ @ apit(signed int, char, float, unsigned long, leng double)
Local Static Varizble

Local Static Variable

v Parameter/retum o Parameter/return

RS o aplin it
e b:int © b : char
© c : float © c : float
© d - unsigned long =) © d : unsigned lang
© e : long double © e : long double
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6.3. In Cases of Undetected Modification
Automatically

Controller Tester cannot detect following types of modification with integrity check.

* Modify value type of global variable.
o Test build error ( when implicit type conversion is unable )
o Test run error ( runtime error including memory overflow, etc )
* Modify symbols excluding global variables.
> Modify lower type of parameters, symbol added with macro by user, static variable, etc.
+ Side effect by modifying function position
o error that test cannot access to global variable
* Modify build stubs.

When modify value type of global variable, symbols excluding global variables, and function position,

user reconfigures test using [Test reconfiguration] feature. When modify build stubs, user delete build
stubs because build stubs are not target of integrity check.
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