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1. Source Code Modification and Test
Reconfiguration
After designing tests source code can be modified. CT 2023.12 offers [Test reconfiguration] feature to
detect source code modifications and help reconfiguring tests affected by the modification.

CT 2023.12 divide source code modifications into four cases.

• Modifying names of classes used in tests.
• Modifying names of test or stub functions.
• Modifying names or type of global variables used in tests.
• Modifying names of member functions used in class codes.
• Modifying names or the numbers of return type or parameter of test functions.
• Modifying the code of the target function to be injected with the fault.

In cases of detectable modification by Controller Tester, refer to In Cases of Detected Modification
Automatically and in cases of undetectable modification by CT 2023.12, refer to In Cases of Undetected
Modification Automatically.

Reflect modified source codes using [Refresh RTV Source File] feature before using
[Test reconfiguration] in case of RTV projects and RTV target projects.*
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1.1. Run [Test Reconfiguration]

How to automatically use [Test Reconfiguration] feature
CT 2023.12 automatically detects following modifications.

• When differ present project information from imported project information using [Import Project]
feature.

• When differ present project information from imported test information using [Import test] feature.
• When detect source code modification after analyzing project.
• When analyze the project after writing the fault injection code in a location where fault injection is

not possible.

When differ present project information from imported project information
using [Import Project] feature
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When differ present project information from imported test information using
[Import test] feature

When detect source code modification after analyzing project

You can use [Test Reconfiguration] feature when CT 2023.12 detects source code modification after
project analysis or reanalysis.

1. When the source codes modify, the Test Navigator View indicates whether the change was made.

2. Select [Reanalyze] in project context menu or run tests to analyze the source codes.

Suresofttech User Guides - 2023.12_en

Page 8 of 177



3. Click [Yes] button in [Test Reconfiguration] dialog, then a dialog for recofiguration appears.

When analyze the project after writing the fault injection code in a location
where fault injection is not possible

When reanalyzing the project, if there is fault injection information that satisfies the condition below, the
Reconfiguring Fault Injection dialog appears.

• When activate a line in a location where the fault cannot be injected and write fault injection code.

In the Reconfiguring Fault Injection dialog, you can see where faults cannot be injected and fault
injection information.
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The Reconfiguring Fault Injection dialog allows you to reuse fault injection information previously written.

How to manually use [Test Reconfiguration] feature
If you click [No] button in [Class Reconfiguration] dialog or [Cancel] button while reconfiguration,
following method allows to use [Class Reconfiguration] feature.

• Select [Class Reconfiguration] from the pull-down menu in the [Class Factory View].

If you click [No] button in [Test Reconfiguration] dialog or [Cancel] button while reconfiguration, following
three method allow to use [Test Reconfiguration] feature.

• Select [Integrity Check] in pull-down menu of the Unit Test View.

• Select [Test reconfiguration] to use [Test Reconfiguration] feature in function context menu or test
context menu of the Unit Test View.
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• You can run Reconfiguring Fault Injection from the context menu or from the pull-down menu in
the Fault Injection View.

◦ Use the Reconfiguring Fault Injection feature in the menu at the top right of the Fault
Injection View.

◦ The Fault Injection View marks fault injection functions that need reconfiguring with a
reconfiguration-required status marker . Reconfiguring Fault Injection can be executed by
double-clicking or right-clicking on the fault injection function that needs to be reconfigured.

You can design a new test based on original test using [Test reconfiguration] feature.*

Suresofttech User Guides - 2023.12_en

Page 11 of 177



The fault injection information cannot be modified where the fault injection function with
reconfiguration-required status marker.

!
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1.2. In Cases of Detected Modification
Automatically
When re-analyze or run the tests after modifying source codes, CT 2023.12 detects modifications with
integrity checker. The types of source code changes that CT 2023.12 detects are:

• Modifying names of classes used in tests
• Modifying names of test or stub functions.
• Modifying names or type of global variables used in tests.
• Modifying names of member functions used in class codes
• Modifying name or number of return type or parameter of test functions.
• Modifying the code of the target function to be injected with the fault.

Modifying names of classes used in tests

When modifying names of classes used in tests, the Class Reconfiguration dialog shows up.

1. The left area displays a list of classes where changes have been detected. Functions that have
been successfully configured will be marked with .

2. The right area displays the list of classes in the current source code:
• The classes are sorted based on the similarity of their names.
• Classes with high similarity are automatically linked.

3. It allows to search a class name. ( *: any string, ?: any letter )

Modifying names of test or stub functions

When modifying names of test or stub functions, the Function Reconfiguration dialog shows up.
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1. Left area is a list of function that modification detected. Functions that finish reconfiguration are
marked with .

2. Left area is a list of function contained in present source code.
• It’s sorted by similarity of function name.
• Function with high similarity is connected automatically.

3. It allow to search a function name. ( *: any string, ?: any letter )
4. It show or hide functions with tests.

Modifying names or type of global variables used in tests

When modifying names or type of global variables used in tests, the Global Variable Reconfiguration
dialog shows up.

1. Left area is a list of global variables that cannot find.
• Uncheck check boxes when variables are deleted.

2. Right area contain text boxes for entering present global variable.
• When user modify a global variable name, it shows global variable list in order of similarity.

3. When user enter a valid variable, red mark in the text box disappear.

Suresofttech User Guides - 2023.12_en

Page 14 of 177



• If many global variables with similar names, such as member variables of a structure, have been
changed, you can use the [Change all variables with the same name] feature to modify the global
variable names at the same time. If the [Change all variables with the same name] checkbox is
checked and the name of a global variable is modified, the name of a global variable with a similar
name is modified at the same time. If you uncheck the checkbox, you can edit the names of global
variables individually.

Modifying names of member functions used in class codes

When modifying names of member functions used in class codes, the Class Code Reconfiguration dialog
shows up.

Suresofttech User Guides - 2023.12_en
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1. In the left area, the classes that need to be reconfigured are displayed in a tree format.
• The classes and class codes are structured as a parent-child tree.
• The number next to each class represents (the number of class codes confirmed by the user

/ the number of class codes to be reconfigured).
• The number next to each class code represents the count of changes and deletions in that

class code.
2. In the right area, you will see the previous class code (gray background, on the left) and the

updated new class code (white background, on the right) during the reconfiguration process.
• The previous class code cannot be modified, while the new class code can be modified.
• Functions that have been deleted or manually added are indicated with a red background.
• Functions that have been changed through the reconfiguration process are indicated with a

yellow background.
• Newly added functions are indicated with a green background.

Modifying name or number of return type or parameter of test functions

When modifying name or number of return type or parameter of test functions, the Test Reconfiguration
dialog shows up.

1. A list of modified functions.
2. Test information about function before modifying.

• If a variable connect to test information after modifying, it’s displayed in green and if not, it’s
displayed in red.

3. Test information about function after modifying.
• When select a variable of function before modifying, it shows connected variable with

selected variable.
• When drag a variable of function before modifying and drop to a variable of function after

modifying, test data are copied.
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Modifying the code of the target function to be injected with the fault

If the code of the fault injection function has changed, the Reconfiguring Fault Injection dialog appears.

The list of fault injection functions is displayed in area 1, pre-change fault injection information is
displayed in area 2, and after-change fault injection information is displayed in area 3.

• The list of fault injection functions
◦ If the checkbox is unchecked, the previous fault injection information is retained without

saving changes.
• The Fault Injection Information window

◦ Pre-change fault injection information can only be copied. You can copy by shortcut(Ctrl +
C) or right-click.

◦ After-change, the fault injection information can be modified. You can copy/paste by shortcut
(Ctrl + C / V) or right-click.

◦ Changed lines are marked with a line number in red.
◦ Double-clicking on a line selects the same line as the one selected in the other Fault

Injection Information window.
◦ The code written on the selected line can be shown in the Fault Injection Code window at

the bottom.
• The Fault Injection code window

◦ The code written before and after the selected line is displayed.
◦ Locations where fault injection is not allowed are disabled so that you cannot write code.
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If there are no tests generated in the project, or if the fault injection line is enabled but no
code is written, the Reconfiguring Fault Injection dialog does not appear.*
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1.3. In Cases of Undetected Modification
Automatically
CT 2023.12 cannot detect following types of modification with integrity check.

• Modify value type of global variable that the type is not defined with typedef.
• Test build error ( when implicit type conversion is unable )
• Test run error ( runtime error including memory overflow, etc )
• Modify symbols excluding global variables.

◦ Modify lower type of parameters, symbol added with macro by user, static variable, etc.
• Side effect by modifying function position

◦ error that test cannot access to global variable
• Modify build stubs.

When modify value type of global variable, symbols excluding global variables, and function position,
user reconfigures test using [Test reconfiguration] feature. When modify build stubs, user delete build
stubs because build stubs are not target of integrity check.
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2. Collaboration Guide
Here’s how to share work and results when multiple people collaborate using CT 2023.12.

• Team Testing Usage Guide
• Sharing Projects with Other Users
• Guides to Import Coverages
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2.1. Team Testing Usage Guide

What is Team Testing?
As time goes by, the scale of software is increasing. With the expansion of software, the scale of testing
also grows. Conversely, update cycles are getting shorter, reducing the time available for testing,
necessitating more tests in less time.

Team Testing is a method that multiple individuals test a single piece of software. There are several
issues with Team Testing. First, it’s challenging to share test environments and test cases with others.
Second, users create duplicately testing resources like stubs, class codes, etc. Third, merging test
results is difficult. Additionally, integrating and rerunning the entire test on one PC to verify the final
results adds further complexities.

CT 2023.12 responds to these changes by offering Team Testing capabilities to conduct more tests in
less time. Team Testing Server is the server created for CT 2023.12 to provide this feature. During a
project, Team Testing Server syncs project configurations among users, enabling sharing of stubs and
class codes. Furthermore, it merges test results each time a test is run, displaying them on a dashboard.
Users can use the dashboard to monitor project progress at a glance.

In essence, CT 2023.12 is a client where each user conducts tests. Team Testing Server stores and
manages projects for sharing among users. The dashboard is a web page presenting project information
and progress stored in Team Testing Server.
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Terminology
Below are the terms used in CT 2023.12’s team testing:

• Team Project: A project exported to Team Testing Server for collaboration among different users.
• Shared Resources:

◦ Configurations that comprise a project, including project properties, preferences, source
code, toolchains, as well as resources like stubs and class codes connected to testing.

◦ Automatically shared among users.
• Test Resources:

◦ Resources necessary for testing, such as tests, test data, etc.
◦ Not automatically shared among users; if sharing is needed, they must be imported from

Team Testing Server.
• Local: The CT (client) where the user works.
• Team Testing Server: Where the work of all users is merged.
• Commit: The action of reflecting changes made in local onto Team Testing Server.
• Update: The action of importing changes made by other users to the local system.
• Conflict: When updating resources modified and committed by other users, if there are also local

changes, it’s referred to as a conflict.
• Revision:

◦ Modification record in Team Testing Server.
◦ Increases when a user commits, changing the version of team project.
◦ Starts at 1 upon project creation and increases by 1 with each commit.
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Team Project Process
The team project can be broadly divided into 3 stages:

1. Project Initialization
• Creating the team project and modifying project configurations to suit the testing

environment.
• Each user imports the team project to their individual PC and collaborates on a shared

project.

2. Test Progression
• Tests are carried out through commits and updates.
• Users receive notifications if there are changes in shared resources, allowing them to

update.
• If changes in source code make the tests unusable, a re-analysis and test reconfiguration

occur.
• Resolving conflicts during the update process is necessary before proceeding with tests.

3. Test Result Merge
• Test results are merged in Team Testing Server and can be monitored in real-time on the

dashboard.
• If you need to run the entire test or output the report, import all the tests to one PC and

output the report.

In addition, it also provides On/Offline Mode feature in case the connection to Team Testing Server is
unstable.
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2.1.1. Project Initialization
Using team projects, users can share project environments with others. There are two ways to create a
team project. The first is to create a new team project. The second is to convert an existing project into a
team project. It’s possible to migrate a project used in previous versions to CT 2023.12 and convert it
into a team project.

Create and Share a Team Project
1. Connect to Team Testing Server from a single PC to create a team project. Refer to the [Creating

a team project]. page in the manual for this process

2. Configure the team project to suit the testing environment. Complete toolchain settings and
necessary configurations for testing. Then commit the changes to Team Testing Server.

3. Import and use the team project on another person’s PC.

Convert to a Team Project
1. Right-click on the project to convert it into a team project.

https://www.youtube.com/embed/Enyc5AFeTho?rel=0
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2. If the settings for this project are incomplete, complete the project settings and then commit the
changes.

3. Import and use the team project on another person’s PC.
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2.1.2. Commit and Update
After multiple users share the team project, testing will be conducted. During the testing process,
changes made on the local PC need to be exported to Team Testing Server or changes from Team
Testing Server need to be imported into the local PC. Exporting changes from the local PC to Team
Testing Server is referred to as commit, and importing changes from Team Testing Server into the local
PC is called update.

Commit

Commit refers to applying the local PC’s work to Team Testing Server. The applied work gets shared
with other users. Committing with different revisions between Team Testing Server and the local can
revert or overwrite other users’ changes. When committing, the revisions on Team Testing Server and
the local must be the same. If the local’s revision is lower than Team Testing Server, an update should
be performed before committing.

Users can commit in two ways:

1. After running tests, commit changes along with the test results (auto-commit).
2. Users can manually commit.

• When users commit manually, they can verify the contents to be committed in the commit
dialog.
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Update

Update refers to import the work from Team Testing Server to the local PC. During an update,
encountering resources to be imported from Team Testing Server that have already been modified
locally is termed a conflict. When conflicts arise, they are resolved in the update dialog before updating.

The update process is as follows:

1. Check and update revisions between Team Testing Server and the local.
2. Review resources to be updated in the update dialog. Depending on the resource type, different

comparison viewers might be shown the update dialog multiple times.
• Resources managed in JSON or XML formats, such as project properties or toolchains, can

be checked for update content through text comparison.
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• Code-based resources like stubs or class code are checked for update content through
source code comparison.

• The resources managed by the DB, such as requirement traceability, compare the data in
the DB in text format to check for updates.

• For fault injections, the update content is reviewed in a form similar to Fault Injection view.
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• For tests, the update content is reviewed in a test editor format.

3. Resolving conflicts can be done in two ways:
• Save as server version

◦ Select the (Copy all from server to local) icon to copy the version from Team
Testing Server to the local. Copying from Team Testing Server to the local overwrites
local changes with Team Testing Server version, and local changes cannot be
modified. The (cancel copy) icon can revert the copied version back to its original
state.

• Manually resolve by editing
◦ Without copying the version from Team Testing Server, the user directly edits the

local version. Referring to the current local and Team Testing Server versions, the
user saves the version they’ve edited. When users resolve conflicts manually, they
should select the (mark as resolved) icon to indicate the resolution of the conflict
for that resource.

4. When all conflicts are resolved, the [OK] button becomes active. Clicking [OK] proceeds with the
update.

5. Depending on the type of updated resources, reanalysis might be necessary after the update.

During team testing, update notifications are provided to keep the local version up-to-date. Besides
update alerts, users are informed of the necessity for an update if Team Testing Server and the local
have different revisions when committing.
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Modify shared resources
Modifying shared resources like stubs or class codes can alter the results of connected tests. When
committing the changed resources, the results of the test in Team Testing Server will be unreliable, and
the results of the test connected with those resources will be deleted from Team Testing Server. In such
cases, the project’s coverage might decrease.

void func() {
if( returnNum() == 1 ) {

/* ... */
} else {

/* ... */
}

}

Creating a stub for returnNum() in the above code and connecting it to a test for void func() can
affect coverage based on the return value of returnNum() stub. When modifying shared resources
connected to tests, the linked tests should be rerun. Committing modified resources leads to the deletion
of execution results of tests connected with those resources from Team Testing Server. Tests with
deleted results are managed as ‘need-to-rerun test’. During an update, if there are need-to-rerun tests,
they are marked with ! in the [Unit/Integration Test] view. Rerunning need-to-rerun will commit new
results and remove the ! marker.
When modifying shared resources and automatically committing after running the connected tests, the
executed tests are not managed as need-to-rerun tests since new test results have been committed.

Reference Videos
Here are videos you can refer to regarding commit/update/conflict:

• A video demonstrating the creation of stubs, executing tests for automatic committing, and
updating committed stubs from another PC.
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• This video showcases manual commit after modifying source code and updates via update
notifications on another PC.

https://www.youtube.com/embed/77Dpg8CYoeo?rel=0
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• A video demonstrating the process of modifying user stubs, committing changes, and resolving
conflicts arising during updates.

https://www.youtube.com/embed/k6801k-71BQ?rel=0
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https://www.youtube.com/embed/67QPhrysG5k?rel=0
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2.1.3. Test Result Merge
After all tests for the team project are completed, it’s necessary to merge the results. There are two ways
to check the aggregated results. The first is to check them on the dashboard. When running tests for the
team project, Team Testing Server merges the results of all tests and displays them on the dashboard.
The second is to generate reports for checking. Currently, CT 2023.12 does not provide report
generation from Team Testing Server, so all tests must be gathered on one PC to generate a report.

Dashboard
You can view the results merged on Team Testing Server in a summary from the dashboard.

Report Generation
You can inport all tests onto a single PC and generate reports for those tests.

1. Use [Import Team Test] feature to import tests from Team Testing Server.
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2. Since importing team tests doesn’t bring test results, all tests need to be run again.
3. Use [Generate test report] feature to create a report for the project.
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2.1.4. On/Offline Mode
When testing in an environment where Team Testing Server is offline or the network connectivity is
unstable, it can be inconvenient due to the connection retry dialog. In such cases, you can switch the
project to offline mode for usage.

To prevent repeated dialog for connection retry in a unstable network connection, you can disconnect
from Team Testing Server and operate in offline mode. Toggle between online and offline modes in
[Properties] > [Team Testing] > [On/Offline].

In offline mode, you cannot perform tasks that require connection with Team Testing Server, such as
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committing or updating. In essence, running tests in offline mode does not commit the results. Once the
connection with Team Testing Server become stable, you can switch back to online mode. When switch
to online mode, resource names are synchronized to prevent overlaps with server resources.
Additionally, an update is carried out to match the latest revision from Team Testing Server. To ensure
your local resources stay up-to-date, always perform an update before continuing your work.

As offline mode doesn’t synchronize with Team Testing Server, it’s advisable to use it for
the shortest time possible.*
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2.2. Sharing Projects with Other Users
You can share the CT projects with others.
Controller Tester 3.3 or later uses [Export Project] and [Import Project] functions.

• Guide to Share Projects
• Guide to Share RTV Projects
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2.2.1. (Ver.3.3 or later) Guide to Share
Projects
From Controller Tester 3.3, you can easily share a project with the [Export Project] and [Import Project]
functions.

• Export project
• Import project
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2.2.1.1. Export project
You can export projects, including project setup and testing.

1. On the main menu, click [File] > [Export]. The Export Wizard opens.

2. Click [General] > [Export Project].

3. After selecting the project to export and the path to export, click the [Finish] button.
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• (Ver.3.7 or later) When you export a project, you can export it including the toolchain and
source files.

4. You can see that there is a folder containing the exported project name in the exported path.
Compress the folder and move it to the computer of the user you want to share.
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2.2.1.2. Import project
Using the Import Project function, you can import a project exported from another PC into the
workspace.

Import general C/C++ Project
1. Click [File] > [Import] in the main menu. The Import Wizard opens.

2. Click [General] > [Import Project] and then click the [Next] button.
3. Click the [Browse] button to find the directory corresponding to the exported project.
4. When you select a directory, the toolchain is automatically selected from the project information to

be imported. If a project with the same name already exists in the workspace, you need to modify
the project name.
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• (After Ver.3.7) If the directory contains a toolchain or source codes, its options are checked
automatically.

5. Click the [Next] button.
6. You can check the source path included in the project to be imported. Invalid paths are marked in

red and can be modified by clicking on the path window.

If there is no toolchain with the same name as the toolchain of the project to be
imported, you must first export and then import the toolchain of the project to be
imported. For details, see [Import Toolchain] and [Export Toolchain] in User Manual.
*
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7. If there is an invalid path, modifying one file path automatically modifies the associated file path.
At this time, you can check the number of modified routes at the top.

If is not in absolute path Windows format, the path is not checked for validity.*
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8. Click the [Finish] button.

Import RTV projects
RTV C/C++ projects can be imported in the same way as regular C/C++ project imports.

1. Click [File] -> [Import] in the main menu. In the Import Wizard, select [General] -> [Import Project]
and click [Next].

2. Click the [Browse] button to select the directory of the project to be imported. When you select a
directory, the toolchain is automatically selected from the project information to be imported. Click
the [Next] button.

3. You can check the source path included in the project to be imported. Invalid paths are marked in
red and can be modified by clicking on the path list.

4. Click the [Finish] button.

Import target project
When importing a target C/C++ project, additional target preferences must be created.

1. Click [File] -> [Import] in the main menu. In the Import Wizard, select [General] -> [Import Project]
and click [Next].

2. Click the [Browse] button to select the directory of the project to be imported. When you select a
directory, the toolchain is automatically selected from the project information to be imported. Click
the [Next] button.

3. In the case of a target project, the [Target Environment setting] window appears. The target
environment setting is loaded from the project information to be imported. Items with invalid paths
are displayed in red.

If there is no RTV server and toolchain information identical to the project to be imported,
RTV server and toolchain information is automatically generated from the project to be
imported.
*
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4. Complete the target environment settings and click the [Next] button.
5. You can check the source path included in the project to be imported. Invalid paths are marked in

red and can be modified by clicking on the path list.
6. Click the [Finish] button.

Even if it is not a target C/C++ project, if it is a project that includes target environment
settings, the target environment setting window appears when [Import Project] is
executed.
*

Even if it contains an invalid path, you can complete the target environment setup and
proceed to the next one, but the one-click target test may not be executed.

!
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2.2.2. (Ver.3.2 or earlier) Guide to Share RTV
Projects
RTV projects can be easily shared because the toolchain and source file information can be fetched from
the RTV server.
The step-by-step scenario according to the usage environment is as follows, and the RTV project can be
shared when the scenario is followed.

• Project sharing scenario
• RTV server user guide
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2.2.2.1. Project sharing scenario

When using the [Existing Projects into Workspace]
function

1. When you create a RTV project, a RTV project directory (hereinafter referred to as RTV_A project)
is created under the CT workspace.

2. The user who wants to share the project receives the RTV_A project directory created in the
above step, and copies and pastes the RTV_A project directory into the CT workspace path that
he uses.

3. Select top-level path to the project directory to import the projects using [Import] > [General] >
[Existing Projects into Workspace] function.

4. Information required for the project is received from the RTV server, and [the toolchain or resource
setting of the project is incorrect. If you want to reset automatically?], Click ‘Yes’ to complete the
RTV setup (RTV server and toolchain registration used when creating the project).

5. You can see that an RTV project (hereinafter RTV_A’ project) with the same name as RTV_A has
been created in the CT test navigator view.

6. Right-click the RTV_A’ project in [Test Navigator View] and perform [Reanalysis].
7. This should be done when connected to the same RTV server.
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When using the [C/C++ Project from RTV Build] function
1. When you create an RTV project, an RTV project directory (hereinafter RTV_A project) is created

under the CT workspace.
2. The user who wants to share the project connects to the same RTV server where the above

project was created from CT that he uses, and registers the same RTV toolchain.
3. In the project creation wizard, select [C/C++ Project from RTV Build] to create an RTV project

(hereinafter RTV_A’ project).
4. Import the $(project folder)/.csdata/link.mk file from the RTV_A project folder in the CT workspace

and overwrite the link.mk file in the RTV_A’ project folder.
5. If you want to share the same test data, check the below.

If the path where the source files are located is long, the entire source file may not be
imported properly. If the path where the source files are located is too long, make sure to
specify the CT’s global path just below the drive. (ex. C:\temp)
To modify the CT global path, open the CodeScroll.ini file in the location where the CT
package is installed and replace the default under the -g option with the new global path
to set.

*

Even if you share the same project, coverage results may differ if you create each unit
test. When you share a test, you must export the test using the [Export] > [Export Test]
feature, and then import the test you exported using the [Import] > [Import Test] feature.
*
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2.2.2.2. RTV server user guide

When using one RTV server
1. When RTV server has a project built using the csbuild capture function

a. Projects can be imported according to the project sharing scenario above, without the need
for additional settings.

2. When the RTV server is connected, but the server (IP/Port) information is different
a. Since server (IP/Port) information at the time of project creation is imported, existing server

information is imported and toolchain information is not imported.
b. After modifying the server information to access the existing server, import the toolchain

with the same name by importing the toolchain. At this time, the path of the tool chain used
in the project should be the same.

Sharing of RTV projects can be difficult if you are using more than one RTV server
(same source file, tool chain, or if you want to receive and use a virtual machine file with
RTV server installed).

!
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2.3. Guides to Import Coverages
When importing coverages from CT 2023.12 in another environment or COVER, these are imported by
the following three criteria. If the criteria are not met, coverage imports may fail.

• version of coverage shared file
• ternary operation option
• coverage type

Suresofttech User Guides - 2023.12_en

Page 52 of 177



2.3.1. Import Coverages by Version
When CT 2023.12 import coverages, it checks the version of the coverage shared file.

• When importing the higher-versioned coverage shared file, the coverage cannot be imported.

• When importing the lower-versioned coverage shared file, importing the coverages for some
functions may fail depending on the option of the tool that exported coverages.

Suresofttech User Guides - 2023.12_en

Page 53 of 177



2.3.2. Import Coverages by Conditional
Operation Option
When the conditional operation option of CT 2023.12 differs from the tool that exported the coverage
shared files, the coverages cannot be imported.

Click the link in the warning window or [Preferences] > [Test] > [Coverage] > Branch coverage, MC/DC
measurement operator]. Then, change the [Conditional Operator(?:)] option to match the file you want to
import.

• When [Toolchains] > [Standard] in COVER is [COVER] > [Branch], turn off the [Conditional
Operator(?:)] option.

• When [Toolchains] > [Standard] in COVER is [COVER] > [MC/DC], turn on the [Conditional
Operator(?:)] option.

When changing the option, run the tests again after [Reanalyze].!
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2.3.3. Import Coverages by Coverage Type
After Controller Tester 3.6, users can import coverages when coverage types are different.

When selecting [Yes], statement/branch coverages are imported except MC/DC. When selecting [No],
coverages are not imported.
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3. Scenario(Time-based) Test Usage Guide
During the requirement testing, you may come across the following requirement.

When the door of the car, which was open, closes, the interior light stays on
for 5 seconds and then turns off.

When there is a timer function for this, this timer function should be repeatedly called at set intervals to
check whether the interior light turns off after 5 seconds.

There are situations where you need to test functions that are called periodically. After CT 2023.12, a
scenario testing feature has been introduced to support these types of tests.

Conditions for Scenario Testing
To convert a normal test into a scenario test, all of the following conditions must be met.

• C Project
• The test target functions must only have functions with void return type and no parameters

Convert to Scenario Test
In [Test Editor] > [Test Info Tab] > [Test target function], select [Convert to Scenario test] to convert to a
scenario test.

Scenario tests maintain the test case context. That is, it runs the next test case while maintaining the
state of the previous test case.

Once converted to a scenario test, it cannot be reverted back to a normal test.*
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Scenario Test

Two variables are added to assist with scenario testing.

• Duration
◦ You can enter values in [Test Case Tab].
◦ It determines the number of iterations of the for loop for each test case.

• Total Duration
◦ It shows the cumulative number of repetitions of the for loop in the test case.

Among the test target fucntions, two settings are added to the cycle function:

• Start time
◦ This is the time at which the function calls start.
◦ If the start time is 40, the function won’t be called when the total duration is between 0 and

39.
• Cycle time

◦ This is the time interval for repeating function calls.
◦ If the period time is 10, the function will be called when the total duration is 10, 20, 30, and

so on.

Below is an illustration to help understanding the scenario testing concept.
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The cycle unit can be set in ms, μs, or ns. This value is only displayed in the test report and test editor,
not affecting the actual execution time. Therefore, even if the cycle unit is set to ms and the total
duration is 5000, it won’t be executed for an actual 5 seconds. Scenario testing simulates this time for
running tests.

Test Code of Scenario Test
Based on the settings in [Test Info Tab], the test code is generated as follows:
The initial function is a function that is called only once before iterating through a for loop, and it’s
initially invoked in the first test case. After that, it isn’t called in any other test cases.

/* Declaration (parameter/return/target object) variables */
unsigned int CS_TC_SPENT_TIME = 0;  // Stores the Duration input value.
static unsigned int CS_TOTAL_SPENT_TIME = 0; // Stores the number of repetitio
ns of test cases. The value of this variable is stored as the output of Total
Duration.

/* Input */
CS_TC_SPENT_TIME = CS_INT_INPUT(unsigned int, "CS_TC_SPENT_TIME");

/* Call initial function */
if (CS_TOTAL_SPENT_TIME == 0) {

// Position where initial function is added
}

// Where cycle functions are repeated. Loops for the Duration input value.
for (int CS_CYCLE_INDEX = 0; CS_CYCLE_INDEX < CS_TC_SPENT_TIME; CS_CYCLE_INDE
X++) {

if ((CS_TOTAL_SPENT_TIME >= 0) && ((CS_TOTAL_SPENT_TIME - 0) % 10 == 0)) {

/* TASK_1ms() */
TASK_1ms();
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}
CS_TOTAL_SPENT_TIME++;

}

/* Output */
CS_INT_OUTPUT(CS_TOTAL_SPENT_TIME, "CS_TOTAL_SPENT_TIME");

Examples
You can fulfill various requirements by using scenario testing.

• Check for changes in specific variables during a scenario test run
• Determine whether to call a function based on the value of the global variable
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3.1. Check for changes in specific variables
during a scenario test run
Divide the test cases to check when running a scenario test to verify the value of a specific variable
during the test run. For instance, in a test where the cycle unit is ms, if we want to check the changes in
a specific variable at 2 and 4 seconds, we design the test cases as follows:

Test Case (TC) Duration Total Duration

1 1999 1999

2 1 2000

3 1999 3999

4 1 4000

Check the value change before/after 2 seconds through TC3 and TC4 and check the value change
before/after 4 seconds through TC3 and TC4.

By dividing the test cases in this way, we can check desired values at specific time. We will explain it in
detail with a simple example.

Source Code and Requirement
The source code and requirement to be used as an example are as follows.

#include <stdio.h>
#include <stdbool.h>

typedef enum {
CLOSED, OPEN

} OpenCloseState;

typedef enum {
OFF, ON

} OnOffState;

OpenCloseState doorState;
OpenCloseState doorSensor;
OnOffState ignitionState;
OnOffState lightState;

void initial() {
doorState = OPEN;
doorSensor = OPEN;

Suresofttech User Guides - 2023.12_en

Page 60 of 177



ignitionState = OFF;
lightState = OFF;

}

void lightOn() { if (lightState != ON)     lightState = ON; }

void lightOff() { if (lightState != OFF)     lightState = OFF; }

void setDoorSensor(OpenCloseState sensor) {
doorSensor = sensor;

}

void tick() {
static int timer = 0;

if (doorState == OPEN && doorSensor == CLOSED) {
timer = 500;
lightOn();

} else if (ignitionState == ON){
timer = 0;
lightOff();

}

if (timer > 0)     timer--;

if (timer == 0)     lightOff();

doorState = doorSensor;
}

Requirement: When the door of the car, which was open, closes, the interior li
ght stays on for 5 seconds and then turns off.

Test Design
We will design a test that meets these requirements.

h3 Design of Cycle Function and Cycle Unit

Using The indoor light turns off after being on for 5 seconds and timer = 500;, it
can be understood that the time unit of the timer is ms, and the function “@tick()@” is called every 10ms.
Therefore, set “@tick()@” as the cycle function, the cycle unit as ms, the start time of “@tick()@” as 0,
and the cycle time as 10.

h3 Design of Initial Function
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The initial() function initializes each sensor and state. Both doorState and doorSensor are
initially set to OPEN. To satisfy the requirement When the door of the car, which was open, c
loses, set the parameter value in the setDoorSensor() function to CLOSED.

h3 Design of Test Cases and Scenario Variable (Time)

To verify the requirement, check the output value of lightState. The interior light should remain on for
5 seconds and then turn off. This means that lightState remains ON until the 499th call of tick(),
and lightState changes to OFF on the 500th call. To check this, set the time to 4990 for the first test
case and 10 for the second test case. Select lightState in the global variable, check [Output], run the
test, and verify the value of lightState.

Write Test
Based on the above design, writing tests will look like the following:

• [Test Info Tab]

• [Test Case Tab]
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Checking Test Results
Run the test and verify the results in [Test Case Tab].

During 0ms to 4990ms, the lightState is ON(1), and when it reaches 5000ms, the lightState
changes to OFF(0). By using scenario testing, it has been confirmed that the source code meets the
requirements.
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3.2. Determine whether to call a function
based on the value of the global variable
When the value of the global variable determines whether a function is called, it is tested using [Before/
Atfer call code].

// Before call code
if( globalVar == 1 ) {
// Function call code.
func()
// After call code
}

In this way, add an if statement in the code before and after the function call to invoke the function when
specific conditions are met. I’ll explain in detail using examples of traffic lights and sound signals.

Source Code and Requirements
The source code and requirements to be used as an example are as follows.

#include <stdio.h>

typedef enum {
RED,
GREEN

} TrafficLightState;

typedef enum {
ON,
OFF

} SoundSystemState;

TrafficLightState trafficLight;
SoundSystemState soundSystem;

void init() {
trafficLight = GREEN;
soundSystem = OFF;

}

void setSoundSystem (SoundSystemState state) {
soundSystem = state;

}
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void alarmForBlind() {
if( trafficLight == GREEN ) {

printf("beep for blind\n");
} else if( trafficLight == RED ) {

printf("warning for blind\n");
}

}

void tick() {
static int timer = 50;

if(timer > 0) {
timer--;

}

if( timer == 0 ) {
timer = 50;
if( trafficLight == GREEN ) {

trafficLight = RED;
} else if( trafficLight == RED ) {

trafficLight = GREEN;
}

}
}

Requirement: The red and green lights are each on for 5 minutes.
If the sound signal is on and the traffic light is green, a signal for visuall
y impaired individuals is output once per second.
If the sound signal is on and the traffic light is red, a warning for visuall
y impaired individuals is output once per second.

Test Design
We will design a test that meets these requirements.

h3 Design of Cycle Function and Cycle Unit

In the tick() function, the timer of the traffic light is set to 50, and as per the requirement, each light
stays on for 5 seconds. Therefore, the cycle unit is ms, and the cycle time for tick() is 100ms.
Since the sound signal outputs a signal every 1 second, the cycle time for alarmForBlind() is
1000ms (1 second).

h3 Design of Initial Function

Call the initial() function as an initial function to assign initial values to each sensor and state. At
this point, the initial value of trafficLight is GREEN and the initial value of soundSystem is OFF.

Suresofttech User Guides - 2023.12_en

Page 65 of 177



h3 Design of Test Cases and Variables

To verify the requirements, we’ll turn on the sound signal and check signals when the light is blue or red.
Accordingly, we’ll design the test cases as follows:

TC Time Sound Signal

1 5000 OFF

2 5000 OFF

3 5000 ON

4 5000 ON

5 5000 OFF

6 5000 OFF

To change the sound signal value, input the following into the user code. When the test case is 3, turn
on the sound signal, and when the test case is 5, turn it off.

if (CS_TESTCASENO()==3) {
setSoundSystem(ON);

} else if (CS_TESTCASENO()==5) {
setSoundSystem(OFF);

}

Select trafficLight from the global variables and check [Output] to confirm the status of the traffic
light.

Write Test
Based on the above design, writing tests will look like the following:

• [Test Info Tab] > [User code]

• [Test Info Tab] > [Test target function]
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• [Test Info Tab] > [Before/After call code]

Checking Test Results
Run the test and verify the results in [Test Case Tab] and [Source Code Editor].

• In [Test Case Tab], confirm that trafficLight changes every 5 seconds.
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• Use the coverage displayed in [Source Code Editor] to confirm that the signal rang in test case #3
and the warning sounded in test case #4.
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4. C++ Test Guide
Here’s how to test C++ using CT 2023.12.

• Guides for C++ Test Using the Class Factory View
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4.1. Guides for C++ Test Using the Class
Factory View

Purpose of using class factories
When testing C++ source code, it is difficult to test because abstract classes cannot create objects.
Class factories can facilitate testing of abstract classes and reduce the iterations that occur when
designing class objects.

The main features of class factories
• Automatically create concrete classes that inherits from an abstract class
• Minimize repetitive tasks by applying them to tests all together

Utilizing class factories
This document explains the basic concepts for testing C++ before using class factories. After that, it
explains how to utilize class factories.

• Basic Concept for C++ Test
• Using the Object Creation Code of Abstract Class for Testing
• Design C++ Tests Using Class Factory
• Using Mock Objects in C++ Test
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4.1.1. Basic Concept for C++ Test
It outlines the basic concepts needed before testing C++ using the Class Factory View.

Pure virtual functions and abstract classes
Pure virtual functions

• Virtual function with declaration but no definition .
• Displayed as = 0.
• Virtual function implemented in derived class .

Abstract classes

• Classes that have pure virtual functions as members.
• Abstract classes cannot create objects.

◦ Declare a variable as a pointer or reference type.
▪ ex. AbstractClass * class1;.

• Support for polymorphism in object-oriented programming.
• Classes that inherit from an abstract class must override pure virtual functions.

◦ If a derived class that inherits from an abstract class does not override a pure virtual
function, the derived class is also an abstract class.

class Abstract {
virtual void f() = 0; // pure virtual

}; // "Abstract" is abstract

class Concrete : Abstract {
void f() override {} // non-pure virtual
virtual void g();     // non-pure virtual

}; // "Concrete" is non-abstract

class Abstract2 : Concrete {
void g() override = 0; // pure virtual overrider

}; // "Abstract2" is abstract

int main()
{

// Abstract a; // Error: abstract class
Concrete b; // OK
Abstract& a = b; // OK to reference abstract base
a.f(); // virtual dispatch to Concrete::f()
// Abstract2 a2; // Error: abstract class (final overrider of g() is p

ure)
}
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4.1.2. Using the Object Creation Code of
Abstract Class for Testing
When analyzing the source code, the object creation code of the concrete class that inherits the abstract
class is automatically generated in the class factory so that the object of the abstract class can be
created. In the object creation code of the abstract class, a framework for the concrete class is provided
so that the user can easily create the concrete class.

When creating a test, if a concrete class that inherits that abstract class exists in the source code, that
class is linked with the test, and if the concrete class does not exist, the object creation code in the class
factory is linked.

You can apply different types of abstract classes to your tests by adding object creation code.
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4.1.3. Design C++ Tests Using Class Factory
After Controller Tester 3.5, you can use class factories for most classes, not just abstract classes.

Advantages of Controller Tester 3.5 Class Factory

Class factories can be used to reduce simple repetitive tasks.

• Class objects that get external data
◦ Database, external input/output, server, and so on.

• In the case of class objects that need to be designed in a complex way in the Test Editor, but the
same should be used for multiple tests.

How to create and apply an object using a class factory

1. Right-click the class in the Class Factory View and use [Create] to create the class object creation
code.

2. Modify the class object creation code according to the test design.
3. Apply the class object creation code to the tests.

• Apply all together
• Apply individually
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4.1.4. Using Mock Objects in C++ Test

Purpose of using mock objects
When testing C++ source code, it is sometimes difficult to test because it costs much to create the actual
object or the test depends on the object a lot. In such cases, using a mock object that mimics the real
object can effectively reduce dependencies on the object. Additionally, you can generate specifications,
such as the expected number of calls of the mock to verify that the object is being used as intended.

Available toolchians
• GCC 6.0 or later
• Visual Studio 2015 and later

The main features of a mock object
• Setting return parameters and return values of a mock object
• Setting call count for mock object
• Checking whether the calls occured in a specific order
• Adding constraints to parameters
• etc

Mock object usage
This article explains how to use mock objects in C++ tests.

• Creating mock objects
• Generate specifications about mock objects
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4.1.4.1. Creating mock objects

Creating mock objects
1. Open [Test Editor], by double-clicking the test for which to create a mock object.
2. In the [Test Info tab], expand the test structure tree and select the object to create a mock.
3. Select [Use mock] at the constructor in the test information edit area on the right.
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4.1.4.2. Generate specifications about mock
objects

Generate specifications about mock objects automatically.
1. In the Test Information tab, click the mock object that you created.
2. In the Test Info Edit area on the right, Click [Generate Sepcification Wizard…] button.

• If specification about the mock object is empty, [Generation mock specification] wizard
automatically appears when you click the mock object.

3. In [Generation mock specification] wizard, select the target function to specify and click [OK]
button.

4. Edit parameters, return values, and repetitions.

• Click [Edit parameters] button to create a specification of the parameters used by the
function.
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◦ Selecting [any value] does not restrict the value of that parameter.
◦ You can restrict parameter values through [< User input… >]. For example, when you

type 1 in the input value and run tests, the test fails if the parameter is not 1.
• Click [Edit return value] button to determine the return value of the function.

◦ Select [Add] button to add the value to return when the function is called.
◦ Select [Remove] button to remove the last added return value.
◦ If you specify one return value, it will be returned repeatedly.
◦ When multiple return values are specify, the function returns them in order when

called. In this case, the test fails if the function is not called by the corresponding
number of return values.

• Click [Edit repetitions] button to create a specification of the number of calls to that function.
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◦ If you select [No number of repetitions specified], you do not restrict the number of
calls.

◦ Use [< User input… >] to limit the number of function calls. For example, if you set the
number of function calls to 3 and run a test, the test fails if the function is not called 3
times.

◦ [No function call] is the same as specifying a zero number of calls. In this case, the
test fails when the function is called.

5. Click [OK] button to generate a specification.

Generate specifications about the mock object yourself
You can modify the specifications created by [Generate Sepcification Wizard…] on Controller Tester or
create various specifications yourself. See this document for more information.

To set the return value and the repetitions at the same time, you must write it directly in
the Test Editor, referring to the specification you created in [Generation mock
specification] wizard.

!
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5. CI/CD Environment and CLI Guide
Here’s how to test in CI/CD environment or in using CLI.

• CT Jenkins plugin Usage Guide
• CLI Guide
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5.1. CT Jenkins plugin Usage Guide
CT Jenkins plugin is an extension for continuous integration and continuous deployment (CI/CD) of the
CT 2023.12 project. By automating tests of CT 2023.12, you can manage your team or organization’s
development process more efficiently.

Requirements

1. CT

You must install CT version 2023.12 or higher.

2. Jenkins

For instructions on installing Jenkins, refer to the Jenkins documentation. (Installing Jenkins)

3. CT Jenkins plugin

• Install with hpi file
1. Select and deploy the ct-jenkins-plugin.hpi file in the Deploy plugin item in Manage Jenkins

> Plugins > Advanced settings.
2. Once installation is complete, you can see that the CT environment item has been added to

the build environment, and the CT test execution and CT custom command items have been
added to Build Steps.

Build Environment settings
Set up the CT execution environment in Manage Jenkins > System > CT (Controller Tester).
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5.1.1. Creating Freestyle Project
In a Freestyle project, you can configure the project by adding a build environment and build steps.
There are two build step options: CT test execution and CT custom command, and it is recommended to
use only one of the two build steps to configure the project.

Build Steps – CT test execution

Project Settings

Set the project you want CT Jenkins plugin to test.

• General Project
◦ For general project, you must enter the path to project exported from CT.
◦ When exporting a project, you must include the source code and toolchain.

• Team Project
◦ For team project, you must enter the team project name that exists on the Team Testing

Server.
◦ Team project must be analyzed.

Source Code Settings

Source code settings are used when regression test with a specific branch in the Git repository.
The source code setting synchronizes the source code of the project selected above based on the top-
level path to the source code in the Git repository.
You can check CT test results for source code that changes with this setting in a CI/CD environment.
If the option is not selected, the test is performed using the source code of the project selected above.
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Test Settings

Set test execution options.

• Self-healing (Auto Recovery)
◦ CT Jenkins plugin automatically performs an integrity check and selects reconfiguration

candidates and execute tests.
◦ Self-healing runs until all tests succeed or until the number of retries is reached.

• Executing Tests in Linux
Select if it is an RTV Project that requires RTV testing.

Report Settings

Select the format in which you want to generate the resulting report.

Build Steps – CT custom command
This is a build step that allows the user to set workspace and CT CLI settings without using the CT test
execution build step.
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For detailed usage instructions and issues, please contact us through the technical support contact
information at the bottom of manual’s troubleshooting page.
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5.1.2. Creating Pipeline Project
In a pipeline project, you can configure the project by writing a Pipeline script.

Build Script Settings
We recommend using the Snippet Generator in Pipeline Syntax to create pipeline scripts.
You can create a script by selecting the build environment setting step (ctEnvironment) and the CT test
execution step (ctTestExecution) in the Snippet Generator, and the ctTestExecution step must be
included within the ctEnvironment step.

Post-build Actions
In the case of pipeline projects, post-build actions are not added automatically, so they should be added
separately.
Post-build actions can also be created using the Snippet Generator, and the steps that can be added are
as follows.

Archive the artifacts

Select archiveArtifacts in Sample Step and enter the following.
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• Files to archive: ct/report/TestReport*.*, self-healing/**

Check coverage results

Select ctCoverageReport in Sample Step and enter the following.

• Path to xml files: ct/report/Jenkins/CoverageResult.xml

Check test results

Select xUnit.Net-v2 in Sample Step and enter the following.
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• Report Type: xUnit.Net-v2 (default)
• Includes Pattern: ct/report/Jenkins/TestResult.xml

Script example
A complete example script based on the above is as follows:
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5.1.3. Check the result
This explains how to check the results after executing a CT Jenkins plugin project.

Project main screen
You can check test results and code coverage trends on the right side of the main screen.
You can check the test report and result files for each self-healing trial in the last successful artifact.

Build details
By clicking on a specific build in the build history, you can view detailed information about that build.
You can check the results collected in that build, coverage summary, and test results.

Suresofttech User Guides - 2023.12_en

Page 89 of 177



Coverage report

You can check the coverage trend graph in more detail by clicking the Coverage Report item on the left
sidebar.
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Test results

You can check the test results in more detail by clicking the Test Result item in the left sidebar.
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5.2. CLI Guide
The scenario explains using CT 2023.12 features by utilizing the Command Line Interface.

• CLI Project Path Reset
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5.2.1. CLI Project Path Reset
If the source code path during export is different from the source code path when importing, an error
occurs as shown below.

In this case, you can specify a new path through mapping while importing the project in the CLI. The
mapping method is as follows.

1. When you export a project, a PathMappingFile.csv file will be created in the specified directory.
2. Edit the PathMappingFile.csv file.

• Old Path: This is the path specified during the project export process.
• New Path: This is the path to be used during the import process.
• status: Indicates the status of the path.

◦ If the file path is normal: “OK”
◦ If the existing [Old Path] is invalid and no [New Path] has been entered: “The old path

is invalid. Please enter a new path.”
◦ In case the entered [New Path] does not exist: “The new path you entered is not valid.

Please check the new path.”
◦ In cases where source code is included in the export : “This project contains source

files. Do not enter new path If you import with source files.”
a. If the paths on the exporting PC and the importing PC are the same, leave the [New Path]

column empty.

b. If the code paths on the exporting PC and the importing PC are different, add the path to be
used on the importing PC in the [New Path] column.
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3. Apply the PathMappingFile.csv using the —mapping-file option when importing the project.
• Example : -e -w "%workSpacePath%" --import -O "--path '%Project path%'
--mapping-file '%PathMappingFile.csv path% --include-tch'"

4. After the command is executed, the results for each path can be checked in the
PathMappingFile.csv file.
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6. Test in Real Target Environments
Here’s how to test in real target environments using CT 2023.12.

• Target Test Guides
• Debugger User Guides
• Target Build Guide
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6.1. Target Test Guides
This user guides document describes how to execute target tests using CT 2023.12.

• Texas Instruments Code Composer Studio
• STM32cubeIDE
• Wind River Workbench
• Wind River Workbench
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6.1.1. Texas Instruments Code Composer
Studio

1. Creat a CT 2023.12 project.

2. Select a created Code Composer Studio toolchain.

3. Select source files to test.
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4. When finish the settings, click [Finish] button to create the project.

5. To use debuggers, set up in Code Composer Studio and CT 2023.12. For more information, refer
to Texas Instruments Code Composer Studio, a sub-topic of Controller Tester Debugger User
Guides in this document.
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6.1.2. STM32cubeIDE
This document describes how to perform target testing using STM32cubeIDE for STM32 family targets.

The application example environment is as follows, and ST-Link debugger is used.

Target test application and execution order
1. Setting Target environment

- On [right click on project] -> [properties] -> [Target test] -> [Target environment Setting], Just fill out the
Property Analysis tab and close it after applying. The target test document is a manual build method, so
other tabs do not affect the test.

2. Execute test case unit with [Run Target Test Case]
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- For accurate testing, run them in test cases.

- If you go through steps 1 and 2, the project of CT 2023.12 will be locked as above.
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3. Clean and build the project in STM32cubeIDE

- Clean the exported source in STM32cubeIDE and build it.

4.Debug in STM32cubeIDE

- If the build is successful, run debug.

5. Execute after setting a break point in return 0;
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- The starting point of the code is main in cs_tfx.c. Put a break point before ‘return 0;’, which is the point
at which testrun(); ends.

6. Check the log in the ct_target_log expression view

- In the expression view, click Add new expression to add an array containing the log (ct_target_log).
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- You can check the contents of ct_target_log as above.

7. Check if it ends with CSET# (whether or not a normal test is performed)

- When the last part of the log ends with CSET#, it can be judged that the test ended normally.
Therefore, you can check once whether the test is running normally in the expression view.

8. Add ct_target_log to monitor memory in memory view
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- Add ct_target_log by clicking ‘+’ to Monitors in memory view for memory dump.

9. Export from memory view to log path of CT 2023.12 project / Check if the file is normally created in
the path

- Click the export button in the memory view to download the memory of ct_target_log to a file.
- Format is RAW Binary, Start address is the start address of ct_target_log of expression view, and
Length specifies the array size of ct_target_log. (Even if the length of the log is shorter than Length, it
does not affect the test.)
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- Check if the file is normally created in the specified path.

10. Restoring source file from CT 2023.12

- Restore the source file from CT 2023.12 to get the target test log.

11. Import Target Test Log -> Import from Log File
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- Click [Import Target Test Log] -> [Import from Log File]

- Import the file created in step 9.
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- You can confirm that the test case was successfully executed and the coverage was measured.
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6.1.3. Wind River Workbench
This document describes how to perform target testing using Wind River Workbench IDE in the VxWorks
6.9 target execution environment.

The application example environment is as follows, and the log interface uses TCP socket
communication.

Target test application and execution order

1. Setting Target environment

As this guide is a target test guide, it is assumed that project creation and analysis have
been completed.*
Problems that occur in each process of the guide document can be resolved through
Controller Tester Target Plug-in Troubleshooting Guide

!
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• On [right click on project] -> [properties] -> [Target test] -> [Target environment Setting], Just fill in
the log interface of the Run tab, apply and close. The environment covered in this document is a
manual build and run method, so the other tabs do not affect testing. The source below is the log
interface applied to the example environment (VxWorks 6.9).

//Do not modify this header file.
#include "cs_tfx_types.h"

//Below is an example.

#define AF_INET        2
#define SOCK_STREAM 1
#define htons(x) (x)

struct in_addr {
unsigned int s_addr;

};

struct sockaddr_in {
unsigned char sin_len;
unsigned char sin_family;
unsigned short sin_port;
struct in_addr sin_addr;
char sin_zero[8];

};

int sock;
struct sockaddr_in addr;

//This function called at test start.
void cs_io_initialize()
{
sock = socket(AF_INET, SOCK_STREAM, 0);
if (sock < 0)
{
printf("create socket failed\n");

}

memset (&addr, 0, sizeof(addr));
addr.sin_addr.s_addr = inet_addr("211.116.222.180"); // IP address of the PC

where the CT 2023.12 is installed
addr.sin_port = htons(2019); // The port to be used by the target log collect

or
addr.sin_family = AF_INET;
addr.sin_len = sizeof(addr);

if ((connect(sock, (struct sockaddr_in *)&addr, sizeof(addr))) < 0) {
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printf("connect failed");
}
else
printf("connected to server!\n");

printf("Controller Tester Init End!!!!\n");
}

//This function called at test end.
void cs_io_finalize()
{
//Close socket.
close(sock);

}

void cs_io_flush()
{

}

//This function prints the test result
void cs_io_putbyte(char v)
{
//Send the target test result.
printf("%c",v);
send(sock, &v, 1, 0);

}

2. Target Test Execution
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• For accurate testing, execute the test case unit by using the [Run Target Test Case] menu. You
can test multiple test cases or functions at once, if memory is available.

• Project in CT 2023.12 will be locked when the target test is executed.

3. Build
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• Rebuild Project the exported code in Wind River Workbench IDE.

4. Target log collector settings

• Set the target log collector according to the port created in the log interface and run it.
• The target log collector is installed in %appdata%\CodeScroll\TargetLogCollector\

TargetLogCollector.exe.
• The first time you run the target log collector in cmd, %appdata%\CodeScroll\TargetLogCollector\

setting.ini is created. You can configure the target log collector with this file.
• The example below is the target log collector setting according to the log interface example.

[LogReceiveServer]
; TCP, UDP server port
port=2019
; tcp, udp, uart or serial
protocol=tcp
; timeout(second)
timeout=60
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lastString=CSET#
; serial(UART) port (Windows: COM#, Linux: /dev/ttyS#)
serialPort=COM1
; serial port setting
baudRate=9600
dataBits=8
stopBits=1
parity=0
flowControl=0

[ScanLog]
; log directory(default: scan/log)
dir=
; log file extension(if empty, scan everything)
fileExtension=log
; begin character when filtering the string of log (ascii code with value sepa
rator ;)
beginCharacter=4;5;6
; end character when filtering the string of log (ascii code with value separa
tor ; , 10 is LF)
endCharacter=10

[LogSendServer]
; send log to Controller Tester
port=2020

5. Setting the target log collector for CT 2023.12

• In CT 2023.12, in [Preferences] -> [Target Test] -> [Target Log Collector], select Use the default
target log collector and turn on auto-detect.
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6. Run binary on target

• Move the built binary to VxWorks OS and put it on the target to run it.

7. Restore source from CT 2023.12

• Restore the source from CT 2023.12 to get the target test log.

8. Get target test log

• The created log is automatically loaded according to the set Auto-detect cycle.
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6.2. Debugger User Guides
This user guides document describes how to use debugger when executing CT 2023.12 target test.

• Lauterbach TRACE32
• PLS Universal Debug Engine
• iSYSTEM winIDEA Debugger
• IAR Embedded Workbench C-SPY Debugger
• Texas Instruments Code Composer Studio
• Microchip MPLAB IDE
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6.2.1. Lauterbach TRACE32
CT 2023.12 can target test using the TRACE32 debugger.
CT 2023.12 uses TRACE32’s cmm script to run tests in the target environment and get the results.
A list of targets supported by TRACE32 can be found on the Lauterbach homepage.

• Supported target list that can generate cmm script automatically
• Step1: Setting target environment in CT
• Step2: Run the target test
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6.2.1.1. Supported target list that can
generate cmm script automatically
CT 2023.12 automatically generates a cmm script file or receives it from the user.
If the cmm script can be generated automatically, you only need to enter the chip name of the target. If
you cannot generate cmm scripts automatically, you must enter the cmm script file path manually.
The targets that currently support the automatic generation of cmm scripts are:

PowerPC

mpc5554, mpc5553, mpc5534, mpc556x, mpc551x, mpc560xe, spc560bxx, spc560pxx,
spc560sxx, mpc560xb, mpc560xp, mpc560xs, spc563m54, mpc5632m, spc563m60,
mpc5633m, spc563m64, mpc5634m, mpc564xs, mpc5668, mpc5674, mpc5644a, spc564a80,
mpc5642a, spc564a70, mpc567xk, spc56hk, mpc5643l, spc56el60, spc56el70, mpc5644b,
mpc5644c, spc564b64, spc56ec64, mpc5645b, spc564b70, mpc5645c, spc56ec70, mpc5646b,
spc564b74, mpc5646c, spc56ec74, mpc5676r, spc56ap, mpc5746m, mpc5744k, spc574k74,
mpc5777m, spc57hm90, mpc574xp, mpc574xg, mpc574xr, mpc577xk, mpc5777c, spc570s,
mpc5726l, spc572l, spc574s, spc58ne, spc58eg, spc58nn, spc582b, spc58ec, spc58nh,
spc584b, s32r274, s32r264, s32r372

ARM

mkw01, mkw20, mkv30, mkv40, mkv10, mkv50, mkm30, mkl0, mkl10, mkl20, mkl30, mkl40,
mkl80, mk0, mk10, mk20, mk30, mk40, mk50, mk60, mk70, mk80, mac57d54h, mac71×1,
mac71×2, mac71×4, mac71×5, mac71×6, mac72×1, lpc51u68, lpc54xx, lpc8xx, lpc11xx,
lpc12xx, lpc13xx, lpc17xx, lpc18xx, lpc21xx, lpc22xx, lpc23xx, lpc24xx, lpc28xx, lpc29xx,
lpc40xx, lpc43xx, imxrt1064, xmc1100, xmc1200, xmc1300, xmc1400, xmc4100, xmc4200,
xmc4300, xmc4400, xmc4500, xmc4700, xmc4800, tle98, s3fm02g, s32k, s6e1a, s6e1c, s6j3

tricore
tc2dx, tc21x, tc22x, tc23x, tc26x, tc27x, tc29x, tc35x, tc37x, tc38x, tc39x, tc116x, tx1167,
tx1197, tc1724, tc1728, tc1736, tc1762, tc1764, tc1766, tc1767, tc1782, tc1784, tc1791, tc1792,
tc1793, tc1796, tc1797, tc1798
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6.2.1.2. Step1: Setting target environment in
CT
Select Debugger on the target environment setting page of the CT 2023.12. Only a list of debuggers
supported is displayed, depending on the toolchain selected for the project.
Set the debugger to TRACE32.

The setting items are displayed according to the selected information. The items you need to set when
using the TRACE32 debugger are shown in the table below.
Some of the settings are required.

trace32_exe_file_path
TRACE32 executable file path. Each target has a different
executable file, so you need to make sure that the target
executable is the correct one. Required

target_binary_path
Path to the binary file for loading into the target environment.
Check and enter the path where the target binary file is created in
your IDE or build script. Required.

chip
Enter the chip name of the target you are using. It is used when
auto-generating a cmm script, so you need to enter the correct chip
name.

user_defined_cmm_script_file_path

Custom cmm script file path. For targets that do not support
automatic generation of cmm scripts, you must write a script to set
the debugger and target usage environment, or enter the path to
the cmm script file you are using.
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6.2.1.3. Step2: Run the target test
You must exit the running TRACE32 program before running the target test.
You can run a target test by selecting [Run Target Test] from the project context menu in the Test
Navigator view or by clicking the [Run] button in the Test View.

• [Run Target Test]

• [Run]

When you run the target test, the TRACE32 program runs. If the test is succeeded, the
TRACE32 program ends automatically.*
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6.2.1.4. Debug the target test
1. After setting it as a target, right-click the test case in the ‘Unit Test’ view and click ‘Check Debug

Information’
2. Build the user project directly or execute the build script registered in the ‘target environment’

setting in the controller tester project
3. Verify that the build was successful
4. Restore the original source by opening the project in CT
5. After running Trace32, open the cmm script file (start.cmm) and execute ‘debug’

(CT_project_path/.csdata/target/start.cmm)
6. Click the ‘step’ button to go to the first line of the target.cmm script
7. Add breakpoint to ‘Go.Hll’ in target.cmm file
8. Click ‘Var’ > ‘Show Function’
9. Double-click after searching for the function to be tested

10. Add breakpoint at the beginning of the function
11. Click the ‘step’ button and confirm that the debugging point moves to the location specified in step

10.
12. ‘Var’ > ‘Show Local…’ . Click to confirm that the value of the local variable changes
13. Run up to the debugging point
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6.2.2. PLS Universal Debug Engine (UDE)
CT 2023.12 can target test using the UDE debugger.
CT 2023.12 uses debugging scripts supported by UDE to run tests and get results in the target
environment.
A list of targets available for connection to UDE can be found on the PLS homepage.

CT 2023.12 uses the UDE workspace information to perform target tests. For this reason, users must
first create a workspace before performing a target test.

• Step1: Create a workspace in UDE IDE
• Step2: Setting target environment in CT
• Step3: Run the target test
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6.2.2.1. Step1: Create a workspace in UDE
IDE
UDE can generate UDE workspaces from the UDE desktop IDE.

1. Create the workspace by selecting the configuration file suitable for the target used.

2. Click the [File]> [Load Program] button to load the binary file. At this point, select the binary file
built from the test code.
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3. Follow the instructions and press the [program] button to load the binary file into the target
according to the target settings. If the load completes successfully, the workspace setup is
complete. Click [Exit] to exit the dialog.

See the manual provided by UDE for details.
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6.2.2.2. Step2: Setting target environment in
CT
Select Debugger on the Target Environment configuration page of the CT 2023.12. Only a list of
debuggers supported is displayed, depending on the toolchain selected for the project.
Set the debugger to UDE.

The setting items are displayed according to the selected information. The items you need to set when
using the UDE debugger are shown in the table below.
Some of the settings are required.

target_binary_path
Path to the binary file for loading into the target environment. Check and enter the
path where the target binary file is created in your IDE or build script. Required.

ude_project_file Path to the workspace project file (.wsx) generated by the UDE IDE. Required.

The default scripting language used by CT 2023.12 is visual basic script.
When the target configuration is complete, click the [OK] or [Finish] button. You are ready to execute the
target test.
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6.2.2.3. Step3: Run the target test
You must have exited the UDE desktop IDE to run the target test.
You can run a target test by selecting [Run Target Test] from the project context menu in the Test
Navigator view or by clicking the [Run] button in the Test View.

• [Run Target Test]

• [Run]

UDE debugging scripts can be written in languages such as C ++, .NET, and Perl. See
the UDE Automation Basics documentation included in the UDE manuals for other
supported languages that can be scripted.
*
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6.2.2.4. Debug the target test
1. After setting it as a target, right-click the test case in the ‘Unit Test’ view and click ‘Check Debug

Information’
2. Build the user project directly or execute the build script registered in the ‘target environment’

setting in the CT project
3. Verify that the build was successful
4. Restore the original source by opening the project in CT
5. Select project after executing Pls Ude (.wsx file)
6. Select the output file built in step.2
7. Notice that the source file and function information contained in the output file are displayed on the

left navigation.
8. Select a source file containing the function to be tested and add breakpoints in the function
9. Press F5 to start from the entry point

Suresofttech User Guides - 2023.12_en

Page 126 of 177



6.2.3. iSYSTEM winIDEA Debugger
CT 2023.12 provides the ability to run tests on your target environment and get results from it
automatically by using winIDEA debugging scripts.
The list of targets supported by winIDEA can be found on the iSYSTEM home page.

The execution of the debugging script requires the python SDK installed together when installing
winIDEA. If it is not installed, you can download it from the iSYSTEM SDK installation page. Also, you
should check the version of winIDEA you use if it supports the SDK. The debugging script provided by
Controller Tester is based on python 3.3.

This document describes the process from creating a project in winIDEA to running a target test in CT
2023.12. The iSYSTEM BlueBox iC5000 Unit debugger and NXP’s MPC56xx target are used for the
examples.

• Preparation for use of iSYSTEM winIDEA
• Step1: Creating and setting up a winIDEA workspace
• Step2: Setting target environment in CT
• Step3: Run the target test
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6.2.3.1. Preparation for use of iSYSTEM
winIDEA
Target testing with winIDEA in CT 2023.12 requires a debugger that winIDEA supports.
Before running the target test, you need to create a winIDEA workspace and connect the debugger for
use to the PC with CT 2023.12.
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6.2.3.2. Step1: Creating and setting up a
winIDEA workspace

1. After running winIDEA, create a new workspace by selecting [File]> [Workspace]> [New
Workspace …] from the top menu. Additional workspace settings are required to use the
workspace you create for the CT 2023.12 target test.

2. First, go to the top menu, select [Hardware]> [Hardware…], and then select the type of the
connected BlueBox in the [Hardware Type] tab.
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3. Next, set the communication method in the [Communication] tab, and press the [Test] button to
check the connection to the debugger. Please refer to the iSYSTEM BlueBox manual for
instructions on how to connect the debugger device depending on the communication method.

4. Click [Hardware]> [Use Software Breakpoints] on the top menu to activate it, and then select the
target type to use in the [CPU] of [Hardware]> [Emulation Options…].
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5. After the debugger setup is complete, you need to register the binary path of the software under
test in the workspace. First, build the source code under test to generate the binary. Then from
winIDEA’s top menu [Debug]> [Files for Download …], select [New…] and add the binary
generated.

The specific options you need to set for each target may vary.*

Suresofttech User Guides - 2023.12_en

Page 131 of 177



6. When everything is set up, save the workspace to create a winIDEA workspace file (.xjrf). The
workspace file is used to configure the target test using winIDEA in Controller Tester.
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You are now finished creating the winIDEA workspace for the target test.
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6.2.3.3. Step2: Setting target environment in
CT
Select a debugger in the [New Project] wizard of the target test project or [Target environment settings]
of the project properties on CT 2023.12. The list of selectable debuggers depends on the toolchain
selected for the project.
Set the debugger to BlueBox.

The fields to be set are displayed according to the selection. If you are using BlueBox, the fields are
shown in the table below.
Required fields are displayed in red in CT 2023.12.

winidea_binary_path The winIDEA execution file(winIDEA.exe) path. Required.

winidea_workspace_file_path The path of the workspace file (.xjrf) created by winIDEA. Required.

The default scripting language provided by Controller Tester is python. If you use a custom debugging
script, you need to write it in python to work properly. If you write in other languages, refer to the
iSYSTEM homepage to install additional SDKs.

When the target environment settings are complete, click the [OK] or [Finish] button. Now you are ready
to run the target test.
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6.2.3.4. Step3: Run the target test
You can run a target test by selecting [Run Target Test] from the project context menu in the Test
Navigator view or by clicking the [Run] button in the Test View.

• [Run Target Test]

• [Run]

Target tests cannot be run if winIDEA is running. You must exit winIDEA before running
the target test in CT 2023.12.*
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6.2.3.5. Debug the target test
1. After setting it as a target, right-click the test case in the ‘Unit Test’ view and click ‘Check Debug

Information’
2. Build the user project directly or execute the build script registered in the ‘target environment’

setting in the CT project
3. Verify that the build was successful
4. Restore the original source by opening the project in CT
5. After running winIDEA, select the workspace containing the built project (.xjrf file)
6. Download to binary file target by selecting [Debug]> [Download]
7. Debugging mode by pressing the Run button at the top
8. Double-click [Project]> [Functions], move to the function location, and set the debugging point

where you want
9. Press F5 to proceed debugging
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6.2.4. IAR Embedded Workbench C-SPY
Debugger
CT 2023.12 provides the ability to automatically run tests and get results in the target environment
through the IAR Embedded Workbench C-SPY debugging function.
The list of targets supported by C-SPY can be found on the IAR website.

To test a target with the IAR Embedded Workbench C-SPY in the CT 2023.12, you need a C-SPY
compatible debugging probe. You need to create an IAR Embedded Workbench project and connect the
debugging probe to be used with the PC where CT 2023.12 is installed before performing the target test.

The list of debugging probes provided by IAR can be found on the homepage.

• Step1: Creating an IAR embedded workbench project
• Step2: Setting an IAR project
• Step3: Setting target environment in CT
• Step4: Run the target test
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6.2.4.1. Step1: Creating an IAR embedded
workbench project

1. Click [File]> [New Workspace] to create a new workspace and then click [Project]> [Create New
Project…] to create a project file (.ewp). When a project file created, the project name is displayed
in the [Workspace] view of the IAR Embedded Workbench.

2. Next, you need to add the source files under test to the project. Right-click on the project, click
[Add]> [Add Files… ] and add the source files to be tested. The added source files are displayed in
a hierarchical structure in [Workspace] view.
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6.2.4.2. Step2: Setting an IAR project
If you created a project, you need to configure the project to use the C-SPY debugging feature. Right-
click on the created project and select [Options …].

1. First, set [Processor variant] in [General Options]. For example, for ARM’s STM32F429IG target,
select Device and select a name that matches the target from the target list on the right.

2. Second, go to the category [Debugger] and select the debugging probe you want to use in the
[Driver] field. Set the details in the Debugging Probe section at the bottom of the [Debugger]
category, depending on how the selected debugging probe and PC are connected.
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3. If I-jet is selected, select [I-jet] at the bottom of the [Debugger] category to set details. For a
description of each setting tab, refer to the IAR debugger manual you want to use.
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Now you are done creating and setting the IAR project for target testing.
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6.2.4.3. Step3: Setting target environment in
CT
Select a debugger in the [New Project] wizard of the target test project or [Target environment settings]
of the project properties on CT 2023.12. The list of selectable debuggers depends on the toolchain
selected for the project.
When creating a project using the IAR toolchain, the debugger must be set to ide to use the IAR C-SPY
debugging feature.

The fields to be set are displayed according to the selection. The fields for C-SPY are as shown in the
table below.
Required fields are displayed in red in CT 2023.12.

cspy_debug_general_xcl_file_path

The path to the debug.general.xcl file required when using the IAR
Embedded Workbench C-SPY debugger. When creating an IAR
project, the project file (.ewp) is automatically created in the [setting]
folder in the saved location. Required.

cspy_debug_driver_xcl_file_path

Path to the debug.driver.xcl file required when using the IAR
Embedded Workbench C-SPY debugger. When creating an IAR
project, the project file (.ewp) is automatically created in the [setting]
folder in the saved location. Required.

When the target environment settings are complete, click the [OK] or [Finish] button. Now you are ready
to run the target test.
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6.2.4.4. Step4: Run the target test
You can run a target test by selecting [Run Target Test] from the project context menu in the Test
Navigator view or by clicking the [Run] button in the Test View.

• [Run Target Test]

• [Run]
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6.2.4.5. Debug the target test
1. After setting it as a target, right-click the test case in the ‘Unit Test’ view and click ‘Check Debug

Information’
2. Build the user project directly or execute the build script registered in the ‘target environment’

setting in the CT project
3. Verify that the build was successful
4. After IAR Workbench run, select the workspace containing the built project (.eww file)
5. Select the source file with the function to be tested in the workspace view, and click the left side of

the line to add the debugging point
6. Right-click the project in the workspace view and open ‘Options …’ to check the Run to option

check in the Debugger item and check that it is designated as ‘main’
7. Click the Download and Debug button at the top to start from main
8. Press F5 to proceed to the debugging point to debug
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6.2.5. Texas Instruments Code Composer
Studio (CCS v4 and later)
CT 2023.12 can run target tests using the Code Composer Studio debugger. Controller Tester uses
debugging scripts supported by Code Composer Studio (since version 4.x) to run the tests in target
environment and get results. Check the Code Composer Studio manual for a list of debugging devices
you can connect to and use with Code Composer Studio.

This document describes how to use Code Composer Studio debugger with following three steps.

• Step1: Create a project in Code Composer Studio
• Step2 : Setting target environment in CT
• Step3: Run the target test

The example uses Spectrum Digital’s XDS560v2 as a debugger and Texas Instruments’ TMS320 as
target device.
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6.2.5.1. Step1: Create a project in Code
Composer Studio

1. Run Code Composer Studio and create a new project. Select [File]-[New] from the top menu and
select the desired project type. In this case, click [CCS Project] to create a project. After entering
the target and debugger information used, click [Verify] to confirm that the connection is
successful.

2. After verifying the debugger and target connections, enter the remaining settings. The example
uses the C2000 Ti compiler. When you click [Finish], the CCS project is created in the workspace.
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Code Composer Studio supports several more debuggers in addition to the built-in debuggers from
Texas Instruments.

1. TI XDS USB (Code Composer Studio default)
2. BlackHawk JTAG emulator
3. Spectrum digital
4. MSP430 USB
5. MSP432 USB
6. Tiva/Stellaris ICDI

CT 2023.12 controls the debugger supported by Code Composer Studio with javascript. You can select
the target and debugger details from the Project Settings screen in Code Composer Studio.
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6.2.5.2. Step2 : Setting target environment in
CT

1. Creat a CT 2023.12 project. For more information to create the project, refer to Texas Instruments
Code Composer Studio in this document.

2. Right-click on the project in test navigator view and select [Properties] – [Target test] – [Target
environment settings]. You can set up target environment in [Target environment settings]. Setting
fields and the list of selectable debuggers depend on the toolchain selected for the project.

3. Select a debugger in [Target environment settings] of CT 2023.12. This example selects IDE
debugger to use Code Composer Studio debugger.

4. Enter needed informations on [Build] tab of [Target environment settings] for Code Composer
Studio build. Following fields need to be filled and these are necessary.

• Fileds of [Build] tab

ide_directory_path Directory path of Code Composer Studio ex) C:\ti\ccs930

workspace Directory path of Code Composer Studio workspace

project_name Project name analyzed by CT 2023.12

5. Enter needed informations on [Run] tab of [Target environment settings] for running target tests.
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Following fields need to be filled and these are necessary.

• Fields of [Run] tab

ccxml_path
Enter a path of Code Composer Studio target configuration file. Check the
project path and target name. File name is the target name selected in
Code Composer Studio ex) project-path\targetConfig\target-name.ccxml

target_binary_path
Enter a path of binary file created during build in Code Composer Studio.
ex) project-path\Debug\project-name.out

debug_probe
Refer to front of ‘/’ in [Device] of Code Composer Studio properties and
enter a target device name. (Spectrum Digital XDS560V2 STM USB
Emulator in example shown below)

cpu_name
Refer to back part of ‘/’ in [Device] of Code Composer Studio properties
and enter a target device name. (C28xx in example shown below)

• Code Composer Studio properties
◦ Right-click Code Composer Studio project and select [Properties] – [Debug] – [Device]

When only one debugger is connected to the target, debug_probe can be left as the*
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6. After finishing target environment settings, click [Finish] button. You are ready to do target tests.

default (*). For single core cpu, you do not need to set cpu_name.
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6.2.5.3. Step3: Run the target test
Before running the target test, you should stop using the workspace where the project you want to build
is located. If you are using a workspace in the IDE, target testing does not work properly.
You can run a target test by selecting [Run Target Test] from the project context menu in the Test
Navigator view or by clicking the [Run] button in the Test View.

• [Run Target Test]

• [Run]

If Code Composer Studio is running during target test execution, a compilation error
occurs.

!

For more information on debug scripting in CCS, see the Texas Instruments home page.*
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6.2.5.4. Debug the target test
1. After setting it as a target, right-click the test case in the ‘Unit Test’ view and click ‘Check Debug

Information’.
2. Run in debugging mode in Code Composer Studio.
3. Click [File] > [Open] File in Code Composer Studio.
4. Select the source file_number.c file with the function to be debugged in the

Controller_Tester_workspace_path/.metadata/.plugins/com.codescroll.ut.embedded/project_name/
TestFixture/cs

5. Add breakpoint where you want to debug
6. Run Debug
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6.2.6. Microchip MPLAB IDE
This document describes how to run target tests using the Microchip MPLAB IDE in three steps.

• Step1: Debugger script settings
• Step2: Setting target environment in CT
• Step3: Run the target test
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6.2.6.1. Step1: Debugger script settings
In order to perform the target test in CT 2023.12, the mdb.bat file included in MPLAB must be modified
so that the log output from the debugger can be saved in a file format.
The mdb.bat file path is as follows.

For windows 32 bit

• C:\Program Files\Microchip\MPLABX\vn.nn\mplab_ide\bin\mdb.bat

For windows 64 bit

• C:\Program Files (x86)\Microchip\MPLABX\vn.nn\mplab_ide\bin\mdb.bat

Modify the code in the last line of the mdb.bat file as follows.

before modification

"%jdkhome:exe =exe%" -Dfile.encoding=UTF-8 -jar "%mdb_jar%" %1

after modification

call "%jdkhome:exe =exe%" -Dfile.encoding=UTF-8 -jar "%mdb_jar%" %1 >> %CT_TAR
GET_PATH%\mdb_log.txt

Microchip MPLAB has a Korean encoding issue, so you should not include Korean in the
CT 2023.12 workspace or project name.

!
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6.2.6.2. Step2: Setting target environment in
CT
Select the debugger in the target test project creation wizard in CT 2023.12 or in the target environment
settings in the project properties. The list of debuggers to choose from depends on the toolchain
selected when creating the project.
Set the debugger to ide.

Setting items are displayed according to the selected information.
Required fields are displayed in red in CT 2023.12.

ide_directory_path The path to the directory where Mplab ide is installed. Required.

project_directory_path The directory path of the project. Required.

make_path
The path to the make.exe file. Just enter the path to make.exe used when
building in the mplab project. Required.

target_binary_path
Binary file to be uploaded to the target (binary location generated during build).
Required.

debugger_tool
You can select the debugger tool information (select among ICD3, RealICE, PICkit3,
SIM, PM3, LicensedDebugger, LicensedProgrammer, SK). Required.

chip Product name of the chip under test (ex..dsPIC33EP512MU814). Required.

In order to perform the target tests in CT 2023.12, the mdb.bat file must be modified as in Step1.
When the target environment setting is finished, click the [OK] or [Finish] button. You are ready to
perform target testing.
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6.2.6.3. Step3: Run the target test
You can run a target test by selecting [Run Target Test] from the project context menu in the Test
Navigator View or clicking the [Run] button in the Test View.

• [Run Target Test]

• [Run]

Suresofttech User Guides - 2023.12_en

Page 156 of 177



6.3. Target Build Guide
CT 2023.12 guides you through building target test code using target project information.

• IAR Embedded Workbench IDE
• Texas Instruments Code Composer Studio
• CodeWarrior IDE
• Hightec Development Platform IDE
• Tasking VX IDE
• Renesas CS+ IDE
• MPLAB X IDE
• Microsoft Visual Studio
• GNU Compiler
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6.3.1. IAR Embedded Workbench IDE
The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an IAR Embedded Workbench, enter the required information in the Analysis and Build tab of
the target preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

• Analysis tab

cpu CPU of target that can be selected from Core of Processor variant

• Build tab

ide_directory_path
Installation path of the IAR Embedded Workbench IDE ex. C:\Program
Files (x86)\IAR Systems\Embedded Workbench 8.4

project_file_path Project file (.ewp) path of IAR Embedded Workbench

build_configuration
Build Configuration of IAR Embedded Workbench Project(Project -> Edit
Configurations… )

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.

When using the IO function of stdio.h, it is necessary to change the library settings.
Right click on the project in the workspace -> Options -> General Options -> Library
Configuration -> Library tab and change it to Full.
*
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6.3.2. Texas Instruments Code Composer
Studio
The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an Code Composer Studio, enter the required information in the Build tab of the target
preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

• Build tab

ide_directory_path Directory path of Code Composer Studio ex.C:\ti\ccs930

workspace Path to workspace directory in Code Composer Studio

project_name
The name of the Code Composer Studio project to be analyzed by
Controller Tester

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
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builds the target test code.

If Code Composer Studio is running during execution, a compile error occurs.!
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6.3.3. CodeWarrior IDE
The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an CodeWarrior project, enter the required information in the Build tab of the target preferences
and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

• Build tab

ide_directory_path
Path to CodeWarrior IDE ex. C:\Program Files (x86)\Freescale\CW for
MPC55xx and MPC56xx 2.10, C:\Freescale\CW MCU

ide_version Classic or Eclipse(for MCUs)

project_file_path
In the case of Classic, the .mcp file named when creating the project, and
in Eclipse, the .project file created when creating the project.

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.

Suresofttech User Guides - 2023.12_en

Page 162 of 177



6.3.4. Hightec Development Platform IDE
The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an Hightec IDE project, enter the required information in the Build tab of the target preferences
and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

• Build tab

ide_directory_path Path to Hightec IDE ex. C:\HIGHTEC\toolchains\arm\v4.6.5.0

project_directory_path Path of project directory created by HighTec IDE

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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6.3.5. Tasking VX IDE
The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an Tasking VX IDE project, enter the required information in the Build tab of the target
preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

• Build tab

ide_version Version of Tasking VX IDE

makefile_path Path of makefile created in Tasking VX IDE project

ide_directory_path
Path to the directory where Tasking VX IDE is installed ex. C:\Program
Files (x86)\TASKING\C166-VX v3.1r2

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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6.3.6. Renesas CS+ IDE
The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an Renesas CS+ IDE project, enter the required information in the Build tab of the target
preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

• Build tab

ide_directory_path
Directory path of Renesas CS + IDE ex. C:\Program Files (x86)\Renesas
Electronics

ide_kind IDE kind(CS+)

workspace_path
This is only necessary for the Renesas HEW IDE, so you do not need to
enter it in CS +.

project_file_path Project file path created by Renesas CS+(.mtpj)

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.

When exporting test codes from Controller Tester, some reference relative paths.
To reference this path when building in the Renesas CS+, add an environment variable.
- Add below paths at property of Build Tool-> Compile Options -> Preprocess ->
Additional include paths
(CTWORKSPACE) \.metadata\.plugins\com.codescroll.ut.embedded\ CT project name
\TestFixture
(CTWORKSPACE) \.metadata\.plugins\com.codescroll.ut.embedded\ CT project name
\TestFixture\cs

*
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6.3.7. MPLAB X IDE
The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an MPLAB X IDE project, enter the required information in the Build tab of the target
preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

• Build tab

ide_directory_path
Installation path of MPLAB X IDE ex. C:\Program Files
(x86)\Microchip\MPLABX\v5.35

project_directory_path Project directory path created in MPLAB X IDE

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.

Suresofttech User Guides - 2023.12_en

Page 167 of 177



6.3.8. Microsoft Visual Studio
The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an Microsoft Visual Studio project, enter the required information in the Build tab of the target
preferences and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

• Build tab

ide_directory_path
Installation path of Microsoft Visual Studio ex. C:\Program Files
(x86)\Microsoft Visual Studio 10.0

build_configuration Configuration and platform to test the target solution ex. Release Win32

sin_path File path of target solution (.sin file)

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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6.3.9. GNU Compiler
The target preference page is automatically filled in according to the tool chain selected by the user. The
type of debugger you can choose depends on your toolchain analysis settings.

To build an GNU Compiler code, enter the required information in the Build tab of the target preferences
and click Done.
The contents to be filled out are as shown in the table below, which is mandatory.

• Build tab

makefile_path Path of user-made makefile

If you click the Done button on the target preference page without writing all the contents or if the path
has been changed, you can set it again at ‘Right click on the project in the test navigator-> Properties->
Test target-> Target environment’.

After setting the target environment and clicking the Run button in the unit test view, the controller tester
builds the target test code.
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7. Identifying the Cause of a Test Error
Occasional errors occur when performing tests on CT 2023.12. At this time, the user can find out the
cause of the test error by checking the debug information of CT 2023.12.

If test execution fails

Debug information verification can be performed even if the test fails. When you execute the [Inspect
Debug Info] of the generated test case, the stack trace is displayed in the [Inspect Debug Info], and you
can know where the test failed.

If the result contains errors after running the test
In some cases, after performing a test in CT 2023.12, error results such as Signaled and Abnormal Exit
are displayed. When you execute the [Inspect Debug Info] of the failed test case, the function call stack
trace is displayed in the [Debug Information View]. If you added a variable/expression to debug, a list of
executed variables/expressions is also displayed.

The Stack trace indicates the order of the function calls. The location where the function was called is
recorded, and the last execution location is recorded at the top of the Stack trace.
The List of variable/expression represents the variable/expression values executed with the test case.

Suresofttech User Guides - 2023.12_en

Page 170 of 177



The list of variables/expressions added to the entire source code can be checked in [List of Variable/
Expressiont] in the toolbar menu of [Debug Information View].

You can also check the variable/expression information to debug in the marker in the source code editor.
When you add a variable/expression to debug, the additional position is expressed as a marker in the
source code editor, and when you mouse over each marker, you can see the list of variables/
expressions added at that position.
If you select a test case that contains debug information, each marker displays the result of the variable/
expression executed by the test case.

The stack trace and the executed variable/expression value can be used to identify the cause of the
error in the test case that executed [Inspect Debug Info].

For more information on adding variables/expressions to debug, see [Inspect Debug
Information] in the CT 2023.12 document.*
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8. Virtual Address Usage Guide
You can set the memory for testing the embedded environment by setting the virtual memory address.

1. Top menu [Window] > [Preferences] > [Unit Test] > [Virtual Address] > [Add…] Selection

2. After entering the name and range of the virtual address, click the [Add(A)] button
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3. Right-click the project [Properties] > [Unit Test] > [Virtual Address] and select the registered virtual
address range in the [Configuration Name] combo box
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4. Using a macro to set a value to a virtual address in [Before call code] of the test structure editor

5. Edit test case values

For details about macro, please refer to the Test Maco page in User Manual*
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9. Navigate Source Codes
CT 2023.12 provides shortcuts and context menu in Source Code Editor for user convenience.

Shortcuts

Item Shortcut Description

Open Include
Browser

Ctrl + Alt + I Display the include relationship of the selected file in the
[Include Browser View].

Show outline Ctrl + O Show outline of selected file in outline popup.

Toggle Source/
Header

Ctrl + Tab Toggle source file and header file.

Open type in
Hierarchy

Ctrl + Alt + H Display hierarchy of the selected item in [Call Hierarchy
View]. (Funtion/Global Variable)

Toggle Mark
Occurrences

Alt + Shift + O Turns the mark occurrence on/off for the item that is
positioned by cursor or is specified by block.

Open
Declaration

F3, Ctrl + Click Move to the declaration of the selected item or open the file
if it is an include file.

Open Resource Ctrl + Shift + R Open a file by searching by name.

References Ctrl + Shift + G Display reference to selected item in Search View.

Forward/
Backward
history

Alt + Right / Left Move editor history forward/backward.

Find Next/
Previous

Ctrl + K / Ctrl + Shift
+ K Search the selected text forward/backward in the current file.

Toggle Folding Ctrl + Numpad_Divide Show/Hide folding icon.

Zoom Out/In
Ctrl + - / Ctrl + Shift
+ = Zoom out/in source code editer.

Expand/
Collaspe

Ctrl + Numpad_Add / Nu
mpad_Subtract Expand/collapse the item on the cursor.

Move Line
Down/UP

Alt + ↓ / ↑ Move line down/up.

Copy/Duplicate
Lines

Ctrl + Alt + ↓ / ↑ Copy lines down/up.
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Context menu

Item Description

Outline [Display the outline of the current file in [Outline View].

System Explorer Open the current file location in Windows Explorer.

Item Description

Search
Text

Search the selected character string in the target (workspace/project/file) and display it in
[Search View].
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