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Introduction
This document provides insight for the integration and visualization of DevAnalytics

All integration exporting steps are carried out from the SAP GUI where DevAnalytics is run and then
exported into Data Tools such as Power BI, Tableau or SAP Lumira.
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Exporting of DevAnalytics Data
If your business, like many others, already utilises data visualization software such as SAP Lumira and
Tableau, those same solutions can be used in combination with DevAnalytics to create dashboards that
monitor and track SAP change.*

Data can be exported from DevAnalytics in a format suitable for importing into such tools. Full data
extracts are possible, but exports can also be streamlined by defining a specific date range and selecting
the necessary classifications (see Reporting). The resulting data can be aggregated across selected
periods (e.g. monthly) to provide the view that you need.

In combination with DevAnalytics’ near-realtime data refresh – updates can occur on a daily basis – this
feature allows you to present relevant information in a manner that is timely, attractive and easily
understandable.

*Licences for third-party tools are not supplied by Basis Technologies and may incur fees.
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Running DevAnalytics to view and extract
data
Once the data for DevAnalytics has been generated (see Setup section) it can be analysed in SAP or
exported for analysis in an external visualization tool.

Note that program /BTR/DEVA_MAIN_N must have been run with the required variant in order to
generate the data. Any previously generated data can be analysed or exported.

To run the data analysis, execute program /BTR/DEVA_TRANS. This program allows data to be
analysed for selected data extract runs.

Execution notes:

• Output mode: Choose how you want to output the data
◦ Hierarchical (in SAP GUI) – This displays the metric data output in the SAP GUI via a grid

and allows the user to drill down, filter, show graphs, etc.
◦ Report (ALV) – Output the data as a flat ALV report
◦ Download to server – Download the data to the specified server folder and filename in tab

delimited format. The filename will automatically be appended with a date and timestamp
◦ Download to PC – Download the data to the specified PC folder and filename in tab

delimited format. The filename will automatically be appended with a date and timestamp
• Analysis period: Chose the date period that you wish to view the data for
• Data source: Always choose “Use instance results”
• Metric selection: Choose which metrics you wish to view and the period you wish to have the

data aggregated by (E.g. Monthly)
• Data restrictions: Enter any specific selection criteria to narrow down the data selection for a

more targeted view (E.g. only show data for specific systems and projects)
• Transformation run options: This allows specific data extract runs to be selected. In most cases

the Latest run would be used but previous extract runs (if available) can also be selected if
required

Notes

Program */BTR/DEVA_TRANS can be scheduled as a background job using the “Download to server”
option to automatically run and download all the available data file for use in external data visualization
tools like Tableau, QlikView, etc.

Hierarchical (in SAP GUI)
When the data has been output in SAP there are options to be able to manipulate the data on screen:

• Metrics can be added to / removed from the graphic section
• Different filters, periods, date ranges can be specified
• Data can be expanded to view a breakdown for each classification
• The data visible on screen can be exported to spreadsheet / Excel
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Report and Download options
The data extracted in these modes split up by metric and the associated classifications so you can
obtain lower level figures across all available classifications. These modes are best used when
extracting the DevAnalytics data to be viewed in external data visualization tools.
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Example Integration Tools to View
DevAnalytics Data
DevAnalytics provides detailed information about your SAP development and delivery processes but also
delivers the means to create at-a-glance dashboards. Review data in the SAP GUI, import it into other
visualisation tools, or dig right into the spreadsheets

These topics below will cover a step by step guide on how to import the DevAnalytics exported data
using Tableau, SAP Lumira and Microsoft Power BI in order to have a visual representation of the data.

*Licences for third-party tools are not supplied by Basis Technologies and may incur fees.
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Microsoft Power BI
Power BI is known as a visual intelligence tool that is used to visualize data and create stories to provide
graphical details of the data. Data is entered in Power BI as dataset and you can apply filters,
hierarchies, and columns to prepare documents.

Power BI is a analytics tools that deliver insights throughout your organization. Connect to hundreds of
data sources, simplify data prep, and drive ad hoc analysis.

Basis Technologies have a ready-made Power BI dashboard template for customers that would prefer to
start with an existing template. This is available from Basis Technologies on request.
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Power BI-User Interface
When you login to Power BI Data visualization tool, below user interface is seen. This is known as the
Power BI Desktop work area.

Transform and clean data, create a model

In Power BI, you can clean and transform data using the built-in Query Editor. With Query Editor you can
make changes to your data, such as changing a data type, removing columns, or combining data from
multiple sources. It’s a little bit like sculpting – you can start with a large block of clay (or data), then
shave pieces off or add others as needed, until the shape of the data is how you want it.
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Each step you take in transforming data (such as rename a table, transform a data type, or delete
columns) is recorded by Query Editor, and each time this query connects to the data source those steps
are carried out so that the data is always shaped the way you specified.

The following image shows the Query Settings pane for a query that has been shaped, and turned into a
model.
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Once your data is how you want it, you can create visuals.

Create visuals
Once you have a data model, you can drag fields onto the report canvas to create visuals. A visual is a
graphic representation of the data in your model. The following visual shows a simple column chart.
There are many different types of visuals to choose from in Power BI. To create or change a visual, just
select the visual icon from the Visualizations pane. If you have a visual selected on the report canvas,
the selected visual changes to the type you selected. If no visual is selected, a new visual is created
based on your selection.
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Create reports
More often, you’ll want to create a collection of visuals that show various aspects of the data you have
used to create your model in Power BI. A collection of visuals, in one Power BI Desktop file, is called a
report. A report can have one or more pages, just like an Excel file can have one or more worksheets. In
the following image you see the first page of a Power BI Desktop report, named Overview (you can see
the tab near the bottom of the image). In this report, there are ten pages.

Share reports
Once a report is ready to share with others, you can Publish the report to the Power BI service, and
make it available to anyone in your organization who has a Power BI license. To publish a Power BI
Desktop report, you select the Publish button from the Home ribbon in Power BI Desktop.Once you
select Publish, Power BI Desktop connects you to the Power BI service using your Power BI account,
and then prompts you to select where in the Power BI service you would like to share the report, such as
your workspace, a team workspace, or some other location in the Power BI service. You must have a
Power BI license to share reports to the Power BI service.
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Step by Step Power BI Data Set from
DevAnalytics
Step 1: Connect to your data. (Using the extracted DevAnalytics data you have from your system when
you ran the exporting of DevAnalytics Data Program) select File -> Import -> Excel Workbook Contents.

A window appears, letting you select the workbook to import. There is currently no limitation on the size
or number of objects in the workbook, but larger workbooks take longer for Power BI Desktop to analyze
and import.
Once a workbook is selected, Power BI Desktop analyzes the workbook and converts it into a Power BI
Desktop file (.pbix). This action is a one-time event; once the Power BI Desktop file is created with these
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steps, the Power BI Desktop file has no dependence on the original Excel workbook, and can be
modified or changed (and saved, and shared) without affecting the original workbook.

Once the import is finished, a Summary page is displayed that describes the items that were converted,
and also lists any items that were not able to be imported.

When you select Close, the report is loaded in Power BI Desktop. The following image shows Power BI
Desktop after an Excel workbook was imported: Power BI Desktop automatically loaded the report based
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on the workbook contents.

Now that the workbook is imported, you can continue working on the report – such as creating new
visualizations, adding data, or creating new report pages – using any of the features and capabilities
included in Power BI Desktop.
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Use SAP HANA in Power BI
With Power BI Desktop, you can now access SAP HANA databases. To use SAP HANA, the SAP HANA
ODBC driver must be installed on the local client computer in order for the Power BI Desktop SAP HANA
data connection to work properly. You can download the SAP HANA ODBC driver from the SAP
Software Download Center. From there, search for the SAP HANA CLIENT for Windows computers.
Since the SAP Software Download Center changes its structure frequently, more specific guidance for
navigating that site is not available.

To connect to a SAP HANA database, select Get Data > Database > SAP HANA Database as shown in
the following image:

When connecting to a SAP HANA database, specify the server name and the port in the format
server:port – the following image shows an example with a server named ServerXYZ and port 30015.
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In this release SAP HANA in DirectQuery mode is supported in Power BI Desktop and the Power BI
service, and you can publish and upload reports that use SAP HANA in DirectQuery mode to the Power
BI service. You can also publish and upload reports to the Power BI Service when not using SAP HANA
in DirectQuery mode.

Supported features for SAP HANA
This release has many capabilities for SAP HANA, as shown in the following list:

The Power BI connector for SAP HANA uses the SAP ODBC driver, to provide the best user experience
SAP HANA supports both DirectQuery and Import options
Power BI supports HANA information models (such as Analytic and Calc views) and has optimized
navigation
With SAP HANA, you can also use the direct SQL feature to connect to Row and Column Tables
Includes Optimized Navigation for HANA Models
Power BI supports SAP HANA Variables and Input parameters
Installing the SAP HANA ODBC driver
Limitations of SAP HANA
There are also a few limitations to using SAP HANA, shown below:

NVARCHAR strings are truncated to maximum length of 4000 Unicode characters
SMALLDECIMAL is not supported
VARBINARY is not supported
Valid Dates are between 1899/12/30 and 9999/12/31
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Addition of Power BI dashboard to AC
WEBUI
Configuration steps to add published URL from Power BI to display it AC Web UI dashboard:

Once you have got the published URL from PowerBI you will go to table /BTI/TE_WEBUICFG in the
ActiveControl Domain Controller system.
Populate the Analytics_URL entry in the table with the valid URL from PowerBI.

Once completed, go to the AC Web UI and a new tab should be displayed with the dashboard/reports
from Power BI that you have published.
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SAP Lumira
SAP Lumira is known as a visual intelligence tool that is used to visualize data and create stories to
provide graphical details of the data. Data is entered in SAP Lumira as dataset and you can apply filters,
hierarchies, and columns to prepare documents. You can choose various charts like Bar charts, Pie
charts, etc. to visualize the data effectively. This basic tutorial explains how to use SAP Lumira with the
DevAnalytics extract once done.
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SAP Lumira-User Interface
When you login to SAP Lumira Data visualization tool, there are four tabs at the top −

The Prepare tab is used to import data set in SAP Lumira. Data is cleansed and converted into
appropriate measures or attributes for the reports. You can add new custom calculations here.
The Visualize tab is used to add graphs and charts on the data that has been imported and organized
in Prepare tab. You can add different attributes and measures to the Label axis.
The Compose tab is used to create stories and presentations, including background colors, titles,
pictures, and text.
The Share tab is used to publish your visualizations to different platforms or with different set of users in
the BI Repository.
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Step by Step SAP Lumira Data Set from
DevAnalytics Extract
Once you open SAP Lumira, go to File → New Data set

You can select from various Data sources to create a new data set. For DevAnalytics we recommend to
use the Microsoft excel data source as that is how you would export your data from the DevAnalytics tool
(as per Exporting of DevAnalytics Data).

Excel file to create data set in SAP Lumira steps:
Step 1 − Go to File → New (Create a data set).
Step 2 − Select a Source − Load an Excel worksheet as a dataset and click the Next icon at the bottom.
Step 3 − Browse the path of .xls file. You have an option to choose the first row as column names. You
can hide a particular column from .xls by selecting the Select All option.
Step 4 − You can click the Advance option to select a custom range. You can also include hidden rows
and columns. Once correct options are selected, click the create button at the bottom.
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Step 5 − All the data with integer values appear under Measures and all the columns appear
under Dimensions. This data will come under the Prepare tab.

Step 6 − Go to the Visualize tab at the top to create the visualization on top of the data set.
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In SAP Lumira, you can quickly create a chart by dragging the objects directly to chart area. To create a
chart, the dataset should contain at least one measure value.
When you create a chart in SAP Lumira, it can be used in compose and Share tab for the current
session.

Step 1 − If you want to save the chart as document to use it permanently you have to go to File → Save.

Step 2 − Go to Visualize tab → Select a chart type from the list of available charts and add to chart
builder.

Step 3 − Drag the Measures and Dimensions on axis of the chart. The text written in the chart helps you
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to find out which object is to be dragged to which axis.

You can also add measures as a dimension in SAP Lumira. To do this, add two or more measures as
dimensions in the chart. This can be used to check how data is spread over multiple axis in a single
chart.

Step 1 − Go to Visualize tab → drag measure to measure panel.

Step 2 − Go to Settings and click use Measures as dimensions option.
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Once you select this option, measures are displayed as new measure dimension in Dimension panel.

Step 3 − Now you see the Dimension axis, measures will be added to the dimensions panel.

Step 4 – Add a dimension to this chart and see how it works.
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Tableau
Tableau is known as a visual intelligence tool that is used to visualize data and create stories to provide
graphical details of the data. Data is entered in Tableau as dataset and you can apply filters, hierarchies,
and columns to prepare documents. You can choose various charts like Bar charts, Pie charts, etc. to
visualize the data effectively. This basic tutorial explains how to use Tableau with the DevAnalytics
extract once done.
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Tableau-User Interface
When you login to Tableau Data visualization tool, below user interface is seen. This is known as the
workspace area.

A. Workbook name. A workbook contains sheets. A sheet can be a worksheet, a dashboard, or a story.
B. Cards and shelves – Drag fields to the cards and shelves in the workspace to add data to your view.
C. Toolbar – Use the toolbar to access commands and analysis and navigation tools.
D. View – This is the workspace where you create your data visualizations.
E. Goes to the start page. .
F. Side Bar – In a worksheet, the side bar area contains the Data pane and the Analytics pane.
G. Go to the data source page.
H. Status bar – Displays information about the current view.
I. Sheet tabs – Tabs represent each sheet in your workbook. This can include worksheets, dashboards,
and stories.
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Step by Step Tableau Data Set from
DevAnalytics Extract
Step 1: Connect to your data. (Using the extracted DevAnalytics data you have from your system when
you ran the exporting of DevAnalytics Data Program)
You can connect to a file and import your excel exported data and it here as per number 1 in green
below:

Example

Once data has been imported it will look as below:

Example
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Step 2: Create a view. From Dimensions in the Data pane, drag a Dimension to the Columns shelf.

Example

Step 3: Focus your results. Filters and colors are ways you can add more focus to the details that
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interest you. You can use filters to include or exclude values in your view. In the Data pane, under
Dimensions, right-click a Dimension and select Show Filter.
Repeat the step above for the Sub-Category field.
The filters are added to the right-hand side of your view in the order that you selected them.

Example
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Google DataStudio
Google DataStudio is known as a visual intelligence tool that is used to visualize data and create stories
to provide graphical details of the data. Data is entered in Google DataStudio as dataset and you can
apply filters, hierarchies, and columns to prepare documents.
Google DataStudio is a analytics tools that deliver insights throughout your organization. Connect to
hundreds of data sources, simplify data prep, and drive ad hoc analysis.
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Google DataStudio-User Interface
1. Log into Data Studio
To log in, you’ll need a Google account—I recommend using the same one as your Analytics, Search
Console, and/or Google Ads account.

You’ll land on the Data Studio overview page. Click the “Home” tab to view your dashboard.

2. Explore the Data Studio Dashboard

If you’ve used Google Docs, Sheets, or Drive before, this dashboard should look pretty familiar.

1. Reports

Here’s where you can access all of your reports (equivalent to a workbook in Tableau or Excel).

Notice that you can filter by who owns the report:

. Data Sources
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Data sources lists all the connections you’ve created between Data Studio and your original data
sources.

Data Studio currently supports 500+ data sources (jump to the section where I show you how to explore
the possibilities.)

Google Data Studio Data Sources
The most popular sources include:

Google Analytics
Google Ads
Google Search Console
BigQuery
YouTube Analytics
PostgreSQL
Search Ads 360
Display & Video 360
If you’re using Google Analytics and/or Search Console (which I highly recommend), you’ll need to
individually connect each view and property, respectively.

So if you have three GA views for three different subdomains, you’ll need to set up three different data
sources.

Fear not, this is an easy process.

3. Explorer

Explorer is an experimental tool that lets you experiment or tweak a chart without modifying your report
itself.

For instance, let’s say you’ve created a table in Data Studio that shows the top landing pages by
conversion rate. While looking at this table, you think, “Huh, I wonder what I’d find if I added average
page load time.”

You don’t want to edit the chart in the report, so you export it into Labs—where you can tweak it to your
heart’s content. If you decide the new chart is valuable, it’s easy to export it back into the report. (Jump
to the section where I explain how.)

4. Product Overview

This brings you back to that Overview tab. Not sure why it’s here; I never click it.

5. Report Gallery

This is a collection of templates and examples. More on the gallery in a bit.
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Step by Step Google DataStudio Data Set
from DevAnalytics
Step 1: Connect to your data. (Using the extracted DevAnalytics data you have from your system when
you ran the exporting of DevAnalytics Data Program) select Connect to data-> file upload(your stored
DevAnalytics file)

Connect to Data:

Once data has been imported, then you can start working on the dashboard/reports.

You can add charts, graphs, scorecards etc. Below example of the report dashboard:
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Addition of Google DataStudio dashboard to
AC WEBUI
Configuration steps to add published URL from Google DataStudio to display it AC Web UI dashboard:

Once you have got the published URL from Google DataStudio you will go to table /BTI/TE_WEBUICFG
in the ActiveControl Domain Controller system.
Populate the Analytics_URL entry in the table with the valid URL from Google DataStudio.

Once completed, go to the AC Web UI and a new tab should be displayed with the dashboard/reports
from Google DataStudio that you have published.
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